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Preface

PC|S
PREFACE

PC|SCHEMATIC Database is a database program, developed by the Danish soft-
ware house PC|SCHEMATIC A/S.

The program enables you to import databases from component vendors, and 
adapt the databases as you please.

PC|SCHEMATIC Database works directly in the database formats Microsoft 
Access and dBase, and can furthermore work in practically any other database for-
mat.

PC|SCHEMATIC Database works with the following programs:

- PC|SCHEMATIC Automation for documentating wiring- and power control cir-
cuit diagrams, as well as PLC diagrams.

- PC|SCHEMATIC Electronics for documentation of electronic circuits and for 
transferring data to PCB layout.

PC|SCHEMATIC A/S also develops software for interfaces, and user-defined 
modules for the PC|SCHEMATIC programs.
CHEMATIC Database
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Survey of the manual
SURVEY OF THE MANUAL

This manual is divided in the following sections:

— Please also apply the index on page 111.

PART DESCRIPTION SUBJECTS

"GETTING 
STARTED"
(P. 11)

SHORT INTRODU-
CTION TO THE 
PROGRAM

WHAT IS A DATABASE

STARTING THE PROGRAM

OPENING A DATABASE

THE WORK AREA

"BASIC FUNC-
TIONS" (P. 21)

HOW TO WORK 
WITH THE CON-
TENTS OF A 
DATABASE

DISPLAYING THE CONTENTS OF A DATABASE

SELECTING, DELETING AND INSERTING

SEARCHING IN A DATABASE

FINDING AND REPLACING

ADVANCED FILTERING WITH SQL

"MAINTAINING 
DATABASES"
(P. 37)

HERE YOU ADAPT 
THE DATABASE 
YOUR NEEDS

CREATING DATABASES

CREATING TABLES

EDITING THE PROPERTIES OF A TABLE

CREATING TABLE MENUS

CONNECTING A TABLE MENU TO A TABLE

"IMPORTING 
DATA"
(P. 61)

IMPORT OF COM-
PONENT VENDOR 
DATABASES AND 
OTHER RELE-
VANT FILES

LOADING A COMPONENT VENDOR DATABASE

IMPORTING A COMPONENT VENDOR DATABASE INTO A 
TABLE

IMPORTING COMMA SEPARATED FILES OR ZIP FILES

FILTERED IMPORT

IMPORTING AN MICROSOFT EXCEL SPREADSHEET

"EXPORTING 
DATA"
(P. 81)

EXPORT OF 
DATABASES - OR 
PARTS OF DATA-
BASES - TO 
OTHER PRO-
GRAMS

CREATING A COMMA SEPARATED FILE FOR EXPORT

EXPORTING TO MICROSOFT EXCEL

GIVING AWAY A DATABASE

LOADING A DATABASE IN OTHER PROGRAMS

"OTHER DATA-
BASE FORMATS"
(P. 95)

SUPPORT OF 
OTHER DATA-
BASE FORMATS 
THAN MICRO-
SOFT ACCESS 
AND DBASE

SUPPORTING OTHER DATABASE FORMATS

MDAC AND UDL FILES

CREATING BDE DATABASE ALIASES
PC|SCHEMATIC Database
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PC|S
TYPOGRAPHY

The following typographical elements are used in this manual:

Furthermore, if you have to activate one of the program buttons, you will see the 
mentioned button in the left margin of the text — facing the place where the button 
is mentioned.

Buttons mentioned shortly after one another, are displayed in the order in which 
they are mentioned.

Short-cut keys

In the program you can use the following short-cut keys:

TYPOGRAPHY USE

ITALICS A TEXT WRITTEN IN ITALICS, IS A TEXT YOU HAVE TO TYPE IN 
YOURSELF.

BOLD TEXTS WRITTEN IN BOLD — NOT INCLUDING HEADLINES — INDI-
CATES FUNCTIONS, BUTTONS OR MENUS.

ITALICS AND BOLD APPLIED FOR FILE NAMES — OR FOR OPTIONS YOU CAN CLICK ON 
IN DIALOG BOXES.

KEYS

< >
[  ]

[CTRL+G]

THE CONTROL KEY IS WRITTEN AS <CTRL>, THE ESCAPE KEY AS 
<ESC>, THE ENTER KEY AS <ENTER>, THE DELETE KEY AS 
<DEL>, WHILE THE SPACEBAR IS WRITTEN AS [SPACEBAR]. 
SINGLE LETTERS IN BRACKETS, SUCH AS [Z], INDICATES THAT THE 
“Z” KEY IS A SHORT-CUT KEY.
IF IT FOR INSTANCE SAYS [CTRL+G], THIS SIGNIFIES THAT YOU 
ACTIVATE THE SHORT-CUT BY PRESSING DOWN <CTRL> AND 
PRESS DOWN THE “G” KEY.

MENUS

=>
FILE => SAVE INDICATES THAT YOU HAVE TO SELECT THE MENU 
FILE, AND THEN SAVE. AN UNDERSCORED LETTER, SUCH AS H IN 
HELP, MEANS THAT THE MENU CAN ALSO BE ACTIVATED BY PRES-
SING [ALT+H].

COMMAND SHORT-CUT COMMAND SHORT-CUT

COPY [CTRL+C] INSERT [CTRL+V]

CUT [CTRL+X] OPEN [CTRL+O]

FIND [CTRL+F] REPLACE [CTRL+R]

FIND NEXT [F3] SHOW USED ONLY [CTRL+U]

SHORT-CUT KEYS IN PC|SCHEMATIC Database
CHEMATIC Database
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This section covers the following subjects:

- What is a database............................................(p. 13)

- How to start the program.................................(p. 16)

- How to open a database..................................(p. 16)

- The work area ....................................................(p. 18)

Getting started





On databases

PC|S
ON DATABASES

If you are already familiar with the database concept, please skip the first part of 
the chapter, and jump to “Table menus” on page 14 and continue reading from 
there.

WHAT IS A DATABASE?
A database is a collection of information, which has been gathered in a number of 
tables.

All information placed on the same row in a table, contains information about the 
same component. This collection of information about the same component is cal-
led a record.

Each individual record consists of a number of data fields, each containing one 
type of information about the component.

The top row contains the names of the individual data fields, the field names.

Below you see a small table, containing five records (components), each contai-
ning four pieces of information about each component (EANNUMBER, STOCKNO, 
ORDERNO and TYPE). This information is placed in individual data fields:

A table typically consist of many records. These records can either be displayed 
several at a time in a table, or individually, like below.

THIS CHAPTER DESCRIBES

This chapter explains the terms database, table, 
record, data field and field name.

THE CONTENTS OF A DATABASE

A DATABASE IN PC|SCHEMATIC TYPICALLY JUST CONSISTS OF ONE 
TABLE CONTAINING COMPONENT INFORMATION (AND ONE TABLE CONTAI-
NING A MENU SYSTEM FOR GROUPING THE COMPONENTS).

A data field

A record

A field name

Table containing five records.
Each record contains four data fields.
CHEMATIC Database
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In a table containing four data fields for each component, an individual record can 
also be displayed like this:

Thus you distinguish between Record view and Table view. Please read more 
about this in “Table or Record viewing” on page 24.

Table menus

In PC|SCHEMATIC Database you 
can furthermore group the compo-
nents in a table, by indicating which 
menupoints they belong to — for 
instance by component function.

These menupoints are displayed in 
the left hand side of the database 
program, and are called the table 
menu.

You can choose whether you wish to 
see all the components of the table, 
or just the components belonging to 
a specific menupoint.

— Read more about this in “Table 
menus in PC|SCHEMATIC Database” on page 24.

TABLES IN PREVIOUS VERSIONS OF PC|SCHEMATIC Database
IN PREVIOUS VERSIONS OF PC|SCHEMATIC Database, THE TABLE CON-
TAINING COMPONENT INFORMATION WERE REFERRED TO AS “A DATABASE”.
IN THIS VERSION THE COMPONENT INFORMATION IS PLACED IN A TABLE IN A 
DATABASE. — READ MORE ABOUT DATABASES AND TABLES IN “MAINTAI-
NING DATABASES” ON PAGE 37.

A field name A data field

A record

The table menu Components/
records
PC|SCHEMATIC Database
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PC|S
WORKING IN PC|SCHEMATIC TABLES

When you edit the contents of a table, the changes are carried out the moment you 
have finished editing one record, and start working on another.

Thus, the changes are carried out on the fly, which do not leave you any possibility 
to cancel the changes by not saving the table.

If more than one person is working on a table in a network, it is very important that 
only one version of the table exist — and that this table is being updated for all the 
users at the same time, each time a record is changed.

If you need to test the database program, you should therefore start by making a 
copy of an existing table. This gives you a table, in which incorrect changes are not 
fatal. See how to do this in “Creating a new Microsoft Access table” on page 42.

One table at the time

You can only work in one table at the time. Therefore, if you are working in one 
table, and then open another, this automatically causes the first table to be closed 
down. This is done without prior warning.
CHEMATIC Database
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Getting started with PC|SCHEMATIC Database
GETTING STARTED WITH PC|SCHEMATIC DATA-
BASE

STARTING PC|SCHEMATIC Database
You can either start PC|SCHEMATIC Database by choosing Start => Programs 
=> PCschematic => Database in Windows, or by choosing Tools => Database in 
the PC|SCHEMATIC Automation program.

When you only wish to open a table in a database and add records, delete records, 
or change the contents of a record, you can do this at any time, without taking any 
special action.

You have now started PC|SCHEMATIC Database.

OPENING A DATABASE

In order to have a database to work on, you can for instance 
open the demo database eldemo.mdb, which comes along 
with the program.

In the emerging Database dialog box, you click on File, and 
then on Open.

You then enter the Open dialog box, where you choose which 
database to open:

Click on eldemo.mdb, and then on Open.

You have now opened the database eldemo.

THIS CHAPTER DESCRIBES

— HOW TO OPEN PC|SCHEMATIC Database.........................................(P. 16)

— HOW TO OPEN A DATABASE IN PC|SCHEMATIC Database..................(P. 16)
PC|SCHEMATIC Database
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PC|S
You must the choose which table to open:

Click on the table Eldemo in the database eldemo.mdb.

If you need to change to another table in the 
database, click on the down-arrow in the 
Table field in the upper-left corner of the pro-
gram.

SEE THE FULL CONTENTS OF THE TABLE

IN ORDER TO SEE THE FULL CONTENTS OF THE TABLE, CHOOSE MENU => 
ACTIVE.
— READ MORE ABOUT THIS IN “TABLE MENUS IN PC|SCHEMATIC DATA-
BASE” ON PAGE 24.
CHEMATIC Database
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The work area
THE WORK AREA

When you have started PC|SCHEMATIC Database you enter the Database dia-
log box, that looks like this:

1. The Menu bar
The Menu bar consists of menus, which gives access to all the functions in the pro-
gram. Choosing in the menu bar is either done by using the mouse, or by using the 
<Alt> key. File can for instance be chosen by pressing [Alt+f].

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES THE WORK AREA OF PC|SCHEMATIC DATA-
BASE.

4) The Table menu 5) The contents displayed

1) The Menu bar 3) The Program tool bar

6) Scroll back and forth 7) Insert, Delete 8) The Elevator
and Update

2) Choose table in the database
PC|SCHEMATIC Database
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The work area

PC|S
2. Choose table in the database
By clicking on the down-arrow in the Table field, you can choose which table in the 
database you wish to see/work on.

3. The Program tool bar
The Program tool bar contains program buttons. Here you can open files, cut, copy, 
paste, search for information, filter which information is displayed and adjust how to 
display the information in the Contents part of the dialog box (5).

4. The Table menu
The contents of a table can be divided into various menupoints, which are dis-
played in the Menu. When the table menu is active, you will only see the part of the 
table, which is belonging to the chosen menupoint. If the menu is inactive, the con-
tents of the entire table is displayed. In that case the text in the menu will be written 
in grey. You enable and disable the table menu by choosing Menu => Active.

— Read more about the table menu in “Table menus in PC|SCHEMATIC Data-
base” on page 24.

5. The contents
Here the contents of the chosen part of the table is displayed. Either one record is 
displayed at the time (record view), or several records (record view). Shift back and 
forth between these two views by clicking the Record view button.

Read more about which part of the table is displayed in “Displaying the contents of 
databases” on page 23.

6. Scroll back and forth
By clicking these buttons you scroll back and forth between the displayed records. 
— Please read more about manoeuvring in the database in “Scrolling back and 
forth between the records” on page 34.

7. Insert, Delete and Update
By clicking on these buttons you determine whether to insert or delete records. You 
can also update the displayed database, which is important if more than one per-
son is working on the database in a network.

— Please read more about these functions in “Editing records” on page 28.

8. The Elevator
By clicking on the elevator, and keeping the mouse button pressed down, you can 
drag the elevator up and down. This enables you to scroll between the chosen 
records, if they cannot be displayed all at a time.

If you click above the elevator, you will move one page up, and if you click below 
the elevator you will move one page down. There is also an elevator in the lower 
part of the dialog box, which enables you to see other information about the com-
ponents.

The table menu in the left-hand side of the screen also uses elevators.
CHEMATIC Database
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The work area
Flat buttons

If you wish the program buttons to be displayed in the 
Windows98-style, you choose Options => Flat Buttons. 
To return to the Windows95-style buttons, choose Options 
=> Flat Buttons again.
PC|SCHEMATIC Database
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This section deals with the basic functions in 
PC|SCHEMATIC Database:

- Displaying the contents of a database...........(p. 23)

- The menu system..............................................(p. 24)

- Data filters ...........................................................(p. 26)

- Inserting, deleting and updating records.......(p. 28)

- Searching facilities .............................................(p. 32)

- Advanced datamanipulation and filtering

with SQL queries ..............................................(p. 35)

Basic functions





Displaying the contents of databases

PC|S
DISPLAYING THE CONTENTS OF DATABASES

WHAT DETERMINES WHAT IS DISPLAYED ON THE SCREEN?
When you see the contents of a table in a database, mainly two factors have 
impact on which records are displayed:

 1) Whether you see the entire table, or whether you just see the contents of a 
menupoint in the table menu.

 2) Whether you use a data filter, with which you select the components you 
wish to see. If you apply a filter, the table menu is set out of effect.

Finally, as an general setting, you can determine whether to display the records 
individually, or whether to see them gathered in a table. This is called record view-
ing and table viewing respectively.

THE CONSEQUENCES OF WHAT IS DISPLAYED

The fact that you can determine which components are displayed, serves two pur-
poses in the program:

 1) It is easier to locate information in the active table.

 2) It determines which records you export from the table, when you choose File 
=> Export.

THIS CHAPTER DESCRIBES

— WHAT DETERMINES WHAT IS DISPLAYED ON THE SCREEN............................(P. 23)
— THE CONSEQUENCES OF WHAT IS DISPLAYED .............................................(P. 23)
— TABLE VIEWING OR RECORD VIEWING.........................................................(P. 24)
— USING TABLE MENUS .................................................................................(P. 24)
— USING THE DATA FILTER ............................................................................(P. 26)
CHEMATIC Database
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Displaying the contents of databases
TABLE OR RECORD VIEWING

In the right-hand side of the Database dialog box, you can either see all the 
records at a time, or display the records individually.

By clicking the Record view button, you can change back and forth between these 
two ways of displaying the contents of the active table.

You can also change back and forth between the two views by choosing View => 
RecordView and View => TableView respectively.

TABLE MENUS IN PC|SCHEMATIC Database
As mentioned in “On databases” on page 13, all records/components in a table 
can belong to a specific menupoint.

Therefore you can choose whether to display all the components in the table, or 
just the components that belongs to a specific menupoint.

In the Database dialog box, the left 
side is a survey of the various menu-
points, to which the components can 
belong. This is called the Table 
menu.

This menu can either be enabled or 
disabled — see “Activate the table 
menu” on page 24.

When it is enabled, the names of the 
menupoints are written in black, and 
when it is disabled, they are written in 
grey (Dimmed).

Please note, that it can be a bit hard 
to see the difference.

When the menu is active, you can only see the components, that belongs to the 
menupoint you have chosen in the menu.

Otherwise, you will see all the components in the table.

Activate the table menu

When you wish to activate the menu part, you 
have to choose Menu => Enabled.

When you wish to display the entire table, you 
choose Menu => Enabled again, which removes 
the check mark.

The table menu Table with

records
Components/
PC|SCHEMATIC Database
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PC|S
Right-click

When you right-click on the menupoints in the left-hand side 
of the dialog box, a menu pops up, in which you can activate 
some of the same functions.

Options using the menu

When you have activated the menu, you see all the menupoints in the menu in the 
left-hand side of the Database dialog box. If you only wish to see the menupoints, 
that contains components, you choose Menu => Show used.

To return to displaying all the menupoints, choose Menu => Show used once 
again.

If you choose Menu => Restore, the program examines all the components in the 
table, to check whether there are new menupoints containing components.

The choice Menu => Properties is elaborated in “Connecting table menus to tab-
les” on page 59, while Menu => Edit is elaborated in “Creating table menus” on 
page 51.

SEE RECORDS THAT DOES NOT FIT THE MENU STRUCTURE

WHEN YOU WISH TO SEE RECORDS, THAT DOES NOT FIT INTO YOUR MENU 
STRUCTURE, CLICK ON MENU => SHOW HIDDEN RECORDS. THEN CLICK ON 
THE DISPLAYED RECORDS, AND DRAG THEM OVER TO THE CORRECT MENU-
POINTS.
DISABLE THE FUNCTION BY CHOOSING MENU => SHOW HIDDEN RECORDS 
AGAIN.

SORTING BY FIELD NAME

When all the table compo-
nents are displayed — that 
is when the menu is not 
active — you have the 
option of sorting the compo-
nents by their field names.

To do this choose Edit => 
Sort by and click on the 
field name you wish the 
data to be sorted by.

You can only sort the components by the field names you have indexed 
in the table. — Read more about index fields in “Index fields” on 
page 50.
CHEMATIC Database
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Displaying the contents of databases
THE DATA FILTER

By clicking on the Data filter button — or by choosing Functions => Data Filter — 
you can set up conditions for which records in the table you wish to display.

When you have clicked the button, the following bar appears:

Here you first specify which data field you wish to use in the filtering. Then you 
choose an operator, and a text or a number you wish to compare the contents of 
the data field with.

When you click on the down-arrow in the operator field, you 
get a lot of different operators to choose from.

If for instance you choose the field EANNUMBER, set the 
operator to begins with and type in 40081, you get all the 
records with a EANNUMBER beginning with 40081.

If you wish to distinguish between upper- and lower-case let-
ters, you click the Aa button, which activates the function 
(highlighted). You have to do this before starting the filtering.

Click the Activate button to carry out the filtering.

Using the Data filter to check new records

Among the operators, you will find the operator is repeated. This tells you whether 
there exists more records having the same contents in a specific data field.

When you have typed in new records in the table, you can therefore assure your-
self that you have not typed in more than one record containing information on the 
same component.

To do this, you have to specify a data field, that uniquely identifies the records in 
the table.

The fields STOCKNO or the field EANNUMBER does this, because no compo-
nents have the same STOCKNO or EANNUMBER. (At the other hand several 
components can have the same MANUFACTUR).

When you have typed in new components in your table, you can therefore choose 
the field EANNUMBER, set the operator to is repeated and click the Activate but-
ton. If this gives any result, it means that you have more than one component 
having the same EANNUMBER in your table.

You must then correct your table, so this is no longer the case.

THE DATA FILTER DISABLES THE TABLE MENU

USING THE DATA FILTER AUTOMATICALLY DISABLES THE TABLE MENU. AS A 
CONSEQUENCE YOU WILL ALWAYS BE SEARCHING IN THE FULL TABLE WHEN 
YOU ARE USING THE DATA FILTER.

Field name Operator Text Start filtering
PC|SCHEMATIC Database
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Separating by component vendor

If you want the components separated by component vendor, you choose the 
SOURCE field, apply the operator is repeated, and click the Activate button.

This groups the components by component vendors. By clicking on the vendor 
names in the left-hand side of the dialog box, you will see which components 
belongs to which vendors in the right-hand side.

Disabling the data filter

When you wish to see the contents of the entire table, you just click the Data filter 
button once again, so that it is no longer highlighted.

You can also disable the filter choosing Functions => Data Filter.

ADVANCED FILTERING USING SQL QUERIES

IF YOU NEED TO MAKE MORE ADVANCED SELECTIONS OF DATA IN A TABLE, 
THIS IS POSSIBLE IF YOU KNOW OF SQL QUERIES.
READ MORE ABOUT THIS IN “SQL QUERIES” ON PAGE 35.
CHEMATIC Database
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EDITING RECORDS

This chapter deals with how to select records or data fields, and how to insert, 
delete and copy records.

Furthermore, you can see how to update databases/tables working in a network.

If you are not working in a table in a database for the moment, please open for 
instance the database eldemo.mdb and select the table Eldemo, as described in 
“Opening a database” on page 16.

If you need a survey of the Database dialog box, please refer to “The work area” 
on page 18.

INSERTING, DELETING AND UPDATING

In the middle of the downmost line of the dialog box — also called the status line — 
you will find some buttons, which gives you the option to insert or delete records in 
the table. You can also update the table (which can be necessary working in a net-
work).

Selecting records or data fields

To select a data field, you just click on the data field once. If you wish to edit the 
contents of the data field, you click on the data field once more, and type in the new 
contents of the data field. (You have to click twice, with a short interval between the 
two clicks — which means you shall not double-click).

THIS CHAPTER DESCRIBES

— INSERTING, DELETING AND UPDATING.........................................................(P. 28)
— MOVING RECORDS TO A NEW MENUPOINT...................................................(P. 31)

NO OPTION TO UNDO CHANGES

WHEN YOU EDIT RECORDS IN A TABLE, YOU MAKE THESE CHANGES IN THE 
TABLE DIRECTLY.
YOU HAVE NO OPTION TO UNDO THE CHANGES YOU MAKE.
PC|SCHEMATIC Database
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When you wish to select an entire 
record, you click on the tiny field on 
the left-hand side of the record.

Deleting records

If you wish to delete a record, you first select the record and then click the Delete 
button. Then you will be asked whether you want to delete the record, and click 
Yes.

You can also delete a record by selecting it — or just a data field inside the record 
— and then press [Ctrl+Del].

If you wish to delete the contents of a data field, you have to select the data field 
(by clicking twice) and then press [Del].

Inserting new records

When you wish to insert a new record, click on the Insert new record button, or 
press <Ins>. This inserts a new empty record, in which you can fill in information. 
Click on the first data field, and fill out the data field. Then click on the succeeding 
data field, and fill it out as well. When you wish to jump to the succeeding data field 
in the record, you can also press the <Tab> button. Pressing <Shift+Tab> brings 
you to the preceding data field.

In the PC|SCHEMATIC Automation manual you can see how to attach electrical 
and mechanical symbols to a record.

Copying data fields or records

By selecting a record and clicking the Copy button, you can copy the contents of 
an entire record. In stead of clicking the Copy button, you can also press [Ctrl+c].

If you then select another record and click the Paste button, the contents of the 
selected record is replaced by the contents of the copied record. In stead of click-
ing the Insert button, you can also press [Ctrl+v].

If you only select a data field in another record and press the Paste button, only the 
data field is replaced by the corresponding data field in the copied record.

Copying records in Record view

If you are working in record view — and therefore only see one record at the time 
— you copy the entire record by pressing down <Ctrl> while clicking the Copy but-
ton.

Records only delete-marked in dBase

When you delete a record in dBase, this causes a delete flag to be set 
for the record, but the record is not completely removed from the table.

If you wish to remove the delete-mark from a record, select the record 
— or just a data field in the record — and click on the Remove delete 
flag button, or choose Edit => Remove delete flag. You can only rem-
ove the delete flag for an entire record.

Click here to select a record
CHEMATIC Database

Page 29



P

Editing records
Applying the Cut button

When you have selected field in a record and click the Cut button, the contents of 
the field is deleted. When you then click on another field and click on the Paste but-
ton, the contents of the selected field is replaced by the contents of the field you 
just removed. In stead of using the Cut button, you can press [Ctrl+x].

Updating

If you are working on a table in a network, it may occur that others are working on 
the table at the same time as you are. Therefore, they may have changed some of 
the information you see for the moment.

To see an updated version of the table, click on the Update button.

NO OTHER USER HAS ACCESS TO THE RECORD YOU EDIT

WHEN EDITING A DATA FIELD IN A RECORD, THE ENTIRE RECORD IS 
UPDATED AUTOMATICALLY. AT THE SAME TIME THE RECORD IS LOCKED, AND 
NO OTHER USER HAS ACCESS TO THE RECORD UNTIL YOU HAVE FINISHED 
EDITING IT. — BUT THEY ARE FREE TO WORK ON THE OTHER RECORDS, 
WHICH YOU HAVE NOT SELECTED.
WHEN YOU LEAVE A RECORD, THE CHANGES YOU HAVE PERFORMED, ARE 
AUTOMATICALLY UPDATED IN THE TABLE.

DELETED RECORDS

WHEN YOU CHOOSE VIEW => DELETED RECORDS, YOU WILL ALSO SEE THE 
DELETED RECORDS IN THE TABLE. THIS IS BECAUSE WHEN A RECORD IS 
DELETED, IT IS NOT REMOVED COMPLETELY, BUT A DELETE FLAG IS SET FOR 
THE RECORD. IN THIS WAY YOU CAN FOR INSTANCE INDICATE THAT A COM-
PONENT IS EXPIRED, AND WAIT TO REMOVE IT COMPLETELY UNTIL IT IS NO 
LONGER ON STOCK, AND NO LONGER IS USED IN EXISTING PROJECTS.
IF A COMPONENT IS NO LONGER BEING USED, YOU CAN NOTICE IT IN A 
REMARKS DATA FIELD FOR THE COMPONENT. — OR, YOU CAN CREATE A 
SPECIAL MENUPOINT IN THE TABLE MENU FOR EXPIRED COMPONENTS. 
MORE ABOUT THIS LATER.
DELETED RECORDS ARE DISPLAYED WITH STRIKETHROUG TEXT ON THE 
SCREEN. AS A DEFAULT, THE PROGRAM IS SET TO DISPLAY DELETED 
RECORDS, BECAUSE THESE CAN BE USED IN OLDER PROJECTS.
IF YOU WISH TO COMPLETELY REMOVE ALL DELETE MARKED RECORDS 
FROM THE TABLE, YOU MUST CHOOSE FILE => PACK. PLEASE NOTE, THAT 
THIS REMOVES ALL DELETE MARKED RECORDS FROM THE TABLE. REMOVING 
DELETE-MARKED RECORDS FROM THE TABLE INDIVIDUALLY IS NOT AN 
OPTION.
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MOVING RECORDS TO A NEW MENUPOINT

When you wish to move records from one menupoint to 
another, you can right-click on the record you want to move, 
and choose Move record in the menu that pops up.

Then right-click on the menupoint you want to transfer the 
record to, and choose Insert record.

You can also move a record by clicking on it and dragging it 
to the desired menupoint.

The record is now transferred from the one menupoint to 
the other, and the data field specifying the menulink of the 
record is automatically changed. — Please refer to “Menulink” on page 56 for 
further details about menulinks in the table.

Records outside menupoints

If there exists records without a filled out menulink data field, they are placed in the 
menupoint Blank first in the table menu.

Records, containing a menulink data field, which does not correspond to any 
menupoint in the menu structure, is displayed when you choose Menu => Show 
hidden records.

You can now transfer the displayed records to the relevant menupoints, as descri-
bed above.

Disable displaying the hidden records by choosing Menu => Display hidden 
records once again.
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SEARCHING IN DATABASES

In PC|SCHEMATIC Database you can find and replace the contents of the indivi-
dual data fields in the tables in the database. You also have the option of scrolling 
back and forth between the components in the table, as well as specifying which 
record number you want to jump to.

This chapter describes how to apply these facilities.

Also, you have the option of filtering which parts of the table you wish to see. 
Please refer to “The Data filter” on page 26 for further details.

SEARCHING ON DATA FIELDS

When you wish to locate a component in the table, you can click the Find button. 
Or you can choose Search => Find or press [Ctrl+f].

You then enter this dialog box, where you type in the text you are looking for.

Here you type in the text in the upper-left corner, and by clicking the down-arrow 
below Searchfield, you specify for which data field the search should be carried 
out.

By clicking the down-arrow below Search direction, you determine whether the 
program should search Forward or Backward compared to where you are located 
in the table for the moment. Or the table could be examined From first record.

If you enable Match Case, the program will only find the data fields containing the 
text S82 in the example above. If it is not enabled, data fields containing the text 
S82 as well as the text s82 will be found.

THIS CHAPTER DESCRIBES

— SEARCHING ON DATA FIELDS .....................................................................(P. 32)
— FIND AND REPLACE ...................................................................................(P. 33)
— SCROLLING BACK AND FORTH BETWEEN THE RECORDS...............................(P. 34)

The result of the search is reported in this line
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If you enable Match whole field, the program only finds the fields matching the 
exact text you have typed in. In the dialog box above, it would then locate the data 
fields where it only says S82.

When you click OK in the dialog box above, the program will select the first compo-
nent having a type data field containing the text S82.

When you press [F3] — or choose Search => Find next — the program will locate 
the next component having a type data field containing the text S82.

If you are applying the table menu or the data filter function, you have to disable 
these to be able to search in the entire table. — To see how to disable these two 
functions, please refer to “Table menus in PC|SCHEMATIC Database” on page 24 
and “The Data filter” on page 26 respectively.

FIND AND REPLACE

If you wish to replace the text you find by another text, you should instead choose 
Search => Replace or press [Ctrl+r]. You then enter this dialog box:

The dialog box function as described above, having the extra facility that you in the 
Replace by field type in the text you want the original text to be substituted by.

In order to find the next data field containing the text S82, you click on Find next. 
When you have found a data field fulfilling the specifications, you click on Replace 
if you wish to replace the text. you will then be asked to confirm this, and you click 
Yes.

If you wish to replace every occurrence of the text S82 with the text S83, you click 
Replace all. You will then be asked whether you wish to replace all occurrences of 
S82, or you just wish to replace the text you have found for the moment. Click 
Replace all.

SEARCH ONLY PERFORMED AMONG THE DISPLAYED COMPONENTS

YOU ONLY SEARCH AMONG THE COMPONENTS DISPLAYED ON THE SCREEN 
FOR THE MOMENT.
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SCROLLING BACK AND FORTH BETWEEN THE RECORDS

In the lower-left corner of the dialog box, some buttons are located, which you use 
for scrolling back and forth between the components in the table.

By clicking the Next and Previous buttons, you can scroll back and forth among 
the selected components.

By clicking the Top and Bottom buttons, you jump to the first and last component 
respectively.

By clicking in the field, you can type in which record number you want to locate. 
When you press <Enter> the program jumps to the desired record.

By choosing Search => Go to record no., the cursor place itself in the field, where 
you can specify which record number you want to jump to.
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SQL QUERIES

This chapter describes how to execute SQL queries in PC|SCHEMATIC Data-
base.

OPTIONS WHEN USING SQL
In PC|SCHEMATIC Database you can execute SQL queries on the database, 
which is open for the moment.

Hereby you can for instance create — or delete — tables.

You can also execute compound queries, which are not covered by the data filter 
function in PC|SCHEMATIC Database, as described in “The Data filter” on 
page 26.

THIS CHAPTER DESCRIBES

— OPTIONS WHEN USING SQL ...................................................................... (P. 35)
— EXECUTING SQL QUERIES ........................................................................ (P. 36)

WHAT IS SQL?
SQL — STRUCTURED QUERY LANGUAGE — IS A COMMONLY USED LAN-
GUAGE FOR EXECUTING QUERIES AND MANIPULATING DATA IN DATABASES.
THE SYNTAX FOR SQL QUERIES IS NOT DESCRIBED IN THIS MANUAL. 
PLEASE REFER TO THE SQL LITERATURE.

ONLY USE SQL IF YOU KNOW WHAT YOU ARE DOING

BECAUSE SQL QUERIES CAN HAVE DRAMATIC CONSEQUENCES — SUCH AS 
DELETING ENTIRE DATABASES WITH NO UNDO — YOU SHOULD ONLY USE 
THIS OPTION IF YOU HAVE WORKING KNOWLEDGE OF SQL QUERIES.
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EXECUTING SQL QUERIES

To execute an SQL query in PC|SCHEMATIC Database choose Functions => 
SQL query, and you enter this dialog box:

Executing a SQL query

Here you type in an SQL query in the upper part of the dialog box, and press the 
Execute SQL button. The result of the query is displayed in the lower part of the 
dialog box on the tab Data record(s). Information from the program is displayed on 
the tab Message.

If you need the name of a table in a query, choose Insert => Tablename and 
choose one of the suggested table names.

Click on the New SQL button to execute a new SQL query.

When you have selected the information you need, click on the Exit and Return 
SQL button. This closes the dialog box, and the selected records are displayed in 
the database dialog box. You can then for instance export these records, as descri-
bed in “Exporting comma separated files” on page 83.

Saving or opening an SQL query

If you wish to save an SQL query, click on the Save SQL file button and save the 
query.

If you wish to open a saved SQL query, click on the Open SQL file button, and 
open the saved SQL query.

Quote tablenames

Under Options => Quote Tablenames in the Database dialog box you can spe-
cify whether to quote tablenames in SQL queries.

The applied driver sets this setting correct. It should therefore only be changed if 
problems occurs in SQL queries as a consequence of misinterpretations of tab-
lenames.

Type in SQL query

Result of the query and info
from the program
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This section deals with:

- Creating a new database.................................(p. 39)

- Creating a new table .........................................(p. 42)

- Editing the data fields in a table .......................(p. 48)

- Creating and editing a table menu..................(p. 51)

- Connecting a menu to a table.........................(p. 59)
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CREATING MICROSOFT ACCESS DATABASES

This section is a description of how to create a Microsoft Access database in 
PC|SCHEMATIC Database.

It is not described how to create the tables of the database, but only how you cre-
ate a database, in which you can place tables in later. — Read more about data-
base and tables in “On databases” on page 13.

— How to create tables is described in “Creating tables” on page 42. How to edit 
the properties of a table is described in “Editing table properties” on page 48.

CREATING A NEW MICROSOFT ACCESS DATABASE

To create a new Microsoft Access database choose File => New:

Here you get the following options:

THIS CHAPTER DESCRIBES

— CREATING A NEW MICROSOFT ACCESS DATABASE......................................(P. 39)
— COPYING AN EXISTING DATABASE...............................................................(P. 41)
— DATABASES AND THE DBASE FORMAT ........................................................(P. 41)

INSTALLATION OF MICROSOFT ACCESS NOT NECESSARY

IN PC|SCHEMATIC Database YOU CAN CREATE AND MAINTAIN MICRO-
SOFT ACCESS DATABASES WITHOUT HAVING INSTALLED MICROSOFT 
ACCESS ON YOUR PC.

OPTION DESCRIPTION OF THE OPTION

MICROSOFT ACCESS DATABASE 
(MDB FILE)

DESCRIBED IN THE FOLLOWING.

MICROSOFT ACCESS TABLE DESCRIBED IN “CREATING TABLES” ON PAGE 42.
CHEMATIC Database

Page 39



P

Creating Microsoft Access databases
Because you are about to create a new Microsoft Access database, choose Micro-
soft Access Database (mdb file) and click Next:

Now choose in which Microsoft Access version you wish to create the database, 
and type in the name of the database. Click Next.

The database is now created, but contains no tables.

You get the following message:

Click on Yes to start creating a new table in the database now, or click No.

MICROSOFT DATA LINK (UDL FILE) DESCRIBED IN “MDAC AND UDL FILES” ON PAGE 99 
AND “CREATING AN UDL FILE” ON PAGE 100.

DBASE TABLE (DBF FILE) DESCRIBED IN “CREATING TABLES” ON PAGE 42.

NAMES FOR DATABASES, TABLES AND DATA FIELDS

A GOOD POLICY FOR NAMING DATABASES, TABLES AND DATA FIELDS IS 
ONLY TO USE THE FOLLOWING CHARACTERS:

1) THE LETTERS FROM A TO Z

2) THE DIGITS FROM 0 TO 9
IN OTHER WORDS, YOU SHOULD NOT USE ANY SPECIAL CHARACTERS OR 
SPECIAL LETTERS FROM ALPHABETS OTHER THAN THE ENGLISH.

OPTION DESCRIPTION OF THE OPTION

Type in the name of the database

Choose Access version
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If you click Yes, you can create a table as described in “Creating tables” on 
page 42.

COPYING A TABLE FROM AN EXISTING DATABASE AND ADAPTING ITS
CONTENTS

If you wish to create a database including tables quickly by copying from an 
existing database, you can do it like this:

 1) Create a database — as described in “Creating a new Microsoft Access 
database” on page 39

 2) Make a copy of an existing table — as described in “Creating tables” on 
page 42 (see “Copying a table” on page 45 in particular)

 3) Adapt the properties of the table — the names and lengths of its fields — as 
described in “Editing table properties” on page 48

 4) Create a menu — as described in “Creating table menus” on page 51

 5) Attach the menu to the table — as described in “Connecting table menus to 
tables” on page 59

Please note that you may not need to execute all the steps mentioned above, when 
creating your own database:

- If you are pleased with the structure of the copied database, there is no reason 
executing step 3

- If you are pleased with the menu attached to the table, you can copy the menu 
(like you copy any other table) in stead of executing step 4

However, it might be a good idea to carry out all the steps to get familiar with the 
database program.

DATABASES AND THE DBASE FORMAT

Microsoft Access works with database in the traditional way, where a database file 
is created containing information about which tables etc. are included in the data-
base. — Read more about this in “On databases” on page 13.

As opposed to this, dBase only works with tables. When working with a table in 
dBase, PC|SCHEMATIC Database understands the folder in which the table is 
placed as a database.

If other dBase tables exists in this folder, they 
can be choosen from the Table window in the 
upper left-hand corner of the program.
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CREATING TABLES

This chapter describes how to create tables in PC|SCHEMATIC Database.

— See how to create Microsoft Access databases in “Creating Microsoft Access 
databases” on page 39.

CREATING A NEW MICROSOFT ACCESS TABLE

To create a new table in the Microsoft Access database you have opened for the 
moment, choose File => New. Then choose Microsoft Access Table and click 
Next.

You then enter this dialog box:

THIS CHAPTER DESCRIBES

— CREATING A NEW MICROSOFT ACCESS TABLE ............................................(P. 42)
— CREATING A NEW DBASE TABLE .................................................................(P. 47)
— DELETING A DATABASE ..............................................................................(P. 47)
— EMPTYING A TABLE....................................................................................(P. 47)

INSTALLATION OF MICROSOFT ACCESS NOT NECESSARY

IN PC|SCHEMATIC Database YOU CAN CREATE AND MAINTAIN MICRO-
SOFT ACCESS AND DBASE TABLES WITHOUT HAVING INSTALLED EITHER 
DBASE OR MICROSOFT ACCESS.
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You then get the following options:

These options are described in the following.

1. Defining a new table
To create a new table from scratch, choose Define New Table and click Next. You 
then enter the following dialog box:

Specify the name of the database — if a database is opened this field is filled out 
automatically — and type in the name of the table.

— See “Names for databases, tables and data fields” on page 40.

Click Next.

OPTION DESCRIPTION OF OPTION

DEFINE NEW TABLE HERE YOU CREATE A TABLE FROM SCRATCH. NO FIELDS ARE 
DEFINED IN ADVANCE. HOWEVER, IN MICROSOFT ACCESS 
TABLES AN ID FIELD IS CREATED AS A PRIMARY KEY.
— SEE “DEFINING A NEW TABLE” ON PAGE 43.

COPY TABLE STRUCTURE HERE YOU COPY A TABLE STRUCTURE FROM AN EXISTING 
TABLE. THUS YOU GET A COMPLETE TABLE, WHERE THE 
FIELDNAMES ARE CREATED, BUT THE TABLE CONTAINS NO 
RECORDS.
— SEE “COPYING A TABLE STRUCTURE” ON PAGE 44.

COPY TABLE HERE YOU COPY OF A COMPLETE TABLE IN A DATABASE. YOU 
GET AN EXACT COPY OF THE TABLE — INCLUDING ALL 
RECORDS.
— SEE “COPYING A TABLE” ON PAGE 45.
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You now enter the following dialog box:

Here you can create the necessary field names in the table. Read more about this 
in “Editing table properties” on page 48.

2. Copying a table structure
To copy the table structure from an existing table select Copy Table Structure and 
click Next.

Here you specify which table you wish to copy — see “Choosing which table to 
copy” on page 45 — and type in the name of the new table.

Doing this you get a complete table where the field names are created, but the 
table contains no records.

CHECK THAT THE TABLE HAS A PRIMARY KEY

REMEMBER TO CHECK THAT THE TABLE HAS A PRIMARY KEY. IF THIS IS NOT 
THE CASE, YOU HAVE TO CREATE ONE YOURSELF. (IF YOU ARE CREATING A 
DBASE TABLE YOU CAN NOT CREATE A PRIMARY KEY).
— READ MORE ABOUT THIS IN “EDITING TABLE PROPERTIES” ON PAGE 48.

Copy the structure
from this table

Name on the
new table
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3. Copying a table
To copy a table including all of its records (here the table Eldemo from the data-
base carrying the same name) you choose Copy Table and click on Next.

You then enter this dialog box where you can select which table you wish to copy, 
and type in the name of the new table.

Choosing which table to copy

Click on Browse to choose the table you wish to copy:

You now have to choose how to open the database in which the table is created.

COPYING TABLES FROM OTHER DATABASE FORMATS

EVEN THOUGH YOU ARE CREATING A MICROSOFT ACCESS TABLE, YOU CAN 
CHOOSE TO COPY A TABLE FROM ANOTHER DATABASE FORMAT. FOR 
INSTANCE YOU CAN COPY A DBASE TABLE, OR A DATABASE OF A FORMAT 
OPENED VIA AN UDL FILE OR A BDE ALIAS.

Copy this
table

Name of the
new table

Click
here
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Click on Database files (*.mdb, *.udl, *.dbf, *.db) and click on Next.

Click on the database eldemo.mdb and click on Open.

Click on the table Eldemo and click Next.

The previously displayed dialog box has now been filled out:

Click on Next to execute the copying.
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When the copying is completed, the new table in the database is opened automati-
cally.

CREATING A NEW DBASE TABLE

To create a new dBase table choose File => New. Here you choose dBase table 
(dbf file) and click on Next.

You now get the option of specifying how to create your new dBase table, which 
takes place exactly as described for Microsoft Access tables. — See how to do this 
in “Creating a new Microsoft Access table” on page 42.

If for instance you choose to copy a Microsoft Access table, you can have a new 
dBase table created from a Microsoft Access table.

— Please also read “Databases and the dBase format” on page 41.

DELETING TABLES

To delete the currently active table, do the following:

 1) Press down <Shift> and choose File => Delete

 2) Answer Yes to delete the table

 3) Press <F5>, and the table disappears from the Table field in the toolbar

The table is now deleted.

EMPTYING TABLES

To delete all records from the currently active table, do the following:

 1) Press down <Shift> and choose File => Empty

 2) Answer Yes to empty the table

All records are now deleted from the table.

CHECK THAT THE TABLE HAS A PRIMARY KEY

REMEMBER TO CHECK THAT THE TABLE HAS A PRIMARY KEY. IF THIS IS NOT 
THE CASE, YOU HAVE TO CREATE ONE YOURSELF. (IF YOU ARE CREATING A 
DBASE TABLE YOU CAN NOT CREATE A PRIMARY KEY).
— READ MORE ABOUT THIS IN “EDITING THE PROPERTIES OF A TABLE” ON 
PAGE 48.
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EDITING TABLE PROPERTIES

EDITING THE PROPERTIES OF A TABLE

If you wish to edit some of the data fields in the active table, choose File => Pro-
perties and you enter this dialog box:

Here you can add or remove data fields, and change the length of the data fields. 
Finally, you determine which data fields shall be index fields in the data fields — 
which means that searching on these data fields will be speeded up if you are 
working in dBase.

THIS CHAPTER DESCRIBES

— EDITING THE PROPERTIES OF A TABLE........................................................(P. 48)
— PRIMARY KEYS..........................................................................................(P. 50)
— INDEX FIELDS ............................................................................................(P. 50)

NEWLY CREATED MICROSOFT ACCESS TABLE

IF YOU HAVE CREATED A NEW MICROSOFT ACCESS TABLE, THERE HAS 
ONLY BEEN CREATED AN ID FIELD FOR THE TABLE.
YOU CAN NOW CREATE THE OTHER FIELDS IN THE TABLE, AS DESCRIBED 
BELOW.
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Adding/inserting a data field in a table

When you wish to add a data field to the end of the table, click on Add.

Type in the name of the data field below Field name, and press <Enter> — see 
“Names for databases, tables and data fields” on page 40.

Under Datatype choose WideString — unless it is a primary key ID field in Micro-
soft Access. If this is the case choose AutoInc. — See “Primary keys” on page 50.

Then click in the Length field of the new data field, type in the length of the data 
field, and press <Enter>.

— Please note, that the program does not memorize what you type in until you 
press <Enter>.

If you wish to place a new data field in the middle of the table, click on the data 
field, which is located where you want the new data field to be located. Then click 
on Insert, and fill out Field name and Length as described above.

Deleting a data field in the table

If you wish to delete a data field from the table, select the data field, and click on 
Delete.

Updating the changes

The changes in the properties of the data fields in the table is not carried out until 
you click OK. When you have deleted a data field from the table, you will be asked 
to confirm the deletion when you click OK.

Click on Cancel if you regret any of the changes you have carried out.

DENIED ACCESS TO EDIT TABLE PROPERTIES

IF SOMEBODY ELSE IS USING A TABLE YOU WISH TO RECONSTRUCT, YOU 
WILL BE DENIED ACCESS TO DO SO.
IF YOU ARE WORKING IN PCSCHEMATIC AND WISH TO EDIT THE PROPERTIES 
OF A TABLE (AND NOT JUST ITS CONTENTS), YOU THEREFORE HAVE TO 
CHOOSE SETTINGS => DATABASE AND CLICK ON DISABLED. OTHERWISE 
YOU YOURSELF WILL BE BLOCKING YOUR OWN ACCESS TO THE TABLE.

Datatypes and primary keys in dBase

In dBase all Datatypes are of the type String.

Also, no Primary key button exists for dBase tables, because primary 
keys can not be created in dBase.
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PRIMARY KEYS

Please note that primary keys does not exist in the dBase format.

If you wish to turn a data field in a table into a primary key, choose File => Proper-
ties, click on the field, and then click on Primary key. When a field is a primary key, 
a small key is displayed in front of the field in the Properties dialog box.

When you create a Microsoft Access table in PC|SCHEMATIC Database, a field 
with the name ID will be created automatically. This field will be set to be primary 
key.

Primary key for Microsoft Access table created from dBase
table

When you create a Microsoft Access table from a dBase table, you must add an ID 
data field (or another data field name) of the type AutoInc and set it to be primary 
key. The data field should be placed as the first data field in the table.

It is important to create a primary key, in order not to have double records in the 
table.

INDEX FIELDS

When you want a data field to be an index field, you click on its Index field, and 
choose Yes in the appearing menu.

WHAT IS A PRIMARY KEY?
A PRIMARY KEY IS A FIELD IN A TABLE, WHICH UNIQUELY IDENTIFIES THE 
INDIVIDUAL RECORDS IN THE TABLE. IF A FIELD IS POINTED OUT TO BE A PRI-
MARY KEY, PC|SCHEMATIC Database WILL NOT ALLOW THE CREATION 
OF TWO RECORDS WITH THE SAME CONTENTS IN THE PRIMARY KEY FIELD.

INDEX FIELDS SPEEDS UP SEARCHING IN DBASE

IF YOU TURN A DATA FIELD INTO AN INDEX FIELD, SEARCHING ON THE DATA 
FIELD WILL BE INCREASED CONSIDERABLY. FURTHERMORE, YOU GOT THE 
OPTION TO SORT THE DATABASE BY ITS INDEX FIELDS. BUT AT THE SAME 
TIME THE INDEX FILE OF THE DATABASE WILL TAKE UP MORE SPACE ON 
YOUR HARD DISK. IF YOU ARE NOT CAREFUL, THIS INDEX FILE COULD EASILY 
TAKE UP MORE SPACE THAN THE DATABASE ITSELF. SO, MAKE SURE ONLY 
TO CREATE THE INDEX FIELDS THAT ARE REALLY NECESSARY.
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CREATING TABLE MENUS

In PC|SCHEMATIC Database you have the option of designing your own table 
menus.

When you have created a table menu, you can connect it to a table, as described in 
“Connecting table menus to tables” on page 59.

CREATING A NEW TABLE MENU

— If you just need to copy an existing table menu, please read “Copying a table 
menu” on page 58.

To create a new menu, do the following:

 1) Choose File => Close if a database is open in PC|SCHEMATIC Database

 2) Choose Menu => Edit

 3) Choose File => New

THIS CHAPTER DESCRIBES

— CREATING A NEW TABLE MENU...................................................................(P. 48)
— ON EDITING TABLE MENUS .........................................................................(P. 53)
— THE TABLE MENU EDITOR .........................................................................(P. 55)
— COPYING AN EXISTING TABLE MENU............................................................(P. 58)

TABLE MENUS WERE PREVIOUSLY CALLED DATABASE MENUS

WHAT WAS CALLED A DATABASE MENU IN PREVIOUS VERSIONS OF 
PC|SCHEMATIC Database IS NOW CALLED A TABLE MENU.
THIS IS BECAUSE THE MENU IS ONLY ATTACHED TO A SINGLE TABLE IN THE 
DATABASE.
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 4) You now have to choose whether to create a table menu in Microsoft Access 
or dBase format:

Choose Microsoft Access Table and click Next.

 5) You must now specify in which database to save the menu, and type in the 
name of the menu in the field Table name:

Click on Next.

 6) You can now add and edit data fields in the table menu, which you edit as an 
ordinary table:
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See how to do this in “Editing the properties of a table” on page 48.
Click OK when you have finished.

 7) You now return to the Table Menu Editor, where you can create menupoints, 
as described in “The Table Menu Editor” on page 55:

 8) Choose File => Exit when you have finished.

You can then connect the menu to a table, as described in “Connecting table 
menus to tables” on page 59.

ON EDITING TABLE MENUS

In the table eldemo — in the database of the same name — a table menu is 
applied, but you do not necessarily have to use this menu in your database.

When you choose Menu => Edit you can edit the table menu, which is connected 
to the database you are working on for the moment.
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No access

When the database is located in a network, it may occur that you are not allowed to 
edit the structure of a table menu — such as adding an extra field for a new lan-
guage for the menupoints. If this is the case, it is because someone else is working 
in the database, and you are therefore not allowed to edit it.

In situations where you have started PC|SCHEMATIC Database from PC|SCHE-
MATIC Automation having the database connected, you can therefore block for 
your own access.

To disconnect the database, you can either close down PC|SCHEMATIC Automa-
tion, or enter PC|SCHEMATIC Automation, choose Settings => Database, click 
on Off, and then click OK.

Databases and table menus

Because more than one database can use the same table menu, you have to look 
out for the following:

 1) Making changes in a table menu for a database, also has consequences for 
other databases using the same table menu.

 2) In PC|SCHEMATIC Automation: The changes are first updated when 
PC|SCHEMATIC Automation is restarted, or when you inactivate the menu 
and activate it again.

 3) In PC|SCHEMATIC Database: You have to press <F5> to see the changes.

ALWAYS EDIT TABLE MENUS FROM MENU => EDIT

THE TABLE MENU YOU CREATE HERE, ALSO IS CREATED AS A DATABASE IN 
THE PC|SCHEMATIC Database FORMAT. THEREFORE, YOU CAN ALSO 
OPEN IT AS AN ORDINARY DATABASE. HOWEVER, IT IS IMPORTANT THAT YOU 
DO NOT DO THIS. THE CONSTRUCTION OF THIS DATABASE HAVE TO FULFIL 
SOME SPECIFICATIONS, WHICH MAKES IT USABLE AS A MENU FOR ANOTHER 
DATABASE. THIS IS HANDLED AUTOMATICALLY WHEN YOU EDIT THE MENU 
USING MENU => EDIT.
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THE TABLE MENU EDITOR

When you have chosen Menu => Edit you enter the Table Menu Editor:

If you right-click on a menupoint in 
the dialog box, a menu pops up, 
giving you the option of  deleting, 
inserting or adding new menu points 
in the menu — as well as adding 
submenus.

You will get the same menu clicking 
on Edit in the menu tool bar.

Edit menupoint

When you wish to edit an entry in the table menu, you click on the menu point in 
the left-hand side of the dialog box, and make the desired changes in the right-
hand side of the dialog box.

Here you can edit the name/description in Danish, English and German, and 
change its menulink. When you click on the down-arrow in the Menulink field, you 
get a list of the available menulinks for the level you are placed on in the Table 
Menu Editor — see “Menulink” on page 56.

The position
in the menu

The Danish
description

The English
description

The German
description

Specifies which records to display
when the menu point is selected
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Make your changes and choose File => Exit when finished. The changes are 
made directly in the table menu, and you have no options for undo.

Menulink

A menulink has two functions:

 1) The menulink determines which records in a table are displayed when you 
choose the menupoint — see “The menu structure and menulink” on 
page 56

 2) By using a special naming in the menulink fields, you can have the records of 
the submenupoints displayed, when you click on a menupoint — see “Dis-
playing records on several levels in the menu” on page 56

The menu structure and menulink

The menu structure for a table (the table menu) consists of menupoints, each dis-
playing different components depending on the nature of the components. If you 
need further division of the components, the menupoints can also contain subme-
nus.

The menulink determines which records are displayed when you click on a menu-
point. If for instance a menupoint has got the menulink 1310, all records in the 
component table containing the menulink 1310 will be displayed when you click on 
the menupoint.

A menulink must be a number containing at least four digits. You can have menu-
points in up till five different levels.

Displaying records on several levels in the menu

When you click on a menupoint, the program displays all components in the com-
ponent table, that has the same menulink as the menupoint.

If the menupoint contains submenus, it is also possible to have displayed all com-
ponents from these.

MENULINKS AND THE CONTENTS OF MENUPOINTS

IN ORDER TO LET THE MENULINK SPECIFY WHICH RECORDS ARE DISPLAYED 
FOR A MENUPOINT, A FIELD IN EACH OF THE RECORDS IN THE COMPONENT 
TABLE MUST CONTAIN A NUMBER CODE, SPECIFYING WHICH MENUPOINT 
THIS INDIVIDUAL RECORD BELONGS TO.
WHICH FIELD THAT CONTAINS THIS NUMBER CODE IN THE DATABASE, IS 
SPECIFIED IN MENU => SETTINGS. READ MORE ABOUT THIS IN “CONNEC-
TING TABLE MENUS TO TABLES” ON PAGE 59.

MENULINKS DOES NOT DETERMINE THE LOCATION OF MENUPOINTS

THE MENULINK DOES NOT DETERMINE WHERE THE MENUPOINT IS PLACED IN 
THE MENU STRUCTURE. THIS IS HANDLED AS DESCRIBED IN “ADDING/INSER-
TING A MENUPOINT” ON PAGE 57.
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If for instance the menupoint Terminals is a submenu to Branch equipment, all 
the terminals from Terminals can also be displayed when you click on Branch 
equipment.

In order to make this work, you must apply number codes following a special 
system in the name of the menulink.

To do so, you have to know the following:

 1) The first two digits in the menulink identifies it on the highest level. If the third 
and fourth digit are both zero, the menupoint will be considered to be on the 
highest level in this context.

 2) If the third and fourth digit have non-zero values in a four-digit menulink, the 
menupoint belongs to the second level.

 3) If you need menupoints on third level, you just assign a six-digit menulink to 
the menupoint. Accordingly you apply eight digits for a fourth level, and ten 
for a fifth.

When for instance the menulink for a record is 162657, the record will be displayed 
when you click on:

 1) The menupoint with the menulink 1600 (highest level)

 2) The menupoint with the menulink 1626 (second level)

 3) The menupoint with the menulink 162657

You can decide for yourself whether you wish to apply the number code system 
described above.

Adding/Inserting a menupoint

When you wish to insert a menupoint in the menu, right-click where you want the 
menupoint to be inserted, and choose Insert in the appearing menu.

In the right-hand side of the dialog box you fill out the UKtext field, and choose 
Menulink by first clicking on the down-arrow in the Menulink field, and then click 
on one of the menulinks displayed.

If you wish to add a menupoint to the end of the menu, choose Add instead.

Delete menupoint

When you wish to delete a menupoint, you right-click on the menupoint, choose 
Delete, and answer Yes to delete the menupoint.

1499

Highest level/ Second level
Main menu
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New submenupoint

When you wish to create a new submenupoint to a menupoint, you right-click on 
the menupoint, and choose New submenu. Here you fill out the field with Descrip-
tion, and choose Menulink by first clicking the down-arrow in the Menulink field. 
This gives you all available sub-menulinks for the chosen menu.

Click on one of the menulinks displayed, and click OK.

Returning to the component table

When you have finished working on the table menu, and have saved your changes, 
you return to the component table by choosing File => Exit.

COPYING A TABLE MENU

When you wish to copy an existing table menu, this is done just like you copy an 
ordinary table. This is described in “Creating a new Microsoft Access table” on 
page 42 — see “Copying a table” on page 45 in particular.

When you have copied the table menu, you attach the table menu to a table as 
described in “Connecting table menus to tables” on page 59.
PC|SCHEMATIC Database

age 58



Connecting table menus to tables

PC|S
CONNECTING TABLE MENUS TO TABLES

When you have a table in a database, for which you want to use a specific table 
menu, you must first open the table in the database. Then choose Menu => Pro-
perties:

In this example, the name of the database is eldemo.mdb. In this database the 
table Eldemo is placed, which is connected to the table menu FAFGE. The table 
menu FAFGE is also placed in the database eldemo.mdb.

To select the menu click on Open Menu, and do the following:

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO CONNECT A TABLE MENU TO A TABLE IN A DATABASE.

— SEE HOW TO CREATE TABLE MENUS IN “CREATING TABLE MENUS” ON 
PAGE 51.
— SEE HOW TO CREATE TABLES IN “CREATING TABLES” ON PAGE 42.

The name of the table menu

Name of the database

The field in the table
containing the menulink

Having created the table
menu correctly, you do not
have to change these fields

containing the table

The name of the table

The name of the database
containing the table menu
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 1) Choose how you wish to open the database in which the table menu is pla-
ced:

Click on Database files (*.mdb, *.udl, *.dbf, *.db) and click Next

 2) You now enter the dialog box Open: Click on eldemo.mdb and click OK

 3) You now enter the Choose table dialog box: Choose the table FAFGE (con-
taining the table menu) and click Next

You now return to the dialog box Menu setup, where you can see that the table 
menu now is attached to the table. Click OK.

You have now connected a table in a database to a table menu.

The fields in the lower part of the menu

Please note, that as long as you are applying the FAFGE menu, and have adapted 
the table menu as described above, there is no reason to change the contents of 
the four fields in the lower part of the menu.

In the table Eldemo the field TABLEGROUP specifies to which FAFGE group the 
various components belong.

The program now makes sure that the records in the table are displayed in the 
menupoint in the table menu, which is specified by the TABLEGROUP field in the 
table.
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This section covers:

- Loading a database from a component

vendor................................................................(p. 63)

- Importing a component vendor database

into your own database ..................................(p. 64)

- Importing comma separated files...................(p. 69)

- Import using filters .............................................(p. 73)

- Importing from Microsoft Excel .......................(p. 78)
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Importing databases from component vendors

PC|S
IMPORTING DATABASES FROM COMPONENT VEN-
DORS

In this chapter you load a component vendor database from a diskette/CD, and 
import it into your own database.

IMPORTING A COMPLETE COMPONENT VENDOR DATABASE

When you wish to import a complete component vendor database into a table in 
your own database, do the following:

 1) Create your own database and a component table, if you have not already 
done so — see “Creating Microsoft Access databases” on page 39 and 
“Creating tables” on page 42

 2) Install the component vendor database — see “Loading a PC|SCHEMATIC 
component vendor database” on page 64

 3) Import the entire component vendor database into a table in your own data-
base — see “Importing the component vendor database into your own data-
base” on page 64

When you only wish to import part of the component vendor database, please read 
“Importing part of a component vendor database” on page 67.

THIS CHAPTER DESCRIBES

— IMPORTING A COMPLETE COMPONENT VENDOR DATABASE ..........................(P. 63)
— LOADING A COMPONENT VENDOR DATABASE ..............................................(P. 64)
— IMPORTING THE COMPONENT VENDOR DATABASE .......................................(P. 64)
— IMPORTING PART OF A COMPONENT VENDOR DATABASE .............................(P. 67)

MAKE A COPY OF YOUR TABLE BEFORE IMPORTING

BEFORE IMPORTING ANYTHING INTO A TABLE IN YOUR DATABASE, IT IS A 
GOOD IDEA TO MAKE A COPY OF THE TABLE.
IF YOU REGRET THE IMPORT, YOU CAN THEN APPLY THE COPY OF THE DATA-
BASE.
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LOADING A PC|SCHEMATIC COMPONENT VENDOR DATABASE

Start by inserting a CD/diskette from a component vendor, click Start in Windows, 
and choose Run. Now type in a:\setup and press <Enter>.

Follow the installation guide until the database is properly installed.

You have now installed the database, but have not loaded it into your own data-
base.

IMPORTING THE COMPONENT VENDOR DATABASE INTO YOUR OWN
DATABASE

Enter the database program. Choose File => Open and open the table in your 
database to which you wish to import the components.

Choose File => Import, select the new component database in the dialog box and 
click Open.

Select the table you wish to import from the database, and click Next.

Adding/updating records

You now enter a dialog box, in which you have to specify the following:

If it is not the first time you import data from the chosen component vendor, you 
already have records with components from this vendor. However, the information 
might have changed. Enable Update existing records, if you want your database 
updated with these changes, or disable the function if this is not the case.

Also enable Add new records, if you wish to add new records to your database.

Click Next.

PC|SCHEMATIC Database DOES NOT HAVE TO BE STARTED

PC|SCHEMATIC Database DOES NOT HAVE TO BE STARTED IN ORDER 
TO INSTALL A COMPONENT VENDOR DATABASE.
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Import settings

You now enter a dialog box, in which you specify which fields in the imported data-
base, you wish to transfer to which fields in your own database.

In the right-hand side of the dialog box — above 3) — you see the data fields of the 
table in the component vendor database. Above 1) you see the data fields of the 
component table in your own database. By transferring the field names from 1) to 
2) you specify which data fields in the table in your own database are going receive 
data from which data fields in the component vendor database table.

Transfering field names

Using the four buttons between 1) and 2) on the figure above, you transfer data 
field names from 1) to 2). If you might loose data due to too short field lengths in 
your table, you will receive a warning.

DO NOT IMPORT ID FIELDS

IF THE RECORDS OF THE COMPONENT VENDOR DATABASE CONTAINS AN ID 
FIELD, YOU SHOULD NOT IMPORT THIS FIELD.
THIS FIELD IS UPDATED AUTOMATICALLY.

1) Available data field
names in your table

4) Contents of data
fields in vendor

3) Data field
names in vendor

2) Data field
names in your

The name of your table The name of the table in the
component vendor database

table table table
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Transfering all data fields

Because all the component vendor databases are adapted to PCschematic, all 
data fields within the component vendor database table have the same field names 
and field lengths as the table Eldemo.

Therefore you can just click the Transfer all button, which causes all the field 
names to be aligned facing the corresponding field names in the other table.

Transfering individual data fields

For each individual data field you can also specify, that the contents of for instance 
the data field named EANNUMBER in your database table, shall receive data from 
the data field that (also) is named EANNUMBER in component vendor database. 
You do this by clicking on the data field EANNUMBER in 1) Available data field 
names in your table, and then click on the Transfer button.

When you transfer the data field names in this way, they are arranged in the order 
in which you transfer them. When they are on the list (2), you can move the fields 
by clicking on them and dragging them to another position.

Reverting data fields

If you regret transferring some data fields, you can transfer them back individually 
by selecting the data fields and clicking the Revert button, or transfer all data fields 
back clicking the Revert all button.

Drag and drop

You can also transfer the data fields individually using drag and drop.

Viewing records in the file you import from

In the right-hand side of the dialog box (4), you can see the contents of the file you 
are going to import.

When you wish to see another record in the same file, click on the New data button 
in the lower part of the dialog box.

Memorizes settings

If you have previously imported a component vendor database, the program 
memorizes the settings you specified at that time.

Transfer the data fields, and click Next.

Search key

The field Choose search key then appears in the left-
hand side of the dialog box.

A search key is a data field, which uniquely identifies the 
records in the table.

The data field remarks, for instance, does not uniquely 
identify a record, because several components can have 
the same remarks.
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On the other hand, the EANNUMBER of the component, precisely identifies the 
component. Therefore choose EANNUMBER as the search key in this case.

Using the search key, the program examines whether there exists components in 
your table, which also exists in the table you import. Depending on what you speci-
fied earlier — in “Updating/adding records” on page 71 — the program will update 
these records or not.

— If you need another search key (in another table in another context), click the 
down-arrow and choose another search key.

Import the file

Click on Import.

You now enter a dialog box, in which you can see which table is being imported, 
and which table it is imported into. Click Start.

The program now imports the table, and after completing the import, it is displayed 
how many records have been updated and added. Please note, that existing 
records cannot be deleted this way. Click OK.

You have now imported the table, and see the contents of the table on the screen.

IMPORTING PART OF A COMPONENT VENDOR DATABASE

When you wish to import a complete component vendor database into your own 
database, do the following:

MAKE A COPY OF YOUR TABLE BEFORE IMPORTING

BEFORE IMPORTING ANYTHING INTO A TABLE IN YOUR DATABASE, IT IS A 
GOOD IDEA TO MAKE A COPY OF THE TABLE.
IF YOU REGRET THE IMPORT, YOU CAN THEN APPLY THE COPY OF THE DATA-
BASE.
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 1) Create your own database and a component table, if you have not already 
done so — see “Creating Microsoft Access databases” on page 39 and 
“Creating tables” on page 42

 2) Install the component vendor database — see “Loading a PC|SCHEMATIC 
component vendor database” on page 64

 3) Export the desired part of the component vendor database to a comma 
separated file — see “Exporting comma separated files” on page 83

 4) Import the comma separated into your own database — see “Importing 
comma separated files” on page 69

When you wish to import the complete component vendor database, please read 
“Importing a complete component vendor database” on page 63.
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IMPORTING COMMA SEPARATED FILES

To import a comma separated file, you will typically need to know in which order 
the data fields are placed in the file. However, you get the option to see what the 
file looks like before importing it.

If you do not know what a comma separated file is, please read “What is a comma 
separated file?” on page 83.

OPENING A COMMA SEPARATED FILE

To open a comma separated file, you first choose File => Import.

Choose the file type Comma sep., and double-click on the file you wish to import.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO IMPORT A COMMA SEPARATED 
FILE INTO A TABLE IN PC|SCHEMATIC Database.

MAKE A COPY OF YOUR TABLE BEFORE IMPORTING

BEFORE IMPORTING ANYTHING INTO A TABLE IN YOUR DATABASE, IT IS A 
GOOD IDEA TO MAKE A COPY OF THE TABLE.
IF YOU REGRET THE IMPORT, YOU CAN THEN APPLY THE COPY OF THE DATA-
BASE.
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Opening zip files

If the comma separated file is saved as a zip file, 
choose the file type Zip file instead, and double-
click on the file you wish to import.

The program then automatically opens the zip 
file. — Then continue as described in the follo-
wing.

Specifying the file setup

You now enter this dialog box, where you specify information on the type of the file:

Here you first make sure that the File format is set to Comma sep.. If this is not 
the case, you must choose the right format under File format.

Under Preview in the lower part of the dialog box, you can see how the program  
understands the contents of the file, when it uses the settings you have specified in 
the upper part of the dialog box.

This might be used to see whether the file is of the type Windows (ANSI) or of the 
type DOS (PC-8). These two file types use different signs for languages having 
special characters. Click on the type below File type which gives the right result.

Specify it is a comma separated file Choose the correct delimiter

Specify whether the file is
of DOS or Windows type

The contents Use the elevator to see
the other parts of the file

Specify whether the first
record contains data field names of the file
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Furthermore, you can see which delimiter is used in the file, and then specify the 
correct separator under Delimiter.

If the first record contains field names, you have to enable Field names in first 
record.

Click Next when the settings are correct.

Updating/adding records

You now have to specify whether you wish to update and/or add records to the 
database. This is elaborated in “Updating/adding records” on page 71.

Click Next.

Import settings

You now enter this dialog box:

If you do not already know which information the individual fields in the comma 
separated file contains, you can use the elevator to leaf through the file, which is 
displayed in the right-hand side of the dialog box. Using the horizontal elevator 
enables you to leaf back and forth between five different records at the time. If you 
wish to see the five following records, you click New data.

This enables you to specify which data fields in your table, that are going to receive 
data from which data fields from the comma separated file.

The name of your table The name of the comma separated file

Use the elevator to leaf
through the comma sep. file

transferred to

Data field names
in your table

The contents of the
comma separated file

Data field names in the
comma separated file
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On the image above, the first record contains data field names, which makes it 
easier to find the corresponding data fields in your own table. The first record will 
always be available in this dialog box, even though it is not going to be imported 
because you enabled First record contains field names in the previous dialog 
box.

Place the field names below Data field names in your own DB facing the appro-
priate data fields in the file, as described in “Transfering field names” on page 65.

Click Next.

Now specify the search key and click Next, as described in “Search key” on 
page 66. Finally, import the file by clicking Import, as described in “Import the file” 
on page 67.

You have now loaded the contents of the comma separated file into your table.

Click OK.

DO NOT COPY ID FIELDS

IF THE RECORDS OF THE COMPONENT VENDOR DATABASE CONTAINS AN ID 
DATA FILED, YOU SHOULD NOT IMPORT THIS DATA FIELD.
THIS FIELD IS UPDATED AUTOMATICALLY.
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FILTERED IMPORT

Because PC|SCHEMATIC Database contains specially designed filters, it is possi-
ble to import some file types originally designed for other programs.

In this way you can for instance import price update disks from Nordisk Solar and 
Louis Poulsen. Both file types contains various types of records, and you therefore 
have to make special settings for each of these.

This chapter is an example on how to import a file of this type.

The next time you import a file having the same file name, you will not have to spe-
cify these settings again, because PC|SCHEMATIC Database memorizes the 
used settings.

OPENING THE FILE

To open the file you choose File => Import, 
and click on the desired file type in the lower 
part of the dialog box — for instance NSC 
article data.

Double-click on the file you wish to import.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO IMPORT FILE TYPES MEANT FOR OTHER PROGRAMS.

MAKE A COPY OF YOUR TABLE BEFORE IMPORTING

BEFORE IMPORTING ANYTHING INTO A TABLE IN YOUR DATABASE, IT IS A 
GOOD IDEA TO MAKE A COPY OF THE TABLE.
IF YOU REGRET THE IMPORT, YOU CAN THEN APPLY THE COPY OF THE DATA-
BASE.
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You now enter this dialog box, where you just have to check whether the file format 
is set properly

Because the file is meant for another system, you cannot see the meaning of the 
contents in the lower part of the dialog box.

Click Next.

Which changes shall be made?

Because the file contains different types of records, you have to specify whether 
you wish to load all the changes/additions the file contains:

The record type Change records only contains minor changes (in this example 
price changes). Here you only change existing records in your component table; if 
the file contains corrections for a record you do not have in your component table, 
the component is not loaded.

Check that the file
format is correct

The contents of the file
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If you enable Update records, all records of this type are loaded into your data-
base. If a record already exists for a component, the contents of this record is 
replaced by the contents of the update record.

Enabling Delete records will delete the specified records.

Make your choices and click Next.

Choosing field names for Change records

Now you have to specify which fields in your database, that matches which fields in 
the Change records in the file.

Therefore transfer all the relevant fields from the list of Free fields to the column 
with the field names of your database (*). This is thoroughly dealt with in “Transfe-
ring field names” on page 65.

Records are only delete-marked in dBase

If you are working in a dBase table, the specified records only becomes 
delete-marked. Read more about delete marking in “Deleted records” 
on page 30.

DO NOT COPY TYPE FIELDS

THE FIELD TYPE IN THE FILE SPECIFIES WHICH TYPE OF RECORD IT IS IN 
THE FILE ITSELF (HERE A CHANGE RECORD). THIS IS NOT THE SAME AS THE 
TYPE DATA FIELD IN FOR INSTANCE THE DEMO DATABASE.
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Click Next.

Now specify which search key shall be applied during the load of this record type, 
and click Next.

You may read more about search keys in “Search key” on page 66.

Choosing data field names for Update/Append records

In a similar way you now have to specify which data fields in the Add records of the 
file, corresponds to which data fields in your database.

Please note, that you do not have to fill out all the fields.

Click Next.

Now specify which search key shall be applied for this record type, and click Next.

Data field names in your DB (*) Data field names in the file

Elevator for scrolling
between five records
at the time

Choose the five
following records

Buttons to transfer
data field names

The contents
of a record
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Choosing data field names for Delete records

Same procedure is repeated for the Delete records of the file.

Transfer the relevant data fields, click Next, specify search key, and click Next once 
again.

Now click Start to import the file.

Click OK when the import is completed.
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IMPORTING MICROSOFT EXCEL DOCUMENTS

RESERVATIONS FOR IMPORTING MICROSOFT EXCEL DOCUMENTS

The program Microsoft Excel is a spreadsheet program, and not a database pro-
gram. However, it is possible to import Microsoft Excel documents in PC|SCHE-
MATIC Database, that opens the Microsoft Excel documents as if they contained 
a database. No 100% guarantee is given that this will take place without errors, but 
it normally works quite well.

However, there are a few things which can give errors during the import, because 
these things are outside the control of PC|SCHEMATIC Database. These things 
are described in the following.

Defines the types of the fields by examining the first 12 rows

When you import data from a Microsoft Excel document the first 12 rows in the 
document are examined to identify the type of the fields in the Microsoft Excel 
document.

When other datatypes are used in succeeding rows in the Microsoft Excel docu-
ment, this can result in a data error.

Understands the first row as field names

When importing the Microsoft Excel document, the program understands the first 
row as field names. If this is not the case in the document, this may result in an 
error.

Create new fields before the import

If the Microsoft Excel document contains field names, which are not defined in your 
table in PC|SCHEMATIC Database, you must create these fields before importing 
the Microsoft Excel document. This is because you can not create new field names 
in your table during the import.

THIS CHAPTER DESCRIBES

— RESERVATIONS FOR IMPORT OF MICROSOFT EXCEL DOCUMENTS ...............(P. 78)
— IMPORTING A MICROSOFT EXCEL DOCUMENT .............................................(P. 79)

MICROSOFT EXCEL DOES NOT HAVE TO BE INSTALLED

IT IS POSSIBLE TO IMPORT MICROSOFT EXCEL DOCUMENTS WITHOUT 
HAVING INSTALLED MICROSOFT EXCEL ON YOUR PC.
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Blank fields can cause errors

It is important to apply the same datatype all the way down for all fields in a column 
in the Microsoft Excel document. If for instance some of the last fields are blank, 
this can cause an error if the first fields contains numbers.

IMPORTING A MICROSOFT EXCEL DOCUMENT

To import a Microsoft Excel document into a table in PC|SCHEMATIC Database, 
do the following:

 1) Open the table you wish to import the Excel document into

 2) If the Microsoft Excel table contains fields that does not exist in your own 
table, you must create these fields before importing the Microsoft Excel table 
— if you wish to import any of these fields

 3) Choose File => Import

 4) You now enter the dialog box Open: Select the file type Microsoft Excel 
files (*.xls), click on the desired Microsoft Excel document, and click on 
Open

 5) Click on the spreadsheet (the “table") you wish to import and click Next

 6) The import then continues as described in “Importing the component vendor 
database into your own database” on page 64

— Please read “Reservations for importing Microsoft Excel documents” on 
page 78.

DO NOT COPY ID FIELDS

IF YOU IMPORT FROM A TABLE WITH AN ID FIELD — OR ANOTHER FIELD-
NAME THAT MATCHES THE FIELD YOU HAVE SET TO BE PRIMARY KEY IN 
YOUR TABLE AND HAS THE DATATYPE AUTOINC — YOU SHALL NOT IMPORT 
THIS FIELD.
THIS FIELD WILL BE FILLED OUT AUTOMATICALLY.
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In this section you can see how to export a table 
in a database from PC|SCHEMATIC Database to 
a file.

This can be done by:

- Creating a comma separated file ...................(p. 83)

- Exporting to Microsoft Excel............................(p. 87)

- Giving a complete database away .................(p. 91)

- Direct loading into another program ..............(p. 94)

Exporting data





Exporting comma separated files

PC|S
EXPORTING COMMA SEPARATED FILES

TWO WAYS OF PASSING ON DATABASE INFORMATION

If you wish to export information from a database, you can do this in two ways:

 1) You can create a so-called comma separated file, which can be loaded into 
many different systems. This is controlled from PC|SCHEMATIC Database.

 2) You can copy the entire database including its table(s) and table menu(s) 
and all other connected files. This is done from Windows or DOS.

This chapter deals with how to create a comma separated file.

— If you wish to create a comma separated file for Microsoft Excel, please read 
“Exporting to Microsoft Excel” on page 87.

— If you wish to copy your entire database, you can see how to do this in “Giving 
away databases” on page 91. Doing this requires further knowledge of Windows or 
DOS.

WHAT IS A COMMA SEPARATED FILE?
As explained in “What is a database?” on page 13, all information in a database is 
arranged in tables, where the various data fields have their own field names.

The internal information about the construction of these tables, are organized in 
different ways depending on the database program. If you need to use the informa-
tion from your PC|SCHEMATIC database in another system, you therefore need to 
be able to save the information in a more generally recognizable way.

Nearly all systems are able to load comma separated files, as it is close to being 
the simplest way possible to save information.

In a comma separated file the contents of all the data fields are listed immediately 
following one another, only separated (!) by a single sign — for instance a comma 
or a semicolon.

THIS CHAPTER DESCRIBES

— THE TWO WAYS OF PASSING ON DATABASE INFORMATION ...........................(P. 83)
— WHAT IS A COMMA SEPARATED FILE?.........................................................(P. 83)
— WHICH PART OF THE DATABASE IS EXPORTED ............................................(P. 84)
— CREATING A COMMA SEPARATED FILE ........................................................(P. 85)

Delimiters (;)Data fields (in quotation marks)
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To make sense of the file, the receiver therefore need to know that the first data 
field in the comma separated file is for instance of the type ITEMNUMBER — and 
so on.

WHICH PART OF THE DATABASE IS EXPORTED

When you export a comma separated file, you have to be aware that you only 
export the part of the database, which is displayed on the screen for the moment.

Thus, when you are applying the data filter, you will only export the filtered part of 
the database — read more about this in “The Data filter” on page 26.

It also has influence whether you see the entire database, or just the contents of a 
single menupoint. Read more about this in “Editing records” on page 28.

If you are familiar with SQL, you can also use SQL queries to select what to export. 
— Read more about this in “SQL queries” on page 35.

You can also export the entire database as a comma separated file. To do this you 
have to neither apply the table menu, the data filter nor SQL queries when you spe-
cify that you wish to export to a file.

ONLY THE CONTENTS OF THE DATA FIELDS ARE PASSED ON

ONLY THE CONTENTS OF THE FIELDS ARE PASSED ON.
INFORMATION ABOUT DATA FIELD NAMES ARE NOT NECESSARILY IN THE 
FILE!
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CREATING A COMMA SEPARATED FILE

To create a comma separated file for export choose File => Export.

This leads you into this dialog box, where you specify the file settings:

Please note, that you in this dialog box specify whether the file should be packed 
as a zip file, by clicking on Create as Zip file. — If you create a zip file, only the zip 
file is created, and not the ordinary text file, whose name is specified in the Export 
file field.

If you enable Export field names as first record, the first record will contain the 
names of the chosen data fields.

Because DOS and Windows does not use the same character sets, you will have 
to specify whether the file is going to be exported to a DOS or a Windows program. 
This is important when working in languages using special characters.

In the lower part of the dialog box, you will see what your file is going to look like.

When you have typed in the name of the file (and path) in the Export File field, you 
click Next.

The file name Create as Zip file DOS/Windows file type

Delimiter

This is how the fileQuotation marks
around data fields is going to appear

Eksport data
field names
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You then enter the following dialog box:

Specifying which data fields to export

Here you specify which data fields you wish to export, by transferring the desired 
data fields to the list in the right-hand side of the dialog box.

The data fields are transferred back and forth by clicking on the buttons, as expla-
ined in “Importing the component vendor database into your own database” on 
page 64.

Specifying the order of the data fields

In the export file the data fields are arranged in the order in which they are listed on 
the list on the right-hand side of the dialog box.

By selecting one or more fields and applying the Up and Down buttons in the right-
hand side of the dialog box, you can change the order in which the data fields are 
going to be placed in the export file.

You select more data fields at a time by clicking on one field in the list, then press 
down [Shift] and click on another data field. Hereby you select the two data fields, 
as well as all intermediate data fields. You can now move the selected data fields 
as described above.

In the window below Preview output file format, you can see how the file is going 
to appear.

Click Next when you have determined which data fields to export, and the file is 
created.

Move data
fields up

These data fields are exportedNot exported

Transfers fields back and forth Displays the file format

and down
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PC|S
EXPORTING TO MICROSOFT EXCEL

This chapter describes how to export a table form PC|SCHEMATIC Database and 
import it in Microsoft Excel.

EXPORT FROM PC|SCHEMATIC Database
In order to export from PC|SCHEMATIC Database you must first open the table 
you wish to export from. If you only wish to export part of the table to Microsoft 
Excel, please read “Which part of the database is exported” on page 84.

Then choose File => Export, and you enter this dialog box:

Here you do the following:

 1) Type in the name of the comma separated file you create

 2) Set File type to Windows

THIS CHAPTER DESCRIBES

— EXPORT FROM PC|SCHEMATIC Database ........................................(P. 87)
— IMPORT IN MICROSOFT EXCEL...................................................................(P. 88)
— PRINTING FROM MICROSOFT EXCEL...........................................................(P. 90)

EXPORT TO MICROSOFT EXCEL ONLY VIA COMMA SEPARATED FILE

YOU CAN NOT EXPORT DIRECTLY TO MICROSOFT EXCEL, BECAUSE MICRO-
SOFT EXCEL IS SPREADSHEET AND NOT A DATABASE PROGRAM.
HOWEVER, YOU CAN EXPORT A COMMA SEPARATED FILE FROM PC|SCHE-
MATIC Database, WHICH YOU THEN IMPORT IN MICROSOFT EXCEL.

1) Type in the name of the file you are creating

2) Set File type to
Windows

3) Select

5) Choose delimiter

4) Select
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 3) Select Export field names as first record, to transfer the field names to 
Microsoft Excel

 4) Select Always use text Qualifier around "data" to make sure that you can 
always import the contents of all the data fields in Microsoft Excel

 5) Select a delimiter — for instance Semicolon — and remember this character 
when you import the file in Microsoft Excel

Then click on Next, and follow the procedure for exporting comma separated files, 
as described in “Specifying which data fields to export” on page 86.

IMPORTING A COMMA SEPARATED FILE IN MICROSOFT EXCEL

Now open Microsoft Excel in order to import the comma separated file, and choose 
File => Open in Microsoft Excel.

Choose the comma separated file, and click on Open.

You now enter the following dialog box:

Select the displayed settings — if  Microsoft Excel does not do this automatically — 
because they match the settings specified during the export from PC|SCHEMATIC 
Database.

Select these
settings
PC|SCHEMATIC Database
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Click on Next, and you enter this dialog box:

Here you specify how the table fields are separated in the comma separated file.

Therefore set Delimiters to Semicolon and Text qualifier to ", so that it matches 
the settings in the comma separated file.

Click on Next, and you enter this dialog box:

Here you specify which format the fields are going to have in Microsoft Excel. In 
order to let these match the fields in PC|SCHEMATIC Database they must all be 
set to the format Text. Do that the following way:

 1) Click on the first column in the displayed part of the table

 2) Drag the elevator to the last column of the table

 3) Press down <Shift> and click on the last column

 4) All of the columns are now selected: Click on Text under Column data for-
mat

Select these settings
so that they match
what you exported
from PC|SCHEMATIC 
Database

1) Click here
2) Drag the elevator to the last column
3) Press down <Shift> and click on the last column 4) Click on Text
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Click on Finish.

The table is now imported in Microsoft Excel:

You can now apply all of the Microsoft Excel functions for adjusting the widths of 
the columns, changing style and type of field names etc.

PRINTING TABLES FROM MICROSOFT EXCEL

Because PC|SCHEMATIC Database has no printing function of its own, you can 
do the following when you wish to print a table:

 1) Import the table in Microsoft Excel as described above

 2) Adjust the appearance of the tables in Microsoft Excel to your liking

 3) Print the table from Microsoft Excel

Field names

The name of
the file
PC|SCHEMATIC Database
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PC|S
GIVING AWAY DATABASES

This chapter describes the options you have for giving complete databases away 
by just copying these from Windows (or DOS) — and not by exporting from 
PC|SCHEMATIC Database.

ON GIVING AWAY DATABASES

The advantage of copying a database as described in the following, is that you can 
pass on the database exactly as it is; including the table menu, specification of 
which fields are index fields, as well as the memorized information from the import/
export dialog boxes.

If you wish to give a copy of your entire database to someone that also use 
PC|SCHEMATIC Database, it is more than just the database you have to pass on.

— Please note, that you can also export all the records in the database, as descri-
bed in “Exporting comma separated files” on page 83.

GIVING AWAY A MICROSOFT ACCESS DATABASE

A Microsoft Access database is placed in a so-called mdb file, i.e. a file with the 
extension .mdb.

Apart from the database file there can exist an attached idb file for each individual 
table in the database. These idb files contains information about which menu is 
connected to the table, as well as the applied import/export settings for the table.

The name of the idb files begins with the name of the database, followed by an 
underscore character and the name of the table. Therefore the idb file for the 
FAFGE table from the database eldemo.mdb will have the name 
eldemo_FAFGE.idb.

THIS CHAPTER DESCRIBES

— ON GIVING AWAY DATABASES.....................................................................(P. 91)
— GIVING AWAY A MICROSOFT ACCESS DATABASE.........................................(P. 91)
— GIVING AWAY A DBASE TABLE/DATABASE....................................................(P. 92)
— REMEMBER SYMBOLS AND CONNECTION NAME FILES ..................................(P. 93)
— UDL FILES AND BDE ALIAS .......................................................................(P. 93)
— EXECUTE THE COPYING .............................................................................(P. 93)

TECHNICAL CHAPTER

THIS CHAPTER IS OF A BIT MORE TECHNICAL CHARACTER THAN SOME OF 
THE OTHERS IN THE MANUAL, AND IT IS NECESSARY THAT YOU KNOW HOW 
TO COPY FILES IN WINDOWS (OR DOS).
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If for instance you wish to copy all relevant files for the database eldemo.mdb, you 
must therefore just copy all files beginning with eldemo in the folder in which the 
database is placed.

GIVING AWAY A DBASE TABLE/DATABASE

A dBase table is placed in a so-called dbf file, which means it has the extension 
.dbf. — Read more about dBase tables/databases in “Databases and the dBase 
format” on page 41.

Apart from the dbf file, two more files can be attached to the database:

 1) A mdx file, containing information about the index fields of the database.

 2) An idb file, containing information about to which table menu the database is 
attached, as well as the memorized settings from the import/export dialog 
boxes.

Both has the same names as the database itself — only the extensions differ.

If the table is called test.dbf, the names of the other files are test.mdx and 
test.idb respectively.

The idb file

It is not strictly necessary to copy the idb file. If you do not pass it on, this has two 
consequences:

 1) The database will have no menu attached. This gives no error message, and 
you can work on the database without difficulties. The new user can subse-
quently attach another table menu.

 2) The new user has to set up the import/export settings from scratch, the first 
time an import is made from a component vendor database.

If you wish to pass on the table menu, you also have to remember to copy the idb 
and the mdx file of the menu file. If you are using the standard FAFGE menu, there 
is no reason to copy the menu, because the new user has the same menu in his 
PC|SCHEMATIC program.
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REMEMBER SYMBOLS AND CONNECTION NAME FILES

When you give away a database, you must remember the following:

1. User-defined symbols
If you have defined some symbols, which you are using in the database, you also 
have to copy these, and place them in the proper symbol libraries.

This goes for electrical as well as mechanical symbols.

2. Pindata files
If you are using pindata files for some of the symbols in your database, these must 
also be included. — Please refer to the PC|SCHEMATIC Automation manual.

UDL FILES AND BDE ALIAS

UDL files can be copied freely and be distributed to the necessary workstations. — 
See “MDAC and UDL files” on page 99.

However, you have to create a new BDE alias on each individual workstation. — 
See “Creating BDE database aliases” on page 103.

COPYING THE FILES

The copying itself is carried out in for instance Windows, where you can place the 
relevant files on a diskette/CD, which you pass on to the new user.
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LOADING DATABASES INTO OTHER PROGRAMS

If you want to document/print out the database, or want to maintain the database 
using another database program, you can load the database directly into another 
program. — See “Exporting to Microsoft Excel” on page 87 if you wish to import 
tables in Microsoft Excel.

Because the files in PC|SCHEMATIC Database are saved in standard Microsoft 
Access or dBase format, this requires that the other program can open Microsoft 
Access or dBase files.

As a precaution, please make a copy of the database before you try whether using 
the database in another program has any side effects. Read more about this in 
“Maintaining databases” on page 37.

— Please note, that you can also transfer the database to another program, by 
exporting it as a comma separated file. Read more about this in “Exporting comma 
separated files” on page 83.

APPLY THE ACCESS FORMAT WITH OTHER MICROSOFT PRODUCT

IF YOU WISH TO USE THE DATABASE IN CONJUNCTION WITH OTHER MICRO-
SOFT PROGRAMS, IT IS RECOMMENDED TO USE THE MICROSOFT ACCESS 
FORMAT, BECAUSE THIS FORMAT IS SUPPORTED THE BEST BY OTHER 
MICROSOFT PRODUCTS.

DO NOT SAVE IN THE ORIGINAL DATABASE FILE FROM OTHER PROGRAMS

IF YOU WISH TO SAVE THE DATABASE FILE FROM ANOTHER PROGRAM, YOU 
HAVE TO BE CAREFUL NOT TO SAVE IT IN THE ORIGINAL DATABASE FILE — 
UNLESS THE PROGRAM CAN MAINTAIN THE INDEX FILE (MDX FILE) OF THE 
DATABASE. YOU MAY READ MORE ABOUT THIS FILE TYPE IN “GIVING AWAY A 
DBASE TABLE/DATABASE” ON PAGE 92.
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In this section you can see how to support other 
database formats than Microsoft Access and 
dBase:

- Supporting other database formats ...............(p. 97)

- MDAC and UDL files ..........................................(p. 99)

- Creating a BDE database alias ..................... (p. 103)
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PC|S
SUPPORTING OTHER DATABASE FORMATS

This chapter describes how other database formats than Microsoft Access and 
dBase are supported.

WHAT DOES PC|SCHEMATIC SUPPORT?
PC|SCHEMATIC supports dBase and Microsoft Access databases directly. When 
PC|SCHEMATIC Automation is installed for the first time, the program has an 
attached Microsoft Access database.

Furthermore, PC|SCHEMATIC is open to other database formats supported by 
either BDE, MDAC or ODBC.

Therefore you can also apply other databases, which are created and maintained 
in other database programs. You can for instance use MS-SQL, Oracle and practi-
cally any commonly used database program together with PC|SCHEMATIC.

THIS CHAPTER DESCRIBES

— WHAT DOES PC|SCHEMATIC SUPPORT? .................................................(P. 97)
— HOW TO SUPPORT OTHER DATABASE FORMATS THE BEST...........................(P. 98)

ONLY FOR THE DATABASE ADMINISTRATOR OF THE COMPANY

TO HANDLE SUPPORT OF OTHER DATABASE FORMATS IN PC|SCHEMATIC 
Database REQUIRES DETAILED KNOWLEDGE ABOUT THE DATABASE FOR-
MATS IN QUESTION.
HANDLING THIS IS A TASK FOR THE DATABASE ADMINISTRATOR OF THE 
COMPANY.

INSTALL MDAC TO WORK IN THE MICROSOFT ACCESS FORMAT

MDAC MUST BE INSTALLED IF YOU WANT TO WORK DIRECTLY IN THE 
MICROSOFT ACCESS DATABASE FORMAT. — SEE HOW TO INSTALL MDAC 
IN “INSTALLING MICROSOFT DATA ACCESS COMPONENTS” ON PAGE 102.

INSTALL BDE TO WORK IN THE DBASE FORMAT

BDE MUST BE INSTALLED ON YOUR PC IF YOU WANT PC|SCHEMATIC 
TO SUPPORT THE DBASE DATABASE FORMAT DIRECTLY. MDAC IS NOT 
NECESSARY IF YOU ONLY WISH NO APPLY DBASE AND BDE ALIASES. — 
SEE HOW TO INSTALL BDE IN “INSTALLING BORLAND DATABASE ENGINE” 
ON PAGE 107.
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HOW TO SUPPORT OTHER DATABASE FORMATS THE BEST

To support another database format the best, the options should be examined in 
the following order of priority:

 1) Can MDAC be used: does an OLE DB provider exist for the database for-
mat? — See “MDAC and UDL files” on page 99

 2) If not: Is there a native driver in BDE that can be used? (If BDE is installed). 
— See “Creating BDE database aliases” on page 103

 3) If not: Is there an ODBC driver in MDAC?

 4) If not: Is there an ODBC driver in BDE?

— If you have any difficulties, please contact your local dealer.

THE CLIENT SOFTWARE MUST BE INSTALLED

IN ORDER TO COMMUNICATE WITH ANOTHER DATABASE FORMAT, THE CLI-
ENT SOFTWARE FOR THIS OTHER DATABASE MUST BE INSTALLED.
THIS IS NOT NECESSARY FOR MICROSOFT ACCESS, DBASE AND MS-SQL.
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PC|S
MDAC AND UDL FILES

This chapter gives a brief introduction to creating UDL files, which makes it possi-
ble to work with other database formats than Microsoft Access and dBase in 
PC|SCHEMATIC.

— It is also possible to work with other database formats via Borland Database 
Engine. Read more about this in “Creating BDE database aliases” on page 103.

WHAT IS MDAC?
MDAC is a database engine, which makes it possible to work with different data-
base formats in PC|SCHEMATIC. When you wish to use MDAC, you have to create 
an UDL file, as described in “What are UDL files?” on page 100 and “Creating an 
UDL file” on page 100.

— If MDAC is not installed on your PC, please refer to “Installing Microsoft Data 
Access Components” on page 102.

THIS CHAPTER DESCRIBES

— WHAT IS MDAC?......................................................................................(P. 99)
— WHAT ARE UDL FILES?...........................................................................(P. 100)
— CREATING AN UDL FILE ..........................................................................(P. 100)
— USING ANOTHER DATABASE FORMAT VIA AN UDL FILE ..............................(P. 101)
— INSTALLING MDAC..................................................................................(P. 102)

GET MORE INFORMATION ABOUT MDAC ETC.
MDAC IS SHORT FOR MICROSOFT DATA ACCESS COMPONENTS.
YOU CAN GET MORE INFORMATION ON MDAC ON MICROSOFTS HOMEPAGE 
AT WWW.MICROSOFT.COM/DATA/PRODINFO.HTM.
THERE YOU CAN ALSO READ ABOUT ADO, ODBC AND MUCH MORE.
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WHAT ARE UDL FILES?
When MDAC is installed on your PC — see “What is MDAC?” on page 99 — you 
have the option of creating the so-called UDL files, which enables you to work in 
other database formats than Microsoft Access and dBase from PC|SCHEMATIC.

The UDL file contains information to MDAC about how the connection to the data-
base format in question is handled.

CREATING AN UDL FILE

To create an UDL file, first choose File => New, and you enter the following dialog 
box:

Choose Microsoft Data Link (udl file) and click Next. You then enter this dialog 
box:

Here you choose the relevant provider. If no OLE DB provider exists for the data-
base format, please refer to “How to support other database formats the best” on 
page 98.

WHAT DOES UDL STAND FOR?
UDL IS SHORT FOR UNIVERSAL DATA LINK (A MICROSOFT FORMAT). UDL 
FILES CAN BE CREATED FROM THE PC|SCHEMATIC Database PROGRAM, 
AS DESCRIBED IN “CREATING AN UDL FILE” ON PAGE 100.

Choose the relevant
provider

Click Next
PC|SCHEMATIC Database
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— Please note that the creation of UDL files is handled in Microsoft dialog boxes. 
The contents and language in these dialog boxes therefore depends on the instal-
lations on the individual PC’s.

Click Next when you have selected a provider:

On the Connection tab you enter the necessary information. If you need to specify 
other information on the other tabs, do this also.

Click OK. You then enter the dialog box Save, where you assign a name to the 
UDL file and click on Save.

Editing the properties of an UDL file

If you later need to change the properties of a created UDL file, just choose File => 
UDL properties. You then get the option to choose which UDL file to edit.

USING ANOTHER DATABASE FORMAT VIA AN UDL FILE

To use another database format via an UDL file, just choose File => Open:

Now choose the file type Microsoft Data Link (*.udl), click on the relevant UDL 
file, and click on Open.

UDL FILES CAN BE COPIED TO OTHER WORKSTATIONS

UDL FILES CAN BE COPIED TO OTHER WORKSTATIONS — AS OPPOSED TO 
BDE FILES, WHICH MUST BE CONFIGURATED FOR EACH PC INDIVIDUALLY.

Click here to apply your
ordinary Windows password
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You then enter the ordinary Select table dialog box, where you open the table you 
wish to work with.

INSTALLING MICROSOFT DATA ACCESS COMPONENTS

If you have installed Windows 2000/ME (or later), Microsoft Office 2000 (or later) or 
Internet Explorer 5.0 (or later), Microsoft Data Access components (MDAC) is 
probably already installed on your PC.

If MDAC is not installed on your PC, you get the option to do so during the installa-
tion of PC|SCHEMATIC Automation.

If MDAC is not installed on your PC, do the following:

 1) Insert the PC|SCHEMATIC Automation CD, and wait a few seconds

 2) The Installation menu is displayed: Choose Support programs and drivers

 3) Choose Install Microsoft Data Access Components

 4) MDAC is being installed

 5) Restart your PC

MDAC is now installed on your PC.

— If you have any difficulties, please contact your local dealer.
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CREATING BDE DATABASE ALIASES

WHAT IS A BDE DATABASE ALIAS?
A BDE alias can be used when you wish to work in a database created in other 
database programs than Microsoft Access or dBase. However, this requires detai-
led knowledge about the settings of this other database program.

The use of another database can take place via a so-called BDE database alias, 
which makes it possible to collect data from other database systems.

If no appropriate BDE alias is created, you have to create one yourself.

CREATING A BDE ALIAS

To create a BDE alias, you must first start the program BDE Administrator.

This is done by choosing File => Open Database Alias, and then click on BDE 
Administrator.

— If the program is not installed on your PC, please read “Installing Borland Data-
base Engine” on page 107.

THIS CHAPTER DESCRIBES

— WHAT IS A BDE DATABASE ALIAS? .......................................................... (P. 103)
— CREATING A BDE ALIAS .......................................................................... (P. 103)
— OPENING A TABLE VIA A BDE DATABASE ALIAS......................................... (P. 105)
— INSTALLING BORLAND DATABASE ENGINE ................................................ (P. 107)

PREFER MDAC IF POSSIBLE

IN MANY CASES IT IS BETTER TO USE MDAC RATHER THAN BDE FOR 
WORKING IN OTHER DATABASE FORMATS.
— READ “HOW TO SUPPORT OTHER DATABASE FORMATS THE BEST” ON 
PAGE 98 TO SEE WHAT IS MOST APPROPRIATE IN YOUR SITUATION.
CHEMATIC Database

Page 103



P

Creating BDE database aliases
When the program is started, click on the Databases tab:

Here you can see which database aliases have been created.

To create a new database alias, you must choose Object => New.

You then enter this dialog box:

Here you choose a driver that matches the database program you wish to use. 
Please note that native drivers are written in upper-case letters on the displayed 
list.

In front of each alias a small symbol is 
placed, which displays whether the 
alias is created with a native driver or 
with an ODBC driver.

CHOOSE A NATIVE DRIVER IF POSSIBLE

IF THERE EXISTS A NATIVE DRIVER FOR THE DATABASE PROGRAM YOU WISH 
TO APPLY, YOU SHOULD SELECT THIS NATIVE DRIVER. THIS IS BECAUSE IT 
WORKS FASTER THAN A CORRESPONDING ODBC INTERFACE.

Native driver ODBC driver
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Click OK.

Hereby a new database alias is created.

To change the name you must double-click on the new alias in the left-hand side of 
the screen, change the name, and press <Enter>. This name will be displayed on 
the alias list in the PC|SCHEMATIC Database program.

Changing the driver settings

When you have chosen an alias in the left-hand side of the screen, you get the 
option of correcting the various settings for the chosen driver.

When you double-click on an alias, you are informed whether its settings can be 
applied or not.

To use the alias, click on it and choose Object => Apply.

Now close the BDE Administrator program by choosing Object => Exit.

OPENING A DATABASE VIA A BDE DATABASE ALIAS

To open a database via a BDE database alias, choose File => Open Database 
Alias, and you enter this dialog box:

DETAILED KNOWLEDGE ABOUT THE DATABASE SYSTEM REQUIRED

TO MAKE THESE CHANGES REQUIRES DETAILED KNOWLEDGE ABOUT THE 
CHOSEN DATABASE SYSTEM.
PLEASE CONTACT YOUR LOCAL HOT-LINE IF YOU HAVE ANY DIFFICULTIES.
CHEMATIC Database

Page 105



P

Creating BDE database aliases
The options in this dialog box depends on which database aliases have been 
created on your PC.

Choose the alias you wish to use, and choose Next:

Now choose the desired table, and click Next.

The table in the database have now been opened via the chosen BDE alias.

BDE DATABASE ALIASES CAN NOT BE COPIED

BDE DATABASE ALIASES MUST BE CREATED ON EACH INDIVIDUAL PC USING 
THE ALIASES.
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INSTALLING BORLAND DATABASE ENGINE

If Borland Database Engine is not installed on your PC, do the following:

 1) Insert the PC|SCHEMATIC Automation CD, and wait a few seconds

 2) The Installation menu is displayed: Choose Support programs and drivers

 3) Choose Install Borland Database Engine

 4) Follow the installation procedure until Borland Database Engine is installed

 5) Restart your PC

Borland Database Engine is now installed on your PC.

— If you have any difficulties, please contact your local dealer.
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