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PREFACE

Automation is a CAD-program for documenting PLC, wiring and power control cir-
cuit diagrams, and can furthermore be used for any kind of electrical installations.

The program is developed by the Danish software house PCSCHEMATIC A/S.

In the same family of CAD programs you will find:

- PCSCHEMATIC Panelrouter for automatic routing of connections in mechani-
cal layouts and for precise calculation of wire lengths. This is an independent 
software, which can run as an integrated part of the Automation software.

- PCSCHEMATIC Cablemanager for cable management and cable routing.

- PCSCHEMATIC Loop for automatic generation of loop diagrams based on 
information from a database or for instance from Excel

PCSCHEMATIC A/S also develop software for interfaces, as well as user-defined 
modules and applications, for the PCSCHEMATIC programs.

Furthermore you can use Automation as a general CAD drawing tool. The pro-
gram uses PCSCHEMATIC’s own file formats, but supports the CAD file formats 
DWG and DXF.

For version 18: New symbol libraries

All of the 60617 symbols were updated in version 18, so that text positions and 
sizes follow the IEC 60617 and IEC/ISO 81714-2 (Design of graphical symbols) 
standards, and the new S-no has been added in the descriptions. This implicates 
the symbols in the folders EN60617, DB60617, IECINST and ALARM.

All of these new versions of the symbols are placed in the folder 60617_2015.

If you choose to update from a version older than version 18, the folders EN60617, 
DB60617, IECINST and ALARM remains with unchanged contents.

If you instead choose to make a new installation, the folders EN60617, DB60617, 
IECINST and ALARM are not created.

Get an overview over the symbol folders in “Symbol folders” on page 247.

For version 12 and later versions: Unicode

In Automation version 12 unicode was introduced. This has the consequence, 
that projects created in version 11 and previous versions, now must be converted 
to unicode in order to be opened correctly. Read more about this in “Unicode” on 
page 10.

Designing your own functions in Automation

You can now create your own functions in Automation by using the build-in inter-
face for COM/OLE automation. — Read more about this in “Scripts” on page 851.

Symbols and databases

All symbols in the program are created by PCSCHEMATIC A/S, with license from 
Danish Standard / IEC. Where no overall standard exists, the symbols have been 
mation
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created in cooperation with either trade organisations, component vendors or 
Automation users.

Automation includes a database program, for which many vendors have created 
special databases. These can be loaded directly into the program. The extra 
advantage of these PCSCHEMATIC databases, are that they, beyond the common 
database information — such as EAN number, description and prices —, contain 
electrical as well as mechanical symbols for the components. You also have the 
option to create your own component databases.

When buying the program, you will get access to component databases from sev-
eral component vendors. These databases are created in Access format.

Furthermore, Automation can use databases, which are supported by ODBC, 
MDAC (Microsoft Data Access Components). In praxis this means that the pro-
gram supports practically any database format for Windows — for instance Oracle 
and Microsoft SQL Server.

Reducing Repetitive Strain Injuries

Along with the program comes the specially designed Mouse Chasing System for 
learning the program short-cut keys while working.

Support and Update

Support and updates are available, but the terms can differ from country to country. 
Please contact your local PCSCHEMATIC agent for detailed information.

PCSCHEMATIC A/S participates in a continuous dialog with the users of the pro-
gram. The input from this dialog is the basis for the future development of the pro-
gram.

OTHER MANUALS

For Automation the following additional manuals exist:

- The Quick start manual: Gives you a quick introduction to Automation.

- The Project Generator manual: Describes how to generate projects automati-
cally in Automation.

- The Component Wizard manual: Describes how to easily create components 
with attached symbols for the component database in Automation.

- The Tools manual: Describes how you can document symbols in projects or 
libraries automatically, how to set up parameters for DWG/DXF import/export, 
how to use the PCSCHEMATIC Translator program, for translating project 
texts, as well as how you automatically create graphical terminal plans, graph-
ical cable plans and graphical connection plans.

- The Database manual: Describes how to use the PCSCHEMATIC Database 
program for creating and maintaining your database for Automation.

- Guide for using Automation Service and the Mounting Assistant: 
Describes how to use PCSCHEMATIC Automation Service as well as how to 
use the Mounting Assistant, which is included in all variants of Automation.

- The Panelrouter manual: Describes how to use the Panelrouter in 
Automation.
Automation
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- The Administrator control manual: Describes how to perform administrator 
control on Automation. Please contact PCSCHEMATIC A/S for further infor-
mation.

Tutorials

Various tutorial manuals also exist, which guides you through how to use the pro-
gram for various types of projects:

- Motor control tutorial: Guides you through creating a motor control project in 
Automation.

- PLC project tutorial: Guides you through creating a motor control project in 
Automation and introduces various advanced options for working with plcs.

- House installation tutorial: Guides you through creating a house installation 
project in Automation.

- Panel Builder tutorial: Guides you through creating a Panel Builder project in 
Automation. The Panel Builder supports you in automatically documenting 
small switchboards and panels according to requirements in EN61439-1 and 3 
concerning power dissipation calculation and more.

- Component Wizard tutorial: Shows you how to easily create components with 
attached symbols in the database.

- Clip Project Marking integration tutorial: Guides you through how you can 
easily print labels in Clip Project Marking directly from Automation.

All of these manuals can be downloaded at www.pcschematic.com/manuals, 
where you can also see the news in the latest version of Automation.

VIDEOS AND ARTICLES AT WWW.PCSCHEMATIC.COM

At www.youtube.com/pcschematic and at www.pcschematic.com/videos you can 
watch videos showing many of the available options in Automation.

At www.pcschematic.com/articles you can also a read survey article about the pro-
gram, as well as articles about the basic drawing functions, PLC functions. lists 
and about working with projects.
mation
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UNICODE

Since version 12, Automation has been able to handle multiple regional character 
sets simultaneously. This is because the program handles unicode.

WHAT IS UNICODE?

Up until now language settings of computers and programs have been more or 
less permanent. In Denmark, Germany, UK and other countries, our computers 
used a character set – WESTERN EUROPE/LATIN 1. This character set contains 
the letters and characters in western European alphabets, including Æ, Ø, Å, Ä, Ö 
and Ü. Other language areas have their own character sets, as for instance China, 
Japan and Russia.

Previously, it was only possible to work with one regional character set at a time. 
You could “cheat” the program to work with a different character set (like Russian) 
by changing some program settings — in Automation in Settings => System/
License. This way it was possible — on for instance a English Windows installation 
— to work with a project, which was originally created using another character set.

Unicode, on the contrary, contains (almost) all existing characters — more than 
100.000, each having its own meaning. "UNI CODE" = "one code".

When you have a program that supports Unicode, this program can show letters/
characters from any alphabet in the same file. In Automation this means that 
when you have a project file, that will be used in Russia, this file can contain a Dan-
ish/English text and Russian characters.

This is because each character has its own unique code. However, the used font 
must contain all the needed characters. And this is not the case with all fonts. 

The PCSCHEMATIC font contains characters for Eastern and Western Europe and 
Russia.

SYSTEM SETTINGS FOR CONVERSION INTO UNICODE

The basic setting for conversion to Unicode-format, is made under Settings => 
System/License on the System tab.

What happens during the conversion, is that all old files must be translated to the 
new format — that is converted from one character set to another. The program will 
guess the character set, as you can see in “Opening a project created before ver-
sion 12” on page 11.

THE PCSCHEMATIC FONT AND UNICODE

The PCSHCEMATIC font is not a Windows font and therefore it has limited Win-
dows functionality. However, it conforms to the standards requirements concerning 
texts in technical documentation, and the font will be the standard font in most pro-
jects.

The PCSHCEMATIC font will also be converted to Unicode-format in all existing 
projects, that you continue to work with. New projects are saved in this format auto-
matically.
Automation
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OPENING A PROJECT CREATED BEFORE VERSION 12

When you open a project created before version 12, the following dialog box 
appears:

You can choose not to display the dialog box again by selecting Do NOT show this 
message again at the bottom of the dialog box.

If you click the Char. set button, you will enter a dialog box, where you can see the 
recommended character set for the actual project. If this is not the correct charac-
ter set, click Select character set where you can see all supported character sets.

When you are pleased with the selectred character set, and do not wish to enter 
the dialog box again the next time you open a project created before version 12, 
select Do NOT show this message again.

The following character sets are supported:

• Central Europe

• Cyrillic

• Western Europe/Latin 1

• Greek

• Turkish

• Hebrew

• Arabic

• Baltic

IMPORTANT TO CHOOSE THE CORRECT CHARACTER SET

IT IS IMPORTANT, THAT YOU CHOOSE THE RIGHT CHARACTER SET FOR OLD 

FILES, AS YOU MIGHT RISK SAVING THE PROJECT IN A FORMAT THAT MAKES 

SHOWING OR RECOVERY OF THE ORIGINAL CHARACTERS IMPOSSIBLE.

THE PROGRAM CREATES BACKUPS OF OLD FILES IN THE OLD FORMAT, IF 

YOU CHOOSE TO. THOSE BACKUPS WILL BE SAVED AS FILE-
NAME(ANSI).~PR/~SY. THIS MEANS, THAT IF YOU HAVE CHOSEN THE 

WRONG CODE PAGE FOR CONVERSION, YOU CAN GO BACK TO THE ORIGINAL 

FORMAT AND TRY AGAIN.

— IF YOU HAVEN’T CREATED PROJECTS INCLUDING ”FOREIGN” ALPHABETS/
CHARACTERS, YOU WILL NOT EXPERIENCE ANY PROBLEMS, AND IT WILL BE 

SAFE FOR YOU TO TICK OFF THE DIALOG WHEN YOU SEE IT THE FIRST TIME.
mation
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• Vietnam

• Thai

• Japanese Shift-JIS

• Simplified Chinese GBK

• Korean

• Traditional Chinese Big5

TEXTS IN SYMBOLS ARE CONVERTED AUTOMATICALLY

Conversion of old symbols function as described above, but you will not enter the 
dialog when you load a new symbol. However, it is important that your settings are 
correct, and we recommend that you keep the setting for automatic backups in old 
version.

MODULE FOR CONVERTING PROJECTS TO UNICODE

You can also install a module to convert projects from versions prior to version 12:

 1) Choose File => Modules

 2) In the dialog box Modules: Click on Convert files from ver. 11 or older and 
click Install

 3) In the dialog box Modules: Click Close

 4) Close all active Automation projects

 5) Choose Tools => Convert files from ver. 11 or older:

 6) Select a folder and click Convert to convert all projects in the folder.
Automation
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QUICK SURVEY OF THE MANUAL

To make the program as easy accessible as possible, the user interface for 
Automation has been developed quite close to the Windows version of the Micro-
soft® Office-package.

If you are not familiar with Windows, you may read the brief introduction in the 
chapter “Windows” on page 23.

The manual itself is divided in sections. Below you can get a survey of the contents 
of these sections.

THE CONTENTS OF PART 1

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES THE CONTENTS OF THIS MANUAL.

SECTION DESCRIPTION SUBJECTS

"Getting star-
ted"
p. 21

SCREEN FUNCTIONS 

IN THE PROGRAM 

E.T.C.

INTRODUCTION TO WINDOWS

THE ONLINE MANUAL

THE PROGRAM WORK AREA

BASIC IMAGE FUNCTIONS

"Basic Dra-
wing facili-
ties"
p. 51

DETAILED DESCRIP-

TION OF THE BASIC 

DRAWING FACILITIES.

DRAWING DIAGRAMS / WORKING WITH LINES, 
SYMBOLS, TEXTS AND AREAS

TRANSFERRING PROPERTIES BETWEEN OBJECTS

ALIGNING AND TRIMMING FUNCTIONS

AUTOMATIC LINE DRAWING / ROUTER

MOUNTING CORRECT DRAWING

TEXT LINKS

THE COMPONENT MENU

OTHER FUNCTIONS ON COMPONENT LEVEL

OBJECT GROUPS

SUB DRAWINGS / DRAG’N DRAW

RENAME SYMBOLS

"Survey and 
Reference 
Designati-
ons"
p. 333

DESCRIPTION OF 

HOW TO FIND PAGES 

AND OBJECTS IN PRO-

JECTS, PERFORM 

DESIGN CHECK AND 

PRINT.

USING THE BUILD-IN EXPLORER

USING THE OBJECT LISTER

FIND AND REPLACE

DESIGN CHECK

PRINTING

USING THE WINDOWS EXPLORER AS PROJECT/
SYMBOL MENU

"Reference 
designati-
ons"
p. 371

DESCRIPTION OF 

HOW TO USE REFER-

ENCE DESIGNATIONS 

IN THE PROGRAM.

- INTRODUCTION TO REFERENCE DESIGNATIONS

- REFERENCE DESIGNATION SETTINGS

- HOW TO WORK WITH REFERENCE DESIGNATIONS
mation
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THE CONTENTS OF PART 2

"References"
p. 419

DESCRIPTION OF 

HOW TO USE REFER-

ENCES IN THE PRO-

GRAM.

AUTOMATICALLY UPDATED REFERENCES

CONTACT MIRRORS

REFERENCE CROSSES

CURRENT PATH NUMBERS / REFERENCE SYSTEM

"Wire num-
bers"
p. 441

DESCRIPTION OF 

HOW TO USE WIRE 

NUMBERS.

AUTOMATIC WIRE NUMBERING

MANUAL PLACING OF WIRE NUMBERS

WIRENUMBER FILES

"Single line 
diagrams"
p. 459

DESCRIPTION OF 

HOW TO WORK WITH 

SINGLE LINE DIA-

GRAMS.

ABOUT SINGLE LINE DIAGRAMS

AUTOMATIC GENERATION OF SINGLE LINE DIA-

GRAMS

"PLC functi-
ons"
p. 463

DESCRIPTION OF 

PLC FUNCTIONS.
SURVEY OF PLC FUNCTIONS

WORKING WITH PLCS

SIGNAL BUSSES

READING PLC I/O FILES

PLC I/O ADDRESSING VIA MICROSOFT EXCEL

SECTION DESCRIPTION SUBJECTS

"Electrical 
installation 
drawing"
p. 519

DESCRIPTION OF 

DRAWING FUNCTIONS 

WITH PARTICULAR 

INTEREST FOR ELEC-

TRICAL INSTALLA-

TION DRAWING.

GROUND PLAN DRAWING

WORKING IN DIFFERENT LAYERS AND ELEVATIONS

SCALING

TIPS FOR ELECTRICAL INSTALLATION DRAWING

"Working 
with Proje-
cts"
p. 537

THINGS YOU NEED TO 

KNOW WHEN YOU 

ARE CREATING PRO-

JECTS.

ON PROJECTS

WORKING WITH PAGES, PAGE TYPES AND PAGE 

FUNCTIONS

PROJECT CHAPTERS

PAGE AND PROJECT TEMPLATES

TEMPLATE PROJECTS

COPYING BETWEEN PROJECTS

WORKING WITH MORE THAT ONE PROJECT OPEN

STARTING ANOTHER PROJECT BY CLICKING

"Lists"
p. 583

HOW TO INSERT 

DRAWING HEADERS/
LISTS.

INSERTING DRAWING HEADER/LIST

LIST SETTINGS

COMPONENT GROUPING

UNIT DRAWINGS

"Databases"
p. 627

HOW TO USE THE 

DATABASE IN YOUR 

PROJECTS.

USING AND CHOOSING A DATABASE

GRAPHICAL CREATION OF COMPONENTS IN THE 

DATABASE

DATABASE SETTINGS

PROGRAMMABLE BARCODE SCANNERS

SECTION DESCRIPTION SUBJECTS
Automation
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"Mechanical 
pages and 
symbols"
p. 689

GET AN OVERVIEW 

OVER HOW TO WORK 

WITH MECHANICAL 

SYMBOLS

HOW TO WORK WITH MECHANICAL SYMBOLS

ARRANGEMENT DRAWINGS

PLACE MECHANICAL SYMBOLS, BASED ON THE 

PLACED ELECTRICAL SYMBOLS, VIA THE DATA-

BASE

PLACE ELECTRICAL SYMBOLS, BASED ON THE 

PLACED MECHANICAL SYMBOLS, VIA THE DATA-

BASE

"Export / 
Import"
p. 715

DESCRIPTION OF 

HOW TO IMPORT/
EXPORT FILES.

LIST FILES

DWG AND DXF FILES

INTEGRATION WITH MICROSOFT EXCEL

INSERTING OBJECTS FROM OTHER PROGRAMS / 
OLE OBJECTS

PLACING SYMBOLS VIA LISTS

PCSCHEMATIC VIEWER

"Create 
Symbols, 
Lists and 
Projects"
p. 749

HOW TO ADAPT SYM-

BOLS, LISTS AND 

DATAFIELDS TO MEET 

YOUR SPECIFIC 

NEEDS, AND HOW TO 

CREATE PROJECTS 

THAT CAN BE USED 

AS TEMPLATES FOR 

OTHER PROJECTS.

CREATING STANDARD PROJECTS AND TEMPLATES

SPECIFYING WHICH DATAFIELDS CAN BE USED IN 

PROJECTS

DESIGNING SYMBOLS

DESIGNING SIGNAL SYMBOLS

DESIGNING DRAWING HEADERS/LISTS

DESIGNING UNIT DRAWINGS

"Updating, 
Modules and 
Licenses"
p. 845

INFORMATION ABOUT 

NETWORK SECURITY 

CHECKS, HOW TO 

INSTALL AND UPDATE 

ADDITIONAL PRO-

GRAM MODULES, AND 

HOW TO ADAPT THE 

SYSTEM TO YOUR 

NEEDS.

PASSWORDS ON PROJECTS

LOCKING PROJECT FILES

INSTALLING MODULES

REVISION MANAGEMENT

ADAPTING THE SYSTEM

SHORT-CUT KEYS

SYSTEM COLORS

REGISTERING PCSCHEMATIC FILE TYPES

INDEXING

DDE AND STARTING FUNCTIONS

ZIPPING / COMPRESSED SAVING

THE MOUSE CHASING SYSTEM

"Appen-
dices"
p. 893

FOR REFERENCE, 
AND FOR ADJUSTING 

THE PROGRAM SET-

TINGS.

PROGRAM SETTINGS

DICTIONARY

DATAFIELDS

FIELDS IN THE INCLUDED DATABASE

VARIABLES

INDEX

SECTION DESCRIPTION SUBJECTS
mation
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HOW TO GET STARTED

Start by installing the program, as described in the independent Information & 
Installation manual.

If you are familiar with Windows, you can then read the independent mini manual 
"Motor control - Tutorial" — or for instance "Electrical installation - Tutorial". Here 
you get a quick introduction on how to create a project, and get ready to carry on 
with the detailed description of the program in “Basic Drawing facilities” on 
page 51. You can also read the "Quick start" manual, which gives you a quick intro-
duction to the program.

If you do not have these manuals, you can download them at www.pcschema-
tic.com/manuals.

Later on, you may return to the remaining part of “Getting started” on page 21, and 
get a better idea of the construction of the program.

You should also read “On projects” on page 539, which gives you a summary of the 
possibilities when you are working with projects in Automation.

— Use the chapter headings as well as the index, to receive information on the 
desired subjects as quickly as possible. The first chapter in some of the sections 
also contains a general overview of the section.

You can also use the program on-line manual, as described in “The On-line 
manual” on page 39.

Overall planning

In the section “Create Symbols, Lists and Projects” on page 749, you can get infor-
mation on how to prepare your projects as easy as possible. In this section you 
design your own symbols and lists, and specify which datafields can be used in the 
project.

Appendix

In the last section of the manual, you can read about the various program settings, 
and how to adjust these to your needs. Here you will also find a dictionary, explain-
ing commonly used terms in Automation, in Windows or in the manual itself. 
Finally, you can see the special characters, that can be applied in your project dia-
grams.

Finding your way around the projects

To find your way around the projects, it is recommended to read “Getting started” 
on page 21, as well as the chapter “Find and Replace” on page 351.

WATCH IT ON VIDEO

YOU CAN WATCH VIDEOS ABOUT THE PROGRAM HERE:

1) AT THE PCSCHEMATIC WEBSITE: — http://www.pcschematic.com/
videos

2) AT THE INTERNATIONAL PCSCHEMATIC YOUTUBE CHANNEL: — http://
www.youtube.com/user/PCSCHEMATIC
Automation
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PCSCHEMATIC website

For direct access to the PCSCHEMATIC website choose Help => Http://
www.pcschematic.com. Here you can for instance get information about the lat-
est updates in the program.

Here you can also sign up for an e-mail service, which informs you when there are 
news on the Automation support page.

You can also download updates for your version of Automation at the website.

TYPOGRAPHY IN THE MANUAL

The following typographical elements are applied in the manual:

Furthermore, when you must click on one of the program buttons, this button will 
be displayed in the left margin of the text — facing where the button is mentioned.

Buttons mentioned shortly after another, will be displayed following the order in 
which they are mentioned in the text.

TYPOGRAPHY USE

ITALICS TEXTS WRITTEN IN ITALICS ARE TEXTS YOU HAVE TO TYPE IN YOURSELF.

BOLD BOLD TEXTS — NOT INCLUDING HEADINGS — ARE USED FOR PROGRAM 

FUNCTIONS, BUTTONS AND MENUS.

BOLD AND ITALICS ARE APPLIED FOR FIELD NAMES OR OPTIONS YOU CAN CLICK ON IN DIA-

LOG BOXES.

KEYS

<>
<CTRL+G>

ALL SHORT-CUT KEYS ON THE KEYBOARD ARE ENCLOSED IN BRACKETS 

— SUCH AS <DEL> FOR THE DELETE KEY.
IF IT SAYS <CTRL+G> THIS MEANS THAT YOU MUST PRESS DOWN THE 

"CONTROL" KEY AND THEN PRESS DOWN THE "G" KEY TO ACTIVATE THE 

SHORT-CUT.
SINGLE LETTERS IN BRACKETS SUCH AS FOR INSTANCE <Z> SPECIFIES 

THAT THE "Z" KEY IS A SHORT-CUT KEY.

MENUS

=>
FILE => SAVE MEANS THAT YOU MUST CLICK ON THE MENU FILE (IN THE 

MENU BAR ON THE UPPER PART OF THE SCREEN) AND THEN CHOOSE 

THE MENU OPTION SAVE.
mation
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This section describes:

- Working with Windows programs.......................p. 23

- Keyboard short-cuts .............................................p. 29

- The Work area........................................................p. 35

- The On-line Manual ...............................................p. 39

- Applying basic Image functions...........................p. 42

Reading this section will save time using the pro-
gram.

At www.youtube.com/pcschematic you can see product 
videos, which can give you a survey of various func-
tions in the program.

INSTALLATION OF THE PROGRAM

SEE HOW TO INSTALL THE PROGRAM IN OUR SEPARATE 

INSTALLATION MANUAL, WHICH CAN BE DOWNLOADED AT 

www.pcschematic.com/manuals.

Getting started

http://www.pcschematic.com/videos
http://www.pcschematic.com/videos
http://www.pcschematic.com/manuals
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WINDOWS

This chapter describes how to use the basic Windows functions. Please skip this 
chapter if you are an experienced Windows user.

MENUS

When you have opened a project in Automation, the uppermost line of the screen, 
will look like this:

This line is called the Menu bar, and clicking on any 
of the words here will make various menus appear. 
Here you specify which commands you want to exe-
cute in the program.

Choosing menus and commands in Automation fol-
lows the common directions for Windows. Below you 
will see the View menu, as an illustration of how to 
choose a command using the menus. Click on View 
in the menu bar, and the following menu will appear:

— As you can see, the letter V is underlined in the 
word View. This means that you can also choose this 
command by pressing <Alt+v>.

Click on the option you want to choose — for 
instance Screen. You can also choose by using the 
arrow keys on the keyboard, and then press <Enter> 
when you have found the desired function.

Most of the commands have an underlined letter. 
Once the menu have been chosen, you can choose 
the command by pressing down the underlined letter. 
In the menu to the left, Zoom can for instance be 
chosen by pressing down <z>.

If the command has got a short-cut key — which 
means the command can be chosen without activat-
ing the menu at all — the short-cut combination is 

THIS CHAPTER DESCRIBES

— MENUS ......................................................................................................p. 23

— DIALOG BOXES ...........................................................................................p. 24

— SHORT-CUT MENUS AND RIGHT-CLICKING.....................................................p. 25

— SWITCHING BETWEEN OPEN WINDOWS.........................................................p. 25

— USING THE MOUSE......................................................................................p. 25

— DOCKING WINDOWS AND TOOLBARS............................................................p. 26
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displayed to the right of the command. You can for instance choose Redraw by 
pressing down <Ctrl+g>.

If an option is dimmed — written in grey — you are not allowed to execute this 
command for the moment.

Three dots succeeding an option — for instance Select page... — signifies that 
you by clicking there will get more options — for instance in a new menu or a dialog 
box.

DIALOG BOXES

Below you will see a part of a dialog box (Settings => Pointer/Screen), together 
with an explanation of the various elements of the dialog box:

SELECTING ELEMENTS IN LISTS

When elements are listed in a dialog box, these elements can be selected as 
described in “Selecting objects in the Object Lister” on page 344.

— See for instance “Copying, Cutting and Pasting more than one page” on 
page 551.

SORTING DATA IN COLUMNS

When a dialog box contains multiple columns, the contents of the dialog box can 
typically be sorted alphabetically based on the contents of the individual columns, 
as described in “The sorting order of the data in the Object Lister” on page 344.

Round buttons within 
an area signifies mutu-
ally exclusive options. 
In this case it is there-
fore only possible to 
specify that the gird 
(please refer to the dic-
tionary) is turned off, 
dotted or squared.

Click on the down-
arrow, and a drop down 
menu will display which 
options you have got. 
In this case you will 
see a list containing 
the possible units of 
measurement.

Squares signifies func-
tions you can enable or 
disable. When you 
have chosen a func-
tion, a check mark is 
placed within the 
square. In this case 
both Hints and Page 
tabs are selected.

The functions are not 
mutually exclusive, and 
can therefore be cho-
sen at the same time.

Tabs Selected tab
Automation
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OK and Cancel

In most of the dialog boxes there will be an OK and a Cancel button as well. The 
OK button causes you to leave the dialog box, and the settings you have specified 
will be effectuated. Clicking on the Cancel button, causes you to leave the dialog 
box without activating the changes you specified.

Please note that the buttons OK and Cancel is not displayed in the figure above. 
However, they are located in the lower part of the dialog box.

In stead of clicking Cancel you can press <Esc>.

Using the keyboard in dialog boxes

— See “Keyboard short-cuts” on page 29.

SHORT-CUT MENUS AND RIGHT-CLICKING

When you right-click on something in a project, you 

will practically always get a so-called short-cut 
menu. This menu gives you some options, which 
are relevant for what you clicked on.

It will therefore frequently be most efficient to right-
click on an object and see which options you get.

The displayed menu appears by right-clicking on a 
page — the "paper" — in a project.

On new keyboards there also exists a short-cut 
menu key. Pressing this key has the same function 
as right-clicking on an object.

SWITCHING BETWEEN WINDOWS

When you want to change between several active projects (windows), press down 
<Ctrl> while pressing <Tab>. You then switch to another active project. You can 
also choose Window in the menu bar on the upper part of the screen, and then 
click on the open project you want to work on. If you have several project windows 
open simultaneously, you can also just click on the project you wish to work on. — 
Please refer to “Several Projects Simultaneously” on page 568.

When you press down the <Alt> key, and then press <Tab>, you can change to 
other active programs.

THE MOUSE

When you are working with Windows, you are using the mouse a great deal of the 
time. The operations you can perform with the mouse are displayed below:

OPERATION DESCRIPTION

CLICK PRESS DOWN AND RELEASE THE LEFT MOUSE BUTTON ONCE.

DOUBLE-CLICK PRESS DOWN THE LEFT MOUSE BUTTON TWICE. IT IS IMPORTANT 

THAT YOU DO NOT MOVE THE MOUSE WHILE CLICKING.
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The small arrow you control on the screen by moving the mouse, is called the 
mouse pointer. In Windows you can for instance specify the appearance of the 
mouse pointer, how rapidly it moves across the screen, and how fast you have to 
click when you double-click. Please refer to your Windows manual for further 
details.

DOCKING WINDOWS AND TOOLBARS

In many Windows programs you can move the toolbars and dock windows to the 
sides of the screen. In the following you can see how to do this in Automation.

When you work on a PC with two monitors, you can get a larger work area by mov-
ing for instance the Component menu to the secondary monitor.

Moving the Explorer, the Component list or the Symbols for
component window

When you start Automation 
for the first time, the Explorer 
window is docked to the left 
toolbar. This means that it is 
placed at a fixed position just 
next to the left toolbar.

Correspondingly, the Compo-
nents and the Symbols for 
component window can be 
docked inside the Component 
menu on the right-hand side of 
the screen.

If you want to place the 
Explorer window at another 
location, you point at the two 
horizontal lines at the top of the 
Explorer window. (When you 
wish to move the Components 

RIGHT-CLICK PRESS DOWN AND RELEASE THE RIGHT MOUSE BUTTON ONCE.

DRAG AND DROP TO SELECT AN OBJECT POINT AT THE OBJECT WITH THE MOUSE 

CURSOR, AND PRESS THE LEFT MOUSE BUTTON. KEEP THE MOUSE 

BUTTON PRESSED DOWN WHILE MOVING THE MOUSE POINTER 

ACROSS THE SCREEN. YOU SAY THAT YOU DRAG THE MOUSE 

ACROSS THE SCREEN. WHEN YOU RELEASE THE MOUSE BUTTON, 
THE OBJECT IS PLACED WHERE YOU POINT WITH THE MOUSE CUR-

SOR.
YOU CAN MOVE BOTH OBJECTS, PROJECT PAGES AND ELEMENTS 

IN LISTS BY DRAG AND DROP.

— SEE “Moving a placed symbol” on page 194, “Drag-
ging a reference designation to a new position in the 
dialog box Reference designations” on page 385 AND 

“Drag pages between projects” on page 569.

OPERATION DESCRIPTION
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or the Symbols for component window you point at the title bar).

Then press down the mouse button, drag the window to another location on the 
screen, and release the mouse button.

If you just place it on the middle of the screen, it will cover for the details on the pro-
ject page. When it is docked it is not in the way for viewing the page.

The Explorer window can be either a free window, or be docked to the left or to the 
right side of the screen.

The Components and the Symbols for component windows are by default 
placed inside the Component menu in the right-hand side of the screen. However, 
both windows can be dragged out as described above, so that you for instance can 
get a larger area on the screen for your diagrams by placing the Component 
menu on another screen.

Docking a window

When you wish to dock the window, click on its title bar, keep the mouse button 
pressed down, and move the window.

The frame of the window is now displayed as a grey box.

When the mouse pointer — 
and not the edge of the grey 
box — is pointing at the edge 
you wish to dock the window 
to, release the mouse button.

Just before you release the 
button, the window will snap 
to its docked position.

Docking the Survey window or the Symbols for component win-
dow

The Survey window can be docked in either the upper or the lower part of the 
Explorer window. Please note, that it is docked inside the Explorer window. Corre-
spondingly, the Symbols for component window can be docked in the upper part 
of the Components window.

DOCKING THE PICKMENU

The pickmenu can also either be a free window, be docked below the upper tool-
bars, or be docked in either of the sides in the program window.

You can only dock one window along any edge of the program window. This means 
that if you have docked the Explorer window to the left-hand side, you will not be 
allowed to dock the pickmenu to the left-hand side as well.
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Docking the Command Toolbar

The command toolbar can be docked, so that it is placed after the program toolbar 
using drag and drop.

The command toolbar can not be moved/docked.

Program toolbar Command toolbar (for symbols) 
Automation
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KEYBOARD SHORT-CUTS

To reduce the risk for repetitive strain injuries from using the mouse too much, it is 
possible to work with Automation using the keyboard. This chapter describes 
these options.

Furthermore, general Windows principles for working without the mouse can be 
applied.

CHOOSING MENU ITEMS USING THE KEYBOARD

Choosing menu items using the keyboard follows the common Windows stand-
ards, as described in “Menus” on page 23.

— Please also refer to “Short-cut Keys” on page 856, where you will find a survey 
of the default short-cut keys, and you can read about how to define short-cut keys 
for all menu items in the toolbar.

THIS CHAPTER DESCRIBES

— CHOOSING MENU ITEMS USING THE KEYBOARD............................................ p. 29

— CHOOSING BUTTONS/FUNCTIONS USING THE KEYBOARD .............................. p. 30

— NAVIGATION IN THE EXPLORER WINDOW ..................................................... p. 30

— CHOOSING IN DIALOG BOXES WITH THE KEYBOARD ...................................... p. 31

— SELECTION IN AVAILABLE SYMBOLS USING THE KEYBOARD........................... p. 31

— PLACING OBJECTS USING THE KEYBOARD.................................................... p. 32

— CHOOSING OBJECTS USING THE KEYBOARD................................................. p. 32

— CHOOSING MORE THAN ONE OBJECT WITH THE KEYBOARD........................... p. 33

— CHOOSING SYMBOLS WITH THE KEYBOARD.................................................. p. 33

— INCREASE/DECREASE SHORT-CUT USING THE KEYBOARD ............................. p. 33

— SHORT-CUTS FOR ACTIVATING THE PENCIL.................................................. p. 33

CONCURRENT LEARNING OF SHORT-CUT KEYS

IN “Preventing Repetitive Strain Injuries” on page 869, YOU CAN SEE 

HOW YOU CAN LEARN THE SHORT-CUT KEYS FOR THE COMMANDS YOU TYP-

ICALLY CLICK ON WITH THE MOUSE — WHILE WORKING WITH THE PROGRAM.
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CHOOSING BUTTONS/FUNCTIONS USING THE KEYBOARD

You can create short-cut keys for all 
buttons in the program. This is done 
by creating a short-cut key for the 
menu item that the button repre-
sents.

If for instance you wish to create a 
short-cut key for the Page menu 
button, you must create a short-cut 
key for the menu item View => 
Select page.

Please note that the Page menu 
button is displayed in front of the 
menu item, so that you can find the 
function in the menu easily.

There are menu item for all buttons 
in the program.

— See “Short-cut Keys” on 
page 856 to see how to create key-
board short-cuts for all buttons.

Short-cuts displayed as hints

When you let the mouse cursor rest over a button, the 
short-cut key is displayed as a hint in brackets after the but-
ton name.

NAVIGATION IN THE EXPLORER WINDOW USING THE KEYBOARD

In the Explorer window you use the arrow-keys to navigate like this:

<Up-arrow>: Move the cursor upwards in the Explorer window

<Down-arrow>: Move the cursor downwards in the Explorer window

<Right-arrow>: Open folder

<Left-arrow>: Close folder
Automation
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CHOOSING IN DIALOG BOXES USING THE KEYBOARD

When you have opened a dialog box, you can choose the different fields, buttons 
or tabs by pressing down the <Alt> key, and press on the key for the underscored 
character for the option in the menu.

If for instance you wish to choose the tab Ref.design. in the dialog box Compo-
nent data above, press down the <Alt> tab, and press the <d> button — because 
d is the underscored character on the tab.

If you wish to select OK in the dialog box Component data, press <Enter>. If you 
wish to select All, press <Ctrl+Enter>.

Using the tab key

In each dialog box there is predefined order, in which you jump between the differ-
ent options in the dialog box.

When you press the <Tab> key, you jump to the next option in the pre-defined 
order.

When you press down <Shift> and press the <Tab> key, you jump back to the pre-
vious option.

SELECTION IN AVAILABLE SYMBOLS USING THE KEYBOARD

When you are using the Available symbols window for a component, the field 
containing the first symbol in Available symbols is coloured blue. This indicates 

Press the <Alt> key and press <d>

to select the tab Ref.design.
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that you will get this symbol in the cross hairs, if you press <Enter>. You can use 
the right and the left arrow key to select one of the other symbols:

To use the keyboard to select symbols in the stationary pickmenu at the top of the 
screen, you must select View => Activate Pickmenu (Short-cut: 
<Shift+Ctrl+F12>).

You can then select the symbols by pressing the key-arrows, and change between 
the different pickmenus by pressing the <PageUp> and <PageDown> keys. When 
you press <Enter> you get the selected symbol in the cross hairs.

If a symbol has different states, you can select the symbol states by pressing the 
arrow-down and arrow-up keys.

PLACING OBJECTS USING THE KEYBOARD

When you have an object in the cross hairs, place it like this:

 1) Use the arrow-keys, which moves the objects with snap (see “Snap” on 
page 47) in the direction of the chosen arrow.

 2) Press <Enter> to place the object. — If you hereby enter a dialog box, please 
refer to “Choosing in dialog boxes using the keyboard” on page 31.

 3) Press <Esc> to remove the object from the cross hairs.

SELECTING OBJECTS USING THE KEYBOARD

To move the cross hairs to select an object, do this:

 1) Press down the <Alt> key, and use the arrow-keys: The cross hairs now jump 
to the next object on the page, in the direction specified by the arrow key.

 2) Press <Enter>, and the object is selected.

 3) Press <Enter> once more, and you enter the component data dialog box / 
the text dialog box.

Left-arrow key Right-arrow key

Left-arrow key Right-arrow key

PageUp PageDown
Automation
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You can now edit data for the selected object.

SELECTING MORE THAN ONE OBJECT USING THE KEYBOARD

To select more than one object using the keyboard, do this:

 1) When the cross hairs is above an object: Press down <Ctrl> and press the 
<Enter> key.

 2) Move the cross hairs to the next object, press down <Ctrl> and press 
<Enter> — etc. until all desired objects are selected.

 3) To enter for instance the dialog box Component data: Place the cross hairs 
over one of the selected objects, and press <Enter> (without pressing down 
<Ctrl>).

You can now edit data for the selected objects.

SELECTING SYMBOLS USING THE KEYBOARD

Type in the symbol file name

When working with symbols, and you press down the <k> key, you enter the dialog 
box Place symbol, where you are asked to type in a symbol file name. — Read 
more about this in “Typing in the symbol file name directly” on page 168.

Type in the symbol article number

When working with symbols, and you press down the <v> key, you enter the dialog 
box Place symbol, where you are asked to type in a symbol article number. — 
Read more about this in “Typing in the Article Number directly” on page 169.

Type in the symbol type

When working with symbols, and you press down the <v> key, you enter the dialog 
box Place symbol, where you are asked to type in a symbol type. — Read more 
about this in “Typing in the Symbol Type directly” on page 170.

INCREMENT/DECREMENT USING THE KEYBOARD

See how to increment/decrement names for symbols, connection points and texts 
in “Short-cut keys for counting on texts” on page 132.

SHORT-CUTS FOR ACTIVATING THE PENCIL

When you are pressing a short-cut key to change from working with one type of 
drawing objects to another, you can activate the Pencil simultaneously, if you press 
the short-cut key twice.

Please note, that the short-cut key <Insert> always can be applied for the Pencil.

Lines

If for instance you press <l> to work with lines, you can press <Insert> to activate 
the Pencil.
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You can also press <l><l> — which is pressing <l> twice. If you then want to deac-
tivate the Pencil, you can do this by pressing <l> once more.

Circles

Correspondingly, the short-cut <c><c> will make you change to Circles with the 
Pencil active.

Texts

If you press <t><t>, you activate Texts, and the cursor will be placed in the text 
field in the texts toolbar.

Symbols

If you press <s><s>, you get the last selected symbol into the cross hairs. If you 
have not chosen a symbol since you opened the project, you enter the Symbol 
menu.

If you have a symbol in the cross hairs and press <s>, the symbol disappears from 
the cross hairs. When you press <s> once more, the symbol returns to the cross 
hairs.

Zoom

When you want to make a new Zoom, you can apply the short-cut key <z>. If you 
on the other hand press <z><z>, the full project page is displayed.
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THE WORK AREA

After starting Automation, you must choose whether to start a new project, or to 
continue working on an existing project.

Because this chapter exclusively deals with the work area on the screen, click the 
New document (New project) button or choose File => New. In the dialog box 
New: Double click on the page template PCSstart. In the dialog box Project data: 
Click OK.

— See more about how you select page and project templates in “Pages and 
Chapters” on page 542.

The program automatically starts up showing the dialog box Project data, with the 
tab Settings activated.

At the top of the dialog box Settings you will find some tabs, each containing a 
menu defining various program, page and project settings.

Click Cancel, OK or press the <Esc> key to leave the dialog box. — You can read 
more about this dialog box in “Settings” on page 895.

When you have opened a project, your screen should look like this:

— Please note that you can change the position of the windows and the toolbars, 
as described in “Docking Windows and Toolbars” on page 26.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES THE WORK AREA OF THE PROGRAM.
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1. The menu bar 

In the menu bar you find the menus, that contains all the functions in the program. 
Choosing a subject in the menu bar, is either done using the mouse or by pressing 
down the <Alt> key while typing in the first underlined character in the menu. Files 
will for instance be selected by pressing <Alt+f>. — See “Menus” on page 23.

2. The program toolbar

The program toolbar contains program buttons. Here you can choose between the 
various program functions. The most common file and printing facilities are placed 
here, as well as the more general drawing and editing tools.

3. The command toolbar

The command toolbar has a varying appearance depending on which object type 
is selected in the program tool bar. It contains function and editing tools for the var-
ious drawing facilities: Lines, Symbols, Texts, Arcs and Areas.

The different appearances of the toolbar for each of these is described in “Basic 
Drawing facilities” on page 51.

4. The pickmenu

Here you place the symbols, line types, text types and arc types you use the most, 
so that you can fetch them right away, and place directly in the diagram pages. 
When for instance you click on a symbol in the pickmenu, Automation change to 
working with symbols automatically, and you get the selected symbol in the cross 
hairs.

By clicking on the tabs at the bottom of the pickmenu, you select which of the cre-
ated to display. (The pickmenu was previously named the pickmenu because it 
contained symbols only).

The pickmenu is described in “Fetching symbols from the Pickmenu” on page 152, 
and can be docked as described in “Docking the Pickmenu” on page 27.

5. The help frame

The help frame displays the standard margin on the paper. It can be deactivated 
easily — see “Pointer/Screen” on page 906. It is also possible to activate a printer 
help frame, displaying the margins of your printer.

6. The Explorer window

In the upper part of the Explorer window you have direct access to:

• The Symbol menu: Here you have access to all of the available symbols in the 
program. Read more about this in “Fetching symbols using the Symbol menu” 
on page 159.

• The Component database: Here you have access to all of the available com-
ponents in the database. Read more about this in “Fetching symbols from the 
database” on page 167.
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• The Object lister: Here you for instance get an overview of any types of texts 
attached to objects in the project — such as texts attached to different types of 
symbols. Read more about this in “The Object Lister” on page 341.

Furthermore, the Explorer window contains two tabs: The Projects tab and the 
SubDrawings tab:

The Projects tab in the Explorer window

On the Projects tab you can get information about all open projects. You get a sur-
vey of the project pages, and a survey of all components on these pages. When for 
instance you click on an page symbol for a project page, the page is displayed on 
the screen. — See “The Explorer window: The Projects tab” on page 335.

The SubDrawings tab in the Explorer window

The SubDrawings tab is applied for handling e.g. placing, editing and displaying 
sub drawings. For instance you can drag sub drawings into the the active project 
page, or create new sub drawings based on copied areas from the active project.

— Read more about this in “Sub drawings” on page 289.

7. The left toolbar

The left toolbar contains various page and zoom functions, and — at the bottom — 
information about the page settings and status. These functions are elaborated in 
“Screen / Image Functions” on page 42.

8. The work area

The work area on the screen corresponds to the size of paper you have chosen to 
work on.

The size of the paper is specified in Settings => Page setup, as described in 
“Page setup” on page 903, or by inserting a drawing header, as described in 
“Insert drawing headers/formulas” on page 585.

9. The survey window 

The survey window gives you a survey of the entire page. The part of the page that 
you are currently viewing on screen at the present (the zoom), is represented by 
the black box. — See “The Survey window” on page 46.

10. Page history buttons

By clicking on the Page history buttons, you can jump to the previously active 
pages in the project. — See “The Page history buttons” on page 543.

11. The status line

Among others you can see here coordinates, layer titles, guiding texts as well as 
various messages. When you let the mouse pointer rest over for instance a button 
on the screen, an explanatory text will appear here.
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12. Current path numbers

Current path numbers are displayed in two different places: At the location you 
specify in your project, as well as on the lower part of the screen. When you zoom 
in on a part of a diagram, the current path numbers will still be displayed on the 
lower part of the screen. Thus you will always know where you are on the diagram.

— See “Current path numbers / Reference System” on page 433.

13. Page tabs

Click on the page tabs to jump back and forth between the pages. — See “Direct 
access to menus and Tabs” on page 49 and “Choosing pages outside the Page 
menu” on page 542.

14. Scrollbars

If you zoomed in on an area, you can make the area move by dragging the scroll-
bars. The scrollbars are only visible when you have zoomed in on an area. — See 
“The Scrollbars” on page 43.

15. Chapter tabs

When you click on a chapter tab, you jump to the first page in the selected chapter. 
— See “Chapters” on page 555.

16. The Component menu: The Component list window

In the Components window inside the Component menu you can for instance 
see all components in the project or all components in the project with available 
symbols (unused functions). Read more about this in “The Component menu” on 
page 254.

17. The Component menu: The Symbols for component window

In the Symbols for component window you can see the symbols for the compo-
nent that you have selected in the Components window. The symbols and their 
eventual accessories are displayed in a list. When a component has available sym-
bols these are displayed at the bottom of the window. From there you can drag the 
symbols into the diagram pages. Read more about this in "The Component menu" 
på side 254.
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THE ON-LINE MANUAL

When using this on-line manual, you have the benefit of reading the manual 
directly on the screen while working with the program. The contents is identical to 
the A4 printable manual, only have the pages been adapted for reading on the 
screen.

OPENING THE ON-LINE MANUAL

To open the On-line manual choose Help and select the manual.

THIS CHAPTER DESCRIBES

— OPENING THE ON-LINE  MANUAL .................................................................p. 39

— THE TABLE OF CONTENTS ..........................................................................p. 40

— THE BUTTONS IN THE ON-LINE  MANUAL......................................................p. 40

— ZOOMING AND ADAPTING TO YOUR SCREEN................................................p. 40

— DIRECT ACCESS TO THE INDEX ...................................................................p. 41

— RETURNING TO Automation....................................................................p. 41

— PRINTING FROM THE ON-LINE MANUAL ........................................................p. 41

Click di-

Up and

rectly to

About the elec-

tronical manual

Click to view a

chapter
Fit the manual

to your screen

Page no.

Return

down

Zoom

Index

Click to view the

sub-chapters

Click to jump to

other chapters

Click on the

+ to see the

sub-chapters
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THE TABLE OF CONTENTS

In the left-hand side of the manual, you can click 
directly on the section you wish to read.

A + in front of a section means that the chapter 
is divided into subsections.

When you click directly on a title of a section, 
the chosen section is displayed.

You can adjust the size of the table of 
contents on the screen. This is done 
by pointing on the line between the 
table of contents and the manual text, 
and then drag the line to either the left 
or the right.

You can turn the displaying of the 
table of contents on and off by press-
ing <F5>.

THE BUTTONS IN THE UPPER-RIGHT CORNER

In the upper-right corner of the on-line manual, 

you will find these four buttons.

When you click the ? button, you enter this 
chapter about using the on-line manual.

If you click the Return button, you jump back 
to the last page that you have viewed in the on-
line manual.

When you click the up and down buttons, you 
leaf one page up or down respectively. You can 
also use the <PageUp> and <PageDown> but-
tons on the keyboard.

ZOOMING AND ADAPTING TO YOUR SCREEN

When you open the on-line manual initially, it is opened to a size fitting your screen. 
If you need to zoom in on a detail in the manual, you click the Zoom button in the 
upper-left corner of your screen.

To re-size the on-line manual to fit your screen, you click the Fit in Window button 
on the upper part of the screen, or press <Ctrl+0>.

Table of contents Manual

Drag the line to the right or to the left

About the elec-

tronical manual

Return to the last

page you read

One page up

One page down
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DIRECT ACCESS TO THE INDEX

On the right-hand side of the on-line manual, you have direct access to the index.

To find an explanation about fx. the selection function, you click S index letter in 
the right-hand side of the manual. This then looks up under S in the index. Now 
click on the dotted line after the word Selection, to bring up to the desired informa-
tion.

Please note, that it is important that the cursor on screen has the 
appearance of a hand with a pointing index-finger, when you click the 
dotted line — or the page number. If this is not the case, you zoom in 
on the text, and therefore can no longer see the full page on screen.

Click the Fit in Window button or press <Ctrl+0> to restore full page view.

RETURNING TO Automation

In order to return to Automation, you 
just click on its program Windows but-
ton at the bottom of your screen — or 
press down the <Alt> button while 
pressing the <Tab> button.

The reason why you have to change back and forth in this way, is because that the 
manual is a document in the independent program Adobe Acrobat reader.

PRINTING FROM THE ON-LINE MANUAL

If you wish to read the manual on print, it is recommended to see the printed man-
ual. To print out directly from the on-line manual, just click the Print button on the 
Acrobat program, and specify what to print out.

Please note, that the on-line manual buttons will also be printed.

Click here
mation
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SCREEN / IMAGE FUNCTIONS

This chapter has to do with the screen-related functions in the program. All buttons 
having this type of function, are located on the left hand side toolbar.

ZOOM, SCROLL AND PAN

In Automation you can specify which part of the page you wish to see on the 
screen.

Zoom

When you want magnify a part of 
the page, you can click on the 
Zoom button, and then select an 
area on the screen using the 
mouse. Do this:

 1) Click and keep the mouse 
button pressed down.

 2) Drag the mouse over the 
area you wish to enlarge, 
and let go of the mouse 
button.

THIS CHAPTER DESCRIBES

— THE FUNCTIONS ZOOM, SCROLL AND PAN...................................................p. 42

— HOME VIEW AND REDRAW...........................................................................p. 45

— SET USER HOME VIEW ................................................................................p. 45

— SHOW EXPANDED DRAWING AREA ...............................................................p. 46

— THE EXPLORER WINDOW ............................................................................p. 47

— THE SURVEY WINDOW ................................................................................p. 46

— SNAP .........................................................................................................p. 47

— GRID..........................................................................................................p. 48

— THE CROSS HAIRS......................................................................................p. 48

— DIRECT ACCESS TO MENUS AND TABS ........................................................p. 49

— GENERAL PROTECTION ERROR....................................................................p. 49

ALL SHORT-CUT KEYS CAN BE CHANGED

PLEASE NOTE, THAT YOU CAN USE MANY SHORT-CUT KEYS IN THE PRO-

GRAM. YOU CAN SEE THE PREDEFINED SHORT-CUT KEYS IN “Short-cut 
Keys” on page 856. THERE IT IS ALSO DESCRIBED HOW TO DEFINE YOUR 

OWN SHORT-CUT KEYS.

1) Click here, and keep the mouse

2) Drag the mouse cursor across the

screen, and release the mouse button

button pressed down

when the desired area is selected
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When you release the mouse button, the chosen area is now enlarged.

View => Zoom or the short-cut key <z> has a similar effect.

On a three-button mouse, the button in the middle can also be used for zoom.

The Zoom All function

When you choose View => Zoom All, a zoom is made so that all objects in the 
work area is displayed — in the closest zoom possible.

If there only are a few objects placed next to each other, the program will zoom in 
on these objects.

If there, on the other hand, are placed objects outside the boundaries of the page, 
the program will zoom out, so that it becomes possible to select these objects.

Zoom in/out

To zoom in, you can choose View => Zoom in (short-cut <Ctrl+Home>), and to 
zoom out you can choose View => Zoom out (short-cut <Ctrl+End>).

— Please also see “Zoom and Scroll for mouse with a wheel” on page 43.

The Scrollbars

When you press down the <Ctrl> key, you can use the arrow 
keys to move the zoom — e.g. the short-cut key 
<Ctrl+RightArrow>.

Having zoomed in on an area, you can also apply the scroll-
bars in the right side and the bottom of the screen. When 
you click on a scroll bar and drag it to another location, the 
displayed zoom is moved correspondingly.

The use of scrollbars can be activated/deactivated as 
described in “Pointer/Screen” on page 906.

Zoom and Scroll for mouse with a wheel

If you have a mouse with a wheel between the left and right mouse buttons, the 
wheel can also be used for zooming and scrolling.

Exactly how it works, is specified under Settings => Pointer/Screen.

Mouse wheel set to Scroll

If Settings => Pointer/Screen => Mouse wheel is set to Scroll, the mouse wheel 
works like this:

PRESS RESULTS IN

<WHEEL FORWARDS> THE ZOOM IS MOVED UPWARDS ON THE PAGE

<WHEEL BACKWARDS> THE ZOOM IS MOVED DOWNWARDS ON THE PAGE

<SHIFT + WHEEL FORWARDS> THE ZOOM IS MOVED TO THE LEFT

<SHIFT + WHEEL BACKWARDS> THE ZOOM IS MOVED TO THE RIGHT

<CTRL + WHEEL FORWARDS> ZOOMS IN WHERE THE CROSS HAIRS IS LOCATED

<CTRL + WHEEL BACKWARDS> ZOOMS OUT WHERE THE CROSS HAIRS IS LOCATED

Scrollbar
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Mouse wheel set to Zoom: Wheel Forward

If Settings => Pointer/Screen => Mouse wheel is set to Zoom: Wheel Forward, 
the mouse wheel works like this:

Mouse wheel set to Zoom: Wheel Backward

If Settings => Pointer/Screen => Mouse wheel is set to Zoom: Wheel Back-
ward, the mouse wheel works like this:

Keep page zoom

By choosing Settings => Pointer/Screen, you can decide whether to keep the 
zoom when changing back and forth between pages in the project. You specify the 
zoom settings by deselecting Keep zoom and Keep page zoom. Read more 
about this in “Pointer/Screen” on page 906.

View previous zoom

When you select View => Previous zoom, you jump back to the previously applied 
zoom on the active page. Because the program memorizes the two last applied 
zooms, you can jump back and forth between these by using this function.

As a short-cut for this function, you can use the <Tab> key, and you can also acti-
vate the function by pressing the <Ctrl> key while clicking the Zoom button.

All pages memorizes the two most recently applied zooms, until the project is 
closed. Please note that this enables you to use the <Tab> button to jump directly 
from full screen to the most recently applied zoom.

Pan

When you have zoomed in on an area, you can click the Pan button ("the hand") in 
the left toolbar. The cursor then changes appearance to a hand.

When you then press down the left mouse button, you can drag the page (pan), so 
that you see exactly the part of the page, that you wish to see.

PRESS RESULTS IN

<WHEEL FORWARDS> ZOOMS IN WHERE THE CROSS HAIRS IS LOCATED

<WHEEL BACKWARDS> ZOOMS OUT

<SHIFT + WHEEL FORWARDS> THE ZOOM IS MOVED UPWARDS ON THE PAGE

<SHIFT + WHEEL BACKWARDS> THE ZOOM IS MOVED DOWNWARDS ON THE PAGE

<CTRL + WHEEL FORWARDS> THE ZOOM IS MOVED TO THE LEFT

<CTRL + WHEEL BACKWARDS> THE ZOOM IS MOVED TO THE RIGHT

PRESS RESULTS IN

<WHEEL FORWARDS> ZOOMS OUT

<WHEEL BACKWARDS> ZOOMS IN WHERE THE CROSS HAIRS IS LOCATED

<SHIFT + WHEEL FORWARDS> THE ZOOM IS MOVED DOWNWARDS ON THE PAGE

<SHIFT + WHEEL BACKWARDS> THE ZOOM IS MOVED UPWARDS ON THE PAGE

<CTRL + WHEEL FORWARDS> THE ZOOM IS MOVED TO THE LEFT

<CTRL + WHEEL BACKWARDS> THE ZOOM IS MOVED TO THE RIGHT
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As long as the Pan button is activated, you can not select any objects on the pro-
ject pages. To continue working in the project, you therefore need to deactivate the 
Pan button by clicking it again, or by pressing <Esc>.

If you have a mouse with a middle mouse button, you can choose to use the middle 
mouse button for panning: Select Settings => Pointer/Screen => Middle mouse 
button and choose Pan.

HOME VIEW AND REDRAW

When you click the Zoom to page button, the entire page will be shown on the 
screen area. Choosing View => Home view gives the same result.

The short-cut keys are <Home> or <z><z>.

To refresh the image on screen, click on the Redraw button. Alternatively select 
View => Redraw; the short-cut key is <Ctrl+g>.

This updates the image on the screen, as well as the survey window.

SET USER HOME VIEW

When you only want Automation to display a specified section of the page when 
you click on the Home view button, do the following:

 1) Choose View => Set User Home view.

 2) The mouse cursor now changes appearance to a two-way arrow: Click to 
specify one corner of the new home view, and click once again to specify the 
opposite corner of the home view. (This is done similar to making a zoom — 
see “Zoom” on page 42).

The next time you click on the Home view button — or press <Home> — the spec-
ified area is displayed on the screen. This is the consequence for all project pages 
having the same page size, as the page you set the home view for — for instance 
A4 horizontal.

If you wish to create other Home views for other page formats, this is also possible.

Display the full page, and not just the User Home view

When you wish to see the full page, and not just the defined Home view, press 
<zz>.
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Remove Home View settings

When you want the Home view button to display the full page again, you choose 
View => Set User Home view again. You then get the following message:

Click Remove to make the Home view button display the full page again, or click 
New to create a new Home view.

EXPANDED DRAWING AREA

When you select View => Clean screen, the active project page will fill all of the 
program window. This makes the program toolbars and the Explorer window invis-
ible.

You return to normal viewing by selecting View => Clean screen again.

The default short-cut key for the function is <Ctrl+0>.

THE SURVEY WINDOW

The survey window is an independent window 
which can be docked inside the Explorer window, 
or be placed anywhere on the screen. — For fur-
ther details about the location of the Survey win-
dow, please refer to “Docking Windows and 
Toolbars” on page 26.

Moving the displayed area

A black box within the window shows which section of the drawing (which zoom) is 
presently being displayed on the full screen. Click on the black box and drag it until 
it covers the part of the drawing you want to see on screen. When the mouse 
pointer is pointing on the black box, you will be noticed that you are now able to 
move the box.

Zooming in the Survey window

You can zoom in and out using the survey window. By placing the mouse pointer 
on the boundary of the black box, it will change into a two-way arrow. You can now 
resize the zoom by dragging the boundary.

Objects displayed in the Survey window

Objects (see “On Drawing objects” on page 53) located on the page, will also be 
displayed in the survey window. This gives you the option to keep the survey of the 
page while working in a zoom. You can select a new zoom using the placed objects 
as guides. Texts will not be displayed in the Survey window.
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The survey window is updated when you click Redraw or display a new project 
page.

Placing the Survey window

You can move the survey window by clicking on the windows menu bar, keeping 
the mouse button pressed down, and then drag the window to a new preferred 
location. The window can be enlarged or reduced by dragging its corners.

When you close down the program, the size and position of the window is memo-
rised.

The Survey window can be activated/deactivated by choosing View => Survey 
window. Short-cut key <F12>.

Docking the Survey window in the Explorer window

See how to dock the Survey window inside the Explorer window in “Docking the 
Survey window or the Symbols for component window” on page 27.

THE EXPLORER WINDOW

In the left side of the screen you find the Explorer window. From here you can for 
instance choose what to display on the screen, change page data and project data, 
change symbol and cable component data, find symbols and close projects.

— Read more about this in “The Explorer window: The Projects tab” on page 335.

SNAP

When you place an object on a drawing, it is important that you can position it 
exactly where you want it. To support this, you can specify that objects only may be 
located in fixed spots, located at intervals of for instance 2.50mm. — If you then 
want to place a symbol, you will only be allowed to move it in steps of 2.50mm on 
the screen, which enables you to place the symbols accurately.

If the distance between the points where you can place the symbols is 2.50mm, 
you say that the snap is 2.50mm.

By clicking the Snap button in the left toolbar, you can toggle between normal snap 
(for instance 2.50mm) and fine snap (for instance 0.50mm).

If you are working in fine snap, the lower part of the left toolbar will display a red 
background under the size of the snap.

Choose Settings => Page settings to change the snap settings — or click on “2.5” 
in the lower part of the left toolbar.

If you have an object on the cross hairs that you want to place, you can place it 
using fine snap by pressing down <Shift>. After you place the object, the program 
automatically change back to normal snap.

Please note that 2.50mm is standard normal snap size for electrical drawings.

— See “Page setup” on page 903.
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GRID

The dots you see placed on the entire page in a drawing, is called the grid of the 
drawing. You can change the distance between the dots by choosing Settings => 
Page settings.

Choosing Settings => Pointer/Screen, you can disable the function completely, or 
choose to use squares instead of dots. See “Pointer/Screen” on page 906.

The size of the grid — in millimetres — only relates to what you see on screen, and 
not to the real size of the drawing. Thus changing the scale of the page from 1:1 to 
1:50, will not make the grid change on the screen.

On scaled (mechanical) pages you can make the snap and the grid follow the page 
scale factor if you choose Settings => Page setup and select Follow page scale. 
— See “Setting the scale of the page” on page 533.

THE CROSS HAIRS

While you are working on a project drawing, the location of the cursor is indicated 
by a crossing vertical and horizontal line. This is called the cross hairs.

In Settings => Pointer/Screen you can see the 
cross hairs is set to be displayed right angled.

When you draw Straight lines (see “Straight 
lines” on page 73), a line will be displayed start-
ing from where you clicked last, pointing towards the cross hairs.

When you select Cross hairs displayed right angled, you will see the line that 
would be drawn if you clicked in this very moment. This line will not always be 
shown ending up in the cross hairs — due to the snap applied.

If the function is not selected, the line will always be shown from the place you 
clicked last and directly to the cross hairs. But this line is not necessarily the exact 
line that would be drawn if you clicked.

When Cross hairs figure with snap is selected, the figure (for instance a symbol) 
you have in the cross hairs will be shown in the nearest snap — exactly where it 
will be located when you click.
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DIRECT ACCESS TO MENUS AND TABS

In the lower left-hand corner of the screen, you will se various information about fx. 
the snap settings and the title of the present layer. Clicking on these fields brings 
you directly into the menus, where these settings can be altered.

When you let the mouse cursor rest an instance over one of the fields, an 
explanatory text is displayed — as for Snap on the figure above.

Page status

In the field Page status the following status options exists:

S: The page has not been changed since last save.

S:+ The page has been changed since last save.

S:R+ The page has been changed since last revision start/stop, and has
 been changed since last save.

Page tabs

By clicking on the page tabs, you jump back and forth between the project 
pages. You can also use the short cut keys <PageUp> and <PageDown> to 
jump between the project pages.

Chapter tabs

When you click on a chapter tab in the right-hand side of the screen, the 
first page in the displayed chapter is displayed.

GENERAL PROTECTION ERROR

If a General protection error occur, the line at the bottom of the screen starts flash-
ing on a red background, giving a warning that the project should be saved under a 
new name, and that the program should be restarted.

Snap
Grid

Page type

Page size

Scale

Page status

Coordinates Layer namePage tabs
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At the same time this window is displayed:

Here you can tell us what happened just before the error occurred, which we would 
very much like to know, so that we can correct it as soon as possible.

When you want to save the project, you automatically enter the dialog box Save 
as, to prevent that you save what might be a project containing errors, so that this 
project replace, the last saved version of the project. However, if you do let this pro-
ject replace the last saved version of the project, Automation automatically cre-
ates a backup file (extension .~pr), so that the original version of the project also 
can be opened succeedingly.
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This section describes the basic drawing facilities:

- Working with drawing objects .............................p. 53

- Transferring data between objects.....................p. 62

- Align, Space and Trim functions ..........................p. 66

- Lines.........................................................................p. 72

- Arcs/Circles...........................................................p. 106

- Texts.......................................................................p. 108

- Symbols.................................................................p. 149

- Functions on Component level .........................p. 250

- Areas......................................................................p. 270

- Object groups.......................................................p. 283

- Sub drawings........................................................p. 289

- Rename symbols.................................................p. 322

- Insert image ..........................................................p. 330

WATCH TUTORIAL VIDEOS / READ SURVEY ARTICLE

PLEASE READ THE SURVEY ARTICLE ABOUT DRAWING 

FUNCTIONS AT www.pcschematic.com/articles AND 

WATCH VIDEOS ABOUT HOW TO CREATE PROJECTS — 
AND MUCH MORE — AT www.youtube.com/pcsche-
matic.

Basic Drawing facilities

http://www.pcschematic.com/articles
http://www.pcschematic.com/articles
http://www.youtube.com/pcschematic
http://www.youtube.com/pcschematic
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ON DRAWING OBJECTS

Any object you place on a drawing has got to be one of four different types of draw-
ing objects: It is either a symbol, a text, a line or a circle.

Also there is the Area-command, which makes it possible to work independently of 
object types.

In the Menu bar and the Program toolbar you have different options at hand, 
depending on which type of objects you have chosen to work with.

The buttons for command change

The buttons, you have to click on to select the various objects, look like this:

— Please see “Auto command change” on page 57 also.

THIS CHAPTER DESCRIBES

— THE BASIC WORKING MODES OF THE PROGRAM........................................... p. 54

— SELECTING OBJECTS.................................................................................. p. 55

— AUTO COMMAND CHANGE........................................................................... p. 57

— HOW TO WORK WITH SELECTED OBJECTS.................................................... p. 58

— SHOW OBJECT BELOW CURSOR .................................................................. p. 60

— THE UNDO FUNCTION................................................................................. p. 60

— TRANSFERRING PROPERTIES BETWEEN OBJECTS......................................... p. 63

— ALIGN, TRIM AND SPACE ............................................................................ p. 66

— INVISIBLE OBJECTS..................................................................................... p. 69

Symbols <s>
(s. 149)

Texts <t>
(s. 108)

Lines <l>
(s. 72)

Circles <c>
(s. 106)

Areas <a>
(s. 270)

WHEN YOU CLICK ONE OF THESE BUTTONS YOUR OPTIONS CHANGE:

— THE PROGRAM TOOLBAR CHANGES

— THE OPTIONS IN THE PROGRAM MENUS CHANGES

— YOU ARE ONLY ALLOWED TO WORK WITH OBJECTS OF THE CHOSEN 

TYPE
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WORKING WITH THE PROGRAM

In Automation there are two different modes to work in.

Which mode you work in is determined by the Draw button (the Pencil).

You either:

a) Draw/place new objects (activated/highlighted Pencil), or you work on

b) Already placed objects (not activated Pencil)

New objects

When you draw/place new objects, you do so like this:

 1) Select the type of objects you wish to work with

 2) Activate the Pencil

 3) Draw / place the objects

Thus if you want to draw a line, you first click on the Lines button (1), then click on 
the Pencil (2), and draw the line (3).

Please note that in several occasions the program activates the Pencil by itself. For 
instance this happens when you have typed in a text in the text field, or when you 
have picked a symbol in order to place it.

Already placed objects

If you, on the other hand, have to work with objects that have already been placed, 
the procedure is like this:

 1) Select the type of objects you wish to work with — see “Auto command 
change” on page 57 also

 2) Deactivate the pencil (Press <Esc>)

 3) Select the object(s) you want to deal with

 4) State what you want to do with the objects

If for instance you want to copy a symbol, you first click the Symbols button (1) and 
deactivate the pencil pressing <Esc> (2). Then select the symbol by clicking on it 
(3), and specify that you wish to copy the symbol by clicking Copy (4).

The copied symbol can now be placed.

Displaying relative coordinates

When moving or copying objects, the object coordinates are displayed in the status 
line at the bottom of the screen.
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SELECTING OBJECTS

When you wish to do something with an existing object, you first have to select the 
object. This takes place in the following way:

Click on the button which corresponds to the type of the object — for instance the 
Texts or the Symbols button. Make sure that the Pencil button is not selected; click 
on it or use <Esc>. Click on the object you wish to select.

The selection will be indicated as a colored field surrounding each chosen object 
individually.

Below you can see how deselected as well as selected objects appear on screen:

When working with symbols, please note that a selection can include the entire 
symbol, or just one of its connection points.

If you select a text, the text toolbar (see “Dictionary” on page 967) will tell you 
which type of text you have chosen.

Remarks about selecting lines

A line is constructed of segments, depending on how many breaks it contains. First 
time you click on a line, all segments in the line will be selected. If you click at the 
line once more, only the segment you click on gets selected.

Electrical lines will be selected up to the next electrical point.

Selection by right-clicking

By right-clicking on an object (of the chosen object type), you will select the object 
and at the same time a short-cut menu will appear. In this menu you can e.g. 
choose Move, Copy or Delete. — Please refer to “Short-cut menus and Right-
clicking” on page 25 for further details.

Selecting more objects of the same kind in one window

You can select more than one object of the same type at the same time. If for 
instance you want to select all texts in an area, click on the Texts button and select 
the desired area with the mouse. Do this by clicking in one corner of the area, and 
then, still pressing down the mouse button, drag the mouse cursor to the opposite 
corner of the area. Thus a marquee rectangle is indicated by dashed lines, having 
one corner where you first clicked and the opposite corner where the mouse 

Deselected Selected
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pointer is located now. When all the desired objects are inside the marquee rectan-
gle, release the mouse button. The texts in the area have now been selected.

If you wish to deselect one or more objects inside the window, press down the 
<Ctrl> key and click on the object(s). If you also wish to select objects outside the 
area, also press down the <Ctrl> key, and click on these objects.

Selecting more objects of the same kind using the mouse

Select the kind of objects you want to work with; for instance Symbols.

Press the <Ctrl> key while clicking on the desired objects. If you have selected a 
symbol you do not want after all, then click on the symbol again — still pressing the 
<Ctrl> key.

Selecting different types of objects in an area

Click on the Area button. Drag a marquee rectangle around the objects as 
described in “Selecting more objects of the same kind in one window” on page 55. 
Hereby all object types inside the window are selected. If you wish to deselect one 
of the selected objects, press the <Ctrl> key and click on the object. If you also 
wish to select objects outside the area, also press down the <Ctrl> key, and click 
on these objects. — Read more about areas in “Areas” on page 270.

Dragging the marquee rectangle left to right — or right to left

How many objects you select, when you drag the marquee rectangle, depends on 
whether you drag the mouse left to right or right to left.

When you select objects by dragging left to right, you only select objects where all 
parts of the object is inside the marquee rectangle and objects having their refer-
ence points inside the marquee rectangle.

"VIEW REFERENCE POINTS" MUST BE ENABLED

IF YOU CAN NOT SEE THE REFERENCE POINTS WHEN YOU ZOOM IN ON AN 

AREA, THIS IS BECAUSE VIEW REFERENCE POINTS HAS NOT BEEN ENABLED. 
ENABLE IT BY CLICKING THE REFERENCE POINTS BUTTON IN THE LEFT 

TOOLBAR, OR BY SELECTING VIEW => REFERENCE POINTS.

— GET MORE INFO ABOUT THIS IN “Settings” on page 895.

1) Click here

2) Press down the mouse button and drag

3) Place the cursor here and release
     the mouse button
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When you select objects by dragging right to left, all objects with just a fraction 
inside the marquee rectangle are selected.

Selecting on different Layers and in different elevations

The ways of selecting objects described above, all assumes that you are working 
in the same layer as the objects you wish to select. — Read more about selecting 
and layers in “Selecting objects on different layers” on page 531, and read more 
about layers in general in “Layers, Elevation and Scaling” on page 527.

Selecting everything on a page

You can select everything on a page (including different layers) by selecting Edit 
=> Select all => All on page. Short-cut <Ctrl+a>. If the Area button is selected all 
objects on the page will be selected. If Symbols is selected, all symbols on the 
page will be selected — and so on.

AUTO COMMAND CHANGE

If you want Automation to change command for you automatically, choose Func-
tions => Auto command change.

When this function is activated, Automation automatically changes between Sym-
bols, Lines, Texts and Circles when you want to select, move or delete objects. 
The program automatically changes to the correct command when the object is 
selected.

The function can be deactivated by choosing Functions => Auto command 
change again.

The function can also be activated/deactivated by clicking the Auto command 
change button, placed to the left of the Lines button.

— Please see “Show object below cursor” on page 60 also.

Dragging left to right Dragging right to left
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WORKING WITH SELECTED OBJECTS

When you want to copy, move, delete or rotate objects, you have to:

 1) Choose the type of objects you are interested in

 2) Select the objects you want to deal with

 3) Copy / move / delete / rotate the objects

Step one and two are dealt with in “Selecting objects” on page 55, and step three 
will be elaborated in the sections to follow.

To see how to place / draw new objects, you have to read the following sections:

“Lines” on page 72, “Arcs/Circles” on page 106, “Texts” on page 108 and “Sym-
bols” on page 149.

Where no further remarks are added, the following functions covers working with 
Symbols, Texts, Lines, Circles and Areas.

Moving selected objects

When you want to move selected objects, you have three options at hand:

a) Click the Move button. You thereby get the selected objects in the cross 
hairs, and just have to click where you want them placed.

b) Use click and draw: Click on the selected object(s), keep the mouse button 
pressed down, and drag them across the screen. Let go of the mouse button 
when you can see the objects where you want them located. Read more 
about drag and drop in “The mouse” on page 25.

c) Right-click inside the window. A menu emerge, and you choose Move. You 
get the selected object(s) in the cross hairs, and can move them across the 
screen. Click when the objects are where you want them located.

Remarks about moving Symbols

When you have to move a symbol that is connected to lines, you can do this in two 
different ways:

a) The symbol remain connected to the lines: Click on the symbol, and drag it to 
the place you want it located.

b) The lines are parked and the symbol can be moved freely: Press down the 
<Ctrl> key while clicking on the symbol, and drag it to where you want it 
placed.

You can also move the symbol freely by clicking on the symbol, and then press 
down <Ctrl> while clicking Move.

Furthermore, if you place a two-poled symbol on top of a conducting line, the sym-
bol will automatically be connected to the line.

Copying selected objects

When you want to copy one or more selected objects, you have got two options:
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a) Click the Copy button. You now get a copy of the selected object(s) in the 
cross hairs, and can place the objects as many times as you want by clicking.

b) Right-click on one of the selected objects. A menu emerge, and you choose 
Copy. You now likewise get a copy of the objects in the cross hairs, and can 
place the objects as many times as you want by clicking.

Deleting selected objects

If you want to delete one or more selected objects, you have also got two options:

a) Click the Delete button or press <Del>. Hereby the objects are removed form 
the screen.

b) Right-click on one of the selected objects. Choose Delete in the emerging 
menu. The objects are removed from the screen.

Please remember that you can undo your actions clicking the Undo button.

If parts of the deleted objects remain on screen, click the Redraw button to get the 
page refreshed.

Remarks when deleting a symbol

If you delete a symbol having conducting lines connected to it, the lines will be 
parked.

Rotating a selected object

This function works for Texts, Symbols and Arcs, but not for lines. The function 
also works for Areas, and lines within the selected area will also be rotated.

All objects are rotated counter-clockwise.

There are four ways of rotating objects:

a) Press <Spacebar>. The object will be rotated 90 degrees counter-clockwise. 
If you press <Ctrl> while pressing <Spacebar> the object is rotated 10 
degrees.

b) Right-click on the object and choose Rotate.

c) Click on the Rotate button in the toolbar.

d) Click in the field V:, type in the rotation angle and press <Enter>. The angle 
can have an accuracy of 1/10 degree. You can also click the down-arrow in 
the field, select an angle, and press <Enter>.

Remarks about rotating symbols

A symbol connected to conducting lines in both ends, will rotate 180 degrees, and 
the connection to the lines will be exchanged. Press down <Ctrl> when you click 
Rotate if you want the symbol to rotate only 90 degrees, and the lines will keep 
their original connections to the connection points.
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Rotating areas

You can also rotate an entire area in one operation. To this, you must first have the 
area in the cross hairs in connection with either moving or copying, as described in 
“Rotating areas” on page 280.

SHOW OBJECT BELOW CURSOR

The function View => Show object below cursor temporarily frames the objects 
below the cursor, as the cursor is moved across the project page.

For lines it is also specified where you would connect to the line, if you clicked on it 
at the given moment.

— Please see “Auto command change” on page 57 also.

UNDO

An important function to know when working 
with objects, is the Undo function.

When you click the Undo button once (short-
cut key <z>), you undo the last action the 
program has performed.

If you let the mouse cursor rest above the 
Undo button, the operation that you can 
undo, is displayed as a hint.

Undoing multiple actions/levels

When you click the down-button next to the 
Undo button, a list of the most recently per-
formed actions are displayed. Here you can 
specify how many actions you wish to undo.

When for instance you click Connection 
data -X3:2 in the figure to the right, all of the 
latest actions are undone, including when the connection data for
-X3:2 was changed.

For Symbols For Lines

Place the cursor here,

and the next points in the

list are displayed

Click here, and the Undo

list is displayed
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See how many actions you undo

To begin with, the list only displays the five latest actions. When you place the cur-
sor above the last point in the list, five more actions are displayed. This continues 
until you see all of the actions that can be undone.

The last point in the list also displays how many actions you have selected in the 
list at any moment.

Some functions can not be undone

Please note that there are functions which you can not undo, such as using the 
automatic wire numbering or placing a drawing header on a page. In the first case 
you can save the project before assigning the wire numbers, and in the last case 
you have to take action yourself to remove the drawing header.
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TRANSFERRING DATA / PROPERTIES BETWEEN OBJECTS

You can transfer two types of information between objects of the same type in 
Automation:

- Component Data, which contains information about the physical components 
attached to the objects, and

- Object properties, which only have to do with the appearance of the objects

Transferring Component Data for Symbols or Lines

It is only possible to transfer component data between symbols or lines.

Transfer component data for Symbols

When you transfer component data from one symbol to another, start by clicking 
the Symbols button, and deactivate the Pencil (Press <Esc>).

COPYING THE COMPONENT DATA

Right-click on the symbol you want to transfer component data from, and choose 
Component data. — Or click on the symbol and then click on the Object data but-
ton.

In the upper left hand corner of the Component data dia-
log box you click the Copy component data button. This 
copies the contents of the fields Name, Type, Article no 
and Function. If symbol datafields are created for the 
symbol — see “Symbol datafields” on page 120 — the 
contents of these are also copied.

Leave the menu by pressing <Esc>.

TRANSFERRING COMPONENT DATA TO A SYMBOL

Right-click on the symbol you want to transfer the component data to, and click the 
Paste component data button.

You have now transferred component data from one symbol to another.

Correct the symbol name if you want to, and click OK.

TRANSFERRING COMPONENT DATA TO MORE THAN ONE SYMBOL

If you want to transfer the copied component data to more than one symbol, you 
can for instance drag a window around the relevant symbols, as described in 
“Selecting more objects of the same kind in one window” on page 55.

Then right-click inside the selected area, and choose Component data. Insert the 
copied component data by choosing Edit => Paste.

THIS CHAPTER DESCRIBES

— HOW TO TRANSFER COMPONENT DATA BETWEEN OBJECTS ......................... p. 62

— HOW TO TRANSFER OBJECT PROPERTIES BETWEEN OBJECTS...................... p. 63

— TRANSFERRING OBJECT PROPERTIES TO MORE THAN ONE OBJECT ............... p. 64
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Please note, that if for instance Type and Article data are dimmed when you enter 
the dialog box, this tells you that the selected symbols do not have identical con-
tents in these fields.

Transfer article data for Lines

If you want to transfer line article data from one line to another, the procedure is the 
same as described in “Transfer component data for Symbols” on page 62. The only 
difference is that you have to activate the Lines button instead of the Symbols but-
ton, and then choose Line article data.

When you copy line data for a line, the contents for any attached line data data-
fields are also copied.

Transferring Object properties between Objects

To all objects there are attached information about the attributes of the object, the 
so-called object properties. These attributes are for instance called line properties 
or text properties.

Below you can see which type of information you can transfer between the various 
types of objects:

Changing object properties on existing object

Select an object. In the toolbar (or in the dialog box Text properties for texts) you 
make the desired changes. Click on the Transfer properties button.

The changes have now been transferred to the chosen object.

Transfer object properties from one object to another

Select the object that carries the desired object properties, and click on the Copy 
properties button — or press down <Shift> while clicking on the object.

Select the object you want to transfer the properties to, and click on Transfer prop-
erties.

OBJECT 

PROPERTIES
INFORMATION THAT CAN BE TRANSFERRED

LINE PROPERTIES THE TYPE, WIDTH, LINE DISTANCE AND COLOR, AS WELL AS WHETHER 

THE LINE IS A CONDUCTING LINE AND WHETHER IT IS A JUMPER LINK 

— SEE E.G. “Lines” on page 72. — BUT NOT THE COURSE OF THE 

LINE, OR IF IT IS DRAWN AS FOR INSTANCE A SLANTED OR CURVED 

LINE.
DURING THE GENERATION OF A SYMBOL, FOLLOW CONNECTED IS 

ALSO TRANSFERRED. SEE “Creating Symbols” on page 761.

TEXT PROPERTIES ALL INFORMATION IN THE DIALOG BOX TEXT PROPERTIES — SEE 

“Specifying text properties / Appearance of text” on 
page 133. THE TEXT ITSELF, AND THE ANGLE IT MIGHT BE ROTATED 

WITH, IS NOT TRANSFERRED.

CIRCLE/ARC PROP-

ERTIES

ALL INFORMATION IN THE CIRCLES TOOLBAR — SEE “Arcs/Circles” 
on page 106.

SYMBOL PROPER-

TIES

ONLY THE SCALE OF THE SYMBOL.
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TRANSFER OBJECT PROPERTIES TO MORE THAN ONE OBJECT

It is possible to transfer object properties to several objects in a single operation. 
For instance you can give a number of texts the same height and/or color.

In this example you can se how this is done by placing the two texts Text1 and 
Text2 — each carrying different text properties — and then give both texts the 
same height without changing the other attributes of the texts.

Place Text1

Click on Texts, click in the text 
field in the texts toolbar, type in 
Text1, and click on the Text prop-
erties button.

Set Height to 2.5, Width to 
AUTO, Alignment to left-down 
and Color to Black.

Click on OK and place the text 
somewhere on the page.

Place Text2

Then click in the text field in the 
texts toolbar once more, but type 
in Text2 this time. Click on Text 
properties, and set Height to 
5.0, Width to AUTO, Alignment 
to centre-centre and Color to 
Red.

Click OK, and place the text on 
the page.
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Transfer text properties

Select both of the texts, click on the 
Copy properties button and then 
on Text properties.

In the dialog box you now see 
which text properties the selected 
texts have in common — in this 
case both has the Width AUTO.

Now set Height to 8.0 and click 
OK.

As you can see, the texts now have 
the same height, but their other 
attributes have not been changed.

Text1 is still black and aligned left-down, while Text2 still is aligned centre-centre 
and red.

You can use the same procedure for lines and circles.
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ALIGNING AND SPACING FUNCTIONS

In Automation you also have some functions for trimming and spacing objects.

The Align function

As you will see, it is possible to align objects in Automation.

In the following example symbols will be used, but you can do exactly the same 
using texts or circles.

These three symbols are to be aligned, at the same height as the symbol to the 
left:

 1) Make sure that the Symbols button is activated, then click and drag to select 
the two symbols to the right:

 2) Select Edit => Align, or right-click inside the selected area and choose 
Align.

 3) A rubber band originating from the symbol in the middle and ending in the 
cross hairs is now displayed. (See the guiding text in the bottom of the 

THIS CHAPTER DESCRIBES

— THE ALIGN FUNCTION................................................................................. p. 66

— THE SPACE FUNCTION................................................................................ p. 67
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screen). Click on the symbol to the left, and the two selected symbols are 
aligned with the symbol.

If the symbols had been closer to be arranged on a vertical line, they would have 
been placed on a vertical line instead.

Please note that the determining symbol may also be one of the selected symbols.

Aligning symbols - across project pages

Symbols placed on separate project pages are aligned like this:

 1) Make sure that the Symbols button is activated, right-click on the symbol 
that you wish to align the other symbols to, and select Align.

 2) Jump to another project page — for instance using the page tabs at the bot-
tom of the screen

 3) On the new project page a thin line now originates from where the selected 
symbol was placed on the previous project page, and ends in the cross-hairs: 
Now click on each individual symbol, that you wish to align to the selected 
symbol. This aligns them to the selected symbol.

It is not possible to do this for other types of objects.

The Space function

There exists a similar function, placing symbols with fixed intervals. Unlike Align 
you relocate all the symbols when you use the Space command.

In the following example symbols are used once again, but texts or circles could be 
used as well.

ALIGN - WITH AND WITHOUT <CTRL>

WHEN YOU RIGHT-CLICK ON A SYMBOL (A) AND SELECT ALIGN AND THEN 

CLICK ANOTHER SYMBOL (B), A IS ALIGNED WITH B.

WHEN YOU PRESS DOWN <CTRL> WHILE CLICKING B, B IS ALIGNED WITH A.

THE SAME GOES FOR OTHER TYPES OF OBJECTS.
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Activate the Symbols 
button, and place 
some symbols as 
shown on the figure.

Then mark up a win-
dow surrounding the 
symbols, and choose 
Edit => Space — or 
right-click and choose 
Space.

Please note the guid-
ing text in the bottom 
right-hand corner of 
the screen.

A rubber band start-
ing in the symbol in 
the middle and ending 
in the cross hairs is 
now displayed.

Click where you want 
the first of the symbols to 
be located.

A dialog box appear on 
screen, and you fill it out as 
shown.

Click OK.

The symbols are now 
placed aligned, with an 
interval of 20mm 
between them, sorted 
by name.

If you set the interval to 
be zero for X and Y, you 
will be asked to point 
out where the first and last symbols have to be located.

When there is not enough space to place the symbols, you will be asked to point 
out a new starting point, from where the remaining symbols can be placed.

Sort by name

When you select Sort by name — only possible for symbols — the symbols are 
placed sorted by their names. If you have marked up the window around the sym-
bols from left to right, the symbols will correspondingly be placed from left to right.

The first sorting criterion is the symbol name, then the Component Group number. 
If these are still identical, the are sorted according to the first connection name. — 
Read more about component grouping in “Component Grouping” on page 613.
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MAKING OBJECTS INVISIBLE

All drawing objects — Symbols, Lines, Texts and Circles/Arcs — can be made 
invisible. This means that the objects will not be displayed on print, but will be dis-
played as dimmed, when the project pages are displayed on the screen.

Making symbols invisible

You can make symbols invisible like this:

a) Via the Component data dialog box: Click on the Symbols button, double-
click on the symbol, which opens the dialog box Component data, where 
you remove the check mark in front of Visible, and click OK.
Or:

b) By right-clicking: Click on the Symbols button, right-click on the symbol, and 
choose Invisible.

If you right-click after having selected an area in which both visible and invisible 
symbols exists, you will both be able to choose Visible and Invisible. You can then 
choose whether all symbols in the area shall be visible or invisible:

For symbols with reference crosses, the reference crosses also becomes invisible.

— Please read “Visible” on page 176 also.

THIS CHAPTER DESCRIBES

— MAKING SYMBOLS INVISIBLE ....................................................................... p. 69

— MAKING LINES INVISIBLE ............................................................................. p. 70

— MAKING TEXTS INVISIBLE ............................................................................ p. 70

— MAKING CIRCLES/ARCS INVISIBLE............................................................... p. 70

— MAKING AREAS INVISIBLE ........................................................................... p. 70

— SUB DRAWINGS AND INVISIBLE OBJECTS...................................................... p. 71
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Making lines invisible

Choose Lines, select an area 
containing the lines you wish 
to make invisible.

Then do the following:

a) Via the dialog box Line 
article data: Right-click 
and choose Compo-
nent data.
In the dialog box Line 
article data: Remove 
the Visible check mark, 
and click OK.
Or:

b) Directly from the right-click menu: Right-click in the area, and click on Invisi-
ble.

The lines are made visible again by right-clicking and then choosing Visible, or by 
entering the Line article data dialog box, and setting a check mark in front of Visi-
ble.

Making texts invisible

You can make texts invisible like this:

a) Via the Text properties dialog box: Click the Texts button, click on the text, 
click on the Text properties button, remove the check mark in front of Visi-
ble text, and click OK. — See “Visible text” on page 136.
Or:

b) By right-clicking: Click the Texts button, right-click on the text and choose 
Invisible.

Invisible texts are not displayed on screen, and can be selected by pressing the 
<Alt> button while clicking where the text would have been, if it was visible.

To make the text visible again, you must then click on the Text properties button, 
select Visible text, and click OK.

Making circles/arcs invisible

Choose Circles, right-click on the circle refer-
ence point, and choose Invisible.

To make the text visible again, right-click on the 
circle reference point again, and choose Visi-
ble.

Making areas invisible

 1) Click on the Area button and select the 
area — see “Areas” on page 270.

Right-click and choose

Component data
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 2) Right-click in the area and choose Invisible.

If you right-click after having selected an area in which both visible and invisible 
objects exists, you will both be able to choose Visible and Invisible. Hereby you 
choose whether to make all objects in the area either visible or invisible. — See the 
image below “Making symbols invisible” on page 69.

Sub drawings and Invisible objects

When inserting sub drawings, the functions described above makes it easy to sub-
sequently make parts of the sub drawings invisible.

— See “Sub drawings” on page 289.
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LINES

When you work with lines, you always start by clicking the Lines button — or by 
using the short-cut key <l>. — See “Auto command change” on page 57 also. If 
you want to draw lines, you then click the Pencil, or right-click on the drawing area 
and choose Draw Line.

The general short-cut key for the Pencil is the <Ins> key, but you can also use the 
<l> key when you are working with Lines. Pressing the <Ins> or the <l> key acti-
vates/deactivates the Pencil.

— See how to move, copy and delete lines in “Working with selected objects” on 
page 58, and see how to transfer data between lines in “Transferring Data / Proper-
ties between Objects” on page 62.

THIS CHAPTER DESCRIBES

— THE TWO TYPES OF LINES IN Automation................................................p. 73

— THE FUNCTIONS IN THE LINES TOOLBAR ......................................................p. 73

— DISCONNECTING DRAWN LINES ...................................................................p. 78

— LINES IN THE PICKMENU .............................................................................p. 79

— CONDUCTING (ELECTRICAL) LINES...............................................................p. 79

— ARTICLE DATA ON LINES .............................................................................p. 80

— AUTOMATIC INSERTION OF ELECTRICAL POTENTIALS ....................................p. 86

— JUMPER LINKS............................................................................................p. 91

— AUTOMATIC LINE DRAWING / ROUTER..........................................................p. 94

— EXTENDED LINES........................................................................................p. 95

— FOLLOW CONNECTED LINES ........................................................................p. 95

— THE TRIM LINE FUNCTION ...........................................................................p. 97

— DRAWING BY MEASURES.............................................................................p. 98

— MOUNTING CORRECT DRAWING.................................................................p. 100

AUTOMATIC LINE DRAWING

YOU CAN ALSO USE THE AUTOMATIC LINE DRAWING FUNCTION (ROUTER) IN 

Automation. THIS FUNCTION CAN BE ACTIVATED WHEN YOU ARE WORKING 

WITH LINES AND SYMBOLS.

— SEE “Automatic line drawing / Router” on page 94.

AUTOMATIC INSERTION OF ELECTRICAL POTENTIALS

Automation CAN INSERT ELECTRICAL POTENTIALS AT THE UPPER AND 

LOWER PART OF DIAGRAM PAGES AUTOMATICALLY. — SEE “Automatic 
insertion of electrical potentials” on page 86.
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THE TWO TYPES OF LINES IN Automation

You can draw two different types of lines in Automation:

a) Conducting (electrical) lines

b) Non conducting / free lines

If Conducting lines is active, the line can only be used as an electrical connection. 
The first time you click the Lines button, Conducting lines is activated automati-
cally.

Conducting lines are described in further detail in “Conducting (electrical) lines” on 
page 79. — Please note that you can specify how to represent crossing non-con-
nected conducting lines on diagram pages in “Pointer/Screen” on page 906.

If Conducting lines is not activated, the lines will be general purpose (non conduct-
ing) lines that can be used anywhere within the project.

THE LINES TOOLBAR

The toolbar for lines looks like this:

In the following you can see the functions of the buttons in the toolbar. — Please 
note that you can also place lines in the pickmenu, as described in “Lines in the 
Pickmenu” on page 79.

Straight lines

When you are drawing Straight lines, the lines are automatically drawn either 
right-angled or diagonally, then see “Pointer/Screen” on page 906).

Deactivate the Conducting lines button (click on the left-
most button if it is highlighted), and activate the Straight 
lines button. Click where you want your line to start.

Then click once for each time you want your line to change 
direction, and double click to stop drawing the line — or click 
once and press <Esc> to stop drawing.

If the Pencil is deactivated (press <Esc>), you can change the course of the line by 
clicking and dragging in its terminal points, or where the line breaks.

When you try to move a line by dragging the line from a connection point, an extra 
line point is inserted on the line.

If you want to insert an extra line point, you can right-click on the line, and choose 
Insert Line Point.

JUMPER LINKS

IT IS ALSO POSSIBLE TO DRAW JUMPER LINKS, AS DESCRIBED IN “Jumper 
links” on page 91.
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Slanted lines

When you draw Slanted lines, you determine the angles of the lines yourself.

Click the Slanted lines button, and draw a line like the 
one you see here.

The line will become as you draw it, depending on the 
snap you are working in. — Read more about snap in 
“Snap” on page 47.

If the Pencil is deactivated (press <Esc>), you can 
change the course of the line by clicking and dragging in 
its terminal points, or where it changes its direction.

Breaks on the line is indicated as for straight lines.

Angled lines

Drawing Angled lines you only 
have to point out where the line 
starts and ends. The program then 
creates an angled line automati-
cally. To let the line bend in the 
opposite direction, press the 
<spacebar>.

These are applied automatically in 
connection with mounting correct 
drawing. Please refer to “Mounting 
correct drawing” on page 100 for 
further details.

Curved lines

Click the Curved lines button.

Using this command enables you to draw curves. Click where you want the turn-
ings of the curve. Note the marks (+) that appear on the curve when you finish 
drawing it.

If the Pencil is deactivated (press <Esc>), you can change the 
curve by clicking and dragging in its marks (+).

Curved lines can only be drawn using solid lines.

Round lines

Click the Round lines button.

This command enables you to create coherent round lines. 
These can be used for corrections or for “comics bobbles.”

Round lines are half circles, drawn counter-clockwise. Round 
lines can only be drawn using solid lines.

As for curved lines, you can change the round lines by click-
ing and dragging in the marks (+).

Click here

... and here
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Rectangles

Click the Rectangle button.

Thus you draw a rectangle: Click where you want one of the corners to be located, 
drag the mouse, and when the rectangle is as desired, click again. You have now 
drawn a rectangle.

Folding a corner on a rectangle

To fold a corner on a rectangle, do this:

 1) Deselect the pencil (press <Esc>)

 2) Right-click on the line close to the corner and choose Fold corner

 3) Click to specify where to fold the corner

This function can be used for closed lines and reference frames. — See “Changing 
the shape of reference frames” on page 409.

Filled areas

If you activate the Filled areas button before you start drawing, you can fill out 
colored areas in rectangles, circles and ovals as you draw lines. If Filled areas can 
not be selected, the button will be dimmed.

Line type: T

Click in the field specifying line types and select the type you wish to use for draw-
ing.

These line types can not be

used as conducting lines
These line types can be used
as conducting lines
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— Please note that the lower of the line types to the left is yellow/green, for PE 
connections.

Line width: B

Here you determine the width of the pen used to draw the 
line. If the line type is hatched or similar, the line width is the 
width of the two borders of the line. (See the figure).

Line distance: A

For line types that are drawn with two full drawn lines (as a 
hatched line), you must specify the distance between these 
two lines. This is called the line distance, and it is measured 
from the centre of the one line to the centre of the other (See 
the figure).

SHORT CUT FOR CHANGE OF LINE TYPE

IN ORDER TO QUICKLY CHANGE LINE TYPE FOR A DRAWN LINE, JUST SELECT 

THE LINE AND PRESS <SPACEBAR>. HEREBY YOU SWITCH DOWN TO THE 

NEXT AVAILABLE LINE TYPE IN THE LIST. IF YOU PRESS <SHIFT> WHILE 

PRESSING <SPACEBAR>, YOU MOVE UPWARDS IN THE LIST OF LINE TYPES.

YOU CAN ONLY SWITCH BETWEEN SIMILAR LINE TYPES — MEANING LINE 

TYPES THAT CAN BE USED FOR CONDUCTING AND NON-CONDUCTING LINES 

RESPECTIVELY.

Line distance

Line width
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Line color: F

When you click here, you can choose the 
line color. You have these options:

Basic colors

Here you can choose fifteen predefined 
colors or the color NP (Non Printable), 
which will be displayed on screen, but not 
on print.

Custom colors

These colors you can define yourself, as 
described in “Custom colors” on page 862.

Other colors

Here you can choose among the most 
recently used colors.

More colors

Here you can freely select a color of your 
own choice.

Extend line

See how to use the Extend line button in “Extended lines” on page 95.

Conducting lines

See how to use the Conducting lines button in “The two types of lines in Automa-
tion” on page 73.

Jumper links

See how to work with Jumper links in “Jumper links” on page 91.

Mounting correct drawing

See how to apply Mounting correct drawing in “Mounting correct drawing” on 
page 100.

Without wire number

When you use the Without wire number button, you can deselect wire numbering 
for individual lines in the project. Read more about this in “Deselecting wire numbe-
ring for individual lines” on page 444.

Follow connected

When you are working in the Edit symbol mode, the button Follow connected also 
appears in the toolbar for Lines. Read more about this in “Follow connected lines” 
on page 95.
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Insert potential

See how to use the Insert potential button for automatic insertion of electrical 
potentials in “Automatic insertion of electrical potentials” on page 86.

DISCONNECTING DRAWN LINES

You can disconnect a drawn line, and subsequently connect the end point of the 
line elsewhere in the diagram page. This can be done:

- For lines connected to symbols

- For lines connected to other lines

To move the end point for a drawn line, do this:

 1) Press the <Ctrl> key while clicking on the line close to the end point. (Do not 
click directly on the end point, because this makes it unclear which of the 
lines meeting in the point, that you wish move).

 2) Drag the end point to its new position.

 3) Release the mouse button. The end point of the line is now moved.

1 2 3
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LINES IN THE PICKMENU

To get quick access to drawing lines with predefined properties, you can place lines 
with the desired properties in the pickmenu at the upper part of the screen.

When you click on one of the lines in the pickmenu, the program automatically 
changes to working with Lines and the Pencil button is activated. You can then 
draw lines with the selected properties. — Read more about line properties in 
“Transferring Data / Properties between Objects” on page 62.

To insert a line type in the pickmenu, right-click on an empty cell in the pickmenu, 
and select Place Line. The currently applied line type is hereby inserted in the 
selected cell in the pickmenu.

If the pickmenu is not displayed on the screen, you can activate the pickmenu by 
selecting Settings => Pointer/Screen and click on Pickmenu.

The pickmenu can also contain symbols, texts and arcs. — Read more about the 
pickmenu in “Fetching symbols from the Pickmenu” on page 152 and “Adapting the 
Pickmenu” on page 198.

CONDUCTING (ELECTRICAL) LINES

A conducting line is an electrical line. It can start and end in electrical points only. 
An electrical point can be another conducting line, a connection point on a symbol 
or a signal.

To specify that a line has to be conducting, you must activate the Conducting 
lines button.

If you try to start or end a con-
ducting line without specifying 
a electrical connection, you 
will be asked about a signal 
name or whether the line 
should be parked.

A signal symbol with a signal 
name signifies an electrical 
connection.

This means that all electrical 
points with identical signal 
names, are the same electrical 
potential.

— Read more about signal 
symbols in “Signal symbols” 
on page 225, and about reference designations on signal symbols in “Variant 
names on signal symbols” on page 230.

Symbols/drawing objects displayed in all pickmenus

Select different menus

in the pickmenu

Click on a line, and

place it in the diagram
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Parking

If you want to wait to decide what the conducting line is to be connected to, you 
choose Parking. Thus the line gets no electrical connection. However, this is just a 
temporary solution, and there should never be parked lines in a completed project.

When you later return to place a signal symbol, just right-click on the parked end of 
the line and choose Place signal symbol.

Warning when connecting non conducting lines to symbols

If you connect a non conducting line with a symbol, you will be warned about this. 
You will be allowed to do so if you insist, but the program draws no connection dot.

Show conducting

At any time you can choose Functions => Show conducting to see which lines 
are conducting. Conducting lines turn green, and non-conducting lines turn red. To 
disable this function choose Functions => Show conducting once more.

Transferring data for conducting lines

Please note that non-conducting lines can become electrical by using the transfer 
data function.

— Read more about this in “Transferring Data / Properties between Objects” on 
page 62.

ARTICLE DATA ON LINES

When you wish to place article data on a line, deselect the Pencil and double-click 
on the line — or right-click on the line, and select Line article data. You then enter 
the dialog box Line article data:

Here you can for instance click on Database, to fetch article data from the data-
base — see “Using the database” on page 629, in particular “Using the database 
for Lines” on page 629.

Specify if the

line is visible
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— Please note that you can also attach article data to cable symbols, as described 
in “Working with cable symbols” on page 239.

Visible Line article data

When you select Visible for one of the article data fields, the contents of this field 
is displayed on the diagram, as illustrated for the Name and Type fields in the fig-
ure below.

When article data for a line is set to be visible, they are placed above the middle of 
the longest segment on the line. — In “Text anchor for linedata” on page 81 you 
can see how to place them next to another segment of the line.

If this segment later disappears — e.g. by deletion or because a symbol is placed 
— the article data are made invisible.

You can specify which article data to display for lines, as a general setting for the 
project. To do this, select Settings => Text/Symbol defaults and then choose 
Line under Text defaults. Read more about this in “Texts displayed in the project 
(general setting)” on page 138.

You can also specify whether to place the texts Aligned or Above (as in the figure 
above).

You can move these article data texts, as you can move any other text in the pro-
gram.

If you select Replace line texts, the texts are placed where the program would 
place these.

Text anchor for linedata

To show line data next to a specific line segment, do this:

 1) Activate the Lines command and deselect the Pencil.

 2) Right-click on the segment and select Text anchor. (If the text is already 
anchored to the selected segment, Text anchor is dimmed).
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Line datafields

If line datafields have been created in the project, you can click the Line data 
fields tab at the lower part of the dialog box and type in the values for the line data 
fields. Please note that when you copy line data for a line, the contents for any 
attached line data datafields are also copied.

— Line datafields are created like you create symbol datafields. Read more about 
this in “Creating symbol datafields” on page 798.

— See how to include line datafields in lists in “Inserting datafields in lists” on 
page 85.

Calculated line datafields (Formula editor)

It is also possible to create calculated line data fields, which can be a combination 
of line data, texts and other line data fields. Thus you can combine multiple line 
data fields in a single line data field.

You can create a calculated line data field like this:

CREATE THE NECESSARY LINE DATA FIELDS

 1) Choose Settings => Text/Symbol defaults. In the Symbol defaults set-
tings: Click on Line data fields.

 2) Under Line data fields: Click the Add button and type in the name of the 
line data field — for instance FieldA. Also create the line data fields FieldB 
and FormulaExample.

CREATE A CALCULATED LINE DATA FIELD

 3) Now click the Formula editor button:

THE LINE DATAFIELD ROUTINGCLASS IS FOR THE PANELROUTER

ON THE TAB LINE DATAFIELD THERE IS ALREADY CREATED A LINE DATA-

FIELD WITH THE NAME ROUTINGCLASS. THIS DATAFIELD IS USED FOR SPEC-

IFYING THE ROUTING CLASS, WHICH YOU CAN READ MORE ABOUT IN THE 

MANUAL FOR THE PANELROUTER.
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 4) You now enter the Formula editor, where you can specify how to create/cal-
culate the line data field:

 5) Select Line data, Line data fields and/or Static text and click Add, which 
adds the selected data fields / texts to the Formula line in the upper part of 
the dialog box — with the correct syntax.
Under Result you can see how the calculated data field will appear when 
inserted on the project pages.

 6) When the formula is complete: Click OK.

EDIT THE FORMULA MANUALLY

If you need to edit the formula manually, just select Edit formula manually in the 
lower-left corner of the dialog box. When you have edited the formula manually, 
click the Validate formula button to check that the syntax is still correct.

Click Clear formula if you want to delete the formula.

DISPLAYING CALCULATED DATA FIELDS ON PROJECT PAGES

When you have created a calculated line data field, as in the example above, you 
can insert it in a project like this:
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 1) Double-click on a line and fill out the dialog box Line article data as dis-
played below, where you only set the line data field FormulaExample to be 
visible:

 2) The line data field FormulaExample for the line is now displayed like this in 
the project:
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Select name and Object Lister - for lines with line data

When working with lines, you can select lines with line data in the project by choos-
ing Functions => Select name. This functions the same way as for symbols, 
which you can read more about in “Find all symbols with identical names” on 
page 264.

You can also use the Object Lister to work with lines with line data.
— See “The Object Lister” on page 341.

Pop-up information with Line article data

If Settings => Pointer/Screen => Show popup information is selected, article 
data for lines are displayed when the cursor is placed over lines — when the Pencil 
is not activated.

Datafields for Line data

In all electrical lists — terminal, cable, connection and PLC lists — you can insert 
datafields with Line-name, Line-type, Line-article no. and Line-function. — See 
“Datafields in Automation” on page 931.

Inserting datafields in lists

When you have created a line datafield, you can subsequently insert it in parts, 
components, terminals, cables, PLC and connections lists. When you edit the list 
page, just choose Insert => Insert Datafield, which opens the dialog box Data-
field. Here you can choose Parts/Components List and select the desired data-
field at the bottom of the list of datafields.

Priority on lines

If you have set up the program to draw arcs when non-connected conducting lines 
cross — see Representation of crossing non-connected conducting lines in 
“Pointer/Screen” on page 906 — you can use Priority to specify which of crossing 
lines are drawn with arcs. This is done by setting a Low, Normal or High priority 
for the lines.

The following rules applies:

• When two lines with different priorities cross, the line with the highest priority is 
drawn without an arc.

• When two lines with the same priority setting cross, the horizontal line has the 
highest priority.
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AUTOMATIC INSERTION OF ELECTRICAL POTENTIALS

Inserting electrical potentials automatically

When you wish to let Automation insert electrical potentials automatically, click 
the Insert Potential button, or choose Insert => Insert Potential.

You then enter the dialog box Insert potential, where you specify which electrical 
potentials to insert:

From this dialog box you can place one or more electrical potentials, either on the 
upper or the lower part of the page — or both at the same time:

THIS CHAPTER DESCRIBES

— INSERTING ELECTRICAL POTENTIALS AUTOMATICALLY...................................p. 86

— PLACING ELECTRICAL POTENTIALS ON THE UPPER PART OF THE PAGE ..........p. 87

— PLACING ELECTRICAL POTENTIALS ON THE LOWER PART OF THE PAGE .........p. 87

— POSITION FOR THE ELECTRICAL POTENTIALS ...............................................p. 88

— REFERENCE TEXTS FOR AUTOMATICALLY PLACED ELECTRICAL POTENTIALS ..p. 88

— REFERENCE DESIGNATIONS FOR AUT. PLACED ELECTRICAL POTENTIALS .......p. 88

— SETTINGS FOR AUTOMATICALLY PLACED ELECTRICAL POTENTIALS ................p. 88

— INSERTING SIGNAL NAMES IN THE SIGNAL NAME LIST ...................................p. 90
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Inserting electrical potentials on the upper part of the page

In the Number field in the dialog 
box, you specify the number of 
potentials you wish to place at the 
upper part of the page.

Subsequently, you can specify 
which signal names to insert.

You have two options:

a) All signal names are fetched 
from the Signal name list: 
Select a signal name below 
Signal name, and click on 
Follow list from selected. 
The names for the selected 
Number of potentials, are 
selected from the Signal 
name list, starting from the 
selected signal name. If 
Number is set to 4, and you have clicked on L1 — as in the figure above — 
the potential names L1, L2, L3 and N are inserted.

b) The signal names are incremented starting with the selected Signal name: 
Choose a signal name under Signal name, and click on Count up from 
selected. The name on the first signal name is then selected from the Signal 
name list, and the subsequent names are incremented by one, as they are 
placed.
If Number is set to 4, and you have clicked on L1, the electrical potentials L1, 
L2, L3 and L4 are inserted.

To only place electrical potentials on the upper part of the page, click the Upper 
button in the right-hand side of the dialog box.

— Please also refer to “Specify Level for the electrical potentials” on page 88, 
“Reference text for automatically placed electrical potentials” on page 88, “Refe-
rence designations for automatically placed electrical potentials” on page 88, “Set-
tings for automatically placed electrical potentials” on page 88 and “Signal names 
on the Signal name list - for automatically inserted electrical potentials” on 
page 90.

Inserting electrical potentials on the lower part of the page

In the Number field below Lower potential in the dialog box, you specify the num-
ber of potentials you wish to place on the lower part of the page.

You can then specify which signal names you wish to apply, following the same 
principles as described in "Inserting electrical potentials on the upper part of the 
page" på side 87.

To only insert potentials on the lower part of the page, click the Lower button in the 
right-hand side of the dialog box.

If you wish to insert potentials on the upper and the lower part of the page in the 
same operation, click the Both button.

Because Number is set to 4

these four signal names are

The signal names that

will be inserted

inserted from the list
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— See also “Specify Level for the electrical potentials” on page 88, “Reference text 
for automatically placed electrical potentials” on page 88, “Reference designations 
for automatically placed electrical potentials” on page 88, “Settings for automati-
cally placed electrical potentials” on page 88 and “Signal names on the Signal 
name list - for automatically inserted electrical potentials” on page 90.

Specify Level for the electrical potentials

If it says 1 in the Level field, the first electrical potential is placed where the func-
tion is set up to place the first electrical potential.

If it e.g. says 3 in the Level field, the potentials are placed starting from where the 
function would have placed the third potential.

— See “Settings for automatically placed electrical potentials” on page 88.

Reference text for automatically placed electrical potentials

To use references for the inserted electrical potentials, select With reference, and 
type in a reference pretext in the Reference text field — if desired.

Reference designations for automatically placed electrical potentials

If you wish to attach reference designations to the automatically inserted electrical 
potentials, click on Select below Reference designations, and choose a refer-
ence designation as described in “Choosing reference designations when placing 
symbols” on page 401.

If you want to display the full reference designation for the potentials, select Show 
full Reference designation, as described in “Show full Reference designation” on 
page 402.

Settings for automatically placed electrical potentials

The placing positions for the automatically placed electrical potentials can be set 
up individually for each individual page size.

This can be done by choosing Insert => Insert Potential, and then click on Setup. 
You then enter the dialog box Insert potential - Setup:

THE SELECTED LINE TYPE IS USED

WHEN INSERTING ELECTRICAL POTENTIALS AUTOMATICALLY, THE LINE TYPE 

YOU HAVE SELECTED BEFORE CHOOSING INSERT => INSERT POTENTIAL IS 

USED FOR DRAWING THE POTENTIALS.

— SEE “Line type: T” on page 75.
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Here you choose — at the top — which page size you wish to edit the settings for, 
make the changes, click on Apply, and then click OK.

Symbols inward

If you want to place the text for the signal symbols above the electrical potentials, 
click on Symbols inward.

Choosing signal symbols

To select which signal symbol to apply, click the SGSIGNAL button, and you enter 
the Symbol menu, where you select the symbol.

Individual setup of signal symbols

If you wish to use an individual setup for the applied signal symbols, click on Indi-
vidual setup of signal symbols.

Select page size for the settings

Y-position for the

upper potential

Y-position for the

lower potential

Distance between

potentials

X-position for right and left

side of potentials

Click here to apply the

settings
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The dialog box then changes appearance, and you get the option to make an indi-
vidual Symbol inward setup, and to choose signal symbol for all four possible 
positions for the signal symbols:

Signal names on the Signal name list - for automatically inserted electrical
potentials

To specify which potential names that 
appears in the Signal name list — see 
“Inserting electrical potentials on the 
upper part of the page” on page 87 —, 
you must choose Insert => Insert 
potential, click on Setup, and here 
click on the tab Signals.

Here the columns Upper signal names 
and Lower signal names appears, for 
specifying the signal names in the Sig-
nal name list for the upper and lower 
electrical potentials respectively.

Edit the lists as described below, and 
then click Apply.

ADDING A SIGNAL NAME

Click on the Plus button, and type in a new signal name.

REMOVING A SIGNAL NAME

Click on the signal name in the list, and click the Minus button.

MOVING A SIGNAL NAME IN THE LIST

Click on the signal name in the list, and click the Up / Down arrows, until the name 
has the desired position in the list.

Click here for an individual setup for the applied signal symbols
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JUMPER LINKS

On drawing Jumper links

In Automation it is possible to work with jumper links. Succeedingly, these jumper 
links can be included in terminal lists and terminal plans automatically. Jumper 
links are not assigned wire numbers during automatic wire numbering.

Drawing jumper links

To draw jumper links, do the following:

 1) Click on the Lines button, and click on the Pencil.

 2) Click on the Jumper links button, and draw the jumper links.

Jumper links can be drawn from all types of connection points. Jumper links can 
not start on the middle of another line, or on the middle of another jumper link.

When you start and end drawing a jumper link, a short message is displayed, 
informing you that you are drawing a jumper link.

Jumper lines in the pickmenu Lines and Texts

You can also place jumper links by clicking on the tab for the pickmenu Lines and 
Texts, and click on one of the jumper line symbols in the pickmenu.

The dot in the middle of the jumper line symbols displays the colour of the jumper 
lines.

THIS CHAPTER DESCRIBES

— ON DRAWING JUMPER LINKS....................................................................... p. 91

— DRAWING JUMPER LINKS ............................................................................ p. 91

— JUMPER LINKS IN LISTS AND TERMINAL PLANS............................................. p. 92
mation

Page 91



P

Lines
Changing jumper links to electrical lines - or the reverse

You can change a jumper link to an electrical line — or change an electrical line to 
a jumper link — by transferring line properties, as described in “Transferring Object 
properties between Objects” on page 63.

Show jumper links

When you choose Functions => View Jumper Links, all jumper links are dis-
played as green lines on the screen, while everything else are displayed in red. To 
disable the function, choose Functions => View Jumper Links once again.

Jumper links in Lists and Terminal plans

Under Functions => Datafield, you will 
now find the datafield Terminals list => 
Jumper link.

This datafield is displayed graphically in 
terminals lists. The result of placing this 
datafield can be seen in the list to the right.

When the datafield is placed on the left-
hand side of the terminals, you must make 
it right-adjusted, so that it expands to the 
left.

When the datafield is placed on the right-
hand side of the terminals, you must corre-
spondingly make it left-adjusted, so that it 
expands to the right.

There is a similar jumper link datafield for 
connections lists.

Article data for jumper links in parts and components lists

You can also get article data from jumper links in the parts and components lists.

— See “Article data on lines” on page 80 and “Which data to include in the list” on 
page 598.

CORRECT AMOUNT OF JUMPER LINKS IN PARTS LISTS

In the PINDATA field of the database, you can specify how many connections a 
jumper link with a specific article number has. When a jumper link for instance has 
two connections (three terminals), write #2 in the PINDATA field. For a jumper link 

SPECIFYING LINE SETTINGS FOR JUMPER LINKS

UNDER SETTINGS => BASIC SETTINGS YOU CAN SPECIFY HOW JUMPER 

LINKS APPEARS IN PROJECTS. READ MORE ABOUT THIS IN “Basic settings” 
on page 925.

— READ MORE ABOUT LINE SETTINGS IN “The Lines toolbar” on page 73.

Place right-

adjusted data

fields here

Place left-

adjusted data

fields here
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for one connection (two terminals), write #1. If you do not specify any value, it is set 
to 1 by default.

For jumper links, you can use the field UnitPrPack to specify the number of possi-
ble connections. This makes it possible to specify the needed amount of jumper 
units in the parts list. (The field UnitPrPack is specified in the database under Set-
tings => Database => Database Setup => Component data next to the field 
Units/Pack).

If the number of connections is not specified for the jumper link in the database, it 
will appear with the quantity 1 in the parts list. — Both when article data is speci-
fied for the jumper link and when it is not.

JUMPER LINKS IN TERMINAL PLANS

Jumper links can also be included in terminal plans. Here a special terminal sym-
bol for displaying jumper links have been designed.

Read more about this in the PCSCHEMATIC Tools manual.
mation

Page 93



P

Lines
AUTOMATIC LINE DRAWING / ROUTER

When you place symbols in a project, you can make Automation draw the symbol 
connections automatically.

When drawing lines, you can also let the program do a part of the job for you.

Automatic line drawing when placing symbols

To use the router when placing Symbols, 
you first choose Router => Active, to set a 
check mark in front of Active.

To deactivate the router, choose Router => 
Active again, so that the check mark disap-
pears.

You will find the following options in the 
Router menu:

SHORT-CUT KEYS FOR OPTIMAL USE OF THE ROUTER

TO MAKE THE ROUTER FUNCTION THE BEST, YOU MUST CREATE SHORT-
CUTS KEYS FOR THE ROUTER FUNCTIONS YOU USE THE MOST.

SEE “User defined short-cut keys” on page 858.

ROUTER => FUNCTION

ACTIVE <½> STARTS AND STOPS THE ROUTER

ONLY NOT CONNECTED 

SYMBOLS BY MOVE

THE ROUTER IS ACTIVATED WHEN A SYMBOL IS MOVED, IF THE 

SYMBOL IS NOT CONNECTED.

ONLY IF ALL IN DIRECTION 

POSSIBLE

THERE WILL ONLY BE ROUTED WHEN ALL CONNECTIONS IN THE 

CHOSEN DIRECTION CAN BE ROUTED.

ONLY TO NEAREST DIREC-

TION <2>
THERE WILL ONLY BE ROUTED FROM THE SIDE OF THE SYMBOL, 
WHICH I CLOSEST TO A LINE OR OTHER CONNECTION POINTS.

HORIZONTAL THERE WILL ONLY BE ROUTED HORIZONTALLY.

LEFT THERE WILL ONLY BE ROUTED TO THE LEFT.

RIGHT THERE WILL ONLY BE ROUTED TO THE RIGHT.

VERTICAL THERE WILL ONLY BE ROUTED VERTICALLY.

UP THERE WILL ONLY BE ROUTED UPWARDS.

DOWN THERE WILL ONLY BE ROUTED DOWNWARDS.

REVERSE ORDER <3> CHANGES THE ROUTING ORDER, WHEN ROUTING TO MORE THAN 

ONE LINE.

SKIP OVER LINE <<> THE ROUTER SKIPS A LINE AND ROUTES TO THE NEXT LINE.

ROUTE <1> IF AN ALREADY PLACED SYMBOL IS SELECTED, THE SYMBOL CAN 

BE ROUTED.
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The router for lines

To apply the router for drawing Lines 
choose Router => Active, to set a 
check mark in front of Active.

To disable the router choose Router 
=> Active again, and the check mark 
disappears.

You have the following options in the 
Router menu for lines:

Pressing the spacebar changes the direction of the router.

 EXTENDED LINES

On all types of lines, you can determine that they shall be 
extended. Select the Extend line button on the toolbar. 
The line will now start half a line width before its starting 
point, and end half a line width after its ending point.

The lower example on the figure is drawn using Extend 
line.

When you draw continuously without stopping when the 
line breaks, extend lines will be chosen automatically.

The upper example is drawn as two independent lines, 
without selecting Extend line.

FOLLOW CONNECTED LINES

This button exists in Edit symbol only. If the symbol is 
designed using Follow connected lines, the lines in the symbol will automatically 
get the same width and color as the conducting lines that are connected to the 
symbol in the project.

ROUTER => FUNCTION

ACTIVE <½> STARTS AND STOPS THE ROUTER.

ANGLED <CTRL+SPACE-

BAR>
CHANGES BETWEEN STRAIGHT AND ANGLED LINES

HORIZONTAL LINES ROUTES ONLY HORIZONTAL LINES.

VERTICAL LINES ROUTES ONLY VERTICAL LINES.

UP/LEFT ROUTES UP/LEFT WHEN WORKING WITH ANGLED LINES.

DOWN/LEFT ROUTES DOWN/LEFT WHEN WORKING WITH ANGLED LINES.

DOWN/RIGHT ROUTES DOWN/RIGHT WHEN WORKING WITH ANGLED LINES.

UP/RIGHT ROUTES UP/RIGHT WHEN WORKING WITH ANGLED LINES.

SKIP OVER LINE <<> THE ROUTER SKIPS A LINE AND ROUTES TO THE NEXT LINE.

1) Place the cursor here

2) Press the <<> button until th

desired line is selected

3) Click to draw the connection
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In the symbol to the left all lines are drawn using Follow connected. Therefore all 
lines in the symbol gets the same width and color as the conducting line, that can 
be seen between the connection points of the two symbols. The other symbol is 
designed without Follow conducting.

A symbol designed using Follow connected, adapt to the last line that was con-
nected to the symbol.

Follow connected can be deactivated as a general setting

Follow connected on symbols can be activated/deactivated by choosing Settings 
=> Text/Symbol defaults, and then activate/deactivate Activate Follow con-
nected on symbols.

— See “Text/Symbol defaults” on page 921, particularly “Activate Follow connected 
on symbols” on page 924.
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THE TRIM LINE/EXTEND LINE FUNCTION

The Trim line command can be used for two purposes:

 1) To extend a line, so that it meets another line.

 2) To truncate a line, so that it meets another line.

Extend a line using Trim line/Extend line

Do this to extend the vertical 

line (in the figure), so that it 
meets the horizontal line:

 1) Click the Lines button, 
and press <Esc> to 
disable the Pencil.

 2) Select the vertical line 
by clicking on it.

 3) Choose Edit => Trim 
line/Extend line.

 4) A thin line starting from 
the selected symbol 
and ending in the cross 
hairs is now displayed: 
Click on the horizontal 
line.

 5) The vertical line is 
extended, so that it 
meets the horizontal.

Trimming the selected
end

Before applying the Trim 
line/Extend line command, 
please click closest to that end of the line, which you wish to trim:

2

4

5

Click here before

selecting Trim line,

to trim this end
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DRAWING BY MEASURES

It is also possible to type in the exact measures of what you want to draw.

In the status line at the bottom of the screen, you can see the X-Y coordinates for 
the cursors location on the screen.

The coordinates to the left state the absolute location, while the coordinates to the 
right states the coordinates relative to where you last clicked (also called the rela-
tive coordinates).

Click on the X-Y coordinate field in the status line, or use the short-cut <Ctrl+i>. 
You now see a dialog box for typing in coordinates.

You can also enter this dialog box choosing Functions => Coordinates.

When you want to draw by measures, you have three options at hand:

Absolute coordinates

The measures are typed in referring to the 
origo of the page, located in the lower-left 
corner of the page.

Relative coordinates

The measures are typed in referring to the 
point last chosen on the page.

Polar coordinates

Here you draw by determining the length 
of the line, and the angle between the line 
and a horizontal line.

Example: Drawing a rectangle by measures

As an example of how to use absolute and relative coordinates, you can now draw 
a rectangle of 100 x 50 mm in different ways.

Click the Lines button, select line type, deactivate Conducting lines, and activate 
the Pencil.

Using Absolute coordinates

 1) Click on the X-Y coordinate field — or press <Ctrl+i>. Choose Absolute.

 2) Type 50 in the X field and 100 in the Y field. You do not have to specify that it 
is in millimetres, due to the system settings. Click OK. (This setting can be 
changed in Settings => Screen/Pointer. Read more about this i “Pointer/
Screen” on page 906). Click Next.

 3) Type 150 in the X field and 100 in the Y field. Click Next.

 4) Type 150 in the X field and 150 in the Y field. Click Next.
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 5) Type 50 in the X field and 150 in the Y field. Click Next.

 6) Type 50 in the X field and 100 in the Y field. Click OK.

 7) Press <Esc>. The rectangle is complete.

Using Relative coordinates

 1) Start the line by clicking anywhere on the screen.

 2) Click on the X-Y coordinate field — or press <Ctrl+i>. Choose Relative.

 3) Type 100 in the X field and 0 in the Y field. Click Next.

 4) Type 0 in the X field and 50 in the Y field. Click Next.

 5) Type -100 in the X field and 0 in the Y field. Click Next.

 6) Type 0 in the X field and -50 in the Y field. Click OK.

 7) Press <Esc>. The rectangle is complete.

Using the Rectangle command with relative coordinates

 1) Click on the Lines, the Rectangle and the Pencil buttons. Deselect Con-
ducting lines.

 2) Start the rectangle by clicking where you want one of the corners of your rec-
tangle.

 3) Click on the X-Y coordinate field — or press <Ctrl+i> — and choose Rela-
tive.

 4) Type 100 in the X field and 50 in the Y field. Click OK.

 5) The rectangle is now complete.
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MOUNTING CORRECT DRAWING

Automation is able to support mounting correct drawing automatically. — In the 
IEC 61082 standard this is also called combined circuit and connection diagram.

On mounting correct drawing

In Automation you can create mounting correct drawings on equal terms with how 
you normally draw diagrams with connection dots:

• In Automation you can mix mounting correct drawing and normal drawing 
mode.

• You switch between mounting correct drawing and normal drawing mode by 
clicking the Mounting correct drawing button.

• Where a connection dot automatically occur in normal diagram drawings, a 
branch figure is inserted in mounting correct drawing mode.

• You can start and end lines on other lines — with automatic insertion of branch 
figures.

• You can also use automatic line drawing / the router for mounting correct drawn 
lines, starting/ending on other lines. — See “Automatic line drawing / Router” 
on page 94.

• Placing sub drawings by drag’n draw or by selecting Insert => Insert sub draw-
ing also handles mounting correct drawing. — See “Sub drawings and moun-
ting correct drawing” on page 103.

• Branch figures are moved automatically along with the lines, which they are 
placed on. You can therefore move e.g. an electrical potential L1 — which is 
placed on the upper part of a page — up or down, just by moving one single 
line, branch figure or signal symbol on the electrical potential.

THIS CHAPTER DESCRIBES

— ON MOUNTING CORRECT DRAWING ........................................................... p. 100

— SETTINGS FOR MOUNTING CORRECT DRAWING ......................................... p. 101

— DESIGN CHECK FOR MOUNTING CORRECT DRAWING .................................. p. 102

— SIGNAL NAMES IN MOUNTING CORRECT DRAWING ..................................... p. 103

— SUB DRAWINGS AND MOUNTING CORRECT DRAWING.................................. p. 103

— CHANGING TO MOUNTING CORRECT DRAWING .......................................... p. 104

— CHANGING TO NOT MOUNTING CORRECT DRAWING ................................... p. 104

— CONVERTING PROJECTS FROM VERSION 8.0 AND PREVIOUS ...................... p. 104

MOUNTING CORRECT DRAWING RECOMMENDED

IF YOU ARE NOT SURE WHETHER TO DRAW MOUNTING CORRECT OR NOT IN 

YOUR DOCUMENTATION, IT IS RECOMMENDED TO DO SO IN Automation. 
THIS IS BECAUSE YOU CAN EASILY CONVERT MOUNTING CORRECT DRAWN 

PROJECTS TO NORMAL DRAWING MODE WITH CONNECTION DOTS, AS 

DESCRIBED IN “Change to Not mounting correct drawing” on page 104.
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In mounting correct drawing mode, there are no limitations on what you are 
allowed to draw. Errors in mounting correct drawing, are exclusively found via the 
Design Check function. — See “Design check for Mounting correct drawing” on 
page 102.

Settings for Mounting correct drawing

When you want to specify how to work with mounting correct drawings, choose 
Settings => Project data:

Here you can specify the bend size and which branch figure to suggest as default.

Bend

On the Project data tab, you also specify 
the size of the bend of the lines on mounting 
correct drawings.

In the Bend field you can change the size of 
the bend by clicking the down-arrow, and 
selecting a bend size. In the figure to the 
right, you can see how the size of the bend 
is specified.

It is recommended not to use the bend size 
5.0mm, because this does not give a clear 
result when e.g. three electrical potentials 
are placed with a distance of 5,0 mm.

It is recommended to use a bend size of 2,0 or 2,5 mm.

CHANGING THE APPLIED BEND SIZE IN A PROJECT

If you change the bend size used in a project, you will be asked whether to change 
the bend size in the existing branch figures in the project.

Branch figureBend size

Bend size
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Branch figures

After the bend size, you can choose which brand figure that the program shall sug-
gest initially, when drawing mounting correct:

When drawing mounting correct, the program will automatically place the latest 
applied branch figure. When pressing the <Spacebar> repeatedly before drawing 
further, you can change to one of the other branch figures.

Changing branch figures on lines

When you wish to use another 
branch figure on a line, then deac-
tivate the Pencil, click on the 
branch figure and press the 
<Spacebar> until the desired figure 
appears.

Having deselected the Pencil, you 
can also right-click on the branch 
figure, select Select figure, and 
select the new branch figure — as 
illustrated to the right.

Design check for Mounting correct drawing

To locate what is not mounting correct in the project, do this:

 1) Click the Design check button — or choose Functions => Design check.

 2) In the dialog box Design check: Click the Design check settings button.

 3) In the dialog box Design check settings: Select Mounting correct and 
click OK.
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 4) In the Design check dialog box you now get a list of all the parts of the pro-
ject, that are not drawn mounting correct:

Based on this list, you can correct the project and make sure it is mounting 
correct. (Please remember that you can click each line in the list, to see 
where the project is not mounting correct).

 5) — Read more about design check in “Design Check” on page 355.

Signal names in Mounting correct drawings

— See “Variant names on signal symbols” on page 230.

Sub drawings and mounting correct drawing

It is an advantage to draw all of your sub drawings mounting correct. Hereby you 
can use them for both mounting correct drawing, and for not mounting correct 
drawing.

When you drag one of these sub drawings into a project, which is not in mounting 
correct drawing mode, the branch figures are automatically converted to connec-
tion dots.

By drawing the sub drawings mounting correct, you therefore only need to maintain 
one single set of sub drawings, which can be applied for both purposes.
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Changing to Mounting correct drawing

You can convert diagrams to mounting correct drawing at different levels:

• For individual connections

• For all connections in an area on the page

• For pages

• For projects

Changing to mounting correct drawing - for individual connections,
pages and areas

 1) Click the Lines button in order to work with lines and press <Esc> to deacti-
vate the Pencil.

 2) Right-click on the line — or select an area using the mouse and right-click 
inside the area — and choose Dot to branch.

 3) Then choose either The selected (for individual connections), In the area or 
On this page.

 4) Branch figures are now inserted at the selected connections.

— Please check that Automation have inserted appropriate branch figures where 
it is not obvious which figure to insert.

If you wish to replace a branch figure, just click the branch figure and select 
another figure by pressing the <Spacebar>, as described in “Changing branch figu-
res on lines” on page 102.

Changing to Mounting correct drawing - for projects
Projects, which are not drawn mounting correct, can get branch figures inserted in
stead of the connection by selecting Functions => Special Functions => Con-
vert Dots to Branches.

— Please check that Automation have inserted appropriate branch figures where 
it is not obvious which figure to insert.

Change to Not mounting correct drawing

Projects, which are drawn mounting correct, can have inserted connection dots in 
stead of branches by selecting Functions => Special Functions => Convert 
Branches to Dots.

Converting mounting correct projects from version 8.0 and pre-
vious

Starting from Automation 9.0 an improved workflow for mounting correct drawing 
has been implemented. To convert mounting correct drawings from version 8.0 and 
previously, select Functions => Special Functions => Convert to Branches.

The connection dots in the project will then be converted to branch figures any-
where this is possible, and double-lines will be removed. — Please check that 
Automation have inserted appropriate branch figures where it is not obvious 
which figure to insert.
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Wire numbers when converting mounting correct drawings from previ-
ous versions

When converting mounting correct drawn projects from version 8.0 and previous, 
wire numbers will be moved, so that they uniquely identify which lines they are 
attached to.
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ARCS/CIRCLES

When you want to draw circles, you click the Circles button and activate the Pen-
cil. Circles have the short-cut key <c>. — See “Auto command change” on 
page 57 also.

The general short-cut key for the Pencil is the <Ins> key, but you can also use the 
<c> key when you are working with Circles. Pressing the <Ins> or the <c> key acti-
vates/deactivates the Pencil.

— Se how to move, copy, rotate and delete circles and arcs in the section “Working 
with selected objects” on page 58, and see how to transfer data between circles/
arcs in “Transferring Data / Properties between Objects” on page 62.

Please note, that circles and arcs can not be rotated.

The Circles toolbar

The toolbar for circles looks like this:

R is for the radius of the circle/arc.

V1 is for the arc start angle, V2 is for the arc end angle. 
The drawing is made counter-clockwise.

To draw a full circle V1 has to be 0 and V2 has to be 
360.
To draw a quarter circle V1 can be 180 while V2 is 270.
To draw a half circle V1 can be 45 while V2 is 225.
Whether the circle is to be filled out, is determined by 
clicking the Filled circles button on the toolbar.

Line width is determined in the field B:, while the color 
of the line and filling is determined in the field F:.

Selected arcs can be rotated by pressing the <Space-
bar>.

Circles / Arcs in the Pickmenu

To get fast access to drawing arcs with predefined properties, you can place arcs 
with the desired properties in the pickmenu at the upper part of the screen. This is 
done as described for lines in “Lines in the Pickmenu” on page 79.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO WORK WITH CIRCLES AND ARCS.
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Ellipses

Using the circle command also enables you 
to draw ellipses. The last field E: in the tool-
bar of the circle command is an ellipse factor.

If the factor is set to 1 you will get an ordinary 
circle. Apart from this, see the impact of the 
different factors on the figure below.

When you fill out both V1 and V2 you can 
also draw arcs.

Converting circles and ellipses to lines

When you want to change a circle to lines, you do this by selecting the circle and 
then choosing Edit => Convert to lines.

When you do this, the circle is converted to lines.

To select these lines, you now have to click the Lines button.

Invisible arcs / circles

— See “Making circles/arcs invisible” on page 70.

INSERT CLOUD

To insert a cloud to mark corrections easily, do this:

 1) Choose Insert => Insert Cloud.

 2) A pencil is now displayed in the 
cross hairs: Click to point out 
one corner for the cloud.

 3) Click to point out the opposite 
corner.

 4) You now enter the dialog box 
Enter text: Type in a text, which 
will be placed in the middle of 
the cloud, and click OK — or 
press <Esc> if you do not wish 
to place a text in the cloud.

 5) Draw a new cloud, or press 
<Esc> when you do not wish to draw more clouds.

The cloud is now drawn.

The applied line color and type is memorized for the next time you draw a cloud.
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TEXTS

When you want to work with texts, you always start by clicking the Texts button — 
or press the short-cut key <t>. If you want to place new texts you click the Pencil 
button. — See “Auto command change” on page 57 also.

The general short-cut key for the Pencil is the <Ins> key, but you can also use the 
<t> key when you are working with Texts. Pressing the <Ins> or the <t> key acti-
vates/deactivates the Pencil.

— See how to move, copy, delete and rotate texts in “Working with selected obje-
cts” on page 58, and see how to transfer data between texts in “Transferring Data / 
Properties between Objects” on page 62.

TEXT TYPES IN Automation

There are various types of texts in Automation, as you will see below.

When the word text is mentioned in this manual, we will be referring to free texts — 
unless specified otherwise.

THIS CHAPTER DESCRIBES

— THE TEXT TYPES IN Automation........................................................... p. 108

— DATAFIELDS ............................................................................................ p. 116

— SYMBOL DATAFIELDS ............................................................................... p. 120

— PROJECT AND PAGE DATA ....................................................................... p. 125

— GENERAL TEXT FUNCTIONS ...................................................................... p. 127

— LOCKING TEXT TYPES .............................................................................. p. 130

— COUNTING ON TEXTS ............................................................................... p. 131

— THE APPEARANCE OF TEXTS / TEXT PROPERTIES ...................................... p. 133

— WHICH TEXTS ARE DISPLAYED IN PROJECTS.............................................. p. 138

— THE READING DIRECTION FOR TEXTS ........................................................ p. 141

— TEXT LINKS ............................................................................................. p. 144

TEXT TYPE DESCRIPTION PAGE

FREE TEXTS TEXTS, THAT CAN BE USED ANYWHERE IN THE PROJECT. 109

SYMBOL TEXTS TEXTS, THAT ARE ATTACHED TO EACH SYMBOL, CONTAINING 

INFORMATION ON THE COMPONENT THAT IS COVERED BY THE 

SYMBOL.

113

CONNECTION 

POINT TEXTS

TEXTS, THAT ARE ATTACHED TO EACH OF A SYMBOLS CONNEC-

TION POINTS.
115

LINE TEXTS TEXTS / ARTICLE DATA ATTACHED TO LINES. 80

DATAFIELDS TEXT FIELDS THAT ARE FILLED OUT AUTOMATICALLY. 116
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GENERAL PURPOSE / FREE TEXTS

General purpose/free texts are texts that can be applied anywhere in diagrams, in 
symbol definitions (see “Creating Symbols” on page 761) or in drawing headers/
formulas.

The free texts can not be transferred to project lists — as opposed to the other 
types of texts.

If a free texts is a part of a symbol definition — see “Creating Symbols” on 
page 761 —, it can not be changed in a diagram later on.

Type in and place a free text

Click on the Texts and the Pencil button — or click inside the text field on the texts 
toolbar.

Type in the text as displayed above and press <Enter>. Please note that the toolbar 
informs you that you are dealing with a free text.

The text is now in the cross hairs. Click where you wish to place it.

You have now placed a free text on a project page.

When the Pencil is not activated, you can press the short-cut key <k>, and you 
enter the dialog box Place text where you also can type in a text and then place it.

From here it is now possible to use the automatic counting functions, which can be 
found in the Texts toolbar. — Read more about these in “Counting on texts” on 
page 131.

Editing texts in projects

When you want to edit a text in a project, do the following:

 1) Disable the Pencil (press <Esc>)

 2) Click on the text and press the short-cut key <k>

 3) Correct the text and press <Enter> — or click OK

If you press <F7> to enter the Object Lister, you can see all the project texts in 
one place. From there you can also edit the texts.

— See “Checking and editing project texts via the Object Lister” on page 349.

Text typeType in the text here
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Autocompletion of texts

Automation memorizes all of the texts which have been used in the program.

While you type in texts, the program therefore gives you some suggestions to 
which text you are typing in.

You can then choose between the suggestions in the list, or continue typing in the 
text.

If no list appears with texts having the same initial letters, you can press 
<Ctrl+Spacebar> and get a list of matching texts, that do not have the same initial 
letters.

Creating a list of texts

As mentioned, the program memorizes all the texts you type in.

If you also want to add texts from existing projects, do like this:

 1) Open the project containing the texts

 2) Choose Functions => Special functions => Transfer Project Texts to 
Auto Completion function

This procedure is repeated for all the projects you want to transfer texts from.

Deleting texts from the autotext function

To delete texts from the autotext function, click on the undesired text in the autotext 
scroll menu, and press <Delete>.

Click here and

press <Delete>
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Special characters

In the project pages you may also need special characters, which are not available 
on your keyboard. This goes for the signs for earth, frame and alternating current 
and characters from other European languages e.t.c.

To insert a special character, right-click in the text field in the text toolbar, and 
choose Insert char:

In the dialog box Insert char you then select the desired character, and click 
Insert.

Right-clicking in dialog boxes and inserting special characters

When you need to insert a special character in a text field in a dialog box, just right-
click and choose Insert char. You then enter the dialog box Insert char, and can 
insert the character as described above.

— Please refer to “Texts in more than one line” on page 127, “Negate (invert) text” 
on page 127 and “Underline text” on page 128.

SPECIAL CHARACTERS AND WINDOWS

THE FONTS YOU GET WITH OLDER VERSIONS OF WINDOWS, DOES NOT CON-

TAIN SPECIAL CHARACTERS. WHEN A SPECIAL CHARACTER DOES NOT EXIST 

IN A SELECTED FONT, A SQUARE IS DISPLAYED IN STEAD OF THE SPECIAL 

CHARACTER IN THE DIALOG BOX ABOVE.

THE FONTS YOU GET WITH WINDOWS VISTA AND SUCCEEDING VERSIONS 

CONTAINS SPECIAL CHARACTERS.

THE PCSCHEMATIC FONT CONTAINS THE NECESSARY SPECIAL CHARAC-

TERS.

Here you can specify
a short-cut key for the
selected character
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Default text properties for free texts

To edit the default text properties (text size e.t.c.) which Automation suggests for 
free texts, do this:

 1) Choose Settings => Text/Symbol defaults.

 2) On the tab Text/Symbol defaults: Click on Free, click on Free text and click 
the Text properties button:

 3) In the dialog box Text properties: Specify the desired text properties, as 
described in “Specifying text properties / Appearance of text” on page 133, 
and click OK.

 4) In the dialog box Text/Symbol defaults: Click the Save as default button, if 
you also want to apply these settings in other projects.

 5) Click OK.

Changing free texts in the project or on the page

When you wish to change text settings for free texts in the project — or on the 
active page in the project — click the Transfer text settings to the project button. 
You then get the option to choose whether to change the settings for All Pages or 
for This Page.

Precise line break in free texts

If you wish to specify how line breaks are made in the free texts in the project, 
please see “Fixed line break on texts” on page 928.
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TEXTS CONNECTED TO SYMBOLS

Symbols have attached symbol texts, and if the symbol has connection points, 
these have attached connection texts as well.

The fields for these texts can not be removed. However they neither have to be 
filled out nor visible. — Read more about symbol texts in “Creating Symbols” on 
page 761.

The symbol texts

To each symbol, some symbol texts are attached, which can contain the symbol/
component name as well as other information about the component, which the 
symbol represents.

These symbol texts exist:

The information that you type into the symbol texts, can be used when for instance 
you want to generate parts lists automatically.

You can also create so-called symbol datafields, which can be attached to the sym-
bols. — See “Symbol datafields” on page 120.

Filling out the symbol texts

When you place a symbol you automatically enter the Component data dialog 
box, where you can enter various information about the symbol, or just click OK 
and return later to fill in the missing data.

If you do not enter the Component data dialog box automatically, you can enable 
this function by entering Settings => Pointer/Screen and select Ask for Names.
— Read more about this in “Pointer/Screen” on page 906.

When you return later to type in the symbol texts, you have to start by clicking the 
Symbols button, or use the short-cut key <s>. Then right-click on the symbol 
whose symbol texts you want to change, and choose Component data in the 
appearing menu.

Instead of right-clicking, you can select the symbol by clicking and then click the 
Data button in the program toolbar.

TEXT TYPE DESCRIPTION

S NAME THE NAME OF THE SYMBOL/COMPONENT — I.E. -K1, -Q34.

S TYPE DESCRIBES THE TYPE OF THE COMPONENT — CAN BE FILLED OUT VIA THE 

DATABASE.

S ARTICLE NO A TEXT TELLING EXACTLY WHICH COMPONENT A SYMBOL DESCRIBES. THIS 

BEING EITHER A EAN 13 NUMBER OR A STOCK NUMBER. CAN BE FILLED 

OUT VIA THE DATABASE.

S FUNCTION THIS TEXT IS USED TO DESCRIBE THE FUNCTION OF THE SYMBOL. CAN BE 

FILLED OUT VIA THE DATABASE.

FETCHING DATA FROM THE COMPONENT DATABASE

COMPONENT DATA SUCH AS ARTICLE NUMBER AND TYPE CAN BE FETCHED 

DIRECTLY FROM THE ATTACHED COMPONENT DATABASE, AS DESCRIBED IN 

“Attaching information from the Database to a Symbol” on page 631.
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You now enter the dialog box Component data, that for instance could be filled out 
like this:

Here you can fill out the symbol texts — for instance by fetching them from the 
attached component database — and decide which of the symbol texts that should 
be displayed together with the symbol in the project. It is also possible to type in 
the connection point names. This is described in “Placing and Naming symbols” on 
page 171.

Click OK when the data are as you want them to be.

Editing the symbol texts directly on a Diagram page

A symbol with visible symbol texts could look like this:

— Please note that references are only displayed when the symbol has references. 
See “Creating Symbols” on page 761, particularly “Position for references to other 
symbols” on page 763.

Clicking a symbol text

When you work with Texts, have disabled the Pencil (press 
<Esc>), and click on a symbol text, the Texts toolbar shows which 
type of symbol text you have clicked on.

To indicate to which symbol the symbol text is connected, a line is displayed going 
from the reference point of the symbol to the symbol text.
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Changing between the symbol texts by pressing <F5>/<F6>

Once you have selected a symbol text, you can change back and forth between the 
symbol texts connected to this symbol by pressing <F5> and <F6>. When a sym-
bol has references, pressing <F5>/<F6> will also jump to the reference text.

— Please refer to “Locking text types” on page 130 for an easier way to change 
symbol texts.

Double-clicking a symbol text

When you work with Texts, have disabled the Pencil (press <Esc>) and double-
click on a symbol text, you enter the dialog box Component data, where you can 
edit the text.

Moving symbol texts on a Diagram page

To move a symbol text you also have to activate the Texts button. Then you can 
move the text as you can move any other object in Automation, for instance using 
drag and drop.

If you press down <Shift> while moving the text, you can place the text using fine 
snap — read more about snap in “Snap” on page 47.

CONNECTION POINT TEXTS

These texts are connected to the connection points of the symbol — where you 
connect conducting lines to the symbol — and contain information about these.

The following types of connection point texts exist:

Connection point texts are filled out and moved like symbol texts. — Please refer to 
“Texts connected to symbols” on page 113 and “Symbol Connection points” on 
page 207.

When you have selected a connection point text, you can change back and forth 
between the texts connected to the connection point by pressing <F5> and <F6>.

CONNECTION POINT TEXT CONTENTS

NAME (C.NAME) THE CONNECTION NUMBER OF THE CONNECTION POINT.

FUNCTION (C.FUNC) THE FUNCTION OF THE CONNECTION POINT.

LABEL (C.LABEL) THE SHORT DESCRIPTION (FOR INSTANCE FOR PLC DRAWINGS).

DESCRIPTION (C.DESCR) THE LONG DESCRIPTION (FOR INSTANCE FOR PLC DRAWINGS).
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DATAFIELDS

Another type of texts are called datafields. These can be filled out automatically by 
the program. Like free texts, they can be applied anywhere in drawings, in symbols 
and in drawing headers/formulas.

Choosing Settings you can specify the contents of some datafields once and for 
all. What you type in here will be inserted into the project any time you place one of 
these datafields. If you change the contents of one of the datafields in Settings, 
the project will be updated automatically. Read more about how to do this in “Pro-
ject and Page data” on page 125.

— Please refer to “Page data and Project data Datafields” on page 755 for further 
details.

To insert a datafield choose Insert => Insert datafield.

You now enter the Datafield dialog box:

The various groups of datafields have the following contents:

DATAFIELD CONTENTS

SYSTEM DATA DATA ABOUT YOUR SYSTEM. FOR INSTANCE USER NAME WHICH IS 

THE NAME OF THE PERSON THAT IS TYPED IN AS USER IN SET-

TINGS => SYSTEM/LICENSE ON THE SYSTEM TAB. DATE AND 

TIME ARE THE ACTUAL DATE AND TIME, MINUTES AND SECONDS.

PROJECT DATA DATA CONCERNING THE ACTUAL PROJECT. YOU CAN DEFINE 

THESE IN SETTINGS => PROJECT DATA.

PAGE DATA DATA CONCERNING THE PAGE YOU ARE WORKING ON IN THE PRO-

JECT. THERE ARE SOME PREDEFINED PAGE DATA DATAFIELDS, 
SUCH AS THE PAGE NUMBER. YOU CAN DEFINE ADDITIONAL PAGE 

DATA DATAFIELDS IN SETTINGS => PAGE DATA.

The selected

datafield

Click here for

drop-down menu

Explanatory

text about the

datafield

The selected

field type

Supplementary

information
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— See the survey of datafields in “Datafields in Automation” on page 931.

The other fields in the menu have following functions:

SYMBOL DATAFIELD 
(ONLY AVAILABLE WHEN 

EDITING DRAWING 

HEADERS / LISTS)

DATAFIELDS YOU CAN DEFINE BY YOURSELF. — READ MORE 

ABOUT THESE IN “Creating Data symbols” on page 797.

YOU CAN ALSO PLACE SYMBOL DATAFIELDS FOR EACH INDIVIDUAL 

FIELD IN THE DATABASE. IN THE LIST OF SYMBOLDATA DATA-

FIELDS, THESE FIELDS ARE ASSIGNED THE NAMES DB<XXXXX>, 
WHERE XXXXX IS THE NAME ON THE DATAFIELD IN THE DATABASE.

LINE DATAFIELD (ONLY 

AVAILABLE WHEN EDIT-

ING DRAWING HEADERS 

/ LISTS)

DATAFIELDS FOR LINES, WHICH YOU CAN DEFINE YOURSELF — 

SEE “Line datafields” on page 82.

TABLE OF CONTENTS 
(ONLY AVAILABLE WHEN 

EDITING DRAWING 

HEADERS / LISTS)

DATAFIELDS FOR TABLES OF CONTENTS.

PARTS/COMPONENTS 

LISTS (ONLY AVAILABLE 

WHEN EDITING DRAWING 

HEADERS / LISTS)

DATAFIELDS FOR PARTS- AND COMPONENTS LISTS.

TERMINALS LIST /
CABLE LIST (ONLY 

AVAILABLE WHEN EDIT-

ING DRAWING HEADERS 

/ LISTS)

DATAFIELDS FOR TERMINALS- AND CABLES LISTS. IN THE SUPPLE-

MENTARY INFORMATION BOX YOU CAN FOR INSTANCE DETERMINE 

WHETHER A DATAFIELD IS FOR THE EXTERNAL OR THE INTERNAL 
PART OF THE LIST.

PLC LIST (ONLY AVAIL-

ABLE WHEN EDITING 

DRAWING HEADERS / 
LISTS)

DATAFIELDS FOR PLC LISTS.

CONNECTIONS LIST 

(ONLY AVAILABLE WHEN 

EDITING DRAWING 

HEADERS / LISTS)

DATAFIELDS FOR CONNECTIONS LISTS.

FIELD FUNCTION

ACTIVATE NEXT IS USED FOR LISTS WHEN A CERTAIN GROUP OF INFORMATIONS MUST BE 

REPEATED SEVERAL TIMES ON A PAGE. EACH TIME THE PROGRAM MEETS 

ACTIVATE NEXT, THE NEXT SET OF INFORMATION ON THE LIST CAN BE 

FILLED INTO THE LIST. SEE “Dictionary” on page 967.

WRAP TEXT IF THE TEXT CONTAINS MORE CHARACTERS THAN STATED IN THE WIDTH 
FIELD, THE REMAINING PART OF THE TEXT WILL NOT BE DISPLAYED. IF 

YOU ACTIVATE WRAP TEXT, THE TEXT WILL CONTINUE ON AN EXTRA LINE 

BELOW.

KEEP LINEBREAK 

(^)
WHEN YOU SELECT KEEP LINEBREAK (^), THE DATAFIELD WILL ALSO 

HAVE THE SPECIFIED LINE BREAK IN THE LISTS CREATED FROM THE PRO-

JECT.

ONLY SHOW TEXT 

ON DATA

THIS OPTION ONLY APPEAR WHEN SOMETHING HAS BEEN TYPED INTO 

THE TEXT FIELD. IF YOU ACTIVATE THIS FUNCTION, THERE WILL NOT BE 

PRINTED ANYTHING ON THE SCREEN IN CASES WHERE THE TEXT FIELD IS 
FILLED OUT, BUT THERE ARE NO ACTUAL DATA IN THE DATAFIELD ITSELF.
ESPECIALLY USED IN LISTS.

DATAFIELD CONTENTS
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Two inserted datafields could for instance look like this:

Please note that this is how datafields look like when you are in Edit symbols — for 
instance because you want to create a list (Read more about creating lists in 
“Creating Lists” on page 818). If you just insert a datafield on a page, you will not 
see the name of the datafield itself (2), but the contents of the datafield.

Use Insert => Insert Datafield to select a datafield you want to insert. Click OK 
when the settings are as you want them.

You now get the chosen datafield into the cross hairs, and click where you want to 
place it.

When you want to edit a placed datafield, you right-click on the datafield and 
choose Datafield. This brings you into the Datafield dialog box.

Inserting the contents of the datafield in the text

By applying the % character, you can insert the contents of the datafield in the mid-
dle of the text in the Text field.

The following options exist:

THE RED ARROW TRANSFERS THE SELECTED DATAFIELD TEXT TO THE TEXT FIELD.

FILL CHARACTER A CHARACTER THAT WILL BE FILLED IN FROM THE END OF THE TEXT AND 

IN THE REMAINING WIDTH OF THE DATAFIELD. FOR INSTANCE A LINE OF 

DOTS IN A TABLE OF CONTENTS BETWEEN THE PAGE TITLE AND THE 

PAGE NUMBER. (3) ON THE FOLLOWING FIGURE.

TEXT HERE YOU CAN TYPE IN A TEXT TO PRECEDE THE CONTENTS OF THE 

DATAFIELD. (1) ON THE FOLLOWING FIGURE.

WIDTH THE MAXIMUM WIDTH OF THE DATAFIELD (NUMBER OF CHARACTERS).

— PLEASE ALSO SEE “Fixed line break on texts” on page 928.

INSERT DESCRIPTION

%S INSERTS THE VALUE/CONTENTS OF THE DATAFIELD UNCHANGED.
IF YOU TYPE IN "PRICE: %S $" — AND THE CONTENTS OF THE DATAFIELD IS 25 —
THIS RESULTS IN THE TEXT "PRICE: 25 $"
— WHEN YOU HAVE TYPED IN THE CONTENTS OF THE DATAFIELD WITH NO DECI-

MALS, THE CONTENTS IS DISPLAYED WITHOUT DECIMALS. IF YOU HAVE TYPED IN 

THE CONTENTS WITH DECIMALS, THE CONTENTS IS DISPLAYED WITH DECIMALS.

%F INSERTS THE VALUE OF THE DATAFIELD AS FLOATING POINT VALUE, WHEN POSSI-

BLE.

FIELD FUNCTION

The text in the

Text field (1)

The name of datafield itself (2)

Fill characters (3)
Automation

age 118



Texts

Auto
When you want to use the % character in a text, just type the % character twice. If 
you write "%.2f %%" this can result in the text "5,00 %".

%.1F INSERTS THE CONTENTS OF THE DATAFIELD AS FLOATING POINT WITH ONE DECI-

MAL. YOU CAN CHOOSE FROM 0 TO 9 DECIMALS.
IF YOU WRITE "PRICE: %.2F $"— AND THE CONTENTS OF THE DATAFIELD IS 25 — 
THIS RESULTS IN THE TEXT "PRICE: 25,00 $"
IF YOU WRITE "%.3F KG." — AND THE CONTENTS OF THE DATAFIELD IS 17,65 — 
THIS RESULTS IN THE TEXT "17,650 KG."

%- NO DATAFIELD VALUE IS INSERTED, AND THE TEXT IS ENDED RIGHT BEFORE THE % 
CHARACTER. IF FOR INSTANCE YOU WRITE "TOTALPRICE:%" THE TEXT "TOTAL-

PRICE:" IS INSERTED IF THE CONTROLLING DATAFIELD HAS A CONTENT.
THIS CAN FOR INSTANCE BE USED AT THE BOTTOM LINE OF A LIST, WHERE THE 

DATAFIELD PRICE 1 TOTAL DOES NOT HAVE A CONTENT UNTIL ALL PAGES IN THE 

LIST HAVE BEEN ADDED. TO MAKE THIS WORK, YOU MUST PLACE THE DATAFIELD 

PRICE 1 TOTAL WITH THE TEXT "TOTAL PRICE:%-" IN THE LEFT SIDE OF THE BOT-

TOM LINE, AND PLACE THE DATAFIELD PRICE TOTAL IN THE RIGHT SIDE OF THE 

BOTTOM LINE WITH THE TEXT "%S $"
SELECT ONLY SHOW TEXT ON DATA FOR BOTH DATAFIELDS.

INSERT DESCRIPTION
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SYMBOL DATAFIELDS

All symbols have attached the symbol texts Name, Type, Article no and Func-
tion. When you wish to attach other information to the symbols, you can create so-
called symbol datafields, which can contain this information.

Below you can see how to create these symbol datafields and how to attach the 
symbols datafields to symbols in the project.

How to create symbol datafields

To create symbol datafields, do this:

 1) Choose Settings => Text/Symbol defaults and click on Symbol data 
fields.

 2) Click the Add datafield button.

 3) In the dialog box Enter text: Type in the name of the symbol datafield and 
click OK.

 4) Click the Add datafield button again to add more symbol datafields.

You can also create a list of predefined values for the datafields, as described in 
“Symbol datafields with predefined values” on page 121.

Click OK to exit the dialog box Text/Symbol defaults.

How to delete symbol datafields

To delete a created symbol datafield, do this:

THIS CHAPTER DESCRIBES

— HOW TO CREATE SYMBOL DATAFIELDS................................................. p. 120

— SYMBOL DATAFIELDS WITH ATTACHED LIST OF VALUES ........................... p. 121

— HOW TO ADD DATAFIELDS TO SYMBOLS................................................ p. 122

LINE DATAFIELDS CREATED THE SAME WAY

WHEN YOU WISH TO CREATE LINE DATAFIELDS, THIS IS DONE THE SAME 

WAY. THE ONLY DIFFERENCE IS THAT YOU HAVE TO CHOOSE LINE DATA 

FIELDS IN STEAD OF SYMBOL DATA FIELDS.
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 1) Choose Settings => Text/Symbol defaults and click on Symbol data 
fields.

 2) Click on the down-arrow in the right-hand side of the dialog box, and select 
the symbol datafield that you wish to delete:

 3) Click the Delete button.

Symbol datafields with predefined values

Symbol datafields can have an attached list of predefined values for the datafield.

To create such a data list, choose Settings => Text/Symbol defaults and click on 
Symbol datafields. Then choose the relevant symbol datafield and click the Val-
ues button.

You then enter the Values dialog box.

The Values dialog box

In the Values dialog box you can maintain a list of which values/texts a specific 
datafield (such as for instance line datafields, tab titles as well as page and project 
titles — and in this case symbol datafields) can contain:

Select the symbol datafield ... and click here to type in the values

Type in the
values

Sort the values Select a value and Set as default

Move up/down
in the list
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TYPE IN VALUES/TEXTS

To type in the values, click inside the Values field and type in the values/texts indi-
vidually and press <Enter> after each value, to ensure that there is only one value 
on each line.

DELETE TEXTS/VALUES

To delete a value: Select the value in the Values field (double-click on the value) 
and press <Delete> or <Backspace>.

SET AS DEFAULT

When you select a value in the list and click the Set as default button, the selected 
value becomes the default value for the datafield. When a value is set as default, 
this is indicated by two @ characters in front of the value in the Values dialog box.

Click OK when the list is complete.

— You can also see “Project and Page data: List of values for a series of data-
fields” on page 758.

Lock data list for symbol datafield

When you have created a data list for a symbol datafield, you have the option of 
locking the data list. You can do this by clicking the lock icon to the right under 
Symbol datafields.

When the icon is displayed as a locked lock, it is only possible to select the values 
specified in the data list.

When the icon is displayed as an open lock (as above), it is also possible to type in 

your own values.

How to add datafields to symbols

To add extra datafields to a placed symbol, do this:

 1) Activate the Symbols button and double-click on the symbol to enter the dia-
log box Component data.

 2) In the dialog box Component data: Click the Symbol data fields tab.

MAKE VALUES ACCESSIBLE FOR THE ENTIRE COMPANY

UNDER SETTINGS => DIRECTORIES YOU CAN SPECIFY WHICH FOLDER TO 

SAVE THE LIST OF VALUES IN. WHEN YOU WORK ON A NETWORK, THE CRE-

ATED LISTS OF VALUES CAN BE MADE AVAILABLE FOR THE ENTIRE COMPANY, 
WHEN THESE LISTS OF VALUES ARE SAVED ON THE SERVER.

— SEE “Directories” on page 911.
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 3) On the Symbol data fields tab: Click Add. (See how to create symbol data-
fields in “How to create symbol datafields” on page 120).

 4) In the Datafield dialog box: Select which datafield to attach to the symbol. 
Here you can choose the symbol datafields that you have created yourself as 
well as the datafields from the attached database. Datafields from the data-
base are written in capital letters.

 5) Select how to fetch the data:
From component: Data is fetched from the component
From symbol: Data is fetched from the symbol
Symbol else component: Data is fetched from the symbol, but if no specific 
data is specified for the symbol, data is fetched from the component

 6) Click OK.

The selected datafield is now attached to the symbol, and you can type in a value 
for the datafield.
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When the datafield has a defined default value, this value is already specified for 
the datafield. If a list of values exists for the symbol datafield, you can choose 
among the values in the list like this:

The specified values in the data list are only suggested values, so you can also 
type in another value in the datafield.

But if the datalist for the datafield is locked — see “Lock data list for symbol data-
field” on page 122 — a lock icon is displayed next to the datafield, and you are only 
allowed to select one of the specified values in the list.

Predefined symbol datafields

Beyond the symbol datafields that you have created by yourself, there are also 
some predefined symbol datafields, which can always be added when you click the 
Add button. These datafields are:

• =+-design.: The full reference designation for the symbol.

• Description: The description for the reference designation.

• Quantity: The contents of the Quantity field in the tab General in the dialog 
box.

When you select Visible field next to the symbol datafields, they will be displayed 
on the project page next to the symbol.

1) Click inside
the field

2) Click here,
and the list i
displayed

3) Select the
desired value

Edit settings for the symbol datafield Remove the symbol datafield
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PROJECT AND PAGE DATA

When you open a new project, the program will show you the tab Project data 
from the Settings dialog box. In this dialog box you also find the tab for Page data 
and for Page settings.

Here you can fill in various data for your project.

To fill out a field, you just click inside the field, and type in the information. You can 
jump between the fields by pressing the <Tab> key.

If you do not wish to enter these data now, press <Esc> or click Cancel.

If you want to fill out or change data later, choose Settings => Project data / Page 
data. Or you can click the Project data or the Page data button. You can also 
right-click on a project page, and select Page data.

If you want to change the name of a datafield in the Project or Page data menu 
(the grey fields in the left hand side of the menu), just right-click on the field name 
you want to change. Then a menu appears, from which you can change the name 
of the field, delete the field, or add new datafields. However, you will not be allowed 
to change the names of project- or page datafields, that are being used in the pres-
ent project. You can change the contents of the fields at any time.

— Read more about this in “Page data and Project data Datafields” on page 755.

Remember to click Redraw to see the effects of the changes in your project.

See how you design drawing headers in “Creating Drawing Headers” on page 807, 
and how to design your own lists in “Creating Lists” on page 818.

Values list for Project and Page title

To the right of the field Project title on the Project data tab, you can click the Val-
ues button. When you click the button, you enter the dialog box Values, where you 
can create/edit a list with possible project titles. When such a list is created, a 
down-arrow is displayed next to the Project title field, when you click inside the 
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text field. If you click the down-arrow, you can subsequently choose between the 
listed project titles.

To the right of the Page title field on the Page data tab, there is a similar Value 
button, which gives you the same option for page titles.

This makes it easier to apply standardized project and page titles in projects.

— Read more about this in “The Values dialog box” on page 121.

Activating the Auto text function for Page title

To activate the auto text function when typing in a Page title, press <Ctrl+Space-
bar>. — See “Autocompletion of texts” on page 110.
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GENERAL TEXT FUNCTIONS

When you are working with texts, there are some text functions you can apply for 
all text types.

Changing a text

If you want to change a text on a drawing, you first select the text by disabling the 
Pencil (press <Esc>), and then click on the text. The text is now in the text field on 
the toolbar. Click inside the field, correct the text, and press <Enter>.

If you double-click on the text in the text field, the text will be selected, and you can 
type in another text instead.

When a text is selected, you can also press the short-cut key <k>, and you will 
enter a dialog box where you also can type in the text.

When you select a text, the type of the text is displayed in the texts toolbar.

Changing a text in the cross hairs

When you have a text in the cross hairs, click in the text field (or press <k>), type in 
a new text, press <Enter> and place the text. This can also be done while copying.

Texts in more than one line

Insert the character ^ where you want a line break. — On your keyboard it is prob-
ably located to the left of the <Enter> key. The character will not appear before you 
type in the following character.

— See also “Line length” on page 135 and “Wrap text” on page 135.

Negate (invert) text

Type in the text in the text field, select it and press <Ctrl+PageUp>. The negate bar 
will only be placed above the selected part of the text.

Alternatively you can select the text in the toolbar, right-click and choose Negate.

If you deselect the Pencil (press <Esc>) and right-click on a text, you can also 
choose Negate.

Here you can change text properties
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You can remove the negation by selecting the text, and then choose Negate again.

Underline text

Select the text as mentioned above and press <Ctrl+PageDown> — or select the 
text, right-click and choose Underline.

If you deselect the Pencil (press <Esc>) and right-click on a text, you can also 
choose Under line.

You can remove the underline by selecting the text, and then choose Underline 
again.

Cut, copy and insert a text in the text field

A text in the text field can be transferred to the Windows clipboard, either by copy-
ing or by cutting from the text.

If you want to transfer text from the text field to the clipboard, you select the text 
you want to transfer, right-click and choose Copy in the menu that appear. A copy 
of the text is now placed on the clipboard.

If you want to transfer a text from the clipboard to a text field, then activate the 
Texts button. Right-click in the text field and choose Insert. Press <Enter> and 
place the text on the drawing.

The text stays on the clipboard until another text is transferred to the clipboard.

Swopping texts

To swop texts and datafields, you can apply the function Edit => Swop texts:

 1) Select a text by clicking on it.

 2) Choose Edit => Swop texts.

 3) Click on the other text, that you want to swop the text with.

You can also right-click on a text, and choose Swop texts.

NEGATED TEXTS AND CHANGING FONTS

IF YOU CHANGE FONT, YOU MUST BE AWARE THAT THIS CAN HAVE AN 

EFFECT ON NEGATED TEXTS. — SEE “Special characters when changing 
the PCSCHEMATIC font to a Windows font” on page 134.

UNDERLINED TEXTS AND CHANGING FONTS

IF YOU CHANGE FONT, YOU MUST BE AWARE THAT THIS CAN HAVE AN 

EFFECT ON UNDERLINED TEXTS. — SEE “Special characters when chan-
ging the PCSCHEMATIC font to a Windows font” on page 134.
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Texts with text leader

To insert a text leader on a text, do this:

 1) Choose Texts and disable the Pencil by pressing <Esc>.

 2) Right-click the text and choose With text leader.

 3) A line is now displayed from the text to the cross-hairs: Click where you want 
the text leader to point.

The text leader line is now drawn. If you want to reposition the text leader arrow, 
just — while still working in Texts — click on the arrow and then drag it to its new 
position.

To remove the text leader: Right-click on the text and choose Without text leader.

Information on texts

To get information about a text, do this:

 1) Choose Texts and disable the pencil by pressing <Esc>.

 2) Right-click on the text and choose Information.

 3) You now enter the dialog box Information, which contains information about 
the text.

Here you find information about the text height, width, position, the used font, line 
length of the text, wrap text information e.t.c.
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LOCKING TEXT TYPES

On the toolbar for texts it is possible to lock which type of texts you want to work 
with, as well as to carry out continuous counting on texts of the type chosen.

Locking a text type

On the toolbar for texts, you can specify, that you only want to work 
with texts of a specific text type.

If for instance you choose the type S.Name, only texts of the type 
Symbol name can be selected in the project. If you then drag a win-
dow around some symbols in a project, only their symbol names are 
selected.

When you have locked the type to Symbol name, you can then assign a name to a 
symbol by typing in the name in the text field in the texts toolbar, press <Enter>, 
and click on the symbol.

Doing it this way, you do not have to click on the reference point for the text Sym-
bol name of the symbol.

If you want to place a connection point text, you lock the relevant text type, and 
click on the connection point itself.

When the text type is set to All, the selection of texts function on all text types.

RESET THE TEXT TYPE TO ALL AFTER USING THIS FUNCTION

TO BE ABLE TO SELECT ALL TYPES OF TEXTS IN THE PROJECT SUBSE-

QUENTLY, YOU SHOULD SET THE TEXT TYPE TO ALL AFTER USING THIS 

FUNCTION.

Increment/decrement Specify numbering system

Interval for incremen-

ting/decrementing Lock text type
Automation

age 130



Texts

Auto
COUNTING ON TEXTS

When you want to place texts with increasing or decreasing numbers, you 
can specify according to which numbering system the texts shall be 
incremented/decremented. Here you can choose between binary, octal, 
decimal and hexadecimal. You can also choose to increment/decrement 
upper- or lower case letters (ALFA or alfa respectively).

The initial value is typed into the text field in the texts toolbar.

If the texts are to be incremented following a specified interval, you type in the 
interval in the Interval field, as displayed on page 130.

When you click on +, the text in the text field is incremented with the value specified 
in the Interval field. This increment follows the number system chosen. If the inter-
val is set to 1, and the number system to dec, the text K1 will be incremented to 
K2.

If you click on - instead, the text will be decremented following similar guidelines.

When you press down <Ctrl> and click on +, the text will be incremented automati-
cally each time you click on a new text.

Therefore, when you have chosen the text type S.Name, have typed in K1 in the 
Text field and 2 in the Interval field, and then press down <Ctrl> and click on +, the 
first symbol you click on will get the symbol name K1, the following K3, then K5 
and so on.

If you press down <Ctrl> and click on -, the texts will be decremented automatically 
following the same directions.

Apply counting on texts in areas

To increment/decrement texts in areas, you do the following:

 1) Click on Texts

 2) Specify text type, interval and numbering system, as described above

 3) Select the area containing the texts you want to count up/down (se below)

 4) Type in the initial value in the text field in the toolbar

 5) Press down <Ctrl> and click on +

 6) Press <Enter>

The selected texts are now counted up according to the directions you have speci-
fied.
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Please note, that the program registers where you clicked the first, when you 
selected the area. The counting of the texts starts from there.

If the counting should be carried out starting from the left-hand side, you therefore 
start by clicking in the left-hand side, when you select the area.

Texts can be counted up on several symbols at the same time — as illustrated on 
the figure above.

— Please refer to “Changing symbol names in an Area” on page 205 to see alter-
native ways to apply automatic counting on symbol names, and to “Choosing con-
nection points in Areas” on page 209 to see how to do it for connection point 
names.

Short-cut keys for counting on texts

When you have selected a symbol, a text or a connection point on a symbol — or 
have a text in the cross hairs —, it is possible to increment or decrement the text/
symbol name/connection name.

To increment, choose Functions => Count up, or press the <+> key on the 
numerical keyboard.

To decrement, choose Functions => Count down, or press the <-> key on the 
numerical keyboard.

Increment/decrement is done according to the interval specified in the Texts tool-
bar.

— Both short-cut keys can be changed as described in “User defined short-cut 
keys” on page 858.

Click in the left-hand side first when you select the area,

if you want the counting to be performed from left to right
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SPECIFYING TEXT PROPERTIES / APPEARANCE OF TEXT

Exit any dialog box that might be activated, click on the Texts button, and press the 
Text properties button.

When changing the various text settings, you click the down-arrow at the left hand 
side of the dialog box, and click on your choice in the drop down box that emerge.

Editing the properties of placed texts

When you want to edit the properties of a placed text, you first click the Texts but-
ton. Then click on the text, and click the Text properties button. — Or: Right-click 
on the text, and select Text properties.

Then make the changes described in this section.

If for instance you want to type in the text height directly, you can also click in the 
Height field itself, and type in the desired height.

The Text properties dialog box contains the following fields:

SELECTING TEXT PROPERTIES VIA THE PICKMENU

YOU CAN SELECT DIFFERENT SETS OF TEXT PROPERTIES VIA THE PICKMENU, 
AS DESCRIBED IN “Texts in the Pickmenu” on page 137.

Font
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Fonts

Here you choose which font you want to use.

On the list you can choose between the PCSCHEMATIC 
font and the other fonts you have on the PC.

Please note that the Windows fonts should only be applied 
when strictly necessary. This is because they are not to be 
used on diagrams according to the EN standards, and 
because they take up extra space in the PC memory.

It can be an advantage to use these fonts in drawing head-
ers, in tables of contents and in lists.

The PCSCHEMATIC font follows the EN standards, and 
should therefore be used on diagrams.

Special characters when changing the PCSCHEMATIC font to a Windows
font

If you change texts written with the PCSCHEMATIC font to be written with a Win-
dows font, use of special characters such as negated characters, underlined char-
acters will give an incorrect result. Earth characters and other special characters 
might also give an incorrect result, depending on which font you use.

— See “Exporting PDF files” on page 366 also.

Height

States the height of the text.

Width

States the width of the text. The width specifies the distance between characters 
and their appearance.

Selecting AUTO sets the width to 2/3 of the height of the text.

SPECIAL CHARACTERS AND WINDOWS

THE FONTS YOU GET WITH OLDER VERSIONS OF WINDOWS, DOES NOT CON-

TAIN SPECIAL CHARACTERS. WHEN A SPECIAL CHARACTER DOES NOT EXIST 

IN A SELECTED FONT, A SQUARE IS DISPLAYED IN STEAD OF THE SPECIAL 

CHARACTER IN THE DIALOG BOX ABOVE.

THE FONTS YOU GET WITH WINDOWS VISTA AND SUCCEEDING VERSIONS 

CONTAINS SPECIAL CHARACTERS.

THE PCSCHEMATIC FONT CONTAINS THE NECESSARY SPECIAL CHARAC-

TERS.
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Alignment

There are nine different alignment 
options, such as centre-centre as shown 
above. When the text is placed in a point, 
it is actually the reference point of the 
text that is located in this point — as you 
can see on the figure.

In the field Alignment you determine 
where the reference point will be located 
in relation to the text. If the text fills more 
than a single line, the reference point is 
positioned relative to the entire text block.

If the text is rotated, it will be rotated around the reference point.

These reference points applies for both the Automation font and for Windows 
fonts — see “Fonts” on page 134.

Shortcut for changing text alignment

When you have selected a text, you can change the text alignment by pressing the 
<Shift> key while pressing the <Spacebar>.

When you have a text in the cross hairs, you can also change the text alignment by 
pressing the <Shift> key while pressing the <Spacebar>.

Frame

If you want a frame around the text, you pick one of the options in this field.

Color

States the color of text and frame. If you choose the color NP (Non Printable), you 
will see the text on the screen, but not on print.

— See “Visible text” on page 136 and “Making objects invisible” on page 69.

Line length

Here you can specify the maximal number of characters that can be included in the 
text line. If the text is longer than this, the extra characters are truncated.

Wrap text

Set a check mark here if the text shall continue on a new line, if the line length is 
exceeded.

Suppress lineshift char

When you select Suppress lineshift char, the manually entered line shift charac-
ters are suppressed. This function is activated individually, via the Text properties 
dialog box, for each individual text you wish to use it on.

The function can e.g. be used in connection with PLC reference symbols, when 
you do not wish to display the I/O connection description text with the same line 
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shifts, which is adapted to the design of the PLC symbol. — See “Working with 
PLCs” on page 466.

The function can also be used in connection with text links, where you wish to sup-
press the line shifts for some of the texts in the text link. — See “Text links” on 
page 144.

Check marks

Bold text, Italic text, Visible text and Fixed text direction are enabled and disa-
bled by clicking inside the check boxes. A check mark is displayed when they are 
enabled.

Bold text

The text will be bold.

Italic text

The text will be in italics.

Underlined text

The text will be underlined.

Visible text

If you remove the check mark in the Visible text check box, the text will not be 
shown in the project. Thus if you remove the check mark for a text containing a 
symbol name, the name of the symbol will not be shown in the project.

If you then click Symbols, right-click on the symbol and choose Component data, 
you can see that it now is stated here as well, that the symbol name is not visible. 
You can turn symbol texts on and off in the Component data dialog box and in the 
dialog box Text properties.

Fixed text direction

If this option is chosen, the text will always be directed as it is when you place it on 
the page. Therefore, if you change the general Reading direction of the page, the 
text will not change direction. Read more about reading direction in “Specify rea-
ding direction” on page 141.

When you have finished specifying the text properties, you click OK.

Not translated

In the field Not translated you can specify not to translate this text, when translat-
ing project texts via the translation program PCSCHEMATIC Translator.

Select text properties from Text/Symbol defaults

In the Text properties dialog box it is also possible to select the settings in the dia-
log box from the settings for a specified text type in Settings => Text/Symbol 
defaults.
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When you click on the down-arrow in the Std.Text field in 
the upper part of the dialog box, you get a list of the vari-
ous text types, you can set the standard size for under 
Settings => Text/Symbol defaults.

Please note, that you can also select the default settings 
for free texts.

If for instance you click on S.Type, the settings in the dia-
log box Text properties will then become the same as 
the current default settings for symbol type texts.

This makes it easier to place free texts having the same 
appearance as for instance symbol texts.

— Please refer to the “Text/Symbol defaults” on page 921 for further details on the 
default settings for texts.

Texts in the Pickmenu

To get fast access to drawing texts with predefined properties — see “Specifying 
text properties / Appearance of text” on page 133 —, you can place texts with the 
desired properties in the pickmenu at the upper part of the screen.

When you click on one of the texts in the pickmenu, the program automatically 
changes to working with Texts, and the cursor is placed in the text-field in the texts 
toolbar.

When you subsequently type in at text and press <Enter>, you get the text in the 
cross hairs. When you place the text in the project, the text gets the selected prop-
erties.

To insert a text type in the pickmenu, right-click on an empty cell in the pickmenu, 
and select Place Text. The currently applied text properties are hereby inserted in 
the cell in the pickmenu.

If the pickmenu is not displayed on the screen, you can activate the pickmenu by 
selecting Settings => Pointer/Screen and click on Pickmenu.

The pickmenu can also contain symbols, lines and arcs. — Read more about the 
pickmenu in “Fetching symbols from the Pickmenu” on page 152 and “Adapting the 
Pickmenu” on page 198.

Symbols/drawing objects displayed in all pickmenus

Select different menus

in the pickmenu

Click on a text, and place texts

with the specified properties
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TEXTS DISPLAYED IN THE PROJECT (GENERAL SETTING)

Entering Settings => Text/Symbol defaults you can — as a general project set-
ting — specify which types of texts that can be displayed in the project.

If you here decide that Symbol article number is not to be shown in the project, 
you will not be able to display the number for any symbol in the project — not even 
though you select the Visible field for Name in the Component data dialog box for 
the symbols in the project.

If you, on the other hand, in Symbol defaults have determined that for instance 
texts of the type Symbol article number can be shown in the project, you can for 
each individual symbol state that for this symbol, the number is not to be shown.

— Read more about this in “Texts connected to symbols” on page 113.

In the left hand side of the Text defaults section you determine which type of texts 
you want to change the settings for. On the right hand side you determine whether 
the various texts can be displayed in the project.

The contents of the right hand side of the text defaults vary depending on the text 
type chosen.

If for instance you want the option to display texts of the type Symbol article num-
ber in the project, you first click on Symbol, then on Article, and finally you select 
the Displayed in project box.

Click against Capital letters if you want the text in capital letters only. Hereby can 
only type in capitals, when you type in the text. Already placed texts are not 
changed.

Name format for symbol names

For symbol names you can determine whether the placing of the symbol on page 
and current path shall be included in the symbol name. Read more about this in 
“Naming symbols due to page and current path number” on page 436.
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Transferring text settings to project texts

If you wish to transfer the text settings for the selected text type to the project — or 
to the active page in the project — click the Transfer text settings to project but-
ton.

All project texts of the selected type hereby gets the settings (text height etc.) spec-
ified on the tab Text/Symbol defaults. You are then asked whether to apply this 
setting for All Pages or for This Page.

Transferring text settings for symbol names

When you click the Transfer text settings to project button for symbol names, 
you must subsequently specify whether to change the settings for Component 
names, Signal names or Wire numbers:

If you select This Page the settings are only transferred to this page — if not, the 
settings are transferred to the project.

Select name type, and click OK.

Save as default

If you want to save the current settings as future standard, you click the Save as 
default button. Click OK. Please note that you only change the default settings for 
the type of text you are displaying in the dialog box at the present. If you click on 
the button with the settings shown above, you will only change the settings for sym-
bol names.

If you want to change the default settings for more text types, you have to click the 
Save as default button each time you have changed the settings for one single 
text type.

If you want to fetch the current default settings for the text type chosen, you click 
the Load defaults button.

If you just want to see what the default settings are, you click the Show defaults 
button, which only displays the default settings as long as you press down the 
mouse button.

When you have saved settings as standard, new projects will get these settings. 
Previously created projects will not be changed.

When you return to the drawing, it is a good idea to click the Redraw button, to 
update the drawing with the new settings.
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Changing text properties

On this tab you can also change the default appearance / which text properties the 
program shall suggest for the various text types.

When you have clicked your way to a text type, you determine its appearance by 
clicking the Text properties button. You now enter directly into the Text properties 
dialog box, as described in “Specifying text properties / Appearance of text” on 
page 133.

Other text standards

When you click on Reference, you can 
determine the appearance of the current 
path numbers by clicking on Horizontal ref-
erence and Vertical reference respectively.

If you click on Reference cross you can 
determine the appearance of the texts in the 
reference crosses that are placed in the pro-
ject subsequently.

Clicking on Symbol reference, likewise 
determine the appearance of the reference 
texts between symbols that are placed in 
the project succeedingly. Signal reference can only be changed in the Edit symbol 
mode.

Text standards for Symbol and Connection

Please note that text defaults for Symbol and Connection only cover the text 
properties that will be suggested when you are designing symbols. Therefore they 
can only be changed in the Design/Edit symbol mode.

Already designed symbols will not be effected by the changes.
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SPECIFY READING DIRECTION

The corners of a piece of paper is always numbered in such a way, that the bottom 
left hand corner has got number zero, the bottom right hand corner has number 
one, the upper right hand corner number two, and the upper left hand corner has 
number three.

Whether the paper is in portrait or in landscape does not change this.

The texts on a drawing will normally only be read seen from two directions.

The texts on a landscape drawing will normally be read seen from the bottom right 
hand corner (corner one). However, if you are drawing on a landscape page, which 
you later print out and rotate to place it in a folder, you must choose reading direc-
tion 0 (texts are read from corner zero). The texts then appears correctly when 
placed in the folder.

The reading direction can be changed in Settings => Page setup => Reading 
direction. You can choose reading direction 0, 1, 2, 3 or -1. The number state the 
corner from which the texts can be read. This means that the rotation of texts, or of 
symbols with texts, will change automatically according to the chosen setting. If 
you wish to change the reading direction on a drawing, you just change the setting, 
and the texts will change accordingly.

If you set the reading direction to -1 the texts will keep the orientation they have 
when you place them in the project. Thus they will not be oriented according to a 
specific reading direction.

If you have got a drawing in landscape, which after printing have to be inserted into 
a portfolio, you have to set the reading direction to 0.

Individual texts with fixed reading direction

You also have the option of specifying a fixed reading direction for individual texts. 
These will not be altered according to the general reading direction in Page setup. 
This facility can for instance be applied in company logos/drawings. See how to 
place texts with fixed reading direction in “Specifying text properties / Appearance 
of text” on page 133.

— See “Position of names when placing symbols” on page 142.
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Transferring the page reading direction to other project pages

When you wish to transfer the reading direction for a page to other pages in the 
project, choose Settings => Page settings and click on the Transfer setting but-
ton on the right-hand side of the Reading direction field. You then get the follow-
ing options:

• Select pages to transfer settings to: You now enter the Page menu where 
you select which pages to transfer the reading direction to and click OK.

• Transfer setting to all pages of same page format: The reading direction is 
transferred to all pages with the same page format.

• Transfer setting to all pages: The reading direction is transferred to all pages 
in the project.

Position of names when placing symbols

When symbols are rotated, symbol and connection names can be positioned in 
two different ways:

a) Names are not rotated, and they are positioned above or to the left of the 
symbol, or

b) Names are rotated with the symbol

How names are positioned in the project, is specified like this:

 1) Choose Settings => Text/symbol defaults

 2) Below Text standards: Select Symbol or Connection

THIS ONLY APPLIES FOR SYMBOLS OF THE TYPE NORMAL

PLEASE NOTE, THAT THIS FUNCTION ONLY APPLIES FOR SYMBOLS OF THE 

TYPE NORMAL.

Rotation 0 Rotation 90 Rotation 180 Rotation 270

With Automatic orientation of name

Without Automatic orientation of name

a)

b)
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 3) Select — or deselect — Automatic orientation of name

The setting only applies for symbols subsequently placed in the project. Already 
placed symbols are not affected.

By default, Automatic orientation of name is selected for both symbol and con-
nection names.

ROTATION: THE RELATION BETWEEN TEXT AND SYMBOL IS FIXED

WHEN YOU ROTATE A SYMBOL, THE SYMBOL TEXTS WILL BE ROTATED WITH 

THE SYMBOL.
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TEXT LINKS

What is a text link?

To ensure that all project texts referring to the same contents are always identical, 
Automation contains a function named text links. When you have linked two — or 
more — texts, and edit one of these texts, the other linked texts are changed auto-
matically.

Any function, from which you can edit texts in the program, updates linked texts 
automatically when editing — see “Where to edit texts in link lists” on page 148.

This is also the case when importing PLC I/O data — see “Text links and importing 
PLC I/O lists” on page 148.

Indication of linked texts

When a text is linked, this is indicated in dialog boxes by a Flash in front of the text 
— for instance in the Component data dialog box:

This is also the case in the Object Lister — see “The Object Lister” on page 341.

In diagrams linked texts are indicated by an arrow drawn through the reference 
point of the text:

THIS CHAPTER DESCRIBES

— WHAT IS A TEXT LINK?..............................................................................p. 144

— INDICATION OF LINKED TEXTS....................................................................p. 144

— CREATING LINKED TEXTS FROM THE TEXTS COMMAND ...............................p. 145

— CREATING LINKED TEXTS FROM THE SYMBOLS COMMAND ..........................p. 145

— THE DIALOG BOX TEXT LINK......................................................................p. 147

— EDITING A TEXT LINK ................................................................................p. 147

— DELETING A TEXT LINK..............................................................................p. 148

— TEXT LINKS AND LOADING PLC I/O LISTS ..................................................p. 148

— MAINTAINING TEXT LINKS ..........................................................................p. 148
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Creating a text link from the Texts command

There are different ways of creating text links in Automation. When working with 
texts, do the following:

 1) Select a text in the project — for instance click at the Texts button, then right-
click on the text reference point, and choose Text link:

 2) The dialog box Text link is displayed: Click on a new text in the project, and 
click on the Add text to link button to link the new text to the text in the dia-
log box:

 3) Continue adding texts to the text links until all relevant texts are linked.

 4) Close the dialog box Text link by clicking on the Close button in the upper 
right-hand corner of the dialog box.

— See “Creating text links from Component data and Connection data” on 
page 145 also.

Creating text links from Component data and Connection data

When working with symbols, you can link symbol texts like this:

 1) Click on Symbols — to start working with symbols.

 2) Right-click on a symbol and select Component data.
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 3) In the dialog box Component data: Right-click in one of the text fields (see 
“Symbol names and Connection names can not be linked” on page 146), and 
select Text link.

 4) You now enter the dialog box Text link, from which you can link texts. — If 
the dialog box Text link is already open, the selected text is added to the 
active link list in the dialog box Text link).

 5) Close the dialog box Component data for the selected symbol, and add 
new texts to the link via the Component data dialog box for other symbols in 
the project, or shift to the Texts command and link more texts as described in 
“Creating a text link from the Texts command” on page 145.

 6) Continue linking texts until all relevant texts are linked.

 7) Close the dialog box Text links by clicking the Close button in the upper 
right-hand corner of the dialog box.

You can do exactly the same for connection points in the dialog box Connection 
data.

SYMBOL NAMES AND CONNECTION NAMES CAN NOT BE LINKED

IN THE DIALOG BOX COMPONENT DATA YOU CAN LINK ALL TEXTS — EXCEPT 

THE SYMBOL NAME.

IN THE DIALOG BOX CONNECTION DATA YOU CAN LINK ALL TEXTS — EXCEPT 

THE CONNECTION NAME.
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The dialog box Text link

In the dialog box Text link a list of all texts which are linked together — a link list — 
is displayed:

Here you have the following options:

Linking texts to the texts in the link list

When working with Texts, and the dialog box Text link is open, you can add new 
texts to the link list by clicking on a text in the project, and then click on the Add 
text to link button in the dialog box Text link.

Removing texts from the selected link

When working with Texts, and the dialog box Text link is open, you can remove a 
text from the link list by clicking on the text in the dialog box, and then click on the 
Remove text from link button in the dialog box Text link.

Show text location

To jump to a text in the project from the dialog box Text link, you have the two fol-
lowing options:

a) Click on the text in the dialog box Text link, and click on the Show text loca-
tion button, or

b) Double-click on the text in the dialog box Text link

The program now displays the page in the project where the text is placed, and 
selects the text. The dialog box Text link remains active on the screen.

Load link list of selected text

When the dialog box Text link is open, and you select a new text in Automation, 
and click on the Load link list of selected text button, the link list of the selected 
text is loaded in the dialog box.

Editing text links

When you wish to add texts to a link list after closing the dialog box Text link — or 
you wish to delete texts from the link list — do this:

 1) Click on the Texts button — to work with texts.
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 2) Right-click on one of the texts in the link list, and open the dialog box by 
selecting Text link.

 3) In the dialog box Text link: Add texts to the link list as described in “Creating 
a text link from the Texts command” on page 145, or remove a text from the 
link list by clicking on the Remove text from link button.

 4) When you have finished editing: Close the dialog box by clicking on the 
Close button in the upper-right corner of the dialog box.

The text used in the text link list can also be edited from the Object Lister, just like 
you edit non-linked texts. — See “The Object Lister” on page 341.

Deleting a text link list

 1) Click on the Texts button — to work with texts.

 2) Right-click on one of texts in the link list, and open the dialog box Text link 
by selecting Text link.

 3) Click on the Remove text from link button in the dialog box until only one 
text remains in the dialog box.

 4) The links are now deleted: Close the dialog box.

Text links and importing PLC I/O lists

When you import a PLC I/O list in Automation — see “Reading PLC I/O lists” on 
page 483 — and a text hereby is changed (a PLC input/output description), which 
is linked to other texts in the project, these texts are automatically changed to the 
imported text.

Where to edit texts in link lists

The texts in the link lists can be maintained the following places:

- From the Symbols command: In the dialog boxes Component data and Con-
nection data — see “Creating text links from Component data and Connection 
data” on page 145

- From the Texts command — see “Editing text links” on page 147

- From the Object Lister — see “The Object Lister” on page 341

- During import — see for instance “Text links and importing PLC I/O lists” on 
page 148

When you edit a linked text, all of the other linked texts are changed accordingly — 
no matter which way you edit the text.
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SYMBOLS

In Automation you apply symbols when you want to show components — or func-
tions in components — in the diagrams in your projects.

Component based workflow

Automation has a component based workflow which encourage working with an 
attached component database, containing information about the components that 
you can use in your projects.

You can also draw - and attach article data later

But you also have the option to just place symbols in the active project and then 
attach article data to them at a later stage.

If you just want to place a lamp, you can just find the symbol for a lamp and insert it 
on the relevant diagram page — and attach article data at a later stage, if neces-
sary. — See “Attaching information from the Database to a Symbol” on page 631.

Components with multiple functions - via the database

When you are about to place a component containing multiple functions, you can 
fetch it from the attached component database. This gives you a pickmenu contain-
ing a symbol for each of the functions in the project — with automatically attached 
article data.

Functions at symbol as well as component level

Automation contains functions for both working at symbol and component level. 
This chapter describes how work with symbols in Automation.

This chapter predominantly describes working with electrical symbols. If you want 
to know more about working with mechanical symbols, please see “Mechanical 

pages and symbols” on page 689.

FUNCTIONS ON COMPONENT LEVEL

MORE SYMBOL FUNCTIONS ARE DESCRIBED IN “Functions on Component 
Level” on page 250, WHERE YOU ALSO WILL FIND A DESCRIPTION OF THE 

COMPONENT MENU IN THE RIGHT-HAND SIDE OF THE WORK AREA.

THE RELATIONSHIP BETWEEN COMPONENTS AND SYMBOLS ARE DESCRIBED 

IN “The relationship between Symbols and Components” on page 251.
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Options for symbols described in other chapters

You can learn more about working with symbols here:

- See how to move, copy, delete and rotate symbols in the section “Working with 
selected objects” on page 58.

- See how to transfer object properties between symbols in “Transferring Compo-
nent Data for Symbols or Lines” on page 62.

- PLC functions: Read more about the special options for working with PLC sym-
bols in “PLC functions” on page 463.

- See “Creating Data symbols” on page 797 for information about how to use 
data symbols.

Designing your own symbols

If you can not find the symbol you need among the symbols that come with 
Automation, then read “Creating Symbols” on page 761, to see how you design 
your own symbols. — Also see “Automatic generation of symbols” on page 217.

THIS CHAPTER DESCRIBES

— FETCHING SYMBOLS WITH AND WITHOUT USING THE DATABASE ................p. 151

— PLACING AND NAMING SYMBOLS...............................................................p. 171

— SYMBOL SUB NAMES................................................................................p. 183

— SYMBOLS WITH STATES ............................................................................p. 185

— NAVIGATING BETWEEN SYMBOLS FOR THE SAME COMPONENT ....................p. 190

— UPDATING SYMBOLS FROM THE DATABASE ................................................p. 191

— MOVING AND DELETING PLACED SYMBOLS ................................................p. 193

— THE SYMBOL TOOLBAR.............................................................................p. 196

— ADAPTING THE PICKMENU.........................................................................p. 198

— CHANGING SYMBOL NAMES IN AREAS........................................................p. 205

— SYMBOL CONNECTION POINTS...................................................................p. 207

— CHOOSING CONNECTION POINTS IN AREAS................................................p. 209

— THE PIN SWOP FUNCTION.........................................................................p. 210

— REPLACING SYMBOLS ...............................................................................p. 213

— AUTOMATIC GENERATION OF SYMBOLS......................................................p. 217

— THE SHOW NET FUNCTION AND THE NETLISTER ........................................p. 222

— NET NAVIGATOR ......................................................................................p. 223

— USING SIGNAL SYMBOLS ..........................................................................p. 225

— USING TERMINAL SYMBOLS.......................................................................p. 236

— USING MULTILAYER TERMINAL SYMBOLS....................................................p. 237

— USING CABLE SYMBOLS............................................................................p. 239

— USING BUSBAR SYMBOLS .........................................................................p. 246

— USING ACCESSORY SYMBOLS ...................................................................p. 246

— SYMBOL FOLDERS IN Automation .........................................................p. 247
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FETCHING SYMBOLS

When you want to work with Symbols, you always start by clicking the Symbols 
button — or use the short-cut key <s>. — See “Auto command change” on 
page 57 also.

The general short-cut key for the Pencil is the <Ins> key, but you can also use the 
<s> key when you are working with Symbols. Pressing the <Ins> or the <s> key 
activates/deactivates the Pencil.

Beyond copying an already placed symbol, there are several ways of fetching a 
symbol in Automation:

Some of the functions are handy when you work without 
using the database, others when you know the exact article 
number of the component you want, others again when you 
know which type of component you want, but do not know 
its exact article number.

WAY TO FETCH SYMBOLS PAGE

FROM THE PICKMENU 152

FROM THE SYMBOL MENU 159

FROM THE DATABASE 167

TYPING IN A SYMBOL FILENAME 168

TYPING IN AN ARTICLE NUMBER 169

TYPING IN A SYMBOL TYPE 170

DIRECT GENERATION OF SYMBOLS 217

FROM WINDOWS EXPLORER 370

USING A BARCODE SCANNER 688

AUTOMATIC LINE DRAWING WHEN PLACING

SYMBOLS

WHEN YOU PLACE A SYMBOL YOU CAN USE THE 

ROUTER FUNCTION, WHICH DRAWS THE LINES CON-

NECTING THE SYMBOL TO THE DIAGRAM AUTOMATI-

CALLY. — READ MORE ABOUT THIS IN “Automatic 
line drawing / Router” on page 94.
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1. Fetching symbols from the Pickmenu

When working in Automation, you have the Pickmenu available on the upper part 
of the screen. Here you place the symbols, components, sub drawings and other 
drawing objects that you use the most.

When you click on a symbol in the pickmenu, you get the symbol in the cross hairs, 
and can place it in the project. The program changes automatically to work with 
Symbols, and the Pencil is activated.

When you choose a symbol with attached article data (a component), the symbols 
for the component are displayed under Available symbols in the lower right-hand 
corner of the screen, if the component has more than one attached symbol. — See 
“Components in the Pickmenu (Symbols with attached article data)” on page 153.

When you choose a sub drawing, you get the sub drawing in the cross hairs, and 
can place it in the project. — Read more in “Sub drawings in the Pickmenu” on 
page 157.

If the pickmenu is not displayed on the screen, choose Settings => Pointer/
Screen and click on Pickmenu.

The pickmenu can also contain line types, text types and arcs. — Read more about 
the pickmenu in “Lines in the Pickmenu” on page 79, “Texts in the Pickmenu” on 
page 137 and “Circles / Arcs in the Pickmenu” on page 106.

OTHER POSSIBILITIES WHEN USING THE PICKMENU

— CHANGING BETWEEN MENUS IN THE PICKMENU..........................................p. 153

— SYMBOLS / DRAWING OBJECTS DISPLAYED IN ALL PICKMENUS....................p. 153

— COMPONENTS IN THE PICKMENU......................................................... p. 153

— ENTERING THE DATABASE USING THE PICKMENU........................................p. 154

— ALTERNATIVE ELECTRICAL SYMBOLS .........................................................p. 155

— SYMBOLS WITH STATES IN THE PICKMENU .................................................p. 157

— POSSIBILITIES AND LIMITATIONS WHEN USING THE PICKMENU .....................p. 158

Symbols/drawing objects displayed in all pickmenus

Select different menus

in the pickmenu

Click on a symbol, and place it

in the diagram
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Selecting the different Pickmenus

The pickmenu contains several different menus, which you select by clicking on the 
tabs at the bottom of the pickmenu.

— See how to create new menus in the pickmenu in “Creating new menus in the 
Pickmenu” on page 200.

Symbols/ Drawing objects displayed in all Pick-
menus

Symbols / drawing objects with a small triangle in the 
upper-left corner of the pickmenu cell, are displayed in 
all menus in the pickmenu.

— See how to give a symbol / drawing object this status 
in “Inserting a Symbol / Drawing object in all Pick-
menus” on page 198.

Components in the Pickmenu (Symbols with attached article data)

The symbols in the Pickmenu can be attached to components in the database.

When you place symbols for a component on a project page, article data are auto-
matically attached to the symbols in the diagram.

This way you automatically attach component data to the symbols when you place 
them in diagrams.

When the component contains more than one function, the symbols for the compo-
nent are displayed in the Symbols for component window, at the bottom of the 
Component menu, when you click on the component in the Pickmenu.

Click to select a new menu

in the pickmenu

Displayed in

all pickmenus

Displayed in selected

pickmenu only
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Here you can click one of the symbols under Available symbols and place it in the 
project. This way you include the component in the project. If you do not place any 
of the symbols for the component on a project page, you have not included the 
component in the project.

— Read more about this in “The Component menu” on page 254.

When you let the cursor rest for a moment over one of the symbols in the pick-
menu, the component data is displayed below the symbol (as a hint) and at the bot-
tom line of the screen.

SYMBOLS WITH MULTIPLE SETS OF DATA IN THE PICKMENU

You can also assign multiple sets 
of component data to a symbol (a 
cell) in the pickmenu. This way 
the same cell can contain the 
same component with e.g. differ-
ent capacities.

When you let the mouse rest over 
a cell containing multiple sets of 
component data, a submenu is 
displayed for the different sets. — 
See “Automatic popup of sub-
menus in the pickmenu” on 
page 199.

You can see that a symbol cell contains component data, by the light-blue rectan-
gle in the lower-right corner of the cell.

— See how to create multiple sets of component data for a symbol in a cell in 
“Adding component data to symbols in the pickmenu” on page 200.

Entering the database using the pickmenu

If you press down <Ctrl> while clicking on a symbol in the pickmenu, you enter the 
database. Here you can see the components that have got the picked symbol as 
the first symbol in the Symbol field of the database. — See “Database settings” on 
page 670 and/or the PCSCHEMATIC Database manual.

It is also possible to right-click on the symbol in the pickmenu, and choose Data-
base.

Select the desired component in the database and click OK.
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Alternative electrical symbols
When you fetch a component via the database — for instance by using the Pick-
menu — it is some times possible to choose between alternative electrical symbols 
for the functions of the component.

If for instance a component has a relay coil and three switch functions, the switch 
functions can be used as either a switch, a make contact or a break contact.

When such a component is displayed under Symbols for components in the 
lower right-hand corner of the screen, the three sets of alternative symbols could 
look like this:

When you choose one of these alternative symbols, the other alternatives for the 
function disappears.

Two displays of the same
set of alternatives
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In the tree structure a checkmark is set next to the selected symbol, which is also 
highlighted by blue text while the other symbols are dimmed.

SYMBOLS WITH MULTIPLE LAYERS OF ALTERNATIVES

It is also possible to create components containing "alternatives containing further 
alternatives". For instance you could first choose between different relay coils, and 
then — depending on this choice — choose between different sets of contacts. 
Thus, the first layer of alternatives is the selection of the relay coil, while the sec-
ond layer of alternatives is the selection of contact sets.

Below you can see how a such component could be presented in the tree structure 
in the Symbols for component window, as well as four examples on how this 
component could be displayed in the diagram.
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— Please also see “Symbols with states” on page 157.

Other options for using alternative symbols

There exists many other ways to use alternative symbols than just the example 
above.

Power control circuit symbols can for instance exist in a normal version and a ver-
sion for one-line diagrams. You can also choose whether to use PLC modules or 
single I/O symbols.

— See how to specify the alternative symbols in the database in “Specifying alter-
native electrical symbols via the database” on page 652.

Symbols with states

Symbols with states can also be placed in the pickmenu. When a symbol in the 
pickmenu has states, a dark blue triangle is displayed in the lower-right corner of 
the cell in the pickmenu.

You can specify whether to display a submenu automatically, as described in 
“Automatic popup of submenus in the pickmenu” on page 199. When you let the 
mouse rest over the state for a symbol, the title for the state is displayed, if a title for 
the state exists.

— See “Symbols with states” on page 185, “Symbols with states for single line dia-
grams” on page 462 and “Creating symbols with states” on page 777.

Sub drawings in the Pickmenu

When you click on a subdrawing in the Pickmenu, you get the sub drawing in the 
crosshairs, and can place it in the project.

If the sub drawing contains data for different models, you select the model like this:

When you choose to place the sub drawing on a mechanical page, the mechanical 
symbols for the sub drawing are placed on the page.

— See how to place sub drawings in the Pickmenu in “Placing sub drawings in the 
Pickmenu” on page 202.

THE RECOMMENDED PROCEDURE FOR SUB DRAWINGS

IN “Manual placing of sub drawings” on page 292 YOU CAN READ MORE 

ABOUT THE NORMALLY RECOMMENDED PROCEDURE FOR PLACING SUB 

DRAWINGS USING THE SUBDRAWINGS TAB IN THE EXPLORER WINDOW.

READ MORE ABOUT SUB DRAWINGS IN THE CHAPTER “Sub drawings” on 
page 289.

1) Let the cursor rest over the subdrawing shortly

2) Click on the desired model
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Possibilities and limitations when using the pickmenu

You have the option of creating 999 different pickmenus. By clicking the up- and 
down arrows in the left side of the pickmenu, you can jump from one pickmenu to 
another. — See how to place symbols in the pickmenu in “Adapting the Pickmenu” 
on page 198.

The pickmenu can be moved around on the screen as an ordinary window in Win-
dows, and can also be docked. When it is docked it will always be displayed on the 
screen. You can read more about this in “Docking the Pickmenu” on page 27.
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2. Fetching symbols using the Symbol menu

Click the Symbols button and the 
Symbol menu button — or press 
the short-cut key <F8>.

You can also click the Symbol 
menu button in the upper part of 
the Explorer window, as dis-
played to the right. This button is 
always available, no matter which 
command you are working in.

Alternatively, you can select Func-
tions => Symbol menu.

In the Symbol menu you then pick the symbol you need:

Placing the found symbol

Click on the desired symbol and click OK — or double-click on the desired symbol 
—, and you return to your diagram with the symbol in the cross hairs.

SHOW SYMBOLS FASTER IN THE SYMBOL MENU

WHEN THE SYMBOLS IN YOUR SYMBOL LIBRARIES ARE NOT PLACED ON 

YOUR OWN PC, BUT ARE LOCATED SOMEWHERE ON YOUR NETWORK, THIS 

CAN RESULT IN A SLOW DISPLAY OF SYMBOLS IN THE DIALOG BOX.

— SE HOW TO PREVENT THIS IN “Show symbols faster in the Symbol 
menu” on page 166.
mation

Page 159



P

Symbols
Place the symbol in the project, and press <Esc> to remove the symbol from the 
cross hairs.

Displaying symbol libraries / project symbols in the Symbol menu

When you wish to locate symbols in the Symbol menu, you can choose which 
symbols to display, in the following way:

Display Library via Folders

Click the Select Libraries from Folders button. You then get an explorer structure 
in the left-hand side of the Symbol menu, where you can find the folder in which 
the desired symbol library is placed.

In the folder Pcselcad on the C:\-drive, you find the folder Symbol. In this folder 
you find a number of sub folders containing various symbol libraries.

When you have chosen a folder here, such as EN60617, you see these symbols 
displayed in the window in the Symbol menu. When there are more symbols than 
can be displayed in the window, there will be a scroll bar in the window.

The contents of the symbol libraries is described in “Symbol folders” on page 247.

If you need to know more about changing folders and opening files, please read 
“Windows” on page 23.

Selecting Libraries via Alias

Click on the Select Library from Alias button. Hereby a list of the created aliases 
in the left-hand side of the Symbol menu. Each of these aliases points on a folder, 
which contains a symbol library.

POSSIBILITIES IN THE SYMBOL MENU

— SYMBOL LIBRARIES / PROJECT SYMBOLS IN THE SYMBOL MENU .................p. 160

— REPRESENTATION OF SYMBOLS IN THE SYMBOL MENU...............................p. 161

— SEARCHING IN THE SYMBOL MENU ............................................................p. 162

— BOOKMARKS IN THE SYMBOL MENU...........................................................p. 163

— ENTERING THE DATABASE VIA THE SYMBOL MENU .....................................p. 166

— CREATING NEW SYMBOLS FROM THE SYMBOL MENU ..................................p. 166

— SHOW SYMBOLS FASTER IN THE SYMBOL MENU.........................................p. 166

AUTOMATIC UPDATE OF THE SYMBOL MENU

IF SYMBOLS, OR THE CONTENTS OF THE SYMBOL DIRECTORY DISPLAYED IN 

THE SYMBOL MENU CURRENTLY, ARE CHANGED FROM OUTSIDE THE PRO-

GRAM — E.G. VIA WINDOWS EXPLORER OR OTHERS ON THE NET — THE 

SYMBOL MENU IS UPDATED AUTOMATICALLY.
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When installing Automation, aliases for the installed symbol libraries are created 
automatically.

— Read more about alias in “Alias for directories” on page 912.

Showing the Project Symbols

Click on the Show Project Symbols button. Hereby all symbols in the project are 
displayed.

Show the most recently used symbols

Click on the History button. Hereby the last 50 symbols fetched via the Symbol 
menu are displayed. This also includes symbols fetched via the Symbol menu 
when working in other projects.

Representation of symbols in the Symbol menu

In the upper right-hand corner of the Symbol menu, you will find three buttons to 
specify how the symbols are displayed in the Symbol menu:

Symbols displayed as Large icons

When you click on the Large icons button, the 
symbols are displayed in the Symbol menu.

When placing the mouse cursor over a symbol, 
the Title, Name and Type of the symbol is dis-
played as a hint.

Symbol names displayed in a List

When you click on the List button, a list of the sym-
bol file names are displayed.

When placing the mouse cursor over a symbol 
name, the symbol is displayed in the right-hand side 
of the menu, and the Title, Name and Type of the 
symbol is displayed as a hint.

Symbol names displayed with Details

When you click on the Detail button, a list of the symbol file names is displayed, 
containing detailed information on the selected symbols.

YOU CAN USE ALIASES, WHICH POINTS ON SYMBOL LIBRARIES PLACED ALL 

OVER THE WORLD.
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When placing the mouse cursor over a line in the list, the symbol is displayed in the 
right-hand side of the menu.

Searching in the Symbol menu

When you need to search after a symbol in 
the selected library, click the Search button 
— or press <Ctrl+f>.

A search field is then displayed. Here you can type in the text you are searching for.

Click on the down-arrow to the right of the Search button to specify which type of 
information you are searching for:

Then type in the symbol text you are searching for in the search field. As you type 
in the text, the program will select the first symbol in the symbol library, having a 
symbol text beginning with the text you have typed in so far. To jump to the next 
symbol matching the text, click the Search again button — or press <F3>.

It makes no difference for the program whether the text has been written as upper 
case or lower case letters.

Begins with/Contains

If you take no special action, the program starts searching for texts beginning with 
the text you type in. When you wish to search for a text that just exists somewhere 
in the selected text type, click on the Begins with/Contains button, so that it 
changes appearance from T... to ..T...

When this happens, the program searches for the text fragments anywhere in the 
selected text types.

To return to searching for texts beginning with the typed in text, click on the Begins 
with/Contains button again, so that it changes appearance from ..T.. to  T....

Click here, and specify

which type of information

you are searching for
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Bookmarks in the Symbol menu

When the Symbol menu displays aliases or folders, it is possible to insert book-
marks. When you click on a bookmark, you jump down to the selected bookmark in 
the folder.

Creating a bookmark in the Symbol menu

To create a bookmark, right-click on a symbol in 
the Symbol menu, and choose Create book-
mark.

You then enter the dialog box Create Bookmark:

Type in the name of the bookmark, and click OK.

The bookmark is now displayed in the lower left-hand corner of the dialog box, 
when you select the alias or library in question in the Symbol menu.

Editing or Deleting created bookmarks

To edit or delete a created bookmark, right-click on the bookmark and choose Edit 
bookmark or Delete bookmark.

Bookmarks and copying symbol libraries

Information about bookmarks are saved in the relevant symbol libraries. This has 
the following consequences:

 1) When there is access to the library from other PCs on the network, the book-
marks can also be seen from these PCs.

 2) When you copy the library, the applied bookmarks are included automati-
cally.

Click on the

bookmark
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Hierarchical displaying of symbols in the Symbol menu

In Automation, the symbols are placed in different folders, without any hierarchical 
structure (see “Bookmarks in the Symbol menu” on page 163 also).

When you click the Symbol groups button in the Symbol menu, you get the 
option of creating your own hierarchical structure, which can make it easier for you 
to find the symbols. You then enter the folder Symbol Grp, which is placed under 
Pcselcad\Symbol:

Here you can create your own grouping of the symbols, which you already have 
access to.

This is done by first creating a structure of 
folders with relevant names. In these fold-
ers, you create the so-called groups, and it 
is in these groups that you can place the 
symbols. Please note, that it is not possi-
ble to place the symbols in a folder, they 
can only be placed in a group.

Example on creating a hierarchical
structure

 1) Create the first folder: Right-click on 
the folder Symbol Grp, and select 
Add folder. Type in the folder name 
Contacts, and click OK.

 2) Create sub folders: Right-click on 
the folder Contacts, and create the sub folder Make, just like you created the 
first folder. Under the Contacts folder, you also create the sub folders Break 
and Switch.

 3) Create a group: Right-click on the folder Switch and select Add group. Type 
in the group name 1P, and click OK. In this group 1P, you can now place sym-
bols.

SYMBOLS ARE NOT PLACED DIRECTLY IN THE GROUPS

THE SYMBOLS ARE NOT PLACED DIRECTLY IN THE CREATED GROUPS. IN 

STEAD, A LINK (OR A REFERENCE) IS CREATED TO THE FOLDER WHERE THE 

SYMBOL IS PLACED IN THE SYMBOL MENU. WHEN A SYMBOL IS CHANGED 

VIA THE EDIT SYMBOL FUNCTION, THE SYMBOLS ARE THEREFORE AUTOMAT-

ICALLY CHANGED IN ALL THE GROUPS, WHICH REFERS TO THE THE EDITED 

SYMBOL.
THE SAME SYMBOL CAN APPEAR IN DIFFERENT GROUPS.
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You have now created a hierarchical structure, containing a group, in which you 
can place symbols.

Placing symbols in a hierarchical structure

To place symbols in a group in the hierarchical structure, do this:

 1) Select the group in the left side of the Symbol menu.

 2) Right-click in the right side, and select Add symbol:

 3) The dialog box Get symbol is now displayed: Select the folder where the 
symbol is placed, by clicking on the folder in the left side of the window.

 4) Now find the symbol in the right side of the window, and double-click on the 
symbol to add it to the group. You can also drag the symbol from the Get 
symbol window, and place it in the group:

1) Select group 2) Right-click and select Add symbol

3) Find the folder

where the symbol

is placed

4) Double-click on

the symbol, or drag

it into the group
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Remove symbol from group

If you wish to remove a symbol from a group, right-click on the symbol, and select 
Remove symbol.

Entering the database from the Symbol menu

To find symbols in the database which has attached symbols of a specific type, do 
the following:

 1) Enter the Symbol menu.

 2) Find the desired symbol, and click on it.

 3) Click on the Database button, and you enter the Database menu.

In the database you now see all the components which has the selected symbol as 
the first symbol in the Symbol field in the database. — See “Database settings” on 
page 670 and/or the PCSCHEMATIC Database manual.

— Read more about fetching symbols via the database in “Fetching symbols from 
the database” on page 167.

Creating symbols or Editing existing from the Symbol menu

To create a new symbol, click on the Create new symbol button.

When you wish to edit an existing symbol, click on it in the Symbol menu, and 
click on the Edit symbol button.

— Read more about this in “Creating Symbols” on page 761.

Show symbols faster in the Symbol menu

When the symbols in your symbol libraries are not placed on your own PC, but are 
located somewhere on your network, this can result in a slow display of symbols in 
the dialog box.

To prevent this on slow networks, do this:

 1) Click the Optimize button in the lower-right corner of the Symbol menu dia-
log box

 2) In the dialog box Optimize symbol view: Select Include subfolders, click 
the Show default symbol library button and click Start

MAY TAKE A LONG TIME ON SLOW NETWORKS!

DEPENDING ON THE SPEED OF THE NETWORK — AND THE NUMBER OF SYM-

BOLS IN THE FOLDERS — THIS MAY TAKE A LONG TIME. EVEN HOURS. BUT 

ONCE IT’S DONE, YOU WILL NEVER NEED TO DO IT AGAIN.
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3. Fetching symbols from the database

If you already know which components you are going to use, you can fetch the 
symbol directly from the database.

Entering the database

Click the Symbols button, press 
down <Ctrl> and click the Symbol 
menu button — or click the Com-
ponent Database button in the 
upper part of the Explorer win-
dow, as displayed to the right. This 
button is always available, no mat-
ter which command you are work-
ing in.

You then enter the database 
directly, if it is on (See “Using the 
database” on page 629 for how to 
turn a database on). You can also 
press the short-cut key <d>.

OPTIONS IN THE DATABASE MENU

— SELECTING A SYMBOL IN THE DATABASE ...................................................p. 168

— PLACING SELECTED SYMBOLS FROM THE DATABASE ..................................p. 168

Select

component

group

Components

Searching

and navigation

Choose e.g.

Fabricate
mation

Page 167

http://www.dps.dk/english/Video/Product_videos.htm


P

Symbols
Selecting a symbol in the database

Click on a folder, for instance Automatic switches / connection material, and 
choose e.g. a Fabricate in the upper right-hand corner of the dialog box, and 
select a component.

Select for instance the component with EAN number 4022903075387 — as dis-
played above. Click OK.

— Read more about searching in the Database menu in “Using the database” on 
page 629.

Placing the selected symbols from the database

A special pickmenu, containing all the electrical symbols for the component, now 
appears in the lower part of the Symbols for component window inside the Com-
ponent menu in the right-hand side of the screen:

If the component consists of just one symbol, you automatically get this symbol in 
the cross hairs.

Click on the symbol you want to use, and place it where you want it.

4. Typing in the symbol file name directly

When you have activated Symbols and press the short-cut key <k>, you enter this 
dialog box:

Type in the file name of the symbol you want, and press <Enter>. The program now 
search the contents of the folder you used last time you used the Symbol menu. If 
the program does not find the symbol there, the program searches the symbol 
libraries with alias — as described in “Alias for directories” on page 912.

If the program can not find a matching symbol, you will enter the Symbol menu. If 
there exists a symbol in the Symbol menu whose name starts with the text you 
typed in, it will be selected.

— In “Automatic generation of symbols” on page 217 you can see how to create 
symbols directly from this dialog box.
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5. Typing in the Article Number directly

When you have activated Symbols and choose Functions => Database => Find 
Article — or press the short-cut key <b> — you enter this dialog box:

Here you type in as much you can remember of the article number, and click OK.

You then enter the database, which displays all components having an article num-
ber matching what you typed in.

If you typed in 40 — as in the figure above — the database will look like this:

Click on the desired component, and click OK.

If the component consists of a single symbol, you now get the symbol in the cross 
hairs. If the component contains more than one symbol, these are displayed under 
Available Symbols in the lower-right corner of the screen.

Click on the symbol you want to use, and place it in a diagram.

If you type in a complete article number in the Place symbol dialog box, you get 
the symbol directly in the cross hairs without entering the database menu.
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6. Typing in the Symbol Type directly

When you have activated Symbols and choose Functions => Database => Find 
Type — or press the short-cut key <v> — you enter this dialog box:

Here you type in as much you can remember of the symbol type, and click OK.

You then enter the database, which displays all components having a symbol type 
matching what you typed in.

If you typed in S you get a list of all components in the database of a type starting 
with S — similar to explained above. Click on the desired component, and click 
OK. You now get the electrical symbol for the component in the cross hairs, or a 
pickmenu is displayed under Available symbols — in the lower-right corner of the 
screen — containing all electrical symbols for the component.

If you type in a complete type specification, you get the symbol directly in the cross 
hairs without entering the database menu.

UPPER AND LOWER CASE CHARACTERS IN THE DATABASE

WHEN YOU TYPE IN THE SYMBOL TYPE, THE PROGRAM DISTINGUISHES 

BETWEEN UPPERCASE AND LOWERCASE LETTERS WHEN YOU ARE APPLYING 

A DATABASE FORMAT, WHICH IS ABLE TO MAKE THIS DISTINCTION.

IF FOR INSTANCE YOU ARE USING AN ACCESS DATABASE, THERE WILL BE 

NO DISTINCTION BETWEEN UPPER AND LOWER CASE CHARACTERS.

THE DBASE FORMAT, ON THE OTHER HAND, MAKES THIS DISTINCTION.
Automation

age 170



Symbols

Auto
PLACING AND NAMING SYMBOLS

When you have got a symbol in the cross hairs — using one of the ways mentioned 
in “Fetching symbols” on page 151 — you can place it by clicking where you wish 
to place it on the drawing.

When you place the symbol, you will automatically be asked about the Compo-
nent data in the following dialog box:

In the dialog box Component data above you type in the component name, and 
other relevant information. — Please refer to “Texts connected to symbols” on 
page 113 for details about the contents of these text fields.

If you have selected the symbol via the database, all the fields are filled out auto-
matically — except for the symbol/component name.

Click OK when you are satisfied with the settings, or click Cancel to cancel the 
changes in the contents of the dialog box.

Press <Esc> to remove the symbol from the cross hairs.

CHANGES CAN BE TRANSFERRED TO ALL SYMBOLS FOR THE COMPONENT

WHEN TEXT PARAMETERS ARE CHANGED IN THE DIALOG BOX COMPONENT 

DATA, THE MESSAGE ALL=CHANGE ALL SYMBOLS FOR THE COMPONENT IS 

DISPLAYED IN THE UPPER-LEFT CORNER OF THE DIALOG BOX.

IF YOU THEN CLICK THE ALL BUTTON IN THE DIALOG BOX, THE CHANGES IN 

THE FIELDS NAME, TYPE, ARTICLE NO, FUNCTION AND THE REFERENCE 

DESIGNATIONS ARE TRANSFERRED TO ALL THE OTHER SYMBOLS FOR THE 

COMPONENT. AT THE SAME TIME ALL SYMBOLS FOR THE COMPONENT ARE 

UPDATED FROM THE DATABASE, AS DESCRIBED IN “Update from Database 
when changing symbol Article no” on page 269.

 IF YOU CLICK OK, DATA IS ONLY CHANGED FOR THE SELECTED SYMBOL.

When the component has an attached refe-

rence designation, it is displayed here

Reference desig-

nations and sub

names are edited

here
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Automatic naming of symbols

When you activate the Auto name button, the symbols you place are assigned the 
next available symbol name for that type of symbol without entering the Compo-
nent data dialog box.

The button is located in the Symbol toolbar on the upper part of the screen. — See 
“The Symbol toolbar” on page 196.

How not to enter the dialog box Component data automatically

If you do not want to enter this dialog box each time you place a symbol, you can 
disable the function by deselecting Ask for names in Settings => Pointer/
Screen. — See “Pointer/Screen” on page 906.X

AUTO NAMING OF SYMBOLS ON AUTOMATIC PROJECT GENERATION

WHEN GENERATING PROJECTS AUTOMATICALLY, THE SYMBOLS IN THE CRE-

ATED PROJECT CAN BE NAMED CONSECUTIVELY AUTOMATICALLY.

— READ MORE ABOUT THIS IN “Generating and Updating projects via 
Excel” on page 614, “Merging projects via Excel” on page 625 AND 

“Auto name symbols during generation” on page 630.

OPTIONS IN THE DIALOG BOX COMPONENT DATA

— SPECIFYING THE COMPONENT NAME .........................................................p. 173

— DISPLAYING/EDITING THE PARTS OF A COMPONENT NAME.........................p. 174

— SPECIFYING TYPE AND ARTICLE NO ..........................................................p. 174

— SPECIFYING FUNCTION .............................................................................p. 175

— VISIBLE/INVISIBLE TEXTS...........................................................................p. 175

— THE GENERAL TAB ...................................................................................p. 175

— THE REF.DESIGN. TAB ..............................................................................p. 177

— THE REFERENCE TAB ...............................................................................p. 178

— CHANGING CONNECTION DATA..................................................................p. 178

— THE ACCESSORY TAB...............................................................................p. 180

— THE SYMBOL DATA TAB ............................................................................p. 181

— COPYING COMPONENT DATA .....................................................................p. 182

— COLLECTING INFORMATION FROM THE DATABASE.......................................p. 182

— ATTACHING UNIT DRAWINGS TO SYMBOLS..................................................p. 182
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Specifying the Component name

In the Name field in the dialog box Component data you can either type in a 
name, or use one of the following options:

Automatic counting in the Component data dialog box

If you press down <Ctrl> when you click on + in the dialog box Component data, 
the names of the following symbols of the same type that you place, will be 
increased by one as you place them in the project.

When this function is activated, you will see a + in front of the Name field in the dia-
log box.

If you press down <Ctrl> when you click on -, they will automatically be decreased 
by one. A - will be displayed in front of Name when this function is activated.

If you press <Ctrl> while clicking on ?, subsequently placed symbols will automati-
cally be assigned the next available symbol name. When this function is activated, 
a ? will be displayed in front of the Name field.

Other options for naming symbols

To see how to rename more symbols at the same time, please refer to “Changing 
symbol names in an Area” on page 205.

BUTTON FUNCTION

Increase the number in the symbol name by one.

Decrease the number in the symbol name by one.

Gives you the next available symbol name for the 
relevant symbol type.

Gives you a list, where you can choose between 
the already used symbol names.

Gives you a selected list of symbol names for all 
relevant symbols in the actual situation.

INSERT SYMBOL NAMES - OR RENAME SYMBOLS

IF YOU NEED TO INSERT NEW/AVAILABLE SYMBOL NAMES — OR CONNEC-

TION NAMES — IN THE PROJECT, YOU CAN SEE HOW TO DO THIS IN “Insert 
new Symbol names or Connection names” on page 328.

IN “Rename selected symbols” on page 322 YOU CAN ALSO SEE HOW TO 

RENAME ALL OF THE SYMBOLS IN THE PROJECT — OR JUST SELECTED SYM-

BOLS.
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Please note that you can also change the symbol texts directly on the diagram 
page, as described in “Editing the symbol texts directly on a Diagram page” on 
page 114.

More advanced ways to change texts directly on diagrams are described in 
"Locking text types" and “Counting on texts” on page 131.

Current path names in symbol names

To include current path names in symbol names automatically, please refer to 
“Naming symbols due to page and current path number” on page 436.

Button for Displaying/Editing the parts of a Component name

The text for the Name field in the dialog box Component data is also a button, 
which you can click on. When clicking this Name button, you enter the following 
dialog box:

In this dialog box you can see and edit the different parts of the symbol name: 
Name (-), Function (=), Location (+), Product (-) and Sub name (.). Only active 
aspects are displayed in the dialog box.

— Please also see “The Ref.design. tab” on page 177 and “Sub names on sym-
bols” on page 183.

Options for the Type and Article no fields

For the fields Type and Article no in the 
dialog box Component data, you can 
either type in data, or fetch these via the 
Used and Used related buttons.

Here the Used button displays all used 
types and article numbers in the project, 
while the Used related button displays 
all used types and article numbers in 
the project for symbols of the same 
type.

In the appearing dialog box you can 
either choose type or article number 
separately, or both at the same time.

Click here and choose

between the applied

reference designations
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— Article number and type data can also be transferred automatically when choos-
ing components via the database, as described in “Fetching symbols from the 
database” on page 167.

Update from database when changing article number

When changing the Article no for a symbol, all symbols for the component are 
updated, if you subsequently select Change all symbols for the component and 
click OK in the Component data dialog box. If the new article number exists in the 
database, the symbols for the component are also updated with component data 
from the database.

The options for how this is done can be specified in Settings => Database => 
Update Components when changing Article No. => Settings, as described in 
“Update from Database when changing symbol Article no” on page 269.

— See also “Updating symbols from the database” on page 191.

Options for the Function field

For the Function field in the dialog box Component data, you can either type in 
data, or apply the buttons Used, Count up and Count down.

The Used button displays the currently applied texts in the project, while the Count 
up / Count down buttons counts up/down on the current function text.

Visible texts

By setting a check mark in the Visible fields, you determine which information will 
be displayed in the project. Read more about the texts in this dialog box in “Texts 
connected to symbols” on page 113.

Please note that the texts will only be displayed in the project if you have not disa-
bled this in Settings => Text/Symbol defaults — see “Texts displayed in the pro-
ject (general setting)” on page 138.

The General tab

On the General tab in the dialog box Component data you can see information 
about the symbol, such as the symbol file name, the symbol type, scale, visibility 
and rotation angle.

The Quantity field in the dialog box Component data

The field Quantity in the dialog box Component data specifies how many occur-
rences of the component the symbol represents.
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For cable symbols you can use the Quantity field for either calculating the cable 
lengths in the entire project or for counting the number of cables / cable symbols in 
the project. In the first case the cable lengths are specified in meters, so that it is 
possible to calculate how many meters of cable are needed in the project. — Also 
see “Predefined symbol datafields” on page 124.

The field Symbol type in the dialog box Component data

By clicking the down-arrow in the field Symbol type in the dialog box Component 
data you can change the symbol type. — Read more about symbol types in “Sym-
bol types” on page 771.

Symbol data in Electrical and Mechanical lists

You can also specify whether the symbol shall be represented in electrical and/or 
mechanical lists.

When you select Electrical, the symbol will be represented on terminals-, cables- 
and PLC lists and in connections list files, if the symbol contains the type of infor-
mation you choose to include in the various lists.

If you select Mechanical, the symbol will be represented in components- and parts 
lists.

When you place a symbol, both Electrical and Mechanical are selected automati-
cally, unless specified otherwise in the symbol definition. — See “Symbol settings: 
Advanced” on page 773.

Visible

When Visible is not selected, the symbol is not displayed on print — See “Making 
objects invisible” on page 69.

Name protected

When you select Name protected, the symbol name is protected against changes. 
This has the following consequences:

• When copying and inserting symbols for the component: The symbol name is 
not changed when the copied symbol is inserted. This also applies when sym-
bols for the component are part of a copied area.

• When using Insert name and Tools => Rename symbols (see “Rename sele-
cted symbols” on page 322) the symbol is not renamed.

• It is not possible to change the symbol name from the Object lister.

IN THE DIALOG BOX COMPONENT DATA: CLICK ON "ALL"

FOR COMPONENTS WITH MORE THAN ONE ATTACHED SYMBOL, PLEASE BE 

AWARE OF THIS: WHEN YOU SELECT NAME PROTECTED FOR ONE OF THE 

SYMBOLS FOR THE COMPONENT, YOU MUST SUBSEQUENTLY CLICK THE ALL 
BUTTON (AND NOT THE OK BUTTON) IN ORDER TO PROTECT THE NAME FOR 

ALL SYMBOLS FOR THE COMPONENT.
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Include in Mechanical Load

If Include in Mechanical Load is selected for the symbol, a mechanical symbol 
will be placed for the symbol during mechanical load, if a mechanical symbol exists 
for the component in the database.

Please note that this setting is selected by default, and that the setting covers all 
symbols for the component.

— Read more about mechanical load in “Placing mechanical symbols via the data-
base” on page 696.

The PLC connected component

When The PLC connected component is selected, the component is understood 
as the connected component when generating PLC lists.

— See “The PLC connected component” on page 942.

The Ref.design. tab

When you use reference designations in the active project, the Ref.design. tab will 
also appear in the dialog box Component data.

From here you choose the reference designations for the symbol, as described in 
“Reference designations for symbols” on page 400. — Another way of selecting 
reference designations for the symbol, is described in “Button for Displaying/Edit-
ing the parts of a Component name” on page 174.

— See also “Show full Reference designation” on page 402 and “Individual control 
of reference designations with line breaks from Component data” on page 402.
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The Reference tab

In Automation all symbols can have attached references. For symbols which does 
not have attached references by default, you will therefore find an extra Reference 
tab in the dialog box Component data.

— Read more about the use of this tab in “References on symbols” on page 423.

Changing Connection data

If you click on the tab Conns., and click in one of the text fields, you can change 
the connection texts for the symbols connection points.

If the connection names are changed in this dialog box, they are set to be visible 
automatically.

This can also be done from the dialog box Connection data, as described in 
“Symbol Connection points” on page 207.

Changing connection Name from the Component data box

From the dialog box Component data you can edit the symbol connection names 
in two ways:

CONNECTION NAMES WITH VARIABLE PART IN THE SYMBOL DEFINITION

If there exists a variable part in the connection name either in the PINDATA infor-
mation from the database or in the symbol definition — see “Connection data with 
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a variable part in the name” on page 766 —, there will exist an extra text field in the 
dialog box Component data.

Here you can type in the variable part of the connection name. If there is a ques-
tion mark, this represents one single character. If there is an asterisk, you can type 
in all of the connection name. This can for instance be applied for terminal sym-
bols. — See “Wildcards/jokers” on page 605 for further information about the wild-
cards ? and *.

Please note in the figure above that the connection names ?1 and ?2 are both 
changed to 61 and 62 respectively, when 6 is written in the text field for the variable 
part of the connection name.

When you have selected the text field Variable part of pin name, the buttons 
Count up, Count down, and Next free for automatic counting has effect on this 
text field:

These button functions as described in “Specifying the Component name” on 
page 173.

— Please refer to “Symbols with variable connection names” on page 658 and 
“Connection data with a variable part in the name” on page 766.

EDITING CONNECTION NAMES DIRECTLY FROM THE NAME FIELD IN COMPONENT DATA

You can also change the connection names directly from the Name field in the 
Component data dialog box. If you type in the Name -K1:13,14, the connection 
points are named 13 and 14 respectively. The connection names are changed 

Type in the variable part, and

the connection names are updated

Click the

+ button
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according to the numbering order of the connection points in the definition of the 
symbol. — For further details about this, please refer to “Place connection points” 
on page 764.

If the connection names are changed in the Component data dialog box, they are 
automatically set to be Visible.

The Accessory tab

Attached mechanical accessories for components can be handled on the Acces-
sory tab in the dialog box Component data:

— If you need to know more about the different types of accessories, please read 
"Accessory types" på side 664.

On the Accessories tab you have the following options:

The dialog box Component data: Fixed accessories

Under Fixed accessories you can see whether fixed accessories are defined for 
the component in the database. This is information only, and you can not change it 
from here, because fixed accessories are defined in the database — see “Acces-
sories in the database” on page 664.

The dialog box Component data: Selected electrical accessories

Here you can see which electrical accessories are selected for the component in 
the Component menu. This is information only, and you can not change it from 
here.

— See how to select electrical accessories for the component in “Optional electri-
cal accessories in Symbols for component” on page 261.
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The dialog box Component data: Optional mechanical accessories

To add optional mechanical accessories to the component, you must first click the 
+ button under Optional mechanical accessories. You can then specify which 
component that you wish to add:

You can then click the DB button in the Article number field to look up the compo-
nent in the database, or type in an article number. You can also specify a type.

When you have added an accessory, you get the option of adding another acces-
sory:

Fast access to the Accessories tab

You can jump directly from a diagram page to the Accessory tab like this: Right-
click on the symbol in the diagram and choose Accessory.

In parts lists mechanical accessories appear with specified quantity and data from 
the database (if any), and in components lists accessories appear together with 
the main component.

Accessories in the database

To determine which field in the database to use for specifying accessories, please 
read “Transferring article data to symbols and lines” on page 672, particularly 
“Optional accessories - Mechanical” on page 677.

The tab Symbol data fields

When a symbol is created with extra symbol datafields, you can type in data for 
these datafields on the Symbol data fields tab. — See “Extra symbol Datafields in 
symbols” on page 776.

You can also add extra symbol datafields to the symbol and type in values for these 
symbol data fields. Furthermore, you can edit and remove these extra symbol 

Specify quantity Specify Article no / Type
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datafields. — See “Symbol datafields” on page 120 and “How to add datafields to 
symbols” on page 122.

When you place a symbol containing datafields of the type Project data or Page 
data, which does not exist in the project, you will be asked whether to include 
these datafields in the project.

Copying Component data

If you wish to copy component data from one symbol to another, please refer to 
“Transfer component data for Symbols” on page 62.

Collecting information from the database

Information about the symbol can be collected directly from the database, which 
you enter by clicking Database. Here you find the appropriate component, and 
click OK.

When you have selected the symbols for the component from the database, all text 
fields, except the Name field, are filled out with information from the database.

— Read more about this in “Using the database” on page 629.

Attaching Unit drawings to Symbols

If you connect a unit drawing to the symbol, you do this by clicking on Unit. This is 
elaborated in “Attach a symbol on a diagram to the unit drawing” on page 625.
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SUB NAMES ON SYMBOLS

In Automation sub names on symbols can be handled intelligently.

What is sub names on symbols?

Sub names on symbols are applied where a component contains functions, which 
must be identified separately.

This could for instance be the case for a reversing contactor with two coils, where it 
must be possible to identify which contacts that are controlled by the individual 
coils. The names of the two coils could here be -Q1.Q1 and -Q1.Q2.

Another example could be a push-button with a build-in lamp, where the symbols 
could be named -S1.S and -S1.P respectively.

Specifying sub names on symbols

To specify a sub name for a symbol, do this:

 1) Enter the dialog box Component data for the sym-
bol — e.g. by double-clicking on the symbol.

 2) In the dialog box Component data: Click on Name:

 3) In the dialog box Name: Click in the field Sub name, and type in a sub name 
— or use the buttons Count up, Count down, Next free or Used related to 
specify the sub name.

FUNCTIONALLY UNDERSTOOD AS DIFFERENT COMPONENTS

SYMBOLS FOR THE SAME COMPONENT, WHICH HAS DIFFERENT SUB NAMES, 
ARE FUNCTIONALLY UNDERSTOOD AS DIFFERENT COMPONENTS IN THE PRO-

JECT, WHILE THEY IN PARTS LISTS ARE UNDERSTOOD AS PARTS OF THE 

SAME COMPONENT.

IF A COMPONENT THEREFORE CONTAINS TWO COILS WITH THE NAMES -
Q1.Q1 AND -Q1.Q2, THESE ARE EACH ASSIGNED THEIR OWN REFERENCE 

CROSS IN THE PROJECT, BUT ARE REPRESENTED AS ONE COMPONENT IN 

THE PARTS LIST.

2) Click here
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 4) Click OK, and click OK in the dialog box Component data.

Sub names can be specified in the database

Sub names can also be specified via the database, as described in “Specifying 
symbol sub names from the database” on page 668.

Sub names included in lists

Sub names on components can also be included in all electrical lists. For this pur-
pose, all datafields containing a component name, have included the option With 
sub name in the dialog box DataField. — See “Datafields” on page 116.

SUB NAMES CAN ONLY BE SPECIFIED IN THE DIALOG BOX NAME

SUB NAMES CAN ONLY BE SPECIFIED IN THE DIALOG BOX NAME.

THEREFORE, IF YOU WRITE -Q1.1 IN THE FIELD NAME IN THE DIALOG BOX 

COMPONENT DATA, THIS IS UNDERSTOOD AS THE COMPONENT NAME, AND 

NOT AS A COMPONENT NAME FOLLOWED BY A SUB NAME.

BECAUSE OF THIS, THE SUB NAME IS NOT DISPLAYED IN THE NAME FIELD IN 

THE DIALOG BOX COMPONENT DATA.
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SYMBOLS WITH STATES

Symbols can be placed with differ-
ent states on the project pages, so 
that the symbols change appear-
ance when their state number is 
changed.

This is only possible for symbols, 
which have been designed with 
different states. — See how to cre-
ate symbols with states in “Crea-
ting symbols with states” on 
page 777.

Select a state for the sym-
bol

When you click to place a symbol 
with a special state in the project, 
you must select the state in the 
Component data dialog box — 
see the figure to the right.

When you subsequently need to 
change the symbol state, enter the Component data dialog for the symbol, select 
a new state, and click OK.

— Please also see “Symbols with states for single line diagrams” on page 462 and 
“Placing symbols with selected states in the pickmenu” on page 201.

Symbols with states and the Component menu

If it is defined in the database that a symbol is to be displayed with a specific state 
selected, and this state has been changed to another state for a placed symbol, 
this is interpreted as if the symbol has not been placed in the project. The symbol 
will therefore still appear under Available symbols in the Component menu, and 
it will be displayed with the state defined in the database.

If no state is specified for the symbol in the database, the symbol disappears from 
Available symbols, when it is placed in the project — no matter which state is 
selected for the symbol in the project.

— Read more about Available symbols in “The Component menu” on page 254.

— See how to specify states for symbols in the database in “Specifying symbol 
state for electrical symbols via the database” on page 654.

SHIFT STATE WITH <SHIFT + SPACEBAR>

WHEN YOU HAVE SELECTED A SYMBOL CONTAINING STATES, YOU CAN SHIFT 

BETWEEN THE STATES BY PRESSING <SHIFT> WHILE PRESSING THE 

<SPACEBAR>. THIS IS ALSO THE CASE WHEN YOU HAVE THE SYMBOL IN THE 

CROSS HAIRS.

Select the state to display

for the symbol
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MULTIPLACING SYMBOLS

In Automation it is possible to place multiple symbols of the same kind in one sin-
gle operation — for instance when placing terminals.

Do this:

 1) Select a symbol, e.g. a terminal 
from the pickmenu.

 2) Right-click on the page, and 
select Start Multiplacement. 
(See the figure above).

 3) A "line" now emerges from 
where you right-clicked, ending 
in the cross hairs. Move the cur-
sor so that the line crosses all of 
the lines that you wish to place 
the symbols on. — See also “Skipping line segments when multiplacing sym-
bols” on page 188.

 4) Right-click on the page, and select Execute Multiplacement.

 5) In the dialog box Component data: Specify symbol names — for instance 
type -X4:0, press <Ctrl> while clicking the + button and click OK:

— See also “Placing and Naming symbols” on page 171 for how to name 
connection names for terminals directly from the Component data dialog 
box.

symbols here
Place terminal
Example:

2) Right-click here 4) Right-click here
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 6) The terminals are now placed with assigned connection names:

Multiplacing motor terminals with UVW

You can also multiplace motor terminals 
with UVW.

When specifying the component name 
above in the Component data dialog 
box, do this:

Type in -X1:1U, -X1:1U1 or -X1:1U2 and 
subsequently press <Ctrl> while clicking 
the + or the ? button on the right-hand 
side of the Name field.

The program automatically detects if a 
PE is needed.

If there are only two conductors, they will 
be named U and V, and the naming starts 
over again.
mation

Page 187



P

Symbols
Skipping line segments when multiplacing symbols

To skip one or more line segments when multiplacing symbols, do this:

 1) Select a symbol, e.g. a terminal, from the pickmenu. Right-click, and select-
Start Multiplacement — see the figure above.

 2) Click before the lines you wish to skip.

 3) Press <Ctrl> and click after the lines you wish to skip.

MARKING TERMINALS FOR INCOMING AND OUTGOING CONDUCTORS (EN 
60445:2017)

TERMINALS FOR INCOMING CONDUCTORS 

SHOULD BE MARKED AS U1, V1 AND W1.

THIS SHOWS THAT THE THREE TERMINALS U1, 
V1 AND W1 ARE MEANT FOR CONNECTING TO 

THREE POWER SUPPLY PHASES.

TERMINALS FOR OUTGOING CONDUCTORS MUST 

BE MARKED AS U2, V2 AND W2.

THIS SHOWS THAT THE THREE TERMINALS U2, 
V2 AND W2 ARE MEANT FOR CONNECTING TO 

THREE OUTGOING PHASES OF CIRCUIT SUP-

PLIED FROM THE CONTROL PANEL.

IF THERE ARE SEVERAL INCOMING OR OUT-

GOING CONDUCTORS/WIRES, YOU MUST USE 

SEQUENTIAL NUMBERING OF TERMINALS.

TERMINALS FOR INCOMING CONDUCTORS:

1U1, 1V1, 1W1 ... 3U1, 3V1, 3W1

TERMINALS FOR OUTGOING CONDUCTORS:

1U2, 1V2, 1W2 ... 3U2, 3V2, 3W2

1 2 3 4

The two lines in the

middle are skipped
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 4) Right-click after the lines you wish to place symbols on, and select Execute 
multiplacement.

— See also “Multiplacing symbols” on page 186.
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NAVIGATION BETWEEN SYMBOLS FOR THE SAME COMPONENT

When you have selected a symbol and choose View => Goto symbol — or if you 
right-click on a symbol and choose Goto symbol — you can select which of the 
other symbols for the component to jump to in the project:

In the Goto symbol function, you have the following options:

• Mechanical: Hereby you jump to the mechanical drawing, when such a drawing 
exist. The mechanical symbol for the component is selected, and the cross 
hairs points out the symbol.

• Diagram: The first of the diagram symbols for the component is selected, and 
the cross hairs points out the symbol.

• Next: The next diagram symbol for the component is selected, and the cross 
hairs points out the symbol.

• Previous: The previous diagram symbol for the component is selected, and the 
cross hairs points out the symbol.

• Select: Here a menu containing all symbols for the component is displayed. For 
each symbol you see the names of the first two connection points, as well as 
the symbol and page type, the page number and reference designation (if 
any). When you select a symbol in the menu, the symbol is selected in the 
project, and the cross hairs points out the symbol.

JUMPING BETWEEN SYMBOLS BY CLICKING ON REFERENCES ON THE PAGE

PLEASE ALSO SEE “Automatically updated references” on page 421,  IN 

PARTICULAR “Automatic jump between references on double-click” on 
page 421. HERE YOU SEE HOW TO JUMP BACK AND FORTH BETWEEN THE 

SYMBOLS FOR THE COMPONENT, BY DOUBLE-CLICKING ON REFERENCES 

PLACED NEXT TO THE SYMBOLS ON THE PROJECT PAGES.
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UPDATING SYMBOLS FROM THE DATABASE

To make sure that e.g. the type texts and/or the connection names for the symbols 
for a component — or for all symbols on a page or in the project — matches the 
given information for the specified EAN numbers in the database, do the following:

 1) Select the symbol(s) you wish to update from the database. If no symbols 
are selected, all symbols in the project — or on the selected page — can be 
updated.

 2) Choose Functions => Component Database => Update from Compo-
nent Database.

 3) You now enter the dialog box Update from Component Database:

UPDATING SYMBOLS WHEN CHANGING ARTICLE NUMBERS

WHEN CHANGING THE ARTICLE NUMBER FOR A SYMBOL, ALL SYMBOLS FOR 

THE COMPONENT CAN ALSO BE UPDATED FROM THE DATABASE.

— SEE “Update from Database when changing symbol Article no” on 
page 269 AND “Update from database when changing article number” 
on page 175.
mation

Page 191



P

Symbols
Here you have the following options:

Select the desired settings, and click OK.

 4) The type texts for the symbols and/or connection names are now updated, 
and you get a status for the update. Here you can click on each individual 
warning in the window, and the program points out the symbol in the project. 
The window remains on the screen until you click the Close button in the 
upper-right corner.

OPTION DESCRIPTION

UPDATE ONLY 

COMPONENTS ON 

THE CURRENT 

PAGE

THIS OPTION IS ONLY DISPLAYED WHEN YOU HAVE NOT 

SELECTED ANY SYMBOLS ON THE PROJECT PAGE.
WHEN YOU SELECT THIS OPTION, ONLY THE SYMBOLS ON THE 

PAGE ARE UPDATED (AS WELL AS ALL RELATED COMPONENTS IN 

THE PROJECT).
WHEN YOU DO NOT SELECT THIS OPTION, ALL COMPONENTS IN 

THE PROJECT ARE UPDATED.

TYPE TEXTS YOU CAN HERE CHOOSE EITHER DO NOT UPDATE, UPDATE 

MISSING ONLY OR UPDATE ALL.

FUNCTION TEXTS IF YOU IN THE DATABASE SETTINGS HAVE SPECIFIED THAT THE 

PROGRAM SHALL TRANSFER CONTENTS TO THE FUNCTION FIELD 

FOR SYMBOLS, YOU WILL ALSO GET THE OPTIONS DO NOT 

UPDATE, UPDATE MISSING ONLY AND UPDATE ALL FOR FUNC-

TION TEXTS.
(THIS IS SPECIFIED IN SETTINGS => DATABASE => DATABASE 

SETUP => COMPONENT DATA IN THE FUNCTION FIELD — SEE 

“Transferring article data to symbols and lines” on 
page 672).

UPDATE CONNEC-

TION POINTS

UPDATES ALL CONNECTION POINTS, SO THAT THEY ARE 

ASSIGNED THE CONNECTION POINT NAMES DESCRIBED IN THE 

DATABASE.

UPDATE CABLE 

WIRES

UPDATES ALL CABLE WIRES WITH THE NAMES SPECIFIED IN THE 

COMPONENT DATABASE.

CHECK FOR COR-

RECT SYMBOLS

ISSUES A WARNING FOR EACH PLACE ANOTHER SYMBOL HAS 

BEEN USED, THAN THE ONE SPECIFIED IN THE DATABASE FOR 

THE ARTICLE NUMBER, AND FOR EACH PLACE THERE E.G. HAS 

BEEN USED A BREAK CONTACT TOO MUCH, COMPARED TO 

WHICH FUNCTION THE COMPONENT CONTAINS ACCORDING TO 

THE DATABASE.
FOR SECURITY REASONS, YOU SUBSEQUENTLY HAVE TO MAKE 

THE NECESSARY CHANGES MANUALLY.

CHECK FOR 

UNKNOWN ARTI-

CLE NO.

ISSUES A WARNING FOR EACH PLACE ARTICLE NUMBERS HAVE 

BEEN USED, WHICH DOES NOT EXIST IN THE DATABASE.
FOR SECURITY REASONS, YOU SUBSEQUENTLY HAVE TO MAKE 

THE NECESSARY CHANGES MANUALLY.

CHECK FOR MISS-

ING ARTICLE NO.
ISSUES A WARNING FOR EACH PLACE NO ARTICLE NUMBERS 

HAVE BEEN SPECIFIED.
FOR SECURITY REASONS, YOU SUBSEQUENTLY HAVE TO MAKE 

THE NECESSARY CHANGES MANUALLY.
Automation

age 192



Symbols

Auto
MOVING AND DELETING PLACED SYMBOLS

In the following it is described how to move and delete symbols in Automation. 
You can also cut and paste symbols, as described in “Cutting and Pasting areas” 
on page 278.

Deleting a placed symbol

You can delete a placed symbol in two different ways:

a) Deleting a symbol and Redrawing the lines

 1) Click the Symbols button, and press <Esc> to deselect the Pencil.

 2) Click the Delete button, and the dialog box Delete is displayed:

 3) You now have the following options:
Click on Symbol: Only the selected symbol is deleted.
Click on Component: All symbols for the selected component is deleted (in 
the figure above, you can see that the physical terminal, from which the sym-
bol is selected, consists of two symbols).
Click on Name: All symbols with this name are deleted (the terminal row in 
the figure above consists of 2 physical components, represented by 12 sym-
bols in the project).
Click Cancel: No action is taken.
— If you select Close lines, the lines are closed for all deleted symbols — 
whenever this is possible. If you do not select Close lines, the lines are 
parked.

The symbol is now deleted, and the line which the symbol was placed on, is now 
closed — if this is possible.

b) Deleting a symbol and Parking the lines

 1) Click on the Symbols button —to start working with symbols.

Here you see how many components

are found with this name in the project

The number of symbols that

will be deleted, if you choose

Name

The number of symbols that

will be deleted, if you choose

Component
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 2) Press down <Ctrl> and click the Delete button: You are now asked whether 
to delete all symbols with the current symbol name: Answer Yes or No.

The symbol is now deleted, and the lines which the symbol was connected to, are 
parked.

Deleting more than one symbol

You can also delete more than one symbol at the same time, by selecting the sym-
bols at the same time — as described in “Changing symbol names in an Area” on 
page 205 — and then delete them as described above.

Moving a placed symbol

You can move a placed symbol in two different ways:

a) Moving a symbol with Connected lines

 1) Click on the Symbols button — to start working with symbols.

 2) Click on the symbol, press down the mouse button, and drag the symbol to a 
new location.

The symbol is now moved, and is still connected to the same lines as before.

b) Moving a symbol and Parking the connected lines

 1) Click on the Symbols button — to start working with symbols.

 2) Press down the <Ctrl> key, and drag the symbol to a new location.

a) Click on the

Delete button

b) Press down <Ctrl> and

click the Delete button
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The symbol is now moved, and the lines which it was previously connected to, now 
becomes connected.

Moving more symbols at the same time

You can also move more symbols at the same time by selecting the relevant sym-
bols — as described in “Changing symbol names in an Area” on page 205 — and 
then move them as described above.

Moving symbols with overlapping connection points

When two symbols are placed so that their connection points are connected 
directly, and one of the symbols are moved, a connecting line is automatically 
drawn between the two previously connected connection points.

a) Drag the symbol to

a new location

b) Press down <Ctrl>

and drag the symbol

to a new location
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THE SYMBOL TOOLBAR

When you have selected a symbol, you get information about the symbol in the 
symbol toolbar:

T: The file name of the symbol you last had in the cross hairs

N: The name of the currently selected symbol

S: The scale of the symbol

Automatic naming of symbols

When the Auto Name button is activated, symbols are automatically assigned the 
next available symbol name when placed in the project.

The automatic naming function can also be started/stopped by choosing Func-
tions => Auto Name.

Scaling symbols

If you want to scale one or more symbols up or down, you can 
use Symbol scale. You can scale a symbol by picking a scale 
factor from the drop down list and press <Enter>, or type in a 
value and press <Enter>. This can be done either when you have got the symbol in 
the cross hairs, or by selecting the symbol(s), typing in a value and then click the 
Transfer properties button. Symbol scale is rarely used in electrical diagrams (not 
standard).

Read more about scaling symbols in “Symbol settings: Advanced” on page 773.

Mirroring symbols

Select a symbol, click the Mirror symbol vertically button, and the symbol will 
mirrored vertically. Or click the Mirror symbol horizontally button, and the symbol 
will be mirrored horizontally.

Rotating symbols

By clicking the Rotate symbol button, you can rotate the selected symbol — see 
“Rotating a selected object” on page 59.

Choose symbol type in an area on the screen

When you are working with symbols, and mark up an area on the screen using the 
mouse, you can specify which of the symbols in the area to select. Do the follow-
ing:

 1) Choose which type of symbols to select: AUTO (= the most common sym-
bols in the area), Symbols (all symbols, which are not wire numbers or sig-
nals), Signals, Wire numbers or All (all symbols of any type in the area).

 2) Select the area using the mouse, and release the mouse button.
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The selected symbols in the area are now selected.

Selecting symbols using Select all or by selecting in areas

When you choose Edit => Select All => Everything on page (short-cut key 
<Ctrl+a>), or when you select symbols in an area, all symbols in the area becomes 
selected, no matter the type.

1) Choose symbol type

2a) Click here

2b)Press down the mouse button and

drag the mouse cursor over the screen

3) The selected type of sym-

bols are selected in the area
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ADAPTING THE PICKMENU

In the pickmenu you can place the symbols you use the most for easy access. 
Below the following aspects are elaborated,

— See how to fetch symbols — and other drawing objects — from the pickmenu in 
“Fetching symbols from the Pickmenu” on page 152.

The pickmenu can also contain line types, text types and arcs. — Read more about 
this in “Lines in the Pickmenu” on page 79, “Texts in the Pickmenu” on page 137 
and “Circles / Arcs in the Pickmenu” on page 106.

Placing symbols in the pickmenu

To place a symbol directly in an empty cell in the pickmenu, you have to have a 
symbol in the cross hairs, and then click inside an empty cell in the pickmenu. You 
can fetch the symbol from either the Symbol menu or from a drawing.

Or, you can right-click inside an empty cell in the pickmenu and choose Place 
symbol, which brings you into the Symbol menu, where you click your way to the 
symbol you want to place in the pickmenu, and click OK.

Include component data when inserting a symbol in the pick-
menu

When you hold a symbol in the cross hairs, and press down <Ctrl> while placing 
the symbol in the pickmenu, the component data is also transferred to the symbol 
in the pickmenu.

Inserting a Symbol / Drawing object in all
Pickmenus

To insert one or more drawing object(s) to be dis-
played in all pickmenus, do the following:

THIS CHAPTER DESCRIBES

— PLACING SYMBOLS IN THE PICKMENU ........................................................p. 198

— PLACING SYMBOLS IN THE PICKMENU WITH COMPONENT DATA ...................p. 198

— INSERTING A SYMBOL/DRAWING OBJECT IN ALL PICKMENUS ........................p. 198

— CREATING A NEW MENU IN THE PICKMENU.................................................p. 200

— SPECIFYING COMPONENT DATA IN THE PICKMENU ......................................p. 200

— PLACING SYMBOLS IN THE PICKMENU VIA THE DATABASE............................p. 201

— PLACING SYMBOLS WITH SELECTED STATES IN THE PICKMENU ...................p. 201

— RIGHT-CLICKING IN THE PICKMENU ............................................................p. 203

Displayed in

all pickmenus

Displayed in selected

pickmenu only
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 1) Right-click on the pickmenu, select Properties, and you enter the dialog box 
Pickmenu properties:

 2) Set the number of fixed cells, click OK, and the new cell(s) are displayed:

 3) Place a new symbol / drawing object in the cell, as described in “Placing 
symbols in the pickmenu” on page 198 or “Include component data when 
inserting a symbol in the pickmenu” on page 198.

 4) The symbol is now represented in all pickmenues.

Removing fixed cells from the pickmenues

To remove a number of symbols from being displayed in all pickmenues, right-click 
on the pickmenu, select Properties, and reduce the number of Fixed Cells to 
desired number of cells. Please note that the right-most fixed cells are removed 
first.

Automatic popup of submenus in the pickmenu

You can specify whether to display a popup menu for symbols with states (see 
“Symbols with states” on page 185) or for symbols with multiple sets of article data 
attached (see “Symbols with multiple sets of data in the Pickmenu” on page 154), 
when you let the mouse rest over the symbol in the pickmenu.

To do this, right-click in the pickmenu, and 
choose Properties. You then enter the dia-
log box Pickmenu properties, where you 
select Automatic popup of submenus.

Under Popup delay you can specify 
whether the popup menu appears instantly, 
when the mouse cursor rests over a symbol with states / sets of article data, or 

2) Correct the num-

ber of fixed cells

Place a new symbol

/ drawing object
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whether to insert a delay before the popup menu appears. To insert a delay has the 
advantage that submenus are not displayed when the mouse cursor just passes 
the pickmenu, in order to make selections in other of the program menus or tool-
bars.

When Automatic popup of submenus is not acti-
vated, small buttons are displayed in the pickmenu in 
the relevant cells. When you click this button, the sub-
menu is displayed.

Creating new menus in the Pickmenu

To create a new menu in the pickmenu, do the following:

 1) Right-click on a cell in the pickmenu (and not one of the tabs), and select 
Create new Menu.

 2) The menu is now created: Right-click on a cell in the pickmenu (and not one 
of the tabs), and select Properties.

 3) In the dialog box Pickmenu properties: Name the menu, and click OK.

Deleting a menu

To delete a menu, do the following:

 1) Select the menu by clicking on the tab for the menu at the bottom of the pick-
menu.

 2) Right-click on a cell in the pickmenu (and not on one of the tabs), select 
Delete Menu, and answer OK to delete the menu.

Adding component data to symbols in the pickmenu

You can attach multiple sets of component data to the symbols in the pickmenu.

To do this, right-click on a symbol in the pickmenu and choose Component Article 
Data. You then enter the Component data dialog box:

Here you have the following options:

Click for submenu
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Create a new line with component data

Click the Plus button. In the new empty line you can either type in component data 
by clicking in the relevant fields, or click the DB button to enter the Database menu 
to select a component. — You can read more about the Database menu in “About 
the Database menu” on page 633.

When you have filled out a component line in the dialog box, and then click the DB 
button, you are asked whether to overwrite the selected line, when returning from 
the database. You also get the option of choosing Add, to create a new line with 
component data.

Deleting a line with component data

Click on the line you wish to delete, and then click the Minus button.

Multiple symbols of the same kind in the pickmenu

Placing multiple symbols of the same kind in the pickmenu, is also an option. When 
you place a symbol which exists in the pickmenu already, you are informed about 
this.

When you let the mouse cursor rest over one of the symbols in the pickmenu, the 
symbol title is displayed both below the symbol (as a hint), and at the bottom of the 
screen.

Placing symbols in the pickmenu using the database

It is also an option to place a symbol in the pickmenu using the database. When 
you right-click on an empty cell in the pickmenu, and choose Place symbol, you 
enter the Symbol menu, where you click on the Database button in the dialog box.

You now enter the database, where you choose the desired component, and click 
OK. The symbol and its attached component data is hereby being transferred to 
the pickmenu.

If the component contains more than one symbol, the first of its symbols is placed 
in the pickmenu.

Placing symbols with selected states in the pickmenu

You can also place symbols, with a specified state selected, in the symbol toolbar. 
To transfer the selected state to the symbol toolbar, press down <Ctrl> when click-
ing the symbol in the symbol toolbar.

— Read more about symbols with states in “Symbols with states” on page 185 and 
“Creating symbols with states” on page 777.
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Placing sub drawings in the Pickmenu

In order to place sub drawings in the Pickmenu, this is required:

 1) Use a database for Automation, which contains a field for sub drawings.

 2) A unique article number must be created for each sub drawing, that you wish 
to place in the Pickmenu.

 3) The article number for each individual sub drawing in the database must 
contain a link to the sub drawing, that you wish to place in the Pickmenu. — 
See how to do this in “URL links” on page 684, particularly “Example for sub-
drawings” on page 685.

In order to place a sub drawing in the Pickmenu, do this:

 1) Place a symbol in the Pickmenu.

 2) Right-click on the symbol in the Pickmenu, and choose Component Article 
Data.

 3) In the dialog box Component data: Click the Database button.

 4) In the Database menu: Select the article number for the sub drawing and 
click OK.

 5) In the dialog box Component data: Click OK.

The sub drawing can now be placed in projects via the Pickmenu, as described in 
“Sub drawings in the Pickmenu” on page 157.

THE RECOMMENDED PROCEDURE FOR SUB DRAWINGS

YOU CAN READ MORE ABOUT SUB DRAWINGS IN THE CHAPTER “Sub dra-
wings” on page 289. THERE YOU CAN ALSO READ ABOUT THE RECOM-

MENDED PROCEDURE FOR PLACING SUB DRAWINGS USING THE 

SUBDRAWINGS TAB IN THE EXPLORER WINDOW.
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Right-clicking in the pickmenu

To the left in the pickmenu title bar the name of the 
menu is displayed. To the right there are two 
arrows, with which you can scroll back and forth 
between the various pickmenus.

If the active pickmenu contains more symbols than 
can be shown at a time, there will also be a scroll 
bar at the bottom of the pickmenu.

Insert new cell

Right-click on a filled out cell in the pickmenu, 
choose Insert Cell, and an empty cell is inserted 
where you right-clicked.

Delete cell

Right-click on a cell and choose Delete Cell. The 
cell is now deleted. This goes for empty cells as 
well cells containing symbols.

Create new menu

Right-click on the pickmenu, and choose Create new Menu.

Give a menu a title

Right-click and choose Properties, and type in a title for the active pickmenu. Here 
you can also determine the size of the pickmenu on the screen. Click OK. The title 
can be seen after the number of the pickmenu.

Go to a specific pickmenu

Right-click and choose Go to Menu. You now get a survey of the menus, contain-
ing their numbers and titles. Click on the menu you wish to use.

Delete a menu

Right-click and choose Delete Menu. The displayed pickmenu — and all of its 
symbols — will be deleted.
mation

Page 203



P

Symbols
Information about the symbol

Right-click on the symbol in the pickmenu and choose Symbol information.
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CHANGING SYMBOL NAMES IN AN AREA

Changing more than one symbol name

When you want to change more than one symbol name at the same time, you can 
select the symbols by dragging a window around them, right-click inside the 
selected area, and choose Component data.

You then enter the Component data dialog box.

In the Component data dialog box you apply the automatic counting facility by typ-
ing in the name of the first symbol, pressing <Ctrl> while clicking on ?, and then 

THIS CHAPTER DESCRIBES

— CHANGING MORE THAN ONE SYMBOL NAME ...............................................p. 205

— THE NAMING ORDER OF SYMBOLS .............................................................p. 206

— OTHER OPTIONS ......................................................................................p. 206
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click OK. — Please refer to “Automatic counting in the Component data dialog box” 
on page 173 for further details.

The symbol names are now changed. Click outside the selected area to deselect 
the symbols.

The naming order of the symbols

It is important how you select the symbols. If you click in the left-hand side of the 
screen, and then drag a window to the right, the numbering of the symbols will be 
carried out from left to right.

If you select the window from right to left, the symbol names are named from the 
right to the left. Thus, the counting direction follows the movement you make when 
you select the window.

If you select the symbols by <Ctrl>-clicking, the symbols are named in the order 
you selected them.

Other options

See how to do the same for connection points in “Choosing connection points in 
Areas” on page 209.

You can also change the symbol texts directly on the diagram page, as described 
in “Editing the symbol texts directly on a Diagram page” on page 114.

Other advanced ways to change texts directly on diagrams are described in 
“Locking text types” on page 130 and “Counting on texts” on page 131.

RENAME SYMBOLS - OR INSERT SYMBOL NAMES

IN “Rename selected symbols” on page 322 YOU CAN SEE HOW TO 

RENAME SELECTED SYMBOLS — OR HOW TO RENAME ALL PROJECT SYM-

BOLS.

IF YOU NEED TO INSERT NEW/AVAILABLE SYMBOL NAMES OR CONNECTION 

NAMES, YOU CAN SEE HOW TO DO THIS IN “Insert new Symbol names or 
Connection names” on page 328.
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SYMBOL CONNECTION POINTS

Connection points for symbols can be selected

The connection points for the symbols can 
be selected as well as the symbols them-
selves.

On the figure to the right, a connection point 
of a terminal symbol is selected.

Specifying Connection data

If you right-click on a symbols connection point and then choose Connection data, 
you can change the connection data for the connection point — e.g. the connection 
name.

— If you accidentally select the whole symbol, and not just the connection point, 
just right-click on the connection point again.

In this dialog box you can type in connection data, and specify which connection 
point texts is visible on the diagram. The connection point texts are described in 
“Connection point texts” on page 115.

THIS CHAPTER DESCRIBES

— CONNECTION POINTS FOR SYMBOLS CAN BE SELECTED .............................p. 207

— SPECIFYING CONNECTION DATA ................................................................p. 207

— EDITING CONNECTION TEXTS FROM COMPONENT DATA DIALOG BOX ...........p. 208

— EDIT NEXT/PREVIOUS FOR CONNECTION POINTS.......................................p. 208

Symbol name Connection name
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The Visible setting only applies for the selected connection 
point. The texts are only visible if they are allowed to be so by 
the over-all visibility settings for connection texts. Please refer 
to “Texts displayed in the project (general setting)” on 
page 138 for further details.

The function of the four buttons in the dialog box, is described 
in “Specifying the Component name” on page 173.

With reference

— See “With reference” on page 766.

No dot generation

— See “No dot generation” on page 766.

Connection data as Info Tips

When the cross hairs is placed above a connection point, the connection data for 
the connection point is displayed as an Info Tip.

Connection name displayed in the toolbar Symbols

When a connection point is selected, the connection name 
is displayed in the symbol name field in the toolbar Symbols. 
This also applies for invisible connection names.

Editing connection texts from the Component data box

When you click on the Conns. tab in the Component data dialog box, you can edit 
the connection texts by clicking in the relevant fields, and then type in the texts. — 
Please refer to “Changing Connection data” on page 178.

Edit Next/Previous for Connection points

When you have selected a connection point, you can jump back and forth between 
the connection points for the same symbol, by pressing <F5> and <F6> — or by 
choosing Edit => Next or Edit => Previous. You jump between the connection 
points according to their connection numbers.

The function also applies for symbol texts.
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CHOOSING CONNECTION POINTS IN AREAS

When you have activated the Symbols function, start dragging a window around 
an area and press <Ctrl> when releasing the mouse button, you select the connec-
tion points in the area. The symbols in the area are not selected.

If you press <Ctrl> and click on connection points outside the area, these will also 
be included. If you press <Ctrl> and click on a selected connection point, it 
becomes deselected.

When you have selected an area and deselected the unwanted connection points 
— as displayed above — you right-click inside the area and choose Connection 
data.

Then apply the automatic counting facility by 
typing in the first Name (1), pressing <Ctrl> 
while clicking on +, and then click OK. The 
selected connection points are then renum-
bered automatically.

— Please refer to “Automatic counting in the 
Component data dialog box” on page 173 for 
further details.

Then rename the remaining connection 
points one by one.

Numbering order for <Ctrl> click

If you select the connection points one by 
one by pressing <Ctrl> while clicking on the 
connection points, they will be renumbered 
according to the order in which you selected 
them.

Select the connection points by

pressing <Ctrl> when you release

the mouse button

Press <Ctrl> and click on the

unwanted connection points

in the area
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PIN SWOP

Letting the connection points of symbols swop places is an option, under the name 
pin swop. This can be done within the same symbol, as well as between symbols.

Pin swop for symbols

To perform a pin swop on a symbol with an even number of connection points, you 
first click the Symbols button, and right-click on the symbol. Then choose Pin 

swop, and the two connection points of the symbol swop places.

Pin swop for symbols in Areas

To perform a pin swop on all symbols with an even number of connection points 
within an area, you also click on the Symbols button first, select an area, and right-

THIS CHAPTER DESCRIBES

— PIN SWOP FOR SYMBOLS ..........................................................................p. 210

— PIN SWOP FOR SYMBOLS IN AREAS ...........................................................p. 210

— FREE PIN SWOP .......................................................................................p. 211

— MOVING CONNECTION POINTS...................................................................p. 211

PIN SWOP - FOR MANUALLY CREATED SYMBOLS

WHEN YOU HAVE CREATED YOUR OWN SYMBOLS, PLEASE REMEMBER TO 

FOLLOW THESE SIMPLE GUIDELINES:

IN THE DEFINITION OF THE SYMBOL IN THE SYMBOL LIBRARY YOU MUST 

MAKE SURE THAT THE CONNECTION POINTS AT THE ONE SIDE OF THE SYM-

BOL ONLY CONTAIN EVEN NUMBERS, WHILE THE CONNECTION POINTS AT 

THE OTHER SIDE ONLY CONTAIN ODD NUMBERS.

PIN SWOP WORKS FOR ALL OF THE SYMBOLS THAT ARE INCLUDED IN THE 

PROGRAM.

Pin swop
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click inside the area. Then choose Pin swop, and the connection points of the 
symbols inside the area swop places.

In this way you can for instance easily change a terminal row, from having the out-
put side turning upwards to turning downwards. — Please refer to “Creating termi-
nal symbols” on page 782 for further details about the input- and output side of 
terminals.

The connection points in the area for the symbols not having two connection points 
are left unchanged.

Connection points for all symbols inside the area with an odd number of connec-
tion points, remain unchanged.

The function can also be activated by choosing Edit => Pin swop.

Free pin swop

Swopping connection points between sym-
bols, and within symbols having more than 
two connection points, is also an option.

To do this, you also have to activate the 
Symbols button. Then right-click on one of 
the two connection points, you want to swop 
places.

Now choose Pin swop, and you get a rub-
ber band in the cross hairs. Then click on 
the connection point you want to swop with, 
and the connection points swop places.

Please note, that this swopping can be per-
formed within the same symbol, or from one 
symbol to another.

Moving connection points

To move a connection point, do this:

 1) Activate the Symbols button, right-click on the connection point, and choose 
Move.
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 2) You now get the connection point in the cross hairs: Click where you wish to 
place the connection point.

When you move connection points on symbols, connected lines are moved also.

DO NOT MOVE CONNECTION POINTS ON STANDARD SYMBOLS

THE POSSIBILITY TO MOVE CONNECTION POINTS IS DESIGNED FOR SPECIAL 

PURPOSES, SUCH AS BLOCK SYMBOLS.

CONNECTION POINTS CAN NOT BE MOVED OUTSIDE THE FRAME OF THE 

SYMBOL (DISPLAYED WHEN SELECTING SYMBOLS).
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REPLACING SYMBOLS

Replacing symbols automatically

In Automation you can have all occurrences of a specific symbol replaced auto-
matically. (Also see “Replacing all symbols in a project” on page 216).

If for instance you decide to use an open contact instead of a close contact, you 
can replace the symbols in the project.

To do so select one of the open contacts, and choose Functions => Replace 
symbol (short-cut key <F4>). You then enter the following dialog box:

When you enter the dialog box, it is presumed that you wish to keep the contents/
value of the symbol texts from the old symbol, while the positions of the texts fol-
lows the text-positions for the new symbol.

The symbol text Value when replacing

When you set a check mark for a Value for some of the texts for the present sym-
bol, these texts are not replaced when you change symbol.

THIS CHAPTER DESCRIBES

— REPLACING SYMBOLS AUTOMATICALLY ......................................................p. 213

— CONNECTION POINTS WHEN REPLACING SYMBOLS .....................................p. 215

— TEXT PROPERTIES WHEN REPLACING SYMBOLS .........................................p. 215

— REPLACING OLDER VERSIONS OF SYMBOLS ...............................................p. 215

— EDIT A SYMBOL - AND REPLACE IT ON THE PROJECT PAGES .......................p. 216

— REPLACE ALL SYMBOLS IN A PROJECT.......................................................p. 216

Click here to re-

place all symbols

Choose a symbol

in the Symbolmenu

Click here to select

the symbol

Click here to keep

the position of the

function text

in the project or

on the page
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The I/O status and Symbol type for the symbol

By selecting/deselecting I/O status you specify whether to keep the I/O status for 
the old symbol, or to use the I/O status for the new symbol.

By selecting/deselecting Symboltype, you specify whether to keep the symbol 
type for the old symbol, or to use the symbol type for the new symbol.

The symbol text Position when replacing

You can for instance enable Position for the function text of the present symbol. 
This ensures you, that the location and the orientation of the function text remains 
unchanged, even though you change symbol.

The symbol text Visibility when replacing symbols

Likewise you can specify whether the selected Visibility shall remain unchanged 
for the new symbol, or whether the visibility shall be specified by the symbol defini-
tion for the new symbol. — By keeping the visibility for the original symbol when 
replacing terminal symbols, you can therefore avoid having to change the visibility 
for the names of the terminal symbols after the replacement.

Replace all symbols in the project or on the page

Select Replace all in project in order to replace all symbols, of the selected type, 
in the project. If you wish to replace all symbols of the selected type on the active 
page in the project, select Replace all on page.

If you do not select any of these options, only the selected symbol will be replaced.

Selecting a new symbol

Click on Select at the bottom of the dialog box, to choose which symbol you wish 
to use instead.

You then enter the Symbol menu, where for instance you choose the symbol 07-
07B02.

Click OK. — See “Fetching symbols using the Symbol menu” on page 159.

You now return to the dialog box Replace Symbol, where you click OK.

1) Find the 60617

3) Click on the symbol

2) Type in fx. 07-07B02

4) Click OK
folder
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The symbol(s) have now been replaced in the project.

— Please note, that it is possible to undo the replace symbol function.

Connection points when replacing symbols

If the connection points of the old and the new symbol are not placed on identical 
positions, you get a warning:

Click OK. However, you can still choose to replace the symbol(s) by clicking OK in 
the Replace Symbol dialog box.

If the new symbol has less connection points than the old one, you get an error 
message. If the new symbol has more connection points, this will be accepted 
when it has connection points on the same locations as the old one.

Transferring connection point texts when Replacing symbols

For symbols with just one connection point, the Replace symbol function also 
transfers connection point texts from the old symbol to the new symbol, when 
these connection points does not have the same position.

When the symbols have more than one connection point, and some of these con-
nection points does not have the same positions, the connection point texts are 
transferred when the connection points are created with the same name in the 
symbol libraries.

Text properties when replacing symbols

The text properties for the symbol texts follows the definition of the new symbol.

Replacing older versions of symbols

Using the Replace symbols function you can replace all the old versions of the 
project symbols. You can see that an older version exists of a symbol in the project, 
if it has a question mark (?) in its symbol file name.

If multiple versions of the selected symbol exists in the project, the field All ver-
sions(?) is displayed in the left-hand side of the dialog box. If you select this 
option, all versions of the symbol on the page or in the project are replaced.

YOU ONLY GET THIS WARNING WHEN THE CONNECTION POINTS ARE CON-

NECTED ELECTRICALLY. WHEN YOU CLICK OK THE NOT MATCHING CONNEC-

TION POINTS ARE PARKED.
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Edit a symbol - and replace it on project pages

To edit a symbol used in the project, and subsequently replace all occurrences of 
the symbol in the project, do this:

 1) Right-click on the symbol on a project page, and choose Edit symbol.

 2) In the Edit symbol mode: You can now edit the symbol — as described in 
“Creating Symbols” on page 761.

 3) When the symbol has been edited and saved: Select Files => Replace sym-
bol.

 4) In the Replace symbol dialog box: You can now replace the old version of 
the symbol with the new version — as described in “Replacing symbols” on 
page 213.

Replacing all symbols in a project

When a symbol is placed in a project, the symbol is saved under the symbol file 
name for the symbol (e.g. Contactor1.sym). Where the symbol originally came 
from then makes no difference for the program.

However, several symbols with the same symbol file name can occur in a project.

You can therefore use the function Functions => Special functions => Replace 
all symbols. It reloads all symbols in the active project based on the order of sym-
bol libraries specified under Alias for directories. — See “Alias for directories” on 
page 912.

Replacing all symbols with symbols from another symbol directory

This special function also enables you to replace all symbols in a project with simi-
lar symbols — symbols with the same symbol file name — that are placed in 
another symbol directory.

This requires that you change the order of the symbol libraries under Alias for 
directories and then choose Functions => Special functions => Replace all 
symbols.
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AUTOMATIC GENERATION OF SYMBOLS

In Automation it is possible to create rectangular and circular symbols automati-
cally, by entering their dimensions. This can both be done "on the fly" while working 
on a project, and by specifying the symbol dimensions via the database.

When you want Automation to generate symbols for you automatically, while 
working on a project, you can do this in two ways:

a) Using the Symbol generator: Read “Automatic generation of symbols — 
using the Symbol generator” on page 217. (If you enter the Symbol genera-
tor, you can enter the Edit symbol mode from there, and continue working on 
the symbol as described in “Creating Symbols” on page 761).

b) By manually typing in the syntax for the appearance of the symbol: Read 
“Automatic generation of electrical and mechanical symbols - By syntax” on 
page 219.

Automatic generation of symbols — using the Symbol generator

You can enter the Symbol generator in four different ways:

a) Select Symbols and click the Symbol generator button.

b) Select Functions => Symbol generator.

c) Select Symbols and click the Symbol menu button. In the Symbol menu: 
Click the Symbol generator button.

d) When editing symbols: Click the Symbol generator button.

You now enter the Symbol generator.

THIS CHAPTER DESCRIBES

— AUTOMATIC GENERATION OF SYMBOLS — USING THE SYMBOL GENERATORp. 217

— AUTOMATIC GENERATION OF SYMBOLS — BY SYNTAX...............................p. 219

— SYNTAX FOR DIRECT GENERATION OF SYMBOLS ........................................p. 220

— AUTOMATIC GENERATION OF ELECTRICAL SYMBOLS FROM THE DATABASE..p. 221

— AUTOMATIC GENERATION OF MECHANICAL SYMBOLS FROM THE DATABASE.p. 221
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Options in the Symbol generator
In the Symbol generator you specify the design of the symbol. In the window in 
the top-right corner of the dialog box, you can see the symbol, based on the pres-
ent settings. The syntax for the generated symbol is displayed in the title bar for the 
dialog box:

SELECT RECTANGULAR OR CIRCULAR

At the top of the dialog box, you select whether to create a Rectangular or a Cir-
cular symbol, and specify Width/Height or Radius.

LINE COLOR AND FILL COLOR

Under Line color, you select which color to use for the lines in the symbol. If you 
select Filled, you can also select a fill color.

FONTS AND TEXT SIZES IN THE SYMBOL GENERATOR

THE TEXTS IN THE GENERATED SYMBOLS ARE ASSIGNED THE SAME TEXT 

SIZES AND FONTS, WHICH ARE USED IN THE ACTIVE PROJECT WHEN THE 

SYMBOL GENERATOR IS STARTED.

Here the syntax for the gene-

rated symbol is displayed

Here the symbol is displayed

based on the specified settings

Click here to continue working with the symbol design
in the Edit symbol mode
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CONNECTIONS: NUMBER, NAMING AND POSITION

You can place con-
nections to the sym-
bol on the top, at the 
bottom, and at the 
right and the left side 
of the symbol.

All of these places, 
you can either spec-
ify a number of con-
nections (which 
names the connec-
tions 1,2,3,...), or specify the names by typing in a name list. — Please remember 
to see the selected connections in the upper-right corner of the dialog box.

SPECIFYING A DESIGN CHARACTER

In the right side of the dialog box, you can specify 
a designation character for the symbol. Please 
note that it is not necessary to place a dash (-) 
before the symbol name, because the program 
can handle this for you automatically for all sym-
bols in the project. — See “Preceding “-” in sym-
bol names” on page 403.

ELECTRICAL OR MECHANICAL SYMBOL

By default the symbol is created as an electrical 
symbol, but if you select Mechanical symbol, it is 
created as a mechanical symbol.

Beyond the different properties connected to 
these two different types of symbols, the texts are 
placed and oriented differently for the two symbol 
types.

POSITION OF CONNECTIONS

Under Position of connections you can choose 
between:

- Inside symbol: The connections are placed on the symbol, and the connection 
texts are placed inside the symbol.

- Outside symbol: The connections are placed on the symbol, and the connec-
tion texts are placed outside the symbol.

- Outside with lines: The connections are placed outside the symbol, with con-
necting lines to the connections. You can specify the length of the connecting 
lines in the field Line length, and can specify the spacing between the pins in 
the field Pin spacing (mm).

Automatic generation of electrical and mechanical symbols - By
syntax

When you need to create a simple symbol quickly, do the following:
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 1) Click the Symbols button, and press the <k> button. The dialog box Place 
Symbol is displayed:

 2) Type in the dimensions of the symbol, and the 
number of connection points — see “Syntax for 
automatic generation of symbols” on page 220.

 3) Place the symbol in the project, and you enter 
the dialog box Component data.

 4) Specify the component data — for instance just 
the symbol name — and click OK.

You have now created a symbol, which you have 
placed directly in the project.

Symbol type for automatically created symbols

Symbols, which are created automatically, are assigned the symbol type Normal.

SYNTAX FOR AUTOMATIC GENERATION OF SYMBOLS

Two types of symbols can be created directly: Circle- and Box symbols.

Circle symbols

When you type #r40mm, the program creates a circle with radius 40 mm as a sym-
bol.

Box symbols

To create a box symbol with the dimensions 20x30 mm, type #x20mmy30mm.

Specifying connection points

To assign two connection points to the left and to the right, add l2r2 after the phys-
ical dimensions of the symbol. The letter l stands for "left", the letter r stands for 
"right".

ACCORDING TO IEC / EN STANDARDS

WHEN YOU GENERATE SYMBOLS AUTOMATICALLY ON ELECTRICAL PAGES, 
THE IEC / EN STANDARDS FOR PLACING TEXTS ARE APPLIED AUTOMATI-

CALLY.
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To assign two connection points on each side of the symbol above, you must there-
fore write #x40mmy50mml2r2.

When you write l2, the counting is done top-down. If you write l-2, the counting is 
done bottom-up.

Accordingly, you can write t for "top" and b for "bottom". If you also wish to specify 
the connection point names, you can write these in brackets in stead of the number 
of connection points.

Thus you can write #x40mmy50mmt(13,21)b(14,22). Hereby you get a symbol 
with the dimensions 40x50, with the connection points 13 and 21 on the top, and 
the connection points 14 and 22 at the bottom.

Connecting line for connection points

To place a 2,5mm connecting line to the connection 
points in the symbol, add a "-" to the end of the format 
string.

E.g.: #x40mmy20mmt2b2-

All connection points are hereby assigned a 2,5mm 
connecting line.

Placing the connection point names

If you take no special action, the connection point names are placed outside the 
symbol. When you want these to be placed inside the symbol, write i at the end of 
the text. If you write #x10mmy20mml2r2i, you get a symbol with two connection 
points to the left and two to the right, where the connection point names are placed 
inside the symbol.

For symbols placed on mechanical pages, the names are typically placed inside 
the symbol, while they are typically placed on the outside for symbols on electrical 
pages.

Automatic generation of Electrical symbols via the Database

To create a symbol directly from the database, type in the symbol dimensions in 
the PCSTYPE field for the component.

Read more about the syntax in “Syntax for automatic generation of symbols” on 
page 220.

Automatic generation of Mechanical symbols via the Database

To any component in the database, you can attach a mechanical symbol. The 
name of the file you have saved this symbol in, you can write in the MECTYPE 
field.

Creating a Mechanical symbol automatically

When you wish Automation to automatically create a symbol with the dimensions 
30x50 mm, you must write #x30mmy50mm in the MECTYPE field. If you in stead 
write #r40mm, the program creates a circle with radius40 mm as a mechanical 
symbol. Read more about this in “Syntax for automatic generation of symbols” on 
page 220.
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— Read more about mechanical symbols in “Mechanical symbols in the database” 
on page 662.

SHOW NET

If you right-click on a connection point of a symbol — or on a signal symbol — and 
choose Show net, you can see which symbols are connected to the same poten-
tial.

It is also specified which connection points on the symbols are connected to the 
potential, and the position of the symbols are also displayed.

After the name of the net, the wire numbers in the net are displayed in brackets, in 
the title bar of the dialog box.

If you double-click on one of the lines, you return to the diagram, and the cross 
hairs point out the location of the connection point of the chosen symbol.

Generate connections lists

To generate a connections list file, choose Lists => Connections List File.

— Read more about generating list files in “Exporting list files” on page 717.

— See also “Connections list for wire numbering” on page 456.

USE THE NET NAVIGATOR

YOU CAN ALSO USE THE NET NAVIGATOR TO EASILY MAINTAIN THE OVER-

VIEW OVER NETS AND CONNECTIONS IN THE PROJECT.

— SEE “Net Navigator” on page 223.

Wire numbers in the net
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NET NAVIGATOR

You can use the Net Navigator to get an overview over nets (potentials) and con-
nections (wires, cable wires and jumper links) in the active project. Despite its tiny 
appearance this is a powerful tool for navigating the nets and connections in the 
active project.

Using the Net Navigator

Start the Net Navigator by choosing Tools => Net Navigator — or by clicking the 
Net Navigator button in the program toolbar.

You then enter the Net Navigator:

How to select connections/nets in the Net Navigator

 1) Specify whether to select Connec-
tions or Nets

 2) Make sure that Additive Selection 
is selected (if you wish to select mul-
tiple connections/nets) and make 
sure that Inverting Selection is not 
selected

 3) Click on a line in the project which is 
a part of the net/connection that you 
wish to select. The connection/net is 
now selected in the project and dis-
played in the Net Navigator

 4) More connections/nets can be 
selected correspondingly

You can now navigate among the pages 
containing the selected connections/nets 
by clicking the navigation buttons in the Net 
Navigator.

Choose to select
Connections or Nets

Navigate between pages
containing selected

Follow nets through
Terminals/Busbars

Get info on last selected
  connection/net

Clear selections of
connections/nets

connections/nets
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How to remove selections in the Net Navigator

This is how to remove individual selections of nets/connections:

 1) In the Net Navigator: Select Inverting Selection

 2) Click on the selected nets/connections, that you wish to deselect

Click Clear if you wish to deselect all selections in the project.

The Net Navigator remains on the screen

The Net Navigator remains on the screen until you close it.

When you click on Deactivated, you can let the Net Navigator remain on the 
screen without the risk of accidentally selecting or deselecting more connections/
nets.
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SIGNAL SYMBOLS

What is a signal symbol

A special kind of symbols are called signal symbols. They are used when you start 
or end a conducting line on a non-electrical point in a diagram, or simply wish to 
name an electrical potential for easy identification.

A signal symbol can be placed in all electrical points, and the signal symbol speci-
fies an electrical connection.

All signal symbols with the same name are connected electrically

To identify an electrical connection from a point, you place a signal symbol, and 
assign a name to this symbol.

The program views all signal symbols with the same signal name as the same 
electrical connection (potential). This means that all signal symbols for instance 
using the name L1 are connected electrically.

Please note that it is only the name of the potential, that identifies the electrical 
connection. This means that you can use the signal symbol itself for different 
potentials, if only you remember to assign different names to the signal symbols.

— See “Automatic insertion of electrical potentials” on page 86.

THIS CHAPTER DESCRIBES

— WHAT IS A SIGNAL SYMBOL.......................................................................p. 225

— THE APPEARANCE OF SIGNAL SYMBOLS.....................................................p. 226

— DESIGNING SIGNAL SYMBOLS ....................................................................p. 226

— PLACING SIGNAL SYMBOLS WHEN DRAWING LINES .....................................p. 226

— SIGNAL SYMBOLS WITH REFERENCE DESIGNATIONS ...................................p. 229

— PLACING SIGNAL SYMBOLS ON PARKED LINES ............................................p. 230

— PLACING SIGNAL SYMBOLS DIRECTLY ........................................................p. 230

— VARIANT NAMES ON SIGNAL SYMBOLS .......................................................p. 230

— INSERT REFERENCE DESIGNATIONS ON SIGNALS AUTOMATICALLY ...............p. 232

— UNREFERRED SIGNAL SYMBOLS ................................................................p. 232

— IMPLIED SIGNALS FOR TERMINALS AND CABLES..........................................p. 233

USE THE NET NAVIGATOR

YOU CAN ALSO USE THE NET NAVIGATOR TO EASILY MAINTAIN THE OVER-

VIEW OVER NETS AND CONNECTIONS IN THE PROJECT.

— SEE “Net Navigator” on page 223.
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The appearance of signal symbols

Signal symbols can for instance look 
as displayed to the right:

Various types of signal symbols are 
located on the symbol folder, in the 
sub folder MISC.

To distinguish the signal symbols from 
other types symbols, they all have 
names starting with SG.

Designing signal symbols

See how to design your own signal 
symbols in “Creating Signal Symbols” 
on page 803.

Placing signal symbols when drawing lines

Activate the Pencil, click on Lines, and make sure the Conducting lines button is 
activated (Highlighted).

Then click on the diagram where you want the signal symbol to be located.

You now enter the dialog box Signals:

Parking

If you wish to wait to connect the conducting line, you can park the line. To do this 
click on Parking, and then click OK. Hereby you get a conducting line with no elec-
trical connection.

However, this is a temporary solution only, which gives you the option to return 
later on, and then assign a name to the signal.

When you later want to place a signal symbol, just right-click on the parked end of 
the line and choose Place signal symbol.

— See how to locate parkings in a project in “Design Check” on page 355.
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Placing the signal symbol

If you, on the other hand, wish to place a signal symbol, click on Signal.

SPECIFY SIGNAL NAME

In the field Signal name you can either type in a name, or use one of the following 
options:

You can also click on the down-arrow in the field Signal name. This gives you the 
option to choose between predefined signal names.

— See the section “Frequently used signal symbol Names” on page 806 to see 
how you can add names to this list by yourself.

BUTTON FUNCTION

INCREASE THE NUMBER IN THE SIGNAL NAME BY 

ONE.

DECREASE THE NUMBER IN THE SIGNAL NAME BY 

ONE.

GIVES YOU THE NEXT AVAILABLE SIGNAL NAME OF 

THE SYMBOL TYPE CHOSEN.

GIVES YOU A LIST, WHERE YOU CAN CHOOSE 

BETWEEN THE SIGNAL NAMES ALREADY USED IN 

THE PROJECT.

GIVES YOU A LIST OF USED VARIANT NAMES FOR 

THE SELECTED SIGNAL SYMBOL — SEE “Variant 
names on signal symbols” on page 230.
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SELECT SIGNAL SYMBOL

When you click the up- and down-arrow in the Signal symbol field in the right 
hand side of the dialog box, you can scroll between the signal symbols that are 
known to the system. The chosen symbol will then be shown in the dialog box.

— See how to place signals in this menu in the section “Frequently used signal 
symbols” on page 805.

ROTATE OR MIRROR THE SIGNAL SYMBOL

Below the symbol itself, you can click the buttons Mirror vertically or Rotate to 
mirror or rotate the symbol.

SIGNAL SYMBOLS FOLLOWING THE LINE DIRECTION

When you select Place in line direction, the signal symbol will follow the direction 
of the line. When you also select Place name on line, the name of the signal sym-
bol will be displayed above the line. The program memorizes the selected settings 
for the different signal symbols in the project — for up to 25 different signal sym-
bols.

SIGNAL NAMES ASSIGNED FROM FUNCTION TEXT OR CONNECTION NAME

WHEN YOU START A LINE FROM A CONNECTION POINT, AND LET IT END WITH 

A SIGNAL, AN EXTRA BUTTON IS DISPLAYED IN THE SIGNALS DIALOG BOX, IF 

A FUNCTION TEXT HAS BEEN SPECIFIED FOR THE CONNECTION POINT, FROM 

WHICH THE LINE IS BEING DRAWN. WHEN YOU CLICK THIS BUTTON, THE SIG-

NAL NAME IS FETCHED FROM THE FUNCTION TEXT FROM THE CONNECTION 

POINT, FROM WHICH THE LINE STARTED:

WHEN FOR INSTANCE THE LINE STARTS FROM A PLC CONNECTION POINT 

— AS IN THE FIGURE ABOVE —, YOU CAN THEREFORE EASILY ASSIGN THE 

ADDRESS FOR THE PLC CONNECTION TO THE SIGNAL NAME. THE SHORT-
CUT KEY FOR THIS FUNCTION IS <ALT+S>.

WHEN A FUNCTION TEXT HAS NOT BEEN 

SPECIFIED FOR THE CONNECTION POINT 

FROM WHICH THE LINE IS BEING DRAWN, 
EITHER CONNECTION NAME OR COMPO-

NENT NAME:CONNECTION NAME CAN BE 

ASSIGNED AS THE SIGNAL NAME.

— SEE “Signal name from PLC or component” on page 928.
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PAGE REFERENCES ON SIGNAL SYMBOLS

In With reference you can assign the symbol reference texts, that refers to the 
other places the same signal symbol is being used.

Selecting Show from/to sets references to the nearest previous and to the next 
following page on which the same signal name occur.

Clicking on Show all will show references to all places the same signal name 
occurs. The program can handle references of an unlimited length.

When you select Show all and In Column, you can specify the maximum number 
of references in each column in the field Max. Number of references pr. column.

If you click in the field Reference text, you can type in the reference text, that will 
be displayed in front of the reference — such as Page_.

REFERENCE DESIGNATIONS ON SIGNAL SYMBOLS

When you wish to include reference designations in the signal name, you can do 
two things:

a) Click on Select, and you get the option of selecting references via the dialog 
box Reference designations, as described in “Reference designations for 
symbols” on page 400, or:

b) Click on the button Insert current page functional/locational aspect for the 
fields Function and/or Location. This assigns the Functional/Locational 
aspect to the signal name.

If you click the Delete button for the fields Function / Location, the displayed func-
tional/locational aspect is deleted.

If you click on Show full Reference designation, the full reference designation is 
displayed for the symbol. If not, only parts of the reference designation different 
from the page reference designation, are displayed.
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CLICK OK WHEN THE SETTINGS ARE OK

When you are contempt with the settings, click OK, otherwise click Cancel.

Placing signal symbols on parked lines

To get the signal symbol in the cross hairs, click the Symbols button, and fetch a 
signal symbol — just like you would fetch any other symbol. Read more about this 
in “Fetching symbols” on page 151.

When you have the signal symbol in the cross hairs, you can place it on a parked 
line. — See “Parking” on page 226.

When you click on the parking point on the drawing, you enter this dialog box:

Because you have already selected a signal symbol, you are not asked about this 
here. Fill out the dialog box following the guidelines given above.

Placing signal symbols directly

You can place a symbol in the cross hairs — for instance via the Symbol menu — 
and place it by clicking on the page. This makes you enter the Signal data menu, 
which you fill out and click OK.

The program now automatically activate the Lines command, and you get a line in 
the cross hairs, starting from the signal symbol.

If you delete the line later on, the signal symbol remains on the page.

Signal symbols can also be placed directly on the connection point of a symbol, or 

on a conducting wire.

Variant names on signal symbols

Automation handles variant names on signal symbols:

What are variant names on signal symbols used for?

Variant names on signal symbols are applied for specifying branches of the same 
signal.
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This being for instance the source point from which three signals with the name L1 
branches off. These three branches can for instance be named L1:1, L1:2 and 
L1:3.

The program sees these as the same signal.

Furthermore, the signal flow follows the variant names. You can change variant 
name on a page, where for instance the name in the left-hand side is L2:4 and in 
the right-hand side is L2:5. — See the figure below.

This makes it possible to keep track of the signal flow.

This supports the correct automatic placing of wire numbers for signals, and can 
make the diagrams mounting correct, with respect to signals.

Comments on variant names

Comments can be attached to variant names, as for instance L1:1 (230 VAC).

Show signal

When you select Functions => Show signal, you enter a dialog box from where 
you select a signal name according to the same principle as described in “Find all 
symbols with identical names” on page 264.

When you have selected a signal name and click OK, the selected signal is dis-
played in green on all project diagram pages, while everything else is displayed in 
red.

To deselect the function, choose Functions => Show signal again.

Reference to

other project

page (double-

click to jump)

Supply panel

Using Variant names, you can follow the signal branches in the project
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Insert Reference designations on Signals automatically

When you wish to let Automation insert reference designations on signal symbols 
automatically, choose Settings => Project data => Reference designations, and 
select Insert Reference designations on Signals.

When you place signal symbols on pages with assigned reference designations, 
the signal symbol will then get these reference designations.

When you place signal symbols in areas with assigned reference designations, the 
signal symbol will then also get these reference designations.

Insert Reference designations on Signals is by default not selected when 
installing the program. You can always place reference designations manually.

Unreferenced signal symbols

If you wish to set all unreferenced signal symbol in the project invisible, just choose 
Functions => Special Functions => Set unreferenced signal symbols invisi-
ble.

— See also “Unreferenced cable symbols” on page 245.

SIGNAL NAMES WITH REF. DESIGNATIONS ACCORDING TO EN61346

A SEMICOLON (;) IS AUTOMATICALLY PLACED BETWEEN SIGNAL NAMES AND 

REFERENCE DESIGNATIONS, AS PRESCRIBED IN EN61346.
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Implicit references for terminal and cable connection points

In some cases references/connections between connection points will be implicit:

Implicit signals for terminals only connected on the internal or external
side

When two terminal symbols with the same names and the same connection 
names, both connection points have activated With reference, and both are only 
connected in one end, they are understood as two representations of the same 
symbol.

References will automatically be displayed for the connection points:

The terminal symbols in the figure above are understood as representations of the 
same symbols, because:

 1) They have same connection names (1U2, 1V2 and 1W2) for the same termi-
nals (=G1+A2-X4)

 2) With reference is activated for the connection points on the terminal sym-
bols, and

Understood as the

same symbols

References are

inserted
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 3) Both sets of terminals are only connected in one end

Implicit signals on cable wires

When two cable symbols with the same names and the same cable wire names, 
and the cable wire connection points for both cables have activated With refer-
ence, and the cable wire connection points for both cables are only connected in 
one direction, the cable wires for the symbols are understood as two representa-
tions of the same cable wires for the same symbol.

The cable wires in the figure above are understood as the same symbols, because:

 1) They have the same cable wire names (BN, BK and BU) for the same cable 
(=G1+A2-W1)

 2) With reference is activated for the cable wire connection points for both of 
the cable symbols, and

To select multiple connection points:

Remember to press <Ctrl> before

releasing the mouse button

Set With reference on the

connection points for both

rows of terminals

Understood as the

same cable wires

Inserted
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 3) Both sets of cable wires are only connected in one direction

Set to With reference

on the connection points

for both cables
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TERMINAL SYMBOLS

When you place terminal symbols, you indicate which connection points are input, 
and which are output for the terminal. This is important when you fill out the termi-
nals lists of the project. — Read more about terminals lists in “Creating a Terminals 
list” on page 826.

— See “Multi layer terminals” on page 237.

— See “Multiplacing symbols” on page 186.

Input and Output on terminal symbols

On the terminal symbol itself, the output 
connection point is solid red.

If you want to change whether a connec-
tion point is input or output, you click the 
Symbols button, right-click on the connec-
tion point, and choose Connection data.

Clicking on the down-arrow in the Main 
type field in the Connection data dialog 
box, enables you to choose whether the 
connection point is of the type input or output — or ext/output, ext/input, int/out-
put or int/input for terminals with additional status PLC, which you can read more 
about in “Creating terminal symbols with additional symbol types” on page 785, 
“Terminal symbols with additional symbol type PLC” on page 786 in particular.

For terminals Extension is set to TERM — or to TERM/PLC, see “Creating termi-
nal symbols with additional symbol types” on page 785, “Terminal symbols with 
additional symbol type PLC” on page 786 in particular.

If you accidentally select the entire symbol instead of the connection point, then 
right-click on the connection point once more.
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Different terminal connection names on the input and output
side

When you have placed a terminal symbol on a project page, and wish to use differ-
ent connection names on the input and output side, do this:

 1) Select the terminal: Choose Symbols and 
double-click on the terminal symbol.

 2) In the dialog box Component data: Set Sym-
boltype2 to Normal and click OK.

 3) You can now double-click on the connection points and name them individu-
ally via the Connection data dialog box.

Changing connection names for terminal rows

See “Renumbering pinnumbers for a terminal row using Select name” on 
page 266.

Designing terminal symbols

See how to design terminal symbols in “Creating terminal symbols” on page 782.

MULTI LAYER TERMINALS

On multi layer terminals

In order to handle multi layer terminals, an extra column have been added in the 
component grouping named Pos.no., that specifies which layer on the terminal the 
terminal symbol refers to.

— See “Component Grouping” on page 613.

THIS CHAPTER DESCRIBES

— ON MULTI LAYER TERMINALS.....................................................................p. 237

— MULTI LAYER TERMINALS ON DIAGRAM PAGES ...........................................p. 238

— MULTI LAYER TERMINALS ON MECHANICAL PAGES......................................p. 238
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Multi layer terminals on diagram pages

When you fetch multi layer terminals 
from the database, the first layer is dis-
played first in the Symbols for compo-
nent window in the lower part of the 
Component menu.

(In version 19 and previous versions, it 
was the order in which the symbols 
were placed in project, that determined 
the layer. This is no longer the case.)

The position numbers can be specified/changed in Functions => Component 
Grouping.

— Please also see “Graphical managing of component grouping for terminals” on 
page 620.

Multi layer terminals on Mechanical pages

The connection point having the connection number 1 on the mechanical symbol, 
is assigned the connection number from the connection point having Pos.No. 1 on 
the symbol on the diagram.

Layer 1 Layer 2

Pos.No. 1

Pos.No. 2

Pos.No. 3

Terminal symbols

on electrical diagram

Definition on

Mechanical symbol

Mechanical symbol

in the project
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WORKING WITH CABLE SYMBOLS

This section deals with how to apply cable symbols on your diagrams.

— See “Creating cable symbols” on page 787 and “Creating busbar symbols” on 
page 789.

The database in Automation can contain information about cable wire names. If 
you are using the database, the names of the cable wires can therefore be sup-
plied automatically.

When you work with cables you enter different dialog boxes when selecting the 
cable wires, depending on whether the system has cable wire names for  the cable 
or not.

You can find cable symbols in the pickmenu, and by opening the folder MISC from 
the Symbol menu. In the database, you will find cables in the folder Flexible 
cables.

Placing cable symbols without Cable wire names from the Data-
base

When you have a cable symbol in the cross hairs, you place it next to some of the 
wires you want to include into the cable. You then enter the Cable data dialog box:

THIS CHAPTER DESCRIBES

— PLACING CABLE SYMBOLS WITHOUT WIRE NAMES FROM THE DATABASE......p. 239

— PLACING CABLE SYMBOLS WITH WIRE NAMES FROM THE DATABASE ............p. 242

— PLACING SYMBOLS FOR THE SAME CABLE IN ONE OPERATION.....................p. 243

— MOVING CONNECTION POINTS FOR CABLE WIRES.......................................p. 243

— ADDING CABLE WIRES TO PLACED CABLES.................................................p. 244

— REMOVING CABLE WIRES FROM PLACED CABLES........................................p. 244

— ADDING A SCREEN ON A PLACED CABLE ....................................................p. 245

— REVERSE DIRECTION ON PLACED CABLES..................................................p. 245

— UNREFERENCED CABLE SYMBOLS .............................................................p. 245

— SETTINGS FOR DEFAULT CABLE DIRECTION................................................p. 246

Specify the number

of wires in the cable
mation

Page 239



P

Symbols
Number of cable wires in the cable

In the field No. of Wires, you can specify how many wires that exists in this cable. 
When this amount of wires have been placed, it will not be possible to place any 
more wires for this cable. — If the cable is fetched via the database, the field No. of 
Wires is filled out automatically.

Filling out the dialog box Cable data

Apart from this, you can fill out the dialog box Cable data as described in “Placing 
and Naming symbols” on page 171. Click OK.

The illustration below is a part of a larger drawing, where the three vertical lines are 
wires.

When you place the cable, a rubber band now starts in the reference point of the 
symbol, and ends up in the cross hairs. This indicates that you can now point out 
which wires to include in the cable.

You have two options: Pointing out the wires individually, or selecting more than 
one wire at the time:

Pointing out individual cable wires

Click on the wires you want to include one at a time. Each time you click on a wire, 
you are asked to type in Connection data.

NUMBER OF WIRES IN COMPONENTS LISTS

WHEN CREATING COMPONENTS LISTS, IT IS POSSIBLE TO INSERT INFORMA-

TION ABOUT THE NUMBER OF WIRES AND USED WIRES FOR THE CABLES IN 

THE LIST VIA THE DATAFIELD CABLE WIRES.

Double-click in the field to select Name from a list of
cable wire names according to standards
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When you click OK the symbol expands to include this wire as well.

When you do not wish to include more wires into the cable you press <Esc>, and 
the "rubber band" disappears. If the number of cable wires is specified in the dialog 
box Cable data, the "rubber band" disappears when the specified number of cable 
wires have been placed in the project.

Pointing out more than one cable wire in a single operation

When you have placed the cable symbol — and a thin line (the "rubber band") 
starts in the reference point of the symbol, and ends up in the cross hairs — you 
can mark up a window over the wires, which you wish to include in the cable:

When you release the mouse button, you enter the dialog box Connection data, 
from where you can name cable wires — for instance by using automatic counting:

Click here Keep the mouse button pressed down,

and drag the mouse cursor across the wires

Release the mouse button

when all wires are included
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If for instance you write 1 in the Name field, press down <Ctrl> while clicking on +, 
and then click OK, the three wires in the example will get the names 1, 2 and 3 
respectively. — See e.g. “Automatic naming of symbols” on page 196.

When you are using a cable with specified wire names from the database, the 
selected wires are automatically assigned wire names according to the order in 
which the wires appear in the database.

Place cables with Cable wire names from the database

When you use the database, you can let the database supply the cable wire names 
automatically.

The procedure for selecting the cable symbol, and pointing out the cable wires is 
the same as described in “Placing cable symbols without Cable wire names from 
the Database” on page 239.

Only, when you select a cable wire, you enter this dialog box instead:

Here you choose which of the cable conductors you wish to apply, and click OK.

Each time you enter this dialog box, you can see which cable wire names are 
Available and which are Used.

If you have changed a cable wire name to a name unknown to the database, you 
also see the tab Unknown.

— Please note that it is also possible to choose cable wires from the tab Used. 
This makes it possible to display the cable wire more than one place in the project.
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Placing symbols for the same cable in a single operation

You can place more than one symbol for the same cable at different locations in the 
diagrams, in a single operation. When these symbols have the same cable name, 
the program knows they represent the same cable.

Select the cable symbol only once

When you place a cable symbol and include some cable wires in the cable, and 
then click exactly over, or exactly under, the cable symbol, a new cable symbol with 
the same cable name is placed in the diagram:

To do as in the figure above, do the following:

 1) Place the cable symbol -W3 and include the cable wires in the cable

 2) Do not press <Esc> to stop including cable wires, but click vertically under 
the -W3 cable symbol

 3) A new cable symbol with the name -W3 is placed in the diagram

FREE PLACING OF THE SUBSEQUENT CABLE SYMBOL

When you need to place the other cable symbol for the same cable anywhere in 
the diagram, do the following:

 1) Place the cable symbol -W3 and include the cable wires in the cable

 2) Do not press <Esc> to stop including cable wires, but press <Ctrl>, and click 
where you wish to place the next cable symbol

 3) A new cable symbol with the name -W3 is now placed where you clicked

Moving connection points for cable wires

It is possible to move the connection points for a cable in relation to the cable sym-
bol. The connection points can only be moved along the axis of the symbol, and 
can not be moved to the opposite side of the reference point of the symbol. To 
move a connection point, do the following:

 1) Make sure that the Symbols button is activated, right-click on the connection 
point, and select Move

1

3

2
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 2) You now get the connection point in the cross hairs: Click where you wish to 
place the connection point.

Moving connection points for cable wires in areas

If you select the connection points in an area — by dragging a window over them 
and pressing <Ctrl> when releasing the mouse button — you can also move the 
selected connection points for the cable in the area.

Adding wires to cables

If you want to add another wire to the cable after having deselected the cable sym-
bol, first make sure the Symbols button is activated, then right-click on the cable 
symbol, and choose Add cable core. A rubber band now radiates from the refer-
ence point and ends in the cross hairs.

Now click on the wire(s) that are to be included in the cable, and each time you 
click on a wire, the symbol expands to include this wire as well.

If you are using a cable with color codes from the database, you will be asked to 
select color codes for each individual wire, as described in “Place cables with 
Cable wire names from the database” on page 242.

You can also select more than one wire in one operation, as described in “Pointing 
out more than one cable wire in a single operation” on page 241.

Press <Esc> when you have finished.

Removing a wire from a cable

If you later on want to remove a core from the cable, you make sure the Symbols 
button is activated, right-click on the connection point for the wire you want to 
exclude, and choose Delete.
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Adding a screen to a placed cable symbol

To add a cable screen to a placed cable symbol, do this:

 1) Click the Symbol button — to work with symbols.

 2) Right-click on the cable symbol, and choose Add Cable screen.

 3) In the dialog box Connection data: Type in a name for the cable screen, and 
click OK.

 4) A connection point for the cable screen is now inserted on the cable symbol, 
the program changes to the Lines command automatically, and initiates the 
drawing of a line starting from the connection point for the cable screen:

 5) Change line type if necessary, and connect the line to the desired symbol.

Reversing the cable direction

To reverse the direction of the cable, right-click on the reference point of the cable, 
and choose Reverse direction. If you have selected multiple cables, the direction 
is reversed on all selected cables.

The direction is of importance when the cable lists are filled out.

Unreferenced cable symbols

When you create a project by using sub drawings or sub projects, where one end 
of a cable is displayed on one project page, and the other end is displayed on 

THE CABLE SYMBOL MUST HAVE A SCREEN CONNECTION POINT

TO USE THE FUNCTION ADD CABLE SCREEN, THE APPLIED CABLE SYMBOL 

MUST HAVE A CONNECTION POINT FOR A CABLE SCREEN IN ITS SYMBOL 

DEFINITION.

— SEE “Connection point for cable screen” on page 787.

LINE SETTINGS MEMORIZED FOR CABLE SCREENS

THE PROGRAM AUTOMATICALLY USE THE LINE SETTINGS, THAT YOU USED 

THE LAST TIME YOU CONNECTED A CABLE SCREEN.

AFTER CONNECTING THE CABLE SCREEN, THE PROGRAM AUTOMATICALLY 

SWITCH BACK TO THE LINE SETTINGS, THAT YOU USED BEFORE CONNECTING 

THE CABLE SCREEN.

— READ MORE ABOUT LINE SETTINGS IN “The Lines toolbar” on page 73.
mation

Page 245



P

Symbols
another project page, it may occur that one end of a cable is not used in a project. 
If With reference is activated for the cable connection points, these will be unrefer-
enced.

These cables can be set to be invisible by choosing Functions => Special Func-
tions => Set unreferenced cable symbols invisible.

— See also “Unreferenced signal symbols” on page 232.

Default Cable direction

In Settings => Text/Symbol default you can specify the cable direction as an 
over-all setting, vertically as well as horizontally.

USING BUSBAR SYMBOLS

— See “Creating busbar symbols” on page 789.

USING ACCESSORY SYMBOLS

To use an accessory symbol to specify that a symbol 
needs an accessory, do this:

 1) Make sure the Symbols button is activated, 
right-click on the symbol, and choose Place 
accessory (or choose Functions => Place 
Accessory).

 2) You now get the accessory symbol in the cross 
hairs: Click where you wish to place the acces-
sory symbol — e.g. next to the symbol.

 3) In the dialog box Component data: The accessory symbol is automatically 
assigned the name of the selected symbol (here -Q1). Type in the article 
number for the accessory, or click on Database, to select the accessory 
component in the database.

Data from accessory symbols are included in the lists, but the accessory symbol 
itself is not included when printing the diagram pages. Accessory symbols do not 
necessarily have to be attached to other symbols in the documentation.

RECOMMENDED TO INCLUDE ACCESSORIES IN OTHER WAYS

STARTING FROM VERSION 17, EASIER WAYS TO INCLUDE ACCESSORY 

INFORMATION HAVE BEEN INTRODUCED. PLEASE READ MORE ABOUT THIS IN 

“Component accessories” on page 676 AND “Optional accessories - 
Mechanical” on page 677.

Support symbol for -Q1
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SYMBOL FOLDERS

The symbols in Automation are located in various folders, depending on their use.

When you wish to fetch a symbol, it is a good idea to know in which folder the sym-
bol is located.

Typically, the symbols will be located in folders under the folder c:\Pcsel-
cad\SYMBOL. Here is a survey of the contents of these folders:

FOLDER CONTENTS

ALARM SYMBOLS FOR ALARM SYSTEMS. NOT STANDARD. (THIS FOLDER IS NOT CRE-

ATED FOR NEW INSTALLATIONS OF VERSION 18 AND SUBSEQUENT VERSIONS. 
INSTEAD, THE DESCRIBED CONTENTS IS PLACED IN THE 60617_2015 
FOLDER).

ANSI SYMBOLS FOLLOWING THE AMERICAN ANSI STANDARD.

BUILDING SYMBOLS FOR GROUND PLAN DRAWINGS: DOORS, WINDOWS, WHITE GOODS 

ETC.

DB60617 SYMBOLS CREATED BECAUSE OF THE DATABASES FOR THE PROGRAM. THE 

SYMBOLS FOLLOWS THE STANDARD EN 60617. (THIS FOLDER IS NOT CRE-

ATED FOR NEW INSTALLATIONS OF VERSION 18 AND SUBSEQUENT VERSIONS. 
INSTEAD, THE DESCRIBED CONTENTS IS PLACED IN THE 60617_2015 
FOLDER).

DEMOMEC EXCLUSIVELY MECHANICAL SYMBOLS FOR SWITCHBOARD DRAWINGS. AT 

PRESENT THE FOLDER ONLY CONTAINS EXAMPLES USED IN "AUTOMATION 

PROJECT TUTORIAL" IN THE PCschematic Tutorial MANUAL.

EIB SYMBOLS FOR INTELLIGENT BUILDING INSTALLATION (EIB).

EN1861 SYMBOLS ACCORDING TO EN 1861, REFRIGERATING SYSTEMS AND HEAT 

PUMPS - SYSTEM FLOW DIAGRAMS AND PIPING AND INSTRUMENT DIAGRAMS - 
LAYOUT AND SYMBOLS.
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EN60617 THE FOLDER CONTAINS SYMBOLS ACCORDING TO THE EUROPEAN STANDARD 

IEC/EN 60617, GRAPHICAL SYMBOLS FOR DIAGRAMS.
THE SYMBOLS FOLLOWS IEC/ISO 81714-2, CONSTRUCTION OF GRAPHICAL 

SYMBOLS. THE SYMBOL NAMES FOLLOWS THE EN 61346 STANDARD FOR 

LETTER CODES.
PCSCHEMATIC HAS A LICENSE FOR USING THE IEC STANDARDS.
THE SYMBOLS ARE SAVED UNDER THEIR SERIAL NUMBER, FOR INSTANCE 04-
02-14.
IF A SYMBOL IN THE IEC STANDARD IS ONLY SHOWN AS A MAKE-FUNCTION 

(N/O, NORMALLY OPENED SYMBOL), AN EVENTUAL CORRESPONDING BREAK-
FUNCTION (N/C, NORMALLY CLOSED SYMBOL) WILL THEN HAVE A B INSTEAD 

OF THE LAST HYPHEN - AND AN S IF THE OPPOSITE IS THE CASE.
POWER CONTROL CIRCUIT SYMBOLS, THAT ARE NOT COVERED BY THE IEC 
STANDARDS, HAVE BEEN ASSIGNED A NAME STARTING WITH H FOLLOWED BY 

AN IEC SERIAL NUMBER, WHERE 0 IS EXCLUDED. THE FIRST HYPHEN HAVE 

BEEN REPLACED BY THE NUMBER OF CONTACTS. FOR INSTANCE: H7303-04.
AT THE SAME TIME A NUMBER OF SYMBOLS NOT SHOWN IN IEC HAVE BEEN 

CREATED, FOLLOWING THE STANDARD.
THE SYMBOLS ARE DESIGNED WITHOUT A MINUS IN FRONT OF THE SYMBOL 

NAMES. THIS IS BECAUSE THE PROGRAM AUTOMATICALLY INSERTS A MINUS 

IN FRONT OF THE NAMES OF THE SYMBOLS YOU PLACE IN THE PROJECTS, IF 

YOU CHOOSE SETTINGS => POINTER/SCREEN AND SELECT INSERT - IN 

FRONT OF SYMBOL NAMES — SEE “Pointer/Screen” on page 906.

IF YOU CHOOSE FUNCTIONS => SPECIAL FUNCTIONS => PREFIX ALL SYM-

BOL NAMES WITH -, A MINUS IS INSERTED IN FRONT OF ALL SYMBOL NAMES IN 

THE SYMBOLS IN THE PROJECT. (THIS FOLDER IS NOT CREATED FOR NEW 

INSTALLATIONS OF VERSION 18 AND SUBSEQUENT VERSIONS. INSTEAD, THE 

DESCRIBED CONTENTS IS PLACED IN THE 60617_2015 FOLDER).

60617_2015 SPECIAL INFORMATION FOR UPDATING TO VERSION 18: ALL 60617 SYMBOLS 

HAVE BEEN UPDATED SO THAT THE POSITION AND SIZES OF THE TEXTS FOL-

LOWS THE STANDARDS IEC 60617 AND IEC/ISO 81714-2 (SYMBOL 

DESIGN), AND ARE ALSO ADDED THE NEW S-NO IN THE DESCRIPTION. THIS 

INCLUDES THE SYMBOLS IN THE FOLDERS EN60617, DB60617, IECINST 
AND ALARM.
ALL OF THESE NEW VERSIONS OF THE SYMBOLS FROM THESE FOLDERS ARE 

PLACED IN THE 60617_2015 FOLDER.
IF YOU HAVE CHOSEN TO UPDATE TO VERSION 18 THE FOLDERS EN60617, 
DB60617, IECINST AND ALARM REMAINS WITH UNCHANGED CONTENTS.
IF YOU HAVE CHOSEN TO MAKE A NEW INSTALLATION OF VERSION 18, THE 

FOLDERS EN60617, DB60617, IECINST AND ALARM ARE NOT CREATED.

FLOW-
CHAR

SYMBOLS FOR (COMPUTER) FLOWCHARTS.

HEAD DRAWING HEADERS, FORMULAS FOR PARTS LISTS AND TABLES OF CONTENTS 

AND UNIT TABLES FOR UNIT DRAWINGS.

IBIICONS IBI LIBRARY, DESIGNED BY COWI A/S.

IECINST SYMBOLS FOR ELECTRICAL INSTALLATIONS, FROM EN 60617, GRAPHICAL 

SYMBOLS FOR DIAGRAMS - PART 11: ARCHITECTURAL AND TOPOGRAPHICAL 

INSTALLATION PLANS AND DIAGRAMS. (THIS FOLDER IS NOT CREATED FOR 

NEW INSTALLATIONS OF VERSION 18 AND SUBSEQUENT VERSIONS. INSTEAD, 
THE DESCRIBED CONTENTS IS PLACED IN THE 60617_2015 FOLDER).

IECPNEU SYMBOLS FOR PNEUMATICS AND HYDRAULICS, FROM EN 60617, FLUID 

POWER SYSTEMS AND COMPONENTS - GRAPHIC SYMBOLS AND CIRCUIT DIA-

GRAMS ACC. TO ISO 1219 AND BASIC SYMBOLS ACC. TO EN 60617.

FOLDER CONTENTS
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MISC SPECIAL SYMBOLS, WHICH ARE NOT OFFICIAL STANDARD, BUT ARE INCLUDED 

IN Automation: SIGNAL SYMBOLS, CABLE SYMBOLS, LOGOS, PLC REFER-

ENCE SYMBOLS ETC. (THIS FOLDER IS NOT CREATED FOR NEW INSTALLA-

TIONS OF VERSION 18 AND SUBSEQUENT VERSIONS. INSTEAD, THE 

DESCRIBED CONTENTS IS PLACED IN THE 60617_2015 FOLDER).

MISC_2015 CONTAINS THE MOST RECENTLY UPDATED VERSION OF THE MISC FOLDER.

PBSYM-
BOL

SYMBOLS FOR THE PANELBUILDER. IN ORDER TO READ MORE ABOUT THE 

PANELBUILDER, PLEASE DOWNLOAD THE TUTORIAL FOR THE PANELBUILDER 

AT www.pcschematic.com/manuals

PLC346 PLC SYMBOLS ARE CREATED IN COOPERATION WITH A BOARD OF PLC VEN-

DORS. NOT STANDARD.

USERLIB FOLDER FOR YOUR OWN SYMBOLS.

FOLDER CONTENTS
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FUNCTIONS ON COMPONENT LEVEL

Automation has a component based workflow which encourages working with an 
attached database containing information about the components that you use in 
your projects.

This means that when you work with symbols in Automation, the individual sym-
bol will frequently just be one symbol among other symbols for the functions in a 
component.

Therefore, there are both functions for working on symbol level and component 
level. This chapter describes how to work at component level in Automation. In 

“Symbols” on page 149 you can see more about how to work at symbol level.

- See how to create your own components in the database in “Creating compo-
nents in the database” on page 647.

- There is also a Component Wizard which guides you through creating new 
components. It is activated by clicking the Component Wizard button in the 
program toolbar, or by choosing Functions => Component Database => 
Component Wizard. It is described in an independent mini manual, which you 
find under Help => Component Wizard manual.

THIS CHAPTER DESCRIBES

— THE RELATIONSHIP BETWEEN SYMBOLS AND COMPONENTS .......................p. 251

— FETCHING SYMBOLS FOR A COMPONENT VIA THE DATABASE ......................p. 253

— THE COMPONENT MENU ...........................................................................p. 254

— THE COMPONENTS WINDOW .....................................................................p. 256

— THE SYMBOLS FOR COMPONENT WINDOW .................................................p. 259

— SHORT-CUTS IN THE COMPONENT MENU ...................................................p. 263

— FINDING SYMBOLS BASED ON THE SYMBOL NAME ......................................p. 264

— SELECT COMPONENT................................................................................p. 268

— PLACE AVAILABLE SYMBOLS FOR A COMPONENT ........................................p. 268

— UPDATING FROM THE DATABASE WHEN CHANGING ARTICLE NO. ................p. 269

RENAME COMPONENTS / SYMBOLS

IN “Rename selected symbols” on page 322 YOU CAN SEE HOW TO 

RENAME SELECTED COMPONENTS/SYMBOLS — OR HOW TO RENAME ALL 

COMPONENTS/SYMBOLS IN THE PROJECT.
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THE RELATIONSHIP BETWEEN SYMBOLS AND COMPONENTS

In order to understand the component based workflow in Automation, it is impor-
tant to understand the relationship between components and symbols.

Components have Electrical and Mechanical symbols

In Automation symbols are used in the documentation as a graphical representa-
tion of the physical components — electrical symbols on diagram pages and 
mechanical symbols on mechanical pages.

A component in Automation has a unique component name. All symbols having 
the same component name are therefore understood as being a part of the same 
component. The components can have both electrical an mechanical symbols and 
article data attached.

The components have attached one electrical symbol for each function in the com-
ponent. Components containing more than one function therefore have multiple 
electrical symbols attached.

These electrical symbols can be placed freely on the diagram pages in the project.

Components can also have one or more mechanical symbols attached.

It is also possible to attach other kinds of symbols, such as pneumatic symbols, to 
the components. Read more about this in “The page database field for symbols” on 
page 257.

Specifying that symbols are part of the same component

In order to specify that symbols belongs to the same component, they must have 
the same component name:

When you type in the same symbol name for two electrical symbols in a project, 
this specifies that they are part of the same component — please also see “Func-
tion assemblies - with multiple article numbers” on page 252.

When you are on a diagram page and choose a component via the database, the 
electrical symbols for the component are displayed under Available symbols at 

Symbols for -K1, placed on different project pages

(Two electrical symbols, and one mechanical)
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the bottom of the Component menu. From there you can place the symbols in the 
project diagrams. — See “Fetching symbols for a Component from the Database” 
on page 253.

If you are working on a mechanical page, you get the mechanical symbol(s) for the 
component in stead, which you can then place on the mechanical page.

— See “Update from Database when changing symbol Article no” on page 269 
also.

Function assemblies - with multiple article numbers

When you are working with advanced contactors, the symbols can be an assembly 
of several components.

The program knows that two — or more — symbols belong to the same compo-
nent when they have the same name and article number.

This also applies for terminal rows and other function assemblies.

— See “Sub names on symbols” on page 183 also.

Component data, lists and databases

When you have attached article numbers to the symbols on the diagrams, the pro-
gram can update lists automatically by fetching the necessary information from the 
database.

— Read more about this in “Using the database” on page 629.

Practically all components in the component vendor databases for Automation 
also have an attached mechanical symbol, which can be used for mechanical lay-
outs. — Read more about this in “Placing mechanical symbols via the database” 
on page 696.
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FETCHING SYMBOLS FOR A COMPONENT FROM THE DATABASE

When you select a component via the database, the electrical symbols for the 
components are displayed under Available symbols at the bottom of the Compo-
nent menu in the right-hand side of the screen. These symbols can then be placed 
in the project diagrams.

This is described in further detail in “Fetching symbols from the database” on 
page 167.

Placing symbols using the database, enables you to generate project lists automat-
ically. You will find the relation between components, databases and automatic 
updating of lists described in further detail in “Using the database” on page 629.
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THE COMPONENT MENU

The Component menu is placed in the right-hand side of the work area, and gives 
you an overview over the applied components in the project.

The Component menu only displays symbols from the symbol category (such as 
electrical, mechanical, pneumatic or hydraulic), which are selected for the active 
page in the project:

- When you work on a Diagram page, only components with electrical symbols 
are displayed.

- When you work on a Mechanical page, only components with mechanical sym-
bols are displayed.

- If you work with another symbol category on the page, only symbols from this 
category are displayed. — See “The page database field for symbols” on 
page 257.

The Component menu contains two independent windows:

- The Components window, which contains a list of the applied components in 
the project (see “The Components window” on page 256) and

- The Symbols for component window, which contains a tree structure display-
ing all of the symbols and optional accessories for the selected component, as 
well as a pickmenu containing the available symbols for the component (see 
“The Symbols for component window” on page 259).

The Components 
window

The Symbols for component
window
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The Component menu can be hidden by clicking the >> button in the upper right-
hand corner of the window.

In order to view the window again, just click the << button on the Component 
menu tab at the far right of the screen.

Furthermore, there is the option of deactivating the Component menu in case you 
do not want the window to be refreshed while you work. — See “Pointer/Screen” on 
page 906.

Moving the Components and the Symbols for component windows

Both the Components and the Symbols for component windows can be moved. 
In order to move one of the windows, you just need to click on the title bar for the 
window and drag the window to the desired position — for instance on another 
screen, if you work with multiple screens.

— See “Moving the Explorer, the Component list or the Symbols for component 
window” on page 26.

Using the Component menu window for different kinds of symbols

You can for instance read more about how to apply the Component menu when 
working with different kinds of symbols here:

— “Workflow for PLCs from the database” on page 469

— “Placing mechanical symbols via the Component menu” on page 697
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The Components window

The Components window is the upper window inside the Component menu. 
Here you can see a list of selected components in the project. When you click on a 
component in the Components window, the contents of the Symbols for compo-
nent window is updated, so that it contains information about the selected compo-
nent. — See “The Symbols for component window” on page 259.

At the top of the Components window you can specify the criteria for which com-
ponents in the project, that are displayed. This can either be one specific criterion, 
or a combination of different types of criteria: Reference designations, component 
names and placing status.

Filter functions in the Components window: Reference designations

When you click the Reference designations button, you enter the dialog box Ref-
erence designations, where you can specify which reference designations to 
show.

— Read more about reference designations in “Reference designations” on 
page 371.

Filter functions in the Components window: Texts for the component

When you click in the Search in selected column field, you can search among the 
texts for the components in the project. First you click on the column that you want 
to search in — the column Name in the figure below — and then click in the search 
field in the upper-right corner. Then type in the characters that you search for in the 
component name. The component names matching the search criterion are now 
displayed in the Components window:

Filtering functions
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Filter functions in the Components window: Placing status

You can also specify which placing status of the 
components:

- When you click the Show all button, all com-
ponents in the project are displayed

- When you click the Completely-placed but-
ton, only components with all symbols placed 
in the project are displayed.

- When you click the Partly-placed button, only 
components where not all symbols have been placed are displayed.

- When you click the Not-placed button, only components with no placed sym-
bols are displayed. This option can for instance be handy if you have placed all 
electrical symbols for a component, and now work on a mechanical page and 
are about to place its mechanical symbol(s) — or the other way around.

DIMMED RED SQUARE

If a dimmed red square is displayed next to a component in the list, this means that 
the symbols for the main component are placed in the project, but the component 
still has accessories, which are not placed yet.

Show Last selected component

When you click the Last selected component button, the last component selected 
in the Components window, is displayed again.

You may need to use this button, because the Components window is updated 
when you click on symbols in the project. When you click this button, the Compo-
nents window once again shows the last component, that you clicked on inside the 
Components window.

The page database field for symbols

Normally, you work with electrical symbols on diagram pages and mechanical sym-
bols on mechanical pages.

GREEN/YELLOW CORRESPONDS TO THE "SHOW AVAILABLE" WINDOW

IF YOU CHOOSE THE SHOW PARTLY-PLACED BUTTON, YOU WILL GET THE 

SAME RESULT AS YOU GOT IN THE "SHOW AVAILABLE" WINDOW, WHICH WAS 

USED IN Automation UNTIL VERSION 19.
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However, in the field Page database field for symbols, you can specify that you 
want to work with a different category of symbols on the page:

If you work with another category of symbols on the page, only symbols of the 
specified category are displayed in the Component menu.

— See how to change the settings in the program, which makes this possible, in 
“Other symbols” on page 675.

Select component and Select component name

When you click on a component in the Components window and then click the 
Select component button, the Select component window is opened for the 
selected component.

— See “Select Component” on page 268.

When you right-click on a component in the Components window and choose 
Select component name, all components with the same component name are 
selected in the Components window.

Update list (from database)

When you click the Update list button, the components in the Components win-
dow are updated with information from the database. It is only relevant to click this 
button if you know that changes have been made in the database.

Shown columns

When you click the Shown columns button, you can 
specify which information to display in the Compo-
nents window.

Please note that you can also move the columns in 
the Components window, so that they appear in an 
order that suits you. To move a column just click on 
the column header and drag it to the desired posi-
tion.
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The Symbols for component window

The Symbols for component window is the window at the bottom of the Compo-
nent menu.

When you have selected a component in the Components window (see “The 
Components window” on page 256), the Symbols for component window dis-
plays a tree structure containing the symbols and optional accessories for the 
selected component, as well as a pickmenu containing the available symbols for 
the component.

Symbols for the component, that are placed in the project, have a check mark after 
the symbol name in the tree view. A check mark is not set for accessories, because 
accessories can be placed multiple times. The selected accessory is displayed 
below the component in the Components window. When you double-click on a 
placed symbol in the Symbols for component window, the cross hairs points out 
the symbol on the project page.

When you click on an available symbol in the tree view, or under Available sym-
bols, you get the symbol in the cross hairs, and can then place it in the project.

Stack similar symbols

When a component has multiple available symbols of the same type, these can be 
displayed in two different ways under Available symbols:

• When the Stack similar symbols button is activated: A single symbol is dis-
played along with an indication of the number of available symbols of this type 
(i.e. 2x)

• When the Stack similar symbols button is not activated: The symbols are dis-
played individually

Click on a placed symbol and 
the cross hairs points it out

Click on an available symbol 
and place it in the project

Stack identical symbols

Specify height for symbols in 
"Available symbols"

Filter (for IO symbols only)
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Filtering and other special options for PLCs

For components with many 
attached symbols, there can be 
tabs at the bottom of Available 
symbols, which makes it easier to 
find the symbols that you need.

For PLCs there can be tabs for ref-
erence symbols, input symbols and 
output symbols.

The Stack similar symbols button 
is also handy when handling many 
similar I/O symbols.

FILTERING FOR SHOWING PLC SYMBOLS UNDER AVAILABLE SYMBOLS

There is also a Filter button, which is used for filtering which symbols to show 
under Available symbols. The filter is activated/deactivated by clicking the Filter 
button. The filter settings is specified by clicking the Filter button, which gives you 
the option of specifying which address interval to show.

You can see that the filter is active when the background color on the Filter button 
is green.

— Learn more about working with PLCs in “Working with PLCs” on page 466.

Tabs for PLCs Filtering
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Optional electrical accessories in Symbols for component
When a component has optional electrical accessories, the optional electrical 
accessories are displayed in the Symbols for component window:

When you click on the + in front of one of the optional accessory components in the 
upper part of the Symbols for component window (PCS2250124 in the figure 
above), the symbols for the accessory component are displayed in list form in the 
upper part of the window while the symbols for the component are displayed in the 
lower part of the window.

From there they can be placed in the project, like any other symbol. Contrary to the 
symbols for "the main component", a check mark is not set for the accessory sym-
bols, because these can be placed more than once in the project. The selected 
accessories are displayed below the component in the Components window.

When one of the symbols for an accessory is placed in the project, the accessory 
will also appear in the Components window in the upper part of the Component 
menu, where the accessory is indented below the main component:

The selected electrical accessories are also displayed in the Component data dia-
log box on the Accessory tab — see “The Accessory tab” on page 180.

Click here ...

... and the symbols for the
accessory is displayed here
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Placing an available symbol for a component

When you click on a component in the list in the Components window, you can 
see the available symbols for the component in the lower part of the Symbols for 
component window under Available symbols.

When you click on one of the available symbols for the component at the bottom of 
the window, you get the symbol in the cross hairs. You can now place the symbol in 
the project — with attached article data and component name.

Placing all available symbols for a component

You can also right-click on one of the symbols for the component under Available 
symbols in the lower part of the Component menu, and choose Place all. This 
gives you all of the available symbols for the component in the cross hairs, and 
they are placed side by side, when you place them on a project page.

Place all - for PLCs

When for instance you have selected all output symbols for a PLC, and wish to 
place them side by side on a page with predefined current path numbers, 
Automation takes this into consideration:

- When between 4 and 16 current path numbers have been defined for the page, 
the PLC symbols will be placed so that the distance between the PLC symbols 
is the same as the distance between the current path numbers

- There will not be placed more PLC symbols on the page, than the number of 
defined current path numbers specified for the page

Place all - on mechanical pages

When you are working on a Mechanical page, the 
Component menu shows all components with 
available mechanical symbols in the project.

When for instance you use Place all to place ter-
minal symbols on a mechanical page, you get all 
mechanical terminal symbols in the cross hairs, so 
that you can place them side by side.
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SHORT-CUTS IN THE COMPONENT MENU

You can use the following short-cut keys in the Component menu:

• Short-cut <Shift + F9>: Functions => Go To: Components — here you return 
to the Components window for the last component that you selected in the 
Component menu.

• Short-cut <Alt + F9>: Functions => Go To: Symbols for component — here 
you return to Symbols for component window for the last component that 
you selected in the Component menu.

• Short-cut <F9>: Functions => Go to: Available symbols — see “Go to: Avai-
lable symbols <F9>” on page 263.

• Short-cut <Ctrl + F9>: Functions => Go To: Available symbols again — here 
you return to Available symbols for the last component that you selected in 
the Component menu.

Go to: Available symbols <F9>

When you have selected a symbol in a diagram and press <F9> or choose Func-
tions => Go to: Available symbols, you enter the Available symbols window at 
the bottom of the Component menu, where the first available symbol for the com-
ponent is highlighted:
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FINDING SYMBOLS BASED ON THE COMPONENT NAME

— See “Select Component” on page 268 also.

Find all symbols with identical names

When you want to get a survey of where the electrical symbols for the component 
are placed in the project, you choose Functions => Select name.

You then enter a dialog box where you specify the name of the component:

When you wish just to find the symbols for a specific component, type in the com-
ponent name, and press <Enter>.

When you need a list of component names in the project, click the Used names 
button, select a name from the list of component names, and click OK.

When there is more than one symbol with the same name, the Select name win-
dow is displayed:

THE SELECT NAME FUNCTION CAN BE USED FOR:

— FINDING SYMBOLS IN THE PROJECT QUICKLY

— EDITING COMPONENT DATA FOR MORE THAN ONE SYMBOL AT THE TIME

THIS CHAPTER DESCRIBES

— FIND ALL SYMBOLS WITH IDENTICAL NAMES ...............................................p. 264

— SEARCHING FOR MORE COMPONENTS USING WILDCARDS ..........................p. 265

— JUMP TO THE NEXT SYMBOL IN THE SELECT NAME LIST AUTOMATICALLY.....p. 265

— CHANGING SYMBOL REF. DESIGNATIONS USING SELECT NAME....................p. 266

— RENUMBER CONNECTION NAMES FOR TERMINAL ROW USING SELECT NAME p. 266
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Here you can see all the places the symbol name occurs in the project, as well as 
different information about the symbols; their connection names, symbol types, 
which project page they are placed on, the page type of this page, and their posi-
tion on the page.

You can remove symbols from the window by selecting them and press <Delete>. 
(Please note that this does not remove the symbols from the project, but only from 
the Select name window). Read more about selecting in “Selecting objects in the 
Object Lister” on page 344.

The contents of the window can be sorted as described in “The sorting order of the 
data in the Object Lister” on page 344.

Searching after more components using Wildcards

When you wish to find all components of a specific type, or do you not know all of 
the component name, you can use the so-called wildcards — as described in 
“Wildcards/jokers” on page 605.

When for instance you write * and click OK all project symbols are selected, as if 
you had pressed <Ctrl> and selected the symbols one at the time.

If you have followed the naming standard about - in symbol names, you can also 
write *-*, whereby all project symbols are selected — except wire number symbols 
and signals (when these do not contain a "-" in their symbol names).

Jump to a symbol from the Select name list

When you click on the different electrical symbols in the Select name box, you 
automatically jump to where the selected symbols are placed in the project — hav-
ing the cross hairs pointing out the symbol.

You can also activate the function by right-clicking on a symbol, and then choose 
Select Name.
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Changing the symbol reference designations using Select name

When for instance you wish to change reference designations, you can do the fol-
lowing:

 1) Activate the Symbols button, right-click on the page and choose Select 
Name.

 2) In the dialog box Select Name: Write for instance *+A1* (see “Searching 
after more components using Wildcards” on page 265) and click OK.

 3) In the window Select Name: Remove the symbols from the list, which you do 
not wish to change the reference designations, and click on the Component 
data button in the toolbar for symbols.

 4) In the dialog box Component data: Click on the tab Ref. design. and click 
on Select.

 5) In the dialog box Reference designations: Select the new reference desig-
nation — for instance +A2 —, and click OK.

 6) In the dialog box Component data: Click OK.

 7) In the window Select name the new reference designations are now dis-
played. Click the Close button in the upper right-hand corner to close the 
window.

Renumbering pinnumbers for a terminal row using Select name

Do you wish to renumber pinnumbers for a terminal row, so that the pinnumbers 
increase from the start to the end of the project, do the following:

 1) Click on the Symbols button, right-click on the page and choose Select 
Name.
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 2) In the dialog box Select Name: Click on the Used button, select the terminal 
row (for instance =G1+A2-X3) and click OK — hereby all symbols for 
=G1+A2-X3 are selected in the project:

 3) In the Select name window: Click on the 
column header Position so that the dis-
played arrow in the field points upwards 
— hereby the symbols are sorted 
according to the order they are placed 
on the pages.

 4) Click on the column header Page so that the dis-
played arrow in the field points upwards — 
hereby the symbols are sorted in page order, and 
according to the order they are placed on the pro-
ject pages.

 5) Click on the Component data button in the toolbar for symbols.

 6) In the dialog box Component data: Assign names to the pin numbers — 
write for instance -X3:1, press down <Ctrl> and click on +, and click OK. The 
pinnumbers are hereby incremented according to the order in which they are 
placed in the list (and hereby in the order in which they are placed in the pro-
ject).

Please note that existing holes in the numbering disappears at the same time.

Click here

Click here
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Changing component data for the selected symbols

Changing component data from the Select name dialog box is done like this:

 1) Select the symbols in the Select name dialog box.

 2) Click on the Object data button — on the top of the screen —, to change 
article data for all of the selected symbols at the same time.

 3) In the Component data dialog box: Click for instance on Database and 
select a new component in the database.

SELECT COMPONENT

If you right-click on a symbol and choose Select Component, you select to all 
symbols having the same component name and the same article number as the 
selected symbol.

This is an option because a component can consist of several parts, each having 
their own article number.

— See “Finding symbols based on the Component Name” on page 264 also.

PLACE AVAILABLE SYMBOLS

If you want to place all symbols which have not been placed for a component, you 
choose Functions => Place available Symbols. You then enter this dialog box, 
where you click on Load selected and type in the component name.

Click OK, and the cross hairs changes appearance to a pencil. Click where you 
want the remaining symbols to be placed.

The symbols are now placed on top of each other.

In order to separate the symbols, drag a window around them, right-click within the 
selected area, and use the Space function — as described in “The Space function” 
on page 67.

If you choose Load all in the dialog box, all unused symbols for all components in 
the project will be placed.

If you choose Load selected and for instance write -K*, all symbols starting with -
K are placed. — Read more about this in “Wildcards/jokers” on page 605.
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UPDATE FROM DATABASE WHEN CHANGING SYMBOL ARTICLE NO

When the Article no is changed for one of the symbols for the component, it is 
possible to have the component updated from the database, as described in 
“Update from database when changing article number” on page 175.

Therefore, if you have changed Article no for one symbol for the component -K1, 
and subsequently select Change Data for all symbols for the component and 
click OK in the dialog box Component data, all symbols for the component -K1 are 
updated.

Settings for updating individual components via the Database

The settings for how to update via the database, are specified like this:

 1) Choose Settings => Database.

 2) Select Update components when changing Article No., and click on Set-
tings.

 3) You now enter the dialog box Update from Component database:

 4) Here you specify how to update the symbols for individual components when 
changing article number — see a description of the options in “Updating 

symbols from the database” on page 191.

UPDATING COMPONENT, PAGE OR PROJECT

IT IS ALSO POSSIBLE TO UPDATE COMPONENTS WITHOUT CHANGING ARTI-

CLE NUMBER, AND TO UPDATE ALL COMPONENTS ON THE ACTIVE PAGE, OR 

IN THE ENTIRE PROJECT.

— SEE HOW TO DO THIS IN “Updating symbols from the database” on 
page 191.
mation

Page 269



P

Areas
AREAS

In Automation you use the Area command when you want to select all symbols, 
lines, texts and circles from an area in a project.

To work with areas, start by clicking on the Area button, or by pressing the short-
cut key <a>.

SELECTING ALL TYPES OF OBJECTS IN AN AREA

Click on the Area button. Mark up a window. All object types within the window will 
now be selected. If you want to exclude any objects, press the <Ctrl> key and click 
on the objects.

If you also want to select objects outside the area, press down <Ctrl> and click on 
the objects.

Please note that it makes a difference whether you select the objects right to left or 
left to right. Read more about this in “Dragging the marquee rectangle left to right 
— or right to left” on page 56.

— Read more about selecting objects in “Selecting objects” on page 55.

THIS CHAPTER DESCRIBES

— SELECTING OBJECTS IN AREAS .................................................................p. 270

— REFERENCE POINTS WHEN SELECTED AREAS ARE MOVED/COPIED ..............p. 271

— INTELLIGENT COPYING OF AREAS..............................................................p. 271

— ASSIGNING REFERENCE DESIGNATIONS WHEN COPYING AREAS..................p. 274

— MOVING OR DELETING SELECTED AREAS...................................................p. 276

— CUTTING AND PASTING AREAS..................................................................p. 278

— MOVING OR COPYING AREAS TO OTHER PROJECT PAGES...........................p. 276

— MAKING AREAS INVISIBLE..........................................................................p. 276

— ROTATING AREAS .....................................................................................p. 280

— SCALING AREAS .......................................................................................p. 280

— COPYING AREAS TO SYMBOL DEFINITIONS ................................................p. 282

INSERTING SUB DRAWINGS

PLEASE NOTE THAT YOU CAN ALSO INSERT SUB DRAWINGS — “Sub dra-
wings” on page 289.
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REFERENCE POINTS WHEN SELECTED AREAS ARE MOVED/COPIED

When you move a selected area, the lower-left corner of the selected area is 
applied as reference point. However, if you right-click inside the selected area and 
choose Select area reference point with Move, you can subsequently point out 
the reference point for the moved area yourself.

When copying you can also right-click and choose Select area reference point 
with Copy.

This can for instance be handy when working with arrangement drawings — see 
“General arrangement drawings” on page 693.

INTELLIGENT COPYING OF AREAS

When you want to copy an area in 
Automation you click the Area button, and 
use the mouse to select the area you want 
to copy — see “Selecting all types of objects 
in an area” on page 270.

You can then either:

a) Click on the Copy button on the upper 
part of the screen, and then click 
where you wish to place the copy

b) Right-click inside the selected area 
and choose Copy, and click where you 
wish to place the copy

c) Click inside the area, press down 
<Ctrl> and drag the copied area to 
where you wish to place the copy
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When you place the copied area, you enter a dialog box, where you specify the 
directions for renaming the names in the copied area:

The options in this dialog box depends on which types of symbols exists in the cop-
ied area.

NAME PROTECTED COMPONENTS ARE NOT RENAMED

READ MORE ABOUT THIS IN “Name protected” on page 176.

FULFILLING STANDARDS WHEN COPYING AREAS

ESPECIALLY IN CONNECTION WITH NAMING OF TERMINALS, DETAILED RULES APPLIES FOR 

NAMING/NUMBERING. THUS MOTOR TERMINALS, SUPPLY TERMINALS AND INPUT- AND OUT-

PUT TERMINALS ARE NUMBERED ACCORDING TO DIFFERENT PRINCIPLES.

WHEN YOU COPY AN AREA THE PROGRAM FIRST EXAMINES WHETHER THE AREA IS DRAWN 

ACCORDING TO THE RULES IN EN60204-1,14.2.1 CONDUCTOR AND CABLE RUNS. IF THIS 

IS THE CASE, THE PROGRAM THEN ANALYSE WHICH TERMINAL TYPES IT CONTAINS, AND 

RENAMES THESE ACCORDING TO THE DIFFERENT PRINCIPLES.

BECAUSE NO HOLES ARE ALLOWED IN THE NUMBERING, THE PROGRAM ALSO KEEPS 

TRACK OF WHICH NAMES/NUMBERS ARE USED FOR THE DIFFERENT TYPES OF TERMINALS.
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Renaming symbols when copying areas

If you want to renumber the symbols in the area, click on Rename symbols. If you 
want to renumber all symbols in the area, so that they start from a specific number, 
you specify this number in the field Start No. (0=Next avail.).

When you only want to assign the next available symbol name to the symbols, just 
type 0 in this field. If for instance you write 20, the symbols are renumbered starting 
from 20.

When you do not want to renumber the symbols, click on Do NOT rename Sym-
bols.

Please note that you can copy the area as many times as you want. Press <Esc> 
for removing the copied area from the cross hairs.

Page/Current path numbers in symbols in copied areas

If you use page/current path numbers in the names of the copied area, the names 
will adjust to the new page/current path numbers automatically.

Renaming terminals when copying areas

With respect to renumbering terminals, you can here choose between the following 
options:

Renaming wire numbers when copying areas

If the copied area contains wire numbers, you can click on Rename Wire Num-
bers. This assigns the next available wire numbers to the copied area. The wire 
numbers are assigned according to the principle you have used to apply for wire 
numbering — See “Automatic wire numbering” on page 443.

Include mechanical accessories

If you select Include mechanical accessories (Only when renaming), any 
mechanical accessories for the symbols will also be copied. As stated it requires 
that this is done when renaming the symbols. Otherwise it would not be possible to 
keep track of where the accessories belong.

OPTION CONSEQUENCE

DO NOT RENAME 

TERMINALS

NEITHER THE TERMINALS NOR THEIR CONNECTION POINTS ARE 

RENUMBERED.
— IF YOU CHOOSE DO NOT RENAME TERMINALS, AND ALL TERMI-

NALS IN THE COPIED AREA CARRY THE SAME NAME, THE TEXT IS 

CHANGED TO KEEP OR EDIT -X4 (WHEN THE TERMINAL NAME IS

-X4). HERE YOU GET THE OPTION OF RENAMING THE TERMINALS IN 

THE AREA BY TYPING IN A NEW TERMINAL NAME.

RENAME TERMINALS ONLY THE TERMINAL NAMES ARE RENUMBERED, NOT THEIR CONNEC-

TION POINTS.

RENAME TERMINAL 

CONNECTION POINTS

THE NAMES OF THE TERMINAL CONNECTION POINTS ARE RENUM-

BERED, THE TERMINAL NAMES ARE NOT CHANGED. — SEE “Fulfil-
ling standards when copying areas” on page 272.
mation

Page 273



P

Areas
Copying an area to another page

If you want to move the copied area to another project page, see how to do this in 
“Moving or Copying areas to other pages” on page 276.

ASSIGNING REFERENCE DESIGNATIONS WHEN COPYING AREAS

If reference designations are used in the area you copy, the button Ref.des. is dis-
played in the dialog box Rename symbols. This gives you the option to assign 
other — or new — reference designations to the copied area.

When you click the Ref.des. button, you enter this dialog box:

In the columns Designation and Description the current reference designations 
are displayed along with their descriptions.

See symbols using the listed reference designations

When you click on the line for one of the reference designations in the dialog box, a 
Show symbols button is displayed. When you click on this button, all symbols 
using this reference designation in the copied area are displayed.

REF. DESIGNATIONS FOR SUB DRAWINGS, PAGES AND FULL PROJECTS

THIS CHAPTER DESCRIBES HOW TO EDIT REFERENCE DESIGNATIONS WHEN 

COPYING AREAS. YOU HAVE THE EXACT SAME OPTIONS WHEN COPYING FULL 

PAGES AND WHEN INSERTING STANDARD PROJECTS.
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Editing a reference designation

If you wish to edit a reference designation, first click on the line with the reference 
designation. Then click on the down-arrow in the column New designation, and 
you get the option of selecting a new reference designation:

By default (Unchanged) is selected, but you get the option of choosing by all 
applied reference designations in the project. You can also choose (none), to 
delete this reference designation from the symbols in the copied area.

CREATING A NEW REFERENCE DESIGNATION

When you need to create a new reference designation, click the Create new button 
to the right in the dialog box, and you enter the dialog box Reference designa-
tions, from which you can create new reference designations. — See how to do 
this in “Defining project reference designations” on page 381, in particular “Adding 
new reference designations” on page 383.

ASSIGNING TEMPORARY REFERENCE DESIGNATIONS

When you can not decide how to name reference designations in the copied area, 
you can create temporary reference designations, which you can use until you 
have found the correct names. You do this by clicking the Create Temp button in 
the right-hand side in the dialog box. Hereby all reference designations in the dia-
log box are assigned a temporary reference designation:

These temporary reference designations are assigned a ~ sign after the reference 
designation prefix. This temporary reference designation is created from the initial 
reference designation, so that =G1 becomes =~G1. If this temporary value is 
already used in the project, the temporary reference designation with the next 
available name using the same reference letter is applied. If =~G1 is used, =~G2 is 
then used in the project — if not used already. The description remains 
unchanged, with a preceding ~ character.

The temporary reference designations are deleted automatically, when they are no 
longer used in the project.
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MOVING OR DELETING SELECTED AREAS

Moving and deleting of areas is done as described in “Working with selected obje-
cts” on page 58.

If you want to move an area to another page in the project, please see “Moving or 
Copying areas to other pages” on page 276.

MAKING AREAS INVISIBLE

— See “Making areas invisible” on page 70.

MOVING OR COPYING AREAS TO OTHER PAGES

When you have an area in the cross hairs — when moving or when copying — you 
can move the area to another page in the project.

This is done by clicking the page tab for the relevant page, which brings you to the 
new page, where you still carry the area in the cross hairs.

Click to place the area.

When you have a copied area in the cross hairs, you can change project page by 
pressing the <PageUp> and <PageDown> buttons, or by using the Explorer win-
dow.

— See “Copying an area from one project to another” on page 570 also.

The dialog box Rename Symbols can be deactivated after first
placement

When you have copied an area and 
insert it for the first time, you enter 
the dialog box Rename Symbols.

Here you specify how to rename the 
copied symbols.

When you select Do NOT show this 
dialog at next placement, these 
settings are memorized the next 
time the area is placed — and dialog 
box is therefore not displayed.

When placing a new copied area, 
the dialog box appears again.

Renaming settings are memorized for copying Areas

The settings in the dialog box Rename Symbols are memorized by the program.

Component grouping when copying terminals

When copying terminals — individually or in areas and pages — Automation 
keeps the individual component grouping, so that the copied symbols are sepa-
rated from the originals.

— See “Component Grouping” on page 613.

Click here NOT to show

the dialog box again
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Copying an area to another project

When you have the area in the cross hairs, you can copy it to another project by:

a) Clicking on the other project in the Explorer window, and press <Ctrl+v>.

b) Following the description in “Copying an area from one project to another” on 
page 570.
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CUTTING AND PASTING AREAS

You can cut and paste an area in the following way:

 1) Click on the Area button, and select the area by dragging a window over it 
with the mouse.

 2) Click on the Cut button, or right-click inside the area and choose Cut.

 3) The area is deleted: Shift to another page — if necessary — and click the 
Paste button. You now get the area in the cross hairs.

 4) Click where you wish to place the area, and you are asked how/whether to 
rename the symbols in the area, as described in “Intelligent copying of areas” 
on page 271. Select the appropriate options, and click OK. — See the figure 
below.

Select the area and

choose Cut (or Copy)

The area is deleted and the

connected lines are parked
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 5) The area is now placed at its new position, with updated symbol names.

Lines are cut along the edges of areas when copying

When cutting a connected area, Automation cuts the lines connected to the area, 
along the edges of the selected area. Where the area is cut out, the connecting 
lines are parked.

When you place the area, the lines in the area are connected to other lines, if you 
place them on these. Otherwise, the lines are parked.

Only lines are cut. Symbols, texts and circles can not be cut in two this way.

USING THE CUT FUNCTION FOR OTHER COMMANDS

THE CUT FUNCTION CAN ALSO BE USED WHEN WORKING WITH SYMBOLS, 
TEXTS, LINES AND CIRCLES.

Parked connection point

Connected to

existing line

Click to place the area, and rename the symbols
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ROTATING AREAS

You have also got the option to rotate an entire 
area. All kinds of objects in the area — sym-
bols, texts, lines and circles/arcs — will be 
rotated.

First click the Area button, and then select the 
area you want to rotate by dragging a window 
around it.

Click inside the area, keep the mouse button pressed down 
and move the mouse. Press <spacebar>. Hereby the area 
is rotated around the point the mouse is pointing at.

Every time you press <spacebar> the area is rotated 90 
degrees counter-clockwise.

When you have selected the area, you can also click the 
Move button, click in the angle field in the command toolbar, 
and type in the angle in which the area is to be rotated.

SCALING AREAS

You can use scaling when you make drawings as well as when you create/edit 
symbols (see “Creating Symbols” on page 761).

To scale an area do the following:

 1) Click on the Area button, and mark up the area you want to scale

 2) Choose Edit => Scale

 3) Type in a scaling factor. — If 
for instance you want the 
area in half size, you type in 
0,5. In double size, you type 
in 2

 4) Click OK

The area have now been scaled. If you are editing a symbol, this can require adap-
tation of texts, and moving of the reference point, because they are now placed in 

another distance to the scaled objects.

CALCULATE SCALE

IF YOU CLICK THE CALCULATE SCALE BUTTON IN THE DIALOG BOX ENTER 

SCALING FACTOR, YOU ARE ASKED TO POINT OUT TWO POINTS ON THE 

DRAWING, AND ARE SUBSEQUENTLY ASKED TO TYPE IN THE PHYSICAL DIS-

TANCE BETWEEN THESE POINTS. THE PROGRAM THEN CALCULATES THE 

SCALING FACTOR AUTOMATICALLY. PLEASE REMEMBER TO ENTER A UNIT OF 

MEASUREMENT WHEN SPECIFYING THE PHYSICAL DISTANCE BETWEEN THE 

POINTS.
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— See for instance how to scale a company logo, to make it fit a drawing header in 
“Placing a Company Logo on a drawing header” on page 817.

Scaling texts in areas

When you have selected an area and choose Edit => Scale, it is possible to spec-
ify whether to scale the free texts in the area. This is done by choosing Scale free 
texts in the dialog box:

Scaling everything on a page

If you want to scale everything on the entire page, you activate the Area button, 
choose Edit => Select all => All on page, and choose Edit => Scale as above.

Read more about selections in areas in “Selecting objects” on page 55.

Specifying the scale of the page

You can also specify the scale of the entire page. — Read more about this in “Set-
ting the scale of the page” on page 533.
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COPYING AREAS INTO EDIT SYMBOL MODE

To copy an area from a project drawing into a symbol, 
do the following:

 1) Click the Area button, and select the area you 
wish to copy.

 2) Right-click, and choose Copy.

 3) Click on the Symbols button, and then on the 
Symbol menu button.

 4) In the Symbol menu: Click on the Create new 
Symbol button.

 5) In the Edit symbol mode: Choose Edit => 
Paste.

 6) You now get the area in the cross hairs: Click to 
place the area in the symbol definition.

 7) Press <Esc> to remove the area from the cross 
hairs.

The copied area is now inserted in the Symbol editor.

You can now place the connection points for the new 
symbol, edit the symbol e.t.c. as described in “Crea-
ting Symbols” on page 761.

COPYING AREAS BETWEEN PROJECTS

ALL SYMBOLS IN THE INSERTED AREA ARE 

AUTOMATICALLY CONVERTED TO LINES WHEN 

THE AREA IS INSERTED IN THE SYMBOL DEFI-

NITION.

THE COPIED AREA CAN ALSO BE INSERTED 

DIRECTLY INTO ANOTHER Automation PRO-

JECT, BY JUMPING TO THE OTHER PROJECT, 
AND CHOOSING EDIT => PASTE.

Copying an area from

a diagram to a

symbol definition
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OBJECT GROUPS

In Automation you can group drawing objects (symbols, lines, circles and texts) 
and images, which are placed on the same project page, in so-called object 
groups. It then becomes easier to work with them subsequently, and you can copy, 
move, delete or replace a group of objects in a single operation.

Please note that object groups are created on page level. — Read more about this 
in “Object groups and sub drawings” on page 287.

CREATING OBJECT GROUPS

To create an object group on a project page, do this:

 1) Select the project page where you wish to create an object group.

 2) Activate the Area button and use the mouse to select an area on the page.

 3) Right-click inside the selected area and choose Object groups => Edit 
object group.

 4) In the dialog box Object groups: Click Create.

 5) In the dialog box Create Object group: Type in a name for the object group 
and click OK.

You have now created an object group. When you then right-click on the page and 
choose Object groups => Show object groups, you can see that it appears in the 
list of object groups on the page.

— If you wish to remove/deselect objects from the created object group, please 
see “Removing objects from an object group” on page 286.

THIS CHAPTER DESCRIBES

— CREATING OBJECT GROUPS......................................................................p. 283

— EDITING OBJECT GROUPS .........................................................................p. 284

— ADDING AN AREA TO A CREATED OBJECT GROUP .......................................p. 286

— INSERTING AN OBJECT GROUP ON ANOTHER PROJECT PAGE ......................p. 286

— OBJECT GROUPS AND RIGHT-CLICKING......................................................p. 287

— OBJECT GROUPS AND SUB DRAWINGS.......................................................p. 287
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— If you wish to add objects to the created object group, please see “Adding an 
area to a created object group” on page 286.

EDITING OBJECT GROUPS

To edit an object group, do this:

 1) Select the project page where the object group is created.

 2) Right-click on the project page and choose Object groups => Show object 
groups.

You now enter the dialog box Object groups:

When you select an object group here, it is also selected in the project and is still 
selected in the project when you close the dialog box. This is also the case if you 
select a number of objects in an object group.

You can subsequently continue working with the selected objects in the project.

In the dialog box Object groups you also have the following options:

Renaming an object group

In the dialog box Object groups you rename an object group like this:

 1) Click on the name of the object group in the upper part of the dialog box.

 2) Click Rename in the right-hand side of the dialog box.

OBJECT GROUP NAME IN LISTS

WHEN A COMPONENT IS PART OF AN OBJECT GROUP, YOU CAN HAVE THE 

NAME OF THE OBJECT GROUP DISPLAYED IN PARTS AND COMPONENTS LISTS 

BY INSERTING THE DATAFIELD OBJECT GROUP NAME. — SEE “Parts/com-
ponents list datafields” on page 936.

Select an
object group

Click and see
the object in
the project
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 3) In the dialog box Rename object group: Type in the new name and click 
OK.

Ungrouping an object group

In the dialog box Object groups you ungroup an object group like this:

 1) Click on the name of the object group in the upper part of the dialog box.

 2) Click Ungroup in the right-hand side of the dialog box, and answer Yes to 
ungroup the object group.

The object group is now ungrouped. The placed symbols, lines and more, which 
were part of the object group on the project page, are still placed on the project 
page. They are just no longer part of an object group.

Replacing an object group

When an object group contains insertion points — for instance because it was orig-
inally placed as a sub drawing — it is possible to replace the object group.

— Get additional information in “Object groups and sub drawings” on page 287 
and “The function of the insertion points” on page 312.

This is how you replace an object group containing insertion points:

 1) In the dialog box Object groups: Click on the name of the object group in 
the upper part of the dialog box.

 2) Click on Replace (dimmed if the selected object group has no insertion 
points) in the right-hand side of the dialog box, and the dialog box Replace 
object group is displayed:

 3) In the dialog box Replace object group: Choose the sub drawing that you 
wish to replace the object group with.

 4) Select one of the following three options:
Replace current group: Only the selected object group is replaced.
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Replace all on page: All object groups of the same name on the project 
page is replaced.
Replace all in project: All object groups with the same name in the project 
are replaced.

 5) Click Replace.

 6) In the dialog box Rename symbols: Specify how to rename symbols and 
terminals in the selected sub drawing, choose model if possible and click 
OK. — Read more about the options in this dialog box in “Intelligent copying 
of areas” on page 271.

The object group is now replaced with the selected sub drawing.

Removing objects from an object group

In the dialog box Object groups you remove objects from an object group like this:

 1) Click on the name of the object group in the upper part of the dialog box. The 
objects in the selected object group are now displayed in the lower part of the 
dialog box.

 2) In the lower part of the dialog box: Click on the object that you wish to 
remove from the object group, and click Remove in the right-hand side of the 
dialog box. (Multiple objects can be selected at the same time using <Ctrl> or 
<Shift> following normal Windows guidelines).

 3) Answer Yes to confirm removing objects from the group.

The objects are now no longer part of the object group. They are still placed on the 
project page, they are just no longer part of an object group.

ADDING AN AREA TO A CREATED OBJECT GROUP

This is how you add an area to a created object group:

 1) Select the project page where the object group is placed.

 2) Activate the Area button and use the mouse to select an area on the page.

 3) Right-click inside the selected area, choose Object groups => Add to 
object group and then select the name of the object group, that you wish to 
add the area to.

The area is now added to the object group.

You can also right-click on an object group — e.g. a symbol — and choose Object 
groups => Add to object group and then select the name of the object group, 
that you wish to add the area to.

INSERTING AN OBJECT GROUP ON ANOTHER PAGE IN THE PROJECT

This is how you copy an object group placed on a project page, and insert it on 
another page in the project:

 1) Select the project page where the object group is placed.
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 2) Activate Symbols, right-click on a symbol in the object group and choose 
Object group => Select object group.

 3) Click the Copy button — or right-click on the selected object group and 
choose Copy. You now have the object group in the cross hairs.

 4) Find the relevant project page and click to place the object group on the 
page.

 5) Fill out the dialog box Rename symbol and click OK.

 6) Press <Esc> in order not to place the object group again.

The object group is now placed.

OBJECT GROUPS AND RIGHT-CLICKING

When you right-click on a drawing object in an object group — for instance a sym-
bol — and choose Object group, you get the following options:

• Remove from object group: The object is removed from the object group.

• Select symbols in the object group: All symbols in the object group are 
selected.

• Select object group: The object group is selected.

• Edit object group: You enter the dialog box Object groups, where the actual 
object group is selected.

OBJECT GROUPS AND SUB DRAWINGS

Please note that object groups are created at page level. In the dialog box Object 
groups you therefore only see the object groups, which are created on the page 
that you are presently working on.

Sub drawings are created at program level, and are accessible in any project you 
are working on.

Object groups across project pages

Even though object groups are only specified for individual project pages, you do 
have some options to use them across project pages:

• Copy object groups from one project page to another
—see “Inserting an object group on another page in the project” on page 286.

• Replace all object groups with the same name in the project with a sub drawing
— see “Replacing an object group” on page 285.

DOES NOT BECOME AN OBJECT GROUP

PLEASE NOTE THAT THE COPIED OBJECT GROUP DOES NOT BECOME AN 

OBJECT GROUP AUTOMATICALLY ON THE NEW PAGE.
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Sub drawings are converted to object groups

When a sub drawing is inserted in a project, it is automatically created as an object 
group. This means that the inserted sub drawing can then use all of the options, 
that are available for working with object groups.

The created object group automatically gets the name of the sub drawing.

— Read more about sub drawings in “Sub drawings” on page 289.
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SUB DRAWINGS

In Automation it is possible to save parts of diagrams as sub drawings, which you 
can then drag directly into project pages in other projects. This is in Automation 
called Drag’n Draw.
— Hereby you can also drag project pages or full projects into the active project.

All of the symbols in the sub drawings can have individual article data attached, 
and you can — as a general setting — specify the settings for how to rename the 
symbols, when the sub drawings are placed in projects.

Furthermore you can create different sets of model values for each individual sub 
drawing, so that you can choose between placing e.g. a 1 kW or a 15 kW motor 
starter circuit when placing the sub drawings.

You can also apply the sub drawings in connection with automatic project genera-
tion, as described in the Project generator manual.

THIS CHAPTER DESCRIBES

— THE SUB DRAWINGS TAB IN THE EXPLORER WINDOW ................................p. 290

— ON INSERTING SUB DRAWINGS..................................................................p. 291

— MANUAL PLACING OF SUB DRAWINGS ........................................................p. 292

— PLACING SUB DRAWINGS BY DRAG’N DRAW ..............................................p. 297

— DRAG’N DRAW SETUP ..............................................................................p. 298

— CREATING SUB DRAWINGS FOR MANUAL PLACING......................................p. 300

— EDITING SUB DRAWINGS ...........................................................................p. 301

— CREATING SUB DRAWINGS BY COPYING FROM PROJECTS ...........................p. 301

— REPLACING SUB DRAWINGS ......................................................................p. 303

— ON PAGES AND SUB DRAWINGS FOR DRAG’N DRAW ..................................p. 304

— CREATING PROJECT PAGES FOR AUTOMATIC PLACING OF SUB DRAWINGS ..p. 305

— PREPARING SUB DRAWINGS FOR DRAG’N DRAW / AUTOMATIC PLACING .....p. 310

— THE FUNCTION OF THE INSERTION POINTS.................................................p. 312

— INSERTING VARIABLES IN SUB DRAWINGS, PAGES AND PROJECTS..............p. 314

— CREATING MODEL DATA FOR SUB DRAWINGS ............................................p. 317

— INVISIBLE AREAS AND SUB DRAWINGS........................................................p. 320

— SUB DRAWINGS WITH INTELLIGENT LINE CONNECTION ................................p. 320

SUB DRAWINGS IN NETWORKS

WHEN YOU ARE WORKING IN A NETWORK, IT COULD BE A GOOD IDEA TO 

PRODUCE A SET OF STANDARD SUB DRAWINGS, AND PLACE THESE IN A 

FOLDER, WHICH EVERYBODY HAS ACCESS TO IN THE NETWORK.
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THE EXPLORER WINDOW: THE SUBDRAWINGS TAB

In the Explorer window in the left-
hand side of the screen, you find the 
tab SubDrawings.

From here you can fetch the sub 
drawings and projects/project pages, 
which you choose to drag into the 
active project.

If the Explorer window is not dis-
played on the screen, please read 
“General settings for the Explorer 
window” on page 335.

— Read more about the Explorer 
window in “The Explorer window: 
The Projects tab” on page 335.

Specifying what to display on the SubDrawings tab

To select — and lock — which folder to display the 
contents of on the SubDrawings tab, you can 
right-click on the folder in the tab.

You can then choose between:

Show from here: The SubDrawings tab displays 
the contents of the selected folder.

One level up: The SubDrawings tab displays the 
contents of the folder one level above the selected 
folder.

Show all: The SubDrawings tab displays 
everything you have access to from your PC.

Other options in the right-click menu

Beyond this, you can choose between:

Place: Hereby you get the selected sub drawing in 
the cross hairs, and can place it in the active pro-
ject, as described in “Manual placing of sub dra-
wings” on page 292.

Insert: This places the sub drawing on the dia-
gram page. Is only possible on pages containing 
insertion points.

Edit: Hereby the selected sub drawing is opened 
in the Edit sub drawing mode, and you can edit 
the sub drawing, as described in “Editing sub dra-
wings” on page 301.

New: Hereby the program enters the Edit sub 
drawing mode, from which you can create a new sub drawing, as described in 
“Creating sub drawings by Copying from projects” on page 301.

(Click on Folder)

(Click on Sub drawing)
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Delete: Hereby the selected sub drawing is deleted. It is not possible to delete fold-
ers from the SubDrawings tab.

Rename: Hereby you can rename the selected sub drawing.

Drag’n Draw setup: — See “Drag’n Draw setup” on page 298.

ON INSERTING/PLACING SUB DRAWINGS

When inserting sub drawings in Automation, this can be done in two different 
ways:

 1) Manually: When you drag the sub drawing from the SubDrawings tab into 
the project page, you get the sub drawing in the cross hairs, and place it 
manually on the project page. — See “Manual placing of sub drawings” on 
page 292.

 2) By Drag’n Draw / Automatic placing of sub drawings: When you drag the sub 
drawing from the SubDrawings tab, and release it as soon as it is over the 
project page, the sub drawing is connected automatically e.g. to the drawn 
potentials on the pages. — See “Placing sub drawings with drag’n draw” on 
page 297.

For both methods applies: Control of Article data, Texts and
Model data

When applying both methods, the symbols in the sub drawings can contain article 
data — e.g. from the database. Furthermore, all texts can be controlled via varia-
bles, and you can select between different sets of model data for the sub drawings, 
if variables and/or sets of model data, that have been created for sub drawings.

For manual placing of sub drawings

All sub drawings can be placed manually.

You can start by creating sub drawings for manual placing, and later prepare them 
for applying drag’n draw.

For Drag’n Draw

To get the full benefit of applying drag’n draw, you need to make some extra prepa-
rations, as described in “On Pages and Sub drawings for Drag’n Draw” on 
page 304.

Having made these preparations, you achieve a faster workflow — and you have 
made practically speaking all of the necessary preparations for applying sub draw-
ings for automatic project generation, as described in the Project generator man-
ual.

SUB DRAWINGS ARE CONVERTED TO OBJECT GROUPS

WHEN YOU INSERT A SUB DRAWING IN A PROJECT, IT IS AUTOMATICALLY 

CONVERTED TO AN OBJECT GROUP. — READ MORE ABOUT THIS IN “Object 
groups and sub drawings” on page 287, PARTICULARLY “Sub drawings 
are converted to object groups” on page 288.
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MANUAL PLACING OF SUB DRAWINGS

To insert a sub drawing manually — see “On inserting/placing sub drawings” on 
page 291 — on the active project page, do the following:

 1) Click on the SubDrawings tab in the Explorer window.
If the Explorer window is not visible, press <Ctrl+F12> or choose Settings 
=> Pointer/Screen and select Explorer window).

 2) Click on the name of the desired sub drawing, and drag it into the project 
page.

 3) You now get the sub drawing in the cross hairs, and click where you wish to 
place the sub drawing in the project.

If the sub drawing contains Model data

 4) If different models have been created for the selected sub drawing, you enter 
the dialog box Rename symbols, in which you select which model you want 
to apply. — Read more about this in “Inserting sub drawings: With model 
data” on page 293.

The sub drawing is now inserted: Symbols are renamed and Article num-
bers added

 5) The sub drawing is now placed in the project page, and:
— The symbols have been renumbered automatically (see “Drag’n Draw 

1) Click here 2) Click on the sub drawing, and

drag it into the project page

3) Click where you

want to place

the sub drawing

4-6) The symbols in the sub drawing are renumbered automatically
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setup” on page 298)
— The symbols in the placed sub drawing contains the same article num-
bers, texts and variables as the sub drawing in the SubDrawings tab.

— Please also see “Creating Project pages for aut. placing of sub drawings” on 
page 305 and see how to apply sub drawings for automatic project generation in 
the Project generator manual.

Sub drawings displayed in window

When you click on a sub drawing in the 
SubDrawings tab, the sub drawing is 
displayed in a small window, so that 
you can see which sub drawing you are 
selecting.

To select the sub drawing, double click 
on the name of the sub drawing — or 
click and drag in the same operation. 
Hereby you get the sub drawing in the 
cross hairs, and you can place it in the 
project.

Inserting sub drawings: With model data

When you insert a sub drawing — see 
“Manual placing of sub drawings” on 
page 292 —, where the sub drawing 
have different sets of model data 
attached, you can select which model 
to apply at the bottom of the dialog box 
Rename symbols:

When you have selected which model 
data to assign to the inserted sub 
drawing, you can click the Variables button in the upper-right corner of the dialog 
box, and the values of variables for the model are displayed:

THE SUB DRAWING IS NOW INSERTED

THE SUB DRAWING IS NOW INSERTED IN THE PROJECT, AND YOU CAN 

CONTINUE WORKING WITH THE SYMBOLS, LINES ETC. IN THE SUB 

DRAWING, JUST AS IF YOU HAD DRAWN IT FROM SCRATCH.
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Here you can edit data — if necessary — by double clicking on a field and then 
editing the text. When you have placed the sub drawing in the project, you can edit 
the texts in via this dialog box, as described in “Editing variables for inserted sub 
drawings” on page 294.

Click OK, and click OK in the dialog box Rename symbols.

Variable markers (/@..) in sub drawings are removed when sub drawings are 
placed in projects.

— See also “Drag’n Draw setup” on page 298, “Drag’n Draw settings: For model 
data” on page 298 in particular.

— See also how to create models for a sub drawing in “Creating Model data for sub 
drawings” on page 317.

Editing variables for inserted sub drawings

To edit the text fields, which had variables on an inserted sub drawing, do this:

 1) Select the project page on which the sub drawing is inserted.

 2) Choose Edit => Variables.

 3) You now enter the dialog box Variables.

Here you see a survey of all variables on the page. If more than one sub 
drawing is inserted on the page, these are all displayed in the dialog box. 
When in doubt about which datafield is listed in the dialog box, click on it in 
the dialog box, and the cross hairs points it out on the diagram page.

THE PURPOSE OF VARIABLES

VARIABLES MAKES IT POSSIBLE TO EDIT SOME OF THE DATA, THAT CAN BE 

INCLUDED IN A SUB DRAWING.

— READ MORE ABOUT THIS IN “Inserting variables in Sub drawings, 
Pages and Projects” on page 314, PARTICULARLY “Inserting variable 
markers on a sub drawing (or on a drawing template)” on page 314.

Click on the variable

points out its position

on the page

field, and the cross hairs
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 4) Double-click on one of the fields in the dialog box, and edit the text. Continue 
like this until all relevant texts are edited.

 5) Click OK.

You can also edit the texts in the sub drawing exactly as you would edit any other 
text in Automation.

Sub drawings: Changing the selected model

When you have placed a sub drawing containing model data, you can subse-
quently change the selected model:

 1) Right-click on the page, and select Variables:

 2) In the dialog box Variables: Right-click on the column header for the section 
(sub drawing), for which you wish to change model.

 3) You now see all of the models for the sub drawing. Click on the desired 
model:

2) Right-click here 3) Select new model
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The model data for the sub drawing are now changed.

It is possible to change model data for any sub drawing in the project. You can also 
do this for sub drawings, that has been placed in the project by automatic project 
generation.

Scope for changing models

All other symbols in the project, that are a part of the applied symbols in the sub 
drawing, will be updated according to the new model automatically.

This meaning, that if the sub drawing e.g. contains a symbol with the name -K3, all 
project symbols for the component -K3 will be updated with the new data.

When the newly selected model implicates that some symbols change state, this 
will also be the case for the implicated symbols outside the sub drawing.
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PLACING SUB DRAWINGS WITH DRAG’N DRAW

To place sub drawings by applying the drag’n draw technique, both the sub drawing 
and the pages they are placed in, must be prepared for drag’n draw / automatic 
placing. — See “On Pages and Sub drawings for Drag’n Draw” on page 304.

When the project pages and the sub drawings are prepared, you can place the sub 
drawings like this:

 1) Click on the SubDrawings tab in the Explorer window.
(If the Explorer window is not visible, then choose Settings => Pointer/
Screen and select Explorer window).

 2) Click on the name of the desired sub drawing, drag it into the project page, 
and release it as soon as it is over the project page — or just press the <Ctrl> 
key and click on the sub drawing. Hereby the sub drawing is placed automat-
ically on the project page, and connects automatically to e.g. the electrical 
potentials on the page:

If variables are placed in the sub drawing, or if you can select different sets of 
model data for the sub drawing, you now get the option of specifying which data to 
insert in the sub drawing. You can read more about this by continuing the explana-
tion under “If the sub drawing contains Model data” on page 292.

1) Click here 2) Click on the sub drawing, drag it over the

project page, and release the mouse button

The sub drawing is placed automatically, and connected to the

existing e.g. electrical potentials. The symbols in the sub drawing

are renamed automatically.
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DRAG’N DRAW SETUP

When sub drawings are placed automatically in project pages, Automation can 
rename symbol names in these sub drawings automatically.

To specify how to do this, right-click somewhere inside the SubDrawings tab, and 
select Drag’n Draw setup:

Here you specify whether to rename symbols in the sub drawings you insert, and 
how to rename these symbols. — Read more about this in “Intelligent copying of 
areas” on page 271.

Beyond this, you have the following options:

Keep page numbers

Because you can also drag full pages / projects into the active project, you can 
select Keep page numbers to specify that you wish to keep the existing page 
numbers, so that these are not changed when you drag new pages into the project. 
This includes both the page numbers in the active project, and the page numbers 
in the project / the project pages, which you drag into the project.

Drag’n Draw settings: For model data

When you select Show dialog if sub drawing contains model data, you always 
enter the dialog box Rename symbols — see “Manual placing of sub drawings” on 
page 292, “Inserting sub drawings: With model data” on page 293 in particular — 
when placing a sub drawing containing model data. From this dialog box you can 
select which model you wish to place.
If the option is not selected, the sub drawing is placed without model data, or with 
the data from the original sub drawing, if the sub drawing contains data values.

Update from database after Model selection

When you select Update from database after Model selection, the sub drawing 
is updated from the database, when you select the model.
If this option is not selected, the symbols in the sub drawing are assigned exactly 
the same data values as the sub drawing.
Automation

age 298



Sub drawings

Auto
When you select Update from database after Model selection, a Setings button 
appears in the dialog box: Click on it, and you enter the dialog box Update from 
Component database.

Here you specify how to perform the update from the database. These options are 
described in “Updating symbols from the database” on page 191.
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CREATING SUB DRAWINGS FOR MANUAL PLACING

A sub drawing can be any project, containing one single 
diagram page. — See also “Creating sub drawings by 
Copying from projects” on page 301.

For instance you can create a sub drawing like this:

Enter the Edit Sub drawing mode

 1) In the SubDrawings tab in the Explorer window:
Right-click in the folder that you wish to place the 
sub drawing in, and choose New:

 2) Automation now changes to the Edit sub draw-
ing mode, which you can see because the Page type 
field at the bottom of the left toolbar blinks green. You 
can now create a new sub drawing.

 3) Draw a sub drawing — for instance as displayed in 
the figure above — and attach article data from the 
database to the symbols, if necessary. It has no 
importance where on the page you draw the sub 
drawing.
— You can also insert a copied area from an existing 
project, as described in “Creating sub drawings by 
Copying from projects” on page 301.

 4) Continue as described in “Inserting e.g. variable mar-
kers and/or model data” on page 302.

LAYERS ARE FLATTENED TO ONE LAYER

WHEN YOU PLACE A SUB DRAWING IN A PROJECT, THE LAYERS IN THE SUB 

DRAWING ARE FLATTENED, SO THAT ALL INFORMATION IN THE SUB DRAWING 

IS PLACED IN ONE LAYER ONLY. THE LAYER STRUCTURE IN THE SUB DRAW-

ING IS THEREFORE LOST, WHEN THE SUB DRAWING IS PLACED IN THE PRO-

JECT.

DO NOT INCLUDE LOGOS IN SUB DRAWINGS.

Blinks green in the

Edit sub drawing

mode
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EDITING SUB DRAWINGS

To edit a sub drawing, right-click on the sub drawing in the SubDrawings tab in the 
Explorer window, and choose Edit. Hereby you can edit the sub drawing as 
described in “Creating sub drawings for manual placing” on page 300.

CREATING SUB DRAWINGS BY COPYING FROM PROJECTS

If you wish to create a sub drawing based on existing 
material from a project, you can do like this:

Copying the desired area

 1) Click the Area button.

 2) Select the area you wish to copy, right-click in 
the area, and choose Copy — see the figure to 
the right.

Entering the Edit sub drawing mode

 3) On the SubDrawings tab in the Explorer win-
dow: Right-click on the folder you wish to place 
the sub drawing in, and select New:

 4) Automation now change to the Edit sub 
drawing mode, which you can see because the 
Page type field at the bottom of the left toolbar 
blinks green. You can now create a new sub 
drawing.

SAVE COPIED AREAS USING SAVE AS

IN STEAD OF CHOOSING NEW, YOU CAN CHOOSE SAVE AS. YOU 

ENTER THE DIALOG BOX SAVE AS, WHERE YOU TYPE IN THE NAME OF 

THE SUB DRAWING AND CLICK SAVE. THE SUB DRAWING IS THEN CRE-

ATED, AND IS DISPLAYED IN THE SELECTED FOLDER IN THE SUB-

DRAWINGS TAB.

TO EDIT THE SUB DRAWING, YOU MUST THEN RIGHT-CLICK ON IT AND 

CHOOSE EDIT.

Copying an area from

a project ...

Blinks green in the

Edit sub drawing

mode
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Inserting the copied area

 5) Right-click on the page and choose Paste.

 6) You are now asked whether to rename the sym-
bols in the area — and get the option of chang-
ing reference designations (if any) in the area:

— See which options you have in “Intelligent 
copying of areas” on page 271.
Select the desired settings and click OK.

 7) The copied area is now displayed including all 
component data and reference designations for 
the symbols in the area. — See the figure to the 
right. Press <Esc> to remove the copied area 
from the cross hairs.

Adapting the sub drawing

 8) Now adapt the copied area, so that it becomes exactly the sub drawing you 
want.

Inserting e.g. variable markers and/or model data

 9) If you want to, you can now place variable markers in the sub drawing, as 
described in “Inserting variables in Sub drawings, Pages and Projects” on 
page 314, and you can create different sets of model data for the sub draw-
ing, as described in “Creating Model data for sub drawings” on page 317.

 10) If you wish to use the sub drawing for drag’n draw or in automatic project 
generation, you must also place insertion points in the sub drawing, as 
described in “The function of the insertion points” on page 312. (It might be 
easier to place the insertion points in the project before you copy the area — 
see "Points to consider in Project generation" in the Project generator man-
ual).

Saving the sub drawing

 11) When you have adapted the sub drawing, click on the Save button, and you 
enter the Save as dialog box. Here the same folder is selected as the one 
you clicked on in the SubDrawings tab, when you chose New.
Assign a name to the sub drawing, and click Save.

Inserting a copied area

when creating a new

sub drawing
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 12) Choose File => Close to leave the edit sub drawing mode.

You have now created a new sub drawing from a copied area in a project, and have 
inserted the sub drawing in a folder, which is accessible from the SubDrawings 
tab in the Explorer window.

REPLACING SUB DRAWINGS

See how to replace sub drawings in “Replacing an object group” on page 285.

SUB DRAWINGS FOR DRAG’N DRAW / AUTOMATIC PLACING

IF YOU WISH TO USE THE SUB DRAWING FOR DRAG’N DRAW / AUTOMATIC 

PLACING, YOU MUST ALSO READ “On Pages and Sub drawings for Drag’n 
Draw” on page 304 AND “Preparing Sub drawings for Drag’n Draw / Aut. 
placing” on page 310.
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ON PAGES AND SUB DRAWINGS FOR DRAG’N DRAW

To apply the automatic functions in Automation for drag’n draw / automatic placing 
of sub drawings, you need to create:

 1) The project pages where you place the sub drawings. Here you must specify 
the area in which you can place sub drawings on the page.

 2) The sub drawings which Automation shall be able to place automatically on 
the project pages. Here you must specify how much space the sub drawing 
needs when it is placed in a project.

The project pages are created just like you create sub drawings — see “Preparing 
Sub drawings for Drag’n Draw / Aut. placing” on page 310. Here it is also described 
how to place the so-called insertion points, used for specifying the size of sub 
drawings and for specifying in which area sub drawings can be placed on project 
pages.

On project pages you will — as opposed to sub drawings — also place a drawing 
header.

Variable markers and Models

In project pages you can, just as for sub drawings, insert variable markers for the 
texts in the page / sub drawing, that you wish to specify the contents of, when you 
drag the page or sub drawing into the project.

For sub drawings you can furthermore specify different sets of model data, which 
you can choose between when placing the individual sub drawing.

Example

An example on creating a drawing template can be found in “Creating Project 
pages for aut. placing of sub drawings” on page 305.

+ 4x =

Project page prepared for + 4 sub drawings = Automatic filled out

automatic placing of sub

drawings by drag’n draw

    project page    for drag’n draw
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CREATING PROJECT PAGES FOR AUT. PLACING OF SUB DRAWINGS

When using drag’n draw you can make Automation place sub drawings on project 
pages automatically.

To get full benefit of this powerful tool, you must first create a project page, on 
which you specify within which area the sub drawings can be placed automatically. 
As you will see, you will only have to create this page once.

Page Templates prepared for automatic placing of sub drawings

To see the design of a page template prepared for automatic placing of sub draw-
ings, do this:

 1) Choose File => New or click the New document button, and you enter the 
dialog box New:

 2) Click on the tab Normal pages, click on Template in the right-hand side, 
click on the page PCS-L1-L2-L3-PEN, and click OK.

AUTOMATIC PROJECT GENERATION: CREATING DRAWING TEMPLATES

WHEN YOU WISH TO CREATE A DRAWING TEMPLATE FOR AUTOMATIC GEN-

ERATION OF PROJECTS — SEE "Creating drawing templates for automatic 
project generation" IN THE Project generator MANUAL — YOU MUST 

CHOOSE PROJECT, AND SAVE THE CREATED PROJECT IN THE FOLDER 

WHERE YOU KEEP DRAWING TEMPLATES. — SEE "Settings for the Project 
Generator" IN THE Project generator MANUAL.

2a) Click on the tab Normal pages 2b) Click on Template

2c) Click on PCS-L1-L2-L3-PEN 2d) Click OK

Or: Click

on Project

when crea-

ting drawing

templates

to create/edit a page
template
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 3) Zoom in on the upper left corner of 
the page. Here an insertion point sym-
bol is placed, as you can see in the fig-
ure to the right.

 4) In the other end of the electrical 
potentials, there is placed another 
insertion point symbol. These two 
symbols specifies the area in which 
sub drawings can be placed automati-
cally. It is important that these two 
symbols are aligned.

 5) Choose File => Close to exit the page 

template.

Placing insertion points on project pages for automatic placing of sub
drawings

If you are creating your own page template, that you wish to prepare for automatic 
placing of sub drawings, you can place the insertion point symbols like this:

 1) Start by opening an existing page template, as described in “Page Templates 
prepared for automatic placing of sub drawings” on page 305. You might 
choose to click on BlankPage, to start on an entirely new page.

 2) Insert a drawing header, electrical potentials and whatever you wish to place 
in the page template.

 3) Click on the Symbols button and then on the Symbol menu button.

 4) In the Symbol menu: Choose the Alias or the folder MISC, select the symbol 
INSPOINT.SYM, and click OK. — Read more about the Symbol menu in 
“Fetching symbols using the Symbol menu” on page 159.

 5) Place the insertion point symbol — for instance at the right-
hand side of L1.

 6) Insert another insertion point symbol — for instance at the 
left-hand side of L1 — and press <Esc> to remove the sym-
bol from the cross hairs. It is important that the two insertion 
point symbols are aligned.

 7) Click on the Save button.

THE INSERTION POINTS SPECIFIES WHERE THE SUB DRAWINGS ARE 

INSERTED

THE TWO INSERTION POINT SYMBOLS SPECIFIES THE AREA IN WHICH 

Automation CAN NOW PLACE THE SUB DRAWINGS AUTOMATICALLY.

— READ MORE ABOUT INSERTION POINT SYMBOLS IN “The function 
of the insertion points” on page 312.

— SEE "Points to consider in Project generation" IN THE Project 
generator MANUAL ALSO.

Insertion point symbol
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 8) In the dialog box Save: Write for instance the name Example.std, select the 
folder Pcselcad\Standard\Template\Normal, and click Save.
(If you have created a drawing template for automatic generation of projects, 
you must remember to save it in the folder where you save drawing tem-
plates. — See "Settings for the Project Generator" in the Project generator 
manual).

 9) Choose File => Close to close the page.
You have now created a template page, prepared for automatic placing of 
sub drawings by drag’n draw.
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Placing sub drawings automatically on a project page

This is how you place a subdrawing automatically on a project page using drag’n 
draw:

 1) Insert a new page that is prepared for automatic insertion of sub drawings: 
Choose File => New or click the New document button. In the dialog box 
New, click on the tab Normal pages, and double-click on PCS-L1-L2-L3-
PEN:

 2) When you have clicked OK in the Settings dialog box, you can see the two 
insertion points on L1, as described in “Page Templates prepared for auto-
matic placing of sub drawings” on page 305.

 3) In the Explorer window: Click on the SubDrawings tab, open the folder 
STANDARD/Subdrawing, click on the sub drawing PCSMOTOR3.PRO 
(which have already been prepared for drag’n draw — see “Preparing Sub 
drawings for Drag’n Draw / Aut. placing” on page 310), drag the sub drawing 
into the project page, and release it as soon as you have dragged it out of the 
Explorer window.

 4) You are now asked whether and how to rename the symbols in the sub draw-
ing, and also get the option of choosing a sub drawing model, at the bottom 
of the dialog box. Click OK.

THE FOLLOWING IS BASED ON THAT YOU USE A TEMPLATE PAGE — AS 

DESCRIBED ABOVE —, PREPARED FOR AUTOMATIC PLACING OF SUB DRAW-

INGS BY DRAG’N DRAW.

IF YOU HAVE CREATED A DRAWING TEMPLATE FOR AUTOMATIC GENERATION 

OF PROJECTS, YOU MUST IN STEAD DRAG IN THIS PAGE FROM THE FOLDER 
YOU HAVE SPECIFIED AS DEFAULT FOLDER FOR DRAWING TEMPLATES AND 

SUB DRAWINGS FOR THE CREATED TEMPLATE — SEE "Settings for the Pro-
ject Generator" IN THE Project generator MANUAL.

1a) Click on the Normal Pages tab
1b) Double-click on PCS-L1-L2-L3
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 5) Automation have now placed the sub drawing on the page automatically, 
and have connected the sub drawing to the electrical potentials on the page.

 6) Now drag the sub drawing PCSMOTOR3.PRO into the project page three 
more times. The sub drawing have now been placed four times on the page 
by using drag’n draw:

— If you could only get room to place the sub drawing three times on the 
page, this is because the insertion points on the page are placed too close to 
make room for four sub drawings on the page. For the future use of the page, 
you might therefore consider to make room for exactly four sub drawings on 
the page. — See e.g. "Points to consider in Project generation" in the Project 
generator manual, "Creating sub drawings as Modules" in particular.

Subsequent update of text fields with variables

Though the variable markers are removed when placing the sub drawings, you still 
have the option of editing text fields from the sub drawing, which had variables.
— See “Editing variables for inserted sub drawings” on page 294.

AUTOMATIC RENAMING AND ARTICLE DATA

ALL SYMBOLS, TERMINALS AND CABLES HAVE HEREBY BEEN RENAMED 

AUTOMATICALLY. FURTHERMORE ALL SYMBOLS CONTAIN DATA FROM THE 

DATABASE, BECAUSE THE PLACED SUB DRAWING CONTAINED ARTICLE NUM-

BERS FOR THE SYMBOLS.

— SEE “Drag’n Draw setup” on page 298 TO SEE HOW TO SPECIFY THE 

SETUP FOR RENAMING E.T.C. WHEN APPLYING DRAG’N DRAW.
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PREPARING SUB DRAWINGS FOR DRAG’N DRAW / AUT. PLACING

When a sub drawing has been prepared for automatic placing, Automation can 
automatically place the sub drawing correct, when you drag it into a page which 
has been prepared for this. — See “Placing sub drawings with drag’n draw” on 
page 297.

— See how to prepare project pages for automatic placing of sub drawings by 
drag’n draw in “Creating Project pages for aut. placing of sub drawings” on 
page 305.

 1) Open an existing sub drawing, or draw a new one, as described in “Creating 
sub drawings for manual placing” on page 300, or copy an area from an 
existing project, and create a sub drawing from this area, as described in 
“Creating sub drawings by Copying from projects” on page 301.

 2) Click on the Symbols button, and then on the Symbol menu button.

 3) In the Symbol menu: Choose the Alias or the folder MISC, choose the sym-
bol INSPOINT.SYM, and click OK. — See e.g. the figure under “Placing 
insertion points on project pages for automatic placing of sub drawings” on 
page 306 or read more about the Symbol menu in “Fetching symbols using 
the Symbol menu” on page 159.

 4) Place the two insertion points, so that they mark how much space the sub 
drawing needs horizontally during the automatic placing — see “The function 
of the insertion points” on page 312 (and see "Points to consider in Project 
generation" in the Project generator manual).

 5) If you also wish to control the texts in the sub drawing (e.g. for automatic pro-
ject generation — see the Automation): Insert some so-called variable 
markers, which makes it possible to control the texts of the sub drawing when 
placing the sub drawing (or to control the texts from a project definition file 
during automatic project generation). Read how to do this in “Inserting varia-
bles in Sub drawings, Pages and Projects” on page 314.

SUB DRAWINGS FOR AUTOMATIC GENERATION OF PROJECTS

WHEN YOU WISH TO APPLY A SUB DRAWING FOR AUTOMATIC PROJECT GEN-

ERATION, IT MUST BE PREPARED FOR AUTOMATIC PLACING.

— READ MORE ABOUT THIS IN "Generate and Update projects automati-
cally" IN THE Project generator MANUAL. PLEASE PAY ATTENTION TO THE 

GENERAL CONSIDERATIONS ON CREATING SUB DRAWINGS IN "Points to 
consider in Project generation".

The left

insertion point
The right

insertion point
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 6) If the sub drawing shall contain sets of model data — which you subse-
quently will be able to choose between when placing the sub drawing by 
drag’n draw —, then also create these, as described in “Creating Model data 
for sub drawings” on page 317.

 7) Save the sub drawing in a folder where you place sub drawings. — If the sub 
drawing shall be used for automatic generation of projects, you can for 
instance save it in the folder which is set to Default folder for drawing tem-
plates and sub drawings, as described in "Settings for the Project Genera-
tor" in the Project generator manual.

You have now created a sub drawing, which can be used for drag’n draw / auto-
matic placing, as described in “Placing sub drawings with drag’n draw” on 
page 297. There you can also see a complete workflow for placing sub drawings 
on project pages using drag’n draw.
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THE FUNCTION OF THE INSERTION POINTS

When you only wish to apply a sub drawing for manual placing, you do not need to 
place insertion point symbols on the sub drawing. However, if you need to be able 
to insert the part drawing automatically — by drag’n draw or by automatic project 
generation —, it must have two insertion points. — See “Insertion points and auto-
matic placing of sub drawings” on page 312.

The left insertion point on the part drawing is the point you get in the cross hairs, 
when you place the sub drawing manually. You could therefore choose to insert just 
one single insertion point with just this purpose.

The insertion point symbols of the sub drawings are removed when you place the 
sub drawing on a project page.

The created insertion point symbols are not displayed when printing project pages. 
This is because they are created using the color NP.

Insertion points and automatic placing of sub drawings

When using automatic placing of sub drawings, there exists two sets of insertion 
points:

 1) The insertion points of the sub drawing: They tell the program how much 
space the sub drawing needs when it is placed automatically.

 2) The insertion points of the project page: They tell the program where sub 
drawings can be placed on the page. (The project page can be fetched 
directly from a template page, or it can be a drawing template — see “On 
Pages and Sub drawings for Drag’n Draw” on page 304).

During the automatic placing the sub drawing is placed so that its left insertion 
point is placed on the left insertion point of the project page. The left insertion point 
of the project page is then moved, so that it now is placed on the position of the 
right insertion point of the sub drawing. The insertion points of the sub drawing are 
deleted from the page.

A sub drawing can not be placed automatically if there is not enough room for this 
sub drawing between the insertion points on the project page.

The left insertion point of the project

page before inserting the sub drawing

The left insertion point of the project

page after inserting the sub drawing
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Insertion points and automatic project generation
During automatic project generation — see "Generate and Update projects auto-
matically" in the Project generator manual — the situation mentioned above 
would result in inserting an extra project page, on which the sub drawing would be 
placed.

Placing the insertion point symbols carefully

When applying insertion point symbols, you must be careful to let the insertion 
points for the sub drawings match the electrical lines on the drawing templates, on 
which the sub drawings are going to be placed.

It is important to make sure of the following (observe the figure above):

 1) Place the insertion point symbols on the sub drawing so that they are at the 
same height as the uppermost parked line.

 2) Also place the insertion point symbols on the project page on the uppermost 
of the phases to which the sub drawing is going to be connected.

 3) Adjust the vertical distance between the parked lines on the sub drawing to 
the distance between the phases on the project page.

 4) Make sure to place the insertion points on the sub drawing so that there are 
room enough for the texts, which can be inserted via automatic project gen-
eration.

— Please also read "Points to consider in Project generation" in the Project gene-
rator manual. Here you will find a survey of additional aspects to consider, when 
creating sub drawings.

SUB DRAWINGS CAN ALSO BE PLACED VERTICALLY

ABOVE YOU FIND A DESCRIPTION OF PLACING SUB DRAWINGS FROM THE 

LEFT TO THE RIGHT.
PLEASE NOTE THAT SUB DRAWINGS CAN ALSO BE PLACED VERTICALLY 

FROM THE TOP TO THE BOTTOM.

1

2

3

Sub drawingProject page
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INSERTING VARIABLES IN SUB DRAWINGS, PAGES AND PROJECTS

When a sub drawing contains variables, you can for instance control symbol article 
numbers, symbol datafields e.g. containing motor data, or free texts placed under 
electrical circuits. —See e.g. “Manual placing of sub drawings” on page 292.

To do this you must:

 1) Insert variables in the sub drawing, as described in “Inserting variable mar-
kers on a sub drawing (or on a drawing template)” on page 314.

 2) Create a variable list, as described in “Creating a variable list” on page 316.

When applying sub drawings for automatic project generation, you can control all 
texts and names in the project. — See the Project generator manual.

Inserting variable markers on a sub drawing (or on a drawing
template)

When you wish to create variables, you do this by inserting so-called variable 
markers in the project. All data can be controlled via these variables.

To insert a variable marker, you write /@1 behind the first text in the sub drawing / 
project, that you wish to turn into a variable. Then you write /@2 behind the next, 
then /@3, and so on, until all variables in the sub drawing have been specified.

When you right-click on the page and choose Variables, you can subsequently 
see the created variables and edit them, if you wish to.

— Please also see “Editing variables for inserted sub drawings” on page 294 and 
“Manual placing of sub drawings” on page 292.

CREATE A VARIABLE LIST

WHEN YOU HAVE PLACED THE RELEVANT VARIABLES ON THE PAGE, CHOOSE 

TOOLS => CREATE VARIABLE LIST IN (SUB) DRAWING TO CREATE A VARIA-

BLE LIST FOR THE SUB DRAWING (OR DRAWING TEMPLATE).

The text with the variable @1 is placed

in the first text column in the project

The text with the variable @2 is placed

in the second text column etc.

definition file.
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Variables specifying parts of a project text

A variable can also be inserted so that it is only part of an otherwise constant pro-
ject text. This is specified by placing the variable between the characters "<" and 
">".

When for instance you write -M</@1>, and the variable @1 is assigned the value 
7, this results in the text -M7.

This can for instance be useful if you are using a system where several symbols in 
a sub drawing must always have the same number. If for instance the symbols in 
the sub drawing shall be named -F1, -Q1, -W1 and -M1 one place, and -F2, -Q2,
-W2 and -M2 in the next, this can be controlled using a single variable: -F</@1>,
-Q</@1>, -W</@1> and -M</@1>.

DEFAULT VALUE FOR INSERTED VARIABLES

When an inserted variable has a text between the "<"-character and a "/"-charac-
ter, this is regarded as the default value for the variable.

This can for instance be applied when creating project definition files, so that you 
can make it clear to yourself what to insert at this exact position in the file. If for 
instance you write Control of <MOTOR/@1>, the variable @1 will get the value 
MOTOR in the project definition file.

Sub drawings with model data

If you wish to create different sets of variable values for a sub drawing, so that you 
can choose between different models when placing the sub drawing, please read 
“Creating Model data for sub drawings” on page 317.

Variables for Page title and Page data

On drawing templates — and in ordinary pro-
ject pages — you can also insert variables on 
all Page data datafields, and in the Page 
title.

When you have inserted these variables in 
the pages, and have executed Tools => Cre-
ate variable list, you can choose Edit => 

VARIABLES ON ORDINARY PROJECT PAGES

YOU CAN ALSO INSERT VARIABLES ON ORDINARY PROJECT PAGES.
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Variables. Here the created variables for the page will always be placed in the first 
section:

Variables for Page article data

It is also possible to create variable for Page article data for pages (Name, Type, 
Article no and Function) on drawing templates for automatic project generation.

You enter the dialog box Page article data by right-clicking on the page, and then 
choose Page article data.

Variables on Symbol datafields

If you are using symbols with specially created symbol datafields — see “Extra 
symbol Datafields in symbols” on page 776 —, you can also insert variables on 
these.

Variables in reference designations

You can also insert variables in reference designations for symbols, reference 
frames and pages. Read more about this in “Variables in reference designations” 
on page 963.

Creating a variable list

This applies for sub drawings / drawing templates / project pages:

When you have placed the relevant variables on the page, choose Tools => Cre-
ate variable list in (Sub) drawing. You have now created a variable list.

Click OK.
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CREATING MODEL DATA FOR SUB DRAWINGS

You can use the same sub drawing for representing different models for e.g. a 
motor starter circuit. Hereby you use one single drawing, but attach different article 
data / texts to the symbols in the sub drawing.

The same sub drawing can therefore be used for e.g. a 55 kW and a 250 kW motor 
starter circuit.

To create models for a sub drawing, do this:

 1) Draw the sub drawing, as described in “Creating sub drawings for manual 
placing” on page 300 or “Creating sub drawings by Copying from projects” on 
page 301. — If the sub drawing shall be used for drag’n draw, please also 
see “Preparing Sub drawings for Drag’n Draw / Aut. placing” on page 310.

 2) Insert variable markers on the texts in the sub drawing, that are different from 
model to model. — See “Inserting variables in Sub drawings, Pages and Pro-
jects” on page 314.

Creating models for a sub drawing

 3) While you are working on the sub drawing (in the Edit sub drawing mode): 
Right-click on the page, and choose Variables:

 4) In the dialog box Variables: Click on Add model:

 5) In the dialog box New model: Type in the name on the new model you wish 
to create, and click OK.

 6) In the dialog box Variables: Double-click in the fields for the different varia-
bles in the model, and type in the data for the model — or right-click on the 

VIDEO ABOUT SUB DRAWINGS WITH MODEL DATA

ON WWW.PCSCHEMATIC.COM UNDER VIDEOS, YOU CAN SEE A VIDEO 

ABOUT HOW TO WORK WITH SUB DRAWINGS WITH MODEL DATA.
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field and select Database, and you enter the Database menu, from which 
you select the desired component:

Creating a new model by copying data

 7) Click on Add model and type in a title for the new model.

 8) Right-click on the first created model, and choose Copy model data:

 9) Right-click on the new model, and choose Paste model data:

 10) Answer OK to overwrite the model data for the new model (do not select to 
insert the title), and the data are inserted as data for the new model.

 11) For the text fields you wish to edit: Double-click on the field, and edit the 
contents. — Or right-click on the field and select Database, and you enter 
the Database menu, from which you select the desired component.

Double-click in the

fields, and type in

the data
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 12) Click OK.

You have now created model values for a sub drawing. The created sets of model 
values, are the model values you can choose from, when the sub drawing is placed 
in a project. — See “Manual placing of sub drawings” on page 292, “Inserting sub 
drawings: With model data” on page 293 in particular.

Creating a model variable

For use in automatic project generation, you can create a so-called model variable, 
so that you via the project definition file can specify which of the models in the sub 
drawings to insert.

Read more about this in "Create model variable" in the Project generator manual.

Model data: Options when right-clicking

When you right-click in the dialog box Variables when creating model data, you get 
the following options:

Database: Gives you the option of 
choosing components from the data-
base. Appears when right-clicking on an 
S.Article or a S.Type variable.

Model title: You can edit the title for the 
selected model.

Model variable: See “Creating a model 
variable” on page 319.

Insert model: Inserts a new model 
where you have clicked.

Add model: Adds a new model.

Delete model: Deletes the selected model.

Move left: Moves the selected model one position to the left. — See also “Drag 
and drop Models in the dialog box” on page 319.

Move right: Moves the selected model one position to the right. — See also “Drag 
and drop Models in the dialog box” on page 319.

Copy model data: Copies the values for the selected model — see “Creating a 
new model by copying data” on page 318.

Insert model data: Inserts the copied model values — see “Creating a new model 
by copying data” on page 318.

Drag and drop Models in the dialog box

To move a model to another position in the dialog box, you can click on the title of 
the model, and drag it to another position in the dialog box.

LINE ARTICLE DATA CAN ALSO CONTAIN VARIABLES

LINE ARTICLE DATA IN SUB DRAWINGS CAN ALSO CONTAIN VARIABLES. THIS 

APPLIES FOR BOTH DRAG’N DRAW AND IN CONNECTION WITH AUTOMATIC 

PROJECT GENERATION.
mation

Page 319



P

Sub drawings
INVISIBLE AREAS AND SUB DRAWINGS

When inserting sub drawings, you can subsequently make parts of these sub 
drawings invisible, as described in “Making objects invisible” on page 69.

SUB DRAWINGS WITH INTELLIGENT LINE CONNECTION

To create sub drawings with intelligent line connection, you must use a line connec-
tion symbol, as described in “Creating Line Connection symbols” on page 795.

This line connection symbol can for instance be placed as displayed in the figure 
below.

Controlled via variable marker in the symbol name

To control the connection, you must insert a variable marker in the symbol name. 
When the variable in the name gets the same value as one of the connection 
points — e.g. 3 —, the wire, which is connected to the symbol, will connect to 
where connection point 3 is placed. It can therefore be controlled if for instance a 
wire in a sub drawing connects to L1, L2 or L3.

Insert e.g. the

line connection

symbol here
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This aspect can therefore be different depending on which model of the sub draw-
ing you choose. Below the models L1, L2 and L3 have been created:

When you place the sub drawing in a project, you can therefore get the following 
result by placing the three different models:

When the sub drawing is placed on the project page, the line connection symbol is 
converted to an ordinary line, and is therefore no longer a symbol.

Model L1 selected Model L3 selectedModel L2 selected
mation

Page 321



P

Rename selected symbols
RENAME SELECTED SYMBOLS

When you select Tools => Rename symbols, you enter the dialog box Rename 
selected symbols, from which you can rename the used symbols in the project.

GENERAL INFO ON THE DIALOG BOX RENAME SELECTED SYMBOLS

When you select Tools => Rename symbols, you enter the dialog box Rename 
selected symbols:

When you wish to rename symbols in the project, do this:

THIS CHAPTER DESCRIBES

— GENERAL INFO ON THE DIALOG BOX RENAME SELECTED SYMBOLS .............p. 322

— SELECTING SYMBOLS IN THE DIALOG BOX..................................................p. 324

— DIRECTION FOR RENUMBERING SYMBOLS ..................................................p. 325

— SPECIFY START VALUE..............................................................................p. 326

— SHOW NEW SYMBOL NAMES......................................................................p. 326

— NAMING WHEN RENUMBERING TERMINALS.................................................p. 326

— INSERTING SYMBOL NAMES OR CONNECTION NAMES ..................................p. 328

— SORTING ON COLUMN CAPTIONS ...............................................................p. 329

INSERT SYMBOL / CONNECTION NAMES

IT IS ALSO POSSIBLE TO RIGHT-CLICK ON A SYMBOL IN THE PROJECT, AND 

SELECT INSERT NAME. — READ MORE ABOUT THIS IN “Insert new Symbol 
names or Connection names” on page 328.
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 1) Select which symbols to rename — see “Selecting symbols in the Rename 
symbols dialog box” on page 324.

 2) Specify a direction for renaming the symbols — see “Direction for renaming 
symbols” on page 325.

 3) Specify how to rename terminals (if any) — see “Naming when renaming ter-
minals” on page 326.

 4) Specify a start number for the renamed symbols, see which names this will 
result in, and execute the renaming — see “Specify Start value for Renaming 
symbols” on page 326.

The function Rename selected symbols can also be handy when you wish to 
keep control of the symbol names when merging projects.

Which symbol names are renamed

Only symbol names ending with a number, are renamed/renumbered. If a symbol 
name contains a number before a letter, this number is not changed.

Undo renumbering

Please note that it is possible to undo the renaming by using the Undo function 
after closing the dialog box Rename selected symbols.

WORKS ONLY WHEN USING FREE NAME FORMAT FOR SYMBOLS

THIS FUNCTION ONLY WORKS IF YOU USE FREE NAMING FORMAT FOR THE 

SYMBOLS IN THE PROJECT — THIS MEANING THAT YOU DO NOT USE CUR-

RENT PATH NUMBERING. IF YOU DO NOT USE FREE NAMING FORMAT, THE 

FUNCTION CAN ONLY BE USED FOR RENAMING TERMINALS.

"NAME PROTECTED" COMPONENTS ARE NOT RENAMED

READ MORE ABOUT THIS IN “Name protected” on page 176.
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SELECTING SYMBOLS IN THE RENAME SYMBOLS DIALOG BOX

When you click on Execute, all symbols listed in the dialog box Rename selected 
symbols are renamed.

You can select which symbols to rename in three different ways:

1. Selecting/deselecting in the list

When you select symbols in the list, you can use the <Shift> and/or the <Ctrl> key, 
as you normally do in Windows, and e.g. in the Object Lister. — See “Selecting 
objects in the Object Lister” on page 344.

The selected symbols can then either be selected or deselected:

• If you click on Select in the right-hand side of the dialog box: The selected sym-
bols are now the only symbols in the list.

• If you click on Deselect in the right-hand side of the dialog box: The selected 
symbols are deleted from the list. (You can also press the  <Delete> button to 
delete the selected symbols from the list).

2. Selecting by specifying symbol names

In the field Select name(s) you can type in which symbols 
you wish to select, among the names already displayed in the 
list.

Then click on Select in the right-hand side of the dialog box. Now only symbols ful-
filling the entered criterion are displayed.

3. Selecting project symbols by right-clicking

You can also select multiple symbols in the project — before entering the dialog 
box Rename selected symbols:

3a) Select the symbols by dragging a window over them with the mouse — if 
necessary please see “Selecting objects” on page 55, in particular “Selecting 
more objects of the same kind in one window” on page 55.
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3b) Right-click and select Rename (see the figure below) — or select Tools => 
Rename symbols.

3c) You now enter the dialog box Rename selected symbols, where only the 
selected symbols are displayed:

DIRECTION FOR RENAMING SYMBOLS

When you rename symbols, it is only their position in the project, that determines 
which names the symbols are assigned.

The direction for the renaming always starts from the first project page, and ends at 
the last project page.

How the renaming is performed on the individual 
project page, can be specified in the upper-left cor-
ner of the dialog box Rename selected symbols.

Here you select one of the four corners, to specify 
from which corner to start the renaming.

Furthermore, you specify the numbering direction 
Vertical or Horisontal.

THE OTHER SYMBOLS FOR THE COMPONENT ARE ALSO RENAMED

PLEASE NOTE, THAT ONLY THE SELECTED SYMBOLS ARE DISPLAYED IN THE 

DIALOG BOX. WHEN A COMPONENT HAS MORE SYMBOLS IN THE PROJECT, 
WITH THE SAME NAME AS THE SELECTED SYMBOL, ALL SYMBOLS FOR THE 

COMPONENT ARE RENAMED IN THE PROJECT.
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What is important for which number a component is assigned, is therefore the first 
time a symbol for the component appears in the project.

— The function and location aspects in reference designations (if any) remains 
unchanged under the renaming.

SPECIFY START VALUE FOR RENAMING SYMBOLS

When you wish to specify a start value for the renamed symbols, type in the num-
ber in the Start value field.

Hereby the new symbol names starts with e.g. the number 100.

SHOW NEW SYMBOL NAMES BEFORE RENAMING SYMBOLS

When you have selected which symbols to rename, have specified a direction for 
the renaming, and have specified a start value (optional), you are ready to execute 
the renaming.

Before you do this, you can click the Show button in the right-hand side of the dia-
log box. The new names are now displayed in the column New Name — see the 
figure above.

When you are satisfied with the new names, click the Execute button, and the 
listed symbols are renamed in the project.

NAMING WHEN RENAMING TERMINALS

In the dialog box Rename selected symbols 
you can specify how to rename the terminals in 
the list.

You have the following options:

UNDO THE RENAMING

PLEASE NOTE THAT IT IS POSSIBLE TO UNDO THE RENAMING BY USING THE 

UNDO FUNCTION, AFTER CLOSING THE DIALOG BOX RENAME SELECTED 

SYMBOLS.

OPTIONS ACTION

DO NOT RENAME 

TERMINALS

NO TERMINALS AND NO TERMINAL CONNECTION POINTS ARE 

RENAMED.
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— These options are precisely the same as the options for intelligent copying of 
areas. See more about this in “Intelligent copying of areas” on page 271.

Example on renaming terminals

When you select e.g. Rename Terminal Connection Points, and click on Show, 
you can see the new connection names for the terminals in the column New 
Pinno:

— See also “Insert new Symbol names or Connection names” on page 328.

RENAME TERMINALS ONLY THE TERMINALS ARE RENAMED. TERMINAL CONNECTION 

POINTS ARE NOT RENAMED.

RENAME TERMINAL 

CONNECTION POINTS

THE TERMINAL CONNECTION POINTS ARE RENAMED. TERMINAL 

NAMES ARE NOT RENAMED. — SEE “Fulfilling standards when 
copying areas” on page 272.

RULES FOR RENAMING TERMINALS

TERMINAL CONNECTION NAMES ARE ONLY RENAMED WHEN THESE ARE 

NUMBERS. TERMINAL CONNECTION NAMES ARE ONLY RENAMED WHEN BOTH

(/ALL) CONNECTION NAMES FOR A TERMINAL ARE IDENTICAL.

OPTIONS ACTION
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INSERT NEW SYMBOL NAMES OR CONNECTION NAMES

It is also possible to use the Rename selected symbols dialog box to insert new 
symbol names or connection names in the project:

1. Insert new symbol names

To insert e.g. three new symbol names starting from -P2 in the project, do this:

1a) Select -P2 in the project.

1b) Select Functions => Rename symbols — or right-click on -P2 and select 
Insert name.

1c) In the dialog box Insert name: Click in the Insert new names field, and type 
in how many names to insert:

1d) Click on Execute.

The symbol -P2 is hereby renamed to -P5, and the subsequent -P symbols are 
renamed correspondingly. (-P3 are renamed to -P6 — etc.).

The symbol names -P2, -P3 and -P4 are now available in the project.

2. Insert new connection names on terminals

To insert e.g. five new connection names in terminal -X1, starting from connection 
4, do this:

2a) Select the terminal which has the connection 4 in the project.

2b) Select Functions => Rename symbols. (Or right-click directly on the termi-
nal symbol and select Insert name).

2c) In the dialog box Insert name: Click in the Insert free names field, and type 
in how many connection names to insert:

2d) Click on Execute.
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The new connection names are now inserted for the terminal, according to the 
same principle as described in “Insert new symbol names” on page 328.

SORTING ACCORDING TO COLUMN NAMES IN THE DIALOG BOX

When you open the dialog box Rename selected symbols, the information in the 
dialog box are sorted by symbol name, but if you wish to e.g. sort according to 
type, you just click on the column caption Type.

When you wish to sort in reverse order, just click on the column caption again. The 
sorting is alphabetical/numerical.

All columns can be sorted in both directions.
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INSERTING IMAGES

If you want to insert an image on a page in your project, you choose Insert => 
Insert Picture. You can choose this function independent from which type of draw-
ing objects you are working with.

You now enter the dialog box Open, where you determine which file to insert into 
the project.

Here you can choose between inserting the image with or without a link. — Se 
more about this on the figure above.

The file types you can open from here 
are either .bmp files, .jpg files, meta-
files, enhanced metafiles, .gif files or 
.png files.

If you need to insert other file types/
image formats, it is possible that you 
can insert the image as an OLE object, 
which is described in “Inserting files 
from other programs / OLE” on page 736.

When you have opened the image, it is placed in the cross hairs, and you click 
where you want to place it on the page.

Move, delete, copy or rotate inserted image

If you want to select an image, you click the Area button, and then click on the ref-
erence point of the image — or, alternatively, drag a window around the reference 
point.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO INSERT AN IMAGE IN A PROJECT.

MAXIMUM SIZE FOR IMAGES 1600X1200 PIXELS

PLEASE NOTE, THAT WHEN INSERTED IMAGES ARE LARGER THAN 

1600X1200 PIXELS, THEY WILL BE DOWNSCALED PROPORTIONALLY.
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If you right-click on the selected image, this menu appear:

Here you determine to either move, copy, delete or rotate the selected image.

Images can not be rotated.

Scaling an image

When you want to change the size of an image, do like this:

 1) Double-click on the image

 2) Point on one of the corners of the image, so that the mouse pointer changes 
to a two-way arrow

 3) Press the mouse button, drag the image to the desired size, and release the 
mouse button

 4) Click somewhere outside the image, to deselect the image

You can also scale an image by choosing Edit => Scale, as described in “Scaling 
areas” on page 280.

Point at the corner, and drag until

the desired size is achieved
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This section describes functions, which gives you a 
survey of projects:

- The Explorer .........................................................p. 335

- The Object Lister..................................................p. 341

- Find and Replace .................................................p. 351

- Design check........................................................p. 355

- Printing...................................................................p. 361

- The Explorer as Project/Symbol menu ............p. 370

- Reference designations......................................p. 373

Survey and Reference 
Designations





The Explorer window: The Projects tab

Auto
THE EXPLORER WINDOW: THE PROJECTS TAB

The Explorer window contains two different tabs: The Projects tab and the Sub-
Drawings tab. This chapter describes the Projects tab, as well as the general 
options in the Explorer window. The SubDrawings tab is described in “Sub dra-
wings” on page 289.

There are also three buttons at the top of the 
Explorer window, which are described else-
where: The Symbol menu button (see “Fetching 
symbols using the Symbol menu” on page 159), 
the Component database button (see “Fetching 
symbols from the database” on page 167) and the 
Object Lister button (see “The Object Lister” on 
page 341).

In the Projects tab in the Explorer window, you can display all types of information 
about the active projects, and can navigate back and forth between the project 
pages in all of the open projects. Furthermore, you can edit Project data, Page 
Data and component data directly from the Explorer window.

GENERAL SETTINGS FOR THE EXPLORER WINDOW

You can specify where to place the Explorer window, as explained in “Docking 
Windows and Toolbars” on page 26.

If you do not want to use the Explorer window, you can turn it off by choosing Set-
tings => Pointer/Screen, and deselect Explorer window.

View Explorer window

View => Explorer window is a menu item which shows/hides the Explorer win-
dow, if Explorer window has been selected in Settings => Pointer/Screen. The 
function has the short-cut key <Shift+F12>, so that you can show/hide the 
Explorer window quickly.

The Explorer window in Edit symbol mode

When you are designing symbols — being in the Edit symbol mode — you most 
likely do not need the Explorer window.

THIS CHAPTER DESCRIBES

— GENERAL SETTINGS FOR THE EXPLORER WINDOW....................................p. 335

— DISPLAYING AND HIDING INFORMATION IN THE PROJECTS TAB ...................p. 336

— EDITING PROJECT, PAGE AND ARTICLE DATA FROM THE PROJECTS TAB ....p. 336

— SELECTING SYMBOLS FROM THE PROJECTS TAB .......................................p. 338

— JUMPING BETWEEN PROJECT PAGES IN DIFFERENT PROJECTS...................p. 340

— UPDATING THE PROJECTS TAB .................................................................p. 340

— CLOSING PROJECTS FROM THE PROJECTS TAB .........................................p. 340
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Therefore you can choose Settings => Pointer/Screen => Explorer window and 
subsequently deselect Show in Edit symbol, which specifies whether to show the 
Explorer window in the Edit symbol mode.

DISPLAY AND HIDE INFORMATION IN THE EXPLORER WINDOW

In the Projects tab in the Explorer window, you 
can display all the information attached to a 
specific object, by clicking the small triangle 
icon next to the object. — Please see the figure 
to the right.

To stop displaying the extra information, click 
the triangle icon once again.

If for instance you click on the triangle icon in 
the Project Data line above, you see the pro-
ject data for the project.

As you can see, the symbol in the Project Data 
line has now changed to a different triangle 
icon. When you click on this triangle, the project 
data datafields are hidden, and the Explorer 
window looks like the first figure again.

CHANGING DATA FROM THE PROJECTS TAB

From the Projects tab in the Explorer window you can change project data, page 
data and component data.

Editing Project data from Projects tab

To edit Project data from the Projects 
tab, right-click on the line Project data, 
and choose Edit Project data.

You then enter the dialog box Project 
data, from where you can edit the project 
data for the project. This dialog box is 
described in “Project and Page data” on 
page 125.

Make the changes and click OK.

Editing the contents of a single Project data datafield

When you want to edit the contents of a single Project data datafield — for instance 
Customer name — you right-click on the datafield in the Explorer window, and 
choose Edit Customer name. You then enter a dialog box where you make the 
changes and click OK.

Click here to open

Click here to close
Automation

age 336



The Explorer window: The Projects tab

Auto
Editing Page data and Project data

Page data datafields are changed directly from the Projects tab in the Explorer 
window, as described in “Editing the contents of a single Project data datafield” on 
page 336.

When you edit a Page data datafield, you also get the option of changing the con-
tents of all Page data datafields of the chosen type in the entire project by choosing 
Change on All Pages.

The contents of Page data datafields can also be edited from the Object Lister 
(short-cut key <F7>), as described in “Editing Page data in the Object Lister” on 
page 350.

Editing Component data from the Projects tab in the Explorer
window

When you want to edit the Component data for at symbol, this can be done by 
right-clicking on the symbol in the Projects tab in the Explorer window, and 
choosing Edit Symbol Data.

This brings you into the dialog box Component data, where you edit the compo-
nent data and click OK.

You can also make changes in article data for cables and signals from the Projects 
tab in the Explorer window.

Component data and cable article data can also be changed directly from the 
Object Lister (short-cut key <F7>), as described in “Check and edit component 
data and cable data” on page 348.
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THE EXPLORER WINDOW: SELECTING SYMBOLS

When you wish to navigate between the symbols in the project using the Projects 
tab in the Explorer window, you have two options:

• You can select a symbol in the active project, and then have it selected in the 
Explorer window

• You can select a symbol in the Explorer window, and then have it selected in 
the project

Select a symbol in the project - and see it in the Explorer window

When you select a symbol in the project and then click the Show selected symbol 
button at the top of the Projects tab in the Explorer window, the symbols for the 
components are displayed on the tab:

This also gives you the possibility to jump to the other symbols for the component 
by double-clicking them in the Explorer window.

— If reference designations are used in the project, please see “Reference desig-
nations in the Explorer window” on page 399.

Select a symbol in the Explorer window - and see it in the project

Next to each symbol in the Projects tab in the Explorer window, you’ll find a small 
symbol icon. When you click the icon, the symbol is selected in the project. When 
you click the icon for a page, the selected page is displayed:

Show the project page

Show/select the symbol
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You can for instance do this in the Projects tab (see the picture below): Click the 
triangle icon next to the project name and click the triangle icon next to Pages. You 
now get a survey of all the pages in the project.

Now click the triangle icon next to the chapter Diagrams, and click the triangle icon 
next to the page 6:Diagram 2. You can now see that you can get more information 
about Page Data, Symbols, Cables and Signals on the page.

Open Symbols, and then open =W1+A1-Q1.

You can now see all the symbols on the page for the selected component — in this 
case two.

When you click on the symbol icon next to the relay symbol, the symbol is dis-
played/selected in the project, as displayed below:

When you then click on the symbol icon next to the make contact, the cross-hairs 
then points out the make contact for you.

The line you clicked on can contain information about the connection names for the 
symbol, the type of the symbol, the symbol file name and the title of the symbol. 
Due to the size of the Explorer window, you will probably not be able to see all that 
information. If you let the mouse pointer rest a short while over the line, the entire 
line will be displayed.

Please note, that you can do the same for Cables and Signals.
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JUMP BETWEEN PAGES IN MORE THAN ONE PROJECT

When you have more than one project open at 
the time, you can find all the open projects in the 
Projects tab in the Explorer window.

When you open Pages for the projects, you can 
jump back and forth between the pages in the dif-
ferent projects, just by clicking on the page icon 
for the relevant project page.

By opening Project Data for the projects, you can 
for instance compare project data for the projects.

UPDATING THE EXPLORER WINDOW

When you delete a project page, which is dis-
played in the Explorer window, this page is also 
deleted from the Explorer window.

CLOSING PROJECTS FROM THE PROJECTS TAB

If you want to close a project from the Projects tab in the Explorer window, right-
click on the project file name and choose Close.

You can also right-click on a project in the Projects tab in the Explorer window, 
and choose Go to. This activates the last page you worked on in the project.
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THE OBJECT LISTER

To navigate quickly in your projects, you can use the Object Lister.

The Object Lister makes it possible for you to locate any given component in a 
project and/or information about the applied symbols/components.

From the Object Lister you can also edit component data, symbol names, refer-
ence designations, PLC I/O data, page data, free texts and many other texts in the 
project. Furthermore, you can print and create files containing selected information 
to for instance Excel.

— See also “The Explorer window: The Projects tab” on page 335 and “Find and 
Replace” on page 351.

THIS CHAPTER DESCRIBES

— ON THE DIALOG BOX OBJECT LISTER ........................................................p. 342

— COMPONENTS IN THE OBJECT LISTER .......................................................p. 343

— SYMBOLS IN THE OBJECT LISTER ..............................................................p. 343

— SELECTING OBJECTS VIA THE OBJECT LISTER ...........................................p. 344

— LOCKING THE OBJECT LISTER TO A REFERENCE DESIGNATION ...................p. 344

— THE SORTING ORDER OF DATA IN THE OBJECT LISTER...............................p. 344

— SELECTING OBJECTS ................................................................................p. 344

— COUNTING ON SELECTED OBJECTS ...........................................................p. 346

— DISPLAYING INFORMATION ........................................................................p. 346

— PRINTING.................................................................................................p. 347

— SAVE TO FILE...........................................................................................p. 347

— CHOOSING NEW COMPONENTS IN THE DATABASE.......................................p. 347

— SEARCHING .............................................................................................p. 348

— EDITING SYMBOL AND CABLE DATA VIA THE OBJECT LISTER ......................p. 348

— EDITING PLC I/O DATA VIA THE OBJECT LISTER........................................p. 349

— EDITING PROJECT TEXTS VIA THE OBJECT LISTER .....................................p. 349

— EDITING PAGE DATA VIA THE OBJECT LISTER ............................................p. 350

— OBJECT LISTER FOR ONE COMPONENT......................................................p. 350

— TEXT LINKS IN THE OBJECT LISTER ...........................................................p. 350
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ON THE OBJECT LISTER DIALOG BOX

To enter the Object Lister you choose Func-
tions => Object Lister, or press the short-cut 
key <F7>.

You can also click the Object Lister button in 
the upper part of the Explorer window, when 
you wish to enter the Object Lister.

When you enter the Object Lister, you must 
first specify which type objects that you want 
to see the attached texts/data for. Then the 
Object Lister is filled with data.

By choosing an object type at the top of the 
Object Lister, you determine whether to show 
texts/data for Symbols, Signals, Wire num-
bers, Cables, Terminals, PLC I/O, PLC I/O 
Ref, Texts, Reference frames, Pages or 
Lines (only lines with article data are dis-
played).

THE OBJECT LISTER REMAINS ON SCREEN

THE OBJECT LISTER REMAINS ON SCREEN WHILE YOU WORK WITH THE 

PROJECT. WHEN THE OBJECT LISTER DISPLAYS DATA, THESE DATA ARE 

UPDATED AUTOMATICALLY, WHEN YOU MAKE CHANGES IN THE PROJECT.

— THE OBJECT LISTER CAN BE SET TO BECOME TRANSPARENT, WHEN YOU 

ARE WORKING ON THE DRAWING AREA, WHILE YOU LET THE OBJECT LISTER 
REMAIN ON THE SCREEN — SEE “Pointer/Screen” on page 906.

Choose which type of

objects to display
Update

Fetch data

from database

Search

Click on an
object, and it

is displayed

in the project
Save as file

e.g. for Excel
For scrollling up/down

and left/right in the list

Edit data

View object

in project

Lock Object Lister

to reference designation

Print
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COMPONENTS IN THE OBJECT LISTER

If components are not displayed in 
the Object Lister, you can activate 
displaying components as 
described in “Displaying information 
in the Object Lister” on page 346.

When a component contains more 
than a single symbol, the compo-
nent name is only displayed for the 
first symbol for the component — 
as you can see in the figure to the 
right.

Brackets after the component name 
specifies the component group 
number — see “Component Grouping” on page 613.

SYMBOLS IN THE OBJECT LISTER

When you have selected the Symbols tab in 
the Object Lister, you will get the project sym-
bols listed in alphabetical order — independ-
ent from which page that you are working on.

You can specify which symbol types to display 
by selecting the relevant symbol types in the 
toolbar in the Object Lister.

Signals in the Object Lister

When you select Signals in the Object Lis-
ter, the signal references are also dis-
played:

+ before the reference, means that the sig-
nal is With reference, and displays From/
To.

* before the reference, means that With reference is not selected, and displays 
All.

- before the reference, means that With reference is not selected.

NAME PROTECTED SYMBOL NAMES CAN NOT BE CHANGED HERE

IF A SYMBOL NAME IS NAME PROTECTED, THE SYMBOL NAME CAN NOT BE 

CHANGED FROM THE OBJECT LISTER. HOWEVER, OTHER TEXTS FOR THE 

SYMBOL CAN BE CHANGED. — READ MORE ABOUT THIS IN “Name protec-
ted” on page 176.
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SELECTING OBJECTS DIRECTLY FROM THE OBJECT LISTER

If for instance you have chosen to work with Symbols, and wish to find the symbol 
=G1+A2-Q2 in the project, scroll down to it and double-click on =G1+A2-Q2. This 
automatically places you on the page in the project where the symbol is located, 
and the symbol will be selected.

This also applies for other types of objects in the Object Lister.

LOCKING THE OBJECT LISTER TO A REFERENCE DESIGNATION

When you click on the Lock list to ref-
erence designation button, you enter 
the dialog box Reference designa-
tion, from which you can select which 
reference designation to display in the 
Object Lister.

Subsequently, only objects with the 
selected reference designation are 
displayed in the Object Lister. In the 
title bar of the Object Lister, you can 
see the selected reference designa-
tion.

If you right-click on the line with field 
names, you can also choose to display 
individual columns with Ref.Design. 
Function, Ref.Design. Location and/
or Ref.Design. Product.You can then easily sort the list by mechanical assembly 
(position) or function.

Show all objects with any reference designation again

To make the Object Lister displays objects with any project designation again, 
click on the Lock list to reference designation button, and select Top node = 
none for both the function and the location aspect in the dialog box Reference 
designations.

THE SORTING ORDER OF THE DATA IN THE OBJECT LISTER

Initially the objects will be sorted by symbol name (page name and text contents 
respectively), but if you want them sorted by for instance article, click on the col-
umn heading Article.

When you wish to see the objects in reverse order, click the column heading again. 
The sorting order is alphabetical/numerical. You can sort all columns in both direc-
tions.

SELECTING OBJECTS IN THE OBJECT LISTER

Selecting objects in the Object Lister follows the common Windows guidelines:

Selecting a single object in the Object Lister

To select one single object in the Object Lister, just click on it.

Only objects with this reference

designation are displayed

Right-click here to select columns for
displaying reference designations
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Choosing a block of objects in the Object Lister

To select a block of objects listed in succession in the Object Lister, click on the 
first object in the block, and press down <Shift> while clicking on the last object in 
the block.

Selecting and deselecting single objects in the Object Lister

To select more than one object individually, press down <Ctrl> while clicking on the 
objects. When you wish to deselect a selected object, without deselecting the other 
selected objects, you must also press down <Ctrl> while clicking on the object.

Selected objects and Printing in the Object Lister

When you have selected more than one object when clicking the Print button in the 
Object Lister, only the selected objects are printed. When only one object is 
selected, all of the list is printed. — See “Printing from the Object Lister” on 
page 347.

This also applies when you click the Save as file button to save a file. — See 
“Save as File from the Object Lister” on page 347.

Example on choosing objects in the Object Lister

To select the selected objects in the Object Lister below, do the following:

 1) Click on the first object in 
the list.

 2) Press down <Shift>, and 
click on the last object in the 
list.

 3) Press down <Ctrl>, and 
click on the object you wish 
to deselect.

The chosen objects can now for instance be printed, saved to a file, or the article 
data for the selected objects can be edited.

1

3

2
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COUNTING ON SELECTED OBJECTS IN THE OBJECT LISTER

When you have selected more than one object in the Object Lister, it is possible to 
apply the automatic counting functions in the program for various of the object texts 
or I/O addresses.

When for instance you wish to change the addresses for the output on a PLC, do 
the following:

 1) In the Object Lister: Click on PLC I/O — to work with PLCs.

 2) Click on the Pencil — to edit texts in the Object Lister.

 3) Select the relevant I/O addresses for the symbol that you want to change the 
addresses for — see “Selecting objects in the Object Lister” on page 344 —, 
and press <Enter> or <F2>:

 4) You now get the option to change the selected texts automatically, as 
described in “Changing a text” on page 127. Click OK.

DISPLAYING INFORMATION IN THE OBJECT LISTER

When you right-click on the row 
with column headings, you can 
choose which information to dis-
play in the Object Lister.

Viewing the different types of 
information can be selected/
deselected by placing/removing 
a check mark in front of each 
type of information.

If for instance components are 
not displayed in the Object Lis-
ter, you can select Component, 
and the column will now appear 
in the Object Lister.

If you want the component name 
to appear as the first column, you 
can just click on the column 
header Component and drag it 
to the desired position.

— See “Components in the 
Object Lister” on page 343.

3a) Click here

3b) Press down
 <Shift> and

click here

2) Click the Pencil

3c) Press <F2>

or <Enter>

Right-click here
to specify which
data to display
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PRINTING FROM THE OBJECT LISTER

When you have selected more than one object, only the selected objects are 
printed, when you click the Print button. When only one object is selected, all of 
the list is printed. — Read more about selecting objects in “Selecting objects in the 
Object Lister” on page 344.

When you click on Print, you enter the dialog box Print, in which you choose 
printer and print the selected.

SAVE AS FILE FROM THE OBJECT LISTER

When you have selected more than one object, only the selected objects are 
saved, when you click the Save as file button. When only one object is selected, all 
of the list is saved. — Read more about selecting objects in “Selecting objects in 
the Object Lister” on page 344.

When you click on Save you enter the dialog box 
Save. Here you can save the selected objects in three 
different ways:

 1) Text files (*.txt): The file is saved in column for-
mat.

 2) Comma separated (*.csv): The file is saved in 
comma separated format.

 3) Microsoft Excel (*.xls) or Microsoft Excel (*.xlsx): The file is saved in 
Microsoft Excel format.

Select file type, type in a file name, and click OK.

CHOOSING NEW COMPONENTS IN DATABASE VIA OBJECT LISTER

This is only possible when working with Symbols or Cables in the Object Lister:

When you click the DB button, you enter the database, located at the article num-
ber of the chosen component. You can then change the component in the project 
by choosing another article number in the database.

Only the selected symbol(s) in the Object Lister have their data changed. — See 
“Selecting objects in the Object Lister” on page 344.

EXCEL MUST BE INSTALLED

IT IS ONLY POSSIBLE TO SAVE IN EXCEL FORMAT WHEN EXCEL IS INSTALLED 

ON THE PC.

THIS IS BECAUSE Automation LETS EXCEL HANDLE THE SAVING. THIS WAY 

YOU ARE NOT DEPENDENT OF WHETHER Automation CAN HANDLE THE 

VERSION OF EXCEL INSTALLED ON YOUR PC.

Click here for a short-
cut to save in Excel
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SEARCHING IN THE OBJECT LISTER

When you click on the Find button, you can search among the selected objects in 
the Object Lister.

Click on the Down arrow, and choose which type of text you wish to search on.

When for instance you choose Type this is marked in the column Type.

Then type in the search text. While you are typing in the text, the Object Lister 
automatically jumps down to the first object in the list, that matches what you have 
typed in for the moment.

Click on the Search again button to find the next object in the list, that matches 
what you have typed in. When no objects matches what you have typed in, the 
Search again button is dimmed.

Automation can either search for texts that begins with what you have typed in, or 
just contains the text.

This depends on whether the Begins with button is activated, or the Contains but-
ton is activated. The button is placed to the right of the Find again button, and 
changes appearance between Begins with and Contains when you click on it.

CHECK AND EDIT COMPONENT DATA AND CABLE DATA

When you click on Symbols 
and then click the Pencil, you 
can correct the article data for 
the symbols directly from the 
Object Lister.

If for instance you want to 
change the symbol type, click in the Type field for the relevant symbol, and make 
the change.

When you click on Cables you can make similar changes for Cable data.

See how to edit article data for more than one cable at the time in “Editing PLC I/O 
data via the Object Lister” on page 349.

Click here and

choose what to

search for

Type in the search

text and press <Enter>

Shows that you are

searching on Type
Automation

age 348



The Object Lister

Auto
EDITING PLC I/O DATA VIA THE OBJECT LISTER

To edit PLC I/O data in Automation, click on PLC I/O in the Object Lister.

You can then choose either Used I/O — which gives you all used PLC I/O symbols 
in the project — or From reference symbols — which gives you all mentioned 
connection points in the PLC reference symbols in the project.

When you click on the Pencil, you can start editing PLC I/O data directly from the 
Object Lister.

Searching for PLC I/O data is done as described in “Searching in the Object Lister” 
on page 348.

See how to edit PLC I/O data for more than one PLC symbol at a time in “Counting 
on selected objects in the Object Lister” on page 346.

PLC I/O data can be saved to a file — for instance in Excel format — as described 
in “Save as File from the Object Lister” on page 347.

CHECKING AND EDITING PROJECT TEXTS VIA THE OBJECT LISTER

It is a good idea to check the project texts by 
clicking on Texts. If you need to make correc-
tions, click the Pencil, and click in the text field 
you wish to edit.

The changes is transferred to the diagrams 
automatically.

When you want to jump to the text in the pro-
ject, first deactivate the Pencil, then double-
click on the text in the Object Lister.

— See how to edit more than one text at a time in “Counting on selected objects in 
the Object Lister” on page 346.
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EDITING PAGE DATA IN THE OBJECT LISTER

When you click on Pages, you 
get a survey of all the project 
pages.

When you then click the Pencil, 
you get the option of editing the 
page titles.

OBJECT LISTER FOR SELECTED SYMBOL

If you select a symbol when you are working in the 
project — for instance -F1 — and press <F7>, you 
will get a survey of all the places -F1 is used in the 
project.

Alternatively you can right-click on a symbol, and 
choose Show used.

You then get the following survey of the symbol:

These functions are also available for signals and wire numbers.

Because the Object Lister remains on the screen, you can subsequently select 
another symbol in the project, and click the Update button in the Object Lister. 
This updates the Object Lister with information from the component, you have 
selected now.

When you want the list on print, click on Print. Click Save to save it as a file.

Click on the Pencil to correct the component data, or click the DB button to find the 
symbol in the database.

TEXT LINKS IN THE OBJECT LISTER

Information about linked text is also displayed in the Object Lister.

— See “Text links” on page 144.
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FIND AND REPLACE

To find objects in projects quickly, you either use the Object Lister — see “The 
Object Lister” on page 341 — or the Find function, which is described in this chap-
ter.

The Object Lister gives you the possibility to locate components in the project and/
or locate article data for the applied symbols/components. Also, you can change 
texts using the Object Lister.

The Find function gives you the option to find symbol texts, and the replace func-
tion gives you the option to replace them as well.

 — Other ways to find symbols quickly are described in “Functions on Component 
Level” on page 250.

FINDING SYMBOL TEXTS

If you want to find symbol texts, you choose Edit => Find (short-cut key <Ctrl+f>) 
and enter this dialog box:

THIS CHAPTER DESCRIBES

— FIND SYMBOL TEXTS................................................................................p. 351

— REPLACE SYMBOL TEXTS .........................................................................p. 353

— THE DIALOG BOX FIND AND REPLACE REMAINS ON SCREEN .......................p. 354

— NEGATED AND UNDERLINED TEXTS IN FIND AND REPLACE .........................p. 354

Click here to see a list containing

project texts of the chosen Text type
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Here you type in the type of text you want to find, and state which type of symbol 
text you want to find, and in which direction you want the search carried out. The 
search direction determines whether you search the full project, the page you are 
working on, or in the direction forwards or backwards. — Please note that if you 
search for Symbol datafields, you search for the values in the symbol datafields. 
Correspondingly, you can only replace the values of the symbol datafields, and not 
their names.

When you set Text type to All, 
Automation search in all texts types in 
the project.

When a text is found, the text is dis-
played in the dialog box.

Text recognition

If you select Match Case, you will only find the texts using upper case and lower 
case letters exactly the way you type them in. If you write X1, the text x1 will not be 
found. However, this text will be found if you have not selected Match case.

If you select Find Whole Text Only, you will only find the symbol texts that con-
tains exactly the letters/characters you typed in. If you have typed in Component, it 
will not find the text Component A38. But this text will be found if you have not 
selected Find Whole Text Only.

Please note, that if you have not selected Find Whole Text Only, the program will 
find all texts having the text you typed in as a part of the text. If you typed in tact, it 
would find the text contact.

Searching with Reference designations

When searching for symbols with reference designations, it is possible only to 
specify either the location or the function part of the reference designation.

If you type in the search text =G1-Q1 and select Match Whole text only, you will 
therefore also find the symbols for the component =G1+A2-Q1.

Zoom during Find and Replace

When a found text is selected on a diagram, it is sometimes an advantage to zoom 
in on the symbol. In the Zoom in mm field you specify how close you want to zoom 
in on the found text.

Find next symbol

When you want to find the text in the project, you click on Find Next, and the next 
text matching the search criteria will be found.

If you exit the Find dialog box, you will find the next text matching the search crite-
ria by choosing Edit => Find next, or by pressing the <F3> key.

Found text
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REPLACING SYMBOL TEXTS

If you want to find and replace symbol texts, you choose Edit => Replace and 
enter this dialog box:

You specify what you want to find as explained above, and in the Replace with 
field you type in the text you want to replace.

When you have clicked on Find Next, and a symbol text has been found, you click 
on Replace to replace the text. After replacing the text, you automatically jump to 
the next text matching the search criterion.

If you do not want to change the text you have found, just click on Find next, and 
you jump to the next text matching the search criterion.

Clicking on Replace All will replace all matching texts in the specified area.

Click on Close when you have finished.

— Please note that if you search for Symbol datafields, you search for the values 
in the symbol datafields. Correspondingly, you can only replace the values of the 
symbol datafields, and not their names.

Find and Replace for connection names

Connection names can also be replaced from the dialog box 
Replace. If you wish to replace the connection name 13 for 
the symbol -Q1, write -Q1:13 in the Find What field, and 
only write the new connection name in the Replace with 
field — e.g. 23 — because the program knows that it is the 
connection name, that is going to be replaced.

Find and Replace in selected area

This is how to use Find or Replace in selected areas:

 1) Choose the Texts command

 2) Use the mouse to select the area

 3) Choose Edit => Find or Edit => Replace

Click here to see a list containing

project texts of the chosen Text type
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FIND AND REPLACE REMAINS ON SCREEN

When you have chosen Find and Replace, the dialog box remains on screen while 
you perform operations, so that you can continue searching easily.

— The Find and Replace dialog box can be set to be transparent, when working 
on the drawing area while the Find and Replace dialog box remains on screen — 
see “Pointer/Screen” on page 906.

NEGATED AND UNDERLINED TEXTS IN FIND AND REPLACE

In the dialog boxes for Edit => Find and 
Edit => Replace you can search for 
negated and underlined texts.

To search for a negated text, do the follow-
ing:

 1) Type in the text, and select the part 
of the text that is negated.

 2) Right-click on the selected, and 
choose Negate.

Searching for underlined texts takes place 
by choosing Underline.

To neutralise the negation of a text, select 
the text, right-click and choose Negate 
again. To neutralise the underlining of an underlined text, choose Underline.

CHANGING FONTS AND NEGATION

PLEASE NOTE, THAT IF YOU CHANGE FONT, THIS CAN HAVE AN EFFECT ON 

THE NEGATION OF TEXTS. — SEE “Special characters when changing the 
PCSCHEMATIC font to a Windows font” on page 134. 
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DESIGN CHECK

When using the design check function in a project, you are notified about the most 
obvious drawing errors:

• If for instance you want your diagrams to be mounting correct, you can check 
the project for connection dots

• If you have chosen to create very detailed connection lists, you can check for 
consistent line data

• Or you can make a simple check whether the diagrams contain short-circuiting 
or unconnected and/or parked lines

Thus the design check function can support you, when you wish to check your 
design.

PERFORMING A DESIGN CHECK

 1) To activate the function, choose Functions => Design Check, or click the 
Design Check button.

 2) In the Design Check dialog box: Click the Design Check settings button.

THIS CHAPTER DESCRIBES

— PERFORMING A DESIGN CHECK.................................................................p. 355

— THE DESIGN CHECK DIALOG BOX ..............................................................p. 358

— DISABLING USED MORE THAN ONCE IN THE SYMBOL DEFINITION ................p. 359

— DESIGN CHECK SETTINGS .........................................................................p. 359

USE THE DESIGN CHECK FUNCTION FREQUENTLY

IT IS A GOOD IDEA TO APPLY THE DESIGN CHECK FUNCTION FROM TIME TO 

TIME WHILE YOU ARE DRAWING. THIS WAY YOU DO NOT HAVE TO BOTHER 

WITH TOO MANY ERROR MESSAGES AT THE SAME TIME.

YOU CAN ALSO CHOOSE TO HAVE SOME DESIGN CHECKS MADE ONLINE, IE 

WHILE DRAWING.
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 3) In the dialog box Design Check settings you now get the following options:

 4) Select which errors to check the project for. To maintain the overview, it may 
be a good idea just to check the project for one type of errors at a time.
If you select All design errors (recommended) at the bottom of the dialog 
box, all checks for design errors are selected in the dialog box.

Click here to open/close a group

Here you select whether to execute the
design check online (ie while drawing)

Activate Online check here

Select what to
check for
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If you select All warnings all checks are selected in the dialog box.

You can read more about the options in the dialog box in “Design check set-
tings” on page 359.

 5) Click OK.

 6) If the design check finds errors, these are now displayed in the dialog box 
Design Check, as described in “The Design Check dialog box” on page 358. 
If this is not the case, you are told that no errors are found.

Design check for Symbols

For each check under Symbols at the top of the dialog box, you can specify 
whether the check shall be performed for Wire numbers, Cables, Terminals and/
or Other symbols. These options appear at the bottom of the dialog box, when 
you have selected one of the options under Symbols at the top of the dialog box.

In the figure below, the check for Missing reference designations is made for 
Other symbols.

ACTIONS PERFORMED BEFORE DESIGN CHECK CAN NOT BE UNDONE

WHEN YOU EXECUTE A DESIGN CHECK, THE PROJECT IS ALSO OPTI-

MIZED. THEREFORE YOU DO NOT HAVE THE OPTION OF UNDOING 

ACTIONS PERFORMED BEFORE YOU EXECUTED THE DESIGN CHECK.

DURING THE OPTIMIZATION PROCESS, LINES THAT ARE DRAWN IN 

SEVERAL STAGES, ARE FOR INSTANCE CORRECTED TO COHERENT 

LINES.
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THE DESIGN CHECK DIALOG BOX

When you choose Functions => Design Check, and click OK to execute a design 
check, you enter the dialog box Design Check:

This dialog box remains on screen while you are working in the project. — The dia-
log box can be set to be transparent, as described in “Pointer/Screen” on 
page 906.

Here you have the following options:

Double-click on errors in the list

When you double-click on an error message in the list, the program jumps to the 
place in the project, which have provoked the message, and the relevant object is 
pointed out by the cross hairs.

Update the Design Check list

When you have made changes in the project, you can click the Update list button. 
This automatically updates the list according to the performed changes.

When you have corrected the errors on the list, there may still be errors in the pro-
ject, due to subsequent obsolete errors.

Therefore it is a good idea to perform another design check, once you have cor-
rected the errors mentioned in the original list.

Accordingly, it may happen that correcting one error will make more than one error 
message disappear.

Design check settings

When you click the Design Check settings button, you enter the Design Check 
menu, from where you specify which types of design check you wish to perform. 
The design check list is automatically updated according to these directions.

Save and Print

Furthermore, you have the following options:

Click on the Save button to save the list in a file.

Click the Print button to print the list.
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Close the Design Check list

To close the design check list, click the Close button in the upper right-hand corner 
of the dialog box.

DESELECT USED MORE THAN ONCE IN THE SYMBOL DEFINITION

It is possible to deselect Functions => Design Check => Used more than once 
for individual symbols via the symbol definition for a symbol.

This is because it for some symbols — particularly for pneumatics symbols — is 
allowed to have more connection points with the same name.

— Read more about this in “No double check” on page 767.

DESIGN CHECK SETTINGS

Below you get an overview of the options in the dialog box Design Check set-

tings:

GROUP CHECK FOR MEANING

SYMBOLS MISSING NAME, 
TYPE, ARTICLE NUM-

BER, FUNCTION

CHECK FOR SYMBOLS WITHOUT NAME/TYPE/ARTICLE 

NUMBER/FUNCTION IN COMPONENT DATA

CONNEC-

TIONS

MISSING NAME CONNECTIONS WITHOUT NAMES DO NOT MAKE SENSE 

IN ELECTRICAL LISTS, SUCH AS CONNECTION LISTS, 
TERMINAL LISTS, CABLE LISTS AND GRAPHICAL PLANS. 
BEWARE, THAT ALL PCS SYMBOLS HAVE NAMES, 
EVEN WHEN THEY ARE INVISIBLE.

USED MORE THAN 

ONCE

IT IS AN ERROR IF A COMPONENT’S TERMINAL IS CON-

NECTED TO TWO OR MORE DIFFERENT NETS/POTEN-

TIALS.

NOT CONNECTED UNCONNECTED TERMINALS ARE ALLOWED BY THE PRO-

GRAM, ALSO WHEN GENERATING LISTS. HOWEVER, 
YOU CAN CHECK FOR UNCONNECTED TERMINALS.

NOT CONNECTED CONNECTIONS ARE ALSO FOUND, 
WHEN A JUMPER/LINE PASSES TERMINALS WITHOUT 
ACTUALLY CONNECTING. GRAPHICALLY THEY APPEAR 

TO BE CONNECTED.

NUMBER OF CON-

NECTED WIRES >2
MORE THAN TWO WIRES ARE CONNECTED TO THE CON-

NECTION POINT. THE NUMBER CAN BE CHANGED.

NUMBER OF CON-

NECTED JUMPER 

LINKS >2

MORE THAN TWO JUMPER LINKS ARE CONNECTED TO 

THE CONNECTION POINT. THE NUMBER CAN BE 

CHANGED.

OVERLAPPING CON-

NECTION POINTS

WHEN TWO CONNECTION POINTS ARE POSITIONED ON 

TOP OF EACH OTHER.

NON-CONDUCTING 

LINE CONNECTED

YOU GET A WARNING WHEN YOU TRY TO CONNECT A 

NON-CONDUCTING LINE TO A TERMINAL, BUT YOU CAN 

IGNORE THE WARNING. THIS OPTION CAN SEARCH 

FOR NON-CONDUCTING CONNECTIONS IN THE PRO-

JECT.
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CABLES MIXED CABLES CHECK FOR MIXED CABLES MEANING MORE THAN ONE 

CABLE ON THE SAME LINK. (PREVIOUSLY THE CHECK 

WAS ONLY AVAILABLE IN CABLE LISTS).

CABLE ON JUMPER 

LINK

JUMPER LINKS CAN NOT BE PART OF A CABLE.

PLCS MISSING IO 
ADDRESS

MISSING IO ADDRESSES ON A PLC SYMBOL IS AN 

ERROR.

IO ADDRESS USED 

MORE THAN ONCE

CHECK WHETHER THE SAME ADDRESS MORE THAN 

ONCE IN THE PROJECT.

MISSING IO STATUS 

TYPE

IF YOU DECIDE TO USE THIS FUNCTION, YOU CAN 

CHECK FOR PLC SYMBOLS WITHOUT STATUS TYPE.

NET/ 
POTEN-

TIALS

REDUNDANT LINES CHECKS WHETHER A CONNECTION STILL EXISTS WHEN 

A CONDUCTOR IS REMOVED.

BROKEN NETS WHEN MOUNTING CORRECT DRAWING IS APPLIED 

INCORRECTLY, YOU CAN END UP WITH NETS WITHOUT 

CONNECTIONS. THIS FUNCTION CAN ALSO BE USED 

FOR CHECKING PROJECTS FROM PREVIOUS VER-

SIONS.

PARKED LINES CHECK FOR LINES WITHOUT CONNECTION TO SIGNALS 

OR OTHER SYMBOLS OR LINES.

MORE SIGNALS IN 

SAME POINT

CHECK FOR MORE THAN ONE SIGNAL SYMBOL IN THE 

SAME POINT.

MORE SIGNALS IN 

SAME NET

SHORT CIRCUIT – CHECK FOR MORE SIGNAL NAMES IN 

THE SAME NET.

NET WITHOUT SYM-

BOLS (UNREACHABLE 

NET)

BOXES AND THE LIKE DRAWN WITH CONDUCTING LINES. 
THESE WILL BE CONSIDERED AS NETS BY THE PRO-

GRAM, BUT THEY WILL BE UNREACHABLE.

ONLY ONE CONNEC-

TION

A NET WITH ONLY ONE CONNECTION CAN NOT HAVE 

ELECTRICAL FUNCTIONS.

WIRE NUM-

BERS

MISSING OR MIS-

MATCH

LINKS WITHOUT WIRE NUMBERS OR DIFFERENT WIRE 

NUMBERS ON THE SAME LINK.

LINES/ 
WIRES 

MISSING NAME, 
TYPE, ARTICLE NUM-

BER, FUNCTION

LINES WITHOUT NAME/TYPE/ARTICLE NUMBER/FUNC-

TION IN COMPONENT DATA.

MISMATCH OF DATA 

IN SAME LINK

WHEN YOU USE DETAILED CONNECTION LISTS, THAT 

CONTAIN LINE DATA, THE PROGRAM CAN CHECK FOR 

DIFFERENT DATA (MISMATCH) ON TWO OR MORE SEG-

MENTS IN THE SAME LINK.

MOUNTING 

CORRECT 

MOUNTING CORRECT CHECKS WHETHER ALL CONNECTIONS ARE MADE WITH 

BENDS AND NOT DOTS.
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PRINTING

In Automation you can choose between just printing out the page you are pres-
ently working on, without changing any page settings, or specify which pages you 
wish to print, and how they shall be printed e.t.c.

If you only want to print out the page you are working on, and do not wish to make 
changes in the printer settings, click the Print this page button.

OPENING THE PRINT DIALOG BOX

The printing dialog box shown below is activated by choosing File => Print or by 
clicking on the Print pages button on the program toolbar. The short-cut key is 
<Ctrl+p>.

THIS CHAPTER DESCRIBES

— OPENING THE PRINT DIALOG BOX .............................................................p. 361

— THE RIGHT-HAND SIDE OF THE DIALOG BOX ...............................................p. 362

— SELECT PAGES ........................................................................................p. 362

— SETUP.....................................................................................................p. 364

— CHOOSE PRINTER....................................................................................p. 366

— BATCH PRINTING ......................................................................................p. 366

— IF DIAGRAMS ARE MINIMIZED WHEN PRINTING ............................................p. 366

— EXPORTING PDF FILES ............................................................................p. 366

— EXPORTING DWG/DXF FILES...................................................................p. 366
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THE RIGHT-HAND SIDE OF THE PRINTER DIALOG BOX

The right-hand side of the dialog box is identical for the tabs Select pages, Setup 
and Printer. Here you get an overview of what printing a page will result in.

You can also determine the number of copies, whether you want the pages printed 
in reverse order, or if you only want to print pages changed later than a specified 
date.

Projects are printed out as one document. This means the printing can not be 
interrupted by other jobs on a network printer.

When printing more than one copy of the project, an information is sent to the 
printer, specifying the number of copies. — This, however, requires that the printer 
driver is able to handle this information. If the printer driver can handle the informa-
tion "10 copies", this is obviously a lot faster than if the program should send the 
project to the printer ten times.

When more than one page and more than one copy is chosen, you can also 
choose Collate, if the chosen printer driver can handle the collate information.

If you wish to display the pages in the dialog box Print as they are printed, click on 
Print with preview.

The print settings are saved when you click on Close, and are in effect the next 
time you print pages.

Printing for Revision

If you are working on a revision — see “Revision 
control” on page 878 — and select From date, you 
get the option of choosing From revision date. 
This makes it possible only to print pages which 
has been changed since the start of the revision.

— See “Printing during revision control” on page 879 also.

SELECT PAGES

Choosing the Select 
pages tab, you specify 
which pages to print.

If you want to print 
page 2 to 4 in the pro-
ject, you click on page 
2, and press down 
<Shift> while clicking 
on page 4.

If you, on the other 
hand, want to select 
page 1 and 3, you click 
on page 1, and press 
down <Ctrl> while 
clicking on page 3.

If you choose All 
pages, Even pages, Odd pages or Current page, the selected pages are singled 
out in the list of project pages.
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Pages marked with a preceding ! character, have been changed since the project 
was opened.

Pages marked with a preceding + character, have been changed since the project 
was last saved.

When you select Select changed pages(+ !), all pages that have either changed 
since the project was last printed, or since the project was last saved, become 
selected.

If states are selected on project pages, the names of these states are displayed in 
brackets after the page title.

Last used page active

When a project page is marked as "Last used page", a checkmark will be set in the 
Last used page active checkbox at the bottom of the dialog box. This way you can 
for instance print all project pages until the page which is marked as the last used 
page. When you wish to print all project pages, just remove the checkmark in the 
Last used page active checkbox.

— To mark the active project page as the last used page choose Settings => Page 
data and select Last used page.

Printing Chapters and Dividers

When you click the Print pages button and click on the tab Select pages, you 
have the option to handle chapters and dividers easily:

This for instance makes it possible to print dividers on a different type of paper.

When you are printing on a duplex printer, you can also specify not to print dividers 
on duplex, by clicking on Dividers NOT duplex. This check box is dimmed if the 
selected printer can not handle duplex.

Printing pages with states

When pages in the active project are using states, you can select all project pages 
with a specific state selected, by doing this:

All pages in the chapter

are printed

Only Dividers are

printed

Prints all selected pages

except the selected

dividers

All pages except
list pages
mation

Page 363



P

Printing
 1) Click on State in the lower-right part of the dialog box

 2) You now get the option of choosing any of the applied states in the project: 
Choose a state

 3) All project pages using the chosen state are now selected. The name of the 
state is also displayed in the State field, and the selected state is listed in 
brackets after the page titles in the dialog box

Printing layers

If you click on Show layer settings, you can specify which layers or layer groups 
on the drawing to print. — See “Printing pages with layers” on page 531.

If you select Dim not active layers, will those layers, which are dimmed when dis-
played on screen, also be dimmed when printing. This is only an option when there 
exists more than one layer on the page.

— Read more about this in “The Layer menu” on page 528.

Printing lists

When one of the pages, that you wish to print, is a list page, the button Update all 
lists is displayed at the bottom of the Select pages tab.

When you click Update all lists before printing, the most recent changes in the 
project are included in the list pages.

However, if you do not click Update all lists before printing, the list pages are 
printed as they appear in the project. Therefore, if any changes has been made in 
the project since the list pages were last updated, these changes are not included 
in the printed list pages.

Under Settings => Special settings you can choose to display a reminder to 
remember to update the project lists before printing. — See “Special settings” on 
page 927, in particular “Printer and PDF dialog” on page 928.

SETUP

Selecting Setup enables you to 
define margins and orientation. But 
to do this, you first have to select 
Paper and margin setup.

When you click Adjust to printer, 
the program gives you the printable 
area of your printer through the fig-
ures in the margin fields.

When you have done this, you will 
see the area, specified by the mar-
gin settings, displayed by a red dash 
line. At the same time you will see 
the area the drawing fills out, indi-
cated by a fully drawn rectangle.

Also there are a number of functions, which make it easier to alter the printout to 
meet your requirements. The drawing can be scaled up and down, and can be 
moved on the paper.
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If you want a margin with room for holes in the paper, you must set the left margin 
to 20mm.

If you click on Auto below Orientation, Automation automatically orientates the 
page according to the paper.

If you deselect Centre drawing and set Scale to and Orientation to Auto, your 
drawing will be adapted to the chosen printer — with respect to the location and 
scaling.

If you choose Even pages under Mirror margin, the margin will be mirrored for the 
even pages in the project — In this context the first page in the project is page 
number 1. If you choose Odd pages the margin of the odd pages will be mirrored.

When you choose Duplex the project will be printed in duplex. — Margins are only 
mirrored when you choose Even pages or Odd pages.

Choose Color when you want to print the project in color.

On black and white printers, selecting Color gives you a printout using a grey tone 
scale. Please note that your printer might convert some colors to the color white. 
The color white will not be seen on the print.

Print zoom

To print a zoom, do the following:

 1) Click on the Zoom button, and make a zoom — see “Zoom” on page 42.

 2) Click the Print pages button, and click on the tab 
Settings.

 3) Choose Print zoom. If you need to move the 
selected zoom, click on the arrows next to Move 
drawing. When you press down <Shift> while 
clicking the arrows, the zoom is moved with three 
times bigger steps.

 4) Click on Print, and the chosen zoom is printed.

Print test page

If you are having difficulties printing the drawing on your printer, click Print test 
page. This will make the printer print out a test page, displaying the printable area 
of your printer, drawn with a thin line along the edges. The right, left, top and bot-
tom margins will also be printed in figures. These are given using one thousandth 
of a millimetre, making 5865um equal to 5.865mm. These settings are specified in 
your printer driver, and therefore are not changeable from the Automation pro-
gram. If the test print does not include all four lines, you have not chosen the cor-
rect printer driver for your printer.

A biased left or right margin, suggests that the printer is not feeding the paper cor-
rectly. If the printable area is biased towards the left- or the right hand side, placing 
the paper differently in the tray might help.

If you are having further difficulties, please contact your local supplier.

Click here to move the

chosen zoom
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CHOOSE PRINTER

The last option is the Printer tab, where you choose which printer to use for print-
ing. Here you also have the option of opening the general Windows dialog box for 
print settings. The settings in this dialog box have lower priority than the ones you 
define in the rest of the dialog box Print, and can be overruled.

When all settings have been set, click on Print in the right hand side of the dialog 
box.

The last used printer and settings for each printer is memorized by the program. 
However, if you have selected Ask when changing printer name, you will be 
asked whether to remember the chosen printer, when you select a new printer.

Alternative PCSCHEMATIC font

In the field Alternative PCSCHEMATIC font you can specify whether to replace 
the PCSCHEMATIC font when printing.

— See “Applying other fonts when printing/exporting PDF files” on page 368.

Displaying the printer name as a hint

When you let the mouse cursor rest over 
the Print pages button, the name of the 
selected printer is displayed as a hint.

BATCH PRINTING

Read more about this in “Batch printing” on page 889.

IF DIAGRAMS ARE MINIMIZED WHEN PRINTING

When printing, Automation squeezes all objects in the work area for each diagram 
page. This may result in that the drawing might be placed in e.g. the lower-left cor-
ner of the printed page. This is because objects are placed outside the frame of the 
normal diagram page.

Read more about this in “The Zoom All function during DWG/DXF import” on 
page 729 and “The Zoom All function” on page 43.

EXPORTING PDF FILES

— See “Intelligent PDF files” on page 367.

EXPORTING DWG AND DXF FILES

In Automation you can both export and import DWG and DXF files. Read more 
about this in “DWG and DXF files” on page 729.
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INTELLIGENT PDF FILES

In Automation you can export your projects as PDF files, where links for instance 
are generated between symbols for the same component on the diagram pages.

EXPORT A PDF FILE

You can start the export of the active project as a PDF file in three different ways:

a) Choose File => Export to => PDF, or

b) Choose File => Save as and choose PDF files (*.pdf) below File type at the 
bottom of the dialog box, or

c) Press <e>

This opens the Setup tab in the dialog box PDF export:

On the Setup tab you have the following options:

THIS CHAPTER DESCRIBES

— EXPORT A PDF FILE.................................................................................p. 367

— QUICK SETUP...........................................................................................p. 368

— FONTS WHEN CREATING PDF FILES ..........................................................p. 368

— SPECIFYING WHICH PAGES TO INCLUDE IN THE PDF FILE ...........................p. 369

— COMMAND FILES FOR CONVERTING PROJECTS TO PDF FORMAT ................p. 369

Specify the reso-
lution in the PDF file

Page size
in the PDF file

Select which layer to print
via the Layer menu

Update all lists
before printing

Select which
pges to export
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Use PDF export folder

When you select Use PDF export folder, the PDF file is saved in the folder speci-
fied for Directories for PDF files. Read more about this in “Directories” on 
page 911. If this option is not selected, the PDF file is saved in the same folder as 
the project.

Active reference links

When you select Active reference links, links are inserted on the following 
objects in the PDF file:

- Active links between symbols in project pages

- Active links from components in lists to components in the project

- Active links from chapter tables of contents to the mentioned project pages

As you can see, the generated PDF files contains almost all links and references 
from the original project files.

Furthermore, you can specify how to zoom when clicking on a link in the PDF file:

- Jump to zoom: The zoom is on the selected symbol on the page.

- Jump to full page: The full page, where the symbol is placed, is displayed.

Symbol popup information

When you select Symbol project information, the generated PDF file will contain 
popup information for the symbols in the project pages.

Line data popup information

When Line data popup information is selected, the PDF file will contain popup 
information for line data on the project pages.

Quick setup

At the bottom of the Setup tab in the dialog box PDF export you can save the 
selected settings by clicking the Save button.

If quick settings are already created, you can select these by clicking on them in 
the list at the bottom of the tab or by clicking on the Open button.

Fonts when creating PDF files

When exporting/printing a project as a PDF file, all PCSCHEMATIC fonts will be 
turned into graphics. Due to the search facilities in the Acrobat program, it is pos-
sible to search on texts using Windows fonts in the PDF file.

Please note, that it is not correct to use Windows fonts on diagram pages accord-
ing to the standards.

APPLYING OTHER FONTS WHEN PRINTING/EXPORTING PDF FILES

When printing/exporting PDF files, it is possible to substitute the PCSCHEMATIC 
font with for instance the Arial font, which is the Windows font that is most similar 
to a CAD font. This function is specially designed for creating PDF files.

This makes it possible to apply the PCSCHEMATIC font in the project, and to get 
texts which you can search on in the PDF file. These texts will also become 
smoother in the PDF files than texts using the PCSCHEMATIC font.
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To do this, you must select the Arial font in the Alternative PCSCHEMATIC font 
field. You also have the option of choosing other fonts.

SPECIAL CHARACTERS IN PDF FILES

If you change texts written with the PCSCHEMATIC font to a Windows font, nega-
tion and underlining will give an incorrect result. The earth character and other 
special characters may also give incorrect results, depending on which font you 
use. — See “Special characters when changing the PCSCHEMATIC font to a 

Windows font” on page 134.

Specifying which pages to include in the PDF file

When you click the Select pages tab in the dialog box PDF Export, you can select 
which pages to include in the PDF file:

This is done as in the Print dialog box, which is described in “Select pages” on 
page 362.

Command files for converting projects to PDF format

It is possible to create command files, which automatically saves Automation pro-
jects as PDF files. Read more about this in “Command files for saving projects as 
PDF, DWG and DXF files” on page 888.

SPECIAL CHARACTERS AND WINDOWS

THE FONTS YOU GET WITH OLDER VERSIONS OF WINDOWS, DOES NOT CON-

TAIN SPECIAL CHARACTERS. WHEN A SPECIAL CHARACTER DOES NOT EXIST 

IN A SELECTED FONT, A SQUARE IS DISPLAYED IN STEAD OF THE SPECIAL 

CHARACTER.

THE FONTS YOU GET WITH WINDOWS VISTA AND SUCCEEDING VERSIONS 

CONTAINS SPECIAL CHARACTERS.

THE PCSCHEMATIC FONT CONTAINS THE NECESSARY SPECIAL CHARAC-

TERS.
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Windows Explorer as Symbol/Project menu

WINDOWS EXPLORER AS SYMBOL/PROJECT MENU

USING THE WINDOWS EXPLORER AS A PROJECT MENU

In Automation it is possible to use Windows Explorer as a kind of Project menu.

When you have opened Windows Explorer, you can therefore drag project files 
from the Explorer to the Automation program, whereby the projects are opened.

When you select several projects at a time, all of the selected projects will be 
opened in Automation:

USING THE WINDOWS EXPLORER AS A SYMBOL MENU

In Automation it is possible to apply Windows explorer as a kind of Symbol 
menu.

As described for projects, you can apply the Windows Explorer to drag symbols 
into an open project. Hereby you get the symbol directly in the cross hairs in 
Automation. You can therefore apply the Windows Explorer as an alternative sym-
bol menu, which you can keep open while working with Automation.

You can only fetch one symbol at the time from the Windows Explorer.

If you open two copies of Windows Explorer, you can apply the one to open pro-
jects from, and the other to fetch symbols from.

THIS CHAPTER DESCRIBES

— USING THE WINDOWS EXPLORER AS A PROJECT MENU .............................p. 370

— USING THE WINDOWS EXPLORER AS A SYMBOL MENU...............................p. 370

Select the files in the

Explorer, and drag

them over to the active

Automation program



In PCSCHEMATIC Automation you can apply refer-
ence designations in the naming of your symbols/
components. Reference designations can be 
defined freely, and are not tied to any specific stand-
ard, but the program makes it easy to follow the ISO/
IEC/EN 81346 standard.

- On reference designations.................................p. 373

- Defining reference designations for projects..p. 381

- Settings for reference designations .................p. 387

- Import/export of reference designations ........p. 396

- Reference designations in the
Explorer window.................................................p. 399

- Reference designations for symbols................p. 400

- Reference designations for reference frames /
areas, pages and chapters ..............................p. 405

- Reference designations: Datafields and lists ..p. 417

- Select/deselect options using
reference designations .....................................p. 418

LEARN MORE ABOUT REFERENCE DESIGNATIONS

IN THE BOOK "ELECTRICAL DOCUMENTATION ACCORDING 

TO STANDARDS", YOU CAN READ MORE ABOUT APPLYING 

REFERENCE DESIGNATIONS IN ELECTRICAL DOCUMENTA-

TION. THE BOOK IS PUBLISHED BY PCSCHEMATIC A/S.

Reference designations
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ON REFERENCE DESIGNATIONS

Reference designations are used in Automation for naming objects — this being 
symbols/components and groups of these.

Reference designations are constructed hierarchically, which makes it easy to 
understand how an object with an assigned reference designation is part of a 
larger picture.

Reference designations for a component are placed next to its symbol(s) in the dia-
grams, and on / next to the physical component, where it is placed/mounted.

Automation supports reference designations according to the ISO/IEC/EN 81346 
standard, but is also open for using reference designations in other ways. It is 
therefore both possible to use an internal company standard and to follow chang-
ing international standards.

ADVANTAGES WHEN USING REFERENCE DESIGNATIONS

When you use reference designations, you for instance get the following advan-
tages:

• You get a clearly structured documentation, where it is easy to identify the indi-
vidual objects and which contexts they are parts of (constituents of).

• You make it easier for different professions to talk about the same issues seen 
from their individual perspectives. — See “Aspects” on page 374.

• It makes it easier for different subcontractors to contribute to the same project / 
the same documentation.

• It makes it easier to reuse the structure from other parts of the documentation.

• It makes it easier to generate documentation with selected/deselected options. 
— See “Projects with selectable options” on page 578.

• If for instance you use reference designations for describing a full production 
plant, you can subsequently easily generate a list containing all products, 
another containing all functions and yet another containing all positions.

THIS CHAPTER DESCRIBES

— ADVANTAGES WHEN USING REFERENCE DESIGNATIONS..............................p. 373

— ASPECTS .................................................................................................p. 374

— PREFIXES ................................................................................................p. 375

— SPECIFYING LEVELS IN ASPECTS ...............................................................p. 375

— REFERENCE DESIGNATIONS IN ONE OR MORE LINES...................................p. 375

— CHARACTER FOR FULL REFERENCE DESIGNATION ......................................p. 376

— REFERENCE DESIGNATIONS ON PAGES AND IN REFERENCE FRAMES ...........p. 376

— EXAMPLE OF COMBINED ASPECTS .............................................................p. 379

— EXAMPLE OF SEPARATE ASPECTS .............................................................p. 380
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Before defining the reference designations, you should have an overview over 
which functions as well as which switchboards/racks and other positions you will 
need in your project.

ASPECTS

A reference designation in Automation can contain up to three different aspects:

- The function aspect

- The position aspect

- The product aspect

You can understand an aspect as "a pair of glasses" that you can put on, when you 
look at the objects (symbols e.t.c.) in a project from a specific perspective. When 
you put on another pair of glasses (use another aspect), you look at the project in 
another way.

Depending on which aspect you use, you can therefore look at the objects as func-
tions (the function aspect), as positions (the position aspect) or as products (the 
product aspect).

Aspects and designations

It is important to be aware that you use the term aspect when you talk about differ-
ent ways that you can look at the documentation / the project from an overview 
position. However, when you talk about what an aspect contains for a specific 
object, you use the term designation instead.

If for instance it says -P1 in the product aspect for a component, you say that the 
component has the product designation -P1.

Separate aspects or Combined aspects

When you use reference designations for identifying objects, you have to choose 
whether to work with the aspects as separate aspects or as combined aspects.

Separate aspects (Recommended)

You can choose that each individual aspect identifies an object. This is called sep-
arate aspects. This way you can let the function aspect, the position aspect and the 
product aspect each identify the objects.

This can give you the following advantages:

- Different involved parties can talk about the same object from their individual 
understanding, and they can all identify the objects from their own perspective. 
When some talk about functions others can talk about positions and others 
again about products — and they can all identify what they are talking about, 
from their own perspective.

- Separate aspects typically makes it easier to get an overview over complex 
assignments. Here you can for instance just look at the functions or products, 
depending on where your focus is.

- See an example in “Example: Separate aspects” on page 380.
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Combined aspects

You can also choose to identify an object by combining aspects, which is called 
combined aspects. Here it is for instance the function aspect and the product 
aspect which in combination identifies the object.

— See an example in “Example: Combined aspects” on page 379.

PREFIXES

Each individual aspect have an assigned prefix, which is a character that you place 
in front of each aspect, that makes it easy to identify the aspect:

- The standard prefix for the Function aspect is: =

- The standard prefix for the Location aspect is: +

- The standard prefix for the Product aspect is: -

ASPECT LEVELS

A reference designation for an aspect contains of a prefix, which typically is placed 
in front of a capital letter, which is followed by an integer. For instance -M01.

Because reference designations are constructed hierarchically, each aspect can 
contain multiple levels. These levels are typically specified by a separator, but it is 
also allowed according to the standards to omit a separator. According to the ISO/
IEC/EN 81346 standard, the following options are allowed:

Please note that the option No separator above requires that the individual levels 
consists of a letter followed by an integer.

REFERENCE DESIGNATIONS ON ONE OR MORE LINES

When you display different aspects in the reference designation on individual lines, 
this means, according to the standards, that each individual line identifies the 
object (separate objects).

According to the standards the character / can also be used for specifying line 
breaks.

ARE COMBINED ASPECTS MAKING IT UNNECESSARILY COMPLICATED?

PLEASE BE AWARE THAT YOU CAN END UP MAKING IT MORE COMPLICATED 

FOR YOURSELF, IF YOU IN THIS WAY MAKES THE ASPECTS DEPEND ON EACH 

OTHER. FOR IS IT ALWAYS COMPLETELY CLEAR WHICH ASPECT DEPENDS ON 

WHICH? IS IT FOR INSTANCE THE POSITION THAT DEPENDS ON THE FUNC-

TION — OR IS IT THE OTHER WAY AROUND?

SEPARATOR BETWEEN LEVELS IN ASPECTS EXAMPLE

PREFIX AS SEPARATOR -A1-B1-C1

DOT AS SEPARATOR -A1.B1.C1

SPACE AS SEPARATOR -A1 B1 C1

NO SEPARATOR -A1B1C1
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This gives the following options for representing reference designations:

Please note that quite a few projects created in version 17 and previous versions 
will be of the type A single reference designation (combined aspects).

We now recommend to use separate aspects, which also is the default setting for 
Automation. — See “Separate aspects or Combined aspects” on page 374.

CHARACTER SPECIFYING FULL REFERENCE DESIGNATION

If the character > is displayed in front of a reference designation — e.g. >-K1 — 
this means that -K1 is the full reference designation for the component. -K1 there-
fore unambiguously identifies the component.

Please note, that this character can therefore also appear when no reference 
designation has been specified for a component.

— See “Do not display sign for full reference designation (>)” on page 391.

REFERENCE DESIGNATIONS ON PAGES AND REFERENCE FRAMES

In Automation you can also specify reference designations for pages and for 
areas on individual pages (reference frames).

Reference frames on pages

It is possible to specify that all symbols on a project page e.g. belongs to Pumping1 
(=M1) and are located in Hall2 (+R2).

If a symbol has the reference designation =M1/+R2/-K5, and you have specified 
the reference designation for the page as =M1/+R2, only the remaining part of the 
reference designation — this being -K5 — will be displayed next to the symbol.

If a symbol does not have the same reference designation as the page, 
Automation automatically displays those of the designations that deviate from the 
reference designations of the page, preceded by the > character to specify that this 
is the full reference designation for the symbol.

— See how to assign reference designations to pages in “Reference designations 
for pages” on page 405.

THE SET OF REFERENCE 

DESIGNATIONS CONTAINS

REFERENCE DESIGNATIONS 

ON INDIVIDUAL LINES

REFERENCE DESIGNATIONS 

IN A SINGLE LINE

THREE REFERENCE DESIGNA-

TIONS (SEPARATE ASPECTS)
                    =A2
                     -B2
                    +C3

=A1/-B2/+C3

A SINGLE REFERENCE DESIG-

NATION (COMBINED ASPECTS)         =A1-B2+C3 =A1-B2+C3

TWO REFERENCE DESIGNA-

TIONS (HYBRID)
              =A1-B2
                   +C3 =A1-B2/+C3
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Reference designations for areas (reference frames)

You can create reference frames on project pages, which can make it easier to get 
an overview over the circuit diagrams. A reference frame specifies that all objects 
placed inside the reference frame have a specific reference designation.

It is also possible to specify other reference designations for individual objects 
inside the reference frame, as shown in “Example: Reference designation with 
three separate aspects” on page 378.

— You can see how to work with reference frames in Automation in “Reference 
designations for Areas on pages (Reference frames)” on page 407.

Example: Reference designations with a single aspect

Here you see the lamp -S1.P3 and the relay coil -S1.K7:

For both symbols inside the reference frame, you can see that the reference frame 
specifies the first level in the product aspect (-S1), and that the dot is the separator 
between the levels.

Example: Reference designation with two combined aspects

Here you see the lamp +S1-P2 and the relay coil +S1-K6:

In this case we are working with combined aspects. Therefore a - character is 
placed after the reference designation for the reference frame (a so-called "trailing 
prefix"). This specifies that the reference designation for the reference frame is to 
mation
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be put together with the designation for the symbol, even though it seems to be 
part of another aspect.

Example: Reference designation with three separate aspects

Here you see the relay coil =A1.C1/+C3.B3/-B2.S1.K2 and the lamp =A2/+C3.C5/
-P4:

In this case we are working with separate aspects.

Please note the following:

- The relay coil is assigned the designations from all of the surrounding reference 
frames. (The aspects are read individually).

- The > character in front of the function designation and the product designation 
for the lamp specifies that this is the full designation for these aspects. The 
location designation does not contain this character, because the location 
aspect is +C3.C5 (where +C3 comes from the outermost reference frame).

Please note that the outermost reference frame in this example could just as well 
have been the reference designation specified for the project page.
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EXAMPLE: COMBINED ASPECTS

Below you can see an example of combined aspects. Read more about combined 
aspects in "Separate aspects or Combined aspects" på side 374.

In the example above the function designation =M1 specifies that the symbol/com-
ponent is a part of the function =M1. This could for instance be "Pumping1". The 
location designation +R2 could for instance be "Hall2".

The product designation -K5 is used to identify the component name itself.

PRODUCT DESIGNATION / SYMBOL NAME

INSTEAD OF THE PRODUCT DESIGNATION FOR A SYMBOL, THE TERM SYMBOL 

NAME IS USED IN THE REST OF THIS MANUAL.

Function designation

Location designation

Component name

(function aspect)

(location aspect)

(product aspect)

For combined aspects:

The reference designation =M1+R2-K5 is interpreted like this:

The product/component -K5 is part of the location +R2, which is a part of

the function =M1.

/ Product designation

For a symbol you can see the following reference designation:

These three aspects in combination identifies the component,
because this is combined aspects.
mation

Page 379



P

On reference designations
EXAMPLE: SEPARATE ASPECTS

Below you can see an example of separate aspects. Read more about separate 

aspects in "Separate aspects or Combined aspects" på side 374.

Please note that the character / for specifying line breaks will be used for reference 
designations in lists.

Function designation

Location designation

Component name

(function aspect)

(location aspect)

(product aspect)

For separate aspects:

The reference designation =M1/+R2/-K5 is interpreted like this:

The product/component -K5 is placed in the location +R2

and is attatched to the function =M1.

/ Product designation

For a symbol you can see the following reference designation:

These three aspects each identify the component,
because they are separate aspects.
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DEFINING PROJECT REFERENCE DESIGNATIONS

To create reference designations in your project, you either click the Reference 
designations button or choose Settings => Project data and click Reference 
designations. 

You then enter the dialog box Reference designations:

In the dialog box Reference designations you can create and edit the Function, 
Location and Product aspects for the reference designations.

— Please note that reference designations can also be imported into the project 
and exported from the project, as described in “Import / export of reference desig-
nations” on page 396.

Click here

General settings

for the project

Show as list

Add, Delete and

Show pages

Delete unused
reference designations

Import/export
ref. des.

using selected

Export desig-

Edit designations

or tree
Show aspects

ref. des.

nations
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The first time you enter the dialog box, no reference designations will be specified.

DISPLAYING REFERENCE DESIGNATIONS IN THE DIALOG BOX REFER-

ENCE DESIGNATIONS

In the upper-left part of the dialog box Reference designations you can specify 
how to display the reference designations in the dialog box:

Display reference designations as hierarchy / Tree

When you click the Show as tree button, the reference designations are displayed 
as a hierarchical structure — see above.

The reference designations are hereby displayed as a folder structure, just like a 
folder structure you would find in the Windows Explorer, with similar possibilities for 
copying, deleting structure parts e.t.c.

Display reference designations as a list

When you click the Show as list button, the reference designations are displayed 
as a list, with all of the reference designations displayed at the same level — see 
above.

Please note that it is not possible to edit reference designations in list view.

OPTIONS IN THE DIALOG BOX REFERENCE DESIGNATIONS

— DISPLAYING REFERENCE DESIGNATIONS IN THE DIALOG BOX ......................p. 382

— SPECIFYING REFERENCE DESIGNATIONS....................................................p. 383

— SEE USED REFERENCE DESIGNATIONS ......................................................p. 383

— SORTING REFERENCE DESIGNATIONS BY COLUMN......................................p. 385

— EDITING REFERENCE DESIGNATIONS..........................................................p. 385

— DELETING REFERENCE DESIGNATIONS.......................................................p. 386

— MOVE A REFERENCE DESIGNATION TO A NEW POSITION .............................p. 386

— SETTINGS IN THE DIALOG BOX REFERENCE DESIGNATIONS.........................p. 387

Hierarchial display of

reference designations

List display of

reference designations
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ADDING NEW REFERENCE DESIGNATIONS

This is how to add a new function reference designation in the Function aspect 
section in the dialog box Reference designations. (Location and Product refer-
ence designations are added accordingly in the Location aspect and Product 
aspect section):

 1) Click on the function reference designation that you wish to create a new 
function reference designation under. If no function reference designations 
has been created yet, just click inside the Function aspect section.

 2) Click the New button at the bottom of the section — or press <Insert>.

 3) In the dialog box New: Type in a new function designation, a Description for 
the function designation and a Description 2 (which for instance can contain 
a description in another language or a number referring to an ERP system). 
In the dialog box the = character is suggested as the prefix for the reference 
designation, but you are free to use another prefix. (See “Settings according 
to standards” on page 390 for non-standard prefixes).
If a function reference designation is selected in the dialog box, the dialog 
box New will contain the data from this reference designation. This way you 
will not need to type in the same initial part of the description text more than 
once.

 4) Click OK when you have typed in the function aspect and its description.

SEE USED REFERENCE DESIGNATIONS

The reference designations cur-
rently applied in the project are 
marked with an Applied refer-
ence designation icon next to 
the reference designation.

Delete all unused reference designations

If you wish to delete all unused reference designations in the project, click the 
Delete unused button at the top of the dialog box.

IEC / EN STANDARD

THE CHARACTERS =, + AND - ARE IEC STANDARD PREFIXES FOR THE FUNC-

TION, LOCATION AND PRODUCT ASPECTS.
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See on which page the reference designations are used

If you wish to see which pages a reference designation is used on, select Show 
pages in the bottom-left corner of the dialog box, and the pages are displayed in 
the right-hand side of the dialog box:

If you then right-click on a page, and choose Go to page, the selected page is dis-
played in the project (you can also double-click on the page):

If you right-click on a page, and choose Show list of objects, a list is displayed, 
containing all the objects on the page with the selected reference designation:

In the left-hand side of the list, you can see the type of the objects. The list can be 
printed, or saved as a file.
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FOR LIST VIEW: SORTING REFERENCE DESIGNATIONS BY COLUMNS

Please note: This only applies for displaying reference designations as a list — see 
“Display reference designations as a list” on page 382.

In the dialog box Reference designations you can sort the reference designations 
alphabetically based on the columns Function aspect, Location aspect and 
Position aspect as well as Description for the reference designations.

This is done as described in “The sorting order of the data in the Object Lister” on 
page 344.

Dragging a reference designation to a new position in the dialog
box Reference designations

When you wish to move a reference designation to another position in the list of 
reference designations, do this by clicking on the reference designation, and then 
drag it to the desired position:

The reference designation is placed just below the reference designation, that you 
point on when you release the mouse button.

If you drag a reference designation beyond the top or the bottom of the list, the list 
starts scrolling.

The last used reference designation will be memorized for the next time the dialog 
box is opened.

EDITING REFERENCE DESIGNATIONS

If you wish to change a reference designation, click on it and click the Edit button 
at the bottom window for the aspect — or click on the reference designation and 
press the <F2> key.

If you change a reference designation with underlying reference designations start-
ing with this reference designation, you will be asked whether these should be 
changed also. If you change the reference designation =G1 to =G2, you can for 
instance have the reference designation =G1A2 changed to =G2A2 automatically.

DESCRIPTIONS FOR UNDERLYING ASPECTS ARE NOT CHANGED!

PLEASE NOTE THAT ONLY DESIGNATIONS FOR UNDERLYING ASPECTS ARE 

CHANGED. IF FOR INSTANCE YOU CHANGE +A1 TO +A3 AND ALSO CHANGE 

THE DESCRIPTION FROM FLOOR 1 TO FLOOR 3, THIS CHANGE IN THE 

DESCRIPTION IS NOT TRANSFERRED TO THE UNDERLYING ASPECTS, WHEN 

THE +A1 ASPECTS ARE CHANGED TO +A3.

Click here

Drag the line to the

desired position

Release the mouse

button
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Changing reference designations for more than one page

To change reference designations for more than one page at a time, see “Edit refe-
rence designations for more than one page” on page 412.

Changing reference designations for Chapters

Changing reference designations for a full chapter, see “Editing reference designa-
tions for chapters” on page 412.

DELETING REFERENCE DESIGNATIONS

To delete a reference designation, click on it and click the Delete button at the bot-
tom of the aspect window— or press the <Delete> key.

MOVE A REFERENCE DESIGNATION TO A NEW POSITION

To move a designation to a new position — for instance from being placed under 
=W3 to be placed under =W4 — do this:

 1) In the dialog box Reference designations: Right-click on the designation 
and select Cut

 2) Right-click on the designation, that you wish to place the designation under, 
and select Insert

The designation has now been moved.

If the designation has any sub designations, these are also included, when you 
move the designation. If the designation and its sub designations are used in the 
project, these are automatically renamed for all relevant objects in the project.

REFERENCE DESIGNATIONS IN THE PAGE MENU

When you use reference designations in a project, the reference designations also 
appear in the Page menu.
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SETTINGS FOR REFERENCE DESIGNATIONS

When you click on the Settings button at the top of the dialog box Reference des-
ignations, you enter the dialog box Reference designations - Settings. In the 
dialog box you have the following tabs:

FORMAT FOR REFERENCE DESIGNATIONS

On the Format tab in the dialog box Reference designations - Settings you 
specify the format for the reference designations in the project.

In the upper-right corner of the tab, you can see an illustration of the format that will 
be applied using the current settings.

TABS IN THE DIALOG BOX "REFERENCE DESIGNATIONS - SETTINGS"

— FORMAT: FORMAT FOR REFERENCE DESIGNATIONS ...................................p. 387

— STANDARD: SETTINGS WITH RESPECT TO STANDARDS ...............................p. 390

— IMPORT: IMPORT SETTINGS FOR REFERENCE DESIGNATIONS ......................p. 393

— GENERAL: GENERAL SETTINGS FOR REFERENCE DESIGNATIONS ................p. 395
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Sets of aspects

Under Sets of aspects you specify — as an overall setting — whether to work with 
Separate aspects or Combined aspects — see “Aspects” on page 374, particu-
larly “Separate aspects or Combined aspects” on page 374.

Please note that the aspects are displayed differently under Aspects, which clari-
fies that combined aspects are hierarchical, while separate aspects consists of 
more than one aspect.

Click Edit to select/deselect aspects or to change their order. This brings you into 
the dialog box Edit aspects, where you have the following options:

The settings here applies for the graphical representation of reference designa-
tions on diagram pages and in lists.

Line breaks

This option normally only appears for Separate aspects, but can also appear for 
Combined aspects.

The aspects are displayed differently

Select/deselect aspectsMove the selected aspect up/down
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Line breaks for Separate aspects

If you select Between all aspects in the set, the aspects are positioned on indi-
vidual lines in the project. If not, the aspects are written in the same line, separated 
by the / character.

If you have selected Allow unauthorised line breaks between individual 
aspects on the Standard tab, you get extra options under Line breaks. Here you 
can choose either Between all aspects in the set, After product, After function 
and/or After location.

Line break - for combined aspects

If you have selected Allow line break between aspects on the Standard tab, you 
get extra options under Line breaks. Here you can choose either After product, 
After function and/or After location.

Delimiters between levels

Here you specify which delimiter to use between the levels within each aspect. You 
have these options, which all follows the IEC 81346 standard:

Prefixes

This option only appears when you have 
selected Allow non-standard prefixes on the 
Standard tab. If you choose non-standard pre-
fixes here, this should be documented in the pro-
ject, in order to follow the standards.

For Function, Location and Product you can 
here choose either None/User defined, Stand-
ard or Space.

None/User defined can be used for either not using a prefix, or for typing in a pre-
fix yourself. The latter is not recommended because Automation does not contain 
automatic functions for supporting user defined prefixes.

OPTION DESCRIPTION

NO DELIMITER

(-A1B1C1)
THE LEVELS ARE WRITTEN AS A LONG STRING OF CHARACTERS 

WITH NO DELIMITER TO SEPARATE THEM.

DOT (DEFAULT)
(-A1.B1.C1)

THE LEVELS ARE SEPARATED BY A DOT. THIS IS THE DEFAULT 

CHOICE.

SPACE

(-A1 B1 C1)
THE LEVELS ARE SEPARATED BY A SPACE CHARACTER.

PREFIX

(-A1-B1-C1)
THE LEVELS ARE SEPARATED BY THE CHOSEN PREFIX FOR THE 

ASPECT.
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SETTINGS ACCORDING TO STANDARDS

When you click the Settings button at the top of the dialog box Reference desig-
nations, you enter the dialog box Reference designations - Settings. On the 
Standard tab in the dialog box you can specify nonconformities to the ISO/IEC/EN 
81346 standard.

On the Standard tab you have different options depending on whether you have 
chosen Combined aspects or Separate aspects on the Format tab.

When you select options on the Standard tab, this can also cause additional 
options to occur on the Format tab.

PROJECTS FROM VERSION 17 AND PREVIOUS VERSIONS

IDEALLY NOTHING SHOULD BE SELECTED ON THE STANDARD TAB, BECAUSE 

ALL SELECTIONS HERE ARE NONCONFORMITIES TO THE STANDARD.

WHEN YOU OPEN A PROJECT FROM VERSION 17 OR PREVIOUS VERSIONS, 
SOME OF THE OPTIONS WILL MOST LIKELY BE SELECTED. THIS REFLECTS 

THAT THE REFERENCE DESIGNATION SETTINGS IN THE PROJECT HAVE NOT 

BEEN FULLY CORRECT ACCORDING TO THE STANDARDS.

IF/WHEN YOU DESELECT THE SELECTED OPTIONS ON THE FORMAT TAB AND 

CLICK OK, THE PROJECT IS CORRECTED SO THAT THE REFERENCE DESIG-

NATIONS NOW FOLLOW THE STANDARDS. IF YOU DON’T CHANGE THESE SET-

TINGS, THE PROJECT REMAINS UNCHANGED, AND YOU CAN CONTINUE 

WORKING AS BEFORE.
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Do not display sign for full reference designation (>)

When the character > appears as the first character for a reference designation, it 
specifies means that it is the full reference designation for the component. The dis-
played reference designation next to the symbol is therefore not meant to be put 
together with either the reference designation for the page or any reference desig-
nations for any reference frames, which the symbol is placed inside. If it therefore 
says >+A1-P2 next to a symbol, this means that +A1-P2 is the full reference desig-
nation for the symbol.

If you select Do not display sign for full reference designation (>), you make it 
much harder to interpret the reference designations in the project correctly — and 
you deviate from the standard.

Please note: For separate aspects a > character can appear in front of each of the 
aspects.

Options for Combined aspects

When you have selected Combined aspects on the Format tab, you have the fol-
lowing options:

Allow line break between aspects

When you are working with Combined aspects and select Allow line break 
between aspects, it will appear like you are working with Separate aspects. This 
will be misleading in the documentation, and is therefore not recommended.

If you select Allow line break between aspects, you will get additional options on 
the Format tab, where you can specify how to insert the line break. — See “Line 
breaks” on page 388.
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Do not show trailing prefix on reference designations on ref. frames
When you are working with Combined aspects, the reference designation for a ref-
erence frame must, according to the standard, contain a trailing prefix for the suc-
ceeding aspect.

You can deselect this by choosing Do not show trailing prefix on reference des-
ignations on ref. frames.

Options for Separate aspects

When you have selected Separate aspects on the Format tab, you have the fol-
lowing options:

Don’t display slash between separate aspects

In lists, and for individual settings for symbols and reference frames, there must, 
according to the standards, be a slash character separating the aspects.

You can deselect this by choosing Don’t display slash between separate 
aspects.

Allow unauthorised line break between individual aspects

When you choose Allow unauthorised line break between individual aspects, 
you get the option of specifying how to insert the line break on the Format tab.
— See “Line breaks” on page 388.

Allow non-standard prefixes

When you choose Allow non-standard prefixes, you get the option of specifying 
which prefixes you want to use, at the bottom of the Format tab.

— See “Prefixes” on page 389.
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IMPORT SETTINGS FOR REFERENCE DESIGNATIONS

When you click the Settings button at the top of the dialog box Reference desig-
nations, you enter the dialog box Reference designations - Settings. On the 
Import tab in this dialog box you can specify which settings applies for importing 
reference designations.

In the upper-right corner of the tab, you can see an example of the reference desig-
nation format specified by the current settings.

Format as defined on the Format tab

When you select Format as defined on the Format tab, the settings specified on 
the Format tab are used when importing (recommended setting).

When you select this option you make it easier for yourself to import the exported 
file again, if you later make changes in the file using for instance Excel — for 
instance for IO lists for PLC’s.

Delimiters between levels

If you do not choose Format as defined on the format tab, you can specify which 
Delimiter between levels to apply:

Letter followed by number

When Letter followed by number is selected, the program interprets letters fol-
lowed by a number as an individual level in an aspect:

• A1, BB2 and ABC3 will therefore be interpreted as a designation containing a 
single level.
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• A1BB2 will be interpreted as a designation containing two levels.

When Letter followed by number is not selected, the program will not interpret 
letters followed by numbers as the specification of levels in reference designations.

Dot

When Dot is selected, the program understands dots in reference designations as 
specifications of levels:

1, A and 112 will be interpreted as a designation in one level.

• A.B, 1.A and 1.12 will be interpreted as a designation in two levels.

Space

When Space is selected, space characters will be interpreted as specifications of 
levels.

Support of KKS codes

On the Import tab you can also specify that you wish to import KKS codes, and 
make these behave hierarchically.

When the KKS codes appears in the project, these can also be presented without 
a separator, which you can specify on the Format tab.

You have these two options:

- 1-letter codes/numbers (KKS)

- 1-letter codes/numbers (KKS) w/leading 3-letter code
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GENERAL SETTINGS FOR REFERENCE DESIGNATIONS

When you click the Settings button at the top of the dialog box Reference desig-
nations, you enter the dialog box Reference designations - Settings. On the 
General tab you can specify whether/how to insert reference designations in the 
project for specific symbol types:

Insert location designations on cables

Because location reference designations are not typically assigned to cables (a 
cable runs from one location to another), you can here specify whether to Insert 
location designations on cables.

This setting specifies whether to automatically insert a location reference designa-
tion for a cable, when the cable is placed on a page with reference designations.

Insert reference designations on signals

To assign signal references to signals: Select Insert reference designations on 
signals. — Please see “Insert Reference designations on Signals automatically” 
on page 232.

Insert reference designations on wire numbers

To include reference designations in wire numbers: Select Insert reference desig-
nations on wire numbers.
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IMPORT / EXPORT OF REFERENCE DESIGNATIONS

Reference designations can be exported/imported to/from Excel and to/from 
comma separated files (*.csv files).

IMPORTING REFERENCE DESIGNATIONS

When importing reference designations via an Excel file, the reference designa-
tions must be created as texts in the Excel file. During the import the reference 
designations are created automatically in the active project based on their prefixes 
(=, + and -).

In “Import settings for reference designations” on page 393 you can see how to 
specify how Automation understand the reference designation files.

— See an example of an Excel file with reference designations in Pcselcad/Lists/
ref-designations_uk.xlsx.

Import the reference designations

When you wish to import reference designations, click the Import button at the top 
of the dialog box Reference designations — or right-click in the dialog box and 
select Import. You the get the option of choosing which file you wish to import ref-
erence designations from.

When you have selected the file, you enter this dialog box:

To the left in the dialog box, you can see the status for the different reference des-
ignations:

ON IMPORT AND EXPORT OF REFERENCE DESIGNATIONS

— IMPORTING REFERENCE DESIGNATIONS .....................................................p. 396

— EXPORTING REFERENCE DESIGNATIONS ....................................................p. 397

— FORMAT FOR REFERENCE DESIGNATION FILES ...........................................p. 398

+ NEW REFERENCE DESIGNATION, WHICH IS ADDED TO THE PROJECT.

GREEN SQUARE REFERENCE DESIGNATION, WHICH ALREADY EXISTS IN THE PROJECT.

YELLOW SQUARE THE REFERENCE DESIGNATION ALREADY EXISTS IN THE PROJECT, 
BUT HAS ANOTHER DESCRIPTION. AFTER IMPORTING, THE IMPORTED 

DESCRIPTION FOR THE REFERENCE DESIGNATION WILL BE USED IN 

THE PROJECT.
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If you do not wish to import some of the reference designations, select the 
unwanted reference designations in the dialog box, and click the Remove button in 
the right-hand side of the dialog box:

Then import the remaining reference designations by clicking OK.

Import reference designations for individual aspects

To import reference designations for just one of the aspects — for instance the 
Location aspect — do one of the following:

a) Right-click in the Location aspect area and select Import Location desig-
nations — or

b) Click in the Location aspect area and click the Import Location designa-
tions button at the bottom of the area for the location aspect.

Then continue as described in “Import the reference designations” on page 396.

EXPORTING REFERENCE DESIGNATIONS

When you want to export the project reference designations, you have two options: 
You can export all reference designations in the project, or just export the reference 
designations for one of the aspects.

• To export all reference designations in the project: Click the Export all button at 
the top of the dialog box Reference designations.

• To export all reference designations for 
one of the aspects: Click inside the 
window for the relevant aspect (for 
instance the location designation) 
and click the Export Location des-
ignations button at the bottom of the 
window — or right-click in the win-
dow and choose Export Location 
designations.

PREFIX NOT INCLUDED DURING THE IMPORT

WHEN YOU IMPORT REFERENCE DESIGNATIONS FOR AN INDIVIDUAL ASPECT, 
IT IS NOT TAKEN INTO CONSIDERATION WHICH PREFIX IS USED — OR 

WHETHER A PREFIX IS USED — IN THE FILE THAT YOU IMPORT FROM.

IN OTHER WORDS: YOU HAVE TO MAKE SURE THAT IT IS THE RIGHT ASPECT 

THE FILE IS IMPORTED TO!
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Specify the file format for the reference designation file

When you choose to export reference designations, you enter a dialog box, where 
you specify where to save the reference designations file, and specify whether to 
save the file as an Excel file or as a CSV file.

FORMAT FOR REFERENCE DESIGNATIONS FILES

The applied format for reference designations files, is displayed in the figure below:

Format in

Excel files

Format in

CSV files
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REFERENCE DESIGNATIONS IN THE EXPLORER WIN-

DOW

When you have created reference designations 
in the active project, these are displayed on the 
Projects tab in the Explorer window at the left 
side of the screen. Here you find the reference 
designations under Components.

When you click on a symbol in the project, and 
then click the Show selected symbol button at 
the upper part of the Projects tab, the reference 
designations for the component are displayed on 
the tab:

This also makes it possible to jump directly to the other symbols for the compo-
nents on the project pages by double-clicking on them in the Explorer window.

— You can read more about the Projects tab in the Explorer window in “The 
Explorer window: The Projects tab” on page 335.
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REFERENCE DESIGNATIONS FOR SYMBOLS

SELECTING REFERENCE DESIGNATIONS WHEN PLACING SYMBOLS

When you have activated the reference designations in the Project data dialog 
box, you can apply reference designations when you place symbols in the project.

THIS CHAPTER DESCRIBES

— REFERENCE DESIGNATIONS WHEN PLACING SYMBOLS................................p. 400

— EDITING REF. DES. FOR ALREADY PLACED SYMBOLS ..................................p. 403

— EDITING REF. DES. USING THE SELECT NAME FUNCTION.............................p. 403

— PRECEDING "-" IN SYMBOL NAMES.............................................................p. 403

— INSERTING REFERENCE DESIGNATIONS FOR SIGNAL SYMBOLS ....................p. 404

Click here
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Choosing reference designations when placing symbols

When you click on the tab Ref. design. and then Select, you enter this dialog box:

Here you select the desired reference designation, and click OK. If one of the 
aspects shall not be a part of the symbol name, you click on Top node = none 
under the aspect.

If you wish to create a new reference designation, click on New, and create the ref-
erence designation — see “Adding new reference designations” on page 383.

When you return to the Component data dialog box, you can see the reference 
designation on the tab Ref. design. in the lower part of the dialog box.

ONLY CREATED ASPECTS DISPLAYED

WHEN PLACING SYMBOLS, THE DIALOG BOX REFERENCE DESIGNATIONS 
ONLY DISPLAYS THE ASPECT WHICH HAVE BEEN CREATED IN THE PROJECT.

IF FOR INSTANCE YOU HAVE NOT CREATED A PRODUCT ASPECT, THIS PART 

OF THE DIALOG BOX IS NOT DISPLAYED, AND THE FUNCTION AND LOCATION 

ASPECT WINDOWS FILL ALL OF THE DIALOG BOX.
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Displaying the page reference designation and the most

recently applied reference designations

When you click on the down-arrow next to the Location field, the location refer-
ence designation for the page and the most recently applied location reference 
designations are displayed. You can then select a location reference designation in 
the list.

The location reference designation for the page and the most recently applied loca-
tion reference designation are displayed in the top of the list.

You can do just the same for function and product reference designations.

Short-cut keys

These functions have the short-cut keys <Ctrl+f> for function reference designa-
tions, <Ctrl+l> for location reference designations and <Ctrl+p> for product refer-
ence designations. The Ref.design. tab is automatically displayed when the short-
cut keys are pressed.

Show full Reference designation

Because the page can be assigned a reference designation, and because the sym-
bol can be placed in an area on the page containing reference designations, only 
the part of the reference designations that are different from the page or the area is 
displayed.

If you wish to display the full reference designation, select Show full Reference 
designation. However, this is not recommended because the reference designa-
tion hereby can be misinterpreted!

— See “Character specifying full reference designation” on page 376 also.

Individual control of reference designations with line breaks from
Component data

Under Settings => Project data => Reference designations => Setup you can 
specify that the reference designations are displayed in more that one line, as a 
general setting for the project.

In the dialog box Component data on the tab Ref.design., you can — for the 
selected symbol — deselect this setting by removing the check mark in the check 
box Reference designation with line break: Project controlled.

Click here ... and select the designation here
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When the check mark is removed, you get the following option:

You can then select/deselect Reference designation with line break for the 
selected symbol, independent of the general project settings. However, this is not 
recommended because it will be misleading according to the standards!

Type in the symbol name / product reference

Now type in the symbol name and click OK.

EDITING REFERENCE DESIGNATIONS FOR PLACED SYMBOLS

When you want to assign reference designations to a group of placed symbols, do 
the following:

 1) Click the Symbols button and select the symbols

 2) Right-click on the selected symbols, and choose Component data

 3) In the dialog box Component data: Click on the tab Ref.design. and click 
on Select

 4) In the dialog box Reference Designations: Choose reference designation 
and click OK

 5) In the dialog box Component data: Click OK

 6) Click somewhere on the page — to deselect the symbols

You have now assigned reference designations to the selected symbols.

EDITING REFERENCE DESIGNATIONS USING SELECT NAME

— See “Changing the symbol reference designations using Select name” on 
page 266.

PRECEDING “-” IN SYMBOL NAMES

The symbols in the EN60617 folder does not have a preceding “-” in their symbol 
names.

Therefore enter Settings => Pointer/Screen and 
select Insert - in front of symbol names. All sym-
bols you place in the following, will have a preceding 
“-” in their symbol names.

Adding "-" in already placed symbols

If you have an old project without "-" in the symbol names, this prefix can be added 
automatically to all symbols in the project, by choosing Functions => Special 
Functions => Prefix all symbol names with -.
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INSERTING REFERENCE DESIGNATIONS ON SIGNAL SYMBOLS AND

SYMBOL REFERENCES

— See “Reference designations on symbol and signal references” on page 426.
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REFERENCE DESIGNATIONS FOR AREAS, PAGES & 
CHAPTERS

CONSIDERATIONS ABOUT REFERENCE DESIGNATIONS

When you specify reference designations for a project, it is recommended to start 
by specifying the reference designations at the top level. This makes it much easier 
to maintain an overview over the structure of the reference designations.

It is therefore recommended to start by specifying the reference designations for 
chapters and pages, and then specify reference designations for reference frames 
— if any — on individual project pages.

If you use nested reference frames, it is recommended to start by placing the outer 
reference frames first.

REFERENCE DESIGNATIONS FOR PAGES

It is also possible to specify reference designations for a full page:

 1) Choose Settings => Page data.

 2) In the dialog box Page data: Click on Select under Reference designa-
tions.

 3) In the dialog box Reference designations: Click on the reference designa-
tions you wish to select for the page and click OK.

 4) If symbols are already placed on the page, you are now asked whether to 
change their reference designations. — Read more about this in “Changing 
reference designations” on page 409.

The page reference is not displayed on the page

Please note, that it is not displayed on the project page, that reference designa-
tions have been attached to it. — See “Inserting a drawing header displaying refe-
rence designations” on page 406.

Click OK.

THIS CHAPTER DESCRIBES

— CONSIDERATIONS ABOUT REFERENCE DESIGNATIONS ................................p. 405

— REFERENCE DESIGNATIONS FOR PAGES ....................................................p. 405

— REFERENCE DESIGNATIONS FOR AREAS ON PAGES ....................................p. 407

— REFERENCE DESIGNATIONS FOR CHAPTERS ..............................................p. 412

— CHANGING REFERENCE DESIGNATIONS FOR MULTIPLE PAGES ....................p. 412

— CHANGING REFERENCE DESIGNATIONS USING CHAPTER TABS ....................p. 415
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Symbol names on pages with reference designations

Every symbol you place on a page with reference designations, are assigned the 
reference designation of the page — unless you specify otherwise for the individual 
symbols in their respective Component data dialog boxes.

Because the symbols are conceived as belonging to the reference designation of 
the page, this reference designation is not displayed as a part of the symbol name 
on the page. Reference designations will only be displayed when they are different 
form the reference designation of the page.

Using the Component menu on pages with reference designations

When you via the Component menu place symbols for a component, which have 
already been assigned a reference designation, this symbol keeps the assigned 
reference designation.

The page reference designation displayed in the Status line

In the status line at the bottom of the 
screen you can see the reference 
designation of the page along with the 
page title. Click OK.

Page reference designation displayed as popup information

When you let the mouse cursor rest over a page 
tab, the page reference designation is displayed in 
the popup information.

Inserting a drawing header displaying reference designations

If you do not take action yourself, the reference designation of the page is not dis-
played on the project page itself. Therefore it is a good idea to place a drawing 
header on the page, in which the reference designation of the page is displayed.

To do this, you must place the datafield Reference designation of the type Page 
data in the drawing header. — See “Datafield for reference designations in proje-
cts” on page 417.

Please refer to “Creating Drawing Headers” on page 807 for further details on cre-
ating drawing headers.

Inserting a datafield with reference designations

You can also place the datafield directly on the page.

To do this choose Insert => Insert datafield. Then click on Page Data, choose the 
datafield Reference designation, and click OK.

The datafields Next used page and Previous used page can also display the ref-
erence designation of the pages they refer to.

The page reference designation
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REFERENCE DESIGNATIONS FOR AREAS ON PAGES (REFERENCE

FRAMES)

It is also possible to specify that areas on pages 
shall have an attached reference designation.

To do this choose Insert => Insert Reference 
Frame.

You then get a pencil in the cross hairs, and draw 
a frame for the area with the reference designa-
tion.

When you have drawn the frame, you enter this 
dialog box:

Here you select the relevant reference designation as described in “Selecting Refe-
rence designations when placing symbols” on page 400, and click OK.

You now return to the above dialog box, where the selected reference designation 
is displayed.

Because the page also can have assigned a reference designation, the only the 
part of the reference designation which is displayed is the part which is different 
from the reference designation of the page.

DO NOT DISPLAY THE FULL REFERENCE DESIGNATION FOR THE REFERENCE 

FRAME!

WHEN YOU WANT THE FULL REFERENCE DESIGNATION TO BE DISPLAYED, 
YOU SELECT SHOW FULL REFERENCE DESIGNATION. HOWEVER, IT IS 

STRONGLY RECOMMENDED NOT TO DO THIS, BECAUSE IT MAY RESULT IN 

THAT THE REFERENCE DESIGNATIONS WILL BE MISINTERPRETED!
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Show Function, Location and/or Product description

If you select Show Function descrip-
tion, Show Location description 
and/or Show Product description 
the selected descriptions for the refer-
ence frame are displayed.

The description for the function refer-
ence designation is positioned in the 
upper-left corner of the frame, while 
the location reference designation 
description is positioned in the lower-
left corner of the frame with the 
description of the product reference 
designation description positioned 
above it.

The texts can be moved freely, and their text data can be edited, as for other texts 
in the program. — See “Moving symbol texts on a Diagram page” on page 115 and 
“Specifying text properties / Appearance of text” on page 133.

If the frame is moved, the texts are moved relative to the frame, which is also the 
case for the reference designation text.

Individual control of reference designations with line break

— See “Individual control of reference designations with line breaks from Compo-
nent data” on page 402.

Click OK

When the dialog box is filled out, click OK.

If symbols are already placed inside the area, that you specified for the reference 
frame, you are now asked whether to change the reference designations for these 
symbols. — Read more about this in “Changing reference designations” on 

page 409.

Moving a reference frame

 1) Disable the Pencil (press <Esc>).

 2) Click on the upper-left corner of the reference frame and drag the reference 
to the desired position.

SPECIFY SETTINGS FOR LINES, TEXTS AND REFERENCE FRAMES

UNDER SETTINGS => BASIC SETTINGS YOU CAN SPECIFY HOW LINES ARE 

DRAWN, WHEN YOU CHOOSE INSERT REFERENCE FRAME.

IN THE SAME DIALOG BOX YOU CAN ALSO SPECIFY THE TEXT PROPERTIES 

FOR THE REFERENCE DESIGNATION TEXTS DISPLAYED NEXT TO THE REFER-

ENCE FRAME.

— READ MORE ABOUT LINES SETTINGS IN “The Lines toolbar” on 
page 73.
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Changing the shape of reference frames

When you have placed a reference frame, you can change the shape of the refer-
ence frame the following ways:

Changing a reference frame to a rectangle with a different shape

Click on one of the corners of the reference frame and drag until the reference 
frame has the desired shape.

Please note: You can not change the shape of a reference frame by dragging the 
upper-left corner. This is because the upper-left corner is used for moving the ref-
erence frame.

Insert Line Point

Right-click on the reference frame and choose Insert Line Point. Then click to 
specify the point where the line breaks.

Fold corner

Right-click on one of the corners of the reference frame and choose Fold corner. 
Then click to specify how to fold the corner.

Please note: You can not fold the upper-left corner of a reference frame.

Editing reference designations for areas

If you want to change the reference designation for the 
area, click the Lines button, right-click on the frame, and 
choose Reference Frame data.

You then enter the dialog box Reference Frame data, as 
described in “Reference designations for Areas on pages 
(Reference frames)” on page 407. Here you type in the 
new reference designations for the area / reference 
frame.

Changing reference designations

When you change the reference designation on a refer-
ence frame, you are asked whether/how to change the 
reference designations for symbols placed inside the ref-
erence frame with the previous reference designation for 
the frame.
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Specifying which symbols inside the frame to assign new reference des-
ignations to

In this dialog box you specify how/whether to update the symbols:

- Do NOT change Reference Designations on symbols: The reference desig-
nations remains unchanged for the symbols inside the reference frame

- Change symbols with the full reference designation "=G1+A1" to 
"=G2+A2": Symbols with the same full reference designation as the reference 
frame, are updated

- Change symbols (One aspect): Here you get the option of specifying which 
aspect to change for symbols with matching reference designations for the 
aspect inside the frame

Change symbols outside the frame with same names

If you choose Change symbols outside the frame with same names, all sym-
bols outside the frame are changed, if they have the same symbol name and refer-
ence designation, as any of the symbols inside the frame.

If the reference frame is placed on a page, which you have just copied into the pro-
ject, you will typically not select this option — so that you do not change names on 
other project pages by accident.

When there are symbols inside the reference frame, which are part of a compo-
nent, for which there also are placed symbols outside the reference frame, it can 
be important that Change symbols outside the frame with same names is 
selected. This ensures you that all symbols for the same component still have the 
same reference designations. — If this is not the case, the program will no longer 
understand these symbols as being parts of the same component.

Show/Edit list of symbols being placed

If you choose Show/Edit list of symbols being placed, you subsequently enter a 
dialog box where you can see which symbols Automation will change reference 
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designations for. Here you can also specify not to assign new reference designa-
tions to some of the symbols in the list, by removing the check mark for these sym-
bols in the list. — See also “Show/Edit list of symbols being changed” on page 416.

Click OK

Make the desired changes in the dialog box Change Reference designations, 
and click OK.

See all reference frames in the project

To see all areas with reference designations in the project, you can enter the 
Object Lister and choose Reference Frames.

— See “The Object Lister” on page 341.
mation

Page 411



P

Reference designations for areas, pages & chapters
EDITING REFERENCE DESIGNATIONS FOR CHAPTERS

To assign the same reference designation to a full chapter, enter the Page menu 
— as described in “Edit reference designations for more than one page” on 
page 412 —, select all pages in the project, and change the reference designations 
for the pages.

— Please refer to “Change reference designations via chapter Divider pages” on 
page 415 also.

EDIT REFERENCE DESIGNATIONS FOR MORE THAN ONE PAGE

To edit reference designations for one or more pages in one operation, do this:

 1) Click the Page menu button, or select View => Select page.

 2) In the Page menu: Select the pages for which you wish to change reference 
designations — e.g. by pressing down the <Ctrl> key, and clicking on the 
pages one by one.

 3) Click on Article data.

YOU MUST ASSIGN REF.DES. MANUALLY TO NEW PAGES IN CHAPTERS

WHEN YOU INSERT A NEW PAGE IN A CHAPTER, THE PAGE IS NOT ASSIGNED 

REFERENCE DESIGNATIONS AUTOMATICALLY.

YOU MUST DO THIS MANUALLY, AS DESCRIBED IN “Reference designations 
for pages” on page 405.

IF THE PAGES DO NOT HAVE IDENTICAL REFERENCE DESIGNATIONS

IN THE DIALOG BOX PAGE ARTICLE DATA: IF THE TEXTS FUNCTION, LOCA-

TION AND/OR PRODUCT ARE DIMMED, THIS MEANS THAT THE SELECTED 

PAGES DO NOT HAVE IDENTICAL REFERENCE DESIGNATIONS.

IF THIS IS THE CASE, IT IS ONLY POSSIBLE TO EDIT THE REFERENCE DESIG-

NATIONS FOR THE PAGES. THE REFERENCE DESIGNATIONS FOR THE SYM-

BOLS WILL NOT BE CHANGED.

NOTE: If dimmed,

only the ref.des. of the

pages can be changed
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 4) In the dialog box Page article data: Click on Select under Reference desig-
nations:

 5) In the dialog box Reference designations: Select the new reference desig-
nations, and click OK. What to do next depends on whether the selected 
pages had identical reference designations:

If the pages did NOT have identical reference designations

6a) If the selected pages did not have 
identical reference designations, do 
the following in the dialog box Page 
article data: Click on the relevant ref-
erence designation(s) to confirm that 
you wish to select this/these reference 
designation(s). This causes Function, 
Location and/or Product to be written 
in black, and the selected pages are 
assigned the reference designation — which is displayed in the title bar of the 
dialog box Page article data. (Please note, that only the pages, and not the 
symbols on the pages, will have their reference designations changed — as 
described in the box “If the pages do not have identical reference designati-
ons” on page 412).
Click OK.

If the pages did have identical reference designations

6b) If the selected pages had identical reference designations, you enter the 
dialog box Change Reference Designations. Here you get the option of 

2) Select the pages

3) Click on Article data

4) Click on Select, and

select reference designations

Click here to confirm the

selected designations
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changing reference designations for the implicated symbols:

— Read about the options in this dialog box in “Options in the dialog box 
Change Reference Designations” on page 415.
Choose how to change reference designations for the involved symbols, and 
click OK. If you have chosen Show/Edit list of symbols being changed, 
please also see “Show/Edit list of symbols being changed” on page 416.

Click OK in the Page menu

 7) You now return to the Page menu: Click OK.
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CHANGE REFERENCE DESIGNATIONS VIA CHAPTER DIVIDER PAGES

To change reference designations via a chapter tab, do this:

 1) Click on the page tab for the divider page for 
the chapter (The chapter front page).

 2) Select Settings => Page data, and click on 
Select in the Reference designations sec-
tion.

 3) In the dialog box Reference designations: Choose reference designations, 
and click OK.

Options in the dialog box Change Reference Designations

 4) You now enter the dialog box Reference designations:

Here you are asked whether to change reference designations on the pages 
in the chapter having the same reference designations as the divider page, 
and which directions to apply for changing the symbols. You have the follow-
ing options:

OPTION EFFECT

CHANGE REFERENCE DESIG-

NATIONS ON CHAPTER PAGES

SELECT THIS OPTION IN ORDER TO CHANGE REFER-

ENCE DESIGNATIONS FOR THE CHAPTER PAGES HAV-

ING THE SAME REFERENCE DESIGNATIONS AS THE 

DIVIDER PAGE.
YOU WILL NOT BE ABLE TO SELECT THE OPTIONS 

BELOW, BEFORE YOU HAVE SELECTED THIS OPTION.

DO NOT CHANGE REFER-

ENCE DESIGNATIONS ON 

SYMBOLS

CLICK HERE IN ORDER NOT TO CHANGE REFERENCE 

DESIGNATIONS ON ANY SYMBOLS.

CHANGE SYMBOLS WITH THE 

FULL REFERENCE DESIGNA-

TION "X" TO "Y"

CLICK HERE TO CHANGE THE FULL REFERENCE DESIG-

NATION.
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Show/Edit list of symbols being changed

 5) If you have chosen Show/Edit list of symbols being changed, you now 
enter the following dialog box:

Remove the check mark in front of the symbols, that shall not have their ref-
erence designations changed, and click OK.

 6) In the dialog box Settings: Click OK

You have now changed reference designations for the desired pages and symbols.

CHANGE SYMBOLS (ONE 

ASPECT)
CLICK HERE — AND THEN CHOOSE ONE OF THE 

OPTIONS — TO CHANGE REFERENCE DESIGNATIONS 

FOR ONE OF THE ASPECTS.

CHANGE SYMBOLS WITH 

FUNCTION REFERENCE 

DESIGNATION "X" TO "Y"

FIRST CHOOSE CHANGE SYMBOLS WITH REF. "X" OR 

"Y": THEN CLICK HERE ONLY TO CHANGE FUNCTION 

REFERENCE DESIGNATION.

CHANGE SYMBOLS WITH 

LOCATION REFERENCE 

DESIGNATION "X" TO "Y"

FIRST CHOOSE CHANGE SYMBOLS WITH REF. "X" OR 

"Y": THEN CLICK HERE ONLY TO CHANGE LOCATION 

REFERENCE DESIGNATION.

CHANGE SYMBOLS ON OTHER 

PAGES WITH SAME NAME AS 

ON THIS PAGE

CLICK HERE, SO THAT YOU ALSO CHANGE REFERENCE 

DESIGNATIONS FOR SYMBOLS OUTSIDE THE CHAPTER, 
WHICH ARE A PART OF THOSE OF THE COMPONENTS 

IN THE CHAPTER, WHICH WILL HAVE THEIR REFERENCE 

DESIGNATIONS CHANGED.

SHOW/EDIT LIST OF SYMBOLS 

BEING CHANGED

CLICK HERE TO GET A LIST OF WHICH SYMBOLS THAT 

ARE GOING TO BE CHANGED. IN THIS LIST YOU CAN 

DESELECT SYMBOLS, FOR WHICH YOU DO NOT WISH 

TO CHANGE REFERENCE DESIGNATIONS.

OPTION EFFECT

Click here for different views

Click here to select/deselect symbols
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REFERENCE DESIGNATIONS: DATAFIELDS AND 

LISTS

DATAFIELD FOR REFERENCE DESIGNATIONS IN PROJECTS

When you wish to place a data-
field containing reference designa-
tions in a list or on a diagram 
page, do the following:

 1) Choose Insert => Insert 
Datafield.

 2) In the dialog box Datafield: 
Click on Project Data, and 
choose the datafield Refer-
ence designation.

 3) Choose the relevant part of 
the reference designation — 
as displayed in the figure to 
the right.

 4) Click OK.

Specify which reference designations to display

When you have selected the datafield Reference desig-
nation in the Project data group, you can choose only to 
display a limited part of the reference designations.

This is done in the field First,last, where you type in the number of the first and the 
last reference designation you wish to display.

THIS CHAPTER DESCRIBES

— DATAFIELD FOR SPECIFYING REFERENCE DESIGNATIONS............................p. 417

— LISTS ACCORDING TO REFERENCE DESIGNATIONS......................................p. 418

REFERENCE DESIGNATIONS IN ALPHABETICAL ORDER

WHEN REFERENCE DESIGNATIONS ARE BEING PRINTED VIA THIS DATAFIELD, 
THEY ALWAYS APPEAR IN ALPHABETICAL ORDER.

The full ref. designation is displayed

The Reference designation is displayed

The attached description is displayed

One of the aspects is displayed
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When for instance you type in 1,20 the first 20 reference designations are dis-
played, if you type in 21,40 the subsequent 20 reference designations are dis-
played. This way it is possible to list the reference designations over several pages 
or and/or columns, when a project contains many reference designations.

LISTS ACCORDING TO REFERENCE DESIGNATIONS

When you apply reference designations, it is possible to create separate lists for 
each Function, Location or Product in the project.

This is done by clicking on the list in the project you want divided following these 
criteria. Here you choose Lists => List settings and enter the dialog box List 
setup, where you click on the Criteria tab.

If you want a list of every symbol having the Function reference designation =P1 
— which for instance could be a pump — you fill out the Criteria tab like this:

Or fill out the Criteria tab like this to get a list of the assembly +A1:

— Please refer to “Specifying Criteria for the components to include” on page 604 
for further details on criteria on lists.

SELECT/DESELECT OPTIONS USING REFERENCE DESIGNATIONS

When you have created a project with reference designations, this makes it possi-
ble to select/deselect options in the project based on the reference designations, 
and then generate a new project only containing the selected options. — Read 
more about this in “Projects with selectable options” on page 578.
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Automatically updated references

Auto
AUTOMATICALLY UPDATED REFERENCES

When you place more than one symbol for the same component in a project, the 
program can automatically create references between these symbols on the pro-
ject pages.

Next to each symbol you can therefore see references to the other symbols for the 
same component. The appearance of these references you can determine your-
self.

— Please see to “Contact mirrors and Reference crosses” on page 428.

— Please also see “Navigation between symbols for the same component” on 
page 190.

INSERTING A REFERENCE SYSTEM

In order to let the program create appropriate references, you must first create/
adapt the reference system for the diagram pages, so that it meets your demands. 
Read more about this in “Setting up the current paths” on page 433.

AUTOMATIC JUMP BETWEEN REFERENCES ON DOUBLE-CLICK

To jump to a symbol which is referred to, do the following:

THIS CHAPTER DESCRIBES

— INSERTING A REFERENCE SYSTEM.............................................................p. 421

— AUTOMATIC JUMP BETWEEN REFERENCES ON DOUBLE-CLICK .....................p. 421

— REFERENCES ON SYMBOLS.......................................................................p. 423

— APPEARANCE OF REFERENCES .................................................................p. 426

— REFERENCE DESIGNATIONS ON SYMBOL AND SIGNAL REFERENCES ............p. 426

— REFERENCES FOR PLCS..........................................................................p. 427
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 1) Double-click on the reference.

 2) The program now automatically jumps to the project page, where the 
referred to symbol is placed. The referred symbol is selected by the cross 
hairs.

Automatic jump to reference from reference cross

Correspondingly you can double-click on the reference in a reference cross or in a 
contact mirror:

When you double-click on the reference for a symbol in the reference cross/contact 
mirror, you return to the symbol with the symbol having the symbol type Relay.

SYMBOL REFERENCES ARE ACTIVE IN ALL COMMANDS

WHEN YOU DOUBLE-CLICK ON A REFERENCE FOR A SYMBOL, Automation 
JUMPS TO THE REFERRED SYMBOL — NO MATTER IF YOU WORK WITH 

LINES, TEXTS, CIRCLES, SYMBOLS OR AREAS.

Double-click on the reference, and the referred symbol is selected

Double-click on the reference in the reference cross

and the referred symbol is selected

Double-click here to return

to the relay coil symbol
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REFERENCES ON SYMBOLS

In Automation you can apply references on all types of symbols.

How the reference appears for a symbol, primarily depends on the symbol type of 
the symbol. However, some symbols are created without symbol type, and there-
fore has no references.

Inserting references on symbols without reference

To insert references on symbols without references — or to change the selected 
reference for a symbol — do the following:

 1) Click on the Symbols button, right-click on the symbol, and choose Compo-
nent data — or double-click on the symbol.

 2) In the dialog box Component data: Click on the Reference tab, choose 
With reference and then either Master reference or With reference, and 
click OK.

Choosing the reference type Master reference

If you select the reference type Master reference, a list is created next to the sym-
bol, containing references to the other symbols having the same symbol name — if 
these are set to With reference.

It is possible to set more than one symbol with the same symbol name to Master 
reference. However, from the symbols set to With reference, there are only a ref-
erence to the first symbol with Master reference in the documentation.

References can be placed in columns. How many references to place in each col-
umn, is specified in the field Max. Number of references pr. column.
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When you choose Master reference for PLC symbols, a PLC I/O reference cross 
is placed next to the symbol.

Choosing the reference type With reference

When you choose the reference type With reference, there will be placed a refer-
ence next to the symbol, which refers to the symbol(s) that has the same symbol 
name and are set to Master reference.

When there are no symbols with the same symbol name which are set to Master 
reference, a reference is placed to the preceding and the succeeding symbol in 
the project. Hereby a chain of references between symbols with the same symbol 
name is created. This makes it easy to run through the project and find all symbols 
having the same symbol name. All you need to do is to double-click on the refer-
ences, and you jump to the next — or previous — symbol in the chain.

Sub names and references

If you only want references between symbols with the same sub names within a 
component, do this:

 1) Double-click on one of the symbols for the component.

 2) In the dialog box Component data: Click on the Reference tab at the bot-
tom of the dialog box.

 3) In the Reference tab: Select Only reference to symbols with same sub 
name.

If Only reference to symbols with same sub name is not selected, references 
will appear for all symbols with the same name, no matter what their sub names 
are.

Symbol type and References

The symbol type is specified in the symbol definition — see “Creating Symbols” on 
page 761; see "Symbol types" in particular.

However, you can change the symbol type for a symbol like this:

 1) Click on the Symbols button — to work with symbols.

 2) Right-click on the symbol and choose Component data.

 3) Click on the General tab, and click on the down-arrow in the Symbol type 
field:

Click here to choose

symbol type
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 4) You can now choose between the following symbol types:

 5) Choose symbol type and click OK.

SYMBOL TYPE STANDARD REFERENCES FOR THE SYMBOL TYPE

NORMAL THE SYMBOL IS NOT ASSIGNED REFERENCES — UNLESS SPECIAL 

ACTION IS TAKEN.

RELAY A REFERENCE CROSS/CONTACT MIRROR IS CREATED FOR THE SYMBOL, 
WHEN PLACED ON A DIAGRAM.

OPEN THE SYMBOL WILL BE CONCEIVED AS AN OPEN CONTACT, AND THERE 

WILL BE PLACED A REFERENCE TO THE SYMBOL IN THE REFERENCE 

CROSS/CONTACT MIRROR BELOW THE RELAY COIL SYMBOL FOR THE 

COMPONENT. THE SYMBOL WILL ALSO GET A REFERENCE TO THE RELAY 

COIL SYMBOL, WHEN THE SYMBOL IS PLACED IN THE PROJECT.

CLOSE THE SYMBOL WILL BE CONCEIVED AS A CLOSE CONTACT, AND THERE 

WILL BE PLACED A REFERENCE TO THE SYMBOL IN THE REFERENCE 

CROSS/CONTACT MIRROR BELOW THE RELAY COIL SYMBOL FOR THE 

COMPONENT. THE SYMBOL WILL ALSO GET A REFERENCE TO THE RELAY 

COIL SYMBOL, WHEN THE SYMBOL IS PLACED IN THE PROJECT.

SWITCH THE SYMBOL WILL BE CONCEIVED AS A SWITCH, AND THERE WILL BE 

PLACED A REFERENCE TO THE SYMBOL IN THE REFERENCE CROSS/CON-

TACT MIRROR BELOW THE RELAY COIL SYMBOL FOR THE COMPONENT. 
IN REFERENCE CROSSES, THERE WILL BE A REFERENCE TO THE SYM-

BOL IN BOTH THE OPEN AND THE CLOSE CONTACT SIDE. THE SYMBOL 

WILL ALSO GET A REFERENCE TO THE RELAY COIL SYMBOL, WHEN THE 

SYMBOL IS PLACED IN THE PROJECT.

MASTER REF-

ERENCE

THE SYMBOL WILL HAVE REFERENCES TO ALL OTHER SYMBOLS OF THE 

SAME SYMBOL NAME. FOR INSTANCE HAND OPERATED CONTACTS

WITH

REFERENCE

REFERS EITHER TO A SYMBOL WITH MASTER REFERENCE, OR TO SYM-

BOLS IN THE CLOSEST PROCEEDING OR SUCCEEDING CURRENT PATH, 
WHICH ARE PART OF THE SAME COMPONENT.

TERMINAL THE SYMBOL IN NOT ASSIGNED REFERENCES — UNLESS SPECIAL 

ACTION IS TAKEN.

PLC THE SYMBOL IN NOT ASSIGNED REFERENCES — UNLESS SPECIAL 

ACTION IS TAKEN.

PLC REFER-

ENCE

SYMBOL WHICH IS TO BE USED AS A PLC REFERENCE SYMBOL.

— SEE “Creating PLC reference symbols” on page 793 AS 

WELL AS “Working with PLCs” on page 466 AND “On PLC refe-
rence symbols” on page 466.

NON CON-

DUCTING

THE SYMBOL IN NOT ASSIGNED REFERENCES — UNLESS SPECIAL 

ACTION IS TAKEN.

SUPPORT THE SYMBOL IN NOT ASSIGNED REFERENCES — UNLESS SPECIAL 

ACTION IS TAKEN.

HEAD SYMBOL THAT ARE USED FOR PLACING OF A LIST ON A PAGE. — SEE 

“Creating a List symbol” on page 829.

ALL SYMBOL TYPES CAN BE CREATED WITH ACTIVE WITH REFERENCE

ALL SYMBOL TYPES CAN BE CREATED WITH WITH REFERENCE ACTIVE VIA 

THEIR SYMBOL DEFINITION. — READ MORE ABOUT THIS IN “Creating Sym-
bols” on page 761, “Symbol settings: Reference” on page 774 IN PAR-

TICULAR.
mation

Page 425



P

Automatically updated references
APPEARANCE OF REFERENCES

To specify the appearance of the reference, do the following:

 1) Choose Settings => Text/Symbol defaults.

 2) Click on Reference.

 3) Then click on Symbol reference to specify the appearance of the symbol 
references.

 4) You now get the following options:

 5) Now choose Reference format, Pre char and Separator and brackets if 
necessary. If you use a reference system with both horizontal and vertical 
references, then select XY reference (see “Horizontal and vertical referen-
ces” on page 434).

 6) When you wish also to change the appearance of the text, click the Text 
properties button, as described in “Specifying text properties / Appearance 
of text” on page 133.

 7) Click OK.

 8) Choose Functions => Update references — and the changes are dis-
played in the project.

When you wish to change the appearance for references for signal symbols, just 
choose Signal reference in step 3 above.

REFERENCE DESIGNATIONS ON SYMBOL AND SIGNAL REFERENCES

To let references for symbols contain reference designations for the page that are 
referred to, do the following:

 1) Choose Settings => Text/Symbol defaults.

 2) Click on Reference.

 3) Then click on Symbol reference to specify the appearance of the references 
for symbols.
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 4) Now choose which reference designations to include in the references, as 
displayed in the figure below:

 5) Click OK.

Signal symbol references with reference designations

You can, correspondingly, activate reference designations for signal symbols by 
choosing Signal reference in stead of Symbol reference in the procedure above.

REFERENCES FOR PLCS

— See “Jumping between PLC ref. symbols and PLC I/O symbols” on page 478.
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CONTACT MIRRORS AND REFERENCE CROSSES

When displaying references for symbols with the type Relay — see “References on 
symbols” on page 423 — you can either use reference crosses or contact mirrors.

This chapter describes how to use reference crosses and contact mirrors in the 
program.

— Please read “Setting up the current paths” on page 433 to see how to set the 
reference system on the project pages.

— Please also read “Automatically updated references” on page 421 for general 
information on references in Automation.

THIS CHAPTER DESCRIBES

— ON CONTACT MIRRORS ............................................................................p. 429

— ON REFERENCE CROSSES ........................................................................p. 430

— CHOOSING BETWEEN CONTACT MIRRORS AND REFERENCE CROSSES ........p. 431

— CONTACT MIRRORS ARE CREATED AUTOMATICALLY BY THE PROGRAM ........p. 431

CONTACT MIRRORS GIVES QUICK ACCESS TO AVAILABLE SYMBOLS

CONTACT MIRRORS ALSO GIVES YOU THE OPTION TO GET THE AVAILABLE 

SYMBOLS FOR A COMPONENT IN THE CROSS HAIRS RIGHT AWAY.
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ON CONTACT MIRRORS

If you have set the program to use contact mirrors — see 
“Choosing between contact mirrors and reference crosses” 
on page 431 — and place a symbol with an article number 
from the attached database, the other symbols for the com-
ponent are displayed at the bottom of the page.

Thus contact mirrors are a graphical representation of the 
other symbols for the component. The contact mirror is 
placed under the symbol for the component, which has the 
symbol type Relay.

When for instance you place a relay coil symbol via the 
database, the other symbols for the component are dis-
played below the relay coil symbol at the bottom of the page 
— as displayed on the figure to the right. In the contact mir-
ror for the relay coil symbol you see a three-poled open 
contact, a close contact and an open contact.

Contact mirrors and changes in the article
number

When you change the article number for a symbol, the con-
tact mirror will be changed, so that it matches the informa-
tion about the article number in the database.

Direct jump to the other symbols for the component

For the symbols, which are already placed in the project, a reference to their loca-
tion is displayed. When you double-click on one of these symbols, you jump 
directly to the symbol in the project. — See “Automatic jump between references 
on double-click” on page 421.

Get available symbols from the contact mirror directly into the
cross hairs

When you double-click on one of the symbols in the con-
tact mirror, which is not placed in the project, you get the 
symbol in the cross hairs, and can then place it in the pro-
ject.

When a symbol is deleted from the project, the reference 
to the symbol is removed from the contact mirror, and you 
can once again see that the symbol is available in the 
contact mirror.

Symbol with the

type Relay

Contact mirror

for the symbol

Double-click on an

available symbol,

and you get it in the

cross hairs
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ON REFERENCE CROSSES

When you are using reference crosses, a reference 
cross is displayed under all symbols of the symbol 
type Relay.

Under the open contact in the reference cross, refer-
ences to all the open contacts for the component are 
displayed. Also, references to all the close contacts 
are displayed below the close contact in the refer-
ence cross.

When you double-click on one of these references, 
you jump directly to the symbol in the project, which 
the reference refers to. — See “Automatic jump bet-
ween references on double-click” on page 421.

Available symbols are not displayed in
reference crosses

Available symbols for the component are not displayed in the reference cross.

When you are using reference crosses, you therefore do not have the option to get 
available symbols directly in the cross hairs, as when you use contact mirrors — 
see “Get available symbols from the contact mirror directly into the cross hairs” on 
page 429.

Reference crosses for symbols with sub names

For components containing symbols with sub names, independent reference 
crosses are created for each of the relay coil symbols for the component, which 
has independent sub names.

Hereby components with several functions can be separated functionally on the 
project pages, and still appear as one component in the project lists.

— See “Sub names on symbols” on page 183, particularly “Functionally under-
stood as different components” on page 183.

Move reference cross

To move a reference cross, do this:

 1) Right-click on the relay coil and choose Move reference symbol

 2) Click to point out the new position of the reference cross

The reference cross is now moved to the new position.

Click here, and you

symbol, which is
jump directly to the

referred to
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CHOOSING BETWEEN CONTACT MIRRORS AND REFERENCE CROSSES

To choose whether to use contact mirrors or reference crosses in Automation, you 
must click the Project data button, and click on either Reference cross or Con-
tact mirror in the lower-left corner of the dialog box, and click OK.

You can, at any time, choose whether you wish to use contact mirrors or reference 
crosses.

If Contact mirror is activated without an attached database, the contact mirrors 
only contains the symbols, which are used in the project.

CONTACT MIRRORS ARE CREATED AUTOMATICALLY

In Automation the program creates the contact mirrors for you automatically, so 
that they contains all the relevant symbols. When for instance you place a relay coil 
symbol from a component from the database, the program automatically creates a 
contact mirror containing the other symbols for the component under the relay coil 
symbol in the project.

If you later place other symbols with the same symbol name in the project, where 
these symbols does not have an article number — or has an unknown article num-
ber — the symbols are added to the bottom of the contact mirror. When these sym-
bols are deleted in the project, they are removed from the contact mirror.

Creating contact mirrors without using the database

When you are working without an attached database, and place a symbol with the 
symbol type Relay, no contact mirror is created for the symbol.

SWITCHING BETWEEN CONTACT MIRRORS AND REF. CROSSES

YOU CAN CHOOSE TO USE CONTACT MIRRORS WHILE WORKING WITH THE 

PROJECT, AND THEN SWITCH TO REFERENCE CROSSES WHEN DELIVERING 

THE PROJECT. — OR VICE VERSA.

HOWEVER, THE DATABASE MUST BE ATTACHED WHEN CHOOSING TO WORK 

WITH CONTACT MIRRORS, BECAUSE THE PROGRAM THEN RUNS THROUGH 

THE PROJECT, IN ORDER TO CREATE CONTACT MIRRORS. IF THE DATABASE 

IS NOT ATTACHED AT THIS TIME, AVAILABLE CONTACTS ARE NOT DISPLAYED.
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The contact mirror is not created until you place another symbol with the same 
symbol name in the project. After this, symbols will be added to the contact mirror 
as you place more symbols with the same symbol name. The symbols will there-
fore appear in the order in which they are placed in the project.

When a symbol is placed using an attached database, the contact mirror for the 
symbol is memorized, also when the database is no longer attached. This applies 
as long as the article number for the symbol remains unchanged.

Contact mirrors for symbols without article numbers

What is mentioned above, only applies when you are working with an attached 
database, and place a symbol without an article number — or a symbol with an 
unknown article number.

When you assign an article number to a symbol, the contact mirror for the symbol 
is created/re-organized according to the order of the symbols for the component in 
the database (In the PCSTYPE field in the database — see “Database settings” on 
page 670).
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CURRENT PATH NUMBERS / REFERENCE SYSTEM

The reference system / current path numbers is a coordinate system you can use 
on your diagrams. It will be used when you refer to the position of the individual 
components, for instance in a reference cross. The current path numbers / refer-
ence systems can be located along the horizontal or vertical axis, or along both 
axis simultaneously.

You can determine to let the number of the current path, and/or page a symbol is 
located on, be part of the name of the symbol. This is called current path naming.

SETTING UP THE CURRENT PATHS

To determine where and how to locate the current path numbers, you choose Set-
tings => Page data => References.

You then enter the Reference system setup dialog box:

THIS CHAPTER DESCRIBES

— SETTING UP THE CURRENT PATHS............................................................p. 433

— THE HORIZONTAL REFERENCE SYSTEM .....................................................p. 434

— THE VERTICAL REFERENCE SYSTEM..........................................................p. 434

— VERTICAL AND HORIZONTAL REFERENCES .................................................p. 434

— COPYING THE REFERENCE SETTINGS ........................................................p. 435

— CHANGING THE REFERENCE CROSSES ......................................................p. 435

— NAMING SYMBOLS ACCORDING TO CURRENT PATH NUMBERS .....................p. 436

— SYMBOL NAMES WHEN MOVING OR COPYING ............................................p. 438

— CURRENT PATH NUMBERS AND AUTOMATIC PROJECT GENERATION ............p. 439

— NAMING DUE TO CHANGES IN THE PAGE MENU ..........................................p. 439
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HORIZONTAL REFERENCE SYSTEM

In the field Active on the tab Horizontal you determine whether you want to use 
references along the x-axis on your diagram or not.

In the Main reference check box you determine whether these current path num-
bers are to be used when referring between symbols.

If Main reference is selected a reference cross will be placed on the diagram for 
each individual symbol having a relay status (See “Symbol types” on page 771). 
These will be filled out with references to the contacts of the same component. If 
Main reference is deselected, no reference crosses will be placed on the diagram.

In the fields X position (mm) and Y position (mm), you determine where to place 
the first current path; in the Distance (mm) field you determine the distance 
between the current paths; and in Number you choose how many current path 
numbers you want on the chosen page.

In the Start value field, you determine the start value of the first current path on the 
diagram, and in Counting direction you choose whether to count from left to right, 
or from right to left.

If you want the current paths on the different pages in the project to be numbered 
in succession, select the Continuous check box. If the page you are working on 
has no preceding diagram, the field will be dimmed and can not be selected.

If you have selected Continuous on a page and then change the initial value, you 
automatically change the initial value on the first of the coherent pages.

In the Reference symbol position field you determine the position of the refer-
ence crosses.

By clicking on the Text properties button, you determine the size of the charac-
ters/figures in the numbering of the current paths.

Default settings

If you want to see the present default settings for the tab Horizontal, you click the 
Show defaults button. The default settings are displayed as long as the button is 
pressed down.

To load the defaults for the tab Horizontal, you click the Load defaults button.

VERTICAL REFERENCE SYSTEM

By clicking on the tab Vertical you will be able to determine corresponding settings 
for the current path numbers along the vertical axis. If you wish, you can use letters 
instead of numbers.

HORIZONTAL AND VERTICAL REFERENCES

When you wish to use both horizontal and vertical references in projects, do this:

 1) In Settings => Page data => References: Select Active for both the Hori-
zontal and the Vertical reference system.

 2) If you want to list the horizontal reference first, select Main reference on the 
Horizontal tab. — And if you want to list the vertical reference first, select 
Main reference on the Vertical tab.
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 3) Click OK.

COPYING THE REFERENCE SETTINGS

If you want these settings for the current path numbers 
to be used on the diagrams you create from now on, you 
click on the tab Default, and then click on the Save as 
default button. Hereby you save all settings made on 
the tabs Horizontal and Vertical.

Please note, that clicking on the Save as standard but-
ton will not effect any pages in the project.

If you want to update the other pages in the project with 
the chosen settings, you click on Update.

Hereby you update all pages having the Page function 
Normal, the Page type Diagram, and also the same 
Page size as the page you are working on at present.

Check marks in the check boxes Active, Main refer-
ence and Continuous are not updated/changed.

— Read more about Page type and Page function in “Pages and Chapters” on 
page 542.

CHANGING THE REFERENCE CROSSES

The reference crosses are defined as symbols, so in order to change these, you 
have to change their symbol definitions. — See “Creating Symbols” on page 761.

You choose which reference cross to use in the project by first choosing Settings 
=> Text/Symbol defaults, then click on Others, on Reference cross, and on 
Add. You then enter the Symbol menu, where you select the symbol for the refer-
ence cross you wish to use.

The reference crosses are defined as symbols, so when you wish to change these, 
you must edit their symbol definitions. — See “Creating Symbols” on page 761.

If you enter Settings => Text/Symbol defaults, click on Reference and then on 
Reference cross, you can edit the appearance of the text in the reference crosses 
by clicking on the Text properties button. Please note, that the appearance will 
only be changed for the reference crosses that are placed in the project after you 
made the changes.

You can also choose which separator to use in the reference crosses:

If you use a reference system with both horizontal and vertical references, then 
select XY reference (see “Horizontal and vertical references” on page 434).

Then choose Functions => Update references and the entire project is updated 
with the new references.
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NAMING SYMBOLS DUE TO PAGE AND CURRENT PATH NUMBER

If you want the page and the number of the current path, in which the symbols are 
located, to be part of the symbol names, you can let Automation handle this auto-
matically.

To arrange this, you choose Settings => Text/Symbol standards, and click on 
Symbols, and then on Name.

In the field Name format you can choose between different formats for the symbol 
names.

When you click the Browse button, you can see which symbol types the settings 
applies for:

Please note that the selected name formats always applies for symbols of the type 
Normal, Relay and Main reference.

Name formats

You can here choose between the following name formats:

THE NAME FORMAT FREE

If you choose Free, the symbol names become exactly as you type them.

THE NAME FORMAT K1/5

If you choose K1/5, the location of the symbol will automatically be included as the 
last part of the symbol name. When you choose this format, you also get the option 
of choosing a different separator than /.

After the letter (K) follows the page number (1) a separator (/) and the number of 
the current path (5) in which the symbol is placed.

If you have chosen this type, you can specify which separator should be used 
between the page number and the current path number. You do this in the Separa-
tor field. Under 2. name you can see the result of the chosen name format.
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THE NAME FORMAT 1K5

If you choose 1K5, the page number will be located before, and the current path 
number after the code letter.

THE NAME FORMAT K5

If you choose K5, only the current path number is included in the symbol name. 
This only makes sense if you are using Continuous current path numbers.

THE NAME FORMAT K15

If you choose K15, the last digit specifies the current path number. Other digits 
after the code letter specifies the page number. If for instance it says -P146 on the 
diagram page, this refers to page 14, current path 6. This format can only be used 
if the current path numbers does not exceed one character — e.g. 0 to 9.

THE NAME FORMAT K105

If you choose K105, the last two digits specifies the current path number. Other 
characters after the code letter specifies the page number. If for instance it says
-P1406 this refers to page 14, current path 6. This format can only be used if the 
current path numbers does not exceed two characters — e.g. 0 to 99.

Changing symbol names to current path names

When you in this dialog box specifies that current path numbers shall be included 
in the symbol names, this only has an effect for the symbols you place succeed-
ingly.

If you want to include current path numbers in the placed symbols, choose Func-
tions => Special Functions => Create CurrentPath Numbers on all Symbols.

You are then asked whether to rename all symbols. Click OK.

The option Create CurrentPath Numbers on all Symbols is only displayed when 
you have specified that current path numbers shall be included in the symbol 
names in the project.

Generation names

If you place more symbols of the same type in the same current path, the symbols 
will still be assigned unique names.

If for instance you place a lamp in current path sixteen on page three, it gets the 
name H3.16. If you then place more lamps in the same current path, they’ll be 
assigned the names H3.16.1 and H3.16.2 — and so on. In this context the addi-

NAMING FORMATS WITH CURRENT PATH NUMBERS AND THE

IEC/EN 61346 STANDARD

THE STANDARD IEC/EN 61346 DOES NOT MENTION CURRENT PATH NUM-

BERING.

IF YOU USE THE FORMAT K1/5 OR 1K5, THIS WILL BE IN CONTRADICTION TO 

THE NAMING RULES IN THE STANDARD.

BUT IF YOU CHOOSE THE FORMAT K5, K15 OR K105, AND EXPLAINS THE 

SIGNIFICANCE OF THE APPLIED FORMAT IN THE DOCUMENTATION, YOU CAN 

FOLLOW THE STANDARDS IN THIS CONTEXT.
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tions are called generation names, and are added to be able to distinguish 
between the symbols.

The generation names are assigned according to the order in which you place the 
symbols, and has nothing to do with their position in the current path.

In the Second separator field, you determine which sign will be used to separate 
the generation name from the current path number.

Save as default

If you want the chosen settings to be in effect for any new project you create, you 
click on the Save as default button.

If you want to load the present default settings for symbol names, you click the 
Load defaults button.

If you just want to see the defaults, you click the Show defaults button, which only 
displays the defaults as long as you keep the mouse button pressed down.

Symbol names in previously created projects will not be affected.

— Read more about default settings and about this dialog box in “Texts displayed 
in the project (general setting)” on page 138.

Changing between name format types

If you change from using the name format Free to a name format with included cur-
rent path numbers, this will not have any effect on symbols already placed in your 
project. The change only concern the symbols you place after having made the 
changes.

If you want to change symbol names for symbols, that have been named using the 
name format Free, in order to make them follow page and current path numbers, 
you must do as described in “Make a symbol regain its adaptability” on page 439.

If you change from one current path name format to another, the changes will 
affect all symbol names, which contains the correct page and current path number 
for the symbol.

During moving or copying, symbols having these name formats, furthermore have 
the capability to have their names corrected, corresponding to page and current 
path numbers of their new location.

SYMBOL NAMES WHEN MOVING OR COPYING

If you copy a symbol with a current path name, the copy of the symbol automati-
cally receives a name corresponding to which page/current path you place it on.

If you, on the other hand, move a symbol, you will be asked whether or not to 
rename the symbol.

If you answer Yes, the symbol is assigned a name corresponding to the new loca-
tion of the symbol.

If your answer is No, the symbol keeps its old name, but at the same time it loses 
the ability automatically to be assigned a current path name during moving/copy-
ing.

Copying or moving more objects at the same time, follows the same directions as 
mentioned above.
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Make a symbol regain its adaptability

If you have a symbol that has lost its adaptability, you can manually change its 
name to what it should be called, according to its present location.

This makes the symbol name regain its adaptability.

NAMING DUE TO CHANGES IN THE PAGE MENU

When you make changes on project pages in the Page menu, this may have con-
sequences for pages containing symbols with current path names. (You can read 
more about this in “The Page menu and current path numbers” on page 546).

If this is the case, you will get a warning. If you answer Yes to rename the symbols, 
their names are changed according to the new page and current path numbers. If 
you copy/move the symbols later on, they will still be able to be assigned new cur-
rent path names.

If your answer is No, the symbol names loose their adaptability. Thus, a symbol 
having the name K3.5 will remain the name K3.5 on its new location. But the pro-
gram will no longer recognize this as a current path name. In this case the symbol 
will from then on be regarded as a symbol having the name format type Free.

— Se how to let the symbol regain its adaptability in "Make a symbol regain its 
adaptability" above.

CURRENT PATH NUMBERS AND AUTOMATIC PROJECT GENERATION

When applying the automatic project generation facilities in Automation, all sym-
bols in the generated project can automatically be assigned current path numbers.

— Read more about this in the Project Generator manual.
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This section describes functions for automatic and 
manual wire numbering:

- Automatic wire numbering.................................p. 443

- Manual wire numbering ......................................p. 452

- Wire number files .................................................p. 455

Wire numbers
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AUTOMATIC WIRE NUMBERING

Automation can assign wire numbers to your drawings automatically. You can also 
assign wire numbers manually, and combine these two ways of working.

— Please refer to “Manual placing of wire numbers” on page 452 to see how to 
place wire numbers manually.

STARTING THE AUTOMATIC WIRE NUMBERING

If you want to insert wire numbers automatically on your diagrams, you choose 
Functions => Wire numbers. This makes you enter the dialog box Wire num-
bers, which contains various tabs. Here you determine how the automatic wire 
numbering is to be carried out.

If you need to place wire numbers manually, this is described in “Manual placing of 
wire numbers” on page 452.

When the settings are appropriate, you click either All Pages, This 
page or Select pages to carry out the automatic wire numbering, 
following the directions you have set up.

When you click on All Pages, the wire numbering is made for all 
pages in the project.

When you click on This Page, the wire numbering is only made for 
the current page.

THIS CHAPTER DESCRIBES

— STARTING THE AUTOMATIC WIRE NUMBERING .......................................... p. 443

— DESELECTING WIRE NUMBERING FOR INDIVIDUAL LINES ............................. p. 444

— LOCKING THE AUTOMATIC WIRE NUMBERING............................................. p. 444

— FUNCTIONS ............................................................................................. p. 445

— POTENTIAL NUMBERING ........................................................................... p. 445

— WIRE NUMBERING.................................................................................... p. 446

— FORMAT.................................................................................................. p. 449

— NUMBER SYMBOL .................................................................................... p. 450

— EXCLUDE SIGNALS .................................................................................. p. 451

NO UNDO FOR AUTOMATIC WIRE NUMBERING

BEFORE ASSIGNING WIRE NUMBERS AUTOMATICALLY, IT SHOULD STRESSED 

THAT IT IS NOT POSSIBLE TO UNDO THIS FUNCTION. THEREFORE, IT IS A 

GOOD IDEA TO SAVE THE PROJECT BEFORE ACTIVATING THE AUTOMATIC 

WIRE NUMBERING.
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When you click on Select pages, you enter a special version of the Page menu:

The pages where it is possible to perform wire numbering, are indicated by a green 
page icon. Select the pages where you wish to assign wire numbers, and click OK.

If you wish to keep the settings in the dialog box Wire Numbers, but not carry out 
the wire numbering right now, click on Close. If you do not wish to keep the new 
settings, click Cancel.

Wire numbering settings in the project file

The directions for the wire numbering you set up here, are remembered in the pro-
ject file. Thus you can perform automatic wire numbering following different guide-
lines in different projects, if you want.

When you start up a new project, the wire number settings used in the last active 
project will be suggested.

Wire numbers in the Object lister

To locate wire numbers in the project, you can use the Object lister, as described in 
“The Object Lister” on page 341.

When you use the Show net function, you get access to the same function, as 
described in “Show net” on page 222.

DESELECTING WIRE NUMBERING FOR INDIVIDUAL LINES

 1) Choose Lines and click the line.

 2) Choose Edit => Without wire number — or click the Without wire number 
button.

You can also right-click the line and choose Without wire number.

— In order to make it possible to assign wire numbers to the line again, just right-
click the line and choose Without wire number.

LOCKING THE AUTOMATIC WIRE NUMBERING

At the top of the dialog box Wire numbers you can lock the project against wire 
numbering/renumbering by selecting Lock the project against wire numbering/
renumbering. This makes it possible to avoid renumbering a project by mistake.

These pages can

be selected
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FUNCTIONS

On the wire number tab Functions, you determine the principles for the automatic 
wire numbering.

Basically, there are two different principles for performing the wire numbering, 
namely potential numbering and wire numbering.

Potential numbering

To select potential numbering, you click on Potential numbering in the upper-left 
corner of the dialog box.

Hereby each electrical potential is assigned its own wire number. If the same elec-
trical potential is separated by signal symbols (see “Signal symbols” on page 225) 
— for instance because it is used on more pages — the same wire number will be 
applied each place this potential exists.

The wire number is placed in the middle of the longest line-segment in the poten-
tial, but may be moved succeedingly if you wish.

If you want the same wire number on each side of a terminal, you click on Same 
number through terminals.

Due to the fact that cables are components of their own right, cable wires will not 
be numbered unless you check off Include cable wires.

Please observe the warning
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Wire numbering

If you want to assign a unique number to each wire in the entire project, you check 
off Wire Numbering in the upper-left corner of the dialog box.

Therefore, if you want to perform automatic wire numbering, you receive this warn-
ing:

Unambiguous drawing

To make it perfectly clear how the wires should be installed, you can make the 
drawing unambiguous:

On the ambiguously drawn figure above, it is not clear whether the horizontal wire 
connects K1 to S1, or from K1 to S2.

On the other hand, the unambiguously drawn figure clearly states that the wire 
connects K1 to S2.

It only makes sense to place a wire number on a drawn line, which only represents 
one wire. However, on the ambiguous drawing above, it is not clear whether the 

THE WIRE NUMBERING IS A QUALIFIED GUESS

IF YOU CANNOT TELL FROM THE DRAWING HOW THE WIRE NUMBERS 

SHOULD BE PLACED, YOU CANNOT ASSUME THAT THE PROGRAM CAN 

GUESS WHERE THE WIRE NUMBERS SHOULD BE LOCATED!

THE PROGRAM WILL PLACE THE CORRECT AMOUNT OF WIRE NUMBERS 

WITHIN THE INDIVIDUAL POTENTIALS, AND YOU WILL THEREFORE RECEIVE 

THE CORRECT AMOUNT OF WIRE NUMBERS IN YOUR WIRE NUMBERS FILE. — 
BUT THERE IS NO GUARANTEE THAT THE NUMBERS WILL BE LOCATED ON 

THE CORRECT WIRES, IF YOU DO NOT DRAW IN MOUNTING MODE.

Ambiguous Unambiguous

1

2
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line from S1 to the connection dot (1), or the line from the connection dot to S2 rep-
resents both wires. On the ambiguous drawing, the symbols could be connected in 
two different ways:

In this case, the program must make a qualified guess.

The program guess

Automation will make a guess 
which polyline represents more 
than one wire. These are not 
assigned a wire number.

— In this context a polyline is the 
line drawn from the connection 
point of a symbol to the connection 
dot in which the line meets another 
line. On the figure, one of the 
polyline is the line starting in the 
connection point 13, and ending in 
the connection dot.

In an electrical potential with for instance three connected symbols, two lines will 
be included. The program will then make a guess, that the shortest polyline repre-
sents both wires. Please bear this in mind when you draw diagrams.

Numbering order

To specify which corner of the page to start the wire 
numbering from, you select one of the four corners.

Also you specify whether the counting direction shall 
be Horizontal or Vertical.

Function

In the lower-left corner of the tab, you determine how 
to assign wire numbers, and where to place the wire 
numbers:

FUNCTION ACTION

PLACE MISSING DOES NOT ALTER WIRE NUMBERS THAT HAVE ALREADY BEEN PLACED, 
BUT ASSIGNS WIRE NUMBERS TO WIRES WITHOUT NUMBERS.

PLACE MISSING 

AND RENUMBER

PLACES NEW WIRE NUMBERS ON WIRES WITHOUT WIRE NUMBERS, AND 

ALLOWS ALREADY PLACED WIRE NUMBERS TO KEEP THEIR POSITION ON 

THE DIAGRAMS, BUT ALL WIRE NUMBERS ARE RENUMBERED.

Wire numbers here

Wire numbers here

Option 1 Option 2

Numbered

Not numbered
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Please notice that the further down you go on the list, the larger is the extent of the 
actions. — Please remember that Undo is no option here!

RENUMBER EXIST-

ING

THIS FUNCTION IS USED WHEN YOU HAVE PLACED ALL THE WIRE NUM-

BERS, AND DO NOT WISH TO PLACE MORE NUMBERS. THEREFORE IT 

ONLY RENUMBERS ALREADY PLACED WIRE NUMBERS - WITHOUT EXAM-

INING WHETHER OTHER WIRES LACKS WIRE NUMBERS.

REMOVE EXISTING 

AND REPLACE

ALL EXISTING WIRE NUMBERS ARE REMOVED COMPLETELY, AND NEW 

WIRE NUMBERS ARE PLACED. THE EARLIER POSITION OF THE WIRE 

NUMBERS ARE NOT REMEMBERED.

REMOVE EXISTING REMOVES ALL WIRE NUMBERS FROM THE PROJECT.

FUNCTION ACTION
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FORMAT FOR AUTOMATIC WIRE NUMBERS

Here you determine the numbering principles for the wire numbers.

FORMAT ACTION

PREFIX HERE YOU CAN PLACE A PREFIX, WHICH IS PLACED AT THE START 

OF THE WIRE NUMBERS.

NUMBERING ONLY FOR POTENTIAL NUMBERING: HERE YOU GET THE POSSIBIL-

ITY TO CHOOSE CONNECTED COMPONENT/CONNECTION. HEREBY 

THE WIRE NUMBER IS ASSIGNED BASED ON THE NAME OF A CON-

NECTION POINT AMONG ONE OF THE CONNECTED COMPONENTS IN 

THE ELECTRICAL POTENTIAL — FOR INSTANCE -Q1:2.

START NUMBER HERE YOU CAN SPECIFY A START NUMBER FOR THE WIRE NUM-

BERS.

FIXED DIGITS HERE YOU STATE WHETHER THE WIRE NUMBERS SHALL CONTAIN 

A FIXED NUMBER OF DIGITS — FROM TWO TO NINE.

PRECEDE PAGE NUM-

BER

PLACES THE PAGE NUMBER IN THE FIRST PART OF THE WIRE NUM-

BER. — CAN ONLY BE CHOSEN IF FIXED DIGITS HAVE BEEN 

CHECKED OFF. INSERTION OF A NEW PAGE BETWEEN PAGES, 
WHICH USES THIS TYPE OF WIRE NUMBERS, WILL NOT CHANGE 

WIRE NUMBERS AUTOMATICALLY.

PAGE SEPARATOR INSERTS A USER DEFINED SEPARATOR BETWEEN THE PAGE NUM-

BER AND THE WIRE NUMBER.

RESTART ON PAGE 

SHIFT

MAKES THE WIRE NUMBERS START ALL OVER ON EACH PAGE.
— CAN ONLY BE SELECTED IF PRECEDE PAGE NUMBER IS 

SELECTED.

SPARES PR. PAGE RESERVES AN EXTRA POOL OF AVAILABLE WIRE NUMBERS FOR 

EACH DIAGRAM PAGE. THUS YOU MAKE ROOM FOR WIRE NUMBERS 

THAT ARE APPLIED LATER ON, WITHOUT THIS CAUSING ANY 

CHANGES TO THE OTHER WIRE NUMBERS IN THE PROJECT.
— DOES NOT MAKE MUCH SENSE IF YOU HAVE CHECKED OFF 

RESTART ON PAGE SHIFT.

RESTART WHEN 

REF.DESIGN. CHANGE

HERE YOU CAN SPECIFY THAT THE WIRE NUMBERING RESTARTS 

WHEN THE REFERENCE DESIGNATION CHANGES. CHOOSE EITHER 

LOCATIONAL ASPECT, FUNCTIONAL ASPECT OR FULL REFER-

ENCE DESIGNATION.
mation

Page 449



P

Automatic wire numbering
Please note, that in the right-hand side of the tab, you can see an example on how 
the wire numbers would appear in a (fictional) project.

NUMBER SYMBOL FOR AUTOMATIC WIRE NUMBERING

When you assign a wire number to a wire, this is done by placing a wire number 
symbol, having the wire number as its symbol name.

When you click on the tab Number symbol, you state which symbol will be used 
as the wire number symbol.

If you want to change which symbol is being used, you click on Browse, whereby 
you enter the Symbol menu. Here you click on the desired wire number symbol, 
and click OK.

You can only apply symbols of the type Wire number.

Position of wire number symbol

In the lower-left corner, you specify whether the wire number symbols are placed 
on the Left side or on the Right side of vertical lines.

Design your own wire number symbol

If you want to design your own wire number symbols, you can see how to design 
symbols in “Creating Symbols” on page 761.
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EXCLUDE SIGNALS FROM AUTOMATIC WIRE NUMBERING

Because some users do not wish to number certain signals, it is possible to deter-
mine which signals should be excluded from the automatic wire numbering.

Select the signals you want to transfer and click on the Transfer button, or click on 
the Transfer all button to exclude all signals from the automatic wire numbering.

Correspondingly you can select excluded signals in the right hand side of the tab, 
and revert them by clicking on the Revert button, or click on the Revert all button 
to get all excluded signals back on the included list of signals to be numbered.
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MANUAL PLACING OF WIRE NUMBERS

If you want to make sure that certain wires in the project are assigned specific wire 
numbers, you can apply the wire numbers manually.

It is a good strategy to place the wire numbers you want to place first, and then 
apply the automatic wire numbering function, as described in “Automatic wire num-
bering” on page 443.

FETCHING A WIRE NUMBER SYMBOL

The wire numbers are placed by a wire number symbol, which you place on the 
line that shall have the wire number.

To fetch a wire number symbol you click on the Symbols and the Symbol menu 
button, to enter the Symbol menu. Or press <F8> to enter the menu directly.

Here you choose a wire number symbol — for instance the symbol WIRENO in the 
MISC folder — and click OK.

Please note, that this wire number must be of the symbol type Wire number.

Place the wire number symbol in the pickmenu

Also, you can place the wire number symbol in the pickmenu, as described in “Pla-
cing symbols in the pickmenu” on page 198.

This speeds up the manual placing of the symbol.

Please refer to “Fetching symbols” on page 151 for further details about fetching 
symbols.

THIS CHAPTER DESCRIBES

— FETCHING A WIRE NUMBER SYMBOL .........................................................p. 452

— PLACING A WIRE NUMBER SYMBOL ...........................................................p. 453

— AUTOMATICALLY INCREMENTING OF WIRE NUMBER NAMES .........................p. 453
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PLACING A WIRE NUMBER SYMBOL

You now have the wire number symbol in the cross hairs, and click on the wire you 
want to place the symbol on.

If the wire already has a wire number, you will get this message:

If you want to place another wire number, click No, and you enter the dialog box 
Wire number data.

If Enter Wire Numbers Manually is not selected, the program automatically sug-
gest the next available wire number — according to the wire numbering principle 
specified in Functions => Wire Numbers.

If Enter Wire Numbers Manually is selected, you can specify the wire number 
names independent of these settings. This way the program supports, that you can 
apply a specific numbering principle for the naming of your manually placed wire 
numbers.

If you select Protected, the wire number will not be renamed or moved automati-
cally when you change the wire numbers automatically in Functions => Wire 
numbers.

AUTOMATIC INCREMENTING OF MANUALLY PLACED WIRE NUMBERS

Having selected Enter Wire Numbers Manually, you can for instance type in L1/1, 
press down <Ctrl>, and click on Plus. Hereby you activate the automatic incre-
menting of the manually placed wire number names. Click OK.

When you place the wire number in a potential already having a wire number, you 
can select Change all in Potential to L1/1. This way you rename all wire numbers 
in the potential. This function is particularly useful when you have copied diagrams 
from other projects.

Now click on another wire, and notice that the name of the new wire number now 
have been incremented to L1/2. Click OK.
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OTHER FUNCTIONS IN THE DIALOG BOX

By selecting Visible in the dialog box, you specify that the wire number should be 
visible on the diagrams.

The buttons +, -, ? and  function as described in “Placing and Naming symbols” 
on page 171.
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WIRE NUMBER FILES

In Automation you can create wire number files for a wire numbering tool. This 
chapter describes how to create wire number files.

CREATING A WIRE NUMBER FILE

When you want have your wire numbers saved in a file, you choose Lists => Wire 
number file.

You then enter this dialog box:

Here you have the following options:

New or All wire numbers

The program keeps track of which wire numbers have been saved in a file. There-
fore clicking on Not yet written (new) only gives you a file with wire numbers, 
which have not been written to a wire number file earlier.

If you want all wire numbers in the project included in the file, you click on All.

How many numbers pr. wire

If you only want a single wire number pr. wire, click on 1 number pr. wire, if you 
want two wire numbers for each wire, you click on 2 numbers pr. wire.

WIRE NUMBERS PR. CONNECTION

If you choose 1 number pr. connection, one wire number pr. connection is cre-
ated. This function only has relevance for potential numbering, where two wires 

THIS CHAPTER DESCRIBES

— CREATING A WIRE NUMBER FILE................................................................p. 455

— CREATING A CONNECTIONS LIST FILE FOR WIRE NUMBERING......................p. 456
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under the same terminal has the same number, and therefore can use the same 
wire number label.

Wire numbers to file according to Line color and Line width

It is furthermore possible to create wire number files, which is sorted according to 
line color and/or line width for the line on which the wire number is placed.

This makes it possible succeedingly to handle the wire numbers differently in the 
wire numbering tool, in which the file is loaded.

To sort the wire numbers, select Sort on Line Color and/or Sort on Line Width.

Wire numbers to file acc. to Function, Location and Product aspect

If you use reference designations on wire numbers — see “Insert reference desig-
nations on signals” on page 617 —, you can also specify whether to include the 
Function aspect, the Location aspect and/or the Product aspect in the file.

Specify name and file format for the wire number file

In the field Wire Numbers File you type in the name of the wire number file, as 
well as the path that leads to the file. The extension of the file specifies the file for-
mat — see the options in the figure below.

By clicking on Browse, you enter the dialog box Save as. Here you can find the 
folder and/or the file name you want to use for the file, and specify the file format for 
the wire number file.

OPENING THE WIRE NUMBER FILE

If you select Open list file in the dialog box Wire Numbers File, the wire number 
file is subsequently opened in a program according to the file format. If for instance 
you selected Microsoft Excel (*.xls), the file is opened in Excel, if you have this 
program installed on your PC.

Creating the wire number file

When you click OK, a wire number file is created, which can be loaded in a wire 
numbering tool, from which you can print the wire numbers to place on the actual 
wires.

CONNECTIONS LIST FOR WIRE NUMBERING

In Automation you can create a connections list file, which contains component 
names with connections for all electrically connected components. Hereby a com-
plete connections list is displayed, where name and connection is displayed for 
each individual connection.

This list can succeedingly be sent to a wire numbering tool, from which you can 
have all the necessary wire numbers printed.

It is also possible to create connections lists with wire numbers, so that the list can 
be used for mounting.
Automation

age 456



Wire number Files

Auto
Creating a connections list for wire numbering

Choose Lists => Connections List File, and you enter this dialog box:

If you create a connections 
list file, which only contains 
component names with con-
nections for all of the electri-
cally connected components, 
just choose the datafield 
Name twice.

When you then select With 
Connection Name for both 
of these datafields, and for 
instance set the one to From 
and the other to To.

You can also select Name 
once and choose either 
From/To or To/From.

— Read more about the 
options in this dialog box in “Specifying the contents of the file” on page 723, and 
see “The buttons in the right-hand side of the dialog box” on page 722 also.
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Settings for Connections lists for file

If you click on Setup, you enter the following dialog box:

Here you have the following options for specifying how to sort the list:

WIRE NUMBERS

The file is sorted by wire numbers, so that the lowest wire numbers are placed first.

COMPONENT NAMES

The file is sorted alphabetically by component names. Thus for instance all wires 
attached to the component -K1 comes first, then wires attached to -K2 etc.

COMPONENT DRAWING LOCATION

The file is sorted according to the pages in the project. First comes everything from 
page 1, then everything from page 2 etc.

STARTING POINT OF WIRES

The file is sorted by the starting 
points, as displayed in the figure to 
the right.

WRITE COMPLETE NETS

If you select Write complete nets, the connections in the same nets are listed in 
succession.

INCLUDE CABLES IN LISTS

Select Include cables in lists, in order to include cables in the list.

CLICK OK

Select the desired setting, and click OK.

— Read more about lists to files in “Exporting list files” on page 717.

IF YOU NEED TO CREATE 

CONNECTIONS LIST FILES 

ACCORDING TO OTHER 

DIRECTIONS, PLEASE CON-

TACT PCSCHEMATIC
A/S.

1

2

3

4

5

6
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SINGLE LINE DIAGRAMS

Automation supports single line diagrams — except for PLCs.

This means that you can draw lines that represents several connections. Corre-
spondingly, you can place symbols, representing several symbols of the same 
kind.

There are three places where you can specify that a line or a symbol represents 
more lines or components. This is in the signal names, the connection names and 
the symbol names.

Single line diagrams and lists

These lines and symbols are automatically unpacked in the lists of the project. 
When it comes to lists, it therefore makes no difference whether you have created 
single line diagrams or ordinary diagrams.

SIGNAL NAMES IN SINGLE LINE DIAGRAMS

As an example, you can draw the signals L1, 
L2 and L3 with just single line.

The only thing you need to do, is to assign 
the signal name L1,L2,L3 to the signal, as 
displayed on figure 2.

On the symbol K1, the connection name of 
the contact to the left is set to 1, which spec-
ifies it is connected to L1.

The connection name of the contact in the 
middle gets the name ,3. This specifies that 
it is connected to L2, because L2 is speci-
fied as the second signal in the signal name.

Correspondingly, the name ,,5 tells you that 
the contact to the right is connected to the 
signal L3.

THIS CHAPTER DESCRIBES

— SIGNAL NAMES IN SINGLE LINE DIAGRAMS .................................................p. 461

— CONNECTION NAMES IN SINGLE LINE DIAGRAMS ........................................p. 462

— SYMBOL NAMES IN SINGLE LINE DIAGRAMS................................................p. 462

— SYMBOLS FOR SINGLE LINE DIAGRAMS IN PICKMENU..................................p. 462

— SYMBOLS WITH STATES FOR SINGLE LINE DIAGRAMS .................................p. 462

Figure 1

Figure 2
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CONNECTION NAMES IN SINGLE LINE DIAGRAMS

On figure 3, the symbol for K1 has 
been replaced by a symbol, which 
only displays one contact.

However, the three names in the con-
nection points of K1, specify that the 
symbol represents a component hav-
ing three contacts.

Therefore the connection names still 
specify the same connections as on 
the other figures.

SYMBOL NAMES IN SINGLE LINE DIAGRAMS

By assigning the names Q1,Q2,Q3 to a sym-
bol, you can in a similar way let a symbol rep-
resent three — or more — symbols of the 
same type.

These two figures represent two different ways 
of drawing the same connection.

SYMBOLS FOR SINGLE LINE DIAGRAMS IN PICKMENU

See how to place symbols for single line diagrams in the pickmenu for a compo-
nent from the database in “Specifying alternative electrical symbols via the data-
base” on page 652.

SYMBOLS WITH STATES FOR SINGLE LINE DIAGRAMS

Symbols can be created with different states, so that the symbols changes appear-
ance when their state number is changed.

Hereby the same symbol can be applied for single line diagrams, where e.g. lines 
across the symbol indicates the number of phases used.

— See how to apply symbols with states in “Symbols with states” on page 185.

— See how to create symbols with states in “Creating symbols with states” on 
page 777.

Figure 3
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This section describes:

- Survey of PLC functions .....................................p. 465

- Working with PLCs ..............................................p. 466

- Importing PLC I/O data .......................................p. 483

- Addressing PLC I/O data via Excel ...................p. 486

- Connection symbol for signal buses ................p. 488

VIDEOS, TUTORIALS AND SURVEY ARTICLE

WATCH THE VIDEO SERIES ABOUT WORKING WITH PLCS 

ON OUR YOUTUBE CHANNEL AT www.youtube.com/
PCSCHEMATIC.

READ THE SURVEY ARTICLE ON WORKING WITH PLCS AT

www.pcschematic.com/articles.

AT www.pcschematic.com/manuals YOU CAN ALSO 

DOWNLOAD THE MINI MANUAL “PLC TUTORIAL”, WHICH 

GUIDES YOU THROUGH CREATING A PLC PROJECT.

PLC functions

http://www.youtube.com/PCSCHEMATIC
http://www.youtube.com/PCSCHEMATIC
http://www.youtube.com/PCSCHEMATIC
http://www.youtube.com/PCSCHEMATIC
http://www.pcschematic.com/articles
http://www.pcschematic.com/articles
http://www.pcschematic.com/manuals
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SURVEY OF PLC FUNCTIONS

When working with PLCs in Automation you have the following options:

 1) Working with PLCs: See “Working with PLCs” on page 466.

 2) Working with PLCs and sub drawings: Read the mini manual "PLC tutorial".

 3) Exporting/Importing PLC I/O data: See “PLC I/O addressing via Excel” on 
page 486.

 4) Controlling PLC related texts for other symbols: See “Text links” on 
page 144, particularly “Text links and importing PLC I/O lists” on page 148.

 5) Editing PLC I/O data via the Object Lister: See “Typing in PLC I/O data via 
the Object Lister” on page 477 and “Editing PLC I/O data via the Object 
Lister” on page 349.

 6) PLC I/O addressing via Excel: “PLC I/O addressing via Excel” on page 486.

 7) Addressing PLC symbols via the database: See “Addressing PLC symbols 
via the database” on page 660.

 8) Applying alternative PLC symbols: See “Alternative symbols for PLCs” on 
page 653.

 9) Connection symbol for signal buses: See “Connection symbol for signal 

buses” on page 488.

THIS CHAPTER DESCRIBES

THIS CHAPTER GIVES A SURVEY OF WHICH OPTIONS YOU HAVE WHEN WORKING WITH 

PLCS IN Automation.

WATCH THE PLC VIDEOS / READ THE "PLC TUTORIAL"

TO GET AN INTRODUCTION TO WORKING WITH PLCS, IT IS RECOMMENDED 

THAT YOU WATCH THE VIDEO SERIES ABOUT WORKING WITH PLCS ON OUR 

YOUTUBE CHANNEL AT www.youtube.com/PCSCHEMATIC.

YOU CAN ALSO READ THE "PLC TUTORIAL". HERE YOU FIND A DESCRIPTION 

OF THE OPTIONS YOU HAVE IN THE PLC MENU.

THE TUTORIAL CAN BE DOWNLOADED AT www.pcschematic.com/manuals.

http://www.dps.dk/english/Video/Product_videos.htm
http://www.pcschematic.com/manuals
http://www.pcschematic.com/manuals
https://www.youtube.com/PCSCHEMATIC
https://www.youtube.com/PCSCHEMATIC
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WORKING WITH PLCS

— Please also refer to “PLC I/O addressing via Excel” on page 486, in particular 
“Export of PLC I/O data to Excel” on page 486.

ON PLC REFERENCE SYMBOLS

When working with PLCs in Automation, you should 
— as your first action — place a PLC reference sym-
bol, which carries the data for the PLC, and functions 
as a kind of control centre for the PLC.

When you have placed the PLC reference symbol, you 
will then typically load the I/O list for the PLC, or type in 
I/O data manually in the program. Not until then will 
you start placing the PLC I/O symbols in Automation.

— Read more about the workflow in “Workflow for 
PLCs from the database” on page 469.

THIS CHAPTER DESCRIBES

— ON PLC REFERENCE SYMBOLS.................................................................p. 466

— MORE THAN ONE PLC REFERENCE SYMBOL FOR THE SAME PLC COMPONENTp. 467

— ASSIGNING ADDRESSES TO PLCS VIA THE DATABASE ................................p. 468

— WORKFLOW FOR PLCS VIA THE DATABASE ...............................................p. 469

— RE-ADDRESSING PLCS.............................................................................p. 474

— PLC DATA ON THE CONNECTION POINTS OF THE I/O SYMBOLS...................p. 476

— TYPING IN PLC I/O DATA VIA THE OBJECT LISTER.....................................p. 477

— JUMPING BETWEEN PLC REFERENCE SYMBOLS AND PLC I/O SYMBOLS .....p. 478

— WORKFLOW FOR PLCS NOT IN THE DATABASE ..........................................p. 479

— SYNCHRONIZING PLC DATA WHEN COPYING BETWEEN PROJECTS ..............p. 481

— UPDATING PLC PROJECTS FROM PREVIOUS VERSIONS ..............................p. 481

PLC reference symbol
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Each line in the PLC reference symbol represents a node

In each individual line in the PLC reference symbol, you can see information about 
one individual node (input/output) on the PLC:

Each of these nodes on the PLC can be represented as individual PLC I/O sym-
bols in the project drawings. You can also apply PLC symbols representing e.g. 
eight nodes.

All re-addressing is performed via the PLC reference symbol

All general re-addressing of PLCs / PLC modules, takes place via the PLC refer-
ence symbols, as described in “Re-addressing PLCs” on page 474.

Creating PLC reference symbols

See how to create PLC reference symbols in “Creating Symbols” on page 761, in 
particular “Creating PLC reference symbols” on page 793.

MORE PLC REFERENCE SYMBOLS FOR THE SAME PLC COMPONENT

You can also control PLC I/O data for a PLC component by using more than one 
PLC reference symbol for the component.

— Please also refer to “Re-addressing when more PLC ref. symbols for a compo-
nent” on page 474.

I/O address

for the node

Connection name on

the PLC (connect-

point on the PLC)

Another connection

name (Here for the

supply)

Reference to the I/O symbol in the project

(Double-click to jump to the I/O symbol)
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ASSIGNING PLC ADDRESSES DIRECTLY FROM THE DATABASE

All PLC components can be assigned addresses directly 

from the database. This saves time, and reduces the risk 
for errors when typing in data.

Read more about this in “Creating components in the 
database” on page 647, particularly “Addressing PLC 
symbols via the database” on page 660.

As an example on this, you can refer to the PLC with 
EAN number PCS8920107 in the included database.

Base addressing of PLCs recommended

It is recommended that all PLCs in the database has a 
base addressing, so that they are assigned the 
addresses they would have, if they were placed in posi-
tion 0 (lowest address).

This also applies for PLCs — e.g. PLC modules — which 
does not have fixed addresses.

This is because the base addressing tells the program which addressing principle 
should be applied for this particular PLC during subsequent re-addressing in 
Automation.

PLCs in the included database

In the database that you get along with the Automation software, you find the 
PLCs under the Electronic systems folder, where they are placed in the PLC 

control systems sub folder.

VIDEO: CREATE YOUR OWN PLC COMPONENTS IN THE DATABASE EASILY

TO SEE HOW TO EASILY CREATE YOUR OWN PLC COMPONENTS WITH 

ATTACHED SYMBOLS IN THE DATABASE, PLEASE WATCH THE PLC VIDEOS IN 

THE "CREATE YOUR OWN COMPONENTS EASILY" PLAYLIST ON OUR YOUTUBE 

CHANNEL AT WWW.YOUTUBE.COM/PCSCHEMATIC.

THERE IS ALSO A "CREATE YOUR OWN COMPONENTS EASILY (COMPONENT 

WIZARD)" TUTORIAL, WHICH YOU CAN DOWNLOAD AT www.pcs-
chematic.com/manuals.

PLC addressed

directly from the

database
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WORKFLOW FOR PLCS FROM THE DATABASE

When you are using PLCs which have been posted in your database for 
Automation — see “Creating components in the database” on page 647 and 
“Addressing PLC symbols via the database” on page 660 —, the following work-

flow is recommended:

1. Select a PLC and place the PLC reference symbol

1a) Press <d> to enter the database and select a PLC, or choose a PLC which 
has been placed in the program pickmenu with data from the database.
— Select for instance the PLC with EAN number PCS8920101 in the 
included database.
You can now see the symbols for the PLC in the Symbols for component 
window in the lower-right corner of the screen:

1b) Choose the first of the PLC reference symbols (in the figure above: the ref-
erence symbol for the outputs), place it on a project page, and assign a 
name to the component in the dialog box Component data.

PLCS AND SUB DRAWINGS

WHEN YOU WISH TO WORK WITH PLCS AND USE SUB DRAWINGS, PLEASE 

READ THE MINI MANUAL "PLC TUTORIAL". HERE YOU FIND A DESCRIPTION 

OF THE ADVANCED POSSIBILITIES YOU HAVE FOR DOING THIS.

THE MANUAL CAN BE DOWNLOADED AT www.pcschematic.com/manuals.

The PLC reference symbols are placed on this tab 
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The reference symbol is now placed on the project page:

At the same time the PLC is included in the Components window in the 
upper-right corner of the screen (If necessary, see “The Component menu” 
on page 254). Here you will always be able to find the PLC in the project:

1c) From the PLC reference symbol, you can now control all data for the PLC in 
the project. In each individual line in the PLC reference symbol, you can see 
information about an individual node in the PLC, represented by I/O symbols 
for the PLC in the project — see “Each line in the PLC reference symbol 
represents a node” on page 467.

2. Loading the PLC I/O list

2a) Now add labels and descriptions to the PLC in one of the two following 
ways:
— Load an I/O list for the PLC, as described in “Reading PLC I/O lists” on 
page 483. Load e.g. the file Pcsexcelio.xls in the Lists folder (apply the for-
mat file ExcelIO.plc — the PLC must be named -K1), which matches the 
selected PLC with EAN number PCS8920101 in the included database. Or:
— Type in labels and descriptions for the PLC via the Object Lister, as 
described in “Typing in PLC I/O data via the Object Lister” on page 477. 
(Please also read “Re-addressing PLCs” on page 474).
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3. Placing PLC I/O symbols in projects

3a) You can now place the I/O symbols for the PLC in the project: Click on the 
tab for the output symbols under Available symbols and select an I/O sym-
bol — or select the symbol in the list in the upper part of the Symbols for 
component window — and place it in the project.
Under Available symbols the address for each symbol is written in red. 
Connection names are displayed as for other symbols. — See more about 
PLC symbols in Available symbols in “Filtering and other special options for 
PLCs” on page 260.

3b) Now place the remaining PLC I/O symbols.

Other options for working with PLCs

There are a couple of options under Available symbols, which can be handy 
when working with PLCs containing many I/O symbols:

Place all

You can right-click on an I/O symbol and choose Place all. This makes it possible 
to for instance place all outputs on the diagram in a single operation.

If page/current path numbers are applied, the symbols are placed with a spacing 
that corresponds to the distance between the current paths, and there is placed no 
more than one symbol for each current path on the page.

Select the IO symbol

Name on output

Address

Tab for output symbols
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Stack similar symbols

When working with PLCs with many I/O symbols, you can choose to click the 
Stack similar symbols button. This way, similar symbols are displayed as a single 
symbol along with a specification of how many symbols it covers (12 in the exam-
ple below).

When you click the "stacked" symbol, a list contain-
ing all the names, that you can choose the individ-
ual I/O symbols from, is displayed. You also get the 
option of choosing Place all.

Filter on addresses

When you click the Filter button under Available symbols, you can specify an 
interval of addresses for which of the symbols for the component to display — for 
instance from O.02 to O.07:
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Please also refer to:

- “More PLC reference symbols for the same PLC component” on page 467.

- “Re-addressing PLCs” on page 474.

- “PLC data on the I/O symbol connection points” on page 476.

- “On PLC reference symbols” on page 466.

- You can also read the independent mini manual "PLC tutorial". Here you are 
introduced to the best ways of working with PLCs. You can also see how to use 
the advanced options for keeping track the addressing when working with 
PLCs and sub drawings. The manual can be downloaded at www.pcs-
chematic.com/manuals.
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RE-ADDRESSING PLCS

All re-addressing of PLC modules in Automation takes place via the PLC refer-
ence symbols.

To re-address, do the following:

 1) Right-click on the PLC reference symbol, choose Component data, and 
click on the tab I/O address:

 2) Type in a new start address for the PLC in the left-hand side, click on From 
left/high — or pick another corner to start numbering from —, choose Num-
ber system, and click OK. (See “Options on the tab I/O address in the Com-
ponent data dialog box” on page 474).

Options on the tab I/O address in the Component data dialog
box

On the tab I/O address in the Component data dialog box, you have the following 
options:

Specify start address

In the left-hand side you type in the start address in the field Input and/or Output.

RE-ADDRESSING WHEN MORE PLC REF. SYMBOLS FOR A COMPONENT

ONLY INPUTS/OUTPUTS ATTACHED TO THE PLC REFERENCE SYMBOL IS RE-
ADDRESSED. WHEN FOR INSTANCE TWO PLC REFERENCE SYMBOLS ARE 

ATTACHED TO A COMPONENT, ONLY THE INPUTS/OUTPUTS REPRESENTED IN 

THE SELECTED PLC REFERENCE SYMBOL ARE RE-ADDRESSED.

WHEN YOU WISH TO RE-ADDRESS INPUTS/OUTPUTS FOR MORE PLC REFER-

ENCE SYMBOLS FOR THE COMPONENT, CHOOSE ALL RELEVANT PLC REFER-

ENCE SYMBOLS BEFORE ENTERING THE COMPONENT DATA DIALOG BOX 

AND RE-ADDRESS.
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Mode

Under Mode you can specify from which corner of the PLC reference symbol the 
numbering shall begin. Here From left/upper will be selected by default, which will 
cover most situations.

Choosing a numbering system

In the field Num. System you can choose whether to number according to the 
binary, the octal, the decimal or the hexadecimal numbering system.

Applying the addresses

To apply the addresses, Apply addresses must be activated. Apply addresses is 
deactivated each time you enter the dialog box. This ensures you that you do not 
activate a re-numbering by clicking OK after making changes in the upper part of 
the dialog box. When you make changes on the tab I/O address, Apply 
addresses is activated automatically.

Changing addresses on PLC I/O symbols

When you change the address on a PLC I/O symbol, this has the effect that all 
data for this address in the PLC reference symbol, is transferred to the PLC I/O 
symbol.

It is not recommended to change the address for a PLC I/O symbol to an address 
which does not exist in the PLC reference symbol. The only thing you should do in 
this context, is to specify that the PLC I/O symbol now represents another input/
output for the same PLC.

— Read more about this in “PLC data on the I/O symbol connection points” on 
page 476.

Exporting PLC I/O data

Read “Export of PLC I/O data to Excel” on page 486 for information about how to 
export PLC I/O data from Automation.

RENUMBERING PLC ADDRESSES WITH COMPOUND NUMBERING SYSTEMS

WHEN RENUMBERING OF PLC ADDRESSES, Automation ALSO HAN-

DLES RENUMBERING FOR MIXED NUMBERING SYSTEMS — E.G. DECI-

MAL NUMBERING BEFORE THE PERIOD COMBINED WITH OCTAL 

NUMBERING AFTER. FOR INSTANCE CAN I17.0-I17.7 BE RENUMBERED 

TO I18.0-18.7.

IN THE FIELD NUM. SYSTEM YOU MUST SPECIFY THE NUMBERING SYS-

TEM APPLIED AFTER THE PERIOD.
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PLC DATA ON THE I/O SYMBOL CONNECTION POINTS

When working with PLC I/O symbols, data for the PLC inputs/outputs are attached 
to the connection points on the PLC I/O symbols. This makes it possible to either 
document PLCs using PLC I/O symbols representing e.g. eight inputs/outputs, or 
by PLC I/O symbols representing a single input/output in each symbol.

The I/O address determines the other texts in the dialog box

It is the address of the PLC I/O symbol connection point, that determines the con-
tents in the other fields for the connection point. When you double-click on the con-
nection point and enter the dialog box Connection data, this address is specified 
in the I/O addr. field.

When you change the I/O address to another I/O address for the PLC — e.g. to the 
address 00.06 in the figure above — and sclick OK, Name, Label and Description 
for the node / connection point is updated with the data specified for the I/O 
address in the reference symbol for the PLC.

Changes in Label and Description are updated in the PLC ref.
symbol

When you change Label or Description in the dialog box Connection data, this 
information is updated in the reference symbol for the PLC. — Please note that you 
also can edit the Label and Description texts via the Object Lister, as described 
in “Typing in PLC I/O data via the Object Lister” on page 477.

RE-ADDRESSING PLCS ONLY POSSIBLE FROM PLC REFERENCE SYMBOLS

ALL GENERAL RE-ADDRESSING OF PLCS TAKES PLACE VIA THE PLC REF-

ERENCE SYMBOLS. — SEE “Re-addressing PLCs” on page 474.

Double-click on the connection point,

and see PLC data for the node

Or: Right-click on the symbol, and

choose PLC I/O data ...

... and edit data via

the Object Lister
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When you change Label and/or Description and at the same time change the I/O 
address in the dialog box, the changes in Label/Description will be overwritten by 
the new data, which are fetched — via the address — from the PLC reference sym-
bol.

TYPING IN PLC I/O DATA VIA THE OBJECT LISTER

When you wish to type in / edit PLC I/O 
data manually in Automation, do the 
following:

 1) Right-click on the reference sym-
bol for the PLC, and click on PLC 
I/O data.

 2) You now enter the Object Lister, 
where PLC I/O data are displayed 
for the selected PLC reference 
symbol.
If the data for the PLC is spread 
over more than one PLC reference symbol, only I/O data for the inputs/out-
puts represented by the selected PLC reference symbol is displayed.

 3) In the Object Lister: Click on the Pencil, double-click on the relevant fields 
(or click and press <F2> / <Enter>), and type in the new data.

RE-ADDRESSING PLCS

IF YOU WISH TO RE-ADDRESS A PLC, PLEASE READ “Re-addressing PLCs” 
on page 474.
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 4) Click OK, and the change(s) are transferred to the PLC.

Read more about the Object Lister in “The Object Lister” on page 341. Here you 
can read about the options for applying automatic counting functions, and the pos-
sibilities for saving data in various file formats.

— Please read “Reading PLC I/O lists” on page 483 also.

JUMPING BETWEEN PLC REF. SYMBOLS AND PLC I/O SYMBOLS

When you have placed an I/O symbol, you can — in the PLC reference symbol — 
double-click on the reference to the I/O symbol, and you jump to the I/O symbol.

On the PLC I/O symbol you can double-click on the reference to the PLC reference 
symbol, and you jump to the line for the selected I/O symbol in the PLC reference 
symbol:

— Read more about references in “Automatically updated references” on 
page 421.

EDITS ONLY I/O DATA ATTACHED TO THE SELECTED PLC REF. SYMBOL

WHEN YOU RIGHT-CLICK AND CHOOSE PLC I/O DATA, YOU CAN ONLY EDIT 

THE I/O DATA ATTACHED TO THIS REFERENCE SYMBOL.

THIS MAKES IT EASIER TO MAINTAIN THE SURVEY WHEN WORKING WITH 

LARGE PLCS WITH MORE THAN ONE ATTACHED PLC REFERENCE SYMBOL.

PLC reference symbol

PLC I/O symbol
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WORKFLOW FOR PLCS NOT REPRESENTED IN THE DATABASE

When you choose to work with PLCs, which does not exist in your database for 
Automation, you should do the following:

1. Select PLC reference symbol(s) for the component

1a) Select an appropriate PLC reference symbol, and place it in the project. You 
can for instance choose one of the two PLC reference symbols placed to the 
right in the pickmenu:

— If you need another already created PLC reference symbol, these can be 
found via the Symbol menu in the folder PLC346, where the PLC reference 
symbol names starts with PLCRef.

1b) Click to place the PLC reference symbol, and name it in the dialog box 
Component data. If you need more than one PLC reference symbol for the 
same PLC component, just click to place these also, and assign the same 
name to these symbols.

1c) Then address the PLC reference symbol(s) as described in “Re-addressing 
PLCs” on page 474, so that the addresses matches this PLC.

2. Type in data for the PLC

2a) Type in data for the PLC, as described in “Typing in PLC I/O data via the 
Object Lister” on page 477.

IT IS RECOMMENDED TO ADD THE APPLIED PLCS TO THE DATABASE

IT IS STRONGLY RECOMMENDED TO ADD THE APPLIED PLCS TO THE DATA-

BASE. THIS CAN SAVE YOU A LOT OF TIME IN THE FUTURE, AND REDUCE THE 

RISK FOR ERRORS. — PLEASE ALSO SEE “Assigning PLC addresses dire-
ctly from the database” on page 468.

IT IS ALSO RECOMMENDED TO USE THE BUILT IN COMPONENT WIZARD FOR 

CREATING PLCS IN THE DATABASE. THE MANUAL FOR THE COMPONENT 

WIZARD MANUAL CAN BE OPENED AT HELP => COMPONENT WIZARD MAN-

UAL AND CAN BE DOWNLOADED AT www.pcschematic.com/manuals.

PLC reference symbol for inputs

PLC reference symbol for outputs

PLC pickmenu
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3. Place the PLC I/O symbols and choose PLC I/O data

• Place the PLC I/O symbols for the PLC by selecting them in the Automation 
pickmenu at the upper part of the screen:

Select an I/O symbol, and click to place it on the project page.
— If you need another already created PLC I/O symbol, these can be found 
via the Symbol menu in the folder PLC346.

• When you place the symbol you enter the dialog box Component data. Here 
you click the I/O addr button in the lower-right corner of the dialog box.

• You then enter the dialog box Inputs (or Outputs):

• Select the desired PLC in the right-hand side of the dialog box, and then select 
the desired input (or output) in the list, and click OK.
Please note that used inputs/outputs are marked by a preceding +.
Under I/O in the lower-right corner of the dialog box you can choose either to 
show all inputs and outputs in the list (All), to show all used inputs and outputs 

(+) or only to show the available inputs and outputs (-).

CHOOSE INPUTS/OUTPUTS FOR ALL PLCS IN THE PROJECT

IF YOU CHOOSE -K IN THE NAME FIELD IN THE RIGHT-HAND SIDE OF 

THE DIALOG BOX, INPUTS/OUTPUTS FOR ALL PLCS IN THE PROJECT 

WITH NAMES BEGINNING WITH -K ARE DISPLAYED.

PLC I/O symbol for output

PLC I/O symbol for input

Used Inputs are

2) Select input/output

1) Select component

marked by a + (if any)
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• When returning to the Component data dialog box, you will see that it now car-
ries data for the component, and when you click OK, you will subsequently 
see that the PLC symbol now carries the selected I/O data:

• Continue like this, until you have placed the relevant symbols.

Please also refer to:

— “Workflow for PLCs from the database” on page 469.

— “Re-addressing PLCs” on page 474.

— “PLC data on the I/O symbol connection points” on page 476.

SYNCHRONIZING PLC DATA WHEN COPYING BETWEEN PROJECTS

If you merge project pages from different projects, so that the pages containing the 
PLC symbols come from one project, while the pages with the PLC reference sym-
bols come from another, no synchronization are made between the PLC symbols 
and the PLC reference symbols.

This is because the program does not know whether to transfer the values from the 
PLC reference symbols to the PLC symbols — or the reverse.
You specify this yourself, by using one of the following functions:

• Functions => Special Functions => Transfer data from PLC reference sym-
bols to PLC symbols, or

• Functions => Special Functions => Transfer data from PLC symbols to 
PLC reference symbols.

UPDATING PLC PROJECTS FROM PREVIOUS VERSIONS

When you wish to update a PLC project from an earlier version of Automation 
than version 7.0, to get the full benefit of applying PLC reference symbols, do the 
following:

 1) Enter the Symbol menu, click on Project symbols and update the symbol 
definition on the applied PLC I/O symbols, so that they follow the guidelines 
described in “Creating PLC I/O symbols” on page 790.

 2) In the project: Replace the applied PLC I/O symbols with the new versions of 
the symbols. Even though you save the updated PLC I/O symbols under the 
same names as before, the symbols in the project must still be replaced with 
the updated versions. — See “Replacing symbols” on page 213.
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 3) Create PLC reference symbols for all PLCs in the project. — See “Creating 
PLC reference symbols” on page 793.
(You might use the predefined PLC reference symbols in the PLC346 folder).

 4) Update the PLCs in the database, so that they now have PLC reference sym-
bols and connection names for the PLC reference symbols. — See “Creating 
PLC components in the database” on page 668.
Because the PLCs most likely are already addressed in the existing project, it 
is not strictly necessary to address the PLCs in the database, though it is 
recommended because of the subsequent use of the PLCs in other projects.
— See “Assigning PLC addresses directly from the database” on page 468.

 5) Right-click on one of the PLC I/O symbols in the project.

 6) In the Component menu under Available symbols: Click on the PLC refer-
ence symbol, and place it an appropriate place in the project. Please note 
that the PLC reference symbol is automatically filled out with data from the 
placed PLC I/O symbols.

 7) Repeat the two steps above for all PLCs in the project.

The project is now updated.
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READING PLC I/O LISTS

In Automation you can read PLC I/O lists from PLC programming tools, and have 
the changes transferred directly to your diagrams.

The reading procedure is build up step by step, so that you only make one decision 
in each dialog box. This is to avoid errors, because errors under the reading could 
be crucial.

Importing symbol datafields for PLCs

If you have created your own symbol datafields for the PLCs in the project, you can 
also import data for these symbol datafields, when importing a PLC I/O list. If data-
fields appear in the imported PLC I/O list, which are not created for the PLCs in the 
project, these datafields will not be imported.

— Read more about this in “Symbol datafields” on page 120.

CHOOSING FORMAT FILE

To start reading a PLC I/O list, choose PLC => Read PLC I/O List.

In the first dialog box, you choose which format file to use, when you read the PLC 
I/O list.

This format file contains 
information about how the 
contents of the PLC I/O file 
shall be interpreted.

Here you choose a format 
file from the displayed list, 
or click on Browse and 
choose another format file.

As you can see, you have 
the option of converting 
description texts on PLC 
connections to upper case 
characters during the 
import, by selecting Convert Description to Uppercase. You can also specify to 
keep line breaks in the imported data by selecting Keep Line Breaks in imported 
Data.

THIS CHAPTER DESCRIBES

— CHOOSING THE FORMAT FILE ....................................................................p. 483

— SPECIFYING THE FILE NAME ......................................................................p. 484

— DISPLAYING THE CONTENTS OF THE FILE ..................................................p. 484

— IF MORE THAN ONE PLC IN THE PROJECT..................................................p. 485

— DISPLAYING THE CHANGES IN THE PROJECT ..............................................p. 485
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Click Next.

— For further information about format files, please refer to “Format files” on 
page 718.

SPECIFYING THE FILE NAME

You are then asked about 
the name of the PLC I/O file 
itself.

To keep the survey of the 
project file names, it is rec-
ommended to let the file 
have the same name as the 
project — but off course 
having another extension 
(such as .txt for text files, or 
.xls for Excel files).

Click on Browse if you 
need to locate another file, 
and then click Next.

THE CONTENTS OF THE FILE

You can then see the con-
tents of the file you are 
going to read, in order to 
make sure, that you have 
chosen the correct file.

The contents of the file will 
be displayed in columns, for 
clarity — even though it 
might actually be a comma 
separated file. If the column 
width is incorrect, this can 
also be detected here.

Apply the elevator in the 
right-hand side of the dialog box, to see the entire contents of the file.

Please notice, that it is not possible to make changes in the file here.

Click Next if no errors are found in the file.

If you find an error, click Cancel, and the file will not be read.

CONNECTION NAMES AS PART OF PLC NAMES

DURING LOAD OF PLC I/O LISTS, THE CONNECTION NAMES OF THE PLC I/
O’S CAN BE A PART OF THE PLC NAME, SO THAT YOU DO NOT NEED A SEP-

ARATE COLUMN FOR CONNECTION NAMES IN THE PLC I/O FILE. (E.G. 
K1:1).
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IF MORE THAN ONE PLC EXISTS IN THE PROJECT

If no name has been specified for the PLC in the file, and there are more than one 
PLC in the project, you must now select which PLC the file contents matches:

Click on the PLC, and click OK.

DISPLAYING THE CHANGES IN RELATION TO THE PROJECT

It is then displayed which 
changes the PLC program-
mer have made, compared 
to the information in the pro-
ject.

When there are ## charac-
ters in a datafield, this 
means that the program has 
not been able to locate this 
datafield in the project.

If the sign ^ already is 
applied to signify line 
breaks, the program esti-
mates which column width the use of this sign corresponds to. In the following, the 
program places ^ signs in the new texts, in order to make them follow a similar col-
umn width.

If you need to, click on Print to print out the changes for documentation purposes, 
or to pass it on to the PLC programmer.

If everything is in order, then click on Execute. It is not until you click here, that the 
program reads the PLC I/O list.
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PLC I/O ADDRESSING VIA EXCEL

In Automation it is possible to export PLC I/O data to an Excel file, which can be 
opened in Excel automatically.

For further details about the options in the individual dialog boxes, please refer to 
“Reading PLC I/O lists” on page 483.

EXPORT OF PLC I/O DATA TO EXCEL

In a project containing PLCs — such as Plcdemo.pro —, exporting PLC I/O data 
can be done like this:

 1) Choose PLC => PLC List File:

THIS CHAPTER DESCRIBES

— EXPORTING PLC I/O DATA TO EXCEL .......................................................p. 486

— IMPORTING PLC I/O DATA FROM EXCEL....................................................p. 487

EXCEL MUST BE INSTALLED

IT IS ONLY POSSIBLE TO SAVE AND OPEN FILES IN EXCEL FORMAT IF EXCEL 

IS INSTALLED ON THE PC.

READ MORE ABOUT THIS IN “Excel must be installed to perform Excel 
Import/Export” on page 735.
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 2) Click on Open — to open a format file specifying which information to 
include in the generated file. (You can also specify this information in the dia-
log box manually).

 3) In the dialog box Open: Select the format file ExcelIO.plc in the folder 
Pcselcad — or another suitable format file for the export — and click OK.

 4) The settings are now as displayed in the dialog box above. Please note that 
the file format is set to Microsoft Excel(R), and that Run Microsoft 
Excel(R) is selected.

 5) Select Field Header in the dialog box, so that you get a header in the Excel 
sheet, that informs you about the contents of the columns.

 6) Click OK.

 7) When there is more than one PLC in the project, you now enter a window, 
where you select which PLC(s) to export PLC I/O data for, or whether to 
export PLC I/O data for.
Select a PLC, or select multiple PLCs — e.g. by pressing <Ctrl> and clicking 
on them — or select all by clicking on All.

 8) Click OK.

 9) Excel is now started, and the created PLC I/O file is displayed in Excel.

IMPORTING PLC I/O DATA FROM EXCEL

In Automation you can update I/O addresses having a PLC name and connection 
number in the PLC I/O list file.

See how to import a PLC I/O list in Excel format in “Reading PLC I/O lists” on 
page 483.
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CONNECTION SYMBOL FOR SIGNAL BUSES

When you want to display a signal bus on the drawing, you do this by drawing a 
wide non conducting line.

— Please refer to “Creating Join symbols” on page 806 to see how to create join 
symbols.

To specify a signal bus as displayed above, do this:

 1) Find a symbol for an IC or a PLC and place it on the drawing.

 2) Activate the Pencil and click the Lines button, select a wide line type — for 
instance like the one above — and set the line width (A:) to an appropriate 
size. On the drawing above it is set to 2.5 mm.

 3) Draw a line like the left-most line on the drawing.

 4) Then draw a line like the one on the right side of the symbol. The lines must 
not be conducting (which they also can not be when you are using a wide line 
type).

 5) You have now drawn the two signal buses: Deactivate the Pencil (press 
<Esc>), select a thin line type, and click on the line to the left of the circuit. 
Thus the line is selected.

 6) Then choose Edit => Join signal — or right-click on the line and choose 
Join signal.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO WORK WITH CONNECTION SYMBOLS FOR SIGNAL BUSES.
Automation

age 488



Connection symbol for signal buses

Auto
 7) A rubber band now emerge starting from the selected line and ending up in 
the cross hairs. Mark up a window that includes all the connection points on 
the left side of the circuit.

 8) The following dialog box appears:

 9) Below Signal name you either type in a name, or specify the name using the 
buttons under the Signal name field, as described in “Specify Signal name” 
on page 227.
If you click on the up- or down-arrow in the right hand side of the dialog box, 
you can choose between the signal symbols, that are defined in the system. 
The symbol itself will also be shown in the window inside the dialog box.
In the upper-left corner you state whether the number in the signal names 
shall be assigned from Top to bottom or from Bottom to top.
Click OK when you are satisfied with the settings.

 10) Press <Esc>, and the line is no longer selected.

 11) If you just want to connect one connection point to the signal symbol, you 
can try to click on the thick line at the right-hand side of the circuit. Thus the 
line is selected.

 12) Then choose Edit => Join signal.

 13) A rubber band now appears starting from the line and ending up in the 
cross hairs. Now click on the connection point on the circuit you wish to con-
nect to the bus.

 14) A dialog box, like the one above, now appears on the screen, and you con-
tinue as described above.

 15) When you have connected the first connection point to the signal bus, you 
will see that there is still a rubber band radiating from the signal bus to the 
cross hairs. If you want to connect more legs to the bus, you can now carry 
on connecting their connection points individually.

 16) If you want to determine yourself where on the line the signal symbol shall 
be located, just select Point at position in the dialog box. When you click 
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OK after doing this, the next thing to do is to click between the signal bus and 
the connection point, where you want the signal symbol to be placed.

The program keeps full control over where the signals enters and leaves the signal 
bus via the signal names. When for instance the signal name A0 is connected 
somewhere to the signal bus, the signal continue the next place A0 is connected to 

the signal bus.

CHANGE SIGNAL SYMBOL BY PRESSING <SPACEBAR>

WHEN YOU HAVE SELECTED A SIGNAL SYMBOL, YOU CAN CHANGE BETWEEN 

THE PREDEFINED SIGNAL SYMBOLS BY PRESSING <SPACEBAR>.
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open . . . . . . . . . . . . . . . . . . . . . . . . . . . 730
open new project by importing  . . . . . . . . 731

DXF files . . . . . . . . . . . . . . . . . . . . . . . . . . . 729
calculate scale . . . . . . . . . . . . . . . . . . . . 280
export . . . . . . . . . . . . . . . . . . . . . . . . . . 732
export project as  . . . . . . . . . . . . . . . . . . 732
export symbol as . . . . . . . . . . . . . . . . . . 734
import . . . . . . . . . . . . . . . . . . . . . . . . . . 730
import as symbol . . . . . . . . . . . . . . . . . . 732
open . . . . . . . . . . . . . . . . . . . . . . . . . . . 730
open new project by importing  . . . . . . . . 731

E
Edit

templates  . . . . . . . . . . . . . . . . . . . . . . . 843
Edit =>

Align . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66
Convert to lines . . . . . . . . . . . . . . . . . . . 107
Copy to Clipboard  . . . . . . . . . . . . . . . . . 575
Data tags  . . . . . . . . . . . . . . . . . . . . . . . 315
Find  . . . . . . . . . . . . . . . . . . . . . . . . . . . 351
Find next . . . . . . . . . . . . . . . . . . . . . . . . 352
Insert special . . . . . . . . . . . . . . . . . . . . . 739
Join signal . . . . . . . . . . . . . . . . . . . 488, 489
Links . . . . . . . . . . . . . . . . . . . . . . . . . . . 742
Next  . . . . . . . . . . . . . . . . . . . . . . . . . . . 208
Paste  . . . . . . . . . . . . . . . . . . . . . . . . . . 282
Pinswop  . . . . . . . . . . . . . . . . . . . . . . . . 211
Previous  . . . . . . . . . . . . . . . . . . . . . . . . 208
Replace  . . . . . . . . . . . . . . . . . . . . . . . . 353
Scale  . . . . . . . . . . . . . . . . . . . . . . . . . . 331
Select all =>

All on layer  . . . . . . . . . . . . . . . . . . . . 531
All on page  . . . . . . . . . . . . . . . . . . . . . 57

Space  . . . . . . . . . . . . . . . . . . . . . . . 68, 699
Variables . . . . . . . . . . . . . . . . . . . . . . . . 294
Without wire number . . . . . . . . . . . . . . . . 444

Edit symbol datafields, tool  . . . . . . . . . . . . . . 848
Editing symbols for a building  . . . . . . . . . . . . 526
EIB, symbol folder  . . . . . . . . . . . . . . . . . . . . 247
Electrical installation . . . . . . . . . . . . . . . . . . . 519
Electrical installations

in different elevations  . . . . . . . . . . . . . . . 525
Electrical lines  . . . . . . . . . . . . . . . . . . . . . . . . 79
Electrical potentials  . . . . . . . . . . . . . . . . . . . 225

automatic insertion of  . . . . . . . . . . . . . . . . 86
on lower part of page . . . . . . . . . . . . . . . 87
on upper part of page . . . . . . . . . . . . . . . 87
settings for . . . . . . . . . . . . . . . . . . . . . . 88

Electrical symbols
components having more  . . . . . . . . . . . . 651
create automatically  . . . . . . . . . . . . . . . . 219

box symbols . . . . . . . . . . . . . . . . . . . . 220
circle symbols  . . . . . . . . . . . . . . . . . . 220
connection points  . . . . . . . . . . . . . . . . 220
from database  . . . . . . . . . . . . . . . . . . 221

place based on placed mechanical symbols 708
Elements of a project  . . . . . . . . . . . . . . . . . . 539
Elevation . . . . . . . . . . . . . . . . . . . . . . . 532, 969

lines changign elevation  . . . . . . . . . . . . . 532
select elevated objects . . . . . . . . . . . . . . 532

Elevation window . . . . . . . . . . . . . . . . . . . . . 969
Ellipses  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
Empty lines between Terminal Rows . . . . . . . 609
EN 60445-2017  . . . . . . . . . . . . . . . . . . . . . . 188
EN 81346  . . . . . . . . . . . . . . . . . . . . . . . . . . 371
EN1861 . . . . . . . . . . . . . . . . . . . . . . . . . . . . 247
EN60204-1,14.2.1, standard . . . . . . . . . . . . . 272
EN60617, symbol folder  . . . . . . . . . . . . . . . . 248
EN61082, standard  . . . . . . . . . . . . . . . . . . . 927
EN61346

signal names according to  . . . . . . . . . . . 232
EN61439-3  . . . . . . . . . . . . . . . . . . . . . . . . . 519
Enter Wire Numbers Manually . . . . . . . . . . . . 453
Error

general protection error . . . . . . . . . . . . . . . 49
Even pages  . . . . . . . . . . . . . . . . . . . . . . . . . 362
Excel

integration with, survey . . . . . . . . . . . . . . 735
place symbols via lists  . . . . . . . . . . . . . . 743
PLC I/O addressing via . . . . . . . . . . . . . . 486

Explorer window . . . . . . . . . . . . . . . . . . 335, 909
displaying and hiding information . . . . . . . 336
move . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
Selecting a symbol on a page . . . . . . . . . 338

Export
DWG and DXF files  . . . . . . . . . . . . . . . . 732
PLC I/O data to Excel . . . . . . . . . . . . . . . 486
project as DWG or DXF file . . . . . . . . . . . 732
symbol as DWG or DXF file  . . . . . . . . . . 734

Extend line . . . . . . . . . . . . . . . . . . . . . . . . . . . 97
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Extend line button . . . . . . . . . . . . . . . . . . . . . . 95
Extended lines . . . . . . . . . . . . . . . . . . . . . . . . 95
Extensions

of list files . . . . . . . . . . . . . . . . . . . . . . . . 727
External program  . . . . . . . . . . . . . . . . . . . . . 721

F
FABRICATE (Show all) . . . . . . . . . . . . . . . . . 634
Fabricate choice

in Database menu  . . . . . . . . . . . . . . . . . 677
Factor, ellipses . . . . . . . . . . . . . . . . . . . . . . . 107
Favorites  . . . . . . . . . . . . . . . . . . . . . . . . . . . 854
Field headings  . . . . . . . . . . . . . . . . . . . . . . . 724
File =>

Close . . . . . . . . . . . . . . . . . . . . . . . . . . . 570
Close and return to PCschematic project . 740
Export to =>

DWG / DXF . . . . . . . . . . . . . . . . . . . . 732
PDF . . . . . . . . . . . . . . . . . . . . . . . . . 367

Modules . . . . . . . . . . . . . . . . . . . . . . . . . 849
New . . . . . . . . . . . . . . . . . . . . . 35, 564, 838
New =>

PCschematic project file . . . . . . . . . . . . 884
Open Unit  . . . . . . . . . . . . . . . . . . . . . . . 836
Print  . . . . . . . . . . . . . . . . . . . . . . . . . . . 361
Print =>

Select pages =>  . . . . . . . . . . . . . . . . . 531
Save unit as . . . . . . . . . . . . . . . . . . . . . . 835
Send to  . . . . . . . . . . . . . . . . . . . . . . . . . 541

File format  . . . . . . . . . . . . . . . . . . . . . . . . . . 724
File type registration, dialog box  . . . . . . . . . . 883
Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 969

commasep. files
place symbols via  . . . . . . . . . . . . . . . . 743

DWG/DXF  . . . . . . . . . . . . . . . . . . . . . . . 729
file names

in database fields  . . . . . . . . . . . . . . . . 685
from Object Lister . . . . . . . . . . . . . . . . . . 347
lists as files  . . . . . . . . . . . . . . . . . . . . . . 717
pindata files  . . . . . . . . . . . . . . . . . . . . . . 658
registering PCSCHEMATIC filtypes . . . . . 883
wire number . . . . . . . . . . . . . . . . . . . . . . 455

Files =>
Modules =>

Scripts  . . . . . . . . . . . . . . . . . . . . . . . 851
Fill character  . . . . . . . . . . . . . . . . . . . . . . . . 118
Filled areas  . . . . . . . . . . . . . . . . . . . . . . . . . . 75
Find Next . . . . . . . . . . . . . . . . . . . . . . . . . . . 352
Find Whole Text Only . . . . . . . . . . . . . . . . . . 352
Fixed digits  . . . . . . . . . . . . . . . . . . . . . . . . . 449
Fixed text direction . . . . . . . . . . . . . . . . . . . . 136
Flat buttons  . . . . . . . . . . . . . . . . . . . . . . . . . 908
FLOWCHAR, symbol folder . . . . . . . . . . . . . . 248
Fold corner  . . . . . . . . . . . . . . . . . . . . . . . . . . 75

for reference frames . . . . . . . . . . . . . . . . 409
FOLDERS  . . . . . . . . . . . . . . . . . . . . . . . . . . 964
Folders  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 969

change symbol in . . . . . . . . . . . . . . . . . . 796
delete symbol from . . . . . . . . . . . . . . . . . 796

most used . . . . . . . . . . . . . . . . . . . . . . . .912
symbol folders  . . . . . . . . . . . . . . . . . . . .247

Follow connected button  . . . . . . . . . . . . .96, 804
Follow connected lines  . . . . . . . . . . . . . . . . . .95
Font . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .134
Foreign languages  . . . . . . . . . . . . . . . . . . . .855
Format file  . . . . . . . . . . . . . . . . . . . . . . . . . .718
Formulas

insert  . . . . . . . . . . . . . . . . . . . . . . . . . . .585
projects  . . . . . . . . . . . . . . . . . . . . . . . . .563

Frame  . . . . . . . . . . . . . . . . . . . . . . . . . . . . .135
Free texts . . . . . . . . . . . . . . . . . . . . . . .109, 969

change . . . . . . . . . . . . . . . . . . . . . . . . . .830
Ftp

links in database fields  . . . . . . . . . . . . . .685
Full circle  . . . . . . . . . . . . . . . . . . . . . . . . . . .106
FUNCTION . . . . . . . . . . . . . . . . . . . . . . . . . .965
Function aspects . . . . . . . . . . . . . . . . . .373, 381
Functions =>

Auto command change  . . . . . . . . . . . . . . .57
Auto Name . . . . . . . . . . . . . . . . . . . . . . .196
Centre drawing . . . . . . . . . . . . . . . . . . . .562
Component Grouping  . . . . . . . . . . .238, 614
Coordinates  . . . . . . . . . . . . . . . . . . . . . . .98
Count down  . . . . . . . . . . . . . . . . . . . . . .132
Count up  . . . . . . . . . . . . . . . . . . . . . . . .132
Database =>

Find Article . . . . . . . . . . . . . . . . . . . . .169
Find Type . . . . . . . . . . . . . . . . . . . . . .170
Insert in Database  . . . . . . . . . . . . . . . .649
Update from Database  . . . . . . . . . . . . .191

Design Check . . . . . . . . . . . . . . . . .355, 358
Design Check =>

Used more than once

deselect . . . . . . . . . . . . . . . . . . . .359
Generate isometry . . . . . . . . . . . . . . . . . .562
Go to Available symbols  . . . . . . . . . . . . .263
Measurement  . . . . . . . . . . . . . . . . . . . . .710
Mechanical load  . . . . . . . . . . . . . . . . . . .698
Object Lister . . . . . . . . . . . . . . . . . . . . . .342
Place Accessory . . . . . . . . . . . . . . . . . . .246
Place available Symbols  . . . . . . . . . . . . .268
Replace symbol  . . . . . . . . . . . . . . . . . . .213
Select name . . . . . . . . . . . . . . . . . . . . . .264
Show conducting . . . . . . . . . . . . . . . . . . . .80
Show signal  . . . . . . . . . . . . . . . . . . . . . .231
Special Functions =>

Convert Branches to Dots  . . . . . . . . . . .104
Convert Dots to Branches  . . . . . . . . . . .104
Convert to Branches . . . . . . . . . . . . . . .104
Create CurrentPath No on all Symb . . . . .437
Exchange Article with Alt. Article on all Symbols 

673
Prefix all symbol names with -  . . . .403, 908
Set all articles as approved in the database 681
Set unreferenced cable symbols invisible  .246
Set unreferenced signal symbols invisible .232
Transfer data from PLCref. to PLCsymb.  .481
Transfer data from PLCsymb. to PLCref.  .481
Transfer Proj. Texts to Auto Compl. func.  .110
Automation
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Special functions =>
Replace all symbols  . . . . . . . . . . . . . . 216

Update references . . . . . . . . . . . . . 426, 435
View Jumper Links . . . . . . . . . . . . . . . . . . 92
Wire numbers  . . . . . . . . . . . . . . . . . . . . 443

G
General protection error . . . . . . . . . . . . . . . . . 49
General purpose texts  . . . . . . . . . . . . . . . . . 109
General, tab  . . . . . . . . . . . . . . . . . . . . . . . . 598
Generation names . . . . . . . . . . . . . . . . . . . . 437
German version

PCSCHEMATIC Viewer . . . . . . . . . . . . . 748
Grafisk klemplan, værktøj . . . . . . . . . . . . . . . 848
Graphical terminal plans, tool

Tools
Grapgical terminal plans  . . . . . . . . . . . 847

Grid  . . . . . . . . . . . . . . . . . . . . . . . . . . . 48, 969
Grid display . . . . . . . . . . . . . . . . . . . . . . . . . 906
Ground plan  . . . . . . . . . . . . . . . . . . . . . . . . 521

place symbols on . . . . . . . . . . . . . . . . . . 525
with elevation  . . . . . . . . . . . . . . . . . . . . 532

Ground plan, page type  . . . . . . . . . . . . . . . . 560
Group Number . . . . . . . . . . . . . . . . . . . . . . . 617
Grouping

components  . . . . . . . . . . . . . . . . . . . . . 613
layers  . . . . . . . . . . . . . . . . . . . . . . . . . . 529

Guess
wire numbers . . . . . . . . . . . . . . . . . . . . . 446

H
Half circle  . . . . . . . . . . . . . . . . . . . . . . . . . . 106
Heat loss calculation

acc. to EN61439-3 . . . . . . . . . . . . . . . . . 519
Height . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 134
Help  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
Help =>

Check for updates  . . . . . . . . . . . . . . . . . 919
Http

//www.pcschematic.com  . . . . . . . . . . . . 19
Help frame  . . . . . . . . . . . . . . . . . . . . . . 36, 909
Help objects color  . . . . . . . . . . . . . . . . . . . . 861
Hints . . . . . . . . . . . . . . . . . . . . . . . . . . 909, 969
Home view

set User Home view . . . . . . . . . . . . . . . . . 45
HOMEDIR . . . . . . . . . . . . . . . . . . . . . . . . . . 914
Horizontal reference . . . . . . . . . . . . . . . . . . . 140
Horizontal, tab . . . . . . . . . . . . . . . . . . . . . . . 434
Hot-line . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
House drawing  . . . . . . . . . . . . . . . . . . . . . . 521
Http

links in database fields . . . . . . . . . . . . . . 685
Hungarian version

PCSCHEMATIC Viewer . . . . . . . . . . . . . 748
Hydraulics

place symbols via lists  . . . . . . . . . . . . . . 743
Hydraulics, symbols . . . . . . . . . . . . . . . . . . . 248

I
I/O lists

read . . . . . . . . . . . . . . . . . . . . . . . . . . . . 483
I/O symbols

create PLC I/O symbols  . . . . . . . . . . . . . 790
IEC 81346 . . . . . . . . . . . . . . . . . . . . . . . . . . 371
IECINST, symbol folder  . . . . . . . . . . . . . . . . 248
IECPNEU, symbol folder . . . . . . . . . . . . . . . . 248
Ignored, page function  . . . . . . . . . . . . . . . . . 548
Image

insert . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66
scale . . . . . . . . . . . . . . . . . . . . . . . . . . . 331

Image functions  . . . . . . . . . . . . . . . . . . . . . . . 42
Import

DWG and DXF files  . . . . . . . . . . . . . . . . 730
as page in project  . . . . . . . . . . . . . . . . 730

PLC I/O data from Excel . . . . . . . . . . . . . 487
Include cable wires . . . . . . . . . . . . . . . . . . . . 445
Include fixed accessories from Database . . . . 599
Include Lines with article data . . . . . . . . . . . . 599
Index

on-line manual . . . . . . . . . . . . . . . . . . . . . 41
Indexed variables . . . . . . . . . . . . . . . . . . . . . 962
Information

automatic information . . . . . . . . . . . . . . . 852
Insert

data fields  . . . . . . . . . . . . . . . . . . . . . . . 812
image  . . . . . . . . . . . . . . . . . . . . . . . . . . . 66
list . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 593
logo . . . . . . . . . . . . . . . . . . . . . . . . . . . . 581
page for mechanical drawing . . . . . . . . . . 696
unit drawing . . . . . . . . . . . . . . . . . . . . . . 625

Insert - in front of symbol names  . . . . . . 403, 908
Insert =>

Insert data field  . . . . . . . . . . . . . . . 116, 931
Insert object . . . . . . . . . . . . . . . . . . 737, 738
Insert Picture  . . . . . . . . . . . . . . . . . . . . . 330
Insert Potential . . . . . . . . . . . . . . . . . . . . . 86
Insert Reference Frame  . . . . . . . . . . . . . 407
Insert sub drawing  . . . . . . . . . . . . . . . . . 100

Insert Line Point
for reference frames . . . . . . . . . . . . . . . . 409

Insert new  . . . . . . . . . . . . . . . . . . . . . . . . . . 545
symbols or connection names . . . . . . . . . 328

Insertion points . . . . . . . . . . . . . . . . . . . . . . . 312
Install modules . . . . . . . . . . . . . . . . . . . . . . . 849
Installation

electrical installation . . . . . . . . . . . . . . . . 519
pickmenu . . . . . . . . . . . . . . . . . . . . . . . . 525

instdemo.pro, demo project . . . . . . . . . . . . . . 525
Intelligent

copying of areas . . . . . . . . . . . . . . . . . . . 271
reference designations . . . . . . . . . . . . . 274

Interface
database . . . . . . . . . . . . . . . . . . . . . . . . 670

Internet
automatic information and update  . . . . . . 852

Interval in minutes  . . . . . . . . . . . . . . . . . . . . 918
mation
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Invert text . . . . . . . . . . . . . . . . . . . . . . . . . . . 127
Invisible . . . . . . . . . . . . . . . . . . . . . . . . . . . . 528

areas . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
circles  . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
lines  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
objects . . . . . . . . . . . . . . . . . . . . . . . . . . . 69
Sub drawings . . . . . . . . . . . . . . . . . . . . . . 71
symbols . . . . . . . . . . . . . . . . . . . . . . . . . . 69
texts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70

ISO
paper size  . . . . . . . . . . . . . . . . . . . . . . . 561

ISO 81346 . . . . . . . . . . . . . . . . . . . . . . . . . . 371
Isometric, page type . . . . . . . . . . . . . . . . . . . 560
Isometrical drawing . . . . . . . . . . . . . . . . . . . . 562
Isometrical symbols

create  . . . . . . . . . . . . . . . . . . . . . . . . . . 692
Italic text  . . . . . . . . . . . . . . . . . . . . . . . . . . . 136

J
JIS

paper size  . . . . . . . . . . . . . . . . . . . . . . . 561
Join symbols

define  . . . . . . . . . . . . . . . . . . . . . . . . . . 806
Jokers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 605
Jumper links . . . . . . . . . . . . . . . . . . . . . . . . . . 91

in lists and terminal plans  . . . . . . . . . . . . . 92

K
Keep cursor position . . . . . . . . . . . . . . . . . . . 906
Keep page zoom  . . . . . . . . . . . . . . . . . . 44, 908
Keep zoom  . . . . . . . . . . . . . . . . . . . . . . 44, 908
Klemmer

standarder . . . . . . . . . . . . . . . . . . . . . . . 188
Klemmer for indgående ledere  . . . . . . . . . . . 188
Komponenter

rename selected
selecting symbols  . . . . . . . . . . . . . . . . 324

L
Language . . . . . . . . . . . . . . . . . . . . . . . . . . . 919
Layers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 528

and drawing headers  . . . . . . . . . . . . . . . 530
change using the mouse . . . . . . . . . . . . . 530
grouping layers . . . . . . . . . . . . . . . . . . . . 529
print page with  . . . . . . . . . . . . . . . . . . . . 531
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This section deals with the functions in PCSCHE-
MATIC Automation, which are specially designed for 
electrical installation drawing.

Following topics are elaborated:

- Creating a ground plan drawing........................p. 521

- Layers, Elevation and Scaling ............................p. 527

- Tips for installation drawing ................................p. 534

If you want to document small switchboards and 
panels with heat loss calculation according to 
EN61439-3, then read the mini manual “Panel 
Builder tutorial”. You can also see how to create an 
electrical installation project in the mini manual “Elec-
trical installation tutorial”.

Both can be downloaded at www.pcschematic.com/
manuals.

OTHER RELEVANT CHAPTERS

— EXPORTING/IMPORTING DWG/DXF FILES p. 729

— INSERTING UNIT DRAWINGS p. 625

— CREATING UNIT PARTS LISTS/DRAWINGS p. 833

Electrical installation drawing

http://www.pcschematic.com/manuals
http://www.pcschematic.com/manuals
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CREATING A GROUND PLAN

This chapter is an example on how to draw a ground plan for a house.

Please note, that it is also possible to import and export DWG and DXF files, as 
described in the Tools manual.

PREPARING FOR A GROUND PLAN DRAWING

Start a new project by clicking the New document button.

Page settings

Choose Settings => Page setup, 
click on Ground plan/Mechanical, 
select the Scale factor 1:50, and 
choose the paper size A3 — or 
another paper size, that fits your 
drawing. Read more about this in 
“Setting up the page to vertical A4 
format” on page 808. Click OK.

Choose Settings => Pointer/
Screen and set the unit of meas-
urement to meters (m).

Click OK.

Moving the origo

Before drawing the house, you can move the origo of the page, so that it is no 
longer located in the lower-left corner of the page:

THIS CHAPTER DESCRIBES

— INITIAL PREPARATIONS FOR A GROUND PLAN DRAWING .............................p. 521

— DRAWING THE WALLS OF THE HOUSE ........................................................p. 523

— DRAWING THE INNER WALLS .....................................................................p. 524

— PLACING SYMBOLS ON A GROUND PLAN....................................................p. 525

— ELECTRICAL INSTALLATIONS IN DIFFERENT ELEVATIONS.............................p. 525

— EDITING SYMBOLS FOR A BUILDING...........................................................p. 526

— WORKING WITH THE DWG AND DXF FORMATS .........................................p. 526

THE PAGE FUNCTION MUST BE SET TO NORMAL

TO USE A PAGE FOR A GROUND PLAN DRAWING, THE PAGE FUNCTION FOR 

THE PAGE MUST BE SET TO NORMAL.
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 1) Click the Move origo button, which gives you the rep-
resentation of the origo in the cross hairs

 2) You now either click wish to position you want the origo, 
or click in the coordinates field at the lower part of the 
screen, where the X-Y coordinates are displayed. The 
coordinates field could for instance look like this:

 3) This dialog box will appear:

 4) Select Absolute. Set X to 5 and Y to 5. You do not have to type in the unit of 
measurement m, because you have already told the program that you are 
working in meters

 5) Click OK

The coordinates for any object placed on the page, will be calculated from the new 
position of the origo.

An easier way to enter the Coordinates dialog box, is by using the short-cut 
<Ctrl+i>.

ORIGO COORDINATES CALCULATED FROM THE LOWER LEFT CORNER

WHEN YOU PLACE THE ORIGO USING THIS DIALOG BOX, THE COORDINATES 

FOR THE ORIGO ITSELF ARE ALWAYS CALCULATED FROM THE LOWER LEFT 

CORNER OF THE PAGE.

The coordinates field
Automation
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Selecting the type of line

If you are not familiar with how to draw lines, please refer to “Lines” on page 72.

When you are drawing the ground plan for a building, you should always use a line 
type (T) and line distance (A), that matches the inner and outer walls. Here you set 
the line distance to the size of the inner and outer walls in real life.

The reason you do this, is because you have already told the program that you are 
working in 1:50. An outer wall of 30cm will therefore have to be drawn with a line 
distance of 300 (mm) - or type in 30cm in the A: field. Please note that the Con-
ducting lines button is automatically deselected for this type of lines.

Weather to draw the lines with Extended line, see “Extended lines” on page 95.

DRAWING THE WALLS OF THE HOUSE

You can now draw the walls in the house you see below:

 1) Click the Lines button, set the line type (T) according to the instructions 
above, and pick an appropriate line distance (A)

 2) Click the Rectangle button in the tool bar for lines, and activate the Pencil 
button

 3) Press <Ctrl+i> or click the Coordinates field, select Absolute, set X and Y to 
0

 4) Click OK. You now start drawing the rectangle (the outer walls) in the point 
(0,0)

Choose this Line type first Then type in this Line distance
mation

Page 523



P

Creating a Ground Plan
 5) To set the opposite corner of the rectangle, press <Ctrl+i>, choose Relative, 
set X to 10 and Y to 7. Click OK

This instructs the program to draw a rectangle with the measurements 10m x 7m, 
starting from the origo.

You can read more about drawing with absolute, relative and polar coordinates in 
“Drawing by measures” on page 98.

DRAWING THE INNER WALLS

 1) Choose a new type of line — according to the figure above — and set the 
line distance to 12cm

 2) Select the Lines button, the Straight lines button and the Pencil

 3) Press <Ctrl+i>, choose Absolute, set X to 7, Y to 0 and click OK.

 4) Press <Ctrl+i> again, choose Relative, set X to 0, Y to 7m and click OK

You can also draw the walls without using the coordinate box.

Now draw the rest of the house using absolute and relative coordinates where 
most appropriate.

DISPLAYING ABSOLUTE AND RELATIVE COORDINATES

THE ABSOLUTE COORDINATES ARE DISPLAYED CONTINUOUSLY IN THE LOWER-LEFT COR-

NER OF THE SCREEN. WHEN YOU ARE DRAWING A LINE OR A RECTANGLE, THE FIELD NEXT 

TO THE COORDINATES WILL SHOW YOU THE COORDINATES RELATIVE TO THE STARTING 

POINT OF YOUR LINE/RECTANGLE.

LINES OPEN UP WHEN YOU PLACE SYMBOLS

WHEN YOU DRAW THE LINES, YOU DO NOT HAVE TO CONSIDER WHERE THE 

DOORS AND WINDOWS ARE GOING TO BE PLACED. WHEN YOU PLACE THE 

WINDOW AND DOOR SYMBOLS ON THE LINES LATER, THE LINES WILL OPEN 

UP AND MAKE ROOM FOR THEM AUTOMATICALLY.

Absolute coordinates Relative coordinates
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PLACING SYMBOLS ON A GROUND PLAN

To place doors, windows etc. on the drawing, click on the Building tab in the pick-
menu, until the displayed pickmenu appears.

From here you can pick the symbols you wish to place on the drawing.

Choosing a symbol

To choose a symbol from the Symbol menu, do the following:

 1) Click the Symbols button and the Symbol menu button — or use the short-
cut keys <s> and <F8> to enter the Symbol menu

 2) In the Symbol menu: Select the folder/alias Building

 3) Click on a symbol you wish to place on the ground plan

 4) Click OK

You have now got the symbol in the cross hairs. Click where you wish to place the 
symbol in your ground plan. The symbol can be moved, rotated and deleted as 
described earlier.

The symbol can be placed on a line by clicking on the line, and space will be made 
for the symbol. The symbol will orientate itself according to the direction of the line. 
It will be rotated counter-clockwise. If the symbol is being moved, it will stick to the 
line (wall) it is placed on.

You can read more about symbols in “Symbols” on page 149.

ELECTRICAL INSTALLATIONS IN DIFFERENT ELEVATIONS

If you wish to place electrical installations on the drawing, it is possible to place 
these in different heights/elevation. To do this you use the Elevation window in the 
upper-right corner of the screen. Symbols for electrical installations can be found in 
the Iecinst alias/folder.

It is a good idea to place the ground plan on one layer and the electrical installa-
tions on another. Also, you could have a layer with sanitary installations, a layer 
with burglar alarms — and so on. Read more about layers in “Layers, Elevation and 
Scaling” on page 527.

You can see an example of this in the project Instdemo.pro.

By clicking on Installation tab in the pickmenu, you can also see pickmenus for 
installations and pneumatics.

Click here

Click here
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USING THE GRID FOR HELP WHILE DRAWING

When you are drawing a building by measures, and the accuracy is not that impor-
tant, you can use the grid/snap for drawing. If the drawing is in scale 1:50, a snap 
of 10mm will correspond to 0.5m. See the real coordinates at the bottom of the 
screen.

The cursor will then move 0.5m each time you press one of the arrow-keys.

EDITING SYMBOLS FOR A BUILDING

If you wish to design more symbols meant for ground plans, there are a few things 
you should know:

This means you must choose Settings => Page settings, and set the scale of the 
page to e.g. 1:2, so that you can design the symbol specifying its real measures.

Symbols designed this way, will fit pages using any scales. Placing the symbol on 
for instance a 1:10 page, will give you a 1:10 symbol as well.

Windows and doors

When you design symbols that can be connected to walls/lines on a drawing, you 
have to be very careful where to place the connection points for the symbol:

As you might see, this symbol has a connection 
point on each side of the window. These connec-
tion points have to be located at exactly the same 
line as the reference point of the symbol. This 
makes it possible to open a line, and connect the 
symbol to the line automatically, when the symbol 
is placed.

The symbol must be saved as a Non conducting symbol. The Selection must be 
set to Whole symbol, when you save the symbol. — For a deeper understanding 
of this, please read “Creating Symbols” on page 761.

WORKING WITH THE DWG OR DXF FORMAT

You can load a drawing in DWG or DXF format, for instance of a building, from 
other CAD programs, such as AutoCAD. The drawing can be loaded as either a 
symbol or a project in Automation.

Read more about this in the Tools manual.

DESIGN SYMBOLS USING REAL MEASURES

WHEN YOU DESIGN A SYMBOL FOR A BUILDING, THE SYMBOL MUST BE 

DESIGNED BY SPECIFYING ITS REAL MEASURES.
Automation
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LAYERS, ELEVATION AND SCALING

In Automation you can work in different layers on the same project page. You can 
also apply scaling, and work in different elevations.

ABOUT LAYERS

If you on a drawing want to be able to display how for instance a switchboard would 
look with and without a switchboard front, you have the option of doing this by plac-
ing the switchboard, the switchboard front and the components on individual layers 
on the drawing. You can determine what you want displayed by turning the different 
layers on and off.

You can copy or move elements of drawings from one layer to another, and by 
working on layers, you can also determine which layers/parts of the drawing you 
want to be included when you print out the drawing.

You can also determine to place eventual corrections on independent layers on the 
drawing.

The layer you are working on will always be visible, but apart from this, you can 
determine yourself which layers you want displayed on the screen. On each page 
in the project you have the option of working on 255 different layers.

Layer information saved in the project file

Information about which layer is active, as well as which layers are visible, are 
saved in each project file individually.

THIS CHAPTER DESCRIBES

— ABOUT LAYERS ........................................................................................p. 527

— THE LAYER MENU.....................................................................................p. 528

— DRAWING HEADERS AND LAYERS ..............................................................p. 530

— CHANGING BETWEEN LAYERS WITH THE MOUSE ........................................p. 530

— MOVING OR COPYING BETWEEN LAYERS ...................................................p. 531

— SELECTING OBJECTS ON LAYERS ..............................................................p. 531

— PRINTING OUT A PAGE WITH LAYERS .........................................................p. 531

— DRAWING WITH ELEVATION.......................................................................p. 532

— SETTING THE SCALE OF AN ENTIRE PAGE ..................................................p. 533

— SCALING AN AREA ....................................................................................p. 533

LAYERS ARE ALSO APPLIED FOR CREATING SYMBOLS WITH STATES

LAYERS ARE ALSO APPLIED WHEN CREATING SYMBOLS WITH STATES, AS 

DESCRIBED IN “Creating symbols with states” on page 777.
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Layers, Elevation and Scaling
THE LAYER MENU

To see or change the layer settings, you first have to enter the Layer menu, which 
is done by clicking on the Layer button on the left tool bar. Clicking on 
Layer=1:Lay 1 at the bottom of the screen will have the same effect:

The pencil displayed against 1:Lay1 states that layer 1 is the active layer. When a 
layer is active, this means you can draw and make changes on this specific layer, 
while you cannot make changes on the inactive layers on the drawing.

If you see a + in front of a layer, this means something has been placed on this 
layer.

Visible layers

The light bulb that you see in front of all the other layers, tells you that these layers 
are visible. When you, like you do here, work on layer number one, you will see the 
other layers in the background drawn with the color grey on the diagrams.

If you want to work on layer three, you click on it, and then click on Active. You will 
now see that the pencil has moved to layer three.

Selecting more than one layer

If you want to make for instance layer four and six invisible, you click on layer four, 
press down <Ctrl> and click on layer six. Then you click on Invisible, and the eyes 
in front of the two names disappear.

If you then click on No visible, all the eyes disappear, and if you click on All visi-
ble, all layers have become visible again.

In order to select for instance all layers from eight to twelve, click first on layer 8, 
then keep the <Shift> key pressed down when clicking on layer 12.

Click here if you only want to see layers with contents
Automation
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Naming layers

If you want to insert a name or a description for a layer, first click on the layer, and 
then click on Rename. A new dialog box appears, you type in the new name and 
click OK. It is a good idea to assign names to the layers, so that you always use the 
same layers to the same purpose.

Saving layer changes in the project

If you regret the changes you have made, you click Cancel, otherwise you click OK 
to save them.

Saving layer settings as Default

If you have a specific use for the various layers, then save the settings as default by 
clicking on Save as default. Subsequently you can load the standard from the 
Layer menu in another project by clicking Load defaults.

Grouping layers

When you click the Groups button in the Layer menu, you have the option of 
grouping the layers according to which layers you wish to see at the same time. If 
you are working with an electrical installation project, you can for instance create a 
layer group containing the ground plan drawing and the electrical installations, and 
another layer group containing the ground plan drawing and the alarm installations.

When you click the Group button in the lower-left corner, the Layer menu is 
expanded, so that you can work with layer groups:

Creating a group

 1) In the field Group name: Type in a name for the group.
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Layers, Elevation and Scaling
 2) In the field Layers in group: Type in the layer numbers separated by com-
mas — or drag the layers from the left-hand side and place them under Lay-
ers in group at the bottom-right corner of the dialog box.

 3) Click Save group.

The layer listed first in the group becomes the active layer, while the other layers 
becomes visible.

If you click on the arrow to the right of Group of layers, the dialog box is further 
expanded, so that you can see the names of the selected layers.

Deleting a group

 1) Under Group of layers: Click on the group.

 2) Click Delete group.

Printing layer groups

When printing you can specify that you only wish to print a specific layer group. — 
See “Printing layers” on page 364.

When you no longer wish to see the layer groups, just click the Groups button 
again.

Only show used layers

When you select Only show used layers at the bottom of the dialog box, the dia-
log box only displays the layers that are used in the project.

DRAWING HEADERS AND LAYERS

Please note, that drawing headers are always placed on layer number zero, which 
is always displayed. If a drawing header is placed on a page, you will always see it, 
no matter which settings you choose in the layer menu.

CHANGING BETWEEN LAYERS USING THE MOUSE

If you press down <Alt> and click on an object which is located on another layer, 
you will be asked whether to change to this layer.

Answer Yes, and you will change layer.

Of course the object you click on have to be of the object type you are working with 
for the moment. If Symbols is active, you can change to symbols on other layers 
— and so on.
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MOVING OR COPYING BETWEEN LAYERS

When you want to move or copy objects from one layer to another, do this:

 1) Enter the Layer menu and choose the layer you want to fetch something 
from

 2) Select what you want to move/copy, right-click and choose Move or Copy

 3) Change layer

 4) Place the selected objects

SELECTING OBJECTS ON DIFFERENT LAYERS

The chapter “Selecting objects” on page 55 describes how to select objects in 
Automation. Below you can see the options of selecting objects in different layers.

Selecting everything on a layer

You can select everything on a layer by choosing Edit => Select all => All on 
layer. If the Area button is active, all objects on the page will be selected. If Lines 
is active, all lines on the layer will be selected.

Selecting an object on a different layer

If you wish to select an object located in another layer than the active, you can 
press down the <Alt> key while clicking on the object. You will then be told on 
which layer the object is located, and will get the option to change to this layer.

Selecting an area in all layers

It is possible to select everything in all layers within an area of your drawing. Select 
for instance Area and mark up an area within the page. Then right-click anywhere 
on the page and choose Select in all layers. All objects on all layers within the 
area are now selected.

If for instance you had selected Symbols in stead of Areas, only the symbols 
within the area would have been selected.

PRINTING PAGES WITH LAYERS

When you want to print out a drawing consisting of several layers, you choose File 
=> Print => Select pages => Show layer settings. Hereby you enter a dialog box 
similar to the one you entered before, but these settings only apply to what you 
print out.

Following the same guidelines as above, you now determine which layers or layer 
groups should be visible, and then click OK. In the lower part of the dialog box, you 
see how the drawing would look on print.

If you do not wish to print out the entire project, please make sure that you have 
only checked off Actual page in the lower-left part of the dialog box, and then click 
on Print in the upper-right corner.

The drawing will now be printed out on your printer. Read more about printing in 
Automation in “Printing” on page 361.
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DRAWING WITH ELEVATION

The Elevation window is used when you want to place 
objects in different elevations on ground plan pages, 
and enables you to work in three dimensions.

The Elevation window is only visible when you are 
working on a Ground plan page in the project.

To specify an elevation, click inside the Elevation win-
dow and then type in the elevation. The five latest elevations are remembered, and 
can be chosen by clicking on the down-arrow in the window.

Selecting objects in another elevation

You can only select objects that are located in the elevation you see in the Eleva-
tion window. If you press down <Shift> while clicking on an object, you automati-
cally change to the elevation in which the selected object is placed.

When you’re drawing lines and wish to connect a line to a symbol in another eleva-
tion, the program automatically shifts to the other elevation, when you connect the 
line to a connection point on the symbol.

Displaying the elevation of symbols as a hint

When a symbol is not placed in the elevation 0, the elevation is displayed as an 
InfoTip when the cross hairs is above the symbol.

Lines changing elevation

If you want to draw a line that changes elevation while drawing, you start by clicking 
where you want the line to start, then click in the Elevation window, type in the ele-

vation for the next point of the line, and click where the line shall end.

EXAMPLE ON WORKING WITH ELEVATION

SEE AN EXAMPLE ON HOW TO WORK WITH ELEVATION IN THE MINI MANUAL 

"ELECTRICAL INSTALLATION TUTORIAL".

YOU CAN DOWNLOAD IT FROM www.pcschematic.com/manuals.
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SETTING THE SCALE OF THE PAGE

The scaling on the page is set in Settings => Page setup. Here 
you determine the scale you want to apply on the page. On dia-
gram drawings the scale will typically be 1:1, while it will typically 
be 1:50 on ground plan drawings.

There is no reason to scale on diagram pages, because you can choose to draw 
on a page with the A3 page size, and make the program scale automatically to fit 
the paper size when printing out the diagram. This kind of settings are set in the 
Printer dialog box, and you can read more about automatic scaling in “Setup” on 
page 364.

The scaling on the page has great influence on the objects you place on the page. 
In the following list, you will see some examples on what to keep in mind when you 
work on scaled pages.

SCALING AREAS

It is also possible to scale an area — both on diagrams and when editing symbols. 
Read more about this in “Scaling areas” on page 280.

EXAMPLE PLEASE NOTE

DRAWING BY MEAS-

URES

WHEN YOU CHANGE THE SCALING OF THE PAGE FROM 1:1 TO 

1:50, ALL COORDINATES ON THE PAGE BECOMES 50 TIMES 

LARGER — EVEN THOUGH THE REPRESENTATION ON THE PAGE 

WILL REMAIN THE SAME. A PAGE OF THE A4 FORMAT OF 21.0CM X 

29.7CM, WILL IN THIS CASE CORRESPOND TO 10.5M X 14.85M.

GRID/SNAP YOUR GRID AND SNAP WILL ALSO BECOME 50 TIMES LARGER. 
THIS MEANS THAT A GRID ON 10MM WILL NOW CORRESPOND TO 

50CM, AND A SNAP OF 2.500MM WILL CORRESPOND TO 12.5CM.
TO MAKE THE GRID/SNAP FOLLOW THE PAGE SCALE, YOU CAN 

CLICK THE PAGE DATA BUTTON, CHOOSE THE TAB PAGE SETUP, 
AND SELECT FOLLOW PAGE SCALE .

THIS SETTING ONLY APPLIES FOR THE SELECTED PAGE(S) IN THE 

PROJECT.

SYMBOLS THE INFLUENCE OF THE SCALING ON A SYMBOL, DEPENDS ON 

WHETHER THE SYMBOL HAS AUTO SCALE OR NO SCALE ADJUST-

MENT. TYPICALLY, A SYMBOL WILL HAVE SCALE ADJUSTMENT, BUT 

NO AUTO SCALE. READ MORE ABOUT THIS IN “Symbol settings: 
Advanced” on page 773.

LINE DISTANCE WHEN YOU DRAW LINES HAVING A SPECIFIC LINE DISTANCE, IT IS 

IMPORTANT TO BEAR IN MIND THE SCALE OF THE PAGE. FOR 

INSTANCE, IF YOU DRAW A WALL OF 30CM ON A PAGE HAVING THE 

SCALE 1:50, YOU HAVE TO SET THE LINE DISTANCE (A) TO 30CM. 
THE PROGRAM WILL PERFORM THE SCALING BY ITSELF, SO THAT 

THE LINE IS DRAWN AS A 6MM LINE ON THE PAGE.
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TIPS FOR INSTALLATION DRAWING

In this chapter, you’ll find some tips, which you can use when you draw installation 
drawings. If you need general information on how to draw in Automation, please 
refer to “Basic Drawing facilities” on page 51.

You can find more options for electrical installation drawing in “Electrical installation 

drawing” on page 519.

GROUND PLAN DRAWINGS AND DWG/DXF FILES

When you wish to draw a ground plan drawing in Automation, please read “Crea-
ting a Ground Plan” on page 521. Do you need to import DWG/DXF files, please 
read “DWG and DXF files” on page 729. Please also refer to “Electrical installation 
drawing” on page 519.

PRECISE POSITIONING OF MECHANICAL SYMBOLS

Se how to position mechanical symbols precisely in “Magnetic snap and Snap in 
objects for mechanical symbols” on page 703.

DRAWING CONNECTIONS ON INSTALLATION DRAWINGS

When symbols are placed in different elevations (for instance on an installation 
drawing), Automation automatically changes elevation when the symbols are con-
nected.

— See also “Selecting objects in another elevation” on page 532.

THIS CHAPTER DESCRIBES

— GROUND PLAN DRAWINGS AND DWG/DXF FILES ......................................p. 534

— PRECISE POSITIONING OF MECHANICAL SYMBOLS ......................................p. 534

— DRAWING CONNECTIONS ON INSTALLATION DRAWINGS...............................p. 534

— CHOOSING CABLES AND WIRES IN THE PICKMENU ......................................p. 535

— INSTALLATION SYMBOLS IN THE PICKMENU WITH ELEVATION .......................p. 535

— DRAWING CONNECTIONS ON INSTALLATION DRAWINGS...............................p. 535

"ELECTRICAL INSTALLATION TUTORIAL"

AT www.pcschematic.com/manuals YOU CAN DOWNLOAD THE MINI MAN-

UAL "ELECTRICAL INSTALLATION TUTORIAL", WHICH GUIDES YOU THROUGH 

CREATING AN ELECTRICAL INSTALLATION PROJECT.

AT www.pcschematic.com/videos — AND AT www.youtube.com/pcs-
chematic — YOU CAN WATCH IT ON VIDEO.
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SELECTING CABLES AND WIRES FROM THE PICKMENU

When you are drawing with cables, wires and jumper links, these can be selected 
directly from the Pickmenu.

All of these line types can be assigned line article data in the Pickmenu. To assign 
line article data, right-click on the cable/wire/jumper link in the Pickmenu, and 
choose Component Article Data. Just like you do for symbols.

When you’re drawing cables and wires, please remember to select Include Lines 
with article data in the list settings for the parts list. — See “Which data to include 
in the list” on page 598.

INSTALLATION SYMBOLS WITH ELEVATION IN THE PICKMENU

Installation symbols in the Pickmenu can be assigned a default elevation, which 
they are automatically assigned when placed on a mechanical page.

When you are working on a page of the type Ground plan/Mechanical, just right-
click on an installation symbol in the Pickmenu, and select Elevation. You can then 
type in the default elevation for the symbol in the Pickmenu.

DRAWING LINES ON INSTALLATION DRAWINGS

When you’re drawing installation drawings, you can draw lines on top of each other, 
without displaying connection dots.

To avoid making connection dots for parallel cables, you must choose Conducting 
lines (without dot connection). This is only possible when you’re working on a 
page of the type Ground plan/Mechanical.
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In this part you can see how to work with projects in 
PCSCHEMATIC Automation. It contains following 
topics:

- On projects ...........................................................p. 539

- Pages and Chapters ...........................................p. 542

- Template and Standard projects.......................p. 563

- Copying full projects into projects.....................p. 565

- Working with More than one Project................p. 568

- Overview projects................................................p. 576

- Select/deselect options in projects ..................p. 578

- Inserting logos in projects...................................p. 581

Please also refer to the Project Generator manual to 
see how to merge projects via Excel.

READ THE SURVEY ARTICLE

READ THE SURVEY ARTICLE ABOUT WORKING WITH PRO-

JECTS AT www.pcschematic.com/articles.

Working with Projects

http://www.pcschematic.com/articles
http://www.pcschematic.com/articles
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ON PROJECTS

Automation is a project oriented program. This means, that all information you 
need when working on a project, is gathered in just one file.

Therefore you do not need to change program to e.g. create parts lists or unit 
drawings, because they are located along with your diagrams inside the project file.

THE ELEMENTS OF A PROJECT

A project typically consists of a front page, a table of contents, pages with dia-
grams, and pages containing various kinds of lists. Also, pages containing 
mechanical symbols for the applied components, can be part of the project. All 
these parts are placed on their individual page(s) inside the project. A project can 
contain several thousand pages. 

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES THE PROJECT ORIENTED CONCEPT OF 

Automation.

Table of

Project drawings

Partslists
Componentslists

Terminallists
Cableslists

PLClists

Chapter dividers

Graphical terminalplans
Graphical cableplans

Graphical connectionplans
Symbol documentation

Updated

automatically

Generated

automatic
ally

Front

contents

page
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Project diagrams

The basis of your projects are the project diagrams. Here you draw your diagrams 
by placing symbols, texts and lines on one or more pages in the project. And here 
you assign the article data to the symbols, that will be transferred to the project lists 
automatically.

How to draw diagrams, are described in the two previous sections “Basic Drawing 
facilities” on page 51 and “Electrical installation drawing” on page 519.

This section

This section covers the topics you need to know something about when you want 
to create projects, containing different types of pages:

THIS CAN ALSO BE CREATED AUTOMATICALLY

— GRAPHICAL TERMINAL PLANS

— GRAPHICAL CABLE PLANS

— GRAPHICAL CONNECTION PLANS

— SYMBOL DOCUMENTATION

THIS IS DESCRIBED IN THE PCSCHEMATIC Tools MANUAL. THERE YOU 

CAN ALSO SEE HOW TO TRANSLATE PROJECT TEXTS USING THE PROGRAM 

PCschematic Translator, AND SPECIFY PARAMETERS FOR DWG/DXF 
IMPORT/EXPORT.

CHAPTER CONTENTS PAGE

"Pages and 
Chapters"

HOW TO CREATE NEW PAGES IN A PROJECT, HOW TO FIND 

PAGES, AND WHICH TYPES OF PAGES YOU CAN CREATE.
CREATING CHAPTERS.

542

"Project templa-
tes and Standard 
projects"

HOW TO APPLY TEMPLATE PROJECTS, CONTAINING JUST 

THE PAGES YOU NEED EACH TIME YOU START A NEW PRO-

JECT.

563

"Copying full Pro-
jects into other 
Projects"

HOW TO COPY FULL PROJECT INTO OTHER PROJECTS. 565

"Several Projects 
Simultaneously"

HOW TO DRAG PAGES FROM PROJECT TO PROJECT, HOW 

TO COPY AREAS FROM PROJECT TO PROJECT, OR COPY TO 

OTHER PROGRAMS.

568

"Overview proje-
cts"

DESCRIBES HOW TO CREATE AN OVERVIEW PROJECT WITH 

LINKS TO ALL RELEVANT PROJECTS IN AN ASSIGNMENT.
576

"Projects with 
selectable opti-
ons"

DESCRIBES HOW YOU CAN CREATE PROJECTS, WHERE 

YOU CAN SELECT/DESELECT OPTIONS, AND THEN GENER-

ATE A NEW PROJECT ONLY CONTAINING THE SELECTED 

OPTIONS.

578

"Inserting logos in 
projects"

HOW TO INSERT A LOGO FOR THE FULL PROJECT. 581
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How to work with lists in projects is covered in the section “Lists” on page 583. In 
the Project Generator manual, you can furthermore see how to merge projects 
and control project data via Excel.

Project information

When you want technical information about the active project, you can right-click 
on any project page and choose Project information.

Here you get information about when the project was originally created, when it 
was last saved, which file name the project is saved under and see how many sym-
bols and connection points are used in the project.

The latter information is calculated according to directions for calculating limitations 
in Automation 40 and other limited Automation versions. Therefore symbols and 
connection points on the first mechanical project page are not included in the cal-
culation.

SENDING PROJECTS BY E-MAIL

WHEN YOU CHOOSE FILE => SEND TO, AN E-MAIL IS CREATED IN YOUR E-
MAIL PROGRAM HAVING THE ACTIVE PROJECT AS AN ATTACHMENT. YOU CAN 

THEN SEND THE PROJECT BY E-MAIL.
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PAGES AND CHAPTERS

When you wish to add or delete pages, and specify the type and function of a 
page, you typically do this in the Page menu. You can also drag pages into the 
active project from the SubDrawings tab in the Explorer window. From the Page 
menu you can also divide projects into chapters, and from here you can copy sev-
eral pages at a time, for insertion into other projects. You can also copy pages or 
projects between the open projects, just by dragging page or chapter tabs from 
one project to another.

CHOOSING PAGES OUTSIDE THE PAGE MENU

When you are not in the Page menu, you can change back and forth 
between the project pages by clicking on the tabs on the lower part of the 
page.

Or you can use the <Page Up> and the <Page Down> keys to jump back 
and forth between the project pages. Another option is clicking the Page 
history buttons, as described in “The Page history buttons” on page 543.

Also, you can choose View => Go to page, and type in a page number.

When you click the chapter tabs on the right-hand side of the screen, the 
first page of the chosen chapter is displayed. These chapter tabs are only 
displayed when the project is divided into chapters. — Read more about 
this in “Chapters” on page 555.

Collapsed chapter tabs

When chapter tabs appears among the page tabs at the bottom of the 
screen, you can choose between seeing:

THIS CHAPTER DESCRIBES

— CHOOSING PAGES OUTSIDE THE PAGE MENU.............................................p. 542

— THE PAGE MENU ......................................................................................p. 544

— INSERTING A NEW PAGE............................................................................p. 546

— COPYING, CUTTING AND PASTING MORE THAN ONE PAGE ..........................p. 551

— PASTING COPIED PAGES IN OTHER PROJECTS............................................p. 552

— MOVE, COPY AND DELETE PAGES AND CHAPTERS BY USING PAGE TABS ...p. 554

— CHAPTERS ...............................................................................................p. 555

— NAMING PAGE TABS..................................................................................p. 557

— COLORS ON PAGE TABS............................................................................p. 557

— SPECIFYING PAGE TYPE...........................................................................p. 560

— SPECIFYING PAPER SIZE ..........................................................................p. 561

— GROUND PLAN DRAWING ..........................................................................p. 561

— ISOMETRIC DRAWING ................................................................................p. 562
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a) Both the chapter tab and page tabs 
for all pages in the chapter:

b) Only the chapter tab:

You can change back and forth between 
the two views by clicking on the chapter icon on the tabs, as illustrated in the figure 
above.

When the active page is placed in a chapter, which is collapsed, the page number 
is displayed in square brackets on the chapter tab — as you can see in the figure 
above. — See more about chapters in “Chapters” on page 555.

The Page history buttons

By clicking the Page history buttons to the left of the page tabs at the bottom of 
the screen, you can jump back and forth between the pages you have been work-
ing on in the project. This function can also be activated by choosing View => 
Page history back and View => Page history forward.

You could say that these buttons function like the Back and Forward buttons in 
Microsoft Internet Explorer, with the only difference that in Automation these are 
only active within the active project.

The Select page button

When you click the little down-arrow between these two buttons, you get a survey 
of the most recently active project pages:

When you click on one of these, you jump to this page in the project. This way you 
can jump to the 10 most recently active pages in the project.

— Please note that it can be an advantage also to have activated the function 
Keep page zoom — see “Keep page zoom” on page 44.

Default short-cut keys for the Page history functions

The default short-cut keys for the three functions are:

FUNCTIONS DEFAULT SHORT-CUT KEYS

PAGE HISTORY BACK <ALT+LEFTARROW>

PAGE HISTORY FORWARD <ALT+RIGHTARROW>

SELECT PAGE <ALT+DOWNARROW>

Click here to change
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Using the Explorer window for Survey

Just to get a survey of the project pages — or for instance find a specific symbol in 
the project — you can also use the Explorer window, as described in “The Explo-
rer window: The Projects tab” on page 335.

THE PAGE MENU

Choose the Page menu by clicking on the Page menu button, or by choosing 
View => Select page.

You use the Page menu to insert new pages into the project, copy or delete pages, 
or to change the settings for the pages you have created. Or you can use it to 
choose which page in the project you want to work on. Besides, the Page menu is 
the place to keep the survey of a huge project, because you will find the titles of all 
the pages listed here.

From the Page menu you can also load other projects into the existing project. 
Read how to do this in “Project templates and Standard projects” on page 563.

Options in the Page menu

The Page menu for a project could for instance appear like this:

In front of each page an icon indicates whether the page has a horizontal or a ver-
tical page format. After this you see the page function, which is described in 
“Creating a new page” on page 546. Folders in front of pages marks the beginning 
of a new chapter.

Pages marked with a +, have been changed since the project was last saved.

Pages marked with a !, have been changed since the project was opened.

If there are pages marked with an R, this means that these pages have been 
changed since the start of a revision check. — See “Revision control” on page 878.

When colors are used for page tabs — see “Colors on page tabs” on page 557 — 
these are displayed in the C column next to the page type. If you right-click on a 
page here in the Page menu, you can also change the color of the page tab for the 
page.
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When states are selected on project pages, the selected states are displayed in 
brackets after the page titles.

In the Page menu you have the following options:

"SELECT ALL PAGES" OR "SELECT CHAPTER"

WHEN YOU RIGHT-CLICK ON A PAGE IN THE PAGE MENU, YOU CAN CHOOSE 

SELECT CHAPTER TO SELECT ALL PAGES IN THE CHAPTER. YOU CAN ALSO 

CHOOSE SELECT ALL PAGES TO SELECT ALL PAGES IN THE PROJECT.

CHOOSE FUNCTION/USE

ADD NEW ADDS A NEW PAGE IN THE END OF THE PROJECT. — SEE “Creating a new 
page” on page 546.

INSERT NEW INSERTS A NEW PAGE IN FRONT OF THE SELECTED PAGE. IF THE FIRST PAGE 

IN THE PROJECT IS SELECTED, THE PAGE WILL BE INSERTED AS A NEW FIRST 

PAGE IN THE PROJECT. — SEE “Creating a new page” on page 546.

CUT CLICK ON THE PAGE(S) YOU WISH TO CUT, CLICK ON CUT, AND CLICK OK TO 

CUT. THE PAGE(S) CAN THEN BE INSERTED WHERE YOU WANT TO, BY USING 

THE INSERT FUNCTION. (SHORT CUT KEY: <CTRL+X>).

— SEE “Copying, Cutting and Pasting more than one page” on 
page 551.

COPY SELECT THE PAGE(S) YOU WISH TO COPY, CLICK ON COPY, CLICK WHERE YOU 

WISH TO INSERT THE COPIED PAGES, AND CLICK ON INSERT, AS DESCRIBED 

BELOW. THE COPIED PAGES ARE THEN INSERTED. (SHORT CUT KEY: 
<CTRL+C>).
THE COPIED PAGES CAN ALSO BE INSERTED INTO OTHER PROJECTS.

— SEE “Page names when copying pages in the Page menu” on 
page 551 AND “Copying, Cutting and Pasting more than one page” 
on page 551.

INSERT IS USED AFTER CUT OR COPY.
CLICK WHERE YOU WISH TO INSERT THE PAGE(S), CLICK ON INSERT, AND 

CLICK OK TO INSERT. (SHORT CUT KEY: <CTRL+I>).

DELETE CLICK ON THE PAGE YOU WISH TO DELETE, CLICK ON DELETE, AND CLICK 

OK.

— SEE HOW TO SELECT MORE THAN ONE PAGE IN “Copying, Cutting and 
Pasting more than one page” on page 551.

ARTICLE 

DATA

WHEN YOU CLICK HERE, YOU CAN EDIT THE ARTICLE DATA AND/OR REFER-

ENCE DESIGNATIONS FOR THE PAGE.
IF YOU HAVE SELECTED MORE THAN ONE PAGE, YOU EDIT ARTICLE DATA/REF-

ERENCE DATA FOR ALL OF THE SELECTED PAGES IN ONE OPERATION. — SEE 

“Edit reference designations for more than one page” on 
page 412.
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The Page menu and current path numbers

If you name project symbols according to their location on page/current path, you 
may read more about which influence it has on these symbol names, when you 
make changes in the project like the ones mentioned above. Please refer to 
“Naming due to changes in the Page menu” on page 439.

CREATING A NEW PAGE

You can create new pages in the project in two different ways:

• By dragging a page into the project via the Explorer window — see “Drag a 
new page into the project - via the Explorer window” on page 546.

• Via the Page menu — see “Creating a new project page - via the Page menu” 
on page 547.

Drag a new page into the project - via the Explorer window

In order to drag a new page into the project from the Explorer window, this 
requires:

a) A page of the desired type already is created in the Explorer window on the 
SubDrawings tab (see “Sub drawings” on page 289), or

PAGE NUM-

BER

CLICK ON THE PAGE IN THE MENU YOU WISH TO CHANGE PAGE NUMBER FOR, 
CLICK ON PAGE NUMBER, TYPE IN THE NEW PAGE NUMBER, AND CLICK OK. 
THE PAGE NUMBER IS NOW CHANGED.
WHEN YOU HAVE SELECTED MORE THAN ONE PAGE, YOU ARE ASKED TO TYPE 

IN THE NUMBER OF THE FIRST OF THE CHOSEN PAGES. THE SUBSEQUENT 

PAGES ARE INCREMENTED AUTOMATICALLY. IF ANY OF THE SELECTED PAGES 

ARE DIVIDERS, YOU ALSO GET THE OPTION OF CHOOSING RENUMBER DIVID-

ERS. IF YOU SELECT RENUMBER DIVIDERS, THE SELECTED DIVIDER(S) ARE 

ALSO RENUMBERED.
IF YOU RIGHT-CLICK ON A PAGE IN THE PAGE MENU AND CHOOSE PAGE NUM-

BER, YOU CAN ALSO CHANGE THE PAGE NUMBER.
WHEN YOU DOUBLE-CLICK ON A PAGE TAB IN A PROJECT, YOU ARE ALSO 

ALLOWED TO CHANGE THE PAGE NUMBER.

GO TO PAGE TYPE IN A PAGE NUMBER AND PRESS <ENTER>. THIS DISPLAYS THE CHOSEN 

PAGE IN THE PAGE MENU.

PAGE 

SETUP..
WHEN YOU CLICK HERE, YOU ENTER SETTINGS => PAGE SETUP FOR THE 

SELECTED PAGE IN THE PAGE MENU. IN THIS MENU YOU SPECIFY THE PAGE 

TYPE, SIZE, SCALE AND SO ON.

— READ MORE ABOUT THIS IN “Page type” on page 560, “Page setup - 
and transferring this to other pages” on page 558 AND “Page 
setup” on page 903.

PAGE DATA CLICKING HERE BRINGS YOU INTO THE DIALOG BOX SETTINGS => PAGE DATA 
FOR THE SELECTED PAGE IN THE PAGE MENU. HERE YOU CAN ASSIGN A 

TITLE TO THE PAGE, TYPE IN INFORMATION ATTACHED TO THIS SPECIFIC 

PAGE, AND PLACE A DRAWING HEADER ON THE PAGE. YOU CAN ALSO SET UP 

CURRENT PATH NUMBERING / A REFERENCE SYSTEM FOR THE PAGE.

— SEE “Insert drawing headers/formulas” on page 585 AND “Page 
data” on page 900.

CHOOSE FUNCTION/USE
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b) A template page of the desired type has been created (see “Creating Templa-
tes” on page 837).

Dragging a page into the project

To drag an existing template page into the pro-
ject via the SubDrawings tab in the Explorer 
window, do this:

 1) Select the page in the project, that you 
wish to place the new page after in the 
project — e.g. by clicking on a page tab 
at the bottom of the screen.

 2) In the Explorer window, on the Sub-
Drawings tab: Open the folder STAND-
ARD/Template — which contains the 
folders with all program templates — 
and open e.g. the folder Normal, as dis-
played in the figure to the right.

 3) Then click on one of the templates in the 
folder — e.g. PCS-L1-L2-L3-PE-N.STD 
— and drag it over to the project page in 
the drawing area on the screen.

 4) When you release the mouse button, 
the new page is placed after the active 
page in the project.

Correspondingly, you can drag other pages directly into the project from the Sub-
Drawings tab.

Creating a new project page - via the Page menu

When you want to create a new page via 
the Page menu, you first enter the Page 
menu, and click on Add new or Insert 
new — as described in “The Page 
menu” on page 544.

If you are not in the Page menu, you can 
add a new page by going to the last 
page of the project, and press <Page 
Down>.

You then enter the Page function dialog 
box, where you specify what you are 
going to use the page for.
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Selecting a Page function

Choose one of the following options and click OK:

PAGE FUNCTION NORMAL FOR SYMBOLS WITH ARTICLE DATA

WHEN YOU WISH TO INCLUDE ARTICLE DATA FOR THE COMPONENTS/SYM-

BOLS IN FOR INSTANCE PARTS LISTS, IT IS IMPORTANT THAT DIAGRAM 

PAGES HAS THE PAGE FUNCTION NORMAL, BEFORE PLACING SYMBOLS ON 

THE DIAGRAM PAGES.

PAGE 

FUNCTION
DESCRIPTION

NAME IN

PAGE MENU

NORMAL THE PAGE IS USED FOR DIAGRAM- OR MECHANICAL/GROUND 

PLAN DRAWINGS. SYMBOLS/COMPONENTS WITH COMPONENT 

DATA FROM PAGES OF THIS TYPE, CAN BE FILLED INTO FOR 

INSTANCE PARTS LISTS.

DIA (DIA-

GRAMS), OR 

GRP 
(GROUND 

PLANS)

IGNORED THE PAGE WILL BE USED TO ENTER INFORMATION THAT SHALL 

NOT BE INCLUDED IN LISTS. COULD FOR INSTANCE BE MOUNT-

ING INSTRUCTIONS, OR A FRONT PAGE FOR THE PROJECT.

IGN

UNIT DRAW-

ING

THE PAGE IS USED FOR UNIT DRAWINGS, AND CAN FOR 

INSTANCE BE ASSIGNED ARTICLE DATA. YOU WILL BE ASKED 

TO SELECT AN EXISTING UNIT DRAWING (A .STD FILE). — READ 

MORE ABOUT THIS IN “Inserting Unit Drawings” on 
page 625.

UNT

TABLE OF 

CONTENTS

THE PAGE IS USED AS A TABLE OF CONTENTS. ON PAGES OF 

THIS TYPE YOU CAN INSERT DATAFIELDS OF THE TYPE TABLE 

OF CONTENTS. — SEE THE DATAFIELDS IN “Table of Con-
tents datafields” on page 935.

PAGES OF THE TYPE TABLE OF CONTENTS CAN BE PLACED 

FREELY IN THE PROJECT. WHICH PART OF THE PROJECT THIS 

PAGE IS A TABLE OF CONTENTS FOR, IS SPECIFIED IN LISTS => 

LIST SETTINGS. — READ MORE ABOUT THIS IN “List settings 
for Tables of Contents” on page 611.

THE TABLE OF CONTENTS IS UPDATED WHEN YOU CHOOSE 

LISTS => UPDATE TABLE OF CONTENTS.

TOC

PARTS LIST THE PAGE WILL BE USED AS A PARTS LIST PAGE. DATAFIELDS 

RELATED TO PARTS LISTS CAN BE INSERTED. — SEE THE 

DATAFIELDS IN “Parts/components list datafields” on 
page 936.

PAR

COMPO-

NENTS LIST

THE PAGE WILL BE USED AS A COMPONENTS LIST PAGE. DATA-

FIELDS RELATED TO COMPONENTS LISTS CAN BE INSERTED.  

— SEE THE DATAFIELDS IN “Parts/components list data-
fields” on page 936.

COM

TERMINALS 

LIST

THE PAGE WILL BE USED AS A TERMINALS LIST PAGE. DATA-

FIELDS RELATED TO TERMINALS LISTS CAN BE INSERTED.

 — SEE THE DATAFIELDS IN “Terminals list datafields” on 
page 938.

TER

CABLE LIST THE PAGE WILL BE USED AS A CABLES LIST PAGE. DATAFIELDS 

RELATED TO CABLES LISTS CAN BE INSERTED. — SEE THE 

DATAFIELDS IN “Cable list datafields” on page 940.

CAB
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OTHER PAGE FUNCTIONS

Furthermore, there are page functions for graphical terminal plans (TEP), graphical 
cable plans (CAP) and for graphical connection plans (CNP) and symbol docu-
mentation (SYM). Pages of this type are created in the modules for creating graph-
ical lists / symbol documentation.

— Read more about this in the PCSCHEMATIC Tools manual.

You can see the page function of a page when you choose Settings => Page 
setup. — See “Page setup” on page 903.

PLC LIST THE PAGE WILL BE USED AS A PLC LIST PAGE. DATAFIELDS 

RELATED TO PLC LISTS CAN BE INSERTED. — SEE THE DATA-

FIELDS IN “PLC list datafields” on page 942.

PLC

CONNEC-

TIONS LIST

THE PAGE WILL BE USED AS A CONNECTIONS LIST PAGE. 
DATAFIELDS RELATED TO CONNECTIONS LISTS CAN BE 

INSERTED. — SEE THE DATAFIELDS IN “Connections list 
datafields” on page 945.

NET

DIVIDER THE PAGE IS USED TO MARK THE START OF A NEW CHAPTER. 
THE TITLE OF THIS PAGE WILL BE DISPLAYED ON THE RIGHT-
HAND SIDE OF THE SCREEN WHILE WORKING IN THE PROJECT, 
ALONG WITH THE OTHER DIVIDER TABS.
A FOLDER WILL BE DISPLAYED IN FRONT OF THE PAGE TITLE IN 

THE EXPLORER WINDOW.
WHEN YOU INSERT A DIVIDER TAB, YOU ARE ASKED TO TYPE IN 

THE NAME OF THE TAB. HERE YOU CAN CHOOSE TO CLICK ON 

VALUES, WHICH GIVES YOU THE OPTION OF CREATING A LIST 

OF POSSIBLE NAMES FOR DIVIDER TABS. WHEN YOU SUBSE-

QUENTLY NEED TO SPECIFY THE NAME OF A DIVIDER TAB, YOU 

CAN CHOOSE AMONG THESE NAMES FROM A DROP-DOWN LIST.

A FOLDER IS 

DISPLAYED

STANDARD/
PROJECT 

FILE

APPLIED WHEN YOU WANT TO LOAD ANOTHER EXISTING PRO-

JECT INTO THE PROJECT. THIS CAN EITHER BE AN ORDINARY 

PROJECT, OR A SO-CALLED STANDARD PROJECT/STANDARD 

DRAWING. — READ MORE ABOUT THIS IN “Project templa-
tes and Standard projects” on page 563.

IS ALSO USED FOR IMPORT OF DWG AND DXF DRAWINGS — 

SEE “DWG and DXF files” on page 729.

NONE

CHANGE PAGE FUNCTION & TRANSFER PAGE FUNCTION TO OTHER PAGES

TO CHANGE THE PAGE FUNCTION FOR A 

PAGE, CHOOSE SETTINGS => PAGE SETUP 
AND CLICK THE DOWN-ARROW BELOW 

PAGE FUNCTION. A LIST OF POSSIBLE 

PAGE FUNCTIONS IS NOW DISPLAYED. NOW 

CLICK THE DESIRED PAGE FUNCTION.

 IN ORDER TO TRANSFER THE SELECTED 

PAGE FUNCTION TO OTHER PAGES IN THE 

PROJECT, CLICK THE TRANSFER SETTINGS 
BUTTON.

PAGE 

FUNCTION
DESCRIPTION

NAME IN

PAGE MENU
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Selecting a page template

When you have selected a Page function, you enter the dialog box New, from 
which you can choose between the created page templates, that matches the 
Page function, you selected:

Click on the desired template page, and click OK.

If you select the template Blank page, you get an empty project page with the 
selected page type.

— See how to create your own templates in “Creating Templates” on page 837, 
particularly “Creating Page templates — via the Template editor” on page 838.

Click OK in the Page menu

You have now inserted the desired page, and are still in the Page menu.

When you click OK to leave the Page menu, you jump to the inserted project page.

Selecting language on predefined drawing headers

In the predefined drawing headers included in the program, it is possible to choose 
multiple languages. Read more about this in “Drawing headers in multiple langua-
ges” on page 816.

TEMPLATE PAGES FOR LISTS

WHEN YOU HAVE SELECTED A PAGE FUNCTION FOR A LIST, YOU CAN, COR-

RESPONDINGLY, SELECT TO INSERT PAGES CONTAINING LIST DRAWING 

HEADERS.
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COPYING, CUTTING AND PASTING MORE THAN ONE PAGE

To copy/cut and then paste more than one page in the Page menu, do this:

 1) Click on the first page you wish to cut/copy.

 2) Press down <Shift> and click on the last of the pages you wish to cut/copy.

 3) Deselect/select further pages by pressing the <Ctrl> key when clicking on 
the pages.

 4) Click on Cut / Copy.

 5) When cutting: Click OK to cut the pages.

 6) Click where you wish to paste the pages, and click Paste.

 7) Click OK to paste the pages.

 8) In the dialog box Rename symbols: Specify whether/how to rename the 
symbols on the pasted pages — see the options for this in “Intelligent copy-
ing of areas” on page 271.

The copied pages can also be pasted after the last page in the project, if you click 
below the last page in the Page menu and choose Paste.

— See also “Pasting copied pages in other projects” on page 552.

PAGE NAMES WHEN COPYING PAGES IN THE PAGE MENU

WHEN COPYING PAGES IN THE PAGE MENU, THE EXISTING PAGE NUMBERS 

ARE NOT CHANGED. THE COPIED PAGES KEEPS THEIR ORIGINAL PAGE NUM-

BERS, WITH AN ADDITIONAL COPY NUMBER INCLUDED IN BRACKETS. IF FOR 

INSTANCE PAGE 2 IS COPIED, THE COPIED PAGE IS ASSIGNED PAGE NUMBER

2 (1).

1) Click here 2) Press down <Shift>

and click here

(Choosing page I3-4)

Example on choices

in the Page menu:

4) Click on Copy

and paste

the pages

3) Press <Ctrl>

and click here

(Deselect DIV)
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PASTING COPIED PAGES IN OTHER PROJECTS

To cut/copy pages from a project, and then paste these pages in another project, 
do the following:

 1) Copy the pages in the Page menu according to the common Windows 
guidelines, as described in “Copying, Cutting and Pasting more than one 
page” on page 551.

 2) Open the other project.

 3) Paste the pages via the Page menu, or by right-clicking on a project page, 
and then choose Paste.

 4) Click OK to paste the pages:

 5) Specify how to renumber symbols, terminals etc. and click OK — see “Intel-
ligent copying of areas” on page 271:
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 6) The pages are now pasted into the other project, and the symbol names etc. 
have been updated for the pasted pages.

— See “Copying full Projects into other Projects” on page 565, “Drag pages bet-
ween projects” on page 569 and “Copying an area from one project to another” on 
page 570.

COPYING CHAPTERS

YOU CAN ALSO COPY FULL CHAPTERS USING DRAG AND DROP, AS 

DESCRIBED IN “Move, Copy and Delete Pages and Chapters via Page 
tabs” on page 554.
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MOVE, COPY AND DELETE PAGES AND CHAPTERS VIA PAGE TABS

By using the page tabs, you can also move or copy project pages and chapters.

Moving pages by using the Page tabs

To move a single page in the project by using the page tabs, do this:

 1) Select the page you wish to move, so that it becomes the active page in the 
project — e.g. by clicking its page tab at the bottom of the screen.

 2) Click on the page tab, keep the mouse key pressed down, and drag the page 
to the page tab for the page in the project, where you wish to place the 
moved page. Release the mouse button.

 3) Click OK to move the page.

The moved page is placed before the page, whose page tab you clicked on.
The moved page can also be inserted after the last page in the project.

You can also move individual pages by right-clicking on the page tab, then choose 
Cut, and right-click on another page tab and choose Insert. You can also copy a 
single page by clicking on its page tab, and then choose Copy.

Move chapters using the page tabs

To move a chapter in the project using 
the page tabs, you just move the page 
tab for the Divider page, that indicates 
the start of the chapter.

When you answer OK to move the 
Divider page, just select Include pages 
in chapter:

Hereby all pages in the chapter are also 
moved.

Copy pages and chapters using the page tabs

You copy pages and chapters just like described above; the only difference is that 
you press the <Ctrl> key while doing it. When you copy pages/chapters, a small + 
is displayed in the cursor.

When you copy pages, you are asked whether/how to rename the symbols on the 
page — and change reference designations (if any) —, as described in “Intelligent 
copying of areas” on page 271.

Delete pages via the page tabs

You can delete an individual page by right-clicking on the page tab for the page, 
and choose Delete.
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CHAPTERS

In Automation you can divide projects in chapters, which gives a better sur-
vey. When a project is divided in chapters, the divider/chapter tabs are dis-
played on the right-hand side of the screen. When you click on one of these 
divider tabs, the first project page in the chosen chapter is displayed.

For chapters, it is possible to:

 1) Create separate tables of contents for each individual chapter in the 
project — se “List settings for Tables of Contents” on page 611.

 2) To change reference designations on chapter level — see “Editing 
reference designations for chapters” on page 412.

 3) To move/copy all pages in the chapter in a single operation — see 
“Move, Copy and Delete Pages and Chapters via Page tabs” on 
page 554.

Chapter tabs at the bottom of the screen

Chapter tabs are also displayed at the bottom of the work area along with the tabs 
for the other project pages. When you right-click on one of these chapter tabs, you 
get a set of options. You can for instance choose to close all chapters, so that only 
the chapter tabs are displayed, or you can open all chapters, so that the individual 
project pages in the chapters are also displayed.

Creating a new chapter

The only thing you have to do to create a new chapter, is to insert a divider page, 
which indicates the start of a new chapter.

The contents of the chapter is the pages between this divider tab and the next 
divider tab.

To insert a divider tab, do this:

 1) Enter the Page menu, click on the page in the menu where you want the 
chapter to start, and click Insert new.

 2) In the dialog box Page function: Click on Divider and click OK.

 3) In the dialog box New: Click on a page template, and click OK.
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 4) In the dialog box Divider: Type in the name of the divider/chapter:

If you click the Values button in the dialog box above, you can create a list of 
chapter titles that you typically use in projects. — See “Values list for Project 
and Page title” on page 125.

 5) Click OK.

You have now created a new chapter.

Inserting chapter drawing
headers

You can now insert a drawing 
header on the page, as 
described in “Insert drawing 
headers/formulas” on 
page 585.

Here you can either choose to 
use the included chapter 
divider drawing header 
Divider in the folder Misc, or 
you can design your own 
drawing header as described 
in “Creating Drawing Hea-
ders” on page 807.

DRAG IN A CHAPTER DIVIDER PAGE FROM THE EXPLORER WINDOW

YOU CAN ALSO DRAG A CHAPTER DIVIDER PAGE INTO THE PROJECT FROM 

THE EXPLORER WINDOW — AS DESCRIBED IN “Drag a new page into the 
project - via the Explorer window” on page 546.

Select a chapter title by clicking here, if a
Values list as been created for dividers

Click here to see

the first page

in the chapter

Click here to see

the Divider tab
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Datafields on chapter level

For the datafields First used page, Last 
used page and Used pages, you can 
select whether these shall cover the full 
project, or just the chapter pages.

— Read more about inserting datafields 
in “Datafields” on page 116.

— Please also see “Last used page 
active” on page 363.

NAMING PAGE TABS

You are free to name all page tabs in a 
project as you please. However, you are 
not allowed to assign the same name to two different page tabs.

Names on page tabs at the bottom of the sceeen

To edit the name of a page tab at the bottom of the screen, do this:

 1) Double-click on the tab.

 2) You can then edit the name 
of the tab: Type in the new 
name and click OK.

You can also rename one or more 
of the pages by selecting the page/
pages in the Page menu and click on Page number, as described in “The Page 
menu” on page 544.

You can also rename a page by right-clicking on the page tab, and choose Page 
number.

Names on chapter tabs at the right-hand side of the screen

The texts in the divider tabs at the right-hand side of the screen shows the Page 
title for the divider tabs.

To quickly change the text on a divider tab in the right-hand side of the screen, do 
this:

 1) Double-click the tab.

 2) In the dialog box Page data: Type in the new name in the Page title field and 
click OK.

COLORS ON PAGE TABS

To change the color of a page tab at the bottom of the screen, do this:

 1) Right-click on the tab and choose Color

 2) Click on Select
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 3) In the dialog box Color: Select the desired color

To remove the color again simply right-click the tab and choose Color => None.

The selected color is also displayed in the Page menu — see “Options in the Page 
menu” on page 544.

PAGE SETUP - AND TRANSFERRING THIS TO OTHER PAGES

When you select Settings => 
Page setup, you enter the dialog 
box Page setup.

You can also enter this dialog 
box by right-clicking on the active 
project page, and choose Page 
setup.

In the dialog box Page setup 
you can for instance specify the 
page type and the paper size, as 
described in “Page type” on 
page 560 and in “Paper size” on 
page 561. — See more options 
in “Page setup” on page 903.

Transferring the Page setup to other project pages

To transfer a page setup from a project page to other project pages, you can right-
click on some of the settings in the Page setup dialog box — for instance Reading 
direction as illustrated below —, which gives you the option of transferring this set-
ting to other project pages:

Right-click here
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If you choose Select pages to transfer setting to, you enter a special version of 
the Page menu, where you select which pages to transfer the setting to:

Here the green icons indicate which pages the setting can be transferred to. If an 
icon is dimmed, the page already has this setting — or the setting is not possible 
for the page. The settings for the other pages are displayed in the Value column.

Choose the pages to transfer the setting to, and click OK.

Page settings that can be transferred to other pages

It is possible to transfer the following Page settings to other project pages, accord-
ing to the procedure described above:

PAGE SETUP REMARKS

READING DIRECTION SEE THE DESCRIPTION ABOVE.

PAGE FUNCTION PAGES, WHICH ARE NOT OF THE TYPE NORMAL, CAN HERE BE 

ASSIGNED THE TYPE NORMAL. THE FUNCTION IS ONLY AVAILABLE 

VIA THE RIGHT-CLICK MENU, WHEN A PAGE HAVE BEEN CHANGED TO 

THE TYPE NORMAL.

LISTTYPE THIS FUNCTION IS ONLY AVAILABLE VIA A RIGHT-CLICK MENU, WHEN 

A LIST PAGE HAS BEEN CHANGED TO THE TYPE NORMAL.

CONTAINS A LIST THE SETTING, THAT A DIAGRAM PAGE ALSO CONTAINS A LIST, CAN 

ALSO BE TRANSFERRED TO OTHER DIAGRAM PAGES. — SEE “Dia-
gram pages - containing a Parts or Components list” on 
page 828,
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PAGE TYPE

The type of a page is determined in Settings => Page 
setup and in the lower part of the left tool bar.

— See “Direct access to menus and Tabs” on 
page 49.

The Page type can be changed any time.

In the list below you can see what the various page 
types are used for:

PAGE TYPE DESCRIPTION

DIAGRAM THE PAGE IS A STANDARD DIAGRAM FOR DRAWING IN TWO DIMEN-

SIONS. USED FOR ALL TYPES OF LISTS AS WELL.

GROUND PLAN/
MECHANICAL

THE PAGE IS USED FOR GROUND PLAN- AND MECHANICAL DRAW-

INGS, WHERE WORKING IN DIFFERENT ELEVATIONS, AND THEREBY 

WORK IN THREE DIMENSIONS, IS POSSIBLE.

ISOMETRIC THE PAGE CAN BE USED FOR ISOMETRICALLY DRAWINGS, OR DIS-

PLAY IN X, Y OR Z.

SEMI ISOMETRIC THE PAGE IS A KIND OF ISOMETRIC PAGE, WITHOUT PURELY ISO-

METRIC ANGLES.
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PAPER SIZE

Under Settings => Page setup you can also choose the size of the page:

Basically, you can choose between User defined, where you type in the measures 
of the page, and Standard size, where you select a norm, and a paper size in this 
norm.

All pages can be either horizontal or vertical. To get a vertical page, you must 
select Vertical format.

On choosing norms for page formats

As it is, you can choose between the page format norms ANSI (American stand-
ard), ISO and JIS (Japanese standard). However, it is easy to add new page format 
norms to the list. Please contact PCSCHEMATIC A/S, or your local support ser-
vice, for further information.

Standard page sizes for List and Chapter tabs

If you are on a list page, and select Settings => Page setup, and choose Save as 
default, the size of this list page becomes the default page size for list pages.

The same is the case for chapter tabs and diagram pages.

GROUND PLAN DRAWING

— See a practical example on how to create ground plan drawings in the “Creating 
a Ground Plan” on page 521.

Select size

Select norm

Choose between

User defined

and Standard size

Click here for

Vertical format
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ISOMETRIC DRAWING

Beyond drawing on an isometric page, you can also use this page type to see 
whether a ground plan page, where three dimensions are used, seems reasonably 
drawn.

If you have drawn a three dimensional ground plan, and wish to check it isometri-
cally, you choose Settings => Page setup. Here you click on Isometric instead of 
Ground plan, and click OK.

When you choose Isometric you can also specify an ISO angle. 
Click on the up- and down arrows to change the ISO angle.

If you choose Semi isometric you can specify another angle 
accordingly.

Click OK.

Centre drawing

If your drawing hereby disappear completely or is halfway out of sight, you choose 
Functions => Centre drawing and get the isometric drawing placed on the middle 
of the screen. You can now check out whether it looks reasonable or not.

To carry on drawing on your ground plan, you choose Ground plan again in the 
Page settings.

If you are working on a Ground plan page and choose Functions => Generate 
isometry, an isometric drawing will be generated, and added to the end of the pro-
ject.
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PROJECT TEMPLATES AND STANDARD PROJECTS

This chapter shows you how to start a new project using an already created stand-
ard project.

WHAT IS A TEMPLATE PROJECT?

To get started as quickly as possible when you create new projects, you can create 
a so-called template project, which contains all the pages you need every time you 
start up a new project.

This way you can build a library of different project templates, which can be used 
when starting different types of projects, or for instance for projects for different 
customers.

THIS CHAPTER DESCRIBES

— WHAT IS A TEMPLATE PROJECT................................................................ p. 563

— USING TEMPLATE PROJECTS .................................................................... p. 564

— ADDING LISTS TO A PROJECT USING TEMPLATE PROJECTS ........................ p. 564

Table of

Pages for drawings

Partslists
Componentslists

Terminallists
Cableslists

PLClists

Chapter dividers

Front

contents

page

Template project
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USING PROJECT TEMPLATES

To create a new project based on a project template, do this:

 1) Choose File => New or click the New document button.

 2) In the dialog box New: Click on the tab for Projects, click on a project on the 
tab, and click OK.

 3) You can now start working on the new based on the project template.

— See how to create project templates in “Creating Templates” on page 837.

ADDING LISTS TO PROJECTS USING STANDARD PROJECTS

When you know that there are a collection of pages — for instance a set of different 
types of lists — which you need to insert frequently in active projects, you can cre-
ate a project containing these pages.

Such a project is called a standard project in Automation.

This standard project can be copied into the active project from the Page menu, as 
described in “Copying full Projects into other Projects” on page 565.

Click here
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COPYING FULL PROJECTS INTO OTHER PROJECTS

When you are working on a project, you can load another project into this project 
via the Page menu.

You may wish to read:

- “Project templates and Standard projects” on page 563, for information about 
Template projects and Standard projects, which can contain the pages you 
need when you start new projects.

- “Merging projects via Excel” on page 625, to see how to merge Automation 
projects via Microsoft Excel.

- “Drag pages between projects” on page 569, to see how to drag pages from 
one project to another.

HOW TO COPY ONE PROJECT INTO ANOTHER

In Automation you can load any project into an existing project as a Standard/
Project file, and then adapt the loaded project pages according to your needs in 
the active project.

To try how to load a project into another project, just open a project, and enter the 
Page menu.

THIS CHAPTER DESCRIBES

— HOW TO COPY ONE PROJECT INTO ANOTHER.............................................p. 565

— PROJECT DATA WHEN COPYING PROJECTS ................................................p. 567
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Here you click Add new — to add a new project/page in the end of this project — 
and then click on Standard/Project file and click OK.

— Instead of Add new you could also click on for instance page four and then click 
Insert new. The project would then be inserted starting on page four.

You now enter the dialog box Open dialog box, and have to type in which project 
you wish to insert. In this case you could open the folder Project, select plc-
demo.pro, and click OK.

Defining new datafields when inserting projects

If the new project contains datafields, which have not been defined in the active 
project, you are asked whether to define these datafields in the project.

Click Yes to define the datafields in the project file.

Renaming symbol names and Page numbers when inserting projects

You will now be asked whether you wish to rename the copied symbols:

Select Rename symbols, Rename terminals, and select Keep page numbers, if 
you wish to keep the original page numbers from the inserted project. — If neces-
sary see “Intelligent copying of areas” on page 271.
Click OK.

Click here not to change

page numbers in the

inserted project
Automation

age 566



Copying full Projects into other Projects

Auto
The selected project in now inserted into the original project:

You have now loaded an entire project into another project.

If you now wish to rearrange the pages in the project, delete pages and so on, you 
can do this as described in “The Page menu” on page 544.

PROJECT DATA WHEN COPYING PAGES

When you load a new project into the original project, these pages will have exactly 
the same Project data as the original project. This is because the Project data only 
is specified in one place for the entire project.

Read more about Project data in “Project data” on page 897.
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SEVERAL PROJECTS SIMULTANEOUSLY

In Automation you have got the option of working on several projects at the same 
time. In practice you should not meet any limitations on how many projects you can 
open; even if the projects consist of several thousand pages each.

You can also see how to create overview projects, with links to other projects in 
“Overview projects” on page 576.

If you are interested in how to copy an entire project into another, please read 
“Copying full Projects into other Projects” on page 565.

— See “Pasting copied pages in other projects” on page 552 also.

DISPLAYING MORE THAN ONE PROJECT AT A TIME

When you wish to see more than one 

project on the screen, first choose the 
menu item Window.

You can then choose between:

a) Cascade,

b) Tile vertical and

c) Tile horizontal.

When you choose Window => Close All, all projects in the program are closed. If 
you have made changes, which have not been saved, you will get the option of 
saving these.

If you have minimized projects displayed on the screen, and choose Window => 
Arrange Icons, all minimized projects are gathered at the bottom of the screen.

THIS CHAPTER DESCRIBES

— DISPLAYING MORE THAN ONE PROJECT AT A TIME......................................p. 568

— DRAGGING PAGES/CHAPTERS BETWEEN PROJECTS....................................p. 569

— COPYING AN AREA FROM ONE PROJECT TO ANOTHER................................p. 570

— DRAWING HEADERS AND COPYING ............................................................p. 573

— OPENING A NEW PROJECT BY CLICKING ON A SYMBOL................................p. 573

— OPENING A UNIT DRAWING .......................................................................p. 574

— WORKING WITH THE SAME PROJECT IN TWO VERSIONS..............................p. 574

— COPYING TO OTHER PROGRAMS................................................................p. 575
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DRAG PAGES BETWEEN PROJECTS

To drag a page from one project to another, you open both projects and choose 
Window => Tile, which places the projects side by side.

Then click on the page you want to copy, keep the mouse button 
pressed down, and drag the page over to the other project. You 
first release the mouse button when you are pointing on the tab, 
for the page in the project, where you want the copied page to be 
placed. (A small + is displayed in the cursor when you copy 
pages).

Then answer Yes to copy the page, and answer the emerging question whether — 
and how — to rename the symbols copied. The page copied is placed immediately 
before the page you clicked on in the project.

The copied pages can also be inserted after the last page in the project.

If necessary you can then rearrange the order of the pages in the Page menu. — 
See “The Page menu” on page 544.

For information on how to change back and forth between open projects, please 
refer to “Switching between windows” on page 25.

— See also “Pasting copied pages in other projects” on page 552.

COPYING FULL CHAPTERS BETWEEN PROJECTS

YOU CAN ALSO DRAG FULL CHAPTERS FROM ONE PROJECT TO ANOTHER, BY 

DRAGGING THE PAGE TAB FOR THE CHAPTER DIVIDER PAGE TO ANOTHER 

PROJECT — OR BY USING THE SAME PROCEDURE AS DESCRIBED ABOVE.

— SEE ALSO “Move, Copy and Delete Pages and Chapters via Page 
tabs” on page 554.
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COPYING AN AREA FROM ONE PROJECT TO ANOTHER

This chapter describes how to copy a drawing — or parts of a drawing — from one 
project to another. In this example, you copy from the project Pcsmotordemo2 to a 
new project. If you will rather use your own projects, please do so.

If you want to follow the example, it is a good idea to close the project you are 
working on for the moment, choosing File => Close.

Then do the following:

 1) Choose File => New or click the New document button, click on the project 
template PCSstart, and click OK.

 2) In the dialog box Settings: Click OK.

 3) Choose File => Open, open the project Pcsmotordemo2.pro in the Project 
folder, and click OK. You now have two projects open.

 4) Select Window => Tile horizontal to see the projects side by side.

 5) Now first click on one of the windows, and click on the page tab for the page 
you wish to copy from — in this case page 5 in the project Pcsmotordemo2.

 6) Then click on the other window, and click on the page tab for the page you 
wish to copy to — here page 5 in the new project. (When there is no page to 
copy to in your project, you can insert a new page as described in “Pages 
and Chapters” on page 542).

CHANGING FROM PROJECT TO PROJECT

TO CHANGE BACK AND FORTH BETWEEN THE PROJECTS, JUST CLICK SOME-

WHERE WITHIN THE WINDOW YOU WANT TO WORK ON. THE BAR AT THE TOP 

OF THE ACTIVE WINDOW WILL THEN BECOME HIGHLIGHTED. YOU CAN ALSO 

CHANGE BACK AND FORTH BETWEEN THE WINDOWS BY PRESSING DOWN 

<CTRL> WHILE PRESSING <TAB>.
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 7) Before copying the diagram in the Pcsmotordemo2 project, you can, if you 
wish to, Zoom in on the area you wish to copy — see “Zoom” on page 42 if 
necessary.

 8) Click on the Area button, and use the mouse pointer to select up the area 
you wish to copy — see “Selecting objects” on page 55 if necessary.
— If you zoom in on the area you wish to copy, this will not effect the size of 
the area you insert in the other project. This is because zoom only has to do 
with what is displayed on the screen in the actual project, and does not 
change the measures/scaling of the objects.

 9) Click the Copy button.

 10) Now click inside the other window, click the Area button if not activated, and 
click the Paste button (short-cut key <Ctrl+v>). You now have the selected 
area in the cross hairs in the project you wish to copy to. Click where you 
wish to insert the area on the page.

 11) You are now asked whether you want to rename the copied symbols. Spec-
ify how you wish to rename the symbols — see “Intelligent copying of areas” 
on page 271 — and click OK.
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 12) The selected area is now copied from the one project into the other.

 13) Press <Esc> not to place the drawing once again.

 14) When you return to the project you copied from, you will have the selected 
area in the cross hairs once again. Therefore, not to place the selected area 
in this project, it is a good idea to change windows by clicking on the title bar 
of the window, and then press <Esc>.

SETTINGS ARE MEMORIZED FOR THE DIFFERENT PROJECTS

PLEASE NOTE THAT THE PROGRAM REMEMBERS ALL SETTINGS CONCERN-

ING THE INDIVIDUAL PROJECTS AS YOU CHANGE BACK AND FORTH BETWEEN 

THE VARIOUS PROJECTS. WHEN FOR INSTANCE YOU ARE WORKING WITH 

SYMBOLS IN ONE WINDOW, AND TEXTS IN ANOTHER, THE PROGRAM WILL 

REMEMBER THIS. THUS WHEN YOU CLICK ON THE FIRST WINDOW YOU WILL 

SEE THE SYMBOLS BUTTON ACTIVE, AND WHEN YOU CLICK ON THE OTHER 

YOU WILL SEE THE TEXTS BUTTON ACTIVE.
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DRAWING HEADERS AND COPYING AREAS

When you copy areas, you cannot copy the drawing headers on the page you copy 
from. But you can choose Settings => Page data any time, and determine which 
drawing header you want to insert on the page you copy to.

Read more about how to insert drawing headers in “Insert drawing headers/formu-
las” on page 585.

If you copy/insert an entire project into another, drawing headers will also be 
inserted/copied. Read more about this in “Copying full Projects into other Projects” 
on page 565.

OPENING NEW PROJECTS BY CLICKING ON SYMBOLS

If for instance you use a distribution panel, and already have an existing project 
where the distribution panel is documented, it is possible to open this project by 
clicking on the symbol.

To achieve this, you do the following:

Place a symbol for the distribution panel on the drawing. — If you do not have a 
suitable symbol, you can see how to create one in “Creating Symbols” on 
page 761.

Right-click on the symbol, and choose Component data.
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In the Article no field you type in the full path to the project in which the switch-
board is documented. If the project is documented in the folder specified for pro-
jects in Settings => Directories, you only have to type in the name of the project 
file itself. Therefore it only says distpan.pro in the dialog box above. Read more 
about this in “Directories” on page 911.

Click OK.

You have now established a connection between the symbol for the distribution 
panel, and the project in which it is documented.

If you then wish to open the project, in which the distribution panel is documented, 
you just have to right-click on the symbol, and then choose Open.

Survey of your projects

You can also use this function to create a project, which you only use to get a sur-
vey of your projects. Each symbol you place in this survey, then represents an indi-
vidual project.

If you attach a project to each symbol — as described above — you can then start 
the projects directly from this survey.

OPENING UNIT DRAWINGS

If you wish to open one of the unit drawings in your projects when you choose 
Open, then click on Detail in the dialog box Component data, and select the rele-
vant drawing.

Read more about this in “Attach a symbol on a diagram to the unit drawing” on 
page 625.

WORKING WITH THE SAME PROJECT IN TWO VERSIONS

It is possible to have a project file open in several versions at the same time. If the 
project for instance is called demo.pro, the first version of the project will be 
named demo.pro:1, the second will be named demo.pro:2 and so on.

The program will give you a warning if you open the same project twice.

KEEP TRACK OF WHICH IS THE ORIGINAL PROJECT

PLEASE NOTE, THAT IT IS VERY IMPORTANT TO KEEP TRACK OF WHICH PRO-

JECT IS THE ORIGINAL, IN ORDER NOT TO SAVE THE WRONG PROJECT IN 

STEAD OF THE ORIGINAL.

IF YOU CLICK ON SAVE FOR VERSION :2 (OR LATER) OF A PROJECT, YOU 

ENTER THE DIALOG BOX SAVE AS.
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COPYING TO OTHER PROGRAMS

If you want to copy an area of the active project into another program, then click on 
the Area button, drag a window around the area, and choose Edit => Copy to 
Clipboard.

If you want to use the area you copied in for instance Word, you just click on the 
Paste button in Word, and the copied area will be inserted as an image.

By clicking on for instance the Symbols button, you only copy the symbols in the 
area you mark up.

If you want to copy areas — or files — from other computer programs to 
Automation, please refer to “Inserting files from other programs / OLE” on 
page 736.

ELECTRICAL INFORMATION IS NOT TRANSFERRED

PLEASE NOTE, THAT ELECTRICAL INFORMATION AND ARTICLE DATA IS NOT 
TRANSFERRED THIS WAY. YOU ONLY TRANSFER THE DRAWING ITSELF.
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OVERVIEW PROJECTS

In Automation you can attach projects to the symbols in the diagram pages. You 
can use this option for creating overview projects containing links to all of the pro-
jects that are included in a specific assignment. At www.pcschematic.com/videos 
you can watch the video "Large projects", where these options are shown.

OPENING NEW PROJECTS BY CLICKING SYMBOLS

If for instance you use an electrical panel in an electrical installation drawing, and 
you already have created a project for the panel, it is possible to open the panel 
project by clicking the panel symbol.

To make this possible, all you have to do is this:

 1) Place a symbol for the electrical panel in the drawing. — In case you do not 
have an appropriate symbol, see how to create one in “Creating Symbols” on 
page 761.

 2) Double-click on the symbol — or right-click and choose Component data.

 3) In the dialog box Component data: Type in the full path to the project in the 
Article no field. However, if the project is placed in the same folder as the 
active project, you only need to type in the file name.

 4) Click OK.

You have now established a connection between the symbol for the electrical panel 
and the project that it is documented in.

To open the project that the panel is documented in, all you have to do, is to right-
click the panel symbol and choose Open.

OVERVIEW OF YOUR PROJECTS

You can also use this function for creating a project which you use exclusively for 
creating an overview of your projects. Each symbol that you place in this project, 
represents an individual project. If you then attach a project to each symbol — as 
described above — you can then start any of your projects directly from this over-
view project.

THIS CHAPTER DESCRIBES

OPENING NEW PROJECTS BY CLICKING SYMBOLS............................................p. 576

OVERVIEW OF YOUR PROJECTS .....................................................................p. 576

OPENING PROJECTS/PAGES FROM REFERENCE FRAMES .................................p. 577
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OPENING PROJECTS/PAGES FROM REFERENCE FRAMES

It is also possible to open projects from reference frames.

When you right-click on the text in a reference frame and choose Open, this hap-
pens:

a) If the project contains 
pages with the reference 
designation: The first 
page in the project with 
this reference designa-
tion is opened.

b) If the project does not 
contain pages with the 
selected reference desig-
nation: Automation looks for a project with the name of the reference desig-
nation, and opens the project if it exists in the same folder as the active 
project. In the figure above, the project should therefore carry the name 
=W1+A2.pro in order to be found and opened.
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PROJECTS WITH SELECTABLE OPTIONS

If for instance you produce a product where you can select/deselect various 
options, it is not necessary to create individual documentation projects for each 
combination of options for the product.

In stead you can create a single (master) project where all of the options are docu-
mented. Based on this project you can then automatically generate documentation 
projects, where you specify exactly which options to include in the individual pro-
jects.

This chapter describes how to automatically generate projects with the selected 
options, based on an already created master project.

INSTALL THE MODULE

To generate projects with selected options, you must first install the module Gener-
ate project from selected options:

 1) Choose File => Modules.

 2) In the dialog box Modules: Click Generate project from selected options 
in the list, and click Install.

 3) Click Close.

The module is now ready for use.

START GENERATE PROJECT WITH SELECTED OPTIONS

Before activating the module you need to create a "master" project, where you 
apply reference designations to specify the options in the project. This project can 
then be used to generate other projects from.

When you generate a new project from the "master" project, you apply the refer-
ence designations to specify which options — or parts of the "master" project — to 
include in the generated project.

Please note that this "master" project is just an ordinary project, which is created 
and saved just like any other project.

— Read more about reference designations in “On reference designations” on 
page 373.

THIS CHAPTER DESCRIBES

— INSTALL THE MODULE ...............................................................................p. 578

— START GENERATE PROJECT BASED ON SELECTED OPTIONS .......................p. 578

— THE REFERENCE DESIGNATIONS TAB ........................................................p. 579

— THE OVERVIEW SYMBOL TAB ....................................................................p. 580
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Generating a project from the master project

To generate a new project based on the "master" project, start by opening the 
"master" project. Then start the module by choosing Tools => Generate project 
with selected options.

You then enter the dialog box Generate project with selected options, where you 
generate a new project from the "master" project.

In the dialog box you specify the desired settings on the tabs Reference designa-
tions and Overview symbol. Then click Generate, and the new project is gener-
ated. Please note that the "master" project is closed when the new project is 
generated.

THE REFERENCE DESIGNATIONS TAB

On the tab Reference designations you choose which of the created function 
and/or location aspects, that is to be included in the new project.

If you want to update the lists in the generated project, so that they match the con-
tents on the project pages, please remember to select Update lists at the bottom 
of the dialog box.

Updating the generated project

If you are not satisfied with the generated project, just choose Tools => Generate 
project with selected options again, select/deselect options, and click the 
Update button to update the project according to the changes. (The Update button 
is located where the Generate button was originally placed).

Select which aspects to include in the generated project

Import/export settings
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THE SURVEY SYMBOL TAB

On the Survey symbol tab you specify whether to include an overview symbol in 
the generated project, which gives an overview over the selected options.

When you have selected Insert overview symbol at the top of the dialog box, you 
get the option of specifying:

• Which drawing header to insert on the page containing the overview symbol

• The text properties for the texts in the overview symbol

• The heading texts for the columns in the overview symbol

Click here to insert an overview symbol
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INSERTING LOGOS IN PROJECTS

ON PLACING LOGOS IN PROJECTS

When you wish to apply a logo in a Automation project, you specify which logo 
you wish to apply for all of the project. This way the logo only takes up file space 
once in the project file. The logo will be saved together with the project file.

The logo must be a *.bmp file, a *.jpg file, an *.emf file or a *.wmf file.

INSERTING A LOGO IN A PROJECT

To insert logos in projects in Automation do this:

Specifying the logo file

 1) Place the logo in an appropriate folder using the Windows Explorer.

 2) Click the Project data button.

 3) In the dialog box Project data: Click on the tab 
for Logo1 or Logo2 in the right-hand side of 
the dialog box.

 4) Click on the Select logo button under Logo in 
the right-hand side of the dialog box.

 5) In the dialog box Open: Find the logo, specify 
whether to insert it directly in the project 
(Insert) or whether to create a link to the logo 
(Link to file), and click OK.

Place the logo using a Datafield on a project page

 6) Choose Insert => Insert Datafield.

 7) In the dialog box Datafield: Click on Project Data, choose the datafield 
Logo, and click OK.

 8) You get the logo in the cross hairs: Click where you wish to place the logo. 
Press <Esc> to remove the logo from the cross hairs.

Adapting the size of the logo

 9) The logo can be very small, and its size must now be adapted: Select the 
logo datafield, and click on the Text properties button.

THIS CHAPTER DESCRIBES

— ON PLACING LOGOS IN PROJECTS .............................................................p. 581

— INSERTING A LOGO IN A PROJECT..............................................................p. 581

Select logo Delete logo

Save logo
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 10) In the dialog box Text properties: Type in the 
size of the logo in the field Height — the width is 
set automatically — and click OK.

 11) Press <Esc> — to deselect the logo.
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In this section you can see how to use lists.

You can read about:

- Inserting drawing headers/formulas.................p. 585

- Specifying list settings .........................................p. 596

- Component Grouping.........................................p. 613

- Inserting unit drawings ........................................p. 625

See also “Exporting list files” on page 717.

READ THE SURVEY ARTICLE

READ THE SURVEY ARTICLE ON WORKING WITH DATA-

BASES AND LISTS AT www.pcschematic.com/articles.

Lists

http://www.pcschematic.com/articles
http://www.pcschematic.com/articles
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INSERT DRAWING HEADERS/FORMULAS

Drawing headers are a kind of formulas consisting of text and graphics, which you 
can insert on the pages in your projects.

In the chapter “Creating Drawing Headers” on page 807 you can see how to create 
your own drawing headers.

This chapter describes how to place a drawing header on a project page.

THIS CHAPTER DESCRIBES

— WHAT A DRAWING HEADER CAN CONSIST OF.............................................p. 586

— PLACING A DRAWING HEADER ON A PAGE..................................................p. 586

— ADDING A NEW PAGE CONTAINING A DRAWING HEADER..............................p. 589

— REPLACING DRAWING HEADERS................................................................p. 590

— INSERTING LISTS......................................................................................p. 593

— UPDATING LISTS.......................................................................................p. 595

— CONTENTS OF LISTS WHEN NO DATABASE IS ATTACHED.............................p. 595

TEMPLATE CONTAINING ALREADY INSERTED DRAWING HEADERS

AS AN ALTERNATIVE TO MANUALLY INSERTING A DRAWING HEADER, YOU 

CAN ALSO OPEN A TEMPLATE PAGE, ON WHICH THERE IS ALREADY PLACED A 

DRAWING HEADER.

— READ MORE ABOUT THIS IN “Pages and Chapters” on page 542 AND 

“Creating a new page” on page 546.
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THE CONTENTS OF A DRAWING HEADER

A drawing header is a kind of formula containing 
text and graphics, which you can choose to insert 
on project pages.

A drawing header can for instance consist of a 
frame drawn around the entire page, with your 
company name and logo in the lower-left corner of 
the frame. Apart from this, the name and number 
of the individual pages, which customer the pro-
ject is carried out for — and much more — can be 
stated in the drawing header.

When you have placed the drawing header on a 
page in the project, you can make the program fill 
in this information for you automatically.

You will typically apply different drawing headers 
on the pages in the project — depending on the 
use of the pages. — You can read more about 
what a drawing header is in “Dictionary” on page 967.

Please note, that you can place two drawing headers on the same page — see 
“Two drawing headers on the same page” on page 591.

INSERTING A DRAWING HEADER ON A PAGE IN A PROJECT

To insert a drawing header on the page you are located on in the project, you first 
click on the Page data button on the program tool bar on the top of the screen. 
This makes you enter the dialog box Page data. You can also enter this dialog box 
by choosing Settings => Page data.

Click here to select

drawing header

The title of the

drawing header

is displayed here

Click to select a dra-

wing header from

the Symbol menu
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Selecting a drawing header

To specify which drawing header is to be placed on the page, click on the down-
arrow in the field below the With drawing header check box.

In the list that appears, you click on the name of the desired drawing header. As 
you scroll down the list of drawing headers, the titles of the drawing headers are 
displayed.

When you choose a drawing header the list disappears, and the name of the draw-
ing header is placed in the field.

At the same time With drawing header is automatically selected.

You have now chosen a drawing header for the current project page.

Adding a drawing header to the list of drawing headers

If you want to add a drawing header to the list of drawing headers, please refer to 
“Adding drawing headers to the List Of Drawing Headers” on page 815.

Choosing a drawing header not on the list

If you want to use a drawing header that is not in the list of drawing headers in 
Automation, click on the Browse button next to the drawing header field. You then 
enter the Symbol menu, where you select the desired drawing header, and click 
OK.

Page title

If you at the same time want to assign a title to the page, you click inside the field 
Page title. Here you for instance type in the text Drawing. You can also fill out the 
other fields with information about this particular page in the project.

NOT ADDED TO THE LIST OF DRAWING HEADERS

THE CHOSEN DRAWING HEADER IS NOT ADDED TO THE LIST OF STANDARD 

DRAWING HEADERS IN Automation.

HOWEVER, WHEN YOU HAVE USED A DRAWING HEADER IN A PAGE IN A PRO-

JECT THIS WAY, YOU WILL SEE THE DRAWING HEADER ON THE LIST OF 

DRAWING HEADERS.

THIS IS BECAUSE THE LIST ALWAYS DISPLAYS THE LIST OF STANDARD 

DRAWING HEADERS IN Automation AND THE USED DRAWING HEADERS IN 

THE ACTIVE PROJECT. WHEN YOU START WORKING IN ANOTHER PROJECT, 
YOU WILL THEREFORE NO LONGER SEE THE DRAWING HEADER IN THE LIST.
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Missing datafields

When you have chosen a 
drawing header, click OK on 
the tab Page data.

If a drawing header contains 
some datafields, which have 
not been created in the cur-
rent project, you will get a 
message about this, as you 
can see in the figure to the 
right.

Click Yes to create them in 
your project. As you will see, 
the drawing header has now been placed on the page.

Active links from Datafields in Drawing headers to the Settings dialog box

When you double-click on a datafield, which comes from the dialog box Settings, 
the dialog box Settings is opened on the tab, from which the datafield collects its 
value. — For instance Customer or Project title in Project data:
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Drawing headers with States

When a drawing header contains different states, you can choose the drawing 
header state in the lower-right corner of the dialog box Page data:

If you wish to transfer the selected state to the other pages in the project, click the 
Transfer setting button on the right-hand side of the State field. You then get the 
following options:

• Select pages to transfer setting to: You now enter the Page menu, where you 
select the pages and click OK.

• Transfer setting to all pages with same drawing header: The setting is trans-
ferred to all project pages using the selected drawing header.

• Transfer setting to all pages: The state is transferred to all project pages of 
the same page type.

ADD NEW PROJECT PAGE, AND ASSIGN A DRAWING HEADER TO IT

If you have not created the page you want to place the drawing header on, you do 
this by entering the Page menu:

 1) In the Page menu: Click on Add.

 2) In the dialog box Page function: Click on Normal and click OK.

 3) In the dialog box New: Click on the template Blank page and click OK.

If you want to know more about the Page menu and the various types of pages 
you can apply, you may read “Pages and Chapters” on page 542.

If you want to place a drawing header on the page you have selected in the Page 
menu, click on Page data, and then continue as described in “Inserting a drawing 
header on a page in a project” on page 586.

When you have inserted the drawing header, you return to the Page menu, and 
here you click OK.

USING STATES IN DRAWING HEADERS TO CHANGE LANGUAGE

YOU CAN USE STATES IN DRAWING HEADERS TO CHANGE LANGUAGE FOR 

THE TEXTS IN THE DRAWING HEADER.

— READ MORE ABOUT THIS IN “Drawing headers in multiple languages” 
on page 816.

Choose state Transfer the state
to other pages
mation

Page 589



P

Insert drawing headers/formulas
REPLACING DRAWING HEADERS

If your company for instance has changed its phone number, you can enter Design 
symbol, correct the phone number in the drawing header, and save the new draw-
ing header under the same name. — See how to change drawing headers in “Pla-
cing a Company Logo on a drawing header” on page 817.

Replacing a drawing header

When you have edited a drawing header, and wish to use the new version in your 
project, do this:

 1) Click on a project page using the drawing header.

 2) Click the Page data button.

 3) At the bottom of the dialog box Page data: Click the Update button.

 4) Specify whether to replace the drawing header On all pages or On this 
page:

If you select On this page: The new version of the drawing header will be 
inserted on this page only.
If you select On all pages: All pages in the project using the old version of 
the drawing header, will have their drawing headers replaced by the new ver-
sion.

EDITED DRAWING HEADERS ARE NOT REPLACED AUTOMATICALLY

WHEN YOU CHANGE THE DEFINITION OF A DRAWING HEADER, WHICH IS 

USED IN A PROJECT, THE DRAWING HEADER IN THE PROJECT WILL NOT BE 

REPLACED BY THE NEW VERSION OF THE DRAWING HEADER, UNTIL YOU 
SPECIFY THAT IT SHALL BE REPLACED.
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Of course you can also choose to replace a drawing header with any other drawing 
header from the list of drawing headers.

TWO DRAWING HEADERS ON THE SAME PAGE

You can place two drawing headers on the same page in the project. This can for 
instance be used for lists. Here you need to create:

- A drawing header containing the title block surrounding each of the list pages

- A series of "contents" drawing headers for parts lists, components lists etc.

If you, at a later stage, need to change the information in the title block, you will 
then only need to change one single drawing header. — And not all of the various 
"contents" list drawing headers.

DRAWING HEADERS AND PAGE FORMATS

DRAWING HEADERS CAN ALWAYS BE REPLACED — ALSO WHEN THEY ARE 

ORIGINALLY INSERTED VIA A TEMPLATE PAGE.

WHEN A DRAWING HEADER WITH A NEW PAGE FORMAT IS SELECTED, THE 

PAGE FORMAT IS CHANGED AUTOMATICALLY.

"Title block" drawing header "Contents" drawing header

(drawing header 1) (drawing header 2)
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Inserting two drawing headers on the same page

In the dialog box Settings => Page data: Click on Primary header, and select a 
drawing header (the title block), as described in “Selecting a drawing header” on 
page 587:

Then click on Secondary header, and select the drawing header containing the 
"contents" for e.g. a parts list:

Both drawing headers are now inserted on the page, and appears just like any 
other drawing header:

Click here Select a drawing header ("the frame")

Click here Select a drawing header ("the contents")
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INSERTING A LIST

Lists are a special type of drawing headers, 
which you can place in your projects.

There are several types of lists in Automation. 
These are for instance parts lists, components 
lists, terminals lists, cables lists, PLC lists and 
tables of contents.

The parts lists collect information from the 
symbols/components which have been placed 
on the project drawings, while the table of con-
tents pages collect information about the vari-
ous project pages.

Because lists are a special kind of drawing 
headers, they have to be updated to have all 
information filled out correctly.

To tell the program which type of information 
have to be filled into a list, you have to make 
sure that the page, on which the list is placed, is set to the right page function.

If you want to insert a parts list, the page function has to be Parts list, and if you 
want to insert a table of contents, the page function must be Table of Contents — 
as opposed to above, where the page function was set to Normal.

Apart form the page function, lists are placed as described above. — Read more 
about page function in “Creating a new page” on page 546.

Diagram pages can also contain lists

Diagram pages can also contain parts or components lists. Read more about this 
in “Diagram pages - containing a Parts or Components list” on page 828.

You can also place a list as a symbol on a diagram page, without letting the list 
become part of the drawing header — see “Creating a List symbol” on page 829.

THE CORRECT PAGE FUNCTION MUST BE SELECTED FOR LISTS

IF YOU DO NOT CHOOSE THE CORRECT PAGE FUNCTION FOR A LIST, THE 

LIST WILL NOT BE FILLED OUT WHEN UPDATED.
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Active links in lists and in tables of contents

When you double-click on 
datafields in lists and in 
tables of contents, you jump 
to the place in the project, 
from where the datafield 
fetched its contents — e.g. a 
page, a symbol or a connec-
tion point. This is the case for 
quite a few datafields, but not 
for all types.

When the cursor is above a 
datafield containing an active link, the datafield is underlined, and the appearence 
of the cursor changes to a pointing hand. However, this is only the case if View => 
Show object below cursor is selected.

When you double-click on e.g. an article number, you jump to the first symbol for 
the component in the project.

Please note that this makes it possible to use the tables of contents in the project 
as a kind of page menus.

Jumping back to the list / table of contents

When for instance you have jumped from an article number in a list to a symbol on 
a project page, you can return to the list by clicking the Page history back button 
to return to the list. The button is placed to the left of the page tabs at the bottom of 
the screen. — See “Choosing pages outside the Page menu” on page 542.

UPDATE ALL LISTS

IN PROJECTS ORIGINALLY CREATED IN Automation VERSION 8.0 OR PREVI-

OUS, YOU MUST FIRST CHOOSE LISTS => UPDATE ALL LISTS TO ACTIVATE 

ALL LINKS IN LISTS AND IN TABLES OF CONTENTS IN THE PROJECT.
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UPDATING LISTS

When for instance you have inserted a parts list on a project page, it will not be 
filled out with information from the project drawings right away.

Choose Lists => Update Parts Lists to update the parts lists in the project.

The list is now updated with information from the present project.

Updating all lists

If you want to update all the lists in the project, choose Lists => Update All Lists.

Updating lists by right-clicking

When the active project page contains a list or a table of contents, you can also 
right-click and choose Update the List.

If a diagram page contains a components or parts list, this list can also be updated 
with this function.

CONTENTS OF LISTS WHEN NO DATABASE IS ATTACHED

Parts and Components lists pages memorize all data, which were originally 
fetched from the database. Therefore these data are not lost when the list pages 
are updated, and the applied article numbers can not be found in the database.

A list will therefore not become empty when updating lists without having a data-
base attached, or with another database attached.

If you send a project to a customer, who does not have the database attached, the 
lists will still be complete, if the customer chooses Lists => Update all lists.
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LIST SETTINGS

In Automation you can specify which types of information you want to include on 
project lists.

By adjusting the settings for a list, you can for instance make separate parts lists 
for the various component vendors, or choose to include articles from the unit 
drawings in your component list.

In order to specify list settings, you first have to have a list in the project. Read 
“Insert drawing headers/formulas” on page 585 if you need to know more about 
how to insert lists in a project.

If you, on the other hand, want to create list files, you can read more about this in 
“Exporting list files” on page 717.

THIS CHAPTER DESCRIBES

— CHOOSING THE LIST IN THE PROJECT ....................................................... p. 597

— UPDATING LISTS ...................................................................................... p. 597

— WHICH PART OF THE PROJECT TO COLLECT DATA FROM ........................... p. 598

— SORTING IN PARTS AND COMPONENTS LISTS............................................ p. 601

— SPECIFY CRITERIA FOR WHICH DATA TO INCLUDE...................................... p. 604

— HOW TO HANDLE REPETITIONS IN THE LIST .............................................. p. 607

— HOW TO REPLACE MISSING INFORMATION................................................. p. 608

— SPECIAL SETTINGS FOR CABLES, TERMINALS AND PLC LISTS.................... p. 609

— LIST SETTINGS FOR CONNECTIONS LISTS.................................................. p. 611

— LIST SETTINGS FOR TABLES OF CONTENTS............................................... p. 611

LIST SETTINGS FOR TEMPLATES

LIST SETTINGS CAN ALSO BE SPECIFIED ON PAGE TEMPLATES, SO THAT YOU 

CAN CREATE LIST TEMPLATES CONTAINING DIFFERENT LIST SETTINGS, FOR 

DIFFERENT PURPOSES.

— READ MORE ABOUT THIS IN “Creating Templates” on page 837, PAR-

TICULARLY “Creating Page templates — via the Template editor” on 
page 838.
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CHOOSING THE LIST IN THE PROJECT

Enter the page you want to change the settings for, and choose Lists => List set-
tings. Here you specify how you want to fill out the list you are presently working 
on.

Depending on which type of list you are working on, you will have different options 
at hand to specify the list setup.

If the components in for instance a parts list requires more than one page, the pro-
gram will notify you about this, and — if you answer Yes — add one or more addi-
tional parts list pages immediately following the first page in the parts list.

If a list results in less pages following an update, you will also be informed about 
this.

UPDATING LISTS

When you are in the dialog box List setup, and you want to update a list, click on 
Update in the right-hand side of the dialog box. This update only applies for the list 
you are working on for the moment.

If you are contempt with the settings, but would like to wait until later before you 
update the list, you click OK. The update will be carried out next time you choose 
Lists => Update lists.

If you are not pleased with the new settings, you click on Cancel.

Please note, that information about list settings are saved in the project file itself.

Errors displayed in result window during list update

If an error occurs during a List update or during List to file operations, these errors 
will be displayed in a result window. These errors could for instance be unknown 
from/to specification in the list settings.

The window functions as for the Design check function — see “Design Check” on 
page 355.
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SPECIFYING FROM WHERE TO COLLECT COMPONENTS

If you have not already done this, then select the relevant list page in the project 
and choose Lists => List settings.

Working with lists you have the option of specifying precisely which components 
you want to include in the lists, and according to which of their symbol texts you 
want the lists to be sorted.

Which data to include in the list

If you select Articles from Unit Lists and Drawings, articles from unit drawings 
are included. The component name from the unit drawing is hereby specified as a 
sub name for the component in the list.

DIFFERENT TABS FOR CABLES, TERMINALS AND PLC LISTS

PLEASE NOTE THAT CONTENTS OF THE GENERAL TAB IS DIFFERENT FOR 

CABLES, TERMINALS AND PLC LISTS — AS DESCRIBED IN “List setup for 
terminals- cables- and PLC lists” on page 609.

Only possible for

components lists

The component S2 in the unit drawing and in the list
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If you select Include fixed accessories from Database, the program will examine 
each component, and see whether they need any accessories, which must be 
included in the list. — Please note that "Optional electrical accessories" and 
"Optional mechanical accessories" are always included in lists. See “Accessories 
in the database” on page 664, in particular “Accessory types” on page 664.

When you select Include Lines with article data, article data from lines will be 
included as well, and the lengths of the lines will be calculated. If you only wish to 

include line data from jumper links, select Only jumper links.

Simple parts- and components lists

If you select Each Symbol is a Component, each symbol will be understood as 
an individual component — even though other symbols with the same name exists.

Therefore, if three symbols with the name -X1 exists, these symbols will be under-
stood as three individual components on both parts- and components lists.

This is also the case when documenting electrical house installations, where 
names are not necessarily assigned to the symbols.

Choose Pages and Layers

In Pages and layers you specify from which project pages the parts list receive 
information, and from which layers information will be collected on these pages. If it 
says 0 in the fields, this signifies that all layers/pages are included in the parts list.

When you click the Browse button next to From page or To page, you enter the 
Page menu, where you select the desired page(s), and click OK.

Pages with reference designations

When you need to discern between two pages having the same page numbers, but 
different reference designations, you do this by placing the character "/" between 
the page name and the reference designation for the page.

If page 17 has the reference designation =G1+A1, you therefore write 17/=G1+A1.

When the page number is selected using the Browse button, the reference desig-
nation is inserted automatically.

Layers

When you click the Browse button next to the Layer field, you enter the Layer 
menu, where you select the desired layer or layer group, and click OK.

FOR PARTS AND COMPONENTS LISTS ONLY

WHEN YOU SELECT INCLUDE LINES WITH ARTICLE DATA, YOU ALSO GET THE 

OPTION OF SPECIFYING AN ADD ON FOR LINES WITH ARTICLE DATA.

THIS OPTION IS MOSTLY USED FOR LINES CARRYING CABLE DATA ON 

GROUNDPLAN PAGES. PLEASE REMEMBER TO SPECIFY A UNIT OF MEAS-

UREMENT FOR THE ADD ON — SUCH AS 100CM.

THE SPECIFIED ADD ON IS INCLUDED IN THE DATAFIELDS TOTAL QUANTITY, 
QUANTITY AND LENGTH FOR LINES.
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Sorting the list

Using the fields Primary and Secondary on the tab General, you determine which 
symbol texts the list is to be sorted according to.

For Components lists only: Labels for component marking

When you under Lists => List settings for a Components list on the General tab 
choose List only one of each name, each name is only included once. Hereby 
you can for instance create labels for component marking.

Include all pages in Table of Contents

If you select Include all pages in Table of Contents, each page in the list is 
included in the Table of Contents. If not, only the first page is mentioned.

Display first and last object in the Page title for lists

When you choose Insert name in page title, the name of the first and the last 
object on the list page is displayed after the page title in each list page. If you also 
select Name only, only the name of the datafield is displayed. If it is not selected, 
the datafield also displays the connection name (or cable wire).

The page title is also displayed in the Page menu, in tables of contents and in 
drawing headers, where the page title is placed as a datafield.

Lists in Columns

In Automation you can create lists in columns. This setting is specified on the tab 
General in the dialog box List settings.

Updated from external list file

If you select Updated from external list file, the list will be updated / filled out via 
data from an external Excel or .csv file. When you click the Update button, you will 
then be asked to point out the external file, which is then loaded on the list page.

The check box can also be applied for excluding a list file from being updated.

THIS FUNCTION IS NOT FOR CORRECTING PARTS LISTS

THIS FUNCTION CAN FOR INSTANCE BE APPLIED WHEN YOU HAVE A CABLING 

LIST BETWEEN PANELBOARDS, AND DO NOT WISH TO DRAW THE CABLING.
— OR IF YOU GENERALLY DO NOT WISH TO INCLUDE LISTS IN THE PROJECT, 
WHICH YOU CAN NOT FILL OUT VIA THE DRAWINGS.

THE FUNCTION IS NOT DESIGNED FOR CORRECTING EXISTING PARTS LISTS!
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SORTING IN PARTS AND COMPONENTS LISTS

The tab Lists => List setup => Sort by only exists for parts and components lists.

Here you can specify how to sort the contents in the list. You can specify a Major 
sort at the upper section of the dialog box and a Minor sort in the lower section:

Major sort

Under Major sort in the upper section of the tab, you have the following options in 
the Type field:

Major sort: None

The sorting performed at specified under Minor sort.

Major sort: Database fields

When you have selected the type Databasefields, you can specify which field in 
the database to sort from in the Value field. This can for instance be applied for 
sorting the list by source or by manufacturer.

The option of sorting according to database fields are only displayed when working 
with an attached database. — Read more about databases in “Databases” on 
page 627.
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Major sort: Symbol datafields

The option of sorting by Symboldatafields is only displayed when symbol data-
fields are created in the project. — Read more about symbol datafields in “Symbol 
datafields” on page 120.

Major sort: Reference designations

When you have selected Reference designation, you get the option of specifying 
whether to sort based on the Full reference designation, Function aspect, 
Location aspect or Product aspect.

The option of sorting by reference designation is only available when reference 
designations are defined in the project. — Read more about reference designa-
tions in “Reference designations” on page 371.

Separation between e.g. manufacturers

Furthermore, you can specify how to separate the different manufacturers in the 
list — if you chose Databasefields and the value Manufactur.

Here you can choose between No separation between (MANUFACTUR) and 
Page shift between (MANUFACTUR) — or you can select Empty lines between 
(MANUFACTUR), and specify the number of blank lines between the manufactur-
ers in the list.

When you select Change page in not enough lines for (MANUFACTUR), the 
components for a new manufacturer starts on top of a new page, when there are 
not enough room for all components from the manufacturer on the page. — This 
option can not be selected when you have selected Page shift between (MANU-
FACTUR) above.

You can also choose Group accessories under the component and Sort 
descending.

Minor sort

At the bottom of the tab you can furthermore specify how the components shall be 
sorted within each individual manufacturer.

In the above dialog box, the components will therefore primarily be grouped by 
manufacturer. For each manufacturer, the components will then be sorted by 
name, and below this by article number. — See also “Sorting on all parts of the 
symbol name” on page 602.

Sorting on all parts of the symbol name

Regardless of what you have specified as Major sort, components lists can also 
be sorted according to all parts of the symbol name in the Minor sort section; the 
function aspect (=), the location aspect (+) and the product aspect / name (-). — 
See “On reference designations” on page 373.
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If for instance you want all components with the same locational aspect (e.g. +A1) 
to be listed together in the same components list, you just need to move LOCA-
TION to the top of the list.

You can either do this by clicking on LOCATION and then drag it to the top of the 
list, or by clicking on LOCATION and then use the arrow buttons next to the list.

If you place PRODUCT/NAME at the top of the list, for instance all -K1 symbols will 
be placed succeedingly, regardless of their function and location aspects.

This makes it possible to create a list where e.g. all panels appears separately.

If you do not make any changes, the order will by default be FUNCTION, LOCA-
TION and PRODUCT/NAME.
mation

Page 603



P

List settings
SPECIFYING CRITERIA FOR THE COMPONENTS TO INCLUDE

On the tab Criteria you set up the conditions for which content you want on the list 
you are working on.

You can fill out seven lines, each containing one criterion. If you need to add more 
criteria, click Add.

Criteria for accessories

The settings on the Criteria tab specifies the criteria for components in the project, 
and not for their accessories. Accessories are therefore only included in lists, when 
the main component fulfil the criteria.

If you select Include all accessories for components, all accessories for compo-
nents fulfilling the criteria, are included in the list.

If you select Only include accessories fulfilling the criteria, accessories are 
only included when they also fulfil the specified criteria.

Only one criterion needs to be fulfilled

When you select Only one Crite-
rion needs to be fulfilled (logical 
OR), the text and changes to or in 
the dialog box.

In the dialog box above this would 
mean that you get all components from AEG Industry, as well as all components 
having a K in the symbol name.

If Only one Criterion needs to be fulfilled is not selected, the text and is dis-
played between the criteria lines. This means all the criteria have to be fulfilled at 
the same time. In the dialog box above, this means you only get components from 
AEG Industry, having a K in their symbol names.
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Setting up a criterion

By clicking in the text fields below Field, you state which datafield the criterion is 
set for. These datafields can be any datafield from the database, or from one of the 
symbol texts.

If you set Operator to =, you can type in what the contents of the field should be 
identical to in the Text field.

If you want the contents to differ from what you type into the Text field, you choose 
the Operator <>.

Accordingly, you can set the operator to determine that the contents must be larger 
than (>) or smaller than (<) what you specify in the Text field. Please note, that 
these operators examine whether the texts are placed before or after the text 
alphabetically.

If you select A<>a, you tell the program to distinguish between upper- and lower-
case letters.

Data for which Criteria can be set

The data, for which you can set criteria, are:

- Datafields from the database (written in capitals)

- Component data (Name, Type, Article no and Function — as well as your own 
symbol datafields)

- Reference designations (the datafield =+design.) — see the figure below

- Symbol type — see “Symbol types” on page 771

- Symbol datafields — see “Creating symbol datafields” on page 798

If you choose Name, Type, Article no or Function a list is displayed containing 
the applied names, types, article numbers or functions in the project. If you choose 
=+-design. you enter the dialog box Reference designations, where you specify 
which reference designation to use as criterion.

Wildcards/jokers

If for instance you need all components on a list having the letter K in their name, 
you need a way to tell this to the program.

For this purpose, you can apply the so-called jokers/wildcards, which are also used 
in Windows.

The special characters used for this purpose are ? and *.

When you place a question mark (?) somewhere in a text, this signifies, that on the 
place in the text where the question mark is located, there have to be exactly one 
character. And this character could be any character.

If you place an asterisk (*), any number of characters could be located on the place 
where the asterisk is located.
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If you, for instance, have to find something on exactly three letters with the letter Q 
as the second character, you type in ?Q?. Thus you state that there has to be one 
— and just one — character in front of Q, and exactly one character after as well.

If you will find a text having an A anywhere in the text, you type in *A*.

— Please note, that if you use ? there have to be a character, but if you use * this 
also covers cases with no characters on the location of the asterisk.

Example

If you want a list of contactors from AEG Industry, you set up as a first criteria, that 
MANUFACTU have to be equal to AEG Industry.

As the second criteria, you state that Name shall be equal to *K*. This gives you all 
component names with a K. — You can see these settings on page 604.

By creating several different parts lists, you can create a parts list for each compo-
nent vendor you order components from.
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HOW TO HANDLE REPETITIONS IN LISTS

This tab only exists for parts and components lists.

On the Repetitions tab, you can specify how repetitions in the list shall be han-
dled.

If you choose the datafield and type in a text, the program inserts the text for each 
repetition of the given datafield.

If you fill out the tab as displayed above, the list will look like this:

To empty a line on the tab, choose the blank field in the drop down box for the line.

Data for which repetitions can be specified

The data, for which repetitions can be specified, are the same as the data which 
can be applied for Criteria. — See “Data for which Criteria can be set” on 
page 605.
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HOW TO REPLACE MISSING INFORMATION

This tab only exists for parts and components lists.

If the program can not find a piece of information about a component in the data-
field you have specified, you can specify another datafield where the information 
can be collected from.

Please note, that data is only collected from the replace field if the original datafield 
is empty for a component.

When the program can not find information about a components description in the 
database (DESCRIPT), you can tell the program to collect the information from the 
Type field in the Component data dialog box for the component on the diagram.

Please remember, that datafields written in upper-case letters represent informa-
tion coming from the database.

Data for which replacements can be specified

The data, for which replacements can be specified, are the same as the data which 
can be applied for Criteria. — See “Data for which Criteria can be set” on 
page 605.
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LIST SETUP FOR TERMINALS- CABLES- AND PLC LISTS

For terminals, cables and PLC lists you have some special options on the General 
tab, and you also have the option of using symbol datafields on the Criteria tab. 
This is described in the following:

The tab General for terminals, cables and PLC lists

If you are working on a terminals, cables or PLC lists and choose Lists => List 
settings, the General tab looks like this:

Separation

Here you specify how to separate the terminals, cables or PLCs on the list.

Here you can choose only to have one terminal row on each page by choosing 
Page shift between Terminal Rows, or to insert empty lines between the terminal 
rows by choosing Empty lines between Terminal Rows. If you choose the latter, 
it is also possible to specify how many empty lines to insert between the terminals/
cables/PLCs in the list.

Components starts on new page in Cables, Terminals and PLC lists

When you select Change page if not enough lines for Terminal Row, a compo-
nent starts on a new page, when there is not enough space for it on the remains of 
the current list page.

Survey of cable connections

For cable- and terminals lists, it is possible to create a survey of what the cables 
connects. This is done by enabling List only one of each name, and can be 
applied for lists in the project as well as lists for files.

In terminals lists the first terminal in the terminal row is displayed (the lowest group 
number). In cable lists the first conductor in the cable is displayed.

Specify no.

of blank lines
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Special for cables
For cable lists, there are two more settings:

SORTING IN CABLES LISTS

For cables lists, you can under Sort by specify whether to 
sort by Cable wire, Terminal at To-end or Terminal at 
From-end.

SORTING SO THAT CABLE WIRES FOR THE SAME CABLE SYMBOL ARE KEPT TOGETHER

When you select Sort within symbol, cable wires which are drawn next to each 
other in the same cable — for instance because they are under the same screen in 
a cable or a twisted pair — are also placed next to each other in the list.

Sort by name on PLC lists

For PLC lists you also specify according to which datafield 
the list is sorted.

For terminals lists only

For terminals lists you can select On named potentials: Show one line per ter-
minal only. When this option is selected, there will only appear a single line in the 
terminals list, for the terminals that are connected to a named potential. If you then 
select Show potential name only, only the potential name appears in the list. If in 
stead you select Show one connection only, one of the connections to the termi-
nal appears in the list.

The remaining settings

Pages and layers and Include all pages in the Table of Contents are described 
in “Specifying from where to collect components” on page 598. The Criteria tab is 
described in “Specifying Criteria for the components to include” on page 604.

Symbol datafields as Criteria for terminals, cables and PLC lists

On the Criteria tab for terminals, cables and PLC lists, you can use user defined 
datafields as criteria. — See “Creating symbol datafields” on page 798 and “Sym-
bol datafields with predefined values” on page 800.

If you therefore have created a symbol datafield Cable route for cables, this can be 
used as a criterion in cables lists, so that cables where Cable route has different 
values — such as In ceiling and In wall — can be listed side by side, or in sepa-
rate lists.
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LIST SETTINGS FOR CONNECTIONS LISTS

To specify the settings for a connections list, you must activate the table of contents 
page and choose Lists => List Settings. You then enter this dialog box:

Here you can specify whether to sort the connections list by Wire Numbers, Com-
ponent names, Component drawing location or Starting point of wires.

You can also specify whether to Write complete nets and/or whether to Include 
cables in the list.

LIST SETTINGS FOR TABLES OF CONTENTS

To specify the settings for a table of contents, you must open the table of contents 
page and choose Lists => List Settings. You then enter this dialog box:

Here you specify what to include in the table of contents

Normally, a table of contents will only contain information from project pages 
placed after the table of contents in the project. If you therefore place a table of 
contents as the last page in the project, it will not contain any information — unless 
you select Include all project pages.
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In the dialog box you have the following options:

Because some of the above options mutually excludes each other, some options 
will be dimmed as you make selections in the dialog box.

OPTION EFFECT

INCLUDE ONLY DIVID-

ERS

THE TABLE OF CONTENTS WILL ONLY CONTAIN THE DIVIDER PAGES 

OF THE PROJECT.

INCLUDE ONLY PAGES 

FROM CHAPTER

THE TABLE OF CONTENTS WILL CONTAIN THE SUCCEEDING PROJECT 

PAGES IN THE CHAPTER.
WHEN YOU SELECT INCLUDE ONLY PAGES FROM CHAPTER, YOU 

ALSO GET THE OPTION OF SELECTING INCLUDE TABLE OF CON-

TENTS. IF YOU SELECT INCLUDE TABLE OF CONTENTS, THE PAGE(S) 
CONTAINING THE TABLE OF CONTENTS FOR THE CHAPTER ARE ALSO 

LISTED IN THE TABLE OF CONTENTS.

INCLUDE ALL PROJECT 

PAGES

WHEN YOU SELECT THIS OPTION, THE TABLE OF CONTENTS WILL 

CONTAIN INFORMATION FROM ALL PAGES IN THE PROJECT.
IF YOU DO NOT SELECT THIS OPTION, THE TABLE OF CONTENTS WILL 

ONLY CONTAIN INFORMATION FROM PROJECT PAGES SUBSEQUENT 

TO THE TABLE OF CONTENTS.

INDENT PAGES IN 

CHAPTER

THE COMMON PROJECT PAGES (DIAGRAMS, LISTS E.T.C.) WILL BE 

INDENTED 15MM. COMPARED TO THE DIVIDERS.

SHOW ONLY PAGE 

TITLES AT DIVIDERS

FOR CHAPTER DIVIDER PAGES, IT OFTEN SAYS THE SAME IN THE 

FIELD SETTINGS => PAGE DATA => PAGE TITLE AND ON THE TAB.
WHEN YOU SELECT THIS OPTION, ONLY THE PAGE TITLE IS DIS-

PLAYED FOR THE DIVIDER PAGES IN THE TABLE OF CONTENTS.

IN COLUMNS — SEE “Lists in Columns” on page 600.
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COMPONENT GROUPING

To get the correct information transferred from the project diagrams to the lists, you 
sometimes need to apply the Component grouping function.

WHEN IS COMPONENT GROUPING NECESSARY

Normally you regard all symbols with the same symbol name as the very same 
component. However, this component can be built up from several physical compo-
nents.

Therefore, when you want to print out the parts lists, there are cases where the 
program cannot determine how many components of a specific type are used in 
the project.

This could also be the case if for instance you use three terminals, each having the 
same symbol name and the same article number. In this case, the program cannot 
tell whether they are three individual terminals, or it is a triple terminal. — Unless 
you have fetched the terminals directly from the database, as described in 
“Fetching symbols from the database” on page 167.

In this case, the program can not tell whether just one or three components with 
the given article number are needed on the parts list.

Therefore, the program will have to make a qualified guess, but if you are not sure 
that the program will guess correctly, you will have to state what is the case your-
self.

To be specific about this, you have to perform a so-called component grouping.

Here you divide symbols having the same names into groups, by assigning the 
same group number to the symbols for each individual component.

THIS CHAPTER DESCRIBES

— WHEN COMPONENT GROUPING IS NECESSARY ..........................................p. 613

— THE COMPONENT GROUPING MENU ..........................................................p. 614

— COMPONENT GROUPING ON MECHANICAL PAGES .......................................p. 614

— FINDING A COMPONENT IN THE MENU ........................................................p. 615

— THE SORTING ORDER OF THE COMPONENTS ..............................................p. 615

— CHANGING THE ORDER BY DRAG AND DROP ..............................................p. 615

— SPECIFYING THE COMPONENT GROUPING ..................................................p. 615

— THE ORDER OF THE COMPONENTS IN LISTS..............................................p. 618

— SPECIFYING THE ORDER IN PARTS LISTS ...................................................p. 618

— SPECIFYING THE ORDER IN TERMINALS LISTS ............................................p. 618

— ENDING A COMPONENT GROUPING............................................................p. 619

— COMPONENT GROUPING AND COPYING......................................................p. 619

— GRAPHICAL MANAGING OF COMPONENT GROUPING FOR TERMINALS ...........p. 620
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When two symbols have the same name, article number and component group 
number, the program knows they are part of the same physical component. If their 
group number differ, the program knows they belong to different components.

Because the component groups are printed out in numerical order (starting from 
the lowest group number), the group numbers have the further advantage, that you 
can determine the order in which components are printed out on the components 
list, as well as in which order terminals are printed out on terminals lists. — Read 
more about this in “The Order of the Components in lists” on page 618.

THE COMPONENT GROUPING MENU

When you have clicked on Symbols, and choose Functions => Component 
Grouping (short-cut <Ctrl+F7>), you enter this dialog box:

You can also select a symbol and choose Functions => Component Grouping, 
which makes you enter the Component Grouping menu for all symbols with the 
chosen symbol name.

Click on Print when you need to print out the component grouping of a component.

Component grouping on mechanical pages

When working with projects containing pages of the type Ground plan/Mechani-
cal, you can click on Mechanical at the bottom of the dialog box, which makes it 
possible to perform the component grouping on the mechanical symbols in the pro-
ject.

GRAPHICAL MANAGING OF COMPONENT GROUPING FOR TERMINALS

WHEN YOU WISH TO MAKE COMPONENT GROUPING FOR TERMINALS, THERE 

IS A MORE GRAPHICALLY INTUITIVE WAY TO DO THIS. THIS IS DESCRIBED IN 

“Graphical managing of component grouping for terminals” on 
page 620.
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FINDING COMPONENTS

If you have not chosen the component you want to group, you can type in the name 
of the component in the lower-left corner of the dialog box.

Clicking on the Used components button gives you a list of the used symbol 
names in the project. Here you click on the symbol name you are interested in, and 
click on OK.

Also, you can scroll back and forth in the list of components by clicking on the Pre-
vious component and Next component buttons. Please note that the arrow-keys 
can be used as short-cut keys for these buttons.

Clicking on the First component button gives you the first component in the list, 
while clicking on the Last component button gives you the last.

When you click the Show where the component is placed button (or click on the 
symbol in the list and press <Enter>), the cross hairs points out the symbol in the 
project — and the Component grouping menu remains on screen.

THE SORTING ORDER OF THE COMPONENTS

By clicking on the column headers in the table, 
you determine by which criterion the components 
will be sorted in the dialog box. If you click on 
Symbol, they will be sorted by symbol name, if 
you click on Conns. they will be sorted by con-
nection numbers — and so on.

You can sort in both ascending and descending 
order. To switch between ascending and descend-
ing order, just click the column header once again.

CHANGING THE ORDER BY DRAG AND DROP

When you have selected one or more symbols in the dialog box Component 
grouping, you can move them by "drag and drop". This means:

 1) Click on the selected symbols

 2) Keep the left mouse button pressed down while you drag the symbols to the 
desired position

 3) Release the mouse button

The symbols are now inserted in the desired position in the dialog box Component 
grouping.

SPECIFYING THE COMPONENT GROUPING

You can either let Automation guess the component grouping, or specify how it 
shall be yourselves:

Descending/ascending

order
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Letting the program do the component grouping

When you need to zero all the group numbers for the chosen symbol name, do the 
following:

 1) Click on the first line in the dialog box

 2) Press down <Shift> and click on the last line in the dialog box: All lines are 
now selected

 3) Type in the component group number 0 and click the Transfer group num-
bers button

When all group numbers for a component is set to zero, this signifies that you have 
not taken the grouping of the component into consideration. When you print out 
lists, the system will then have to guess in which order the possible parts of the 
component shall be printed, as well as whether they belong to the same compo-
nent or not.

Specifying component grouping by assigning group numbers
automatically

If you wish to state that you have specify that all three terminals with the same 
symbol name are part of the same component, you therefore have to assign group 
number one to all of them.

For instance you have six terminal symbols with the same symbol name, and want 
to state that they represent two components each containing three terminals. You 
therefore give three of the terminals group number 1, while the remaining three 
gets group number 2. Do the following:

 1) Set Position pr. terminal to 3 (short-cut <Alt+p>). — This tells the program 
that three terminals are required for one part component (for instance for 
multi layered terminals).

 2) Set Groupnumber to 1 (short-cut <Alt+g>).

 3) Click for instance on the column Conns. — to sort the terminals by connec-
tion name.

 4) Select the three terminals, and click on Preset Group Numbers, and the 
three selected terminals are assigned group number 1 and the positions 1, 2 
and 3 respectively.

 5) Set Group Number to 2.

GROUP NUMBER 0 FOR TERMINALS

ALL TERMINAL SYMBOLS WITH GROUP NUMBER 0 IS UNDERSTOOD AS INDI-

VIDUAL TERMINALS.

OTHER TYPES OF SYMBOLS WITH GROUP NUMBER 0 ARE UNDERSTOOD AS 

PART OF THE SAME COMPONENT.

PLEASE NOTE: TERMINALS WITH COMPONENT GROUP NUMBER 0 CAN NOT 

HAVE ACESSORIES. STARTING FROM VERSION 21 WE GENERALLY RECOM-

MEND NOT TO ASSIGN COMPONENT GROUP NUMBER 0 TO TERMINALS.
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 6) Select the three remaining terminals, and click on Preset Group Numbers, 
and the three selected terminals are assigned group number 2 and the posi-
tions 1, 2 and 3 respectively.

Assigning group numbers manually

If you want to transfer a group number to a symbol, you click the up- and down-
arrows in the field below Group Number until the desired number is in the box.

Then select the symbols, which are part of the component, and click on the Trans-
fer Group Number button, which transfers the group number to the selected sym-
bol.

ASSIGNING GROUP- AND POSITION NUMBERS IN A SINGLE OPERATION

WHEN THE TERMINALS APPEARS IN THE DESIRED ORDER IN THE MENU, AND 

YOU HAVE SET GROUP NUMBER AND POSITION PR. TERMINAL CORRECTLY, 
YOU CAN ASSIGN ALL OF THE TERMINALS IN THE MENU CORRECT GROUP 

AND POSITION NUMBERS IN ONE SINGLE OPERATION, BY CLICKING THE PRE-

SET GROUP NUMBERS BUTTON.

COUNTING UP AND DOWN BY DOUBLE-CLICKING

DOUBLE-CLICKING ON A COMPONENT ON THE LIST, WILL INCREASE ITS 

GROUP NUMBER BY ONE.

PRESSING DOWN <SHIFT> WHILE DOUBLE-CLICKING WILL DECREASE ITS 

GROUP NUMBER BY ONE.
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THE ORDER OF THE COMPONENTS IN LISTS

When Automation fills out a list, the components are listed according to the follow-
ing criteria:

 1) Component name

 2) Group number

 3) Position number

 4) Article number

This means, that for each symbol name, the components are printed out primarily 
ordered by group number, then ordered according to position number, and finally 
according to article number.

SPECIFYING THE ORDER IN PARTS LISTS

If you have constructed your own component, for instance a contactor with add-on 
contacts, you can therefore determine in which order the component parts should 
appear on the parts list.

Because the lowest group numbers for the component appears first on lists, you do 
this by assigning the lowest group numbers to the parts that shall appear first.

In this way you can get the contactor first, followed by the auxiliary contacts.

SPECIFYING THE ORDER IN TERMINALS LISTS

The group numbers for the component also determines in which order the termi-
nals are printed out in terminals lists.

For individual terminals you can therefore determine their order in the lists using 
the group numbers, so that they are printed out as they should be mounted.

— Please also see “Keep component grouping when copying terminals” on 
page 619.
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END COMPONENT GROUPING

When you have completed the component grouping for a component, and change 
to another component name in the lower-left corner, you will be asked whether you 
want to transfer the changed group numbers to the component.

Click on Yes.

When you have finished grouping components, you click on OK, whereby you 
approve the component grouping you have carried out.

COMPONENT GROUPING AND COPYING

For everything which is being placed via the database, the component grouping is 
handled automatically by the program.

For all copying, the used component grouping is examined, and the component 

grouping is continued following the same directions for the inserted copies.

KEEP COMPONENT GROUPING WHEN COPYING TERMINALS

TO KEEP THE COMPONENT GROUPING WHEN COPYING TERMINALS, DO THIS: 
SELECT THE SYMBOLS, CHOOSE EDIT => COPY (IDENTICAL), AND INSERT 

THE SYMBOLS. THIS WAY THE PASTED SYMBOL NAMES, CONNECTION NAMES 

AND GROUP NUMBERS REMAINS UNCHANGED.

WHEN YOU CHOOSE EDIT => COPY (IDENTICAL), YOU CAN THEREFORE 

EASILY COPY TERMINAL ROWS, SO THAT THE INTERNAL SIDE IS DISPLAYED 

AT ONE PAGE, WHILE THE EXTERNAL IS DISPLAYED AT ANOTHER.
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GRAPHICAL MANAGING OF COMPONENT GROUPING FOR TERMINALS

There also exists a more graphically oriented way of grouping terminals. To acti-
vate it, you must right-click on a terminal symbol, and choose Show terminal row. 
You then enter the dialog box Show terminal row:

The significance of the order of the terminals

The order of the terminals in the dialog box, specifies the order, in which they sub-
sequently appear, in parts lists, components lists, terminals lists and graphical ter-
minal plans. When the terminals are placed using mechanical placing, this is also 
the order that they will appear in.

— If necessary, please refer to “When is Component grouping necessary” on 
page 613.

Show the terminal rows in the project

Initially, only the 
selected terminal row is 
displayed. When you 
right-click on the tab for 
the selected terminal 
row and choose Add 
all terminals in pro-
ject, all terminal rows in 
the project appears as 
tabs in the dialog box.

To close a tab for a ter-
minal row, just right-
click on the tab, and 
choose Close tab.

Selecting terminals

To select a terminal, just click on it in the dialog box. To for instance select the ter-
minals 1 to 3 in the figure above, just click on terminal 1, and press <Shift> while 
clicking terminal 3. You can select further terminals by pressing <Ctrl> while click-
ing the terminals in the dialog box.

Right-click here
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Grouping terminals in a component

In the dialog box Show terminal row, the individual 
terminal is indicated by a rectangle with a name/
number inside (the connection name for the termi-
nal symbol).

Around the individual terminals, another rectangle 
indicates which terminals are part of the same com-
ponent. In the figure to the right (1) and (2) are 
therefore part of the same component.

GROUPING BY CLICK AND DRAG

To group two terminals: Click on a terminal, and 
then drag it into another terminal component. 
Please note that you must point at the top or the bottom of the terminal when 
releasing the mouse button. — This meaning the frame around the component:

— Please also see “Changing the order of the terminals by click and drag” on 
page 621.

GROUPING BY RIGHT-CLICKING

You can also select the ter-
minals you wish to group, 
right-click, and select 
Group into one compo-
nent.

To cancel a grouping: 
Right-click on a grouped 
component and choose 
Split into separate com-
ponents.

Changing the order of the terminals by click and drag

To change the order of the terminals in the dialog box: Click on the terminal you 
wish to move, drag it to the position where you wish to place it, and release the 
mouse button.

Indication of terminal

Indication of component

A) Click on the terminal (2)

B) Drag it into the component frame
around (1) and release the mouse

C) Terminal (1) and (2) are now grouped
in the same component frame
mation

Page 621



P

Component Grouping
When you release the mouse button, you must point at a terminal symbol — at (2) 
in the figure below — and not at the top or at the bottom of the component frame:

Specifying multi terminals / multi layer terminals

To specify that a grouped component is a multi terminal: Right-click on the grouped 
component, and choose Component is multi terminal/layered. This assigns 
position numbers to the terminals in the group.

Links to the terminals in the project

Below the terminals in the dialog box, 
you find a small symbol. When you click 
this symbol, the terminal is selected in 
the project.

When a terminal appears more than 
one place in the project — if for instance 
the internal and the external sides are 
placed on different project pages — 
there will be a link to each symbol for the terminal.

Example on graphical grouping of terminals

You can group three terminals, to become part of the same component, like this:

 1) Open the Show terminal row window: Right-click on a terminal and choose 
Show terminal row.

 2) Select the terminals in the diagram.

A) Click on the terminal (3)

B) Drag it to a position where you want to 
place it (2) and release the mouse button

C) Terminal (3) is now placed between
terminal (1) and (2) 

Click here, and the ter-
minal is selected in the
project
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 3) In the Show terminal window the terminals are now selected automatically: 
Right-click on the terminals in the window and choose Group to one com-
ponent.

 4) The terminals are now grouped as one component.
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Automatic grouping of terminals

When you click the Auto.group button in the lower-right cor-
ner of the dialog box, the selected terminal row is grouped in 
the Show terminal row window.

When you click the down-arrow next to the Auto-group button and choose 
Auto.group all shown terminal rows, all terminal rows in the Show terminal row 
window are grouped.

Rules for automatic grouping

When you click the down-arrow next to Auto.group and choose Options for 
auto.group, you can specify how to group the terminal rows:

Here you have the following options:

OPTION EFFECT

THE ORDER FOLLOWS THE ALPHANU-

MERIC ORDER OF THE TERMINAL NUM-

BERS

WHEN TERMINALS FOR INSTANCE ARE NAMED 1, 2 
AND 3, THEY ARE SORTED IN THIS ORDER. IF THEY 

ARE LISTED AS 3, 1, 2 IN THE WINDOW, THIS IS 

THEREFORE CHANGED TO 1, 2, 3.

DIFFERENT TERMINAL NUMBERS = DIF-

FERENT COMPONENTS

WHEN THE TERMINALS ARE NAMED 1, 2, AND 3 
THEY BECOME THREE DIFFERENT COMPONENTS.

SAME TERMINAL NUMBER = SAME COM-

PONENT

WHEN THE TERMINALS ARE NAMED 1, 1 AND 1 
THEY BECOME ONE COMPONENT.

LAYERING FROM DATABASE THE LAYERING IS FETCHED FROM THE DATABASE.

LAYERING. ALL COMPONENTS HAVE _ 
LAYER

IF THE NUMBER OF LAYERS FOR INSTANCE ARE SET 

TO 3, THE TERMINALS ARE GROUPED IN THREES. 
WITHIN EACH COMPONENT, THE TERMINALS GET 

THE LAYER NUMBERS (POSITION NUMBERS) 1, 2 
AND 3.
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INSERTING UNIT DRAWINGS

In your projects you can insert the so-called unit drawings, specifying what an indi-
vidual component consist of. It is then possible to attach the unit drawing to a sym-
bol in the project. When you right-click on this symbol, you will then get the option 
to jump to the page where the unit drawing for the symbol is located.

When you use extended parts lists in your project, articles from the unit drawings 
are included in the parts lists. Read more about this in “Specifying from where to 
collect components” on page 598.

— See how to create a unit drawing in “Creating Unit Drawings” on page 833.

INSERT EXISTING UNIT DRAWING / PARTS LIST INTO A PROJECT

When you want to insert an already created unit drawing into a project, you enter 
the Page menu to create a new page, and then state that this page shall contain a 
unit drawing:

Click on the Page menu button, and then click on Insert or Add. In the emerging 
window you click on Unit drawing and click OK.

A new dialog box appears, and you click your way to the folder with the unit draw-
ing, and click on the unit drawing. If you are not sure how to locate files, you can 
read more about this in “Windows” on page 23.

Click OK when you have found the unit drawing. You have now inserted the unit 
drawing into your project.

ATTACH A SYMBOL ON A DIAGRAM TO THE UNIT DRAWING

When you have placed the unit drawing in your project, you can enter one of your 
diagram pages and right-click on a symbol. Then choose Component data => 
Unit.

In the appearing list of unit drawings in the project, you select the relevant unit 
drawing, and click on OK. You then return to the Component data dialog box, and 
click OK again.

The program now knows which unit drawing is attached to the symbol.

When you then right-click on the symbol and choose Open, you automatically go 
to the page with the unit drawing for the symbol.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO INSERT A UNIT DRAWING IN A PROJECT.
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In this section you can see how to use the database 
in PCSCHEMATIC Automation.

You can read about:

- Using the database .............................................p. 629

- Creating components in the database ............p. 647

- Database settings................................................p. 670

- Choosing a database..........................................p. 687

- Programmable Barcode Scanners...................p. 688

READ SURVEY ARTICLE - WATCH VIDEOS

READ THE SURVEY ARTICLE ABOUT WORKING WITH 

DATABASES AND LISTS AT www.pcschematic.com/arti-
cles.

WATCH THE VIDEOS ABOUT HOW TO CREATE YOUR OWN 

COMPONENTS AT THE PCSCHEMATIC YOUTUBE CHAN-

NEL:

www.youtube.com/PCSCHEMATIC

Databases

http://www.pcschematic.com/articles
http://www.pcschematic.com/articles
http://www.pcschematic.com/articles
http://www.pcschematic.com/articles
https://www.youtube.com/PCSCHEMATIC
https://www.youtube.com/PCSCHEMATIC
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USING THE DATABASE

Automation has an attached database from which you can collect information 
about the components you use in your projects.

In Automation you can either use one of the component vendor databases for the 
program, or use the database which is installed automatically along with the pro-
gram.

You can also create your own databases, by entering records in the databases by 
yourself, or by selecting the components you are interested in from the component 
vendor databases.

You can also read about the database in the PCSCHEMATIC Database manual, 
and in the following chapters.

Using the database for Lines

This chapter focus on using the database while working with symbols.

If you wish to attach article data to a line, this is also possible. To do this, activate 
the Lines button, deactivate the Pencil (press <Esc>), right-click on the line and 
choose Line article data. Then follow the same procedure as described in this 
chapter.

Please note that you can also apply article data to cable symbols, as described in 
“Working with cable symbols” on page 239.

THIS CHAPTER DESCRIBES

— HOW THE DATABASE WORKS (BASIC PRINCIPLES)...................................... p. 630

— ATTACHING COMPONENT DATA FROM THE DATABASE TO A SYMBOL .......... p. 631

— ABOUT THE DATABASE MENU ................................................................... p. 633

— SEARCHING FOR COMPONENTS IN THE DATABASE MENU ........................... p. 634

— EDITING RECORDS IN THE DATABASE ........................................................ p. 640

— INTERNAL DATABASE................................................................................ p. 642

’

SEE ALSO THE SURVEY ARTICLE ABOUT WORKING WITH DATABASES

IN THE SURVEY ARTICLE IN THE BEGINNING OF THE SECTION “Lists” on 
page 583, YOU CAN READ MORE ABOUT WORKING WITH LISTS AND DATA-

BASES IN Automation.
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HOW DOES THE DATABASE WORK?

In the component vendor databases for Automation, the component vendors have 
included ordering data, as well as electrical and mechanical symbols for each com-
ponent.

When you click on the component in the database, you automatically get a pick-
menu containing all the electrical symbols for the component. These symbols each 
represent one of the functions in the component.

When you subsequently place the symbols on your diagrams, the program remem-
bers which components these symbols represent.

When you have completed your electrical diagrams, the program can therefore 
automatically fill out components lists and parts lists etc. — without you having to 
type in any component information.
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Originating from the electrical symbols on the diagrams, the program can also 
fetch the mechanical symbols for the components automatically. These symbols 
can for instance be used for mechanical layouts.

— Read more about this at www.pcschematic.com/articles.

ATTACHING INFORMATION FROM THE DATABASE TO A SYMBOL

In “Fetching symbols” on page 151 you will find a description of the many ways you 
can place symbols with and without information from the database.

If you want to attach information from the database to a symbol which is already 
placed on a diagram, you do like this: Click on Symbols, deactivate the Pencil 
(press <Esc>), right-click on the symbol, and choose Component data.

In the dialog box Component data: Click on Database, and you enter the data-
base.

If an article number is already specified for the symbol in the Component data dia-
log box, the program locates the component when you enter the database.

If only a type text has been specified in the dialog box, all components having the 
same type text will be displayed in the database.

If no type text is specified, a list of components containing matching symbols will 
be displayed.

In the database you find the record for on the component you want to apply, and 
click OK.

You then return to the dialog box Component data, where you can see that the 
information have been transferred.

Click OK.

How to find the right component is described in the following.
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Displaying database information for a symbol

When you want to see which information the database contains for a symbol, right-
click on one of the symbols for the component in the project, and choose Open. 
You then enter the Record Viewer:

Please note that you can not change database information from here. — See how 
to change information in the database in “Editing records in the database” on 
page 640.

Click on Close.

APPENDIX FOR DATAFIELDS IN THE COMPONENT DATABASE

IN “Datafields in the component database” on page 956 YOU CAN SEE 

WHICH DATAFIELDS ARE CREATED IN THE COMPONENT MANUFACTURER 

DATABASE, WHICH IS DELIVERED WITH THE Automation SOFTWARE.
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ABOUT THE DATABASE MENU

When you wish to enter the Database 
menu, you can for instance press the 
short-cut key <d>, as described in 
“Fetching symbols from the database” 
on page 167.

You can also click the Component 
Database button in the upper part of the 
Explorer window, as displayed to the 
right. This button is always available, no 
matter which command you are working 
in.

The Database menu contains folders, each containing different groups of compo-
nents.

If you are using the PCSCHEMATIC Database program you can create your own 
database menu. — Please refer to the PCSCHEMATIC Database manual for fur-
ther details.

If you are using your own database program, you can also create your own menu 
table there. However, it is recommended to create it in the PCSCHEMATIC Data-
base program first, and then transfer it to your own database system. This ensures 
you that the menu has the right format.

If you wish to change which database fields/information is displayed in the Data-
base menu, please refer to “Database settings” on page 670.

Menu for the database Records in database

Scroll/search among
the records displayed

Specify which records
to display

Open links (if any)
for the selected
record
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SEARCHING FOR COMPONENTS IN THE DATABASE MENU

When you are in the Database menu (short-cut key <d>), you can find the compo-
nent, that you are looking for, in various ways.

Please note that the following methods can be combined:

1. Choosing a folder in the article menu

For instance you can click on the folder in the article menu — in the upper-left cor-
ner of the dialog box — which contains the type of components you are looking for. 
The contents of the folder is then displayed, and you click on the desired compo-
nent. However, if the folder contains many components, this will not be sufficient.

Display Fabricates with components from selected Article group only

If you have selected Settings => Database => Component search and have 
selected Show only tablemenu points containing the selected fabricates com-
ponents, the Fabricate menu in the right-hand side only displays fabricates hav-
ing components in the selected article group.

2. Selecting a Fabricate / Vendor

In the upper right-hand corner of the Database menu you 
can find a menu, from which you can choose which fabri-
cate to display components for. — See how to activate this 
option in “Product choice or Fabricate choice in the Data-
base menu” on page 677.

This fabricate menu works in combination with the com-
mon database menu (in which the components are 
grouped by function).

When clicking on a fabricate, all components being of this fabricate and being 
placed in the selected folder in the database menu, are displayed.

When for instance you click on Automatic switches / connection material in the 
menu, and on AEG in the fabricate menu, all components in the menu item Auto-
matic switches / connection material of the fabricate AEG are displayed.

When you click on FABRICATE (Show all), all fabricates in the selected compo-
nent grouping menu item are displayed.

3. Activate search

In the lower-right corner of the dialog box, you have the option of searching in sev-
eral ways.

If you activate the Case sensitive query button, the query will discern between 
upper- and lower case letters when you search for a component. (When the 
applied database format supports this).

If you activate the Autorun query button, the program will start searching each 
time you type in a new character in one of the search fields. If this button is not acti-
vated, the searching is not activated until you click the Run query button.
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Specifying the EAN number or the type of the component

When you know the EAN 
number — or just the 
beginning of the number 
— you can click on the tab 
Item No. / Type / Desc. in 
the lower-right side of the 
dialog box. Here you type 
in the number in the field 
EANNUMBER begins 
with. The program then finds every component in the entire database, that 
matches the number. When you only wish to search in the selected folder, select 
and only in Branch equipment at the bottom of the dialog box (The menu item 
changes name according to the folder selected).

When working in the Database menu, the short-cut key <Ctrl+a> gives you direct 
access to this search field.

— Please note, that if you have specified the datafield ITEMNO as Article number 
in Settings => Database => Database settings => Component data, the field 
will be named ITEMNO begins with in stead.

Searching for component or type

When you know the type of the component, you can type it into the TYPE begins 
with field. When working in the Database menu, the short-cut key <Ctrl+t> gives 
you direct access to this search field.

Applying 1.Searchkey

When you wish to search 
on other fields in the 
database, you click on 
the tab 1. Searchkey, or 
press the short-cut key 
<Ctrl+1>.

Here you choose which 
datafield you want to 
search on, an operator, 
and a text to compare the contents of the datafield with.

SPECIFYING AN ALTERNATIVE SEARCH KEY

WHEN YOU CHOOSE SETTINGS => DATABASE => DATABASE SETTINGS => 
COMPONENT DATA, YOU CAN SPECIFY AN ALTERNATIVE SEARCH KEY — 
FOR INSTANCE THE FIELD ORDERNO. THE PROGRAM WILL THEN SEARCH 

FOR THE ALTERNATIVE SEARCH KEY, IF NONE OF THE CHOSEN RECORDS 

HAVE AN EAN NUMBER BEGINNING WITH THE NUMBER YOU TYPE IN.

Click here only to search

in the selected folder

Datafield in the database TextOperator
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In the figure above the following is chosen:

- The datafield PCSTYPE

- The operator begins with

- The text 07-02-01

This tells the program to find all records having a PCSTYPE 
that begins with the text 07-02-01.

It is possible to choose from many different types of operators, 
which are chosen by clicking on the down-arrow in the opera-
tor field.

If the Autorun query button is activated, the program will find 
matching records, as you type in the text.

Applying 1. and 2. Search key

When you want to search 
on two datafields at the 
same time, you can 
choose to apply the first 
and the second search 
key simultaneously.

Specification of datafield, 
operator and text is similar 
to 1. Search key. If you 
enable and PCSTYPE 
begins with “07-02-01”, the program finds the records which fulfils both specified 
criteria. The text in this field will therefore differ, depending on the chosen search 
criterion on the tab 1. Searchkey.

When you want to search in the folder chosen in the upper part of the menu, you 
enable and only in Automatic switches. (Accordingly, the name of the folder will 
vary). If this function is not enabled, the search will be carried out in the entire data-
base.

The short-cut key for the tab 2. Searchkey is <Ctrl+2>.

Searching and editing among the found records

By applying the buttons in the lower-left corner, you 
can leaf through the found records, edit component 
information, or search among the found records.

If you enable Count records, the program will auto-
matically display how many records/components 
have been found, each time you have performed a new query. However, if you do 
not need this information, it is recommended that you disable this function, due to 
increased search rates.

Leafing through the found records

When you click the First button, you will be placed on the first component in the 
list.

Operators

Search in the selected

folder only
Apply both
search keys
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The Previous button gives you the component just above the actual chosen com-
ponent.

The Next button gives you the component just below the actual chosen compo-
nent.

The Last button gives you the last component in the list.

Update the database

The Refresh button refreshes the records from the database, which are displayed 
on your screen. This is important when the database is located in a network, where 
other users can change the contents of the database while you are working with it.

Edit records

When you click the Pencil, you can edit, delete and add records to the database. 
Please read more about this in “Editing records in the database” on page 640.

Search for records

When you click the Find button you will enter the dialog box Search, where you 
can specify what you are searching for. You only search among the records which 
are listed in the Database dialog box for the moment — or in the selected folder.

The dialog box Search is elaborated in “Finding symbol texts” on page 351.

Please note that the dialog box here has an extra option: If you choose Search all 
records, the program will search in the entire database. If you do not choose this, 
the program will only search among the listed records.

Displaying Approved components only

When you select Show approved components only, only approved components 
are displayed in the Database menu.

— Read more about this in “Display only Approved components and hide Obsolete 
components” on page 680.

SETTING UP THE DATABASE MENU FOR APPROVED/OBSOLETE

TO WORK WITH APPROVED/OBSOLETE COMPONENTS, THE DATABASE MENU 
MUST FIRST BE SET UP FOR THIS. READ MORE ABOUT THIS IN “Approved 
and Obsolete components in the database” on page 679.
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Hiding Obsolete components

When you select Hide obsolete components, no obsolete components are dis-
played in the Database menu.

— Read more about this in “Display only Approved components and hide Obsolete 
components” on page 680.

Specifying that a component is Approved or Obsolete

To specify that a component is approved or obsolete, do the following:

 1) Enter the Database menu (Press <d>).

 2) In the Database menu: Find the component, click on it to select it, and click 
on the Pencil.

 3) In the dialog box Edit record: Scroll down to the fields Approved and Obso-
lete and click on them, which sets a check mark in the fields.

 4) Click the Post changes button, and click Close.

 5) The changes are now displayed in the Database menu:

Please note that it is only possible to set a check mark in the Approved and Obso-
lete fields if these fields are created as boolean fields in the attached database. — 
See “Using non-boolean fields for Approved/Obsolete” on page 679.

Open link for selected record in Database menu

When you in the Database menu 
have selected a record, which con-
tains fields with links, you can acti-
vate these links directly from the 
Database menu — without hav-
ing to open the relevant record in 
the Edit record dialog box. This 
can be done by clicking the Open 
link button in the Database menu.

When you let the mouse cursor 
rest over this button, it is displayed 
which link field that will be opened, 
when you click on the button.

Click here to display approved components only

Click here not to see the obsolete components

Click here to open link

for the selected record

The link is displayed here
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Specify preferred link field in the database

When a record for a component has more than one field containing links, the pro-
gram will open the first field in the record containing a link, when you click the 
Open link button.

However, you can specify a Preferred Link Field, as described in “URL links” on 
page 684. The link from this specified field will then be opened, when you click the 
Open link button.

Choosing between several fields with links

When you click the down-button to the right of the 
Open link button, you get a survey of the fields in the 
selected record, that contains links. When you click 
on a field in the list, the link in the selected field is 
opened.

SHOW PICTURES OF COMPONENTS IN THE DATABASE

If you have pictures of your components in the database, it is possible to show 
these in the Database menu.

This requires the following:

 1) There must be created a field in the database to specify where the pictures 
of the components are placed

 2) The database must contain links to the correct pictures for the individual 
components. — It is recommended that you use the so-called File Link 
Alias for pictures, which you can read more about in “URL links” on 
page 684, particularly in “Example for pictures” on page 685.

 3) That you have selected Show picture in the lower-right corner of the Data-
base menu dialog box.

Also displayed in the dialog box Component data

If a picture is selected for the component in the database, the picture is automati-
cally displayed in the dialog box Component data, when you select a symbol for 
the component on a project page.

The file format for the pictures must be either bmp, jpg, png or gif.
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EDITING RECORDS IN THE DATABASE

When you click on the Pencil in the Database menu — see “About the Database 
menu” on page 633 — you enter the dialog box Record Editor, where you can edit 
the records/components, that are listed in the Database dialog box the moment.

If the Pencil is not visible, you do not have permission to alter the contents of the 
database.

The dialog box Record Editor looks like this:

When you click the Find button you enter the Find dialog box, where you specify 
what you are looking for. You only search among the records that are listed in the 
Database dialog box. If you click the Find again button, the next record fulfilling 
the search criteria is found. This also happens when you press <F3>.

When you click the Replace button, you enter the dialog box Find & Replace. The 
information is not transferred to the database until you click the Post button.

APPENDIX FOR DATAFIELDS IN THE COMPONENT DATABASE

IN “Datafields in the component database” on page 956 YOU CAN SEE 

WHICH DATAFIELDS ARE CREATED IN THE COMPONENT MANUFACTURER 

DATABASE, WHICH IS DELIVERED WITH THE Automation SOFTWARE.

Cut and edit

functions

Functions for

Find and Replace

Insert record

Delete record

Refresh

Cancel

Post

Print record
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— Please read more about the dialog boxes Find and Find & Replace in “Find 
and Replace” on page 351.

Copy / Insert full records in the dialog box Edit Record

To copy a full record in the dialog box Edit Record, you must press the <Ctrl> key 
when clicking the Copy button.

To then insert the full record you must press the <Ctrl> key again when clicking the 
Insert button.

Drop-down lists in the dialog box Edit Record

In the dialog box Edit Record there are drop-down lists for all editable textfields, 
which enables you to select the existing values in the database.

Click here

... and select
in the list
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PROJECT COMPONENT DATABASE

A "project component database" is a component database, which is included in the 
project file. The project component database contains component data for all com-
ponents used in the project.

This makes it possible for you to take the project with you without loosing compo-
nent data, when you don’t have access to your Automation component database. 
Or, you can send the project to someone else, that doesn’t have any access to 
your Automation component database.

When a project has a project component database, the project fetches data from 
the project component database, before searching for data in the Automation 
component database. — How the component database works, depends on 
whether it is locked. Read more about this in “Locking the project component data-
base for the active project” on page 645.

Specify what to include in the project component database

To specify which database fields to include in the project component database, 
select Settings => Database:

Below Database fields saved in project files, you have the following options:

OPTION MEANING

NONE NO PROJECT COMPONENT DATABASE WILL BE ATTACHED TO 

THE PROJECT.

FIELDS USED IN LISTS ALL DATA REQUIRED FOR UPDATING THE APPLIED LISTS, ARE 

INCLUDED IN THE PROJECT COMPONENT DATABASE.

SYSTEM FIELDS AND 

FIELDS USED IN LISTS

THE DATA MENTIONED ABOVE ARE INCLUDED, AS WELL AS THE 

FIELDS NEEDED BY THE PROGRAM TO DISPLAY AVAILABLE SYM-

BOLS ETC. FOR THE USED COMPONENTS.
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Updating the project component database

To update the project component database, do this:

 1) Select Functions => Database => Project component database.

 2) In the dialog box Project component database: Click the Update button.

 3) In the dialog box Update Project component database:
When you select Update articles that already exists in the database, only 
article numbers existing in the project component database will be updated.
When you select REMOVE ALL data and insert new from database, all 
data in the project component database are deleted, and are inserted again 
from the program component database.
Click OK.

ALL DATABASE FIELDS ALL DATABASE INFORMATION FOR THE USED COMPONENTS ARE 

INCLUDED. PLEASE NOTE: ANY TYPE OF PRICE INFORMATION 

WILL ALSO BE INCLUDED.

FIELDS NEVER TO BE 

SAVED

WHEN YOU CLICK HERE, YOU ENTER A LIST, WHERE YOU DESE-

LECT THE INFORMATION (FIELDS) THAT YOU DO NOT WISH TO 

INCLUDE.

OPTION MEANING
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 4) The project component database is now updated:

Editing the project component database

When you select Functions => Database => Project component database, you 
have the following options for editing the project component database:

ALSO UPDATED WHEN LISTS ARE UPDATED

WHEN PROJECT LISTS ARE UPDATED, THE PROJECT COMPONENT DATABASE 

IS ALSO UPDATED.

Export selected components to file

Delete selected componentsUpdate selected

Update all

components

components
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When you right-click on a field in the dialog box Project component database, 
you have these options:

Locking the project component database for the active project

Please note that how the project component database 
works, depends on whether it is locked or not. You 
specify whether the component database is locked in 
the lower-right corner of the Settings => Database 
dialog box.

Generally speaking, you can say that:

• When the project component database is locked, the project fetch component 
data from the project component database.

• When the project component database is not locked, the project fetch compo-
nent data from the PCSCHEMATIC database. When the project component 
database is not locked, it works just like in version 10 and previous versions.

When the project component database is NOT locked

- All component data are fetched from the PCSCHEMATIC database, and the 
project component database is updated correspondingly, when new compo-
nents are added to the project.

- When the project is saved, all unused component data are deleted from the pro-
ject component database.

- If you edit the contents in the project component database: Please note that 
your changes may be lost when the project component database is updated by 
the program.

When the project component database IS locked:

- When new components are fetched from the Database menu — and these 
components are not represented in the project component database — their 
component data are still fetched from the attached PCSCHEMATIC database.
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- Component data for all placed project components are fetched from the project 
component database. Data are only fetched from the PCSCHEMATIC data-
base, when component data are not found in the project component database.

- When lists are updated, unknown component data are added to the project 
component database. After this, all data are fetched from the project compo-
nent database.

- When you edit data in the project component database, you can be sure that 
the changes are not lost. Existing data in the project component database are 
never changed automatically. The only time the project component database is 
updated automatically by Automation, is when new component data are 
added when lists are updated.

- The datafields (columns) in the project component database are not changed 
by the program, unless you choose Update in the Project component data-
base dialog box. — See “Editing the project component database” on 
page 644.
If for instance the PCSTYPE datafield is not included in the project component 
database, this has the consequence that you can not use the Available sym-
bols function in the Component menu, until the project component database 
is updated with these datafields.
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CREATING COMPONENTS IN THE DATABASE

In Automation you can create components in the database with attached electri-
cal and mechanical symbols.

In the manual for the included database program PCSCHEMATIC Database you 

can read more about the options for structuring your database — and much more.

GRAPHICAL CREATION OF NEW COMPONENTS IN THE DATABASE

If you want to create a new component in the database with attached electrical 
symbols, and a mechanical symbol, you first have to place all of the symbols for the 
component in the same project.

Placing all of the symbols for the component in the same project

If you are not already working in a project where all of the symbols for the compo-
nent exists, do the following:

 1) Create the electrical symbols and the mechanical symbol — if these does 
not exist in one of the existing libraries — see “Creating Symbols” on 
page 761

 2) Open or create a project containing both a page of the type Diagram and a 
page of the type Ground plan — see “Creating a new page” on page 546

THIS CHAPTER DESCRIBES

— GRAPHICAL CREATION OF NEW COMPONENTS...........................................p. 647

— INFORMATION ABOUT THE COMPONENT IN THE DATABASE ..........................p. 649

— WHEN THE COMPONENT ALREADY EXISTS .................................................p. 650

— THE ELECTRICAL AND MECHANICAL SYMBOLS FOR THE COMPONENT..........p. 651

— ACCESSORIES IN THE DATABASE...............................................................p. 664

— SPECIFYING THE SYMBOL REFERENCE LETTER FROM THE DATABASE .........p. 667

— SPECIFYING SYMBOL SUB NAMES FROM THE DATABASE .............................p. 668

— CREATING PLC COMPONENTS IN THE DATABASE .......................................p. 668

YOU CAN ALSO USE THE COMPONENT WIZARD - WATCH VIDEOS!

THERE ALSO EXISTS A "COMPONENT WIZARD", WHICH GUIDES YOU 

THROUGH CREATING NEW COMPONENTS FOR PCSCHEMATIC DATABASES. 
IT IS ACTIVATED BY CHOOSING FUNCTIONS => COMPONENT DATABASE => 
COMPONENT WIZARD, AND IS DESCRIBED IN A MINI MANUAL, WHICH YOU 

CAN FIND UNDER HELP => MANUAL FOR COMPONENT WIZARD.

WATCH THE VIDEOS ABOUT HOW TO CREATE YOUR OWN COMPONENTS AT 

THE PCSCHEMATIC YOUTUBE CHANNEL:

WWW.YOUTUBE.COM/PCSCHEMATIC
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 3) Click on the Symbols button

 4) Place all of the electrical symbols for the component on the Diagram page, 
and the mechanical symbol on the Ground plan page. Assign the same 
name to all of the symbols

 5) Right-click on one of the symbols, choose Select Name, and click on the 
Object data button

 6) In the dialog box Component data: Type in Article no and Type for the 
symbols

You are now prepared to create the component in the database, as described 
below.

Creating a component in the database using an existing project

When you wish to add a new component to the database from an existing project, 
do the following (please refer to “Placing all of the symbols for the component in 
the same project” on page 647 to see how to add Article no and Type information 
to the component):

 1) Click on the Symbols button

 2) Right-click on one of the symbols for the component

IN THE DATABASE THE SYMBOLS ARE ASSIGNED THE CONNECTION NAMES 

USED IN THE PROJECT. IT CAN THEREFORE BE NECESSARY TO CHANGE 

THESE BEFORE THE COMPONENT IS ADDED TO THE DATABASE.

THE SYMBOLS ARE ARRANGED AS THEY ARE PLACED IN THE PROJECT — IN 

THE SAME ORDER AS YOU READ A BOOK; THIS MEANING SYMBOLS IN THE 

TOP LEFT CORNER ARE PLACED FIRST, WHILE SYMBOLS IN THE LOW RIGHT 

CORNER ARE PLACED LAST.

Electrical symbols on

the Diagram page
Mechanical symbol on

the Ground plan page
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 3) Choose Select Component

 4) Choose Functions => Database => Insert in Database (or press down 
<Shift+Ctrl> and press <d>)

 5) You now enter the dialog box Edit Record, from where you create the com-
ponent as a record in the database — see “Information about the component 
in the database” on page 649

If a component with the specified article number already exists, you will be 
informed about this, as described in “When the component already exists in the 
database” on page 650.

You have now created a new component in the database.

All electrical and mechanical symbols in the project with the same symbol name 
and article number, will be attached to the component in the database.

INFORMATION ABOUT THE COMPONENT IN THE DATABASE

When you enter the Edit Record dialog box, you can create new components as 
records in the database, as well as edit already existing records. — You can read 
more about editing records in “Editing records in the database” on page 640.

If you have entered the dialog box via a graphical creation of new records — as 
described in “Graphical creation of New Components in the Database” on 
page 647 — some of the datafields of the record have already been filled out.

Fill out the relevant datafields with text information by clicking in the text fields, and 
typing in the information. Click on the Post button when you have completed typing 
in information. Then click on Close.

SUB NAMES, ALTERNATIVE SYMBOLS, # AND SYMBOL TYPE

Automation ALSO DETECTS IF YOU APPLY SUB NAMES, ALTERNATIVE SYM-

BOLS, # FOR SPECIFYING MULTIPLE SYMBOLS WITH IDENTICAL NAMES, AND 

CHANGES IN SYMBOL TYPE COMPARED TO THE SPECIFIED TYPE IN THE 

DATABASE.

Click and drag

here to see more

of the record
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In some of the fields you have the option of specifying connection names, refer-
ence letter for the symbols and much more. — These options are described in 
“Electrical and Mechanical symbols for components” on page 651.

Here the use of the following datafields are elaborated:

WHEN THE COMPONENT ALREADY EXISTS IN THE DATABASE

If you are trying to create a component with an article number, which already exists 
in the database, you are informed about this. You are also told which changes this 
will cause in the database, if you enter the new information about the component in 
the database.

If you here click OK the component is created with the new contents, but if you 
click Cancel the previous component remains in the database.

— Please note that the program does not check whether the new component con-
tains the same symbols as the old, arranged in a different order. The main purpose 
of this check is just to inform you that a component with the same article number 
already exists in the database.

DATAFIELD IS DESCRIBED IN

PCSTYPE “Electrical symbols” on page 651. (SEE “The database field 
PCSTYPE in the component database” on page 948).

PINDATA “Connection names/Pindata” on page 657. (SEE “The data-
base field PINDATA in the component database” on 
page 950 AND “The Database field PINDATA: Counting” on 
page 952).

MECTYPE “Mechanical symbols in the database” on page 662. (SEE 

“The Database field MECTYPE” on page 954).

ACCESSORY “Accessories in the database” on page 664.

REFID “Specifying Ref. Letter for the symbol in the Database” on 
page 667.
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ELECTRICAL AND MECHANICAL SYMBOLS FOR COMPONENTS

When you attach symbols to components in the database, you concentrate on 
three different datafields. These are the datafields PCSTYPE, PINDATA and MEC-
TYPE. (However, it is possible to add extra fields for different types of mechanical 
symbols). These datafields contains information on the electrical symbol(s), the 
connection names, and the mechanical symbol (optional) for the component.

Electrical symbols

In the database field PCSTYPE you specify the 
electrical symbol(s) that represents the compo-
nent on diagrams in Automation.

In this datafield you type in the name of the file, 
in which the electrical symbol is saved. The 
program then searches for these files in the 
directory specified in Settings => Directories => Symbols. — Read more about 
this in “Directories” on page 911.

Components with more than one electrical symbol

If the component consists of several electrical symbols, you apply a semicolon to 
separate the symbols. If a component contains more symbols of the same kind, 
you can type in a number sign (#) followed by the number of symbols, immediately 
following the file name.

In the example above, 07-02-01#3 means that the component contains three elec-
trical symbols of the type 07-02-01. — If you need to create components with alter-
native electrical symbols for the functions of the component, please refer to 
“Specifying alternative electrical symbols via the database” on page 652.

THIS CHAPTER DESCRIBES

— ELECTRICAL SYMBOLS IN THE DATABASE ...................................................p. 651

— CONNECTION NAMES / PINDATA IN THE DATABASE ..................................p. 657

— ADDRESSING PLC SYMBOLS VIA THE DATABASE........................................p. 660

— MECHANICAL SYMBOLS IN THE DATABASE..................................................p. 662

OPTIONS FOR ELECTRICAL SYMBOLS IN THE DATABASE

— COMPONENTS WITH MORE THAN ONE ELECTRICAL SYMBOL ........................p. 651

— SPECIFYING THE SYMBOL TYPE.................................................................p. 652

— ALTERNATIVE ELECTRICAL SYMBOLS .........................................................p. 652

— SPECIFYING SYMBOL STATES ....................................................................p. 654

— ACTIVATING REFERENCES.........................................................................p. 655

— SUPPORT SYMBOLS IN THE PCSTYPE FIELD ............................................p. 656
mation

Page 651



P

Creating components in the database
When you are working on a Diagram page in Automation, enter the database, 
and select this component, you will get these electrical symbols to choose from 
under Available symbols in the lower-right corner of the screen:

Specifying the symbol type via the database

If you want to specify a different symbol type for a symbol than the one it was cre-
ated with — see “Saving the symbol” on page 770 — you can also do this in the 
symbol name in the PCSTYPE datafield. All you have to do, is to place a sign of 
equation and a letter following the symbol name.

Thus, if the symbol 07-01-03 should have a symbol type as for instance Main refer-
ence, you then write 07-01-03=M. — However, you cannot apply this facility on 
multi symbols — see “Creating a symbol as a Multi symbol” on page 779 — or for 
symbols using # to specify that the symbol is used several times for the compo-
nent.

Below you see which letters results in which symbol type.

SPECIFYING SYMBOL TYPE FOR TERMINALS WITH ADDITIONAL SYMBOL TYPE

When a terminal symbol shall be assigned more than one symbol type — such as 
Terminal and Relay or/and Terminal and Open — you specify it like this: 07-15-
01=T,R;07-02-01=T,O

— Read more about terminal symbols with more than one symbol type in “Creating 
terminal symbols with additional symbol types” on page 785.

Specifying alternative electrical symbols via the database

When you fetch a component via the database — for instance from the pickmenu 
— it is possible to specify alternative electrical symbols for the functions of the 
component.

If for instance a component has relay coil and two switch functions, the switch func-
tions can be used as both a switch, a make contact and a break contact.

LETTER SYMBOL TYPE LETTER SYMBOL TYPE

C CLOSE R RELAY

M MAIN REFERENCE S SWITCH

N NORMAL T TERMINAL

O OPEN W WITH REFERENCE

P PLC

The symbol 07-02-01.sym The symbol 07-02-03.sym
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When you get the pickmenu for a such component, it could appear like this under 
Available symbols in the lower-right corner of the screen:

When you fetch one of these alternative electrical symbols, the other alternative 
symbols for the function disappears. — Read more about alternative electrical 
symbols in “Alternative electrical symbols” on page 155.

SPECIFYING ALTERNATIVE SYMBOLS

When you specify that you can choose between more than one symbol for one of a 
components functions, you write the options for the function in square brackets 
with a vertical line between the options.

The fact that you can choose between the options 07-02-04, 07-02-01 and 07-02-
03 is therefore specified by writing [07-02-04|07-02-01|07-02-03]. When one of 
these symbols is selected, the other two disappears from the pickmenu for the 
component.

You can also specify repetitions of "or"-sections, by typing #n after the last square 
bracket in the section —where n represents the number of repetitions. In the figure 
above, the section [07-02-04|07-02-01|07-02-03] appears twice. That could there-
fore be specified like this: [07-02-04|07-02-01|07-02-03]#2

ALTERNATIVE SYMBOLS FOR PLCS

For PLCs you can thus choose whether to draw using one PLC module, or using 
single I/O symbols.

Alternative electrical symbols

Alternative electrical symbols

(1-2-3)

(1-2-3)
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In the figure above you can choose between one PLC symbol with eight inputs, or 
eight symbols with one input each.

If you choose one of the symbols with one input, the symbol with the eight inputs 
disappears from the pickmenu. Also, the eight other symbols disappear if you 
choose the symbol with the eight outputs.

ALTERNATIVE SYMBOLS AND PINDATA

When you have specified the alternative PCSTYPE´s, you specify their connection 
names in the PINDATA field — in the same order as the symbols are listed in the 
PCSTYPE field.

— Please note that you shall not mention anything about alternative PCSTYPEs in 
the PINDATA field.

FETCHING PINDATA DIRECTLY FROM THE SYMBOL DEFINITION

If pindata for a symbol is to be fetched directly from the symbol definition — and 
not from the database — just type a semicolon in the PINDATA field, and continue 
specifying pindata for the subsequent symbols. Thus, if for instance the first speci-
fied symbol under PCSTYPE should be assigned pindata from the symbol defini-
tion, simply let the contents of the PINDATA field start with a semicolon, and then 
specify the pindata for the remaining symbols.

Specifying symbol state for electrical symbols via the database

For electrical symbols created with states — see “Creating symbols with states” on 
page 777 — you can specify which state the symbol shall be in, when it is placed in 
the project. You specify this in the PINDATA field using the § character succeeded 
by the state number.

If the symbol XXXXX is to be placed in state 2, you therefore write XXXXX§2 in the 
PCSTYPE field.
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— See also “Symbols with states” on page 185 and “Symbols with states and the 
Component menu” on page 185.

Activating references on electrical symbols via the database

When you do not specify information about references for a symbol in the data-
base, the symbol references are activated/deactivated as specified in the symbols 
definition, when the symbol is placed in a project.

To control the activation/deactivation of references on a symbol via the database, 
the symbol filename in the PCSTYPE field must be followed by a *, followed by 
either N, W or M.

This has the following meaning:

The function has no effect on symbols, which through their symbol type already 
have references (e.g. Relay, Open, Close or WithReference), unless the symbol 
type have first been changed using the = function — see “Specifying symbol state 
for electrical symbols via the database” on page 654.

REFERENCE CONTROL COMBINED WITH OTHER OPTIONS

The control of the symbol references via the database, can be combined with the 
other parameters for controlling symbol properties via the database. Example:

06-05-04*N When the symbol is created with the reference, the reference is deacti-
vated.

06-05-04*W The reference will be activated, no matter what the symbol definition 
says.

06-05-04*M The reference will be activated and be set to master reference, no mat-
ter what the symbol definition says.

07-02-03=T,P§3*W The symbol gets the symbol type Terminal and PLC (=T,P), is 
set to state 3 (§3) and the reference is activated (*W).
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Support symbols in the PCSTYPE field
In the field PCSTYPE it is also possible to specify that there shall be placed one or 
more extra components along with the selected component — components which 
are not known prior to the moment of placing the component. So-called support 
symbols.

For a lamp this could be a blue, yellow or red glass, where you prior to the placing 
of the component do not know which color of the glass is needed — and, conse-
quently, which article number to apply.

If you specify a symbol of the type Support in the PCSTYPE field, this symbol will 
be displayed under Available symbols in the Component menu when you are 
working with the component, so that you will remember to place the support sym-
bol.

If the symbol is not of the type Support, it will be conceived as a part of the com-
ponent.

When placing the support symbol, you enter the dialog box Component data, 
from which you can specify name and other component data.

Please note that you can also specify additionals to components in the field ADDI-
TIONALS — as described in “Accessories in the database” on page 664. When 
you specify (sub)components here, these will be displayed as accessories in the 
Component menu under Symbols for component.

— Please also see “Creating Symbols” on page 761, particularly “Symbol types” 
on page 771.

SUPPORT SYMBOLS ARE BEING PHASED OUT - USE ACCESSORIES!

EVEN THOUGH YOU ARE ABLE TO USE SUPPORT SYMBOLS IN THE PROGRAM, 
THEY WILL BE PHASED OUT IN THE LONG RUN.

IN STEAD, WE RECOMMEND THAT YOU SPECIFY ACCESSORIES TO COMPO-

NENTS IN THE FIELD ACCESSORY — AS DESCRIBED IN “Accessories in 
the database” on page 664. IF YOU SPECIFY (SUB)COMPONENTS HERE, 
THESE WILL BE DISPLAYED AS ACCESSORIES IN THE COMPONENT MENU 
UNDER SYMBOLS FOR COMPONENT.

— ALSO SEE “Creating Symbols” on page 761, IN PARTICULAR “Symbol 
types” on page 771.
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Connection names/Pindata

What is connection names /pindata

When you create electrical symbols in 
Automation, you assign connection 
names to each of the connection points 
of the symbol. — See “Creating Symbols” 
on page 761.

In the database you have to specify 
which connection names the connection 
points have, when you place the symbol 
in a diagram.

You do that in the datafield PINDATA. 
Here you type in the connection names 
separated by a comma.

The connection point having the smallest 
number in the symbol definition, is 
assigned the first number on the list — 
and so on.

If the component contains several electri-
cal symbols, these are separated by a 
semicolon.

In the example above, where the first 
three symbols are of the same kind (07-
02-01#3), you have to type in the connec-
tion name for each of the three symbols, 
separated by a semicolon. — See the 
PINDATA datafield on page 651.

When you place the symbol on a dia-
gram, it will be assigned the connection 
names, you have specified in the data-
field PINDATA.

Connection names for single line symbols

Connection names for symbols for single line drawings are specified with a ’ sign 
around the list of connection names for a connection point.

CONNECTION NAMES / PINDATA IN THE DATABASE

— WHAT IS CONNECTION NAMES / PINDATA ...................................................p. 657

— CONNECTION NAMES FOR SINGLE LINE SYMBOLS .......................................p. 657

— SYMBOLS WITH VARIABLE CONNECTION NAMES..........................................p. 658

— CONNECTION NAMES IN FILES ...................................................................p. 658

— ALREADY DESIGNED SYMBOLS AND CONNECTION NAMES............................p. 658

— SPECIFYING I/O STATUS FOR CONNECTION POINTS VIA THE PINDATA FIELDp. 659

Connection name: 1

Connection name: 2

Names when designing a symbol

Names when the symbol is
placed using the database

Connection name (1)

Connection name (2)
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If for instance you write 1,2,3,4,5,6;’1,3,5’,’2,4,6’ this means that the first symbol 
has six connection points, while the other has two connection points with three 
names each.

Symbols with variable connection names

If you write ? or * in a connection name, an extra text field appears in the dialog box 
Component data, when you place the symbol. Here you can type in a variable 
part of the connection name, which is the same for all of the connection points for 
the symbol. This is for instance handy for make, break and switch symbols, where 
the position is not known prior to placing the symbol in the project.

— See “Connection names with variable part in the Symbol definition” on 
page 178, “Connection data with a variable part in the name” on page 766 and 
“Wildcards/jokers” on page 605.

Connection names in files

For symbols having many connections, such as PLCs, you can choose to place the 
pindata information in a separate file.

This file must be a text file, where you only have information on one component on 
each line.

If you write FILE= followed by the name of the file, the program will look for the file 
in the library you have specified under Settings => Directories => Database. 
Alternatively, you can type in the path leading to the file, along with the file name.

— See “Creating PLC components in the database” on page 668.

Already designed symbols and connection names

In the symbol libraries of Automation, all symbols are designed with invisible con-
nection names (pindata). To display in which order the connection names are spec-
ified, they are set to be visible on the figure below.

Type in the pindata

OR

Type in a filename

The contents of the

file 40MT-DSS.pin

Naming of connection names in Automation
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age 658



Creating components in the database

Auto
In the already designed symbols, the connection names start with the number one 
and is incremented following the reading direction.

When the symbols are selected using the Automation program, the connection 
names specified in the database, automatically become visible.

Specifying IO status for connection points via the PINDATA field

IO status for connection points can be specified via the PINDATA field in the data-
base. The status is inserted in square brackets — as for IO addresses on PLCs 
(see “Addressing PLC symbols via the database” on page 660).

Syntax for specifying IO status

IO status is specified by /I: followed by two characters. The following options 
exists:

/I:ET External terminal connection.

/I:IT Internal terminal connection.

/I:OP Output PLC connection.

/I:IP Input PLC connection.

/I:EI External terminal connection with PLC input.

/I:EO External terminal connection with PLC output.

/I:II Internal terminal connection with PLC input.

/I:IO Internal terminal connection with PLC output.

/I:N Sets IO status to None, None (deletes IO status)

EXAMPLE: TWO PLC SYMBOLS WITH ADDRESS AND IO STATUS SPECIFICATION:

PCSTYPE = PLCO1;PLCI1

PINDATA = 1[100.00/I:OP]; 1[100.01/I:IP]

EXAMPLE: AN OPEN SYMBOL WITH IO STATUS SPECIFICATION:

PCSTYPE = 07-02-01

PINDATA = 13[/I:ET],14[/I:IT]

Naming levels for multi-level terminals via the database

In the PINDATA field in the database you can for multi-level 
terminals specify a digit or a letter for the layer. If for instance 
you write *A;*B;*C, you can, when subsequently placing the 
first terminal symbol, specify a value for the asterisk, which is 
automatically transferred to the other symbols for the termi-
nal:

This way you can e.g. name the first multi-level terminal 1A, 1B and 1C respec-
tively, while the other multi-level terminal is named 2A, 2B and 2C respectively.

In the dialog box Symbol article data: Type in a level number
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Activating references from the database

References can be activated and deactivated via the database, so that these can 
be controlled independent from the symbol definition. You can control the refer-
ences by inserting /W:1 (active reference) or /W:0 (not active reference) in the 
parameter section for the connection points.

Example: 1[/W:1],2[10.00/W:1/I:OP],3[/W:0]

This means:

- Connection 1: Gets an Active reference

- Connection 2: Gets the function text 10.00 (see “Addressing PLC symbols via 
the PINDATA field” on page 660), I/O status set to Output PLC (see “Syntax for 
specifying IO status” on page 659) and an Active reference

- Connection 3: Gets a Not active reference

Addressing PLC symbols via the database

— Please also see “Connection names/Pindata” on page 657 and “Connection 
names in files” on page 658.

Addressing PLC symbols via the PINDATA field

PLC symbols can be addressed via the database. The address (the function text) 
is specified in square brackets [] after the connection name in the PINDATA field in 
the database.

Example: 1[1000.00],2[1000.01], ...

Enumerated names for symbols with one or more connection point

In the PINDATA field in the database, you can specify enumerated names for sym-
bols with one connection point.

Example: A1;..;A8;B1,..,B8

This specifies connection names for eight one-legged symbols with the connection 
names A1 - A8, and one symbol with eight connection points B1 - B8. (Symbols 
are separated by a semicolon, connection points by a comma).

OPTIONS FOR ADDRESSING PLC SYMBOLS IN THE DATABASE

— ADDRESSING PLC SYMBOLS VIA THE PINDATA FIELD...............................p. 660

— ENUMERATED NAMES FOR SYMBOLS WITH ONE OR MORE CONNECTION POINTp. 660

— ENUMERATED PLC ADDRESSES IN THE PINDATA FIELD ...........................p. 661

— COUNTING FUNCTIONS FOR PLC ADDRESSES IN THE PINDATA FIELD .......p. 661

— SPECIFYING A NUMBERING SYSTEM...........................................................p. 661

— INCREMENTING BY MORE THAN ONE ..........................................................p. 661

— FIXED NUMBER OF DIGITS ON COUNTING FIELD ..........................................p. 661
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Enumerated PLC addresses in the PINDATA field

The PINDATA field in the database can handle enumerated PLC addresses (func-
tion texts).

Example: A1[1000.00];..;A8;B1[2000.00];..;B8

The address in the example is automatically incremented from 1000.00 to 1000.07, 
and from 2000.00 to 2000.07 for the individual connection points.

Counting functions for PLC addresses in the PINDATA field

The PINDATA field can contain counting functions.

Example: 
1[1000.00],1G2,1V2,2[1000.01],2G2,2V2,3[1000.02],3G2,3V2,4[1000.03],4G2,4
V2

Can be written using the following notation:

{++(1)[++(1000.00)],++(1)G2,++(1)V2,}#4

Here the contents of the curled brackets is repeated four times ( {...}#4 ).

Please note that the character just before the last curled bracket ( } ) — in the 
example above a comma ( , ) — specifies whether the text inside the curled brack-
ets describes one or more symbols.

If this character is a comma ( , ), this means that the text contains a list of pindata 
for one single symbol.

If the character is a semicolon ( ; ), each repetition contains data for a new symbol.

Specifying a numbering system

Which system of notation / numbering system to count according to, can be speci-
fied after ++(. This is specified with the characters B, D, H or O — Binary, Deci-
mal, Hex or Octal, respectively. When no system of notation is specified, the 
decimal numbering system is used.

Example: {++(1)[++(O1000.00)],++(1)G2,++(1)V2,}#4

In the example above, the PLC is addressed according to the octal numbering sys-
tem, while the others are addressed according to the decimal numbering system.

Incrementing by more than one

When you wish to increment by more than one, this can be specified after ++. E.g. 
++2(1).

Example: {A++(0)[++2(00.00)],COM;B++(0)[++2(00.01)],COM;}#8

A0[00.00],COM;B0[00.01],COM; A1[00.02],COM;B1[00.03],COM; ...

When you wish to decrement, ++ is replaced by --. 

Fixed number of digits on counting field

When you want a fixed number of digits on a counting field, you must write : after 
the number, followed by a number between 1 and 9.

Example: {A++(0)[ 00.--2(07:2)],COM;B++(0)[00.--2(01:2)],COM;}#8
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Mechanical symbols in the database

You can also attach a mechanical symbol 

to a component. The name of the file in 
which the symbol is saved, should be 
placed in the database field MECTYPE — 
for instance PCSMV1.

Please note that you can also specify that 
other fields in the database contains 
mechanical symbols — see “Mechanical 
symbol” on page 675. Hereby you can 
have different mechanical symbols for the 
same component. The component can 
therefore be illustrated differently, on differ-
ent mechanical pages in the project.

It is therefore possible on one page to 
show an operating cabinet with the front 
closed, so that you only see the compo-
nents visible with the front closed. Another page could then show the bottom plate. 
You can therefore have database fields, each containing mechanical symbols for 
different purposes — for instance PNEUTYPE, FRONTTYPE and MECTYPE.

lige formål — f.eks. PNEUTYPE, FRONTTYPE og MEKTYPE.

Specifying multiple mechanical symbols for a component

If a component contains multiple mechanical symbols, these are specified sepa-
rated by a semicolon: PCSMV1;PCSMV5

When the component contains multiple mechanical symbols of the same type, this 
is specified by typing the symbol name followed by a # character, which again is 
followed by the number of mechanical symbols. To specify two symbols of the type 
PCSMV1, write this: PCSMV1#2

Specifying optional mechanical symbols

To specify that you can choose either PCSMV1 or PCSMV5, write this: 
[PCSMV1|PCSMV5]

Creating mechanical symbols directly from the MECTYPE field

When you want to program to automatically create a mechanical symbol of 30x50 
mm, write #x30mmy50mm in the field MECTYPE. If you write #r40mm, the pro-
gram creates a circle with a radius of 40mm as the mechanical symbol. These 
mechanical symbols has no connection points.

Specifying symbol state for mechanical symbols

For mechanical symbols created with states — see “Creating symbols with states” 
on page 777 — you can specify which state the symbol shall be in, when it is 
placed in the project. You specify this in the MECTYPE field using the § character 
succeeded by the state number.

If the symbol XXXXX is to be placed in state 2, you therefore write XXXXX§2 in the 
MECTYPE field.
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— Read more about mechanical symbols in “Placing mechanical symbols via the 
database” on page 696 and in “From Mechanical to Electrical drawing” on 
page 708.
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ACCESSORIES IN THE DATABASE

To connect accessories to a component in the database, you first have to create a 
record for each accessory component, and place these records in the relevant 
folder(s) in the database menu. These records must all contain an article number 
they can be identified by in the database — for instance in the EANNUMBER field.

Accessory types

It is possible to specify these types of accessories:

• Fixed accessories: Accessories attached to the "main component" without 
placing any electrical or mechanical symbols for the accessory in the project. 
When the main component is placed in the project, the fixed accessories for it 
is included in component and parts lists.
— See “Specifying that a component has fixed accessories” on page 664.

• Optional mechanical accessories: Can be fetched from the database when 
selected. When electrical symbols for the main component are placed on a 
Diagram page, the mechanical symbol for the accessory can be placed on 
Ground plan/Mechanical pages. Optional mechanical accessories are 
always included in component and parts lists.
— See “Optional accessories - Mechanical” on page 666.

• Optional electrical accessories: Can be fetched from the database when 
selected. The electrical symbol(s) are placed on Diagram pages in the pro-
ject. A mechanical symbol will typically also be attached to the accessory 
component. Optional electrical accessories are always included in component 
and parts lists.
— See “Optional accessories - Electrical” on page 667.

Specifying that a component has fixed accessories

In the Automation program: Under Settings => Database => Database setup => 
Component accessories in the field Fixed accessories you can specifywhich 
field in the attached database that contains fixed accessories. In normal installa-
tions of the software, the database field ACCESSORY is used for this purpose.

In the database: To specify, that a component has fixed accessory parts, you type 
in the article number in the ACCESSORY field for the component in the database. 
In case a component has more than one accessory part, their article numbers 
must be separated by a semicolon (;) in the ACCESSORY field.

SPECIFYING ACCESSORIES IN THE DATABASE

— ACCESSORY TYPES ..................................................................................p. 664

— SPECIFYING THAT A COMPONENT HAS FIXED ACCESSORIES ........................p. 664

— SPECIFYING THE CONTENTS OF THE ACCESSORY FIELD IN A FILE ...........p. 665

— UNIT PARTS LIST CAN BE SPECIFIED IN THE FIELD ACCESSORY...............p. 665

— OPTIONAL ACCESSORIES - MECHANICAL....................................................p. 666

— OPTIONAL ACCESSORIES - ELECTRICAL.....................................................p. 667
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If you need more than one of a specific 
fixed accessory part, you type # followed 
by the number needed, after the EAN-
NUMBER of the accessory part in the 
ACCESSORY field.

If you for instance need two of the accessory part 1234567890123, you type in 
1234567890123#2 in the ACCESSORY field.

In Automation you can specify whether to include the fixed accessories in your 
project lists. — Please refer to “Specifying from where to collect components” on 
page 598 for further details about this.

— See “Support symbols in the PCSTYPE field” on page 656 also.

Fixed accessories for cables

For cables the amount of fixed accessories can depend on two different parame-
ters:

 1) The cable length: Type in for instance CLIPS1234#5 to specify that 5 cable 
clips of the type CLIPS1234 are needed for each meter of cable.
(The length of the individual cables are specified in the Quantity field in the 
Cable data dialog box).

 2) The number of cables: Type in for instance CONNECTOR1234##2 to specify 
that 2 connectors of the type CONNECTOR1234 is to be included for each 
individual cable.

Thus you use a single # character when the accessory depends on the length, and 
two # characters when the accessory depends on the number of cables.

Specifying the contents of the ACCESSORY field in a file

As for connection names — see “Connection names/Pindata” on page 657 — you 
can specify the contents of the field ACCESSORY in a file. This is done by writing 
FILE= followed by the name of the file.

In this file one article number can be written on each line — such as:

3240900056666

5908326935039

1236374000001

There is no special requirements for the file name, but if you do not specify a path, 
the program searches for the file where the database catalog is pointing.

— Read more in “Connection names in files” on page 658.

Unit parts list can be specified in the field ACCESSORY

If you write UNIT= in the ACCESSORY field, this specifies that the article numbers 
in the ACCESSORY field is a unit parts list. This field therefore does not contain 
accessories to the components, but is a specification of what the component con-
sists of.

If for instance you write UNIT=112345566;504509345;123871312 this means that 
the component consists of the three listed article numbers.

Two of this part
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If you in the list setting for a parts list or a components list select Articles from 
Unit Lists and Drawings — see “Specifying from where to collect components” 
on page 598 — these three article numbers will be included in the list in stead of 
the specified article number for the component.

Typing in unit list information in the database, functions just as inserting a unit parts 
list in the project for the component. — Read more about this in “Inserting Unit Dra-
wings” on page 625.

If the list of article numbers is long, you can place the article numbers in a file, and 
write UNIT=FILE= followed by the name of the file.

The article numbers must be placed on separate lines — as described in “Specify-
ing the contents of the ACCESSORY field in a file” on page 665.

Optional accessories - Mechanical

Optional mechanical accessories are mechanical accessories for a component 
which can be fetched from the database when necessary. — This being for 
instance end plates and dividers for terminal rows.

When the electrical symbol for the main component is placed on a Diagram page, 
the optional mechanical symbol(s) for the accessories can subsequently be placed 
on Ground plan/Mechanical pages.

Optional mechanical accessories are always included in component and parts 
lists.

Until version 16, this type of mechanical accessories were specified using support 
symbols, which still is an option — even though it is not recommended. Read more 
about this in “Support symbols in the PCSTYPE field” on page 656.

— Please also see “Component accessories” on page 676, in particular “Optional 
accessories - Mechanical” on page 677. 

Add mechanical accessories

In “The Accessory tab” on page 180 you can see how to add mechanical accesso-
ries to a component directly from the active project.
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Optional accessories - Electrical

Optional electrical accessories are elec-
trical accessories for a component 
which can be fetched from the database 
when necessary. — This being for 
instance auxiliary contacts.

Optional electrical accessories appears 
in the Component menu under Sym-
bols for component when working on 
Diagram pages (electrical symbols) and 
when working on Ground plan/
Mechanical pages (mechanical sym-
bols).

When you have selected optional electri-
cal accessories for a component, the 
accessories are always included in elec-
trical and mechanical lists.

— Please also see “Component acces-
sories” on page 676, in particular “Opti-
onal accessories - Electrical” on 
page 677.

Add electrical accessories

To add electrical accessories to a component directly from the active project, right-
click a symbol for the component and choose Electrical accessory. You then 
enter the database, where you select the accessory.

SPECIFYING REF. LETTER FOR THE SYMBOL IN THE DATABASE

When you type in a letter in the field REFID, symbols for the component will be 
assigned a name starting with this letter, when placing the symbols in a project.

If for instance you write K, the letter K will be suggested as default reference letter 
when you place the symbol in a diagram.

However, to make this work you first have to choose Settings => Database => 
Database => Database setup => Component data, and there choose REFID in 
the field Reference letter. If the field has no contents in the database for the cho-
sen symbol, the reference letter (the symbol name) from the symbol definition is 
applied. — See “Creating Symbols” on page 761.

INSERT "-" IN FRONT OF SYMBOL NAMES AUTOMATICALLY

YOU CAN MAKE THE PROGRAM INSERT A MINUS IN FRONT OF ALL SYMBOLS 

BEING PLACED IN THE PROJECT, BY CHOOSING SETTINGS => POINTER/
SCREEN AND SELECT INSERT - IN FRONT OF SYMBOL NAMES. — SEE 

“Pointer/Screen” on page 906.
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SPECIFYING SYMBOL SUB NAMES FROM THE DATABASE

Automation can handle sub names on symbols intelligently, as described in “Sub 
names on symbols” on page 183. To specify sub names on symbols via the data-
base, write the following in the field PCSTYPE:

Hereby the component will contain the sub names F, Q1 and Q2.

Specifying pindata in the database for components with sub names

When you specify connection names / pindata in the database for components with 
sub names, you specify these in the order in which the symbols appears in the 
PCSTYPE field:

As you can see, the fact that sub names are being applied for the component, 
makes no difference for how to fill out the PINDATA field.

— See an example on this in the pickmenu:

CREATING PLC COMPONENTS IN THE DATABASE

To create a PLC component in the database, do this:

 1) Create the necessary PLC I/O symbols for the PLC, if you wish to use other 
PLC symbols than the ones already created in Automation. — See “Crea-
ting PLC I/O symbols” on page 790.

 2) Create PLC reference symbol(s) for the PLC, if you wish to use other PLC 
reference symbols than the ones already created in Automation. — See 
“Creating PLC reference symbols” on page 793.

Click on this symbol (with sub names)

... and you get this

pickmenu under

Sub names are shown here

Available symbols
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 3) Press [d] to enter the Database menu, where you click on the Pencil, to edit 
records.

 4) In the dialog box Edit Record: You can now either click the Insert button and 
create a new record with the PLC, or choose an existing PLC component in 
the database and update it. — See “Editing records in the database” on 
page 640.

 5) In the field PCSTYPE you now specify the PLC reference symbol(s) for the 
PLC, followed by its PLC I/O symbols. — See “Electrical symbols” on 
page 651, and e.g. “Alternative symbols for PLCs” on page 653.

 6) In the PINDATA field you now specify the connection names for the PLC ref-
erence symbol(s) followed by the connection names for the PLC I/O symbols 
— see “Connection names/Pindata” on page 657.
This information most likely becomes quite comprehensive, so you will have 
to place it in a file, as described in “Connection names in files” on page 658:

It is recommended to address the PLCs in the database as displayed in the 
example above. — See “Addressing PLC symbols via the database” on 
page 660.

 7) Add the remaining relevant data for the component — such as the EANnum-
ber — and click on Post and then on Close.

 8) The PLC component is now created/updated, and you return to the Data-
base menu.

— See also “Graphical creation of New Components in the Database” on 
page 647, “Information about the component in the database” on page 649 and 
“Electrical and Mechanical symbols for components” on page 651.

SIMPLE NOTATION FOR ADDRESSES IN PLCS

YOU DO NOT NEED TO APPLY THE COMPACT NOTATION DISPLAYED IN 

THE FIGURE ABOVE. YOU CAN JUST SPECIFY EACH INDIVIDUAL 

ADDRESS IN SQUARE BRACKETS AFTER THE CONNECTION POINTS. — 
SEE “Addressing PLC symbols via the PINDATA field” on 
page 660.
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DATABASE SETTINGS

This chapter deals with how the information from the attached database is repre-
sented in Automation.

The work with constructing the database itself, as well as the import of databases 
from component vendors, takes place in an independent database program.

This can either be the PCSCHEMATIC Database program, or any other open 
database program you use in conjunction with Automation — see “Choosing a 
database” on page 687.

If you are using the PCSCHEMATIC Database program, you can start it by choos-
ing Tools => Database in Automation. — Please refer to the PCSCHEMATIC 
Database manual for further details.

If you want to see how to fetch article data from components in the database, 
please read “Using the database” on page 629.

MAPPING OF THE DATAFIELDS IN THE DATABASE

When you are working with a database in Automation, you can determine which 
component information from the database will be displayed in Automation, and 
how the program shall interpret the information from the database.

To determine this you choose Settings => Database, and then click on Database 
setup.

You then enter the dialog box Database setup. Here you specify the settings you 
need, and click OK to accept the changes, or Cancel not to save the changes.

THIS CHAPTER DESCRIBES

— MAPPING OF THE DATAFIELDS IN THE DATABASE........................................p. 670

— TRANSFERRING ARTICLE DATA TO SYMBOLS AND LINES..............................p. 672

— COMPONENT ACCESSORIES ......................................................................p. 676

— CHOOSING PRODUCT/FABRICATE IN THE DATABASE ..................................p. 677

— APPROVED AND OBSOLETE COMPONENTS.................................................p. 679

— CHOOSING A DATABASE MENU..................................................................p. 681

— CHOOSING MENUS WHEN USING OTHER DATABASE PROGRAMS .................p. 683

— URL LINKS...............................................................................................p. 684

— COMPONENT GUIDE..................................................................................p. 685

— LINKS TO E.G. PDF FILES OR INTERNET ADDRESSES IN THE DATABASE ......p. 685
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The Field setup tab looks like this:

Which database fields are displayed in Automation

On the tab Field setup, the datafields in the Show fields column are the datafields 
from the database, which will be displayed in Automation.

Here they will be displayed under the name specified in the Field title column. Any 
name in this column can be changed if you click on the name, and type in a new 
field name.

The order in which the field names are listed in this dialog box, is also the order in 
which the fields are displayed in the database menu. If for instance you want Price 
to appear first on the list, just click on Price, and drag the field to above the first 
field in the list. This will make these fields exchange places. The fields in between 
the two fields will not change places.

In the Alignment column you determine whether the text is to be left-, right- or 
centre-adjusted. If you want to change the alignment, just click on the alignment 
field, and choose the desired alignment in the menu that pops up.

Adding or removing fields

Under Free fields to the left in the dialog box, you can see the fields in the data-
base, which are not being displayed in Automation at the present.

If for instance you want to display the field TAX, you click on the field and then click 
on the Transfer button.

To remove a field from the Show fields column, just click on the field, and then 
click on the Revert button.

To have all of the database fields displayed in Automation, you click on the Trans-
fer all button.
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Not to display any of the database fields, you click on the Revert all button. Please 
note that the datafields are not deleted, but transferred to the column of Free 
fields.

TRANSFERRING ARTICLE DATA TO SYMBOLS AND LINES

Click on the tab Component data in the upper part of the dialog box.

In order to transfer article data from the database to the symbols or lines in pro-
jects, it is important that you specify which fields in the database are transferred as 
Article, Type and Function article data to the symbols and lines in the projects.

This is specified in the fields Article, Type and Function on the Component data 
tab in the Component Database setup dialog box.

The database field mentioned in the Article field, will also become the permanent 
search field in the bottom of the Database menu on the tab Item no./Type/Desc..

— See an overview over the used field names in the database, which is installed 
with the Automation software in “Datafields in the component database” on 
page 956.

Alternative article number

In the field Alt. article you specify which field in the database will be used as arti-
cle number, if the datafield you have chosen as Article has no contents for a com-
ponent. This field is for instance useful when you start up using EAN numbers in 
stead of item numbers. If you set Article to EANNUMBER and Alt. Article to 
ITEMNUMBER, the symbols in the project will get the EAN number where a such 
exists. If no EAN number exists, they get an item number instead.
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Thus you make sure that a symbol always has got an article number, without hav-
ing to type in item numbers as EAN numbers in the database.

Replace article number with alternative article number

If you want to replace the article number with the alternative article number for all 
symbols in a project, choose Functions => Special Functions => Exchange 
Article with Alt. Article on all Symbols.

Description

When you select a field in the database to 
use as Description, the contents of this 
datafield will be displayed as pop-up infor-
mation, when you let the mouse rest over 
the symbol in diagrams and in pickmenus. 
The description is also displayed in the 
Information dialog box for the symbol.

You can for instance choose to map to the 
database field UKDESCRIPT (default setting) to have the English texts for the 
symbol displayed, or map to the database field DEDESCRIPT for German texts — 
or use the field DESCRIPT for another language.

You can also create your own database fields in other languages, and map to 
these.

Descriptions displayed in lists

This description can also be included in lists, when you insert the datafield Parts/
Components List => UKDESCRIPT. — Read more about this in “Creating Lists” 
on page 818.

Description displayed for symbols

The description can also be inserted as a datafield in the definition of a symbol, so 
that you can have the description text for the symbol displayed in different lan-

USE INDEXED FIELDS FOR ARTICLE NUMBER AND ALT. ARTICLE NUMBER

IN ORDER TO GET REASONABLE ACCESS TIMES FOR COMPONENTS IN THE 

DATABASE, IT IS RECOMMENDED ONLY TO USE INDEXED FIELDS FOR ARTI-

CLE AND ALT. ARTICLE.
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guages, depending on which database field you choose to map to. — See “Inser-
ting symbol datafields from database in symbol definition” on page 776.

Parts list prices

When you insert datafields of the type Parts list, you can then choose to insert the 
datafields Price 1 and Price 2.

In the lower-right corner of the dialog box, you specify which of the database fields 
that shall be used as Price 1 and Price 2.

If a discount factor have to be included for the two prices, this is specified in Dis-
count 1 and Discount 2 respectively.

Units/Pack

The quantity of the component. — See the options in the description of the QUAN-
TITY datafield in “Parts/components list datafields” on page 936.

Diagram symbol

In the Diagram symbol field you specify which datafield in the database that con-
tains the file name for the electrical symbol(s) for the component. This for instance 
makes it possible for the program to show you the electrical symbols for the com-
ponent, when you choose the component from the database, and wish to place the 
symbols on a Diagram page.

— See “Electrical symbols” on page 651.

To create electrical symbols directly from the database, you type in the dimensions 
of the symbols in the PCSTYPE field for the component. — Read more about the 
syntax in “Syntax for automatic generation of symbols” on page 220.

Single line symbol

In the field Single line symbol you specify which field in the database contains the 
single line symbol for the component. This symbol is used for automatic generation 
of single line diagrams.

Reference letter

Here you can specify which reference letter the symbol is assigned when it is 
placed in a project. If this field contains a letter, this letter will be applied. If the field 
has no contents, the symbol will be assigned the reference letter from the symbol 
definition. — See “Specifying Ref. Letter for the symbol in the Database” on 
page 667.

Pin names

Here you specify which field in the database to use to assign names to the connec-
tion points of the electrical symbols. — See “Connection names/Pindata” on 
page 657.
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Mechanical symbol

In the Mechanical sym. field you specify which field(s) in the database contains 
the file name of the mechanical symbol(s). These symbols displays the physical 
appearance of the component. This for instance makes it possible for the program 
to show you the mechanical symbol(s) for the component, when you choose the 
component from the database, and wish to place the symbols on a Ground plan/
Mechanical page.
— Read more about this in “Mechanical symbols in the database” on page 662 and 
“Placing mechanical symbols via the database” on page 696.

Creating mechanical symbols directly from the database

In order to create mechanical symbols directly from the database, type in the sym-
bol dimensions in the MECHTYPE field for the component. — See the syntax in 
“Syntax for automatic generation of symbols” on page 220.

Other symbols

In the Other symbols field you can 
specify whether any other fields in the 
database contains other symbol cate-
gories, that you need in your projects — 
a part from the electrical and mechani-
cal symbols.

When you have added these datafields 
in the Other symbols field, you subsequently have the option of placing these 
symbols on project pages.

Adding fields for Mechanical symbols

To add a field to the list of mechanical symbol fields, click the Plus button. You then 
enter the dialog box Other symbols, where you select the fields that contains the 
symbols of the desired symbol category in the attached database, and click OK.

Deleting fields for Mechanical symbols

To delete a field from the list of fields with other symbols, select the field in the list 
(see the figure), and click the Minus button.

Moving a field in the list of Mechanical symbols

To move a field with mechanical symbols, click on the field in the list, and then click 
the Up-arrow or the Down-arrow button.

Specifying that you want to apply "other symbols" on a page

When for instance you have added the datafield PNEUTYPE under Other sym-
bols, you can subsequently select this datafield for the active project page in the 
Page database field for symbols — see “The page database field for symbols” 
on page 257.

When you work on this project page and select a component from the database, 
the program then shows you the symbols specified in the PNEUTYPE datafield. 
Correspondingly the Component menu will only show symbols of the type PNEU-
TYPE, when you work on this project page.
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— You can read more about the Component menu in “The Component menu” on 
page 254.

Use DB-Cache

If the applied database is placed on a network, and you use the dBase database 
format, you can select Use DB-Cache, which makes the database work faster.

If you are not working on a network, this option makes no difference.

Save settings

Click OK to save the changes you have carried out. If you click Cancel, your 
changes will not be saved.

COMPONENT ACCESSORIES

In Settings => Database => Database setup => Component accessories you 
specify how the program understands ("maps") the fields in the database, which 
contains accessories.

There are three types of accessories:

• Fixed accessories

• Optional mechanical accessories

• Optional electrical accessories

Read more about these types of accessories in “Accessories in the database” on 
page 664 and “Accessory types” on page 664.
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Fixed accessories

A component can have specific additional parts attached to it, which also must be 
used each time the component is used, but not necessarily need to appear any-
where else than in the parts lists for the project. This could for instance be a base 
for a relay.

In the Fixed accessories field you specify which field in the database contains this 
accessory. — See “Datafield: ACCESSORY” on page 959.

If a mechanical symbol is defined for the accessory, you can place this mechanical 
symbol on mechanical pages in the project. However, whether you place the 
mechanical symbol for the accessory in the project, makes no difference for 
whether the accessory is included in the project lists. This is exclusively specified 
in the settings for the individual lists.

In “Specifying from where to collect components” on page 598 and in “Which data 
to include in the list” on page 598 you can see how to specify whether to include 
accessories in lists.

— Read more about fixed accessories in “Specifying that a component has fixed 
accessories” on page 664.

Optional accessories - Mechanical

Under Optional accessories in the field Mechanical you can specify which field in 
the database, that contains the article numbers which are presented as optional 
mechanical accessories in the dialog box Component data.

In the PCSCHEMATIC database the field OPT_ACCESSORY can be used for 
specifying optional accessories. — See “Datafield: OPT__ACCESSORY” on 
page 958.

— See “Optional accessories - Mechanical” on page 666 and “The Accessory tab” 
on page 180.

Optional accessories - Electrical

Under Optional accessories in the field Electrical you can specify which field in 
the database, that contains the article numbers which are presented as optional 
electrical accessories in the dialog box Component data.

In the PCSCHEMATIC database the field OPT_ADDON can be used for specifying 
optional electrical accessories. — See “Datafield: OPT_ADDON” on page 959.

PRODUCT CHOICE OR FABRICATE CHOICE IN THE DATABASE MENU

In the Database menu you can choose whether it shall be possible to show com-
ponents based on their fabricate — or the like.

To choose which of the database fields to let Automation sort after, do the follow-
ing:
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 1) Choose Settings => Database => Database setup:

 2) In the dialog box Database setup: Click on the tab Component search, 
click on the Down arrow in the Fabricate field, and choose which database 
field to divide by — for instance Manufactur. (Choose (None) in order not to 
use this Fabricate menu).

 3) Click OK to leave the dialog box Database setup, and click OK to leave the 
dialog box Settings.

— See how to apply this option in “Selecting a Fabricate / Vendor” on page 634.

Show only table menu items containing components of the
selected fabricate

When you wish the table menu in the right-hand corner of the Database menu 
only to display those table menu items, which contains components of the selected 
fabricate, do the following:

 1) Choose Settings => Database => Database setup => Component 
search.

 2) Select Show only tablemenu points containing the selected fabricates 
components.
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APPROVED AND OBSOLETE COMPONENTS IN THE DATABASE

In Automation it is possible to discern between approved and non-approved com-
ponents, as well as between obsolete and non-obsolete components.

Specify which database fields to use for Approved and/or Obso-
lete

To specify which of the fields in the selected database that Automation shall con-
ceive as Approved and Obsolete, do the following:

 1) Choose Settings => Database => Database setup.

 2) In the dialog box Database setup: Click on the tab Component search, and 
click on the Down arrow in the Approved and the Obsolete field, to choose 
which database field contains this information.

 3) Click OK to leave the dialog box Database setup, and click OK to leave the 
dialog box Settings.

Using non-boolean fields for Approved/Obsolete

In PCSCHEMATIC Database it is possible to create boolean datafields. Only 
when one of these boolean datafields is used as Approved/Obsolete, you will get 

APPROVED AND OBSOLETE FIELDS IN THE COMPONENT DATABASES

IN Automation TWO SPECIAL FIELDS EXISTS IN THE COMPONENT VENDOR DATABASES 

FOR THE PROGRAM: AN APPROVED FIELD AND AN OBSOLETE FIELD.

THE DATABASE FIELD APPROVED IS USED TO GET A BETTER SURVEY OF THE DATABASE, 
BY MAKING IT POSSIBLE ONLY TO SHOW THOSE OF THE COMPONENTS THAT YOU TYPI-

CALLY USE IN THE PROJECTS. — SEE “Display only Approved components and 
hide Obsolete components” on page 680.

THE DATABASE FIELD OBSOLETE IS USED TO MARK THE OBSOLETE COMPONENTS IN THE 

DATABASE. THIS MAKES IT POSSIBLE TO MAINTAIN OBSOLETE COMPONENTS IN THE DATA-

BASE, WITHOUT THE RISK OF USING THESE COMPONENTS WHEN CREATING NEW PRO-

JECTS.

Click here and choose the field

in the applied database
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the option to set a check mark for Approved and/or Obsolete in the Database 
menu in Automation.

If you choose a non-boolean field, you get the option to specify which values in the 
chosen datafield that identifies approved components.

These values must be separated by a semicolon (;).

In the component vendor databases for Automation, the fields Approved and 
Obsolete are created as boolean fields.

Displaying the fields Approved and Obsolete in the database
menu

To display the fields Approved and Obsolete in the Database menu, do this:

 1) Choose Settings => Database => Database setup.

 2) In the dialog box Database setup: Click on the tab Field setup.

 3) On the tab Field setup: Click on the fields Obsolete and Approved in the 
column Free fields and drag them over to the column Show fields:

Display only Approved components and hide Obsolete compo-
nents

When you have selected the approved components, you can set the Database 
menu to display approved components only. This makes it faster to locate the com-
ponents you typically use. When you need to fetch other components, you can set 
the Database menu to display all components again.

THE FIELDS APPROVED AND OBSOLETE DOES NOT NECESSARILY HAVE TO 

BE DISPLAYED IN THE DATABASE MENU.

Click on the fields and drag them over to the Visible fields
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When you wish to see approved components only, choose Show approved com-
ponents only in the Database menu.

Correspondingly, you can hide obsolete components by selecting Hide obsolete 
components in the Database menu.

Only display table menupoints containing Approved/Obsolete
components

When you want the tablemenu in the upper left-hand corner of the Database 
menu only to contain menupoints, which actually contains approved components, 
do the following:

 1) Choose Settings => Database setup => Component search.

 2) Select Show only tablemenu points containing approved components.

When you wish to do the same for obsolete components, select Show only table-
menu points containing not obsolete components.

Approving all article numbers in a project

To set all the applied article numbers in the active project to Approved in the data-
base, choose Functions => Special functions => Set all articles as approved 
in the database.

No editing of approved/obsolete components

If you will not allow editing of approved and/or obsolete components, do this:

 1) Choose Settings => Database settings => Component search.

 2) Select No editing of approved components and/or No editing of obso-
lete components.

— See the figure in “Only display table menupoints containing Approved/Obsolete 
components” on page 681.

CHOOSING A DATABASE MENU

A menu structure can be attached to the database, such as the component struc-
ture menu (FAFGE), in which you can group the database components according 
to their use. This makes it easier to locate the desired components.
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To do this, you click on the Database menu tab.

In the figure above, the menu DBmenu is attached to a database named Compo-
nents.

If you do not wish to have a menu attached, you click the No Menu button in the 
lower-right corner.

If you want to attach an existing menu, you click Open Menu. You then enter the 
dialog box Open, where you choose the desired database menu.

When you choose a database menu, which have been correctly created in 
PCSCHEMATIC Database, the fields Table link, Description, Menu index and 
Menu table will then be filled out correctly.

If you select Show only active menupoints, menu items are only displayed when 
they contain components.

The connection between the menu and the database

The field Table link contains a code, which separates the different groups in the 
menu. When the menu and the database exchange information, it takes place 
using this field.

The field Description contains the names of the groups in the menus.

The field Menu index contains information on how the individual groups are placed 
within the menu.

Name of the menu Name of the database

Under normal circumstances

the contents of these three fields

are not to be changed

Datafield in the database

containing a menu link
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To enable the database and the menu to communicate, there is also a datafield in 
the database, which contains a menu link. On the figure below this field is called 
TABLEGROUP.

If you have a component/record in the database, where it says 2210 in its 
TABLEGROUP field, this connects the component/record to the record, where it 
says 2210 in the Menu link field of the menu.

In the menu it says that the group Extra protection relays has got the menu link 
2210. Therefore the program knows, that the component mentioned belongs to the 
group Extra protection relays.

On the figure above, you can therefore see, that Component XX belongs to the 
group Extra protection relays.

For a more detailed explanation, please refer to the PCSCHEMATIC Database 
manual.

CHOOSING MENUS WHEN USING OTHER DATABASE PROGRAMS

If you are using another database program than PCSCHEMATIC Database, you 
will have an extra field on the Database menu tab.

When you click on the down-arrow in the Menu Table field, it is displayed which 
tables are available for the chosen database.

Here you specify which table in the other database program, that contains the 
menu structure.

DatabaseMenu

Component XX

EANno. 4012233029006

HPFI switch

Tablegroup:2210Table link: 2210

Description: Extra protection relays

Choose menu table in

another database program
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URL LINKS

On the tab URL links you can define a number of link aliases. The purpose of 
these are that you can specify an alias for a path to e.g. a component catalogue, 
which is placed as a pdf file somewhere on your PC or on the network you are 
attached to. This alias can then be used in the database, when you for instance 
wish to link to the catalogue for a specific component.

(The idea behind using an alias is explained in further detail in “The Alias concept” 
on page 912 — please note that the syntax is different for these two types of ali-
ases).

To edit, create or delete a File Link Alias, right-click in the dialog box, and choose 
either Edit, New or Remove.

Default File link aliases

The following file link aliases have already been created during the installation of 
Automation:

Using a File Link Alias

When you are using a File Link Alias in the field 
for a component in the database, you must place a % character before and after 
the name of the alias, as displayed in the figure above.

FILE LINK ALIAS USE

PIC FOR SPECIFYING THE PATH TO THE LOCATION OF PICTURES OF 

COMPONENTS IN THE DATABASE.

DOC FOR SPECIFYING THE PATH TO THE LOCATION OF DOCUMENTS, 
SUCH AS DATASHEETS IN THE DATABASE.

SUB FOR SPECIFYING THE PATH TO THE LOCATION OF SUBDRAWINGS IN 

THE DATABASE.
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Example for subdrawings

To specify the path to a subdrawing PCSMOTOR1.PRO placed in the Subdraw-
ings folder, you must write: %SUB%\PCSMOTOR1.PRO

You can see the path to the Subdrawings folder in the figure above.

Example for pictures

To specify the path to a picture Con01.jpg placed in the Pictures folder, you must 
write: %PIC%\Con01.jpg

You can see the path to the Pictures folder in the figure above.

File link aliases and other syntaxes

A File Link Alias can be applied in all links, unless you also use the syntax FILE=. 
(FILE= is for instance used for pindata / cable colors).

Please note: Windows environment variables can also be used in the database 
fields.

Create a Preferred Link field

At the top of the tab Link Alias, you can specify a Preferred Link field.

When you have selected a record in the Database menu, where some of the fields 
of this record contains links, and you then click the Open link button, the link in the 
field that you have specified as Preferred Link field will be opened. — Read more 
about this in “Open link for selected record in Database menu” on page 638.

COMPONENT WIZARD

On the tab Settings => Database => Database setup => Component Wizard 
you can specify which database fields you want to work with in the Component 
Wizard, which helps you to create components in the database easily.

The Component Wizard is activated by clicking the Component Wizard button in 
the program toolbar — or by choosing Functions => Component database => 
Component Wizard — and is described in an independent mini-manual, which 
you can download at www.pcschematic.com/manuals.

LINKS IN DATABASE FIELDS

Database fields can contain links to for instance PDF files, internet addresses or e-
mail addresses.

Automation will try to detect these links in the database by itself. If this does not 
succeed, you can write the full link by specifying the applied protocol, such as for 
instance:

- http://www.pcschematic.com/...

- ftp://ftp.pcschematic.com/public/my_file

- mailto:obl@company.com

File names will be recognised when they follow the syntax \\server\path\filename or 
x:\path\filename.
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When you are using a field in the database for this purpose, all of the contents of 
the field is conceived as the specification of the address. This meaning that you 
can not write comments or the like in the field.
Automation

age 686



Choosing a database

Automation

Page 687

CHOOSING A DATABASE

Automation supports Access databases directly. However, Automation is open 
for other database formats which are supported by either MDAC or ODBC.

Therefore you can also apply databases, which are created and maintained by 
other database programs. Thus you can apply MS-SQL, Oracle and most of the 
major database programs in conjunction with Automation.

CHOOSING A DATABASE

When you want to specify which database you want to attach to Automation, you 
choose Settings => Database => Select database file.

You then enter the dialog box Select database, where you click your way to the 
desired database, and click Open.

If you wish to use a database, which has not been created in Access, you must 
choose a so-called UDL file, by choosing Microsoft Data Link (*.udl).

CHOOSING THE TABLE IN THE DATABASE

When you have selected the database, you are asked to select the table in the 
database, which contains the component data. Select the table, click Next, and the 
database is attached to Automation.

— Read more about handling databases in the PCSCHEMATIC Database man-
ual.

ON UDL FILES

UDL IS SHORT FOR UNIVERSAL DATA LINK — ALSO CALLED MICROSOFT 

DATA LINK. THE UDL FILE CONFIGURES THE SETTINGS FOR HOW 

Automation CREATES THE CONNECTION TO ANOTHER DATABASE SYSTEM.

UDL FILES CAN BE CREATED FROM THE PCSCHEMATIC Database PRO-

GRAM.
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PROGRAMMABLE BARCODE SCANNERS

If you have a programmable barcode scanner, you can use it to collect symbols 
from the database.

When you have programmed the scanner properly, all you have to do is to scan in 
the barcode from the component vendor catalog. This gives you the symbol for the 
component directly into the cross hairs.

This requires, of course, that the component vendor have included the particular 
component in their database to Automation.

The reason why this is possible, is that there have been created short-cut keys to 
the search criteria in the Database menu.

Short-cut keys in the database menu

In the Database menu the following short-cuts have been created, for the search 
criteria tabs in the lower-right corner of the dialog box:

Programming the scanner

Exactly how the scanner should be programmed, depends on the applied scanner, 
as well as whether the scanner can send commands while scanning.

As an example, the scanner could be programmed like this: "d"Ctrl-a<EANNR>Alt-
o.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO USE A BARCODE SCANNER IN THE PROGRAM.

SHORT-CUT FIELD SHORT-CUT FIELD

<CTRL+A> ITEM NO <CTRL+1> 1.SEARCHKEY

<CTRL+T> TYPE <CTRL+2> 2.SEARCHKEY



In this section you can see how to work with 
mechanical symbols in PCSCHEMATIC Automation.

You can read about:

- Overview of options when working with
mechanical symbols ..........................................p. 691

- Arrangement drawings on
mechanical pages..............................................p. 693

- Place mechanical symbols, based on placed
electrical symbols, via the database ...............p. 696

- Place electrical symbols, based on placed
mechanical symbols, via the database ..........p. 708

- Measurement objects.........................................p. 710

GROUND PLAN PAGES

PAGES OF THE TYPE GROUND PLAN/MECHANICAL ARE 

APPLIED FOR MECHANICAL SYMBOLS, AND ARE ALSO 

USED FOR GROUND PLAN DRAWINGS. READ MORE 

ABOUT THIS IN “ELECTRICAL INSTALLATION DRAWING” ON 

PAGE 519.

Mechanical pages and symbols
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MECHANICAL SYMBOLS - OVERVIEW

In the following chapters you can read about:

- In “General arrangement drawings” on page 693 you can read more about how 
to create general arrangement drawings on mechanical pages in Automation.

- In “Placing mechanical symbols via the database” on page 696 you can see 
how Automation can automatically fetch the mechanical symbols, that are 
attached to those components, for which electrical symbols have already been 
placed in the diagram pages. You can also read about the easiest ways to posi-
tion mechanical symbols correctly.

- In “From Mechanical to Electrical drawing” on page 708 you can see how to 
start a project by creating a mechanical drawing, and then automatically fetch 
the electrical symbols, for the components that you placed the mechanical 
symbols for.

- In “Measurement objects” on page 710 you can see how to apply measurement 
objects on mechanical pages.

Beyond this, you have the following options when working with mechanical sym-
bols:

Creating mechanical symbols in the database

Read how to attach mechanical symbols to a component in the database in “Elec-
trical and Mechanical symbols for components” on page 651 and “Mechanical 
symbols in the database” on page 662.

See how to design your own symbols in "Creating Symbols" på side 761.

Creating mechanical symbols automatically

See how to create a mechanical symbol on the fly in “Automatic generation of sym-
bols” on page 217 and in “Electrical or Mechanical symbol” on page 219.

Displaying mechanical symbols on screen

When working with mechanical symbols, these are drawn with thin lines on the 
screen, which should increase the readability. If this is not the case on your moni-
tor, you can disable the setting under Settings => Special settings.

— See “Settings for the page type Ground plan / Mechanical” on page 928.

THIS CHAPTER DESCRIBES

HERE YOU GET A SURVEY OVER THE OPTIONS YOU HAVE WHEN WORKING WITH MECHANI-

CAL SYMBOLS IN AUTOMATION.
— IF NECESSARY, YOU CAN READ MORE ABOUT THE RELATIONSHIP BETWEEN COMPO-

NENTS, ELECTRICAL SYMBOLS AND MECHANICAL SYMBOLS IN “The relationship bet-
ween Symbols and Components” on page 251.
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3D/isometrical symbols

It is also possible to create 3D/isometric symbols, where all connection points are 
placed on the correct position with attached data.

These symbols can only be created using the Component Wizard, which is 
described in an independent manual, which is available under Help => Compo-
nent Wizard manual.

These symbols can be used together with the built-in Panelrouter, which for 
instance can generate wiring lists, from which you can have wire bundles / har-
nesses produced.

The Panelrouter is described in an independent manual.

You can see an example of a page containing this category of symbols in the demo 
project Pcsdemo2.pro, where you can open the first layout page, choose Settings 
=> Page setup, set the page type to ISOmetric and click OK:
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GENERAL ARRANGEMENT DRAWINGS

Basic information on general arrangement drawings

General arrangement drawings are created on pages of the type Ground plan/
Mechanical, and can for instance be used for creating a quick overview over 
whether there is room enough for placing the necessary components in a specific 
panel. — See how to create these pages and place symbols on them in“Placing 
mechanical symbols via the database” on page 696.

All objects that you place on these pages are dimensionally stable. You can put 
measures on mechanical pages using the measurement command, as described 
in “Measurement objects” on page 710.

You can also place conduits, and include the conduits in parts lists, if you have 

specified article data for the conduits.

In the following you will get some tips on how to create your general arrangement 
drawings appropriately:

1. Apply layers for different parts of the panel

In order to make it easier to make changes in the different parts of the panel, you 
can benefit from creating layers on the mechanical page, so that the mounting 
plate is on one layer, DIN rails on another, conduits on a third — and so on.

— Read more about layers in “Layers, Elevation and Scaling” on page 527.

THIS CHAPTER DESCRIBES

YOU CAN WORK WITH ARRANGEMENT DRAWINGS AT MANY LEVELS IN Automation — 

RIGHT FROM CREATING A QUICK OVERVIEW TO GENERATING PRECISE OUTPUT FOR WIRE 

ASSEMBLY MACHINES.

THIS CHAPTER GIVES ADVICE ON HOW TO ESTABLISH AN EFFECTIVE WORK FLOW FOR 

GENERATING ARRANGEMENT DRAWINGS ON MECHANICAL PAGES.

GET MORE INFORMATION IN THE PANELROUTER MANUAL

IN THE MANUAL FOR THE PANELROUTER YOU CAN SEE HOW TO CREATE A 

CLEAR AND UNAMBIGUOUS DOCUMENTATION, THAT SPECIFIES EXACTLY 

HOW TO MOUNT THE PANELS — SO THAT YOU ARE SURE THAT THERE ARE 

ENOUGH ROOM FOR THE WIRES IN THE CONDUITS, THAT INCOMPATIBLE 

WIRE CLASSES ARE NOT PLACED IN THE SAME CONDUITS E.T.C.

BASED ON THE CREATED DOCUMENTATION YOU CAN SUBSEQUENTLY GEN-

ERATE COMPLETE PRODUCTION LISTS CONTAINING AUTOMATICALLY CALCU-

LATED WIRE LENGTHS, WHICH CAN BE SENT DIRECTLY TO SELECTED WIRE 

PREFABRICATION MACHINES.
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2. Create template pages matching the module measures of the

panels

When you are working with commonly used panel types, you can benefit from cre-
ating template pages, where the settings in Page setup for snap and grid match 
the module measures of the panels.

Also select Follow page scale, so that the specified grid will match the applied 
measures on the page. — See “Setting the scale of the page” on page 533.

— Read more about snap and grid in “Snap” on page 47 and “Grid” on page 48.

— Read more about creating page templates in “Creating Templates” on page 837.

3. Module based symbols in general arrangement drawings

You can also create mechanical symbols, that fits the measures of the modules. If 
the measure of the modules are for instance 18mm, you can design the mechani-
cal symbols, so that they fit module measures of 18mm — namely 18mm, 36mm, 
54mm e.t.c.

You can also create symbols for DIN rails, where the distance between the rails is 
fixed and match the module measures of the panels. Here you can for instance 
create a symbol with states, where each state contains one, two or three rows of 
rails.

In order to make this work, it is crucial to place the reference points for the symbols 
consequently in the same corner of the modules.

The small panel to the left in the figure below is pieced together by symbols for 
socket, door, DIN rails, sides — left and right — and top.

It is important that the sizes of all the mechanical symbols fits the module meas-
ures of the page, which again fits the module measures of the applied panel type. It 
is equally important that the corners are positioned identically — so that the refer-
ence points are placed on identical positions, which makes the individual parts fit 
like legos.

— See how to create symbols with states in “Creating symbols with states” on 
page 777.

4. Easy positioning in DIN rails and in specified cut-outs

In order to make the first symbol in a DIN rail "snap" to the rail, you need to create 
the rail as a rectangle drawn using the color NP.

— Read more in “Quick placing in a DIN-rail or in a specified cut-out” on page 703.

Panel put together
by modules

Socket Door DIN rails Sides Top
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5. Apply the Mechanical load function

When you place multiple components / mechanical symbols on a mechanical 
page, they are frequently placed next to each other. When you use the function 
Mechanical load, this will happen automatically.

— See “Placing mechanical symbols via the database” on page 696, especially 
“Placing mechanical symbols using Mechanical load” on page 698.

When you place the mechanical symbols via the Component menu, you have to 
make sure that the components are placed next to each other. Here it can help to 
apply the Magnetical snap function.

— See “Magnetic snap and Snap in objects for mechanical symbols” on page 703.

6. Place terminals quickly

If you want to be able to fetch an entire terminal row from the Component menu, 
so that you can subsequently place them in correct order, this requires that the ter-
minals are component grouped correctly based on the article number — for 
instance that double terminals have two layers.

This is most easily handled using the Show terminal row function, which is in the 
right-click menu for terminals on diagram pages. — Read more about this in 
“Graphical managing of component grouping for terminals” on page 620.

— Read more about component grouping in “Component Grouping” on page 613.

7. Moving areas with a new anchor point

When you move objects using the Area command, you can right-click inside the 
selected area to specify a new anchor point for the moved area, which makes it 
easier to place it correctly in relation to the other objects on the page.

— Read more in “Reference points when selected areas are moved/copied” on 
page 271.

8. Importing DWG/DXF files

Creating a mechanical page / general arrangement drawing can also be done by 
importing a DWG/DXF file.

This could for instance be relevant when you apply one of the various tools, where 
you start by generating the mounting plate, with the intention of being able to drill 
holes e.t.c. for the final production.

— Get more information in “DWG and DXF files” on page 729.

9. Exporting to DWG/DXF

When the mounting plate is ready, it can be exported as a DWG/DXF file. Here it is 
possible to export one layer per drawing. Thus you can place mounting holes on 
specific layers, which can be exported to the DWG/DXF file, which can then be 
used for the final production.

— Get more information in “DWG and DXF files” on page 729.
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PLACING MECHANICAL SYMBOLS VIA THE DATA-

BASE

When you have a database connected to Automation, it is possible to perform a 
so called mechanical load, which gives you the mechanical symbols you need to 
make a mechanical drawing, displaying how the components appear in real life.

You can also place mechanical symbols individually using the Component menu.

— Read more about the relation between components, electrical symbols and 
mechanical symbols in “The relationship between Symbols and Components” on 
page 251.

— Read more about how the database works in “Using the database” on 
page 629.

INSERTING A PAGE FOR A MECHANICAL DRAWING

To generate a mechanical drawing, you first have to insert a page of the type 
Ground plan/Mechanical, on which to place the drawing:

 1) Enter the Page Menu, click on Add new and click OK to insert a Normal 
page.

 2) In the dialog box New: Click on the template DPSA3MECH and click OK.

 3) In the Page menu: Click OK.

THIS CHAPTER DESCRIBES

— INSERTING A PAGE FOR A MECHANICAL DRAWING.......................................p. 696

— PLACING MECHANICAL SYMBOLS USING THE COMPONENT MENU.................p. 697

— PLACING MECHANICAL SYMBOLS USING MECHANICAL LOAD........................p. 698

— PLACING MECHANICAL SYMBOLS ACC. TO REFERENCE DESIGNATIONS.........p. 701

— PLACING MECHANICAL SYMBOLS AS BOXES................................................p. 701

— PLACE ONLY MECHANICAL SYMBOLS NOT PLACED ON OTHER PAGES...........p. 701

— UPDATE ALL SYMBOLS FROM THE DATABASE .............................................p. 702

— MESSAGES AND WARNINGS DURING MECHANICAL LOAD.............................p. 702

— SELECTING UNKNOWN MECHANICAL SYMBOLS ...........................................p. 702

— DISPLAYING CONNECTIONS FOR MECHANICAL SYMBOLS.............................p. 703

— MAGNETIC SNAP AND SNAP IN OBJECTS FOR MECHANICAL SYMBOLS ..........p. 703

— REFERENCES IN LISTS TO THE LOCATION OF A MECHANICAL SYMBOL ........p. 705

— REFERENCES FROM MECHANICAL TO ELECTRICAL SYMBOLS......................p. 706

— MEASUREMENT OBJECTS..........................................................................p. 706

— DRAW ORDER ..........................................................................................p. 707
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PLACING MECHANICAL SYMBOLS VIA THE COMPONENT MENU

When you are working on a page of the type Ground plan/Mechanical, you can 
place mechanical symbols on the page, and hereby for instance create general 
arrangement drawings, which you can read more about in “General arrangement 
drawings” on page 693.

You can place mechanical symbols on mechanical pages using the Component 
menu. In the following the special options for working with mechanical symbols in 
the Component menu are described. For more general information about the 
Component menu, please refer to “The Component menu” on page 254.

You can also place multiple mechanical symbols in a single operation, which is 
described in “Placing mechanical symbols using Mechanical load” on page 698.

Placing terminal rows on mechanical pages

When working with terminals in the Component menu on a mechanical page, you 
can place a full terminal row like this:

 1) Right-click on one of the terminal components in the upper part of the Com-
ponent menu and choose Select component. (Or: Double-click on one of 
the components).

 2) Under Available symbols: Right-click on one of the symbols and choose 
Place all.

 3) You now get the full terminal row in the cross hairs: Click where you want to 
place the terminal row on the page.

Placing mechanical symbols for electrical accessories

When an electrical accessory for a component is selected, the list in the upper part 
of the Component menu contains an extra line with the same component name — 
for the mechanical symbol for the electrical accessory.

Here you can also choose Select component and then Place all.
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Placing mechanical accessories

Fixed mechanical accessories are also displayed as mechanical symbols, which 
can be placed from the Component menu on mechanical pages.

Optional mechanical accessories can also be placed from the Component menu.

— Read more about fixed mechanical accessories in “Accessories in the data-
base” on page 664, especially “Specifying that a component has fixed acces-
sories” on page 664.

— Read more about optional mechanical accessories in “Optional accessories - 
Mechanical” on page 666.

PLACING MECHANICAL SYMBOLS USING MECHANICAL LOAD

You can place multiple mechanical symbols in a single operation by Mechanical 
load. This function fetches the mechanical symbols for the components with elec-
trical symbols placed in the project. The mechanical symbols are loaded automati-
cally from the database, in which the electrical symbols, through their EAN13 
number/article numbers, are connected to the mechanical symbols.

Click the Symbols button, and choose Functions => Mechanical load, or right-
click on the project page and choose Mechanical load.

Specify which symbols to place

In the appearing menu you click on Load selected, type in *-Q* and click on OK. 
You will now load all mechanical symbols, attached to the components in the dia-
gram, containing the text -Q. — Read more about how to select the symbols in 
“Wildcards/jokers” on page 605.

SELECT INCLUDE IN MECHANICAL LOAD

MECHANICAL SYMBOLS ARE ONLY PLACED FOR COMPONENTS HAVING 

INCLUDE IN MECHANICAL LOAD SELECTED IN THE DIALOG BOX COMPONENT 
DATA.

— SEE “Include in Mechanical Load” on page 177.

Specify which type of

mechanical symbols

you wish to place
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Specify which Type of mechanical symbols to place

Please note: This is only relevant it your database contains different types of 
mechanical symbols — see “Mechanical symbol” on page 675.

In the field Database symbol field, you can further specify which type of mechan-
ical symbols you wish to place on the page. Please note that you can only place 
one type of mechanical symbols on a project page. When you specify a Database 
symbol field here, the Database symbol field is automatically changed under 
Settings => Page setup — see “Other symbols” on page 675.

Place the mechanical symbols on the page

When you click OK in the dialog box Mechanical load, the mechanical symbols 
are placed directly on the page. You have two options for how to do this, depending 
on whether you choose Space symbols and align:

1 Space symbols and align

If you select Space symbols and align, you first get a 
pencil in the cross hairs, and then click on the position on the page, where you 
wish to place the first symbol. Then click where you wish to place the last symbol. 
Please note that the symbols will either be placed on a vertical or a horizontal line. 
If there is not enough space for the symbols within the specified area, you get a 
message telling you to point out a new starting position for the remaining symbols.

2 Place the symbols in a pile

If you do not choose Space symbols and align, you get 
a pencil in the cross hairs, and then click somewhere on the page.

The mechanical symbols are then placed in a pile.

REARRANGING THE MECHANICAL SYMBOLS

For a more appropriate arranging of the symbols, mark up a window surrounding 
the symbols.

Then choose Edit => Space. Now click where the first mechanical symbol shall be 
located. In the menu that appears you select Align as well as Sort by name.
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Click OK.

Now click so that you only draw a horizontal line, which is shorter than the width of 
a single mechanical symbol. Hereby the mechanical symbols will be placed end to 
end.

By rearranging the symbols, you can then create your own switchboard.

Function texts are also transferred during mechanical load

The function text for the components is also transferred to the mechanical symbols 
during mechanical load.

Convert to boxes / Convert to mechanical symbols

At the bottom of the Symbols for component window there is a button which 
gives you the option to toggle between Convert to boxes and Convert to 
mechanical symbols. This means that you can change how mechanical symbols 
are represented on the page after they are placed on the project page:

MAGNETIC MECHANICAL SYMBOLS

WHEN YOU MOVE A MECHANICAL SYMBOL, IT CAN BE DIFFICULT TO POSI-

TION IT, SO THAT IT IS PLACED EXACTLY SIDE BY SIDE WITH ANOTHER 

MECHANICAL SYMBOL.

THEREFORE, IF YOU ACTIVATE THE MECHANICAL SNAP BUTTON BEFORE 

POSITIONING THE SYMBOL, THE SYMBOL MAGNETICALLY CLINGS TO THE 

SYMBOL, THAT YOU WANT TO PLACE IT NEXT TO. READ MORE ABOUT THIS 

AS WELL AS OTHER OPTIONS IN “Magnetic snap and Snap in objects for 
mechanical symbols” on page 703.
Automation

age 700



Placing mechanical symbols via the database

Auto
PLACING MECHANICAL SYMBOLS ACC. TO REFERENCE DESIGNATION

When you select Functions => Mechanical Load and click the Used names but-
ton, you enter the dialog box Select name, where you can select which reference 
designation to place mechanical symbols for:

PLACING MECHANICAL SYMBOLS AS BOXES

If you do not wish to use the mechanical symbols included in the component data-
bases for Automation, select Place symbol as boxes in the dialog box Mechani-
cal load.

Hereby the mechanical symbols are placed as boxes with connection points. The 
boxes gets the same measures as the mechanical symbols in the databases. If 
measures has been specified in the database, these measures are applied. Con-
nection points are only placed if these are specified in the database.

— See “Placing mechanical symbols using Mechanical load” on page 698.

PLACE ONLY MECHANICAL SYMBOLS NOT USED ON OTHER PAGES

If you in select Place only symbols not used on other mechanical pages in the 
dialog box Mechanical Load, Automation will only place mechanical symbols, 
that do not appear on other mechanical pages in the project.
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UPDATE ALL SYMBOLS FROM THE DATABASE

This is how to update all mechanical symbols on a project page, so that they match 
the definitions for the mechanical symbols in the database:

 1) Select the project page where the mechanical symbols are placed and 
choose Functions => Mechanical load

 2) In the dialog box Mechanical load: Select Update all symbols from the 
component database and click OK.

MESSAGES AND WARNINGS DURING MECHANICAL LOAD

If something unexpected happens during the mechanical load, you will get mes-
sages and warnings displayed in a window.

The cause can here be:

 1) An article number have not been typed in for the electrical symbol in the pro-
ject

 2) The component does not have an attached mechanical symbol

 3) The mechanical symbol have been removed from the hard disk

This should make it easier to make corrections succeedingly.

SELECT UNKNOWN MECHANICAL SYMBOLS

When electrical symbols are deleted in a project, this might result in mechanical 
pages containing mechanical symbols for components no longer applied in the 
project. To select these mechanical symbols, you can right-click on a mechanical 
page and select Select unknown Components:

Hereby the window Select unknown components is displayed, and all mechani-
cal symbols, for which no electrical symbols exists, are selected on the page.
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You can now delete the selected symbols, or for instance copy them to another 
page. The window Select unknown components functions like the Select name 
and the Select components windows, as described in “Finding symbols based on 
the Component Name” on page 264.

DISPLAYING CONNECTIONS FOR MECHANICAL SYMBOLS

When you move a mechanical symbol on a 
Groundplan page, it is displayed which of the 
other mechanical symbols are connected to the 
symbol — according to the information about 
the electrical connections on the electrical dia-
gram pages. This makes it easier to find the 
optimal position for the mechanical symbol.

You get the same result when you right-click on 
a mechanical symbol and choose Mark net.

The function can be activated/deactivated by 
choosing Settings => Pointer/Screen and then 
click on Net router.

MAGNETIC SNAP AND SNAP IN OBJECTS FOR MECHANICAL SYMBOLS

When you wish to place mechanical symbols accurately relative to each other, you 
can either use "Magnetic snap" or "Snap in objects".

Magnetic snap

When you wish to place a mechanical symbol, so that it is placed exactly side-by-
side with an already placed mechanical symbol, just activate the Magnetic snap 
button (short-cut key <m>), when placing the symbol. The mechanical symbol will 
then be placed precisely side-by-side with the placed symbol — with either the left 
side, the right side, the top or the bottom of the already placed symbol.

QUICK PLACING IN A DIN-RAIL OR IN A SPECIFIED CUT-OUT

When you wish to easily place a mechanical symbol in a panel on a DIN-rail or in a 
pre-specified cut-out, just activate the Magnetic snap button and keep the <Shift> 
key pressed down when placing the mechanical symbol. This places the symbol 
precisely in the right side or in the left side of the rail or cabinet.

For symbols without states, this requires that the area for placing components / 
mechanical symbols are drawn with the colour NP in layer 0 or in layer 255. For 
symbols with states, this area must be drawn with the colour NP in each individual 
state. If you wish to see the specified area on print also, you must also draw the 
area with a "normal" colour. To see the specified area, you must also make sure 
that the area drawn with the "normal" colour is placed on top of the NP colour. To 
do this, right-click and choose Draw order => Bring to front, as described in 
“Draw order” on page 707.

— See more tips for working with general arrangement drawings in "General 
arrangement drawings" på side 693.
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Snap in objects

In stead of Magnetic snap, you can activate the Snap in objects button, which 
gives you the option of "snapping" based on several points on both the object you 
are placing, and on the object you are placing the object next to. (The "objects" are 
here mechanical symbols).

You can for instance snap to all object corners, and to the middle of all sides of the 
objects.

When the function is activated, and the cross hairs is above a possible snapping 
point, a small "o" is displayed in the cross hairs:

 1) Activate the Snap in objects button, and click the mechanical symbol, that 
you wish to move. Now place the cross hairs above the point you wish to 
snap from. When the small "o" is displayed in the cross hairs (see the middle 
of the left side for the symbol in figure 1 below), press the left mouse button, 
and keep it pressed down.

 2) Now drag the mechanical symbol over to the mechanical symbol, that you 
wish to place it next to. When the small "o" is displayed in the cross hairs over 
the point in the other symbol that you wish to snap to (the middle of the right 
side of the symbol in image 2 below), release the mouse button.

 3) The mechanical symbol is now positioned precisely in relation to the other 
mechanical symbol.

You can also use Snap in objects, when you have selected multiple symbols.

1 2 3
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REFERENCES IN LISTS TO THE POSITION OF MECHANICAL SYMBOLS

If a reference system have been placed on a project page containing mechanical 
symbols, it is also possible to refer to the position of the symbols on the page 
according to the reference system.

Placing the reference system

The reference system is placed on 
the page by choosing Settings => 
Page data => Reference, as 
described in the Automation man-
ual. Here the reference system can 
be activated vertically and horizon-
tally at the same time.

Please note, that the reference cho-
sen to be Main reference is men-
tioned first in the datafield.

Inserting the datafield

To refer to the position of the 
mechanical symbols, choose Insert 
=> Insert Datafield, as explained in 
“Datafields” on page 116. Here you click on Parts/Components list, and choose 
the datafield Mechanical position.

Here you can choose between x,y position, which gives the components coordi-
nates in relation to the origo of the page, and Field position, which gives the coor-
dinates in relation to the reference system.

In the components list for the project, you can therefore specify where in the 
switchboard the components are placed.

— Read more about how to create lists in “Creating Lists” on page 818.
mation

Page 705



P

Placing mechanical symbols via the database
REFERENCES FROM MECHANICAL TO ELECTRICAL SYMBOLS

By default no references are displayed from mechanical symbols on the Ground-
plan/Mechanical pages, to the electrical symbols on the Diagram pages.

When you wish to create a reference from a mechanical symbol to one of the elec-
trical symbols for the component, do this:

 1) Click on the Symbols button, right-click on the symbol, and choose Compo-
nent data — or double-click on the symbol.

 2) In the dialog box Component data: Click on the tab Reference, select With 
reference and then With reference (in the right-hand side), and click OK.

You have now created a reference from the mechanical symbol. When you have 
selected Symbols and double-click on the reference for the mechanical symbol, 
you jump to the electrical symbol for the component, which is set to Main refer-
ence. If none of the electrical symbols for the component is set to this, you jump to 
the first found symbol for the component, which exists on a diagram page in pro-
ject.

MEASUREMENT OBJECTS

Read about measurement objects in “Measurement objects” on page 710.

MECHANICAL SYMBOLS MUST HAVE A SIMPLE REFERENCE TYPE

THIS ONLY APPLIES FOR MECHANICAL SYMBOLS WITH A SIMPLE REFERENCE 

TYPE. SYMBOLS WITH RELAY OR MASTER REFERENCE MUST THEREFORE 

BE SET TO NORMAL — OR TO ANOTHER SYMBOL TYPE WITH SIMPLE REFER-

ENCES — TO MAKE IT WORK.
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DRAW ORDER

The draw order specifies which objects are in the front, and which objects are in 
the back on the drawing, in case of overlapping objects.

The draw order is fixed for the different object types, but within the same object 
type — e.g. for symbols —, it is possible to change the draw order, as described 
below.

The draw order is specially important on pages with mechanical drawings.

Draw order for different object types

When placing objects on a page, the objects will be drawn in the following draw 
order. (Please note that the objects at the bottom of the list will be placed at the top 
of the project drawing):

 1) Drawing headers and current path numbers

 2) Images and OLE objects

 3) Datafield placed on the page with images

 4) Lines

 5) Circles

 6) Free texts

 7) Datafields placed on the page with text

 8) Symbols

As you can see in the list, symbols are placed in the front, and they will therefore 
cover any other object type they might be overlapping.

Draw order for objects of the same type

To specify the draw order for objects of the same type — as for the mechanical 
symbol in the figure to the right — you must right-click on the object, and choose 
Draw order.

You can then choose:

- Bring to front: Place the object in front of all other overlapping objects of the 
same type.

- Send to back: Place the object behind all other overlapping objects of the same 
type.

- Step forward: Moves the object one position forwards, among to the overlap-
ping objects.

- Step backward: Moves the object one position backwards, among to the over-
lapping objects.
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From Mechanical to Electrical drawing
FROM MECHANICAL TO ELECTRICAL DRAWING

When you choose to start a project by creating a mechanical drawing, you can do 
this by for instance placing the mechanical symbols for a motor control, such as 
fuses, motor starters and contactors.

When working with an attached database in Automation, the program can auto-
matically fetch the electrical symbols, that are attached to those components, for 
which their mechanical symbols have been placed on the mechanical pages.

The electrical symbols can then subsequently be placed in the diagram pages in 
the project.

Do for instance like this:

Creating a new project with a diagram page and a mechanical page

 1) Choose File => New or click the New document button.

 2) In the dialog box New: Select the template PCSstart and click OK. — You 
have now chosen a project containing a single page for drawing diagrams.

 3) In the dialog box Settings: Click OK.

Placing a mechanical symbol on a Ground plan / Mechanical page

 4) Click on the page tab for page 10, to select a mechanical page.

 5) While being on the mechanical page: Press <d> to enter the database.

OTHER OPTIONS

ALSO SEE “Placing mechanical symbols via the Component menu” on 
page 697.
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 6) Select a mechanical symbol: For instance write PCSCON-AUX in the field 
Type contains, choose the contactor with the type PCSCON-AUX07, and 
click OK.

 7) You now get the mechanical symbol for the component in the cross hairs: 
Click somewhere on the mechanical page to place the symbol, click OK in 
the dialog box Component data and press <Esc> to remove the symbol 
from the cross hairs.

 8) If necessary, place more mechanical symbols on the page.

Fetch symbols automatically on the diagram page

 9) Shift to the diagram page by clicking on the tab 5 at the bottom of the screen.

 10) On the diagram page: In the upper part of the Component menu you can 
now select which component to place electrical symbols for.

 11) The electrical symbols for the component are now displayed under Availa-
ble symbols at the bottom of the Component menu, and you can now 
place these symbols as you normally do.

DISPLAY SYMBOLS NOT YET PLACED IN DIAGRAMS

WHEN YOU HAVE PLACED THE MECHANICAL 

SYMBOLS BEFORE THE ELECTRICAL SYM-

BOLS, AND CLICK ON THE SHOW PARTLY-
PLACED BUTTON IN THE COMPONENTS WIN-

DOW, YOU GET A LIST OF ALL THE SYMBOLS, 
YOU HAVE NOT PLACED IN THE DIAGRAM 

PAGES YET.

IN THIS CONNECTION THE BUTTON IS A HELP 

TO REMEMBER TO DRAW ALL THE CIRCUITS.
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MEASUREMENT OBJECTS

Inserting measurement objects

To place measurement objects, which can 
place and calculate measurements 
between two points, choose Functions 
=> Measurement.

The starting point for the measure-
ment object

You now get a pencil in the cross hairs, 
which tells you, that you can now point out 
the starting point of the measurement 
object.

If you want to start the measurement from 
a symbol — e.g. from the symbol refer-
ence point or from a corner point on the 
symbol —, the program automatically 
examines the symbol definition, and finds 
the exact coordinates from this point.

If filled lines are applied, you can both 
measure from the centre of the lines, and 
from the edges of the lines.

Circles can furthermore be measured at 
intervals of 90 degrees — see the figure 
to the right.

THIS CHAPTER DESCRIBES

— INSERTING MEASUREMENT OBJECTS..........................................................p. 710

— FREE MEASUREMENT................................................................................p. 712

— ROTATING MEASUREMENT OBJECTS ..........................................................p. 713

— EDITING THE MEASUREMENT START AND END POINTS................................p. 713

— EDITING MEASUREMENT DATA ...................................................................p. 714

— MEASUREMENT OBJECTS AND LAYERS ......................................................p. 714

— DELETING MEASUREMENT OBJECTS...........................................................p. 714

MEASUREMENT ON GROUND PLAN/MECHANICAL AND DIAGRAM PAGES

YOU CAN INSERT MEASUREMENT OBJECTS ON PAGES WITH PAGE TYPE 

GROUND PLAN / MECHANICAL AND ON PAGES WITH PAGE TYPE DIAGRAM. 
IN THE FOLLOWING YOU CAN SEE HOW TO USE MEASUREMENT OBJECTS ON 

PAGES WITH PAGE TYPE GROUND PLAN / MECHANICAL.

— SEE “Page type” on page 560.
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As displayed in the figure below, the program shows exactly which point you are 
selecting:

Click to point out the start point for the measurement object.

— When you wish to place a measurement object, which apparently does not 
relate to the placed objects on the drawing, please refer to “Free measurement” on 
page 712.

Pointing out the end point for the measurement object and place the
measurement

Now click where you wish to place the end point for the measurement object.

You now get the text containing the measurement itself in the cross hairs. — When 
start and end points does not have the same vertical or horizontal coordinates, you 
can rotate the measurement, as described in “Rotating the measurement object 
with the <Spacebar>” on page 713.

Click to place the measurement object.

MEASUREMENT OBJECTS ON OTHER LAYERS

YOU CAN PLACE THE MEASUREMENT OBJECTS ON ANOTHER LAYER, THAN 

THE LAYER WHERE THE DRAWING IS PLACED. WHEN WORKING ON ANOTHER 

LAYER, JUST PRESS THE <ALT> KEY WHILE POINTING OUT THE START AND 

END POINTS FOR THE MEASUREMENT OBJECT.

WHEN YOU PLACE MEASUREMENT OBJECTS ON ANOTHER LAYER, YOU CAN 

EASILY DISABLE/ENABLE SHOWING THE MEASUREMENT OBJECTS.

READ MORE ABOUT THIS IN “Layers, Elevation and Scaling” on page 527.
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Specifying the Measurement data

You now enter the dialog box Measurement:

Here you can specify the appearance of the measurement object, whether to 
attach a unit specification to the measurement, and how many decimals to apply.

At the bottom of the dialog box, you can edit which font you wish to use for the 
measurement texts, by clicking the Text properties button.

Click OK, and the measurement is placed on the drawing:

Free measurement

When you choose Functions => Measurement, the program will suggest start 
and end points for the measurement object, based on the objects in the diagram.

BASIC SETTINGS: TEXT PROPERTIES FOR MEASUREMENT OBJECTS

THE BASIC SETTINGS FOR TEXTS IN MEASUREMENT OBJECTS ARE SPECIFIED 

IN SETTINGS => BASIC SETTINGS. — SEE “Basic settings” on page 925 
AND “Reference frame, cloud and measurement texts” on page 925.
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If you press the <Ctrl> button, you can place the start and end points for the meas-
urement object freely. This is called free measurement in Automation.

Rotating the measurement object with the <Spacebar>

When the start and end points of a measurement object do not have the same 
coordinates vertically or horizontally, you can — when you have pointed out the 
end point for the measurement object — use the <Spacebar> to rotate the meas-
urement object:

Editing the measurement start and end points

To edit the coordinates of start and/or end point of a measurement object, do the 
following:

 1) Click on the Texts button, and select the measurement object by clicking on 
the measurement text:

Click here
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 2) Now click on the measurement start/end point, and drag it to the desired 
position:

 3) Release the mouse button, and the position of the start/end point(s) have 
now been changed:

Editing Measurement data

To change the appearance of a meas-
urement object, do this:

 1) Click on the Texts button, right-
click on the measurement text, 
and choose Measurement data.

 2) You now enter the Measurement 
data dialog box, where you can 
edit the appearance of the meas-
urement object — see “Specifying 
the Measurement data” on 
page 712.

Measurement objects and Layers

When you press the <Alt> key, the measurement function is able to see objects 
placed in other layers on the page. You can therefore choose to place the meas-
urement objects in other layers on the page. When printing the page, it is then pos-
sible to control whether to print the measurement objects or not.

— See “Layers, Elevation and Scaling” on page 527, in particular “Printing pages 
with layers” on page 531.

Deleting a measurement object

To delete a measurement object, click the Texts button, select the measurement 
text, and click the Delete button.
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In this part you can see how to import and export 
files.

You can read about:

- Exporting Lists as Files ........................................p. 717

- Exporting/Importing DWG/DXF files .................p. 729

- Integration with Excel ..........................................p. 735

- OLE objects ..........................................................p. 736

- Placing symbols via Lists ....................................p. 743

- Opening files from the Tools menu...................p. 747

- PCSCHEMATIC Viewer and
PCSCHEMATIC Service ....................................p. 748
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EXPORTING LIST FILES

In Automation you can create list files — such as parts and components list files, 
cable lists, PLC lists, terminal lists and connection lists.

Different types of list files

This chapter describes how to create files with parts lists, components lists, termi-
nals lists, cables lists, PLC lists and connections lists.

These types of files are created according to the same directions, and are created 
from the same type of dialog boxes.

It is possible to create comma separated files, as well as column files. These files 
can subsequently be loaded into other programs.

Components list files can for instance be used for labels to mechanical assemblies.

Furthermore, it is possible to create wire number files. — Please refer to “Wire 
number Files” on page 455 for further details.

LIST FILES FOR AREAS

If you have selected an area — or just some symbols — before choosing Lists => 
Parts List File, the list will only contain information from the selected area. When n 
area is selected, the list will be generated for the full project.

THIS CHAPTER DESCRIBES

— LIST FILES FOR AREAS ............................................................................. p. 717

— HOW TO CREATE A LIST FILE .................................................................... p. 718

— THE FORMAT FILE .................................................................................... p. 718

— LISTS AND EXCEL .................................................................................... p. 720

— LISTS FOR EXTERNAL PROGRAMS ............................................................. p. 720

— LISTS IN XML FORMAT............................................................................. p. 721

— THE BUTTONS IN THE DIALOG BOX ............................................................ p. 722

— SPECIFYING THE FILE NAME ..................................................................... p. 723

— SPECIFYING THE CONTENTS OF THE FILE .................................................. p. 723

— HOW TO MATCH THE SYSTEM YOU EXPORT TO .......................................... p. 723

— REFERENCE DESIGNATIONS IN LISTS TO FILES........................................... p. 725

— AN EXAMPLE ........................................................................................... p. 726

— THE LIST FILES AND THEIR EXTENSIONS .................................................... p. 727

— CHOOSING LIST FILE SETTINGS FROM THE TOOLS MENU............................ p. 728
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CREATING A LIST FILE

In the following it is shown how to create a parts list file, but the other types of lists 
can be created correspondingly.

To create a file containing parts list information, you choose Lists => Parts List 
File. You then enter this dialog box:

FORMAT FILES

Along with the list file, a so-called format file is created, containing the information 
you specify in this dialog box.

It contains information on how the file is constructed, but no information about the 
individual components in the list.

Thus the format file contains information on which datafields are included in the 
parts list file, the order in which they appear, whether the file is comma separated... 
and so on.

Format files are independent of languages, which means that you can use the 
same format files for your English projects as for your projects in other languages 
— as long as the format file exclusively contains the predefined PCSCHEMATIC 
datafields. When the format file contains datafields, that you have defined yourself, 

Type in the name

of the parts list

file

Chosen file

information

Extra information

on the chosen

datafield

Setup/format

of the file
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you must be aware to give these datafields the same name in any language that 
you use.

Transfer list settings for existing Project lists to List files

When you wish to create a list file with the same list settings as an existing list 
page in the project, do the following:

 1) Select the page in the project.

 2) Choose Lists => Parts List file — if you wish to create a parts list file.

 3) Click on the button As Page. This fetches the list settings and datafields from 
the project list page, and the similar settings are created for the list file.

 4) Make corrections if necessary — to save the list in e.g. Excel or XML format 
— and click OK.

Please note that the button As Page only appears in the dialog box when you have 
selected a list page in the project.

Placing fixed list formats in the Tools menu

When you frequently use a specific list format, you can make it directly accessible 
from the Tools menu at the upper part of the screen:

 1) In the dialog box Parts list file: Set the desired settings for the file and click 
the Insert in Tools menu button:

 2) In the dialog box Insert in Tools menu: Type in an appropriate name and 
click OK.

When you subsequently choose Settings => Parts List File(0), the dialog box 
Parts List File is opened with the specified settings. Click OK and the list file is 
generated.

MAKE FORMAT FILES AVAILABLE FOR ALL OF THE COMPANY

UNDER SETTINGS => DIRECTORIES YOU CAN SPECIFY IN WHICH FOLDER TO 

SAVE THE FORMAT FILES FOR THE PROJECT. WHEN YOU WORK ON A NET-

WORK, THESE FILES CAN THEREFORE BECOME AVAILABLE TO ALL OF THE 

COMPANY, IF THEY ARE SAVED IN A FOLDER WHICH IS ACCESSIBLE FOR ANY-

ONE IN THE NETWORK.

— READ MORE IN “Directories” on page 911.
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If you want the list to be generated without entering the dialog box Parts List File, 
just select Silent in the lower-left corner of the dialog box.

— Read more about the Tools menu in “Tools” on page 914.

LISTS AND EXCEL

In Automation lists can be created directly in Excel.

— See also “Lists in XML format” on page 721.

All lists can be loaded/written as Excel files

Automation can create all list files as Excel files — just like the program can load 
Excel files.

Starting Excel from Automation

When you create a list file, you can start Excel from Automation at the same time 
by selecting Open list file.

It is a good idea also to select Field Header to get a survey of which information is 
placed in which columns in the Excel file.

Converting line breaks when exporting to Excel

When you select Convert line breaks, the Automation line breaks (^) are con-
verted to line breaks in the Excel file.

When Excel files are imported in Automation, all line breaks in the Excel file are 
always converted to the line break character (^) in Automation.

Placing symbols from an Excel components list

Furthermore, you can place symbols in Automation based on an Excel compo-
nents list, as described in “Placing symbols via lists” on page 743.

EXCEL MUST BE INSTALLED

IT IS ONLY POSSIBLE TO SAVE IN EXCEL FORMAT — OR OPEN LISTS IN 

EXCEL FORMAT — IF EXCEL IN INSTALLED ON THE PC. READ MORE ABOUT 

THIS IN “Excel must be installed to perform Excel Import/Export” on 
page 735.

Click here to create

an Excel file
Click here to start

Excel automatically
Select Excel
format
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Lists for external programs

If for instance you have 
installed an interface for 
ClipProject or MPrintPro, 
you have the option in the 
File format section of 
choosing External pro-
gram. You can then specify 
which program you wish to export the file for.

Interfaces for other programs can be downloaded at the PCSCHEMATIC website 
at www.pcschematic.com/EN/download-menu/other/download-other.htm

LISTS IN XML FORMAT

When you, at the bottom of the dialog box List File, select the file format XML, the 
list is saved in the XML format.

Among other options, this opens the possibility to include several lists in the same 
file, and to load the created lists in database programs, that handles the XML for-
mat. The created XML file can for instance be displayed in the Internet Explorer.

Please also see:

— “Lists and Excel” on page 720.

— “Other options when importing XML list files” on page 746.
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THE BUTTONS IN THE RIGHT-HAND SIDE OF THE DIALOG BOX

In the right-hand side of the dialog box, you find the following buttons:

OK and Close

When you click OK the list file is created, and you will be asked whether to save the 
changes in the format file.

If you click Close, the list is not created, but you get the option of saving the 
changes in the format file.

New

Click here to create a new format file. You then enter the dialog box Save as, and 
do not risk overwriting the previously applied format file.

— See “Format files” on page 718 if necessary.

Open

The next time you want to create a parts list file, which shall be constructed in a 
similar way, you load this format file by clicking Open, and therefore do not have to 
specify the file settings again.

Save and Save as

The buttons Save and Save as are used for saving the format file.

As Page

Click here to fetch the settings from an existing project list page, as described in 
“Transfer list settings for existing Project lists to List files” on page 719.

This button only appears when you have selected a list page in the project.

Create list file

(+ save format file)

Specify list criteria,

sorting order etc.

Save the format file

Do not save the list file

(+ save the format file)

Open an existing

format file

Create a new format file

Copy the format from

the selected list page

in the project

These buttons deals

with the format file
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Settings/Criteria

If you want to specify further criteria for how to select the components, you click on 
Setup. Hereby you enter the dialog box List setup, which you can read more 
about in “List settings” on page 596.

SPECIFYING THE FILE NAME

Under List File in the upper part of the dialog box — see page 718 — you specify 
under which name the parts list shall be saved. If the selected folder is not appro-
priate, you click on Browse, and select another folder.

The suggested extension to the file name is .par, because you are dealing with a 
parts list.

SPECIFYING THE CONTENTS OF THE FILE

To specify which datafields shall be included into the file, select the desired data-
fields, and click on the Transfer information button. Please note that you can 
transfer more information at the time by selecting datafields using <Shift> or 
<Ctrl>.

By selecting fields in the Used fields column and clicking on the Revert informa-
tion button, you can correspondingly remove fields from the list of fields to be 
included into the file.

The information is arranged in the order in which they are transferred to the Fields 
in file column. If you therefore want the manufacturer first in the file, start by trans-
ferring the MANUFACTUR field, so that it is placed on top of the Fields in file list.

If you want to transfer all the fields, click on the Transfer all fields button.

If you want to empty the list, click on the Revert all fields button.

Please note, that you are allowed to place the same datafield more than one place 
in the file.

The order of the fields can be changed using drag and drop.

Extra information

For some datafields — such as Name in the figure on page 718 — you can deter-
mine whether extra information shall be included into the datafield. Choose the 
extra information you want by clicking on it.

MATCHING THE SYSTEM YOU EXPORT TO

In order to match the file format of the system you export the file to, you can also 
include field headings and specify the file format.

SYMBOL DATAFIELDS IN COMPONENTS LISTS

YOU CAN ALSO INCLUDE THE SYMBOL DATAFIELDS, THAT YOU HAVE CRE-

ATED BY YOURSELF, IN THE EXPORTED COMPONENTS LIST FILE. — SEE 

“Creating Data symbols” on page 797.
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Field headings

When you want the first record in the file to contain the names of the applied data-
fields, select Field header.

Whether to select Field header or not, depends on the program you wish to trans-
fer the file to.

Keep line break

When you want a text to contain a line 
break, do the following:

 1) Place the line break character (^) 
in all project texts that needs a 
line break — as described in 
“Texts in more than one line” on 
page 127

 2) In the dialog box Format file click 
on the relevant field type, and 
select Keep line break (^)

If for instance you want the Type field in 
the file to contain a line break in the file, 
first click on Type, then click on Keep line break (^).

File header

When you click on the tab File 
Header, you can specify which 
data to include in the file header 
— if you wish to include a file 
header.

You transfer the datafields to the 
file as described in “Specifying the 
contents of the file” on page 723.

File format

The settings you specify here, depends on the system you are going to export the 
file to. You can choose between different file formats: Comma separated files, Col-
umn files, Excel files and XML files.

If you choose Comma separated, the fields will be separated by a comma. If you 
need another sign to separate the datafields, you type it in the Separator field.

If you choose Column, the 
datafields will be placed in 
columns. The width of the 
columns are then displayed 
in brackets for the individual 
datafields on the list. If you 
want to change the width of 
the column for e.g. the data-
field Type, click on the Type field in the list of used fields, and type in the desired 

Click here

... and here
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width in the Column width field. If you want to optimize the column widths, select 
Optimize column width.

Thus the width of each 
column is set to the width 
of the longest datafield of 
the type plus one. For the 
field Type the column 
width is here set to 10, 
because the longest field 
in the Type column is 
nine characters long.

Please note, that if you have selected Field header, this can determine the width 
of the columns. On the figure above, this is the case for the Quantity column.

If you choose Microsoft Excel(R), please refer to “Lists and Excel” on page 720.

REFERENCE DESIGNATIONS IN LIST FILES

For list files it is possible to 
insert the field =+design. and 
then choose Page designa-
tion, Functional aspect or 
Locational aspect respec-
tively.

This makes it possible to place 
this information in independent 
columns in the file, without the 
component name appears in the column.

Please note that you must specify whether to place a Designation or a Descrip-
tion.

If you wish to include the component name, use the field Name, to which the refer-
ence designations can also be added.
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EXAMPLE

Choose Lists => Parts List File, and type in the name you want to assign to the 
parts list file in the Fields in file field.

In the field Datafields choose the datafields displayed in the dialog box below 
under Fields in the file one by one, and click on the Transfer information button.

If you accidentally transfer a wrong datafield, click the Revert information button. 
The datafield is then removed from the list.

You can change the order of appearance in the Fields in file column using drag 
and drop.

Click OK to create the file.

You will now be asked whether you want to save the changes in the setup of the 
parts list file. If you want to create a similar file another time, click Yes, otherwise 
click No.

The parts list file have now been created.

DATAFIELDS IN UPPERCASE ARE FETCHED FROM THE DATABASE

DATAFIELDS WRITTEN IN UPPERCASE ARE FETCHED FROM THE DATABASE. 
THE OTHER DATAFIELDS ARE FETCHED FROM THE PROJECT DIAGRAMS.
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THE LIST FILES AND THEIR EXTENSIONS

When you want to create the other types of list files, this is done just like you create 
a parts list file.

Below you can see which extension the format files are assigned for the different 
file types.

For further information about the datafields for the different list types, please refer 
to “Creating Lists” on page 818.

Connect points File

A connect points file contains all connection names for all components in the pro-
ject. If for instance you create a connect point file containing the datafield Con-
nected, you can generate a survey of which connection points are connected / not 
connected in the project.

Connections list to file

When you use fields from the 
database, you can for connec-
tion list files choose that the 
value is From or To the com-
ponent — or that it shall be 
fetched from the Line article 
data for the line, or from the 
attached Wire Number.

This can for instance be used 
for mounting lists, specifying 
where to mount wires.

If symbol datafields have been 
created, you can here choose between From, To and Wire Number.

It is also possible to apply connections list files for specific types of wire numbering, 
as described in “Creating a connections list for wire numbering” on page 457.

Wire number files

It is also possible to create wire number files.

— See “Wire number Files” on page 455.

LIST TYPE FORMAT FILE

PARTS LIST .PFF

COMPONENTS LIST .CFF

TERMINALS LIST .TFF

CABLES LIST .CBF

PLC I/O LIST .PLC

CONNECT POINTS LIST .COF

CONNECTIONS LIST .CNF
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CHOOSING LIST FILE SETTINGS FROM THE TOOLS MENU

To export list files directly from the Tools menu, do this:

 1) Choose Lists => Parts List File (or another type of list file).

 2) In the dialog box Parts List File: Specify the desired settings — as explained 
in “Exporting list files” on page 717.

 3) Save the format file — as explained in “Format files” on page 718 and “The 
buttons in the right-hand side of the dialog box” on page 722.

 4) Click on the button Insert in Tools menu at the upper part of the dialog box:

 5) In the dialog box Insert in Tools menu: Type in the desired menu text, and 
click OK.

A list with the specified settings can now be created directly from the Tools menu:

When you select PCSCHEMATIC parts list, you enter the dialog box Parts List 
File, where the settings are exactly as you have specified.

Just click OK, and the list is created.
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DWG AND DXF FILES

In Automation it is possible to import DWG and DXF files, and continue working 
from these files in the program. It is also possible to export DWG and DXF files.

If you are working in layers, the layer structure will be maintained during import as 
well as export. — Read more about layers in “Layers, Elevation and Scaling” on 
page 527.

If you wish to change the parameters for the DXF import or export, please refer to 
the PCSCHEMATIC Tools manual.

THE ZOOM ALL FUNCTION DURING DWG/DXF IMPORT

When working with imported DWG/DXF files, it might happen that objects are 
placed outside the normal drawing area.

During the import to Automation, all imported objects are placed inside the project 
pages in Automation, and the page sizes and page scales are adapted to make 
this possible.

If there, in the DWG/DXF file, are placed objects outside the normal drawing area, 
this can therefore result in, that the drawing is placed in e.g. the lower-left corner of 
the page. Consequently, it will not fill out much of the page in the created 
Automation project. If you subsequently change the size of the page and/or the 
scale of the page — in order to be able to see the drawing — this might result in 
that objects are placed outside the page in Automation.

When you wish to print such a page, this gives problems because the printing 
presses all objects in the work area to be placed on the page. The drawing can 
hereby e.g. end up in the lower-left corner of the page.

To avoid this, choose View => Zoom All, which displays all objects in the work 
area. Hereby hidden objects with negative or huge positive coordinates can be dis-
played — and subsequently deleted. — See “The Zoom All function” on page 43.

THIS CHAPTER DESCRIBES

— THE ZOOM ALL FUNCTION ........................................................................p. 729

— IMPORTING DWG/DXF FILES....................................................................p. 730

— IMPORTING A DWG/DXF FILE AS A PAGE IN A PROJECT ............................p. 730

— STARTING A NEW PROJECT BY IMPORTING A DWG/DXF FILE....................p. 731

— IMPORTING A DWG/DXF FILE AS A SYMBOL .............................................p. 732

— EXPORTING DWG/DXF FILES...................................................................p. 732

— EXPORTING A PROJECT AS A DWG/DXF FILE ...........................................p. 732

— EXPORTING A SYMBOL AS A DWG/DXF FILE ............................................p. 734

— WHICH FUNCTIONS ARE TRANSFERRED?...................................................p. 734
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IMPORTING DWG/DXF FILES

There are three different ways of importing a DWG/DXF file into Automation:

a) You can import a DWG/DXF file in an active project by importing it from the 
Page menu — see “Importing a DWG/DXF file as a page in a project” on 
page 730.

b) You can start up a new project by importing a DWG/DXF file — see “Starting 
new projects by importing DWG/DXF files” on page 731.

c) You can import a DWG/DXF file as a symbol, and then continue working with 
the symbol like any ordinary symbol in Automation — see “Importing DWG/
DXF files as symbols” on page 732.

The following sections in this chapter elaborates on these options.

IMPORTING A DWG/DXF FILE AS A PAGE IN A PROJECT

If you are working in a project, and want to insert a DWG/DXF file, you first click on 
the Page menu button.

In the Page menu you then click where you want the page to be inserted as a new 
page, and click on Insert new. Or click on Add new to have it inserted as the last 
page in the project. — Read more about the Page menu in “The Page menu” on 
page 544.

You then enter the dialog box Page function, where you specify which type of 
page you want to insert: Click on Standard/Project file, and then click OK.

Opening DWG/DXF files

In the dialog box Open Standard which now appear, you click your way to the 
folder where the DWG/DXF file is located, choose Acad files (*.dwg) or DXF files 
(*.dxf) as file type, click on the DWG/DXF file, and then on Open.

ADAPT DWG/DXF FILES BEFORE IMPORTING

PLEASE NOTE, THAT IT IS A GOOD IDEA TO REDUCE THE DWG/DXF FILE 

BEFORE IMPORTING IT, SO THAT IT ONLY CONTAINS EXACTLY WHAT YOU 

NEED IN YOUR PROJECT.
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Select map file and specify View

You then enter a dialog box, where you specify which map file to use during the 
import:

You can also view the file in a separate window before importing, by clicking the 
button pointed out next to the View field in the figure above.

In the View field you specify which view you wish to import from the DWG/DXF file, 
if a viewpoint is defined in the file. When you select Drawing extents in model-
space, the whole file is imported.

Click OK.

Opening more DWG/DXF files

You have now inserted the DWG/DXF file, but are still in the Page menu. If you 
want to insert more DWG/DXF files, you repeat this procedure for each DWG/DXF 
file.

When you have finished inserting DWG/DXF files, click OK to leave the Page 
menu.

STARTING NEW PROJECTS BY IMPORTING DWG/DXF FILES

Clicking on the Open button you enter the dialog box Open, from which you can 
import a DWG/DXF file as described in "Opening DWG/DXF files" above.

Hereby you create a project consisting of one page, on which the DWG/DXF file is 
located. Using this as a basis, you can now build up a new project.

See the file before
importing

Specify mapfile

Select view
mation

Page 731



P

DWG and DXF files
IMPORTING DWG/DXF FILES AS SYMBOLS

It is also an option to import a DWG/DXF file as a symbol. This has the advantage 
that you can move the symbol in the project as you like, and at the same time you 
can not change the symbol by accident.

If you want to import a DWG/DXF file as a symbol, you do like this:

Click on the Symbols button, and then on the Symbol menu button, which brings 
you into the Symbol menu.

Here you click on the Create new symbol button, which brings you into the Sym-
bol editor. Here you click on the Open symbol button, which leads you to the dia-
log box Open, where you choose Acad files (*.dwg) or DXF files (*.dxf) as file 
type.

Find the next DWG/DXF file, and click OK.

Returning to the Symbol menu, you see the DWG/DXF file displayed in the lower-
right corner of the menu.

Click on OK, which gives you the DWG/DXF symbol in the cross hairs as a symbol. 
Click where you want to place the symbol.

The program automatically place the reference point for the symbol in the lower-left 
corner, where all symbol texts are placed as well. The symbol is a normal symbol, 
with selection in the reference point. — Read more about this in “Symbol types” on 
page 771.

If you wish to change the imported symbol — or save it in a symbol folder — you 
can click on the Edit symbol button when you are in the Symbol menu. Here you 
can edit and save as for a normal symbol.

— Read more about working with symbols in “Symbols” on page 149, and about 
how to edit symbols in “Creating Symbols” on page 761.

EXPORTING DWG/DXF FILES

Both projects and symbols can be exported as DWG/DXF files.

EXPORTING PROJECTS AS DWG/DXF FILES

When you wish to export a project as a DWG or a DXF file, just choose File => 
Export to => DWG or File => Export to => DXF, specify a file name and click 
Save.

You can also choose File => Save as, set the file type to Acad files (*.dwg) or 
DXF files (*.dxf), specify a file name, and click on Save.
Automation

age 732



DWG and DXF files

Auto
When you save the project as a DWG/DXF file, you enter the following menu:

Apart from choosing which version to export to, you have the following options:

OPTION RESULTS IN

CODEPAGE THE PROGRAM WILL AUTOMATICALLY APPLY THE CODEPAGE, WHICH 

THE PC IS SET TO USE. IF YOU WISH TO APPLY ANOTHER CODEPAGE 

FOR THE EXPORT, SELECT THIS CODEPAGE IN THE CODEPAGE FIELD IN 

THE DIALOG BOX.

1 PAGE PR. FILE EACH PAGE IN THE PROJECT IS EXPORTED AS A SEPARATE FILE.

1 PAGE PR. LAYER EACH PAGE IN THE PROJECT IS SAVED IN A SEPARATE LAYER. THIS WAY 

THE ENTIRE PROJECT CAN BE SAVED IN THE SAME FILE.

IF THE Automation PROJECT CONTAINS LAYERS, THE DIVISION IN 

LAYERS NO LONGER EXISTS.

ONLY PAGE F1 ONLY THE ACTIVE PAGE IN THE PROJECT IS EXPORTED.

PAGE 1. LAYER 

LAY 1
ONLY THE SELECTED LAYER ON THE ACTIVE PAGE IN THE PROJECT IS 

EXPORTED.

LAYER (LAY 1) ON 

PAGE F1 
EXPLODED

WHEN YOU CHOOSE THIS OPTION, YOU CHOOSE WHICH LAYER TO 

EXPLODE, AND THEN EXPORT.
OUTPUT CAN FOR INSTANCE BE APPLIED FOR A NUMERICALLY CON-

TROLLED MACHINE.

Choose which version

to export to

Specify codepage
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EXPORTING A SYMBOL AS A DWG/DXF FILE

Saving a symbol as a DWG/DXF file is also possible. You do this by first clicking on 
the Symbols button and then on the Symbol menu button, which brings you into 
the Symbol menu. — Or press the short-cut <F8> to enter the menu.

Here you find the symbol you want to save as a DWG/DXF file, click on it and click 
on the Edit symbol button. You are now in the Edit symbol mode.

Then you choose File => Save as, click on OK in the first dialog box, set the file 
type to Acad files (*.dwg) or DXF files (*.dxf) and type in the name in the follow-
ing dialog box, and click OK.

Then choose File => Close to exit the Edit symbol mode. You now return to the 
Symbol menu, where you click on Cancel in order to return to the project.

Read more about editing and saving symbols in “Creating Symbols” on page 761.

WHICH FUNCTIONS ARE TRANSFERRED FOR DWG AND DXF FILES

Functions which are common for the program, you are importing from, and 
Automation will be transferred.

When importing objects which Automation cannot handle, it is recommended to 
“explode” the drawing before importing it. Automation cannot handle coordinates 
— for instance line lengths — on more than two kilometre.

During export of objects which the DWG/DXF format can not handle, Automation 
tries to use object types known to the DWG/DXF format.

Electrical properties cannot be transferred using the DWG/DXF format.

— Please refer to the PCSCHEMATIC Tools manual.

If you are having difficulties importing DWG/DXF files, please contact your local 
support service.

COMMAND FILES FOR CONVERTING PROJECTS TO DWG/DXF FOR-

MAT

It is possible to create command files, which automatically saves Automation pro-
jects as DWG or DXF files. Read more about this in “Command files for saving pro-
jects as PDF, DWG and DXF files” on page 888.

ALL PAGES 

PLACED ON ONE 

PAGE IN THE SAME 

FILE

ALL PROJECT PAGES ARE PLACED ON THE SAME LAYER ON A SINGLE 

PROJECT PAGE.

LAST USED PAGE 

ACTIVE

IF YOU ON ONE OF THE PROJECT PAGES HAVE ENTERED SETTINGS => 

PAGE DATA AND SELECTED MARK AS LAST USED PAGE (SEE “Mark 
as last used page” on page 901), YOU CAN USE THIS WHEN 

EXPORTING DWG/DXF FILES.
IN THE DIALOG BOX DWG/DXF EXPORT:
- IF YOU SELECT LAST USED PAGE ACTIVE, ONLY THIS PAGE AND 

PRECEDING PROJECT PAGES ARE EXPORTED.
- IF YOU DO NOT SELECT LAST USED PAGE ACTIVE, ALL PROJECT 

PAGES ARE EXPORTED.

OPTION RESULTS IN
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INTEGRATION WITH MICROSOFT EXCEL

In Automation you can work together with Microsoft Excel in the following ways:

 1) Automatic project generation via Excel - see “Generating and Updating pro-
jects via Excel” on page 614.

 2) All lists to files can be saved in Excel format. This means all reports can be 
saved in Excel format — see “Lists and Excel” on page 720.

 3) PLC I/O data imported in Excel, where changes can be made, after which 
these changes can be imported in Automation — see “PLC I/O addressing 
via Excel” on page 486.

 4) You can save data from the Object Lister in Excel format — see “The Object 
Lister” on page 341.

 5) You can draw projects based on Parts/components lists from Excel, whereby 
Automation automatically fetches the applied components from the 
attached database — see “Placing symbols via lists” on page 743.

 6) Furthermore, you can merge Automation projects via Excel — see “Merging 
projects via Excel” on page 625.

THIS CHAPTER DESCRIBES

THIS CHAPTER IS A SURVEY OF THE VARIOUS WAYS YOU CAN USE MICROSOFT 

EXCEL TOGETHER WITH Automation.

EXCEL MUST BE INSTALLED TO PERFORM EXCEL IMPORT/EXPORT

IT IS ONLY POSSIBLE TO SAVE AND OPEN FILES IN EXCEL FORMAT IF MICRO-

SOFT EXCEL IS INSTALLED ON THE PC.

THIS IS BECAUSE Automation LETS EXCEL HANDLE THESE PROCEDURES. 
YOU ARE THEREFORE NOT DEPENDANT ON WHETHER Automation CAN 

HANDLE WHICHEVER VERSION OF EXCEL YOU HAVE INSTALLED.



P

Inserting files from other programs / OLE
INSERTING FILES FROM OTHER PROGRAMS / OLE

In Automation you can insert so-called OLE objects directly on the project pages. 
This means that you can work with files from other computer programs inside 
Automation.

WHAT IS AN OLE OBJECT?

OLE is a standard for communication between computer programs, which makes it 
possible to be in one computer program, and from there work on a document in 
another computer program. (OLE is an abbreviation of "Object Linking and Embed-
ding").

To make this possible, both computer programs have to be installed on the com-
puter, and both computer programs have to support OLE objects.

Because Automation supports OLE objects, you can therefore:

 1) Create new objects in other computer programs directly from a Automation 
project, and keep on working with the documents from Automation

 2) Insert existing documents from other computer programs in Automation, 
and work on the documents from Automation

Thus you can insert Word or Excel 
documents directly on the pages in 
Automation, and keep working on 
them from Automation as if you 
were working in Word or Excel 
respectively.

Inserting Automation projects as 
OLE objects in other computer pro-
grams is not possible.

THIS CHAPTER DESCRIBES

— WHAT IS AN OLE OBJECT?.......................................................................p. 736

— CREATING NEW OLE OBJECTS..................................................................p. 737

— INSERTING EXISTING OLE OBJECTS ..........................................................p. 738

— COPYING AREAS AND INSERTING AS OLE OBJECTS....................................p. 739

— EDITING PLACED OLE OBJECTS ................................................................p. 739

— OPENING OTHER COMPUTER PROGRAMS VIA OLE OBJECTS.......................p. 740

— UPDATING PLACED OLE OBJECTS.............................................................p. 741

— INSERTING AUTOCAD PROJECTS AS OLE OBJECTS...................................p. 741

— HANDLING OLE OBJECTS IN OTHER COMPUTER PROGRAMS .......................p. 741

— PROPERTIES ON OLE OBJECTS ................................................................p. 741

— UPDATE ALL OLE OBJECTS AND OTHER LINKS ...........................................p. 742

Automation

project

Word document

in Automation

as OLE object
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CREATING NEW OLE OBJECTS IN Automation

To create a new OLE object — for instance a new Word document — choose 
Insert => Insert object. — If you want to insert an existing document, please refer 
to “Inserting existing objects in Automation” on page 738.

You now enter the following dialog box:

Here you click on Create new object, and choose which type of OLE object/docu-
ment/file you want to insert in the project. The options you get on the list are those 
of the installed programs on your computer, which supports inserting OLE objects 
in other programs — for instance the Microsoft Office package.

Placing the OLE object

Click on OK when you have chosen which type of document you want to create. 
You are then asked to point out where on the page to place the OLE object.

Having placed the OLE object, you can change its size like this:

 1) Place the mouse pointer 
over one of the corners of 
the OLE object, so that 
the cursor changes 
appearance to a two-way 
arrow

 2) Press down the left 
mouse button, and drag 
the corner to another 
position

 3) Release the mouse button

Click here for

new OLE object

Choose which

type of OLE

object you want

Click here if you want to display an

icon in stead of the document contents

to create

1

2

3

mation
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When an OLE object is placed — for instance a Word document — the toolbars in 
Automation are replaced with the toolbars from Word.

You can now work with the full functionality on Word inside Automation.

When you have finished working with the word document, you just click outside the 
area containing the word document. Doing this causes the Automation toolbars to 
reappear, and you can continue working in Automation.

The text from the Word document now appears to be an ordinary text in 
Automation.

INSERTING EXISTING OBJECTS IN Automation

When you want to insert existing documents in Automation — for instance an 
existing Word document — choose Insert => Insert object. — If you are inter-
ested in creating a new file, please refer to “Creating new OLE objects in Automa-
tion” on page 737.

You now enter the following dialog box:

Click here to insert

an existing object

Specify where the

object/document

Specify whether to create a copy, or

whether you want to make changes

directly in the original

is palced
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Here you choose Create from file, and find the document you want to place in the 
project, by either clicking on Browse, or by typing in the file name in the File field 
(including the path — see “Dictionary” on page 967 — leading to the file).

Linking

If you choose Link you will enter the program in which the document is created — 
for instance Word — when you open the document from Automation. From there 
you make changes in the original document, and return to Automation.

When you do not choose Link, a copy of the document will be created in 
Automation. This means that two independent documents now exists. Changes in 
the one document will not be transferred to the other — and vice versa.

Click OK.

Placing the OLE object

You are now asked to place the OLE object, as described in “Placing the OLE 
object” on page 737.

COPYING AREAS AND INSERTING THEM AS OLE OBJECTS

When you copy an area — for instance 
from Excel — by selecting the area and 
pressing <Ctrl+c>, you can insert the 
area in Automation by choosing Edit => 
Paste special.

You now get the option of choosing 
between Insert and Insert link.

When you choose Insert link changes 
will be transferred automatically between 
the project and the original file — as described in “Linking” on page 739.

When you choose Insert only a copy of the copied area will be inserted, without 
connection to the original file.

EDITING A PLACED OLE OBJECT

When you want to edit a placed OLE object, do like this:

 1) Click the Area button

 2) Double-click inside the area covered by the OLE object — to select the OLE 
object

PLEASE NOTE THAT WHEN YOU LINK A WORD DOCUMENT TO Automation, 
YOU CAN STILL EDIT THE DOCUMENT DIRECTLY FROM WORD WITHOUT 

INVOLVING Automation.

BECAUSE THE DOCUMENT IS LINKED TO THE Automation PROJECT, THE 

CHANGES IN THE DOCUMENT WILL ALSO BE DISPLAYED IN Automation.
mation
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 3) Right-click on the OLE object and choose Document object => Edit

You have now opened the OLE object, and can edit its contents.

When you click outside the area of the OLE object, you return to working in 
Automation. The changes in the OLE object are saved automatically.

OPENING OTHER PROGRAMS FROM OLE OBJECTS

When you want to open on OLE object in Automation, so that the computer pro-
gram in which the OLE object is created fills the screen, do like this:

 1) Click the Area button

 2) Double-click inside the area covered by the OLE object to select the OLE 
object

 3) Right-click on the OLE-object and choose Document object => Open

If for instance you have opened an Excel document, the Excel program starts, and 
the size of the document in Excel matches the size in has in Automation.

Returning to Automation

To return to Automation, do like this:

 1) Choose File => Close and return to Automation project

 2) Click on the PCSCHEMATIC Automation button on the process line at the 
bottom of the screen

ENABLE DISPLAYING REFERENCE POINTS

IT CAN BE DIFFICULT TO SEE HOW MUCH SPACE A NON-SELECTED OLE 
OBJECT TAKES UP IF YOU HAVE DISABLED REFERENCEPOINTS IN SETTINGS 

=> POINTER/SCREEN OR BY CLICKING THE REFERENCE POINTS BUTTON IN 

THE LEFT TOOLBAR.

— PLEASE SEE TO “Pointer/Screen” on page 906.
Automation
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You have now returned to Automation.

UPDATING OLE OBJECTS

When the contents of an OLE object have been updated outside the control of 
Automation, you can transfer the changes to Automation:

 1) Click the Area button

 2) Double-click within the area covered by the OLE object to select the OLE 
object

 3) Right-click on the OLE-object and choose Document object => Update

You have now updated the OLE object copy in Automation. — However, these 
changes will for most programs be transferred to Automation automatically.

INSERTING AUTOCAD DOCUMENT AS OLE OBJECT

When inserting OLE objects in Automation, you have the option of drawing on top 
of the OLE object.

When inserting a ground plan drawing, you can therefore choose to draw for 
instance the electrical installations on top of the AutoCAD file. This way you only 
have the electrical installations in Automation, and only have the ground plan 
drawing in AutoCAD — without needing to convert any files.

When the AutoCAD file is placed in Automation with Link — see “Inserting 
existing objects in Automation” on page 738 — the changes on the ground plan 
drawing will be transferred automatically from AutoCAD to Automation.

HANDLING OLE OBJECTS IN OTHER COMPUTER PROGRAMS

The handling of OLE objects from other computer programs, can differ from what is 
described above. This is because there can be a difference in how these computer 
programs have chosen to support OLE.

PROPERTIES ON OLE OBJECTS

It is possible to specify properties on OLE objects. This is done like this:

 1) Click on the Area button.

 2) Double-click on the OLE object.

 3) Right-click on the OLE object, and choose Document object => Properties.

AUTOCAD MUST BE INSTALLED

TO INSERT AUTOCAD FILES AS OLE OBJECTS IN Automation YOU MUST 

HAVE AUTOCAD INSTALLED ON YOUR COMPUTER.

ALTERNATIVELY YOU CAN IMPORT AUTOCAD FILES IN Automation AS 

EITHER DWG OR DXF FILES. — PLEASE REFER TO “DWG and DXF files” 
on page 729.
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 4) You can now specify properties on the OLE object.

When using linked OLE objects you can hereby change the link to another file. Fur-
thermore you can change the size of the OLE object under Properties.

UPDATE OLE OBJECTS AND OTHER LINKS

When a project contains OLE objects, which have been inserted via Insert => 
Insert object, where at least one object have been linked to the project, you can 
choose Edit => Links.

Hereby you enter the dialog box Links:

If the contents of one of these OLE objects have changed, then select the object 
and click on Update Now, so that the object is updated in the project also. Please 
note that the OLE objects in Automation are only updated when you select this 
manually.

From the dialog box you can also open a source file — click on Open Source — or 
select another source for the OLE object — click on Change Source.

From this dialog box you can also handle linked pictures inserted via Insert => 
Insert picture.
Automation
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PLACING SYMBOLS VIA LISTS

ON PLACING SYMBOLS VIA LISTS

In Automation you can read parts and components list files containing article 
numbers, and use these files to place symbols in projects.

These lists will typically consist of parts for a machine, and could for instance be a 
components list containing sensors, motors e.t.c.

For hydraulics/pneumatics there will typically be an extra column, where the 
machine responsible informs the electrical constructor which sensors to use, and 
how to use them.

It is also possible to change project data when reading partis list and component-
slist files. You can also specify where to save the Automation project, and where 
to save PDF files generated from the project — see “Other options when importing 
XML list files” on page 746.

READING COMPONENTS LISTS/PARTS LISTS

 1) Choose Lists => Read Components List (or Lists => Read Parts List).

 2) In the dialog box Select Components List you select the folder where the 
list is placed, specify whether it is an Excel file (file type *.xls) or a comma 
separated file (file type *.csv), and double-click on the file.

THIS CHAPTER DESCRIBES

— ON PLACING SYMBOLS VIA LISTS ...............................................................p. 743

— READING COMPONENTS LISTS/PARTS LISTS ..............................................p. 743

— READING COMPONENTS / PARTS LISTS FROM MULTIPLE WINDOWS ..............p. 745

— UPDATING LOADED COMPONENTS / PARTS LISTS........................................p. 746

— INTERRUPTED PLACING OF COMPONENTS .................................................p. 746

— OTHER OPTIONS WHEN IMPORTING XML LIST FILES ...................................p. 746

POSSIBLE LIST FORMATS

THE INFORMATION IN THE LIST FILE MUST BE THE FOLLOWING: NAME, ARTI-

CLE NO., TYPE AND FUNCTION.

THE LIST CAN BOTH BE AN EXCEL FILE AND A COMMASEPARATED FILE — 
FOR INSTANCE CREATED FROM A DATABASE SYSTEM.

HOWEVER, IT IS ONLY POSSIBLE TO OPEN LISTS IN THE EXCEL FORMAT IF 

EXCEL IS INSTALLED ON THE PC. — SEE “Excel must be installed to per-
form Excel Import/Export” on page 735.
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Placing the components from the Components List window

 3) A survey of the components is now displayed in Automation:

 4) Double-click on a component in the window, and you get the component in 
the cross hairs. When a component contains more than one function, the 
symbols for all functions in the component are displayed under Available 
symbols in the lower-right corner of the screen.

 5) Place the symbol, and the components list from the file is updated in 
Automation.

 6) Continue until all components are placed in the project.

The buttons in the window

When you click on the Show not-placed button, all components, for which all sym-
bols are not placed, are displayed.

When you click on the Show partly-placed button, all components, for which all 
symbols are not placed — or just partly placed —, are displayed.

When you click on the Show all button, all placed as well as not placed compo-
nents are displayed.

When you click on the Show completely-placed button, only the completely 
placed components are displayed.
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When you click on the Update list button, the list is updated.

Show where the component is placed

When you wish to see where a component is placed in the project, click on the 
component in the list, and click the Show where the component is placed button.

The Select name window is now displayed for the component. When you click on 
one of the symbols in the window, the program jumps to the page in the project 
where the symbol is placed, and selects the symbol.

LOADING COMPONENTS/PARTS LISTS FROM MULTIPLE WINDOWS

The functions Lists => Read Components List and Lists => Read Parts List can 
open more than one window/list at the same time.

Hereby you can get access to symbols from different lists at the same time, or load 
the same list in different windows, and select components via different views of the 
same list.

THE COMPONENT LIST WINDOW REMAINS VISIBLE

THE COMPONENT LIST WINDOW REMAINS VISIBLE WHILE WORKING WITH 

THE PROJECT, AND CAN BE SET TO BECOME TRANSPARENT, WHILE YOU ARE 

WORKING ON THE DRAWING AREA — SEE “Pointer/Screen” on page 906.

1) Click on the

component in

2) Click on

the Eye

3) Click on the symbol

in the Select name

4) The symbol is

selected in the

the list window project
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UPDATING LOADED COMPONENTS/PARTS LISTS

The functions Lists => Read Components List and Lists => Read Parts List 
registers whether the loaded file has been changed, and displays a Reload button, 
which can reload the list file.

The button flashes red/black, and the list file is reloaded when you click the button, 
and subsequently answer OK to reload the file.

INTERRUPTED PLACING OF COMPONENTS FROM THE PARTS LIST

When placing components from the list is interrupted, and for instance continued 
the next day, Automation examines what has already been placed, and you can 
continue working on this basis.

OTHER OPTIONS WHEN IMPORTING XML LIST FILES

Beyond placing symbols when importing parts list and components list files, you 
have the following options:

Importing Project data from XML files

When you import a parts list or components list in XML format, you can transfer 
project data to the Automation project at the same time. The specified project 
data are hereby updated in the project, or created, if they do not already exist.

Projectdata are specified like this in the XML file:

Specify where to save the project and PDF files

When you import a parts list or components list in XML format, you can — in the 
XML file — specify in which folder to save the Automation project subsequently. 
Correspondingly, you can also specify in which folder to save PDF files generated 
from the project.

This type of information is specified in the XML file like this:

This updates the information specified under Settings => Directories for Projects 
and for PDF export. — Read more about this in “Directories” on page 911.

More XML syntax

You can read more about the syntax for XML files in “Lists in XML format” on 
page 721.
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OPENING FILES FROM THE TOOLS MENU

Opening files in other programs directly from Automation is possible. This can for 
instance be used as a short-cut when you want to see the lists to files, which you 
create from Automation.

The #OPENFILE# command

In the dialog box Settings => Tools, the command #OPENFILE# can now be 
applied. It is used when you want to open a file in another Windows program from 
Automation.

When the command is used along with a file name, the extension of the file deter-
mines which program shall be applied for opening the program. — Please note, 
that it is Windows that handles which program is used for opening the file.

If it therefore says #OPENFILE#C:\tekst.doc under Program name (full path), the 
type doc determines, that the file should be opened in the program Word.

— Please refer to “Tools” on page 914 for further information on the dialog box Set-
tings => Tools, and which other commands can be applied there.

Display lists to files

If no file name is specified, or if the file name contains the sign *, you will enter the 
Open dialog box.

This can for instance be used when you are creat-
ing lists to files. If you place the following line in the 
dialog box, you will be able to open the lists for 
files you create in Automation quickly:

When you then choose Tools => Show textfile, 
you enter the dialog box Open, with the folder 
c:\Pcselcad\list opened.

Here you click on the desired file, click OK, and 
get the file opened in the program Notepad.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO OPEN FILES IN OTHER 

PROGRAMS DIRECTLY FROM Automation
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PCSCHEMATIC Viewer and PCSCHEMATIC Service

PCSCHEMATIC VIEWER AND PCSCHEMATIC 
SERVICE

PCSCHEMATIC Viewer

For the Automation software there exists a PCSCHEMATIC Viewer, which you 
can send to your customers for free. The Viewer can be downloaded from 
www.pcschematic.com/viewer in the English, German, Polish, Czech, Hungarian, 
Russian, Chinese, Swedish, Norwegian and Danish version.

Options in PCSCHEMATIC Viewer

When you open a project with the PCSCHEMATIC Viewer, you can do the follow-
ing:

- See all project pages, and zoom in all parts of the project

- See Page data and Project data

- Search for project texts and find objects via the Object Lister

- Choose which project layers are visible

- Print out on paper

You do not have the option of editing projects in the PCSCHEMATIC Viewer.

PCSCHEAMTIC Service has more options

For service and maintenance PCSCHEMATIC Service (commercial version) gives 
you more options. Beyond the options in the viewer, you can also:

- Apply the Mounting Assistent

- Export production list files

- Export to PDF (with active links)

- Navigate in the project with the Net Navigator

- Change object type and hereby specify which type of objects you are working 
with

- Right-click on objects, and hereby for instance navigate in projects starting from 
the individual symbols

- Get information from the attached database

- Create short-cut keys

You do not have the option of editing projects in PCSCHEMATIC Service.

At www.pcschematic.com/manuals you can download a short introduction to the 
options that you have in PCSCHEMATIC Service — including how to use the 
Mounting Assistent.

http://www.pcschematic.com/manuals
http://www.pcschematic.com/viewer


This section deals with how to prepare your projects, 
and how to design the extra symbols and lists you 
need.

You can read about:

- Preparing Projects ...............................................p. 751

- Specifying which Datafields to use ...................p. 755

- Designing Symbols ..............................................p. 761

- Designing Signal symbols...................................p. 803

- Designing Drawing Headers ..............................p. 807

- Designing Lists .....................................................p. 818

- Designing Unit Drawings.....................................p. 833

- Creating Page and Project templates..............p. 837

Reading this section saves you a lot of time in the 
projects to come.

VIDEOS ABOUT CREATING YOUR OWN SYMBOLS

WATCH THE VIDEOS ABOUT HOW TO CREATE YOUR OWN 

SYMBOLS AT THE PCSCHEMATIC YOUTUBE CHANNEL:

www.youtube.com/PCSCHEMATIC

Create Symbols, Lists and Projects

https://www.youtube.com/PCSCHEMATIC
https://www.youtube.com/PCSCHEMATIC
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PLANNING AHEAD

When you have become more familiar with the program, it is a good idea to con-
sider how to prepare your future projects in Automation the best. The sooner you 
do this, the more time you will save — and the more you will benefit from the pro-
gram facilities.

This chapter gives you a survey of what is worth considering, and contains refer-
ences to the places where the various topics are elaborated.

If you have any difficulties, please contact your local support service.

CREATING DRAWING HEADERS

To adapt the program to your company needs, you will need to design your own 
drawing headers. These drawing headers are a kind of formulas you place on the 
pages in your projects, and can be used as front pages, drawing headers for draw-
ings, or formulas for tables of contents as well as several types of lists.

THIS CHAPTER DESCRIBES

— CREATING DRAWING HEADERS .................................................................p. 751

— CREATING PAGE TEMPLATES ....................................................................p. 752

— CREATING PROJECT TEMPLATES...............................................................p. 752

— CREATING SUB DRAWINGS .......................................................................p. 753

— PROJECT AND PAGE DATA ........................................................................p. 753

— CREATING SYMBOLS AND SYMBOL DATAFIELDS .........................................p. 754

— FOLDERS CONTAINING PROJECTS..............................................................p. 754

— OPTIONS FOR MULTIUSER SYSTEMS ..........................................................p. 754
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Furthermore, you have got the option to create unit drawings, which are pages on 
which you specify what a specific component consist of.

You can either create your drawing headers from scratch, or you can create them 
by adapting the drawing headers, which comes along with the program, to your 
own needs. Read more about this in “Creating Drawing Headers” on page 807, 
“Creating Lists” on page 818 and “Changing an already created list/drawing hea-
der” on page 830.

If you need to create your own unit drawings, please read “Creating Unit Drawings” 
on page 833.

CREATING YOUR OWN PAGE TEMPLATES

When you have created these drawing headers, you can succeedingly place them 
on individual page templates, so that you, when creating new project pages, 
directly can select pages, on which these drawing headers are already inserted.

— Read more about this in “Creating Templates” on page 837, particularly “Crea-
ting Page templates — via the Template editor” on page 838.

CREATING YOUR OWN PROJECT TEMPLATES

What really saves time, is if you specify a standard for how your projects shall be 
set up, and then create a project containing everything you need when you start up 
a new project.

Such a project template could for instance contain a front page, a table of contents, 
some pages for project drawings, a parts list, a components list, a terminals list 
and a cables list — and at the same time it contains the datafields you need.

Front page Table of Parts-, components-

Terminals list PLC list A4 Drawing header A3 Drawing header

and Cables listContents

Chapter

Front page

Chapter Table

of Contents
Automation
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Furthermore, you could once and for all have created the unit drawings you might 
need in your projects. These could then be loaded into your projects when you 
need them.

When you start up a new project, you start by selecting the project template, and 
continue working from this.

By doing the work once and for all you save time, and avoid doing the same things 
over and over.

Please note that you can create many different standard projects if you need to.

— Read more about this in “Creating Templates” on page 837, particularly “Crea-
ting Project templates” on page 840.

CREATING SUB DRAWINGS

The next step from here is creating your own sub drawings, which you can drag 
directly into the project diagrams. These sub drawings can also be created based 
on existing diagram pages. — Read more about this in “Sub drawings” on 
page 289.

These sub drawings can also be applied in automatic project generation, which 
you can read more about in the Project generator manual.

PROJECT AND PAGE DATA

You can attach different types of information to a project; some is attached to the 
entire project, some is only attached to the individual pages in the project.

This information is typed in on a central place, and can then be inserted as data-
fields on the project pages.

Table of

Pages for drawings

Partslists
Componentslists

Terminallists
Cableslists

PLClists

Chapter dividers

Front

contents

page

Template project
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When you start Automation, it is already determined which datafields you can 
insert on your project pages. But maybe some of these datafields are superficial, 
while you lack other datafields.

When you have determined which information you typically need in your projects, 
you may therefore adapt your standard project, so that it contains exactly the data-
fields you need. — See how to do this in “Page data and Project data Datafields” 
on page 755.

CREATING SYMBOLS AND SYMBOL DATAFIELDS

Even though many symbols comes with the program, you still may need to design 
your own symbols, data symbols or signal symbols for your projects.

If this is the case, you may read:

- “Creating Symbols” on page 761 to see how to design symbols,

- “Symbol datafields” on page 120 about how to create your own symbol data-
fields,

- “Creating Data symbols” on page 797 for designing data symbols, and

- “Creating Signal Symbols” on page 803 for designing signal symbols

FOLDERS CONTAINING PROJECTS

To maintain a survey of your projects, it is a good idea to create specific folders for 
the various types of projects.

OPTIONS FOR MULTIUSER SYSTEMS

On multiuser systems, the administrator can furthermore do several things to e.g. 
give every user access to a predefined set of pickmenus, to control database set-
tings, and to ensure every user uses the same version of the program.
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PAGE DATA AND PROJECT DATA DATAFIELDS

As described in “Datafields” on page 116, you can use datafields in Automation. It 
is a good idea to have a general strategy for which (user-defined) datafields you 
want to use in your projects.

A survey of the datafields in Automation can be found in “Datafields in Automa-
tion” on page 931.

WHAT IS A DATAFIELD?

All information concerning the entire project is gathered in the dialog box Settings 
=> Project data. Here you for instance type in the project title, as well as the name 
and address of the customer.

THIS CHAPTER DESCRIBES

— WHAT IS A DATAFIELD? ............................................................................p. 755

— SPECIFYING WHICH DATAFIELDS SHALL BE AVAILABLE ................................p. 757

— ADDING NEW DATAFIELDS TO PROJECT AND PAGE DATA ...........................p. 758

— LIST OF VALUES FOR PROJECT DATA AND PAGE DATA ...............................p. 758

— DEFAULT DATAFIELDS...............................................................................p. 760

Project data datafields
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If you need to insert one of these informations in your project — for instance the 
name of the customer — do this:

 1) Choose Insert => Insert Datafield.

 2) In the dialog box Datafield: Click on Project Data and then on the datafield 
Customer name.

 3) You now get the chosen datafield in the cross hairs: Click to specify where to 
place it on the page.

When you update your list, the name of the customer will be read from the Project 
Data tab, and inserted on your list.

If the customer change address later on, you only have to change this address 
once in Settings => Project data, which automatically corrects the address on all 
the pages where the datafield Customer Name exists in the project.

Thus datafields makes it possible to have information, that need to be used several 
places within the project, to be located in one central place.

If one or more information need to be changed, you only have to correct it once, 
and the program corrects all the places the datafields appear in the project.

Datafields, which are only attached to the individual pages in the project, are 
located in Settings => Page data.

Datafield in the drawing header definition

Datafield in the drawing headerThe contents of the datafield specified

in Settings => Project data in the active project
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Datafields in Lists

The figure above displays the following types of datafields in lists:

 1) The contents of the datafield Name collected from the diagrams

 2) The contents of the datafield DESCRIPT collected from the database

 3) The contents of the datafield Title collected from the Page title field in Set-
tings => Page data

Read more about datafields, and how to place these in a project, in “Datafields” on 
page 116.

SPECIFYING AVAILABLE DATAFIELDS

When you insert datafields using Insert => Insert Datafield, the contents of some 
of these datafields, are specified in the dialog box Settings.

You can specifying which of datafields on the Project data and Page data tabs you 
want to use in your projects.

If there is a particular type of datafields you would like to be able to insert, you can 
create these, and if you do not need some of the other datafields, you can delete 
those as well.

Drawing header/List

Drawing header/List filled out with project data

1

2

3
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ADDING NEW DATAFIELDS TO PROJECT DATA AND PAGE DATA

To add new datafields, that can be inserted as Project data datafields in your pro-
jects, do this:

 1) Enter Settings => Project data:

 2) Click on the name of the project data datafield that is placed where you wish 
to insert the new project data datafield and click the Add datafield button. 
(You can also right-click on the datafield and choose Add datafield).

 3) In the dialog box Enter text: Type in the name of the new datafield and click 
OK.

You can now use the new Project data datafield in the project.

Please note that the new datafield is positioned in the list where you clicked initially. 
If for instance you clicked the Address field, this field is moved one position down-
wards, and the new datafield has taken its place.

You can also delete and edit datafields, change the position of the datafields in the 
dialog box, remove unused datafields etc. Read more about this in “Buttons for 
handling Project and Page data datafields” on page 898.

Changes in the datafields for Page data is made correspondingly.

CHANGING THE NAMES OF USED DATAFIELDS NOT ALLOWED

You are not allowed to change the names of the datafields which are being cur-
rently used in the project.

The contents of the datafields you can change any time.

PROJECT AND PAGE DATA: LIST OF VALUES FOR A SERIES OF DATA-

FIELDS

In lists of values for Project and Page data datafields it is possible to fill out a 
series of datafields in a single operation — for instance all information attached to 
a specific customer.

When a value in the list of values contains the characters ++ this specifies that the 
consecutive datafield(s) in Project data / Page data will also be filled out with the 
text entered after the ++ characters.

If for instance you enter the value
PCSCHEMATIC A/S++Bygaden 7++4040++Jyllinge++4678 8244
five consecutive datafields will be filled out in one operation. Do this:
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Create the values in the list of values

 1) Click on the first of the datafields — here the datafield Customer name —, 
and click the Values button.

 2) In the dialog box Values: Type in the text PCSCHEMATIC A/S++Bygaden 
7++4040++Jyllinge++4678 8244 and click OK:

Select values from the list

 3) Click in the textfield next to the datafield, and a down-arrow appears in the 
right-hand side of the textfield. Click on the arrow, and select the line with the 
values in the drop-down list:

 4) Hereby the datafield is filled out — as is the four subsequent datafields in the 
dialog box Project data:

Series of datafields can be filled out the same way for Page data.

— Read more about lists of values in “The Values dialog box” on page 121.

3a) Click here 3b) ... click here

3c) ... and select the value in the list
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DEFAULT DATAFIELDS

To turn your changes into a default setting for datafields, you have to click on the 
Save as default button. This have to be done on the Project data tab as well as 
on the Page data tab.

PROJECT DATA AND PAGE DATA DATAFIELDS ARE SAVED IN THE PROJECT 

FILE.
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CREATING SYMBOLS

When you are working with Automation, it might happen that the program folders 
does not contain the specific symbol you need. Therefore, this chapter is a guide 
on how to create your own symbols.

In the following chapters you can see how to create signal symbols in “Creating 
Signal Symbols” on page 803, and how to create data symbols in “Creating Data 
symbols” on page 797.

— To see how to use the already created symbols, please read “Symbols” on 

page 149.

THIS CHAPTER DESCRIBES

— CREATING A NEW SYMBOL ........................................................................p. 762

— THE SYMBOL TYPES .................................................................................p. 771

— EXTRA SYMBOL DATAFIELDS IN THE SYMBOL .............................................p. 776

— SYMBOLS WITH STATES ............................................................................p. 777

— SYMBOLS WITH CONNECTION POINTS IN OTHER LAYERS .............................p. 779

— CREATING SYMBOLS AS MULTI SYMBOLS ...................................................p. 779

— SPECIFYING DEFAULT TEXT SETTINGS FOR EDIT SYMBOL MODE..................p. 781

— LOADING ANOTHER SYMBOL INTO A SYMBOL..............................................p. 781

— COPYING AREAS INTO EDIT SYMBOL..........................................................p. 782

— CREATING TERMINAL SYMBOLS .................................................................p. 782

— CREATING TERMINAL SYMBOLS WITH ADDITIONAL SYMBOL TYPE .................p. 785

— CREATING CABLE SYMBOLS ......................................................................p. 787

— CREATING BUSBAR SYMBOLS ....................................................................p. 789

— CREATING PLC I/O SYMBOLS ...................................................................p. 790

— CREATING PLC REFERENCE SYMBOLS ......................................................p. 793

— CREATING LINE CONNECTION SYMBOLS .....................................................p. 795

— OTHER OPTIONS ......................................................................................p. 796

AUTOMATIC CREATION OF SYMBOLS

IF YOU WANT THE PROGRAM TO CREATE SIMPLE SYMBOLS FOR YOU AUTO-

MATICALLY, PLEASE READ “Automatic generation of symbols” on 
page 217.
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CREATING A NEW SYMBOL

In the example you can create a simple symbol, consisting of a rectangle with a cir-
cle inside. Furthermore, the symbol will contain a free text as well as two connec-
tion points. The precise meaning of this is follows later.

To create a symbol, you have to be working in a project. If this is not the case you 
have to open a new project: 

Click on the New document button, and leave the dialog box Settings by pressing 
<Esc> or by clicking on Cancel.

You are now ready to create a new symbol:

Click on the Symbols button, or use the short-cut <s>. Then click on the Symbol 
menu button. Also, you can press <F8> to enter the Symbol menu directly.

You have now entered the Symbol menu:

Click on the Select Library from Folders button or on the Select Library from 
Alias button, and select the folder/alias you wish to save the symbol under — e.g. 
the folder MISC.

Then click on the Create new symbol button, to create a new symbol.

— Read more about the Symbol menu in “Fetching symbols using the Symbol 
menu” on page 159.

You now enter the Edit symbol mode, in which you can see SYMB flashing on a 
red background in the lower part of the left tool bar.

Make an appropriate Zoom <z> around the red marks in the middle of the screen. 
— If you are not sure to zoom, please see “Zoom” on page 42.

Click here
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On the middle of the screen, you will see the following drawn with the color red:

The symbol reference point

The asterisk (*) is the reference point for the new symbol. This reference point indi-
cates the position of the symbol, and that it is this point you rotate the symbol 
around, if you rotate it. A symbol has only got one reference point.

Reference points for symbol texts

The red pluses (+) are the reference points for the symbol texts. — Read more 
about these texts in “Texts connected to symbols” on page 113.

Position for references to other symbols

When creating new symbols, you can furthermore specify the position for refer-
ences to other symbols. The position of this reference point is pointed out in the 
lower-left corner in the figure above.

The red plus for this reference text is always present in the Edit symbol mode, but 
does not become active for placed symbols before the symbol reference is acti-
vated — for symbols of the type Open, Close etc.

When you place a symbol of a type, for which references are not displayed — e.g. 
symbols of the type Normal —, the reference is not displayed until you have 

"VIEW REFERENCE POINTS" MUST BE ENABLED

IF YOU CAN NOT SEE THE REFERENCE POINTS WHEN YOU ZOOM IN ON AN 

AREA, THIS IS BECAUSE VIEW REFERENCE POINTS HAS NOT BEEN ENABLED. 
ENABLE IT BY CLICKING THE REFERENCE POINTS BUTTON IN THE LEFT 

TOOLBAR, OR BY SELECTING VIEW => REFERENCE POINTS.

— GET MORE INFO ABOUT THIS IN “Settings” on page 895.

Symbol reference point

Symbol type

Symbol name

Symbol function

Symbol article no.

Reference points for

the symbol texts

(hidden under the

reference point)

Position for references

to other symbols
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selected With reference on the tab References in the dialog box Component 
data.

Moving the reference point

To make room to draw the symbol itself, you can now move the reference point a bit 
to the left. Therefore, click on the Reference point button. Click on the reference 
point, and drag it to where you want it placed. — In this case you move it 15mm to 
the left. See the coordinates in the lower-left corner of the screen.

Lines in symbols

Click on the Lines button (short-cut <l>), and click on the Draw button (in order to 
make it highlighted).

You can determine that lines in the symbol must follow the width and the color of 
the conducting lines, which gets connected to the symbol, when you are using it on 
a diagram later on. If the Follow connected button is not activated (highlighted), 
then click on it. Read more about this in “Follow connected lines” on page 95.

Drawing lines as a rectangle

To draw the rectangle in the symbol, you now click on the Rectangle button.

Point out the lower-left corner of the rectangle by clicking on a point 10mm below 
and 10mm to the left of the reference point. Then point out the upper-right corner 
of the rectangle by clicking on a point 10mm above and 10mm to the right of the 
reference point.

You have now drawn a rectangle of 20x20mm around the reference point.

Coordinates and distances are displayed in the lower-left corner of the screen.

Place connection points

To be able to use the symbol electrically later on, there have to be some points on 
the symbol, to which electrical lines can be connected, when you place the symbol 

OTHER OPTIONS: USE THE SYMBOL GENERATOR AND PICKMENUS

WHEN YOU ARE IN THE EDIT SYMBOL MODE (WHICH YOU ARE NOW), YOU 

CAN ALSO USE THE SYMBOL GENERATOR TO CREATE A "RAW SYMBOL", 
WHICH YOU CAN THEN CONTINUE WORKING ON HERE.

TO DO THIS, CHOOSE SYMBOLS AND CLICK ON THE SYMBOL GENERATOR 
BUTTON. — READ MORE IN “Automatic generation of symbols — using 
the Symbol generator” on page 217.

YOU CAN ALSO CREATE YOUR OWN PICKMENUS, WHICH YOU CAN USE WHEN 

DESIGNING SYMBOLS. YOU CAN CREATE PICKMENUS FOR DIFFERENT 

GROUPS OF SYMBOLS, EACH USING THEIR SET OF ADDITIONAL SYMBOLS. 
THE PICKMENUS CAN CONTAIN BOTH SYMBOLS, LINE TYPES AND TEXT 

TYPES.
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in a diagram. These points are called connection points, and you place them by 
clicking on the Symbols button, the Connection point button and the Pencil.

You then get a connection point in the cross hairs, and click where you want the 
two connection points located — see the illustration below.

When you then place the connection points, you will be asked about their connec-
tion point data.

Symbol name Symbol article number

Connection point Connection point

Symbol reference point

Symbol function

Symbol type

Frame displaying how much

space the symbol needs
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In this case, you can for instance give them the names 1 and 2 respectively, and 
make the names invisible on diagram pages, by deselecting the Visible check box 

for the Name field.

MORE OPTIONS IN THE DIALOG BOX CONNECTION DATA

Connection data with a variable part in the name

If you write ?1 and ?2, you can — directly from the dia-
log box Component data — type in what shall be at 
the place of the question mark in the connection name, 
when you place the symbol in the project.

This can for instance be useful when placing make and 
break symbols, where the mechanical position is not 
known prior to the placing of the symbol. Correspondingly, for terminals it 
can be useful just to write *, which gives you the option of typing in all of the 
connection name when placing the terminal in the project.

— See “Connection names with variable part in the Symbol definition” on 
page 178, “Wildcards/jokers” on page 605 and “Symbols with variable con-
nection names” on page 658.

With reference

If you click here, an independent reference text is created for the connection 
point, which refers to connection points on symbols with the same name and 
connection name. This is particularly applied for PLC symbols — see “Crea-
ting PLC I/O symbols” on page 790 and “Creating PLC reference symbols” 
on page 793.

INACTIVE REFERENCE

When you have selected With reference, you then get the option of choos-
ing Inactive reference. When you do so, the reference is not activated when 
the symbol is placed. But it makes it possible for you to pre-define the posi-
tion of the references, if these should be activated after the symbol has been 
placed in a project.

No dot generation

— Regarding No dot generation, see “No dot generation” on page 766.
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You have now placed the connection points for the symbol.

Press <Esc> to get rid of the connection point symbol in the cross hairs.

Drawing a circle

You draw the circle in the symbol by clicking on the Pencil and the Circles button 
(short-cut <c>).

The tool bar for circles/arcs then appear, and you get a circle in the cross hairs.

You may read more about this tool bar in “Arcs/Circles” on page 106.

Set the radius (R:) to 8.0, and place the circle with its centre in the symbol refer-
ence point.

Typing in a free text

In the middle of the symbol, the free text Block shall appear. — See “Texts” on 
page 108 for further details about the various text types in Automation.

Therefore click on the Texts button, or press the short-cut key <t>.

Click in the text field in the texts tool bar, and type in the text Block. Press <Enter>.

You now have the text in the cross hairs.

No double check

When performing a design check — see “Design Check” on page 355 —, it 
is possible to examine whether the project contains symbols, which has 
more than one connection point with the same name. This is done by select-
ing Used more than once.

However, for some symbols — pneumatic symbols in particular — connec-
tion points with identical names allowed according to the standards.

To disable this check for a connection point in the symbol definition, select 
No double check. Having done this, the program will not examine whether 
this connection point name is used more than once for the component, when 
performing a design check.

NOTE FOR NO DOUBLE CHECK

BEFORE DISABLING THE DOUBLE CHECK IN THE SYMBOL DEFINITION, YOU 

SHOULD MAKE SURE THAT THIS IS ALLOWED FOR THIS SYMBOL TYPE 

ACCORDING TO DOCUMENTATION STANDARDS.

IT IS NOT POSSIBLE TO DISABLE THIS DOUBLE CHECK FOR A SYMBOL IN ANY 

OTHER WAY THAN VIA THE SYMBOL DEFINITION.

MORE OPTIONS IN THE DIALOG BOX CONNECTION DATA
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Changing text properties

Click on the Text properties 
button. Give the text a height of 
3.0mm, and set the alignment 
to centre-centre.

Select height and alignment as 
displayed in the Text proper-
ties menu. Click OK.

The text in the cross hairs now 
has the chosen properties.

If you are not sure how to make 
these settings, please read 
“Specifying text properties / 
Appearance of text” on 
page 133.

Place the text by clicking in the middle of the symbol.

Press <Esc> or click on the Pencil in order not to place more copies of the text.

— Please note that a free text in a symbol definition can not be changed when you 
later place the symbol in a project. These texts can only be changed here in the 
programs Edit symbol mode.

Texts and text properties for symbol texts

Click on the Texts button, if not already selected. Deselect the Pencil by pressing 
<Esc>. Click on the reference point for the text Symbol name, to select it. In the 
command tool bar you can see whether you have selected the right text reference 
point.

Here it should say S.Name.

If you fill out this field with the prefix B, this letter will be suggested as a symbol 
name, when you place the symbol in a project. Press <k>, and this dialog box 
appear:

Type in B and press <Enter>. — In stead of pressing on <k> you can click in the 
text field in the command tool bar, type in B and press <Enter>.
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When you have selected one of the symbol texts, you can change back and forth 
between the symbol texts by pressing <F5>.

Changing text properties

While the text is selected on the drawing, you click on the Text properties button, 
and choose a height of 2.5mm and a centre-centre adjustment.

Click OK.

The text properties settings which are suggested for the various types of symbol 
texts, are set on the tab Settings => Text/Symbol defaults. You may read more 
about this in “Changing text properties” on page 140.

Moving the symbol texts

To move the Symbol name text on the diagram, you do like this:

Click on the Texts button, and deactivate the Pencil (press <Esc>). Click on the 
Symbol name text, in order to select it. Then click on the Move button.

Usually you work in a snap of 2.5mm. The Snap button is selected (highlighted).

To place the text in a finer snap, you press down <Shift>. The snap is now 0.25mm. 
This you can see on a red background in the lower part of the left tool bar. Now 
click where you want to place the text. Let go of the <Shift> key, and you return to 
the normal snap.

Move the other symbol texts according to the drawing of the symbol above.

DO NOT WRITE "-B" IN THE SYMBOL NAME

IT IS RECOMMENDED THAT YOU DO NOT WRITE "-B" IN THE SYMBOL NAME. 
IF YOU CHOOSE SETTINGS => POINTER/SCREEN AND SELECT INSERT - IN 

FRONT OF SYMBOL NAMES, THE PROGRAM AUTOMATICALLY INSERTS A 

MINUS IN FRONT OF THE SYMBOL NAME WHEN YOU PLACE THE SYMBOL IN A 

PROJECT — SEE “Pointer/Screen” on page 906.

IF YOU WRITE "B?" THE SYMBOL WILL AUTOMATICALLY BE ASSIGNED THE 

NEXT AVAILABLE SYMBOL NAME, WHEN YOU PLACE THE SYMBOL.

CHANGING SYMBOL TEXTS WITH THE SYMBOL BUTTON CHOSEN

When you have activated the Symbols button while designing a symbol, you 
get this tool bar on the screen:

Here you can also fill out the symbol texts by clicking on the various fields, 
and type in the relevant texts.
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Read more about snap and grid in “Screen / Image Functions” on page 42.

Saving the symbol

Click on the Save button. If you have not saved the symbol before, a dialog box for 
Symbol settings will appear. Give the symbol a Title — this means a description of 
the use or appearance of the symbol. This text will be displayed in the upper part of 
the Symbol menu when the symbol is selected there — and you also use it to 
determine which symbol to pick when you choose symbols in the pickmenu.

SHOW SYMBOL TEXTS

If you want to see which size the 
different symbol texts will have 
when they are filled out, which 
color they have, or whether they 
will cover the drawing of the 
symbol when they are filled out, 
you can choose View => Show 
texts.

Only texts which have not yet 
been filled out, will be altered.

You can change the appearance 
of the texts using the Text prop-
erties button.

Choose View => Show texts again, to turn the function off again.
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Click inside the field, and type in for instance Block symbol with two connection 
points.

Symbol types

As Symbol type you can choose between the following symbol types:

THE SYMBOL SETTINGS BUTTON

YOU CAN ALSO ENTER THIS DIALOG BOX WHILE DESIGNING THE SYMBOL, IF 

YOU CLICK ON THE SYMBOLS BUTTON, AND THEN ON THE SYMBOL SET-

TINGS BUTTON.

SYMBOL TYPE USE

NORMAL SYMBOLS WITHOUT A SPECIAL SYMBOL TYPE.

RELAY SYMBOLS WHICH WILL HAVE AN ATTACHED REFERENCE CROSS WHEN 

PLACED ON A DIAGRAM PAGE.

OPEN THE SYMBOL WILL BE CONCEIVED AS AN OPEN CONTACT, AND THE LOCA-

TION OF THE SYMBOL WILL BE DISPLAYED IN THE REFERENCE CROSS, AS 

AN OPEN CONTACT FOR THE COMPONENT IT IS A PART OF. WILL ALSO BE 

ASSIGNED A REFERENCE TO THE RELAY SYMBOL FOR THE SAME COMPO-

NENT.

CLOSE THE SYMBOL WILL BE CONCEIVED AS A CLOSE CONTACT, AND THE LOCA-

TION OF THE SYMBOL WILL BE DISPLAYED IN THE REFERENCE CROSS, AS A 

CLOSE CONTACT FOR THE COMPONENT IT IS A PART OF. WILL ALSO BE 

ASSIGNED A REFERENCE TO THE RELAY SYMBOL FOR THE SAME COMPO-

NENT.
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SWITCH THE SYMBOL WILL BE CONCEIVED AS A SWITCH, AND THE LOCATION OF THE 

SYMBOL WILL BE DISPLAYED IN THE REFERENCE CROSS, AS AN OPEN- AS 

WELL AS A CLOSE CONTACT FOR THE COMPONENT IT IS A PART OF. WILL 

ALSO BE ASSIGNED A REFERENCE TO THE RELAY SYMBOL FOR THE SAME 

COMPONENT.

MASTER REF-

ERENCE

THE SYMBOL WILL HAVE REFERENCES TO ALL OTHER SYMBOLS HAVING THE 

SAME SYMBOL NAME. FOR INSTANCE MANUALLY CONTROLLED CONTACTS.

WITH REFER-

ENCE

REFERS EITHER TO A SYMBOL WITH MASTER REFERENCE, OR TO THE 

CLOSEST PRECEDING- AS WELL AS SUCCEEDING SYMBOL, WHICH IS PART 

OF THE SAME COMPONENT.

REFERENCE A SYMBOL WHICH IS A REFERENCE CROSS.

SIGNAL A SYMBOL USED AS REFERENCE FOR A SIGNAL FROM ONE ELECTRICAL 

POINT TO ANOTHER. READ MORE ABOUT THIS KIND OF SYMBOLS IN 

“Creating Signal Symbols” on page 803, AND IN “Signal symbols” 
on page 225.

MULTISIGNAL RESERVED FOR FUTURE USE.

TERMINAL THE SYMBOL WILL APPEAR IN TERMINALS LISTS.
TERMINAL SYMBOLS HAVE THE OPTION OF HAVING AN ADDITIONAL SYMBOL 

TYPE — SEE “Creating terminal symbols with additional symbol 
types” on page 785.

PLC SEE “Creating PLC I/O symbols” on page 790.

THE SYMBOL WILL APPEAR IN PLC LISTS.

PLCREFER-

ENCE

SYMBOL, WHICH SHALL BE USED AS A PLC REFERENCE SYMBOL.

— SEE “Creating PLC reference symbols” on page 793 AS WELL 

AS “Working with PLCs” on page 466, PARTICULARLY “On PLC 
reference symbols” on page 466.

DATA APPLIED TO ADD INFORMATION TO A COMPONENT WHICH HAVE BEEN 

PLACED ON THE DRAWING. THIS INFORMATION CAN ALSO APPEAR IN LISTS. 

READ MORE IN “Creating Data symbols” on page 797.

NON CONDUCT-

ING

THE SYMBOL CAN BE CONNECTED TO A NON CONDUCTING LINE. FOR 

INSTANCE A SYMBOL FOR A WINDOW OR A DOOR, WHICH CAN BE PLACED 

ON A NON CONDUCTING LINE (A WALL).

SUPPORT A SYMBOL BELONGING TO A SPECIFIC COMPONENT, AND THAT WILL 

APPEAR IN LISTS. TYPICALLY BOTH TEXTS AND LINES ARE SET TO NP (SEE 

“Line color: F” on page 77 AND “Color” on page 135), SO THEY ARE 

DISPLAYED ON SCREEN BUT NOT ON PRINT.

CABLE THE SYMBOL IS A CABLE, AND WILL APPEAR IN CABLES LISTS

— SEE FOR INSTANCE “Working with cable symbols” on page 239, 

AND “Creating cable symbols” on page 787.

WIRE NUMBER A SYMBOL WHICH CAN BE APPLIED AS A WIRE NUMBER SYMBOL. IS USED 

DURING AUTOMATIC OR MANUAL WIRE NUMBERING. THE PROGRAM SUG-

GESTS NEXT AVAILABLE WIRE NUMBER, WHEN YOU PLACE A WIRE NUMBER 

MANUALLY.

— SEE “Automatic wire numbering” on page 443.

BUSBAR THE SYMBOL IS A BUSBAR. — SEE “Creating busbar symbols” on 
page 789.

INSERTION 

POINT

USED FOR AUTOMATIC INSERTION OF SUB DRAWINGS. — SEE “Placing 
sub drawings with drag’n draw” on page 297.

SYMBOL TYPE USE
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The symbol in this example has no specific directions, so the symbol type is Nor-
mal.

Selection

The Selection shall be set to Whole symbol. This means that the symbol will be 
selected if you click anywhere on the symbol.

If you set the Selection to Reference point, this means the symbol only will be 
selected when you click directly on its reference point. This facility is used for sym-
bols on which you place other symbols, such as a switchboard symbol.

Click on OK.

LINE CONNEC-

TION

SYMBOL APPLIED IN CONNECTION WITH SUB DRAWINGS WITH MODELS. THE 

SYMBOL IS APPLIED FOR SPECIFYING WHERE TO CONNECT A WIRE IN A SUB 

DRAWING, WHEN THE SUB DRAWING IS PLACED IN A PROJECT PAGE. — SEE 

“Creating Line Connection symbols” on page 795.

HEAD SYMBOL APPLIED FOR DIRECT PLACING OF A LIST ON A PAGE. — SEE 

“Creating a List symbol” on page 829.

IN PROJECTS YOU CAN ALSO CHOOSE THE REFERENCE POINTS FOR SYM-

BOLS WITH SELECTION SET TO REFERENCE POINT.

SYMBOL SETTINGS: ADVANCED

CLICK ON THE ADVANCED TAB FOR EXTRA OPTIONS:

HERE YOU CAN TURN THE NO SCALE ADJUSTMENT FUNCTION ON AND OFF. NORMALLY IT 

WILL BE TURNED OFF, WHICH SIGNIFIES THAT THE SYMBOL HAS GOT SCALE ADJUSTMENT. 
THIS MEANS THAT YOU CAN USE THE SAME SYMBOL ON A PAGE WITH THE SCALE 1:1 AS 

WELL AS ON A PAGE WITH THE SCALE 1:50.

SYMBOL TYPE USE
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Saving the symbol

First time you save a symbol, you enter the Save as dialog box. Here you select 
the folder you want to save the symbol in, like you normally do in Windows.

AUTO SCALE IS — JUST LIKE NO SCALE ADJUSTMENT — A FUNCTION YOU DO NOT USE IN 

ORDINARY DIAGRAM OR GROUND PLAN DRAWINGS. THIS IS A SPECIAL FUNCTION, WHICH 

MAKES THE SYMBOL SCALE ITSELF, SO THAT IT CORRESPONDS TO THE LINE TYPE YOU 

PLACE IT ON. YOU CAN ONLY USE THIS FUNCTION FOR SYMBOLS DESIGNED TO FIT 10MM 

LINES.

WHAT MULTISYMBOL IS USED FOR, IS DESCRIBED IN “Creating a symbol as a Multi 
symbol” on page 779.

WHEN MECHANICAL IS SELECTED, THE SYMBOL WILL BE INCLUDED IN COMPONENTS AND 

PARTS LISTS. MECHANICAL IS SELECTED BY DEFAULT.

— SEE “Symbol data in Electrical and Mechanical lists” on page 176.

WHEN ELECTRICAL IS SELECTED, THE SYMBOL WILL BE INCLUDED IN ALL ELECTRICAL 

LISTS — SUCH AS TERMINALS, CABLES, CONNECTIONS AND PLC LISTS — WHEN THE SYM-

BOL CONTAINS INFORMATION TO INCLUDE IN THESE LISTS. ELECTRICAL IS SELECTED BY 

DEFAULT.

— SEE “Symbol data in Electrical and Mechanical lists” on page 176.

SYMBOL SETTINGS: REFERENCE

IF NECESSARY, CLICK THE REFERENCE TAB:

FOR SYMBOL TYPES CREATED WITHOUT REFERENCES, YOU CAN HERE SPECIFY TO CRE-

ATE THE SYMBOL WITH WITH REFERENCE ACTIVATED, WHEN PLACED IN A PROJECT PAGE. 
THE OTHER WITH REFERENCE SETTINGS CAN ALSO BE PREDEFINED.

— READ MORE ABOUT THIS IN “References on symbols” on page 423, “Inserting 
references on symbols without reference” on page 423 AND “Symbol type 
and References” on page 424.

SYMBOL SETTINGS: ADVANCED
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Click in the File name field and type in the name Block. The symbol will automati-
cally get the extension .sym.

Please refer to “Symbol folders” on page 247 to determine in which folder you will 
save the symbol.

Click on Save. The symbol/symbol definition has now been saved under the sym-
bol file name Block.sym.

Printing symbols

If you wish to print the symbol, just click on the Print this page button.

Leaving the Symbol menu

Having saved the symbol, you may now leave the Design symbol mode.

Therefore choose File => Close.

You now return to the Symbol 
menu, where you can find the 
symbol by changing to the folder 
you saved the symbol in.

Here the symbol file name is dis-
played below the symbol in the 
menu. When you place the cursor 
above the symbol, its Title, Name and Type is displayed as a hint.

If you need the symbol on your drawing, you then click on OK.

You then return to the project with the symbol in the cross hairs, and you can now 
place it in the project.

SYMBOL CREATION TIME IN GMT

THE TIME OF CREATION FOR SYMBOLS IS REGISTERED IN GMT. THE CREA-

TION TIME OF ANY SYMBOL IS THEREFORE INDEPENDENT OF WHERE IN THE 

WORLD THIS SYMBOL IS CREATED. NO UNNECESSARY GENERATION NAMES 

WILL THEREFORE BE GENERATED DUE TO SYMBOLS CREATED IN DIFFERENT 

TIME ZONES, OR WHEN CHANGING BETWEEN SUMMER/WINTER TIME.
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— Read more about what you then can do with the symbol in “Symbols” on 
page 149.

Renaming symbol file names

To rename the symbol file name of a created symbol from the Symbol menu, do 
this:

 1) Enter the Symbol menu

 2) Right-click on the symbol, and choose Rename

 3) Type in the new symbol file name, and click OK

EXTRA SYMBOL DATAFIELDS IN SYMBOLS

You can also insert extra datafields in the definition of a symbol. To do this you 
must first create the relevant symbol datafields, and then insert these in the symbol 
definition. Read more about this in “Symbol datafields” on page 120.

You can also insert datafields of the type Project data and Symbol data in the 
symbol definition.

When you have placed the symbol on a project page, you type in the contents of 
the datafield as described in “The tab Symbol data fields” on page 181.

Inserting symbol datafields from database in symbol definition

There is also a symbol datafield for all fields in the database. In your projects you 
can therefore place symboldata datafields, that fetches data from the database.

To place a such symboldata datafield in the definition of a symbol, do this when 
you are in the Edit symbol mode:

 1) Choose Insert => Insert Datafield.

 2) In the dialog box Datafield: Click on Symbol datafield and select one of the 
datafields, that fetches information from the database. (The datafields fetch-
ing data from the database, are named DB[xxxxxx], where xxxxxxx is the 
name on the database field. For instance will DB[DESCRIPT] fetch the con-
tents from the DESCRIPT field for the component in the database).

Symbol datafields, which you have designed yourself, will be written as ordinary 
text. — See “Creating Data symbols” on page 797.

Typing in data when placing symbols with extra symbol data-
fields

When you have placed the symbol in a project, you type in the contents of the data-
fields as described in “The tab Symbol data fields” on page 181.
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Inserting datafields with reference designations in the symbol
definition

To insert a reference designation for a symbol in the symbol definition, you must 
specify that you want to insert a Symbol datafield, as described above, and insert 
the symbol datafield =+-design..

— See more about the options for the datafield in “Symbol datafields” on page 934 
in the subsection “Edit symbol: Description and reference designation as extra 
Symbol datafield” on page 934.

Descriptions in multiple languages in the symbol definition

You can also insert the datafield Symbol Datafield => Description in the symbol 
definition, which also makes it possible to control in which language the description 
of the symbol is written. — See “Description” on page 673.

CREATING SYMBOLS WITH STATES

When you wish to create a symbol with states — see “Symbols with states” on 
page 185 — you start by drawing the symbol as described in “Creating Symbols” 
on page 761.

How to specify the states

The only extra thing you must do, is to start by clicking the States to layers button, 
when you enter the Edit symbol mode.

This tells the program that the layers in the symbol now shall be understood as 
states. You can then use the Layer menu for specifying the symbol states:

The common parts are placed in layer 0

In layer 0 you draw what all states for the symbols have in common.

In layer 1 you draw what is to be displayed extra for the symbol in state 1. In layer 2 
you draw what is special for state 2 — and so on.

When clicking the States to layers button again, everything is displayed in layer 0.

Assigning titles to the states

To assign a title to a state for the symbol, click the Symbol settings button. On the 
tab General, click in the field Title of state:1 (displayed when you are in layer/state 
1), and type in the title for this state:
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To specify the title for another state, you must first change layer using the Layer 
menu, and then name the state for this layer as described above.

The state titles are displayed in the Symbol menu

When you have saved a symbol with states, you can subsequently see the names 
of the states in the Symbol menu, when you let the mouse rest over the symbol:

The states and state titles are displayed in the Component data dialog
box

When you place a symbol in the project — see “Symbols with states” on page 185 
— the states are ordered by state number in the dialog box Component data. 
When you let the mouse cursor rest over one of the states, the title for the state is 
displayed.

States and their titles are also displayed in the Information dialog box for symbols.

Datafields in states

Datafields can also be placed in the individual states for a symbol. For instance 
you can use this to create one state where no symbol datafields are visible, and 
another state where some — or all — symbol datafields are visible.

— Read more about symbol datafields in “Creating symbol datafields” on 
page 798.

Inserting states and Removing empty states

When working with multiple symbols for which you want to apply the same state 
numbers for identical states, it may become necessary to adapt which layers are 
used for specific purposes for the individual symbols. Therefore, you can right-click 
on a layer in the States dialog box and choose Insert state or Remove empty 
state, which makes it easier to adapt the state numbers for the individual symbols.

Other relevant links

— See how to work with layers in “Layers, Elevation and Scaling” on page 527.

FOR THE DESIGN PHASE ONLY

PLEASE NOTE, THAT THIS IS MEANT FOR THE DESIGN PHASE ONLY. IF YOU, 
AT A LATER STAGE, REPLACE A SYMBOL IN A PROJECT WITH A SYMBOL 

WHERE THE STATE NUMBERS / LAYERS HAVE OTHER MEANINGS, THE APPLI-

CATION OF THE STATES WILL NO LONGER MAKE SENSE.
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— See also “Symbols with states for single line diagrams” on page 462 and “Pla-
cing symbols with selected states in the pickmenu” on page 201.

— See how you from the database can control which state a symbol shall be in 
when placed in a the project in “Specifying symbol state for electrical symbols via 
the database” on page 654 and “Specifying symbol state for mechanical symbols” 
on page 662.

— See how to use mechanical symbols with states in order to easily create module 
based general arrangement drawings in “Module based symbols in general arran-
gement drawings” on page 694.

SYMBOLS WITH CONNECTION POINTS IN OTHER LAYERS

The connection points you place in the symbol definition are placed in layer 0. This 
makes the connection point available in the layer you place the symbol.

If you place connection points in other layers in the symbol definition, the connec-
tion points are placed in these layers — no matter which layer you place the sym-
bol in.

— Read more about layers in “Layers, Elevation and Scaling” on page 527.

CREATING A SYMBOL AS A MULTI SYMBOL

If the electrical symbols for a com-
ponent have to be three independ-
ent symbols of the same kind, you 
can state this by saving the symbol 
as a so-called multi symbol. This 
facility can for instance be used for 
PLCs.

Enter the Symbol menu (press 
<F8>), click on the symbol you just 
created, and then click on Edit 
symbol.

Zoom in on the symbol, and click 
on the Connection point button.

Right-click on the connection point 
in the left side of the symbol, 
choose Connection data and type 
in 1,3,5 in the Name field. Click on OK.

Then right-click on the connection point on the right side of the symbol, choose 
Connection data, type in 2,4,6 in the Name field, and click OK.

Hereby you state that the symbol shall consist of three independent symbols of the 
same name, and that the first symbol shall have the connection names 1 and 2, the 
second the names 3 and 4, and the last gets the names 5 and 6.
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Saving the multi symbol

Now choose File => Save as. Correct the title of the symbol if you want — please 
note that the Symbol type must remain Normal — and click on the tab Advanced. 

On this tab you select Multisymbol, and click OK.

Then type in the new name of the symbol — or keep the old — and click OK.

You have now saved the symbol as a multi symbol.

Fetching the multi symbol

When you fetch the symbol as you normally do from the Symbol menu (press 
<F8> and choose the symbol), three identical symbols are displayed under Availa-
ble symbols at the bottom of the Component menu.

Click on the symbols, and place them individually on the drawing.

Symbols with extra connection points

If you want one of the three symbol to have an extra connection point, you place 
this extra connection point on the symbol.

To determine that for instance only the third of the symbols shall have this connec-
tion point, you type in ,,7 in the Name field in its Connection data dialog box. 
Hereby you state that the two first symbols shall not have this connection point, 
and that the connection point in the third symbol shall have the name 7.

If only the first of the symbols shall have the connection point, you just type in 7 in 
the Name field.
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THE SYMBOL MANIPULATOR

For Automation there also exists a so-called Symbol manipulator, which is a small 
software tool, that can manipulate all symbols in a symbol library. This being for 
instance changes in the text position, size and font.

Any use of the Symbol manipulator is at your own risk. Please remember to make 
a back-up, before using the Symbol manipulator. To get the Symbol manipulator, 
please contact PCSCHEMATIC.

SPECIFYING DEFAULT TEXT SETTINGS FOR EDIT SYMBOL MODE

To specify where Automation shall position the different text reference points in 
relation to the symbol reference point, as well as which text properties to suggest 
for these texts, do the following:

 1) When Automation is in the Edit symbol mode: Choose Settings => Text/
Symbol defaults.

 2) On the tab Text/Symbol defaults: Click on Symbol.

 3) You can then choose which symbol text to edit default settings for:

 4) Specify the text position in relation to the symbol reference point, and click 
the Text properties button, if necessary.

 5) In the dialog box Text properties: Specify the desired text properties, as 
described in “Specifying text properties / Appearance of text” on page 133, 
and click OK.

 6) On the tab Text/Symbol defaults: Click the Save as default button, if the 
selected text settings also shall apply for other projects.

 7) Click OK.

LOADING ANOTHER SYMBOL INTO THE SYMBOL

While you are designing a symbol, you have got the option to load another symbol 
into the symbol you are designing.

To do this, you click on the Symbols button, and then on the Symbol menu button. 
Please note, that when you are designing symbols, the Symbol menu button is 
placed to the right on the command tool bar.

Choose symbol text Specify the text position

in relation to the symbol

reference point

Specify text

properties
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You then enter the Symbol menu, click on the symbol you want to use, and click 
on OK.

You get the symbol in the cross hairs, and click where you want it placed.

When you have placed the symbol, it is no longer conceived as an independent 
symbol. This is because the lines are now conceived as ordinary lines in the sym-
bol you are now designing.

The reference points and the symbol texts are not transferred in the inserted sym-
bol, but its connection points are still connection points, and the names of the con-
nection points remain unchanged.

You can also use File => Open, and find the symbol there.

Finally, you can also load a DWG or a DXF file into the symbol — see “DWG and 
DXF files” on page 729.

COPYING AREAS TO EDIT SYMBOL

It is possible to copy an area from a project drawing, and use this copied area 
when creating symbols in the Edit symbol mode.

— Read more about this in “Copying areas into Edit symbol mode” on page 282.

CREATING TERMINAL SYMBOLS

When you create a terminal symbol, you have 
to state which connection points are Input 
and which are Output. This you can only do 
after having placed the connection points.

When you have placed a connection point, 
you right-click on it, and choose Connection 
data.

By clicking on the down-arrow in the Main 
type field in the Connection data dialog box, 
you can choose whether the connection point 
is of the type Input or Output, which is of 
importance on terminals lists.
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If you set a connection to the main type Output, the connection point will be filled 
out with the color red.

The type can also be changed after having placed the terminal in a project draw-
ing. Read more about this in “Terminal symbols” on page 236.

Set the Extension to TERM (terminal) — see “Creating terminal symbols with 
additional symbol types” on page 785 also.

Naming the connection points

The names of both the connection points shall be set to 0, and the Visible field dis-
abled for one of the two connection names. When the connection names (terminal 
numbers) are inserted on the drawing, both the connection points will get the same 
name, but only the one will be visible.

No dot generation

When you use terminal symbols, you can let two conducting lines connect to the 
same connection point on the terminal.

IDENTICAL CONNECTION NAMES FOR TERMINAL SYMBOLS

IF YOU IN THE DEFINITION OF A TERMINAL SYMBOL ASSIGN THE SAME NAME 

TO ALL CONNECTION NAMES, Automation WILL MAKE SURE THAT THESE 

CONNECTION NAMES REMAINS IDENTICAL, WHEN THE SYMBOL IS PLACED IN 

A PROJECT PAGE, AND ONE OF THE CONNECTION NAMES IS CHANGED.

— SEE “Terminal symbols with different connection names” on 
page 785
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Normally, this will result in a connection dot being placed in the connection point. If 
you do not want this to happen, you can select No dot generation in the lower part 
of the menu.

Save the connection symbol

Click on OK.

Terminal symbols are saved under the symbol type Terminal — see “Creating ter-
minal symbols with additional symbol types” on page 785.

You can read more about terminal lists in “Creating a Terminals list” on page 826.

No dot generation Dot
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CREATING TERMINAL SYMBOLS WITH ADDITIONAL SYMBOL TYPES

In order to support intelligent terminals and terminals with build-in functions, sym-
bols with the symbol type Terminal can be assigned an additional symbol type — 
for instance Terminal and Relay. Terminal symbols can have the additional symbol 
types Relay, Open, Close, Switch or PLC.

Specifying additional status for terminal symbols

To specify an additional symbol type for a terminal symbol, do the following when 
creating the symbol in the Edit symbol mode:

 1) Click the Symbol settings button.

 2) In the dialog box Symbol options: Select the symbol type Terminal. You 
then get the option of choosing a Symbol type2, which is the additional sym-
bol type for the symbol:

 3) Select e.g. Open and click OK.

You have hereby assigned the additional symbol type Terminal and the additional 
symbol type Open to the symbol. The symbol will therefore function as an open 
contact in the diagram, with references to other symbols, and it will also be 
included in terminals lists.

Terminal symbols with different connection names

Because terminal symbols can behave as both terminal and relay or PLC, the con-
nection names on all of the connections on the terminal symbols are not automati-
cally the same. This is only the case if the symbol in Edit symbol is created with 
identical names on all connections. — See “Identical connection names for termi-
nal symbols” on page 783.
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Terminal symbols with additional symbol type PLC

For terminals with additional symbol type PLC, the Extension of the connection 
points must be set to TERM/PLC. As Main type you can then choose between ext/
output, ext/input, int/output and int/input, which are created for this purpose.

Symbols with this additional symbol type are included in both terminals lists and 
PLC lists.

The different Main types under IO status have the following meaning:

— See “Creating PLC I/O symbols” on page 790 also.

Specifying terminal additional symbol type via the database

— See how to specify the additional symbol type for terminals via the database in 
“Specifying the symbol type via the database” on page 652, “Specifying symbol 
type for terminals with additional symbol type” on page 652 in particular.

IO STATUS MAIN TYPE SIGNIFICANCE

NONE THE CONNECTION POINT HAS NO MAIN TYPE. FOR INSTANCE USED 

FOR SUPPLY. (NOT AVAILABLE FOR THE EXTENSION TERM/PLC).

OUTPUT THE CONNECTION POINT IS SET TO OUTPUT. (NOT AVAILABLE FOR 

THE EXTENSION TERM/PLC).

INPUT THE CONNECTION POINT IS SET TO INPUT. (NOT AVAILABLE FOR 

THE EXTENSION TERM/PLC).

EXT/OUTPUT THE CONNECTION POINT ON THE EXTERNAL SIDE OF THE TERMINAL 

AND THE PLC IO STATUS IS SET TO OUTPUT. (AVAILABLE FOR THE 

EXTENSION TERM/PLC ONLY).

EXT/INPUT THE CONNECTION POINT ON THE EXTERNAL SIDE OF THE TERMINAL 

AND THE PLC IO STATUS IS SET TO INPUT. (AVAILABLE FOR THE 

EXTENSION TERM/PLC ONLY).

INT/OUTPUT THE CONNECTION POINT ON THE INTERNAL SIDE OF THE TERMINAL 

AND THE PLC IO STATUS IS SET TO OUTPUT. (AVAILABLE FOR THE 

EXTENSION TERM/PLC ONLY).

INT/INPUT THE CONNECTION POINT ON THE INTERNAL SIDE OF THE TERMINAL 

AND THE PLC IO STATUS IS SET TO INPUT. (AVAILABLE FOR THE 

EXTENSION TERM/PLC ONLY).
Automation

age 786



Creating Symbols

Auto
CREATING CABLE SYMBOLS

Cable symbols are created as described above. However, when you design cable 
symbols, you only place one connection point, even though the cable for instance 
consist of seven wires.

— See “Creating busbar symbols” on page 789.

When you use the cable symbol on a project diagram select which wires are 
included into the cable, the program automatically create new connection points for 
each wire you add.

The connection point you place in the cable definition states the location of the first 
cable wire in the cable. As you add more cable wires to the cable on a diagram, the 
cable symbol expands.

When you design the cable symbol, it is important what you place/draw to the left, 
and what you place/draw to the right of the connection point for the cable wires.

To the left of the connection point you place the reference point for the cable sym-
bol, and draw the lines you need at the start of the cable symbol.

To the right you draw what you need at the end of the cable symbol.

Lines going from the left side of the connection point to the right side of the con-
nection point are expanded as you add new cable wires to the cable on the dia-
gram. This means that the dotted line on the figure above will expand as you 
connect new cable wires to the cable on a diagram.

Connection point for cable screen

If you place two connection points for the cable symbol, the right-most connection 
point will be conceived as a connection point for a cable screen.

Remains unchanged Remains unchangedExpands

The connection pointThe reference point for

the cable symbol for cable wires
Connection point

for cable screen
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Indicate a cable wire is connected to the cable

When you connect a cable wire to the cable on a diagram, the lines in the middle 
part of the cable definition expands to include those, but no sign is displayed where 
the cable wire meets the connection point of the cable symbol.

If you want such a sign, you can place the Function text of the connection point on 
top of the connection point. Then type in the Function text "/" and choose the 
alignment centre-centre. — See “Specifying text properties / Appearance of text” 
on page 133 for further details.

Direction of the Cable symbol

In the symbol you design, to direction is facing upwards. If you need a small arrow 
displaying the direction of the cable, you have to draw it yourself. If you use the 
color NP for this arrow, it will be displayed on screen only, and not on print.

Saving the Cable symbol

When you save the symbol, you have to set the symbol type to Cable in the Sym-
bol options menu. — See e.g. “Symbol types” on page 771.

— See how to work with cable symbols in “Working with cable symbols” on 
page 239.

Specifying Color codes for Cable symbols

When you are working with cable symbols you can let Automation control the 
color codes for the wires in the cable.

You have to specify these color codes in the record for the cable in the database. 
This is done like you specify connection names for symbols in general. Please refer 
to the PCSCHEMATIC Database manual for further details.

Most used cable direction

For setting the most used cable direction, please refer to “Default Cable direction” 
on page 246.
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CREATING BUSBAR SYMBOLS

When you create a busbar symbol, you must place two connection points, connect 
these with a line, and save the symbol with the symbol type busbar:

The connection name is applied for the name of the potential, which the busbar is 
connected to. Both connection points must be assigned the same connection 
name (L1 in the figure above).

Please note: At the present moment there is no specific standard describing how 
busbar symbols should appear in electrical documentation.

Busbar symbols in projects

When you place a busbar symbol in a diagram, you can stretch it and move it just 
like an ordinary line.

Busbar symbol facts

There are the following advantages for using busbar symbols in stead of drawing 
electrical potentials:

- The busbars will appear as busbars in e.g. parts lists

- Wire numbers are not placed on busbars

- The busbars are also included in graphical plans

Connectionpoint

Reference point

for the symbol

Connection name Symbol name Connection name
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CREATING PLC I/O SYMBOLS

— Read about PLC I/O symbols and their use in “Working with PLCs” on 
page 466, “Workflow for PLCs from the database” on page 469 and “PLC data on 
the I/O symbol connection points” on page 476.

PLC I/O symbols are designed as other symbols — see “Creating Symbols” on 
page 761.

When designing PLC I/O symbols, you must furthermore do the following:

Activate With reference for PLC I/O symbol input/output connec-
tion points

When you place the connection points representing inputs/outputs on the PLC I/O 
symbols, you must enter the dialog box Connection data (e.g. by double-clicking 
on the connection points) and select With reference.

Hereby an independent reference text Ref is attached to the connection point. This 
text you can subsequently place an appropriate place in the symbol definition — 
see “PLC I/O symbols placed in projects” on page 792.

When you have placed the created PLC I/O symbol in the project, the Ref text will 
contain a reference to this connection point in the PLC reference symbol for the 
PLC in the project. — See “Jumping between PLC ref. symbols and PLC I/O sym-
bols” on page 478.

For I/O connection points

For connection points

Connection points for PLC I/O symbols

for common terminals
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Connection points for common terminals: Do not select With reference

For connection points with common terminals (supply/ground) you shall not select 
With reference.

IO status for connection points on PLC I/O symbols

Set the Main type for input and output connection points to input or output, 
depending on whether they shall refer to inputs or outputs. Furthermore, set the 
Extension for these connection points to PLC.

— Please refer to the figure on page 790.

Connection points for common terminals shall not be assigned Main type
or Extension

For connection points for common terminals (supply/ground), both Main type and 
Extension shall be set to none.

I/O addr. in the symbol definition can specify pairs of connection
points

In the field I/O addr. you specify an address for the connection point. This address 
has two functions:

 1) The program understands connection points with the same I/O addr. in the 
symbol definition as belonging together. When you draw a PLC I/O symbol 
with e.g. eight connection points, which are addressed in pairs, you can 
therefore give the pairs the same I/O address.

 2) When placing the PLC I/O symbol directly in the project — without first hav-
ing addressed the PLC via a PLC reference symbol —, the connection point 
will be assigned the address which you specify here.

Please note, that the field I/O addr. is called Function for a start, and will not get 
the name I/O addr. until you have set IO status for the connection point, as 
described in “IO status for connection points on PLC I/O symbols” on page 791.

— Please refer to the figure on page 790.

Save the PLC I/O symbol with the symbol type PLC

When you save the PLC I/O symbol — see “Saving the symbol” on page 770 and 
“Symbol types” on page 771 —, you must give it the symbol type PLC.

When you use the symbol in projects, you can therefore apply all of the automatic 
PLC functions in Automation, and the symbol will furthermore be included in PLC 
lists.
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PLC I/O symbols placed in projects

When you have placed the PLC I/O symbol in the project, it can for instance look 
like this:

— See also “PLC data on the I/O symbol connection points” on page 476 and 
“Jumping between PLC ref. symbols and PLC I/O symbols” on page 478.

Name of the PLC Name of the connection point

(Name of the physical pin on the PLC)

Address (The I/O addr. field for

Reference to the connection point

(The Name field for the symbol)

the connection point)

in the PLC reference symbol

The Description field

(The Ref field)
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CREATING PLC REFERENCE SYMBOLS

— Read about PLC reference symbols and 
their use in “On PLC reference symbols” on 
page 466.

PLC reference symbols are designed as 
described in “Creating Symbols” on 
page 761.

When designing PLC reference symbols, 
you must furthermore do the following:

Activate With reference for the
PLC symbol I/O connection points

When you place the PLC connection 
points, you must enter the dialog box 
Connection data (e.g. by double-clicking 
on the connection point) and select With 
reference.
This places a reference text Ref attached 
to the connection point. This reference 
text refers to connection points on PLC I/
O symbols with the same name and con-
nection point in the project. — See 
“Creating PLC I/O symbols” on page 790.

When you have placed the created PLC 
reference symbol in the project, and sub-
sequently place the PLC I/O symbol with the connection name 1, there will be 
placed a reference to the position of the PLC I/O symbol next to connection name 1 
in the project. — See “Jumping between PLC ref. symbols and PLC I/O symbols” 
on page 478.

You shall only choose With reference for the I/O connection points.

I/O status for PLC reference symbol I/O connection points

Set the Main type for the connection points to output or input, depending on 
whether the connection points shall refer to an input or an output.

Furthermore, set the Extension for the connection points to PLC.

Connection points

Texts for the connection points

Select Reference
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PLC reference symbol contains connection data for  I/O symbols

Data for the PLC inputs/outputs are attached to the connection points on the PLC I/
O symbols — see “PLC data on the I/O symbol connection points” on page 476. In 
this example, the PLC reference symbol consists of lines with data from these con-
nection points:

Save the PLC reference symbol with the type PLC reference

When saving the PLC reference symbol — see “Saving the symbol” on page 770 
and “Symbol types” on page 771 —, you must save it with the symbol type PLC 
reference.

Connection pointI/O address (C.Function)

Reference to the position of the

PLC I/O symbol in the project (Ref)

Name on a PLC I/O symbol con-

nection point, for which this line

will contain data, when this PLC

reference symbol is used in the

project

description (C.Descr.)
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CREATING LINE CONNECTION SYMBOLS

The symbol type Line connection symbol is applied in connection with placing 
sub drawings using drag’n draw and in connection with sub drawings in the Project 
Generator. — See how to apply the symbol in praxis in “Sub drawings with intelli-
gent line connection” on page 320. See the Project generator manual also.

The symbol is applied to specify to which wire in the diagram to connect a wire in 
the sub drawing, when the sub drawing is placed in a project page. The individual 
connection points on the symbol can for instance have the connection names 1, 2 
and 3.

Please remember to save the symbol using the symbol type Line connection.

In the MISC folder you can find the line connection symbols LineConnect3.sym 
and LineConnect4.sym.

Line connection symbol

with the connection

names 1, 2 and 3
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OTHER OPTIONS

Deleting symbols from folder/library

To delete a symbol from the Symbol menu, you have to enter the Symbol menu 
(press <F8>), right-click on the symbol you want to delete, and choose Delete 
symbol in the menu that pops up.

Changing a symbol in a folder/library

To change a symbol, you have to enter the Symbol menu (press <F8>), click on 
the symbol you want to change, and then click on the Edit symbol button.

Or you can right-click on the symbol you want to change, and choose Edit symbol.

You can now change the symbol, and change it under the same name, or under a 
new name.

Changing the symbol type

When a symbol is being used in a project, you can change the symbol type by 
right-clicking on the symbol. A menu pops up, you click on Component data, and 
then click on the down-arrow in the Symbol type field, which gives you a list of the 
possible symbol types. Pick your choice, and click OK.

DWG/DXF files and symbols

It is an option to save a symbol as a DWG/DXF file, as well as to load a DWG/DXF 
file as a symbol in Automation.

— See how to do this in “DWG and DXF files” on page 729.
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CREATING DATA SYMBOLS

If you want to attach some extra information to a symbol you have placed in a pro-
ject, you can do this by using another symbol, called a data symbol.

This extra information can subsequently be included into lists.

Please refer to “Creating Symbols” on page 761 for general information about how 
to create symbols.

CREATING YOUR OWN DATA SYMBOL

In a project you use a motor, and for this motor you 
would like to have information about how many 
windings it has, as well as how many kW it is on 
included on your drawing and on your lists.

However, you cannot enter this information in the 
Component data menu, and you therefore have to 
attach them to the symbol otherwise. This is done 
by creating a data symbol. This symbol can for 
instance be drawn as a table you can fill out — as 
the example on page 799.

THIS CHAPTER DESCRIBES

— CREATING YOUR OWN DATA SYMBOL........................................................p. 797

— DESIGNING THE DATA SYMBOL ..................................................................p. 798

— PLACING THE DATA SYMBOL IN A PROJECT ................................................p. 799

— SYMBOL DATAFIELDS WITH PREDEFINED VALUES........................................p. 800

— DATA SYMBOLS AND LISTS .......................................................................p. 801

— DATA SYMBOLS AND COMPONENTS LISTS FILES.........................................p. 801

INSERT YOUR OWN SYMBOL DATAFIELDS IN THE SYMBOL DEFINITION

PLEASE NOTE THAT IT IS ALSO POSSIBLE TO INSERT YOUR OWN SYMBOL 

DATAFIELDS IN THE DEFINITION OF A SYMBOL, WHICH IN MOST CASES WILL 

BE THE BEST SOLUTION — SEE “Extra symbol Datafields in symbols” on 
page 776.
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DESIGNING THE DATA SYMBOL

To design the data symbol click on the Symbols button and on Symbol menu — 
or press [F8> to enter the Symbol menu. Here you click on the Create symbol 
button.

Drawing the symbol

Click on the Lines and the Rectangle button, as well as the Pencil. Draw a rectan-
gle like the one you can see on page 799, then click on Straight lines and draw 
the horizontal line in the middle of the symbol. — How to draw lines is described in 
detail in “Lines” on page 72.

Creating symbol datafields

Now you have to create two symbol datafields, to contain the information you want 
to insert into the data symbol.

Therefore you choose Settings => Text/Symbol defaults, and click on Symbol 
data fields in the left-hand side of the menu.

Here you click the Add button, type in Windings in the appearing menu, and click 
on OK. Click the Add button again, type in kW: and click on OK. You have now cre-
ated the two symbol datafields Windings and kW.

You can also create a list of predefined values for the datafields, as described in 
“Symbol datafields with predefined values” on page 800.

Click OK to exit the dialog box.

— Please note you do not have to be designing a symbol to create the symbol 
datafields.

LINE DATAFIELDS ARE CREATED THE SAME WAY

WHEN YOU WISH TO CREATE LINE DATAFIELDS THIS IS DONE THE SAME WAY. 
IN STEAD OF SYMBOL DATA FIELDS, YOU JUST CHOOSE LINE DATA FIELDS.
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Placing the symbol datafields in the data symbol

To place the symbol datafields in the data symbol, choose Insert => Insert data-
field.

In the Datafield dialog box you click on Symbol Datafield, choose Windings and 
click on the red down-arrow in the lower part of the menu. Place a colon (:) and a 
space character after the transferred text in the Text field, and set the Width to 20.

You can also adapt the text size by clicking on the Text properties button. Read 
more about this in “Specifying text properties / Appearance of text” on page 133.

Place the text in the upper part of the rectangle, as displayed on the drawing.

Insert the datafield kW correspondingly.

Moving the symbol name

Click on the reference point for the text Symbol name, and place it above the data 
symbol by dragging.

Saving the symbol

You have now completed the creation of the data symbol, and are ready to save it. 
Click on Save, and you enter the dialog box symbol settings: Set Selection to 
Whole symbol, and set Symbol type to Data.

Click on OK, assign a name to the symbol in the following menu, and click OK 
again.

Now leave the Design symbol mode by choosing File => Close, and leave the 
Symbol menu by clicking on Cancel.

PLACING THE DATA SYMBOL IN THE PROJECT

Press on [F8> to enter the Symbol menu, where you click on the data symbol and 
click OK. Returning to the project drawing, with the data symbol in the cross hairs, 
you place the symbol next to the motor symbol.
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When you click to place the data symbol, you automatically enter this dialog box:

By assigning the name +W1-M1 to the data symbol, you tell the program that the 
information in this data symbol, is attached to the symbol with the name +W1-M1.

Fill out the data symbol fields, click on OK, and place the symbol.

If the data symbol does not have an appropriate size compared to the motor sym-
bol, you can scale it using the symbol scale field in the symbol tool bar. Read more 
about this in “Scaling symbols” on page 196.

SYMBOL DATAFIELDS WITH PREDEFINED VALUES

Symbol datafields can have a list of predefined values, consisting of typed in val-
ues for the datafield.
Automation

age 800



Creating Data symbols

Auto
To create such a list of predefined values, choose Settings => Text/Symbol 
defaults and click on Symbol datafields. Then select the relevant symbol data-
field, and click on Values.

You then enter a dialog box, where you type in the values, and click OK.

Placing symbols containing symbol datafields

When you place a symbol containing a symbol datafield, the tab Symbol data is 
added to the dialog box Component data.

Here you click in the text field for the relevant datafield (1, below), and a down-
arrow is displayed. When you click on the down-arrow (2), a list of the symboldata 
values is displayed (3).

SYMBOL DATAFIELDS AND LISTS

To include the information from the symbol datafields in your lists, you must — 
when you design the list — choose Insert => Insert Datafield, click on Symbol 
Datafields, and insert the symbol datafields you need. Read more about designing 
lists in “Creating Lists” on page 818.

This way you can for instance create a components list for the motors in the pro-
ject, containing information about their windings and effect. Read more about sort-
ing and list criteria in “List settings” on page 596.

DATA SYMBOLS AND COMPONENTS LIST FILES

When you create components lists files, symbol datafields for the applied data 
symbols — and symbol datafields from any other symbols — can be included in 
these lists.

Choose symbol datafield

... and click here to type

in the values

1) Click in the field

2) Click here, and the

list is displayed

3) Choose the desired

value
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— Read more about components list files in “Exporting list files” on page 717, par-
ticularly “Specifying the contents of the file” on page 723.

SYMBOL DATAFIELDS IN ALL SYMBOLS

YOU CAN INSERT SYMBOL DATAFIELDS IN ANY TYPE OF SYMBOLS IN 

Automation.
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CREATING SIGNAL SYMBOLS

A special type of symbols are called signal symbols. They are used when you start 
or end a conducting line in a non-electrical point on the drawing.

Read more about signal symbols and how to use them in your projects in “Signal 
symbols” on page 225.

This chapter is only a brief introduction on how to design your own signal symbols. 
If you find it too brief, please read “Creating Symbols” on page 761, where you get 
a more thorough example on how to design symbols.

CREATING YOUR OWN SIGNAL SYMBOL

Click on the Symbols button and then on the Symbol menu button. In the Symbol 
menu you click on the Create new symbol button.

You now enter the Design symbol mode, and see these reference points on the 

middle of the screen.

THIS CHAPTER DESCRIBES

— CREATING YOUR OWN SIGNAL SYMBOL.....................................................p. 803

— DESIGNING THE SIGNAL SYMBOL ..............................................................p. 804

— FREQUENTLY USED SIGNAL SYMBOLS........................................................p. 805

— FREQUENTLY USED SIGNAL SYMBOL NAMES ..............................................p. 806

— CREATING JOIN SYMBOLS.........................................................................p. 806

"VIEW REFERENCE POINTS" MUST BE ENABLED

IF YOU CAN NOT SEE THE REFERENCE POINTS WHEN YOU ZOOM IN ON AN 

AREA, THIS IS BECAUSE VIEW REFERENCE POINTS HAS NOT BEEN ENABLED. 
ENABLE IT BY CLICKING THE REFERENCE POINTS BUTTON IN THE LEFT 

TOOLBAR, OR BY SELECTING VIEW => REFERENCE POINTS.

— GET MORE INFO ABOUT THIS IN “Settings” on page 895.

Reference point for
the symbol you are
designing

Reference points
for the symbol texts
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DESIGNING THE SIGNAL SYMBOL

You can now design a signal symbol with the following appearance:

A right-arrow on a total of 7.5mm.

The arrowhead itself is on 45 degrees, and 
5mm high.

In the name field, it could for instance say 
Signal, but you do not have to type in any-
thing in this field, because the signal name 
will be filled out when you place the signal 
symbol on a diagram.

Drawing the signal symbol

Make an appropriate Zoom <z> around the symbol reference point. Click on the 
Reference point button as well as the Pencil, and click where you want the refer-
ence point located (1).

Click on the Lines button as well as the Follow connected button. Draw a hori-
zontal line on 5mm (2) starting from the reference point. If you are using the 2.5mm 
standard snap, you do this by pressing two times on the right-arrow key. Click on 
the mouse and press <Esc>.

— Read more about snap in “Snap” on page 47.

Click on the Filled areas button, click 2.5mm above the terminal point of the line 
(3), click 2.5mm in extension of the horizontal line, then 2.5mm down to the left (5), 
in order to get a filled triangle. (The program automatically choose a slanted line of 
45 degrees — if that is not so, please read more about Ortho 45 in “Pointer/
Screen” on page 906).

Click on the Texts button, click on the text reference point for S.Name, click on the 
Move button, press down <Shift> to get a finer snap, and place the text field.

Click in the white Text field in the texts tool bar on the top of the screen — or press 
<k> — and type in Signal and press <Enter> (6).

Text fields in signal symbols

When you save a symbol as a signal symbol, the symbol will only contain the sym-
bol texts Symbol Name and Symbol Type.

You can see this by clicking on the Symbols button, and then on the Symbol set-
tings button. Click on the down-arrow in the Symbol type field, choose Signal in 
the drop down list, and click on OK.

This makes the other symbol texts disappear, which also happens when you save 
the symbol as a signal symbol.

You should not type in anything in the Symbol Type field, because this field is used 
to contain the page reference for the signal symbol. Therefore place the symbol 
type field where you want the reference text to be located.

You will typically not specify a symbol name when you create a signal symbol, 
because you normally do not determine the name of a signal symbol until you 
place it in a project. — Read more about which names will be suggested in “Fre-
quently used signal symbol Names” on page 806.

(6)

(4)

(5)

(1)

(2)

(3)
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However, if you do not specify a name when you place a signal symbol in a project, 
the signal symbol will get the name specified in the Symbol name field.

Saving the symbol

Choose File => Save as, and assign a title to the symbol. If you have not already 
done this, you choose the symbol type Signal and click on OK.

Then save the symbol, as described in “Saving the symbol” on page 774. Remem-
ber — in the Save as dialog box — to determine which folder you want to save the 
symbol in.

All Automation signal symbols are saved in the MISC folder, having names start-
ing with SG.

FREQUENTLY USED SIGNAL SYMBOLS

Signal symbols you use often, can be added to the list of signal symbols, that 
appear when you click on the up- and down-arrows below Signal symbol in the 
dialog box Signals, which you can see below.

You enter this dialog box automatically when you start or end a conducting line in a 
non electrical point in a diagram.

To add signal symbols to this list, you choose Settings => Text/Symbol defaults.
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Here you click on Signal symbols in the lower-left corner of the dialog box, and 
click on New.

You now enter the Symbol menu, where you find and select the desired signal 
symbol, and click on OK.

Please remember to exit Settings by clicking OK.

The signal symbol is now added to the list.

If you click on Delete instead of New, you can remove signal symbols from the list.

FREQUENTLY USED SIGNAL SYMBOL NAMES

To add a signal name to the list of predefined signal names, you choose Settings 
=> Text/Symbol defaults.

Here you click on Signal names and click on Add.

In the appearing dialog box you type in the new name, and click on OK.

If you want to remove a signal name, you click on the down-arrow in the field below 
Signal name, and click on the signal name you want to remove. Click on Remove, 
and the signal name is removed.

CREATING JOIN SYMBOLS

When you create join symbols, this follows the same philosophy as for creating 
cable symbols — see “Creating cable symbols” on page 787.

In join symbols you have to place the reference point to the left, and draw the sym-
bol to the right.

When you place the join symbol on a diagram page, only the horizontal lines in the 
symbol definition are expanded. Furthermore these lines need to be on the same 
line as the connection point in order to be expanded.

Other lines in the symbol definition are moved according to the expansion of the 
horizontal line, but remain unchanged.

When you save the join symbol, choose the Symbol type Signal.

Expands

Remains unchanged
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CREATING DRAWING HEADERS

In this chapter you can see how to create your own drawing header.

Please refer to “Changing an already created list/drawing header” on page 830 to 
see how to change one of the predefined drawing headers for your own use.

See how to place a drawing header on a project page in “Insert drawing headers/
formulas” on page 585.

THIS CHAPTER DESCRIBES

— WHAT IS A DRAWING HEADER ..................................................................p. 808

— INITIAL PREPARATIONS BEFORE CREATING A DRAWING HEADER ..................p. 808

— DESIGNING THE DRAWING HEADER............................................................p. 810

— ADDING THE DRAWING HEADER TO THE LIST OF DRAWING HEADERS .........p. 815

— REMOVING DRAWING HEADERS FROM THE LIST OF DRAWING HEADERS .....p. 815

— DRAWING HEADERS WITH STATES .............................................................p. 816

— DRAWING HEADERS IN MULTIPLE LANGUAGES............................................p. 816

— PREDEFINED DRAWING HEADERS ..............................................................p. 817

— PLACING YOUR COMPANY LOGO ON A DRAWING HEADER...........................p. 817

— CHANGING DATAFIELDS IN PAGE DATA AND PROJECT DATA........................p. 817

INSERTING DRAWING HEADERS ON TEMPLATES

WHEN YOU HAVE CREATED A DRAWING HEADER, YOU CAN INSERT IT ON A 

TEMPLATE PAGE, AS DESCRIBED IN “Creating Templates” on page 837, 
PARTICULARLY “Creating Page templates — via the Template editor” on 
page 838.
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WHAT IS A DRAWING HEADER?

A drawing header is a kind of formula contain-
ing text and graphics, which you can choose to 
place on your project pages. For instance can 
a drawing header consist of a frame around 
the entire page, with your company name and 
logo placed in the lower-right corner. Apart 
from this the drawing header can contain infor-
mation about the name and number of the indi-
vidual page, which customer the project is 
carried out for — and much more.

Once you have created a drawing header, you 
can make the program fill out this information 
for you automatically.

This chapter contains an example on how to 
design your own drawing header.

INITIAL PREPARATIONS BEFORE CREATING A DRAWING HEADER

Creating a new symbol

When you create a drawing header you have to be working in a project, so if that is 
not the case you have to open a new project: Click on the New document button, 
and then leave the Settings dialog box by pressing <Esc>.

Click on the Symbols button and on Symbol menu — or press <F8> to enter the 
Symbol menu, where you click on Create new symbol button.

The program is now in the Design symbols mode. As long as you are here, SYMB 
will flash on a red background in the lower part of the left tool bar.

Setting up the page to vertical A4 format

The next thing you do is to make sure that the program is set to the correct page 
format — in this case a vertical A4 page. The page type shall also be correct, and 
because you are going to create a drawing header, the type must be Diagram:

 1) Choose Settings => Page setup. — As a short-cut to enter this dialog box, 
you can click on the field in the lower part of the left tool bar, where the page 
size is displayed.

 2) On the tab Page setup: Click on Standard size, choose the A4 format, and 
select Vertical format. Set Grid to 5.00mm. — Read more about this tab in 
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“Page setup” on page 903, and about grid and snap in “Screen / Image Fun-
ctions” on page 42.

 3) Click OK.

Help frame displayed on the page

Choose Settings => Pointer/Screen.

Click on Help frame in the right hand side of the dialog box.

The help frame displays the margin which is specified as the most common used 
standard, and is therefore only meant as a guideline for where to draw on the page. 
The frame is displayed with a dashed red line.

However, it is not sure that the standard corresponds to the settings on your 
printer. If you therefore want to see on the area on which you printer is able to print, 
you click on Printer help frame. This way you can assure yourself that your printer 
will be able to print out in the scale 1:1, when you print out the entire page. This 
help frame is displayed by a grey dash line. Deselect the printer help frame in this 
example.

If you only use the help frame, the program will automatically scale the drawing 
header to fit to your printer, before you print the page.

Click on OK.

You now see an A4 page with help frames and a grid on 5.00mm. The reference 
point for the drawing header as well as the text reference points, are placed on the 
middle of the page. These reference points shall now be moved to a more appro-

priate location.

"VIEW REFERENCE POINTS" MUST BE ENABLED

IF YOU CAN NOT SEE THE REFERENCE POINTS WHEN YOU ZOOM IN ON AN 

AREA, THIS IS BECAUSE VIEW REFERENCE POINTS HAS NOT BEEN ENABLED. 
ENABLE IT BY CLICKING THE REFERENCE POINTS BUTTON IN THE LEFT 

TOOLBAR, OR BY SELECTING VIEW => REFERENCE POINTS.

— GET MORE INFO ABOUT THIS IN “Settings” on page 895.
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Moving the reference points

The reference point of a drawing header must be placed precisely on one of the 
four corners of the help frame. In this example you must place it in the lower-left 
corner of the frame.

When you later place the drawing header on a page in a project, the reference 
point of the drawing header will position itself in the corresponding corner of the 
help frame on the page. In this case in the lower-left corner.

Therefore, click on the Symbol button, and click on the Reference point button. 
Click on the reference point you see on the middle of the screen, and drag it until it 
precisely on the lower-left corner of the help frame. In this case the coordinates 
should be x=20.00 y= 5.00mm.

Make a Zoom including the four text reference points and the lower-left corner of 
the page. Then click on the Texts button and right-click on the upper-most of the 
four text reference points. A rubber band starting from the symbol reference point 
in the lower-left corner of the screen, and ending in the text reference point, 
together with a menu. Choose Move in the menu, and then click on the symbol ref-
erence point in the lower-left corner of the screen.

You have now placed the text reference point on the symbol reference point.

Now move the three remaining text reference points correspondingly, because you 
do not need any of these in a drawing header.

Click on the Refresh button if the page need to be 
refreshed.

You are now ready to design the drawing header 
itself.

DESIGNING THE DRAWING HEADER

Drawing the frame

Click on the Zoom to page button, the Pencil, the 
Lines button as well as the Rectangle button. Set 
the line width to 0.5mm. Draw the frame so that it 
covers the entire help frame. — If you are not sure 
how to do this, please read “Lines” on page 72.

The fields in the drawing header is enlarged here:

Placing the text fields

Click on the Straight lines button. Draw the upper-most horizontal line (See the 
figure above). The x- and y-coordinates are displayed in the lower-left corner of the 
screen. Start 30mm above the bottom of the frame (x=20, y=35) and draw the hori-
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zontal line. Let go of the line by double-clicking on the frame to the right — or click 
once and press <Esc>. The vertical line is drawn 70mm from the left of the frame 
(x=90).

Now set the line width to 0.25 and draw the rest of the lines. The small vertical line 
is placed in x=132.50mm.

General information on inserting datafields

When you insert datafields in a drawing header, you can make the program fill out 
the datafields for you. There are nine different types of datafields:

So when you need to insert a datafield in a drawing header, you first choose which 
type of datafield you want to insert, and then which specific datafield of the chosen 
type.

Please note, that datafields written in upper case letters, contains information from 
the database.

To see how to fill out project- or page data, please read “Project and Page data” on 
page 125.

If you need to create new project- or page datafields, you can see how to do this in 
“Page data and Project data Datafields” on page 755.

— For a complete survey of the datafields in Automation, please refer to “Data-
fields in Automation” on page 931.

DATAFIELD TYPE DESCRIPTION

SYSTEM DATA GENERAL INFORMATION ABOUT USER NAME, COMPANY NAME, 
TIME AND DATE.

PROJECT DATA INFORMATION REGARDING THE ENTIRE PROJECT — FOR 

INSTANCE THE ADDRESS OF THE CUSTOMER, CASE NUMBER, THE 

NAME OF THE CONSTRUCTOR AND SO ON.

PAGE DATA RELEVANT INFORMATION FOR THE INDIVIDUAL PAGE IN THE PRO-

JECT — SUCH AS PAGE NUMBER, THE SCALE OF THE PAGE, AND 

THE TIME FOR LAST CORRECTION OF THE PAGE.

SYMBOL DATAFIELD DATAFIELDS YOU CAN DEFINE — READ MORE IN “Symbol data-
fields” on page 120.

TABLE OF CONTENTS SPECIAL INFORMATION NEEDED FOR A TABLE OF CONTENTS — 
SUCH AS A HEADING FOR THE TABLE OF CONTENTS OR SPECIFICA-

TION OF DRAWING TYPES.

PARTS/COMPONENTS 

LIST

SPECIAL INFORMATION NEEDED ON PARTS- OR COMPONENTS 

LISTS — ARTICLE NUMBERS, PRICES, DESCRIPTIONS OF COMPO-

NENTS AND SO ON.

TERMINALS LIST SPECIAL INFORMATION FOR TERMINALS LISTS — THE NAME AND 

TYPE OF THE TERMINAL AND MORE.

CABLE LIST SPECIAL INFORMATION FOR CABLE LISTS — THE NAME AND TYPE 

OF THE CABLE AND MORE.

PLC LIST SPECIAL INFORMATION FOR PLC LISTS — THE NAME, TYPE, 
FUNCTION AND I/O DATA OF THE PLC.
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Insert the datafields

In this drawing header you need the following datafields:

Datafields from Project Data:- Title

- Customer name

- Designer

Datafields from Page Data:- Page number

- Last used page

To determine the appearance of the datafields, you click on the Texts button, and 
then on the Text properties button. Here you set Height to 2.5mm, Width to 
AUTO and Alignment to left-down. Click OK.

To insert a datafield, you choose Insert => Insert Datafield.

The dialog box Datafield is then displayed:

See an elaboration of the functions in this dialog box in “Datafields” on page 116.

Choose Project Data. In the field to the right of Project Data you click on the 
down-arrow. In the appearing drop-down menu you choose the datafield Title.

When you have chosen Title you can transfer the word Title to the Text field by 
clicking on the red arrow. The cursor is then placed inside the text field. Type in a 
colon (:) after Title. If you want space between the colon and the following title, 
please press the <spacebar> key.

In the Width field in the lower-left corner of the menu you can type in the allowed 
number of characters in the filed. In this case, let it be 80.

Click on OK. Place the datafield in the upper-right corner on the enlarged part on 
the drawing header.

Press <Esc> not to place the datafield again.

Continue by placing the datafield Customer name, which is also of the type Pro-
ject Data.
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age 812



Creating Drawing Headers

Auto
The next field is Designer. It is also of the type Project Data, and in the Text field 
you type in Design. Set the width to 10. — The already transferred text is also 
included in this maximum number of characters.

Now click on Page Data, because the two last datafields Page number and Last 
used page are of this type.

Choose Page number, type in Page in the Text field, and set the width to 10. Click 
on OK. Click on the Text properties button and set the alignment to right-down 
(See “Specifying text properties / Appearance of text” on page 133). Click on OK 
and place the text.

Choose Last used page, type in the text of, set the Width to 10, and click on OK. 
Click on the Text properties button, set the Alignment to left-down, and click on 
OK. Place the text.

Free text in drawing headers

Now click in the text field in the texts tool bar, and type in the text Hans Chr Ander-
son^Maschinery Inc. Click on the Text properties button, and set the text to the 
Height 4.0mm, Width AUTO, Alignment left-down, and choose Bold text.

The ^ character signifies line break, and will not be displayed on the screen until 
you have typed in a succeeding character.

Place the text like you see it on the figure above. — See more about how to type in 
a free text in “Type in and place a free text” on page 109.

Now change the Text properties settings to the Height 2.0mm, Width AUTO, 
Alignment centre-centre. Deselect Bold text.

Then place the remaining texts, as you see them on the figure above.

You have now created a drawing header, and can save the final result.

DRAWING HEADER FOR DIAGRAM PAGES - INCLUDING A LIST

IT IS ALSO POSSIBLE TO CREATE DRAWING HEADERS FOR DIAGRAM PAGES, 
WHICH INCLUDES A LIST ON THE PAGE. — SEE “Diagram pages - contai-
ning a Parts or Components list” on page 828.
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Saving the symbol / the drawing header

Choose File => Save as.

Fill out the dialog box as you see below.

Please note, that you can also enter this dialog box while designing the drawing 
header, if you click on the Symbols button, and then on the Symbol settings but-
ton.

Now click on OK, and save the drawing header in the MISC folder with the file 
name A4Vertic.

You can also create your own folder for drawing headers.

Click on OK.

Leaving the Edit symbol mode

You have now saved the drawing header, and shall now make the program leave 
the Design/Edit symbol mode. Do this by choosing File => Close.

You now return to the Symbol menu, where you click on Cancel or press <Esc>.
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ADDING DRAWING HEADERS TO THE LIST OF DRAWING HEADERS

The next thing you need to do, is to add the drawing header to the list, which con-
tains all the drawing headers you can use in your projects.

Therefore choose Settings => Text/Symbol defaults.

Click on Primary header in the left side of the dialog box.

Then click the Add button, which brings you into the Symbol menu.

Here you click on the image of the drawing header you want to add, and the draw-
ing header now change to the color grey.

Click on OK.

You have now returned to the tab Text/Symbol Standards, and can here see the 
name of the drawing header in the field Drawing headers. Click on OK.

The drawing header is now ready to be used in a project.

Inserting the drawing header in a project

After having added the drawing header to the list of drawing headers, you can use 
it in your project.

— See how to insert a drawing header on a project page in “Insert drawing hea-
ders/formulas” on page 585.

REMOVING DRAWING HEADERS FROM LIST OF DRAWING HEADERS

If you want to remove a drawing header from the list of drawing headers, you 
choose Settings => Text/Symbol defaults. Here you click on the down-arrow in 
the field below Drawing headers. In the appearing drop-down menu, you click on 
the drawing header you want to remove from the list, click the Remove button, and 
answer Yes to remove the drawing header from the list. Click on OK.

The drawing header is now removed from the list of drawing headers.
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DRAWING HEADERS WITH STATES

You can also create drawing headers with states, just like you create symbols with 
states. — Read more about this in “Creating symbols with states” on page 777.

— See how to select states when placing drawing headers in “Drawing headers 
with States” on page 589.

DRAWING HEADERS IN MULTIPLE LANGUAGES

You can use states in drawing headers for controlling which language is used in the 
drawing headers.

How it works

 1) Create a drawing header, which contains states with 
attached language codes. The first letters in the title for the 
state must contain the language code — for instance UK for 
English. To make this work, it requires that you, for the rele-
vant states, have translated the texts to the desired lan-
guage(s).

 2) Place the drawing header on a page in the project: The pro-
gram now automatically activates the first state, which is 
created for the language, that you have chosen to use in 
the program. If for instance you work in English, the first 
state with the English language code is selected.
(You choose language under Settings => System, where you can also see 
the language codes — see “System” on page 918, particularly “Choose lan-
guage” on page 919).

 3) If you wish to change other drawing headers to the same state, you can do 
this by clicking the Transfer settings button to the right of the State field — 
see “Drawing headers with States” on page 589. This for instance makes it 
possible to change language in all drawing headers in the project.

Examples on the application

The drawing headers that are included in the program (see “Predefined drawing 
headers” on page 817 and “Predefined lists” on page 830) are created so that you 
can choose whether to use English or Danish texts. You change language by 
changing state for the drawing header.
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PREDEFINED DRAWING HEADERS

To make things a little easier, some predefined drawing headers already exist. 
They are located in the folder c:\Pcselcad\Symbol\Misc. To make use of these 
drawing headers in your projects, you can open them and adapt them to your 
needs — as described in “Changing an already created list/drawing header” on 
page 830.

Drawing headers in this folder are created so that you can choose whether they 
should use English or Danish texts. You switch between the languages by choos-
ing state for the drawing header. — See “Drawing headers with States” on 
page 589.

You can drag pages containing these drawing headers into your projects from the 
Sub drawings tab in the Explorer window. These pages are placed in the folder 
Template/Normal.

PLACING A COMPANY LOGO ON A DRAWING HEADER

When you wish to place a logo in a drawing header, it is recommended to do so by 
creating a project logo, as described in “Inserting logos in projects” on page 581.

This also makes it possible to replace the logo easily, when working for different 
customers.

CHANGING DATAFIELDS IN PAGE DATA AND PROJECT DATA

If you want to change the name of a datafield in Project data or Page data, please 
right-click on the datafield. Hereby a menu appear, in which you can edit, delete or 
add datafields. Read more about this in “Page data and Project data Datafields” on 
page 755.
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CREATING LISTS

In this chapter you can see how to create your own project lists.

If you want to create list files you do not need to design a list the way it is described 
here. Please refer to “Exporting list files” on page 717 for further details.

In “Insert drawing headers/formulas” on page 585 you can see how to insert lists in 
projects.

THIS CHAPTER DESCRIBES

— WHAT IS A LIST ........................................................................................p. 819

— LISTS/DRAWING HEADERS ........................................................................p. 819

— HOW TO CREATE A LIST ............................................................................p. 820

— ADDING THE LIST TO THE LIST OF DRAWING HEADERS ..............................p. 824

— USING DATAFIELDS...................................................................................p. 824

— CREATING A TABLE OF CONTENTS ............................................................p. 825

— CREATING A COMPONENTS LIST ...............................................................p. 825

— CREATING A TERMINALS LIST ...................................................................p. 826

— CREATING A CABLES LIST.........................................................................p. 826

— CREATING A PLC LIST..............................................................................p. 827

— CREATING A CONNECTIONS LIST ...............................................................p. 828

— CREATING A DIAGRAM PAGE CONTAINING A PARTS OR COMPONENTS LIST .p. 828

— CREATING A LIST SYMBOL ........................................................................p. 829

— PREDEFINED LISTS ...................................................................................p. 830

— CHANGING AN ALREADY CREATED LIST/DRAWING HEADER ..........................p. 830

— OTHER OPTIONS ......................................................................................p. 832

INSERTING DRAWING HEADERS / LISTS IN TEMPLATES

WHEN YOU HAVE CREATED A LIST DRAWING HEADER, YOU CAN INSERT IT ON 

A TEMPLATE PAGE, AS DESCRIBED IN “Creating Templates” on page 837, 
PARTICULARLY “Creating Page templates — via the Template editor” on 
page 838.
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WHAT IS A LIST?

In your projects you may need to create various 
types of lists, such as parts lists, components lists, 
terminals lists, cable lists, PLC lists or tables of con-
tents.

This chapter is a thorough example on how to cre-
ate a parts list, followed by brief descriptions of how 
to create the other types of lists.

The procedure how to create lists, are basically the 
same for all types of lists; the only difference is 
which datafields you insert on the various types.

Basically it is all about placing text fields and data-
fields, which collects information from the other pro-
ject pages, onto a drawing header page. You 
determine how to place the texts and datafields, and you can also draw lines and 
place a company logo on the page.

When you have created a list and inserted it in your project, you can make the pro-
gram fill out the list with project information automatically.

This way you can for instance create a table of contents, with information about 
which drawings and lists are placed on the project pages, as well as a parts list 
containing information about all the components you need to carry out the project 
in praxis.

LISTS/DRAWING HEADERS

It is important to note, that in Automation, lists are conceived as drawing headers. 
As a consequence of this, you create lists the same way as you create drawing 
headers. Also, the functions in the program which can be used for drawing head-
ers, can be used for lists as well.

However, when working with lists, you have to update the lists to have them filled 
out with project information. This will be elaborated later.

If a filled out list needs more than just one project page, the program will automati-
cally insert the required extra amount of pages.

You are now ready to start creating a parts list.
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HOW TO CREATE A LIST

The following is an example on how the create a parts list.

Initial preparations

Because a list is also a drawing header, all initial prepa-
rations are the same for lists as for drawing headers.

Now perform the initial preparations as described in 
“Initial preparations before creating a drawing header” 
on page 808.

You Are now ready to design the parts list.

The upper part of the list you are about to design in this 
example looks like this:

Column headings

You Are now ready to make the column headings for the parts list. The texts you 
shall place in this example are:

- Article number

- Function

- Quantity

Click on the Texts button, and then on the Text properties button.

The Text properties menu appear. Here you set Height to 3.0, Width to AUTO, 
and Alignment to left-down. If you are not sure how to do this, please read “Spe-
cifying text properties / Appearance of text” on page 133.

Click on OK. You have now determined the appearance of the text, and have 
returned to the page.

Click inside the field to the right of the Text properties button, type in Article number 
and press <Enter>.

SELECT DATAFIELDS AND PLACE TEXTS AS YOU WISH

YOU ARE FREE TO PLACE THE TEXTS DIFFERENTLY, TO ASSIGN OTHER 

NAMES TO THE COLUMNS OR TO USE OTHER DATAFIELDS THAN THE ONES 

CHOSEN HERE.
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You now get the text in the cross hairs, and place it by pointing on the point 
x=20.00mm y=265.00mm and then click once. (See the coordinates in the lower-
left corner of the screen).

The text Article number have now been placed on the page.

Press <Esc> not to place the text again.

Now place these texts following the same procedure:

- The text Function in x=75.00 y=265.00mm and

- The text Quantity in x=177.50 y=265.00mm

Corrections

If you by accident place a text in the wrong place, then deactivate the Pencil (press 
<Esc>), select the text by clicking on its reference point, and then move it using the 
Move button, or delete it using the Delete button. Then Refresh the page. Also, 
you can choose Undo to undo your latest action. Read more about these options 
in “Working with selected objects” on page 58.

Inserting the datafields

Now the column headings have been properly placed, and it is time to place some 
datafields, in which information from the drawings can be inserted.

Choosing a datafield

Start by choosing Insert => Insert Datafield.

Click on Parts/Components list and then click on the down-arrow in the field 
immediately to the right of Parts/Components list.

In the appearing drop-down menu, you click on Article no. — Please note not to 
select ARTICLE NO written in upper case, because this will fetch its contents from 
the database instead. — Read more about the database in “Using the database” 
on page 629.

Click in the field Width in the lower-right corner of the dialog box, and type in 20.

Then select Activate next. What this means will be elaborated in “Activate next” 
on page 822.

(As opposed to creating the drawing header, please do not click on the red arrow, 
because you do not need a fixed text in this datafield).

— You can read more about the Datafield dialog box in “Datafields” on page 116.

Click on OK.

Placing the datafield

You now have the datafield in the cross hairs, and place it in the point x=25.00 
y=245.00mm.

Press <Esc> not to place it more than once.

You have now placed the first datafield.

Placing the remaining datafields

Choose Insert => Insert Datafield, deactivate Activate next, and insert the fol-
lowing datafields following the same procedure as above:
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- The field Function (width 80) in x=75.00 y=245.00mm and

- The field Quantity (width 20) in x=177.50 y=245.00 mm

Press <Esc> not to place the last datafield again.

Aligning the datafields

As a precaution, you can now align the datafields. Therefore mark up a window 
around the three datafields by clicking and dragging.

Then choose Edit => Align, and click on the reference point for the left-most of the 
texts. — Read more about this function in “The Align function” on page 66.

More rows of datafields

You have now placed the first row of datafields in the parts list. However, the parts 
list should consist of many rows of datafields, why you should now copy the three 
datafields and place them below the other datafields several times.

First make a Zoom including the three datafields (Article no, Function and Quan-
tity) and which contains room for twelve more rows of datafields.

Then mark up an area around the three datafields (not including the column head-
ings), so that all the datafields are selected when you release the mouse button. — 
If you are not sure how to mark up an area, please see “Selecting objects” on 
page 55.

Then click on the Copy button, and place the lines below each other, with a dis-
tance of for instance 10mm. This is most easily done by pressing four times on the 
down-arrow of the keyboard, then press <Enter>, and repeat these actions until all 
the rows of datafields have been placed.

Press <Esc> not to place more copies.

If you have not aligned the rows of datafields properly, then select the rows individ-
ually, and place them using the Move button, as described above.

Activate next

The first time the program meets a check mark in Activate next, you tell the pro-
gram to collect information about the first component in the project, which shall be 

DATAFIELDS FOR EAN13 BARCODES

FOR PARTS/COMPONENTS LISTS YOU CAN ALSO INSERT THE DATAFIELD 

EAN13 BARCODE FOR AUTOMATIC GENERATION AND INSERTION OF EAN13 
BARCODES. YOU CAN HERE CHOOSE BETWEEN THE THREE STANDARD SIZES 

FOR BARCODES.
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included in the parts list. The following datafields — such as Function and Quan-
tity — will then contain the function and quantity of this first component.

The next time the program meets Activate next, it collects information about the 
next component on the project drawings. The datafields Description and Amount 
now contains information about the second component in the project — and so 
forth.

Creating a fancier parts list

Now the parts list is completed, and ready to be 
saved, but you can still choose to do a few things 
to make it look better:

a) You can draw lines on the parts list — see 
“Lines” on page 72.

b) You can insert the datafields and lines, which 
were inserted in “Creating Drawing Hea-
ders” on page 807. In that case follow the 
directions given in “Designing the drawing 
header” on page 810.

c) You can insert a heading for the entire parts 
list. (The datafield on the figure is Page 
Data, Title).

d) Place a company logo on the page — see “Placing a Company Logo on a 
drawing header” on page 817.

Saving the parts list

To save the parts list, you do like this:

Choose File => Save as.

You now enter the dialog box Symbol settings: Type in a Title for the symbol, set 
the symbol type to Normal and set the selection to Reference point.

The symbol Title is the description of the symbol, which will be displayed in the 
Symbol menu. Click OK.

You now enter the dialog box Symbol settings: Type in a file name — such as 
Testlist.sym — and select which folder to save the symbol in.

DATAFIELDS FOLLOWING ACTIVATE NEXT MUST BE ALIGNED

IT IS IMPORTANT TO NOTE, THAT IF YOU PLACE A DATAFIELD JUST A BIT 

HIGHER THAN THE DATAFIELD IN WHICH YOU HAD SELECTED ACTIVATE 

NEXT, THIS DATAFIELD WILL COLLECT ITS INFORMATION FROM THE COMPO-

NENT ABOVE.

THEREFORE IT IS RECOMMENDED TO LET DATAFIELDS, WHICH FOLLOWS 

ACTIVATE NEXT, BE ALIGNED BEFORE YOU START COPYING.
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You can for instance save the list in the folder c:\Pcselcad\Symbol\Misc. How-
ever, it is recommended that you create your own folder for saving lists. Click on 
Save when all the settings are correct.

The parts list has now been saved.

Leaving the Create/Edit symbol mode

To make the program leave the Edit/Create symbol mode, you choose File => 
Close.

You now return to the Symbol menu, where you click on Cancel or press <Esc>.

Please note, that the text SYMB, which was flashing on a red background in the 
lower part of the left tool bar, now has disappeared.

ADDING THE PARTS LIST TO THE LIST OF DRAWING HEADERS

The next thing you have to do, is to add the parts list to the list of drawing headers. 
This is done as described in “Adding drawing headers to the List Of Drawing Hea-
ders” on page 815.

You will not be able to use the parts list in your project until you have done this.

See “Insert drawing headers/formulas” on page 585 to see how to insert the parts 
list on a page in a project, as well as how you get the list updated.

USING DATAFIELDS

Which datafields you can use, depends on which type of list you are creating.

You can always use datafields of the type System Data, Project Data and Page 
Data. But apart from these types of datafields, you can only use datafields corre-
sponding to the type of list you are creating.

If you are creating a table of contents, you can make use of datafields of the type 
Table of Contents, but not of the type Parts/Components List.

See which datafields you can use in parts lists in “Parts/components list datafields” 
on page 936.
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CREATING A TABLE OF CONTENTS

When you serrate a table of contents, you follow exactly the same guidelines as for 
designing a parts list.

The only differences — apart from the way you want to set up the lists yourself — 
is that you will need datafields of the type Table of Contents, and that you in the 
Page menu — as mentioned in “Insert drawing headers/formulas” on page 585 — 
will have to set the page function to Table of Contents when you insert the page in 
the project.

In a table of contents you can also insert a data filed displaying the reference 
designation of the page.

To see an example of a table of contents, take a look at A4INDEX, mentioned in 
“Predefined lists” on page 830.

See which datafields you can use in tables of contents in “Table of Contents data-
fields” on page 935.

CREATING A COMPONENTS LIST

You can also create a components list, containing all the components in the pro-
ject. For each component you can place its name and its exact location on the pro-
ject drawings, so that you can use this list to locate any component in the project.

For components lists, you set the page function to Components list, and use 
datafields of the type Parts/Components list. Components lists are created like 
you create parts lists.

See which datafields you can use in components lists in “Parts/components list 
datafields” on page 936.
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CREATING A TERMINALS LIST

You can also create a terminals list, containing a survey of all terminals in the pro-
ject, their names, and which wires enter and exit the terminals. At the same time 
you can let the list contain information about which cables the wires are a part of.

This way you get a survey of which wires shall be connected to which terminals.

To get transferred special information for terminals lists, you have to set the page 
function to Terminals list, and use datafields of the type Terminals list. Apart 
from this, terminals lists are designed following the same guidelines as for parts 
lists.

When you place datafields for terminals lists, you have to be sure whether to click 
on External or Internal in the lower part of the dialog box Datafield. — See 
“Datafields” on page 116.

Correspondingly, when you place terminal symbols on a project drawing, you have 
to be conscious about which connection point of the terminal is the Input and 
which is the Output. Read more about this in “Terminal symbols” on page 236.

See which datafields you can use in terminals lists in “Terminals list datafields” on 
page 938.

CREATING A CABLES LIST

Furthermore you can create a cable list containing a survey of the project cables, 
and from where- and to where they are to be connected.

Set the page function to Cable list, use datafields of the type Cable list, and cre-
ate the list as described for parts lists in the beginning of this chapter.

If you want cable lengths to appear in the cables list, please see “Cable direction 
and Default cable quantity” on page 923 and “The Quantity field in the dialog box 
Component data” on page 175.

See which datafields you can use in cables lists in “Cable list datafields” on 
page 940.
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CREATING A PLC LIST

Finally, you can create a PLC list containing a survey of the inputs and outputs on 
the PLC. At the same time it can contain a description of which functions are 
attached to the various terminals on the PLC. The list can also contain connection 
points labels.

Set the page function to PLC list, use datafields of the type PLC list, and design 
the list as described above.

See which datafields you can use in PLC lists in “PLC list datafields” on page 942.

Datafields and PLC lists

When you are working with PLCs, you 
can place the information about the PLC 
labels and descriptions in two different 
places.

You can click on the Symbols button and 
right-click on the connection point on the 
PLC itself, and fill out the fields Descrip-
tion and Label.

Or you can right-click on the connection 
point on the symbol connected to the ter-
minal in the PLC, and fill out the fields 
Description and Label here.

When you design a PLC list, you there-
fore have to be aware that you have to 
use different datafields depending on 
which of the procedures you use.

If you want to collect the information from the connection point of the PLC, you 
must use the datafields C.descr and C.Label. But if you want to collect the infor-
mation from the connection point of the connected symbol, you have to use the 
datafields Cc.C.descr and Cc.C.label.

Specifying The PLC connected component

When you have selected a symbol on a project page and enter the Component 
data dialog box, you can specify that the selected symbol shall be understood as 
the component connected to the PLC, by selecting The PLC connected compo-
nent.

The two options
mation

Page 827



P

Creating Lists
CREATING A CONNECTIONS LIST

You can also create a connections list containing an overview over the connections 
in the project. It is basically the same as creating a connections list file, which is 
described in “Connections list to file” on page 727.

Set the page function to Connections list, insert datafields of the type Connec-
tions list, and create the list as described above.

See which datafields you can use in connections lists in “Connections list data-
fields” on page 945.

DIAGRAM PAGES - CONTAINING A PARTS OR COMPONENTS LIST

It is possible to create a drawing header for normal diagram pages or ground plan/
mechanical pages, which also contains either a parts or a components list. How-
ever, these lists can only contain information from the page they are placed on.

When you create the list as a part of the drawing header, the list will therefore only 
contain data about the components placed on the page. Furthermore, it is your 
responsibility to ensure that the list is long enough for the components, that are 
going to be placed on the page. This is because new pages will not be inserted, if 
this list is to short.

To create such a drawing header, you must do as described in “How to create a 
List” on page 820 — with the only difference that you make room for diagram draw-
ings in the drawing header.

Specify that the diagram page contains a list

When you, at a later stage, insert a 
such drawing header on a project 
page, you must succeedingly choose 
Settings => Page setup, and select 
Contains a list, and then specify 
whether it is a Components List or a 
Parts List.

Click here i you wish to transfer

the setting to other pages
Automation

age 828



Creating Lists

Auto
LISTS WITH VERTICAL AND HORIZONTAL REFERENCES

If you want the list to contain both vertical and horizontal references to the compo-
nents on the page, do this:

 1) Set the reference system for the page to vertical and horizontal references 
— see “Horizontal and vertical references” on page 434

 2) Set the reference format for symbols to XY reference — as described in 
“Appearance of references” on page 426

Access to List Settings

On diagram pages containing lists, you can also right-click on the page and choose 
List settings, and then specify the list settings, as described in “List settings” on 
page 596. For this type of lists, there will be some limitations on the settings you 
can specify.

CREATING A LIST SYMBOL

You can also create a symbol containing either a parts or a components list. When 
you place this symbol on a diagram page, it will subsequently function as a parts or 
components list for the page — according to the same directions as described in 
“Diagram pages - containing a Parts or Components list” on page 828.

When you create a symbol of this kind, datafields e.t.c. must be placed as 
described in “How to create a List” on page 820. When saving the symbol, you 
must set the Symbol type to Head — see “Saving the parts list” on page 823.

When you have created the symbol, you can place it on diagram pages, just like 
you normally place symbols. Then specify that the page contains a parts or com-
ponents list, as described in “Specify that the diagram page contains a list” on 
page 828. The symbol will then function as a list for the page.

You can find an example on such a symbol with the name Listsymbol.sym in the 
MISC folder.

— See “Access to List Settings” on page 829 also.
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PREDEFINED LISTS

To make things a little easier, some lists have already been defined, which you can 
use in your projects. They are located in the folder c:\Pcselcad\symbol\misc. To 
use them in your project, you can open them and change them, until they fulfil your 
demands — as described in "Changing an already created list/drawing header" 
below.

You can drag pages containing many of these drawing headers into your projects 
from the Sub drawings tab in the Explorer window. These pages are placed in the 
sub folders under the Template folder.

CHANGING AN ALREADY CREATED LIST/DRAWING HEADER

If you want to adapt an already created list/drawing header, you click on the Sym-
bols button, and then on the Symbol menu button.

You have now entered the Symbol menu. Here you find the folder in which the 
drawing header is placed, and then click on the drawing of the drawing header you 
wish to change.

This makes the Edit symbol button appear in the lower-left part of the Symbol 
menu, and you click on it. You now have the option of adapting the chosen drawing 
header to meet your demands.

Saving the drawing header under a new name

In order not to overwrite the already existing drawing header, you start by choosing 
File => Save as and save the drawing header under a new name. For instance you 
can give it the name Newlist.sym. — See how to do this in “Saving the parts list” on 
page 823.

Changing free texts and removing the company logo

Make a Zoom covering the lower-left corner of the list.

Click on the Area button, mark up an area around the cat, and press <Del>. The 
company logo has now disappeared.

Click on Refresh.

To change the company name 
you now click on Texts, and 
then click on the reference 
point for the text PCSCHE-
MATIC A/S, which selects the 
text.

Now press <k> or click inside 
the text field in the texts tool 
bar. Correct the company 
name to your own company name — or to for instance H C Andersen Inc — and 
press <Enter>.

As you will see, the text has now been changed.

Correct the remaining free texts correspondingly.

Please note that you can delete and move texts as you normally do. — Read more 
about this in “Working with selected objects” on page 58.
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The appearance of a selected text, can be changed by clicking on the Text proper-
ties button. This is elaborated in “Specifying text properties / Appearance of text” 
on page 133.

Changing a datafield

Also, you can change the 
inserted datafields on the 
drawing header.

Click on the Texts button, and 
click on the reference point for 
the datafield Printed. Now click 
on the Data button on the 
upper part of the screen, which 
makes you enter the Datafield 
dialog box for the datafield 
Printed.

Another way to enter the dialog 
box Datafield, is to right-click 
on the text/datafield, and 
choose Text properties in the 
pop-up menu.

Here you choose the desired datafield — for instance Designer of the type Project 
data — and type in Designed by: in the Text field in the lower part of the dialog 
box. Click on OK.

As you can see, the datafield Printed has now been replaced by the datafield 
Designer.

Changing a column of datafields of the same kind

When adapting a list to meet your demands, 
you will also need to change an entire col-
umn of datafields of the same type, into a 
row of datafields of another type.

To do this, you activate the Texts button, 
and select the datafields you want to change 
— as described in “Working with selected 
objects” on page 58.

For instance you can click on the Zoom to 
page button, and mark up a window around 
all the datafields in the right-most column. 
Please be careful not to include the column 
header.

— You can tell that a text field is a datafield 
by the red dash line which is displayed 
around datafields.

Click on the Data button — or right-click on the selected datafields — to enter the 
dialog box Datafield for the datafield. Now choose for instance the datafield Price1 
and click OK.

As you can see, all the datafields in the column have been changed to Price1.
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When you have completed your corrections, save the list by clicking on the Save 
button.

OTHER OPTIONS

Company logo on list

If you have created your company logo as a symbol or as a DWG or a DXF file, you 
can place it on your list/drawing header. — See how to do this in “Inserting logos in 
projects” on page 581.

Delete a page with a list on

If you want to remove a page with a list on completely from a project, you have to 
delete the page, on which the list is placed. Therefore, click on the Page menu but-
ton.

In the Page menu you click on the page you want to delete, and choose Delete => 
OK. Click OK once again to close the Page menu dialog box.

The page has now been deleted from the project.

Remove a list from a page

If you want to remove a list, but keep the page on which the list is placed, you first 
click on the tab for the page. Then choose Settings => Page data — or click 
directly on the Page data button in the program tool bar.

In the Page data dialog box you deselect With drawing header, and click on OK.

The list has now been removed form the page.

Please note that the Page function of the page remains unchanged. If the page 
had the page function Parts list, it will still have this page function after the drawing 
header/list has been removed from the page.

Once a page has been created, its page function can not be changed. — Read 
more about this in “Creating a new page” on page 546.

Use states in drawing headers / lists to change language

You can use states in drawing headers / lists to change language for the applied 
texts.

— See “Drawing headers in multiple languages” on page 816.
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CREATING UNIT DRAWINGS

If a component consists of several different parts, you can specify which parts it 
consists of in a unit parts list. This unit parts list can also contain a unit drawing, 
displaying the parts of the component, but this is not mandatory.

When you use an extended parts list (please refer to “Specifying from where to col-
lect components” on page 598), the program examines for which components a 
unit drawing have been created. In the parts list, the component will then be repre-
sented by what you specified in the unit parts list.

Unit drawings can consist of more than one page.

CREATING A UNIT PARTS LIST

The procedure for designing the unit parts list, is the same as for designing an ordi-
nary parts list. So, if you want to design your own unit parts list, you should do this 
now, as specified in “Creating Lists” on page 818. Alternatively you can use an 
already created parts list.

However, you have to do a little more before you can use it as a unit parts list.

INITIAL PREPARATIONS

The first thing you have to do, is to click on the New document button.

Here you must first make sure that the page is a vertical A4 page, as described in 
“Setting up the page to vertical A4 format” on page 808. — Also make sure that the 
page function is set to Normal.

To place the unit parts list on the page, you now choose Settings => Page data 
and right-click on the field below Add drawing header. In the pop-up menu, you 
then click on Add drawing header.

You now enter the Symbol menu, where you can select one of the symbols men-
tioned below in the folder MISC.

Click on your own parts list, or choose the symbol UNITLI, and click OK.

You have now placed the unit parts list on the page.

THIS CHAPTER DESCRIBES

— CREATING A UNIT PARTS LIST ..................................................................p. 833

— INITIAL PREPARATIONS..............................................................................p. 833

— ASSIGNING AN ARTICLE NUMBER TO THE UNIT PARTS LIST.........................p. 834

— CREATING A UNIT DRAWING .....................................................................p. 834

— UNIT DRAWING FROM ALREADY CREATED SYMBOL....................................p. 835

— UNIT PARTS LISTS WITHOUT UNIT DRAWINGS.............................................p. 835

— CREATING UNIT PARTS LISTS FROM A DRAWING OF AN ENTIRE COMPONENT p. 835

— CORRECTING A UNIT DRAWING/UNIT PARTS LIST ........................................p. 836

— INSERTING UNIT DRAWINGS IN PROJECTS ..................................................p. 836
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ASSIGNING AN ARTICLE NUMBER TO THE UNIT PARTS LIST

To be able to use the page as a unit parts list, you have to assign an article number 
to the page.

Therefore, right-click somewhere on the page, and choose Page article data. 
Assign a Name and an Article no to the page, and fill out the Type and Function 
fields as well. Click on OK.

You determine the article number of the page yourself, and in the following this is 
the number you use, when you connect a symbol to the unit drawing.

CREATING A UNIT DRAWING

You are now ready to create the unit drawing. In this example you could for 
instance draw three rectangles, which illustrates the parts the component is made 
of. Also, you could place the page title on the top of the page.

If you are not sure how to do these things, please refer to “Lines” on page 72 as 
well as “Project and Page data” on page 125.

Now place the symbols (position numbers), in which you in the Component data 
specify the information, which is necessary for the parts on the unit drawing.

To do this, click on the Symbols button and then on the Symbol menu button.

Find the symbol Posno1, which is created as a circle, in the folder MISC, and dou-
ble-click on the symbol.

You then get the symbol in the cross hairs, and place a symbol close to each of the 
three rectangles.

When you place a symbol, you enter the Component data menu, where you type 
in 1 in the Name field for the first symbol, and 2 and 3 in the Name field for the two 
following symbols. Type in the remaining component data yourself, or fetch them by 
clicking on the Database button. Click on OK when the information have been filled 
out correctly.

If you are not asked about the component data automatically, just right-click on the 
symbols one by one, and fill out the information as described. — Read more about 
this in “Pointer/Screen” on page 906.
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If you do not want a circle around the position numbers, you can use the symbol 
Posno2 in stead of Posno1.

Saving the unit drawing

You have now finished designing your unit drawing/parts list.

To save it, you choose File => Save unit as.

When you have confirmed that you wish to save the project as a unit drawing, you 
are asked to specify Page data (for instance type in the name Test), and then enter 
a dialog box, where you for instance type in the file name test.std and click OK.

The program now knows that the page is a unit drawing/parts list.

Therefore you can transfer the information from the symbols to the unit parts list by 
choosing Lists => Update Unit Drawing.

Save the unit drawing again.

Then choose File => Close.

The unit drawing is now ready to be used.

UNIT DRAWING FROM ALREADY CREATED SYMBOLS

If you already had created the parts on the unit drawing as symbols, you can place 
them on the unit drawing as well. — Please refer to “Creating Symbols” on 
page 761 to see how to create symbols.

Now place the symbols for the parts on the unit drawing.

Then right-click on the symbols — one by one — on the drawings of the parts and 
choose Component data. In stead of the symbol name, you then type in the num-
ber you want the part to have on the drawing and in the unit parts list.

In you have not assigned component information to the symbols, you can now type 
in this information, or find them clicking on Database.

Save the unit drawing as described in “Saving the unit drawing” on page 835.

UNIT PARTS LISTS WITHOUT UNIT DRAWINGS

If you do not want any drawings on your unit parts list, this is also an option. Still, 
you have to create a symbol for each part, in order to specify which parts the com-
ponent is made of.

Here you may use the symbols Posno1 or Posno2, as described above, or you 
can design a symbol for this very purpose yourself.

To these symbols you add the necessary component data, as described above.

In stead of the symbol name, you type in the number you want the part to have on 
the unit parts list.

CREATING UNIT DRAWINGS USING A COMPONENT DRAWING

If you have a drawing of the entire component, you can load it as a symbol from the 
Symbol menu.

If the drawing is in the DWG/DXF format, please refer to “Importing DWG/DXF files 
as symbols” on page 732 to see how to import the drawing via the Symbol menu.
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In stead of drawing each individual part, you now place some new symbols (Pos-
no1 or Posno2), each pointing at an individual part on the drawing.

For each of these symbols you add the relevant article data, as described above.

The crucial part for how the unit parts list is filled out, is exclusively which informa-
tion is attached to the symbols placed on the page. The drawing itself is no more 
than an illustration.

If you want to place other relevant information on the page — for instance about 
expenses — you just place additional symbols on the page containing this informa-
tion.

CORRECTING A UNIT DRAWING/PARTS LIST

In order to change a unit drawing, you choose File => Open Unit.

Then you get the possibility to choose between the available unit drawings.

Pick one of them, perform the changes, and save the unit drawing as mentioned 
earlier.

INSERTING UNIT DRAWINGS IN PROJECTS

Please read “Inserting Unit Drawings” on page 625 to see how to insert a unit 
drawing in a project.
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CREATING TEMPLATES

ON TEMPLATES

In Automation you can create templates for all types of project pages, as well as 
for full projects.

Each time you create a new project, or a new project page, you can therefore start 
out on the basis of an already created template.

Using templates on networks

Using templates enables you to let one person create the company templates, and 
make these templates available for all users via the network. This complete set of 
company templates therefore only needs to be placed at one location, and can be 
maintained by one — or more — persons.

The other users of Automation therefore does not have to be familiar with creating 
drawing headers (including lists, tables of contents and chapter tabs), or how to 
specify list settings.

It is therefore easy to achieve a standard appearance of Automation projects. It is 
also simple to make changes in the complete set of template projects and pages, 
because these only have to be changed at one place.

THIS CHAPTER DESCRIBES

— ON TEMPLATES........................................................................................p. 837

— CREATING PAGE TEMPLATES - VIA THE TEMPLATE EDITOR .........................p. 838

— CREATING PAGE TEMPLATES - VIA THE SUBDRAWINGS TAB .......................p. 839

— CREATING PROJECT TEMPLATES...............................................................p. 840

— CREATING TEMPLATES BASED ON EXISTING PROJECTS...............................p. 842

— CONVERTING STANDARD PROJECTS TO PROJECT TEMPLATES....................p. 842

— EDITING EXISTING TEMPLATES ..................................................................p. 843

— DELETING A TEMPLATE .............................................................................p. 843

— TEMPLATE FOR CLICKING THE NEW DOCUMENT BUTTON ............................p. 844

— TEMPLATES IN Automation...................................................................p. 844
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CREATING PAGE TEMPLATES — VIA THE TEMPLATE EDITOR

In Automation you can create template pages for all types of project pages. The 
following describes how to create a template page for a normal diagram page via 
the Template editor. — See also “Creating Page templates — via the SubDra-
wings tab” on page 839.

To create a template for a diagram page, do the following:

 1) Choose File => New or click the New document button, and you enter the 
dialog box New:

 2) Click on the tab Normal Pages, click on Template in the right-hand side — 
to create a new template page —, click for instance on Blank Page, and click 
OK.

 3) You now enter the Template editor, from where you create new templates: 
Click on the Page data button, if you wish to place a drawing header on the 
page.

 4) The tab Page data from the dialog box Settings is displayed: Choose a 
drawing header at the lower part of the tab, type in page data if necessary, 
and click OK.

 5) If you wish to draw/place objects on the page, do this now — exactly like 
when you normally work in Automation.

NEW TEMPLATES FOR LISTS AND CHAPTER DIVIDERS

IF YOU WISH TO CREATE A NEW TEMPLATE FOR E.G. A TERMINAL LIST PAGE, 
SELECT THE TAB TERMINALS LISTS IN STEAD.

IF YOU ARE CREATING A NEW CHAPTER DIVIDER, CLICK ON THE TAB DIVIDER.

2a) Click on the tab Normal Pages 2b) Click on Template

2c) Click on Blank Page 2d) Click OK
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Here you can for instance draw the phases on the upper part of the page.

You can also place existing sub drawings on the page, as described in “Sub 
drawings” on page 289.

 6) Click on the Save button, and you enter the dialog box Save as, where you 
type in a name of the template, and click Save.

 7) Choose File => Close, and you leave the Template editor, and return to 
normal Automation mode.

CREATING PAGE TEMPLATES — VIA THE SUBDRAWINGS TAB

When you are working in a single-page project, 
you can save it as a template by right-clicking 
on one of the folders in the Template folder, 
and choose Save as.

You then enter the Save as dialog box, where 
you select which folder to save the template in, 
assign a name to the template, and click Save.

Please note that the program automatically 
assigns the extension .std to the template.

If there is a drawing header on the page, the 
template will be understood as a full page. If 
not, it will behave as a normal sub drawing — 
see “Sub drawings” on page 289.

IN PAGE TEMPLATES THE FOLLOWING IS MEMORISED

— ALL CREATED PAGE DATA DATAFIELDS, AS WELL AS THEIR CONTENTS (IF 

ANY)

— THE REFERENCE SYSTEM FOR THE PAGE

— FOR LISTS: THE SPECIFIED LIST SETTINGS — SUCH AS VENDOR AND 

REPETITIONS

— ALL OTHER PAGE SETTINGS
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CREATING PROJECT TEMPLATES

When you wish to create templates for full projects, enter the Template editor, and 
create a full project as described in “Creating Page templates — via the Template 
editor” on page 838.

In template projects you can place anything you need in a project:

When creating project templates, you are free to insert the already created page 
templates in the project template.

When you are working for different customers, you can create different project tem-
plates for each individual customer. You can also create project templates contain-
ing lists for different component vendors.

— Please read “Creating a template based on an existing project” on page 842 to 
see how to create a template based on an existing project.

— PLEASE NOTE THAT THE TEMPLATE PROJECT MUST BE CREATED FROM 

THE TAB PROJECTS IN THE DIALOG BOX NEW.

Table of

Pages for drawings

Partslists
Componentslists

Terminallists
Cableslists

PLClists

Chapter dividers

Front

contents

page

Template project
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— Please refer to “Converting Standard projects to Project templates” on page 842 
to see how to use standard projects from previous versions of Automation as tem-
plates in this version.

IN PROJECT TEMPLATES THE FOLLOWING IS MEMORISED

— ALL PAGE SETTINGS FOR EACH INDIVIDUAL PROJECT PAGE, AS 

DESCRIBED IN “In Page templates the following is memorised” on 
page 839

— ALL CREATED PROJECT DATA DATAFIELDS, AS WELL AS THEIR CONTENTS 

(IF ANY)

—THE DEFINED REFERENCE DESIGNATIONS

— THE APPLIED COMPANY LOGO

— SETTINGS FOR TEXT PROPERTIES

— SETTINGS FOR TEXT VISIBILITY

— LAYER SETTINGS

— ALL OTHER PROJECT SETTINGS
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CREATING A TEMPLATE BASED ON AN EXISTING PROJECT

To create a template based on an existing project, do the 

following:

 1) In the Windows Explorer: Right-click on the project 
file, and click on Cut — or click on Copy if you wish 
to keep the original project.

 2) Open the folder Pcselcad\Standard\Template: In 
this folder exists a folder for each type of templates.

 3) Open the folder for the type of template you wish to 
create — in this case the Project folder —, by dou-
ble-clicking on the folder.

 4) Right-click inside the folder, and choose Paste.

 5) The copied project is now inserted in the folder: Right-click on the project file, 
and choose Rename.

 6) You can now edit the name of the file: Replace the extension .pro with the 
text .std, and press <Enter>.

You have now created a template based on an existing project. If you wish to edit 
the template, you can do this as described in “Editing templates” on page 843.

Correspondingly, you can save existing projects, containing one page only, as page 
templates. Please be careful to save the project page templates in the correct fold-
ers.

CONVERTING STANDARD PROJECTS TO PROJECT TEMPLATES

The projects called standard projects in version 4.0 (and previous versions) of 
Automation can be used as templates in subsequent versions.

To do so, you must follow the procedure described in “Creating a template based 
on an existing project” on page 842.

Here you find

the templates
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EDITING TEMPLATES

 1) Choose File => New or click the New document button.

 2) In the dialog box New: Click on the tab on which the template is placed.

 3) Click on Template in the right-hand side of the dialog box.

 4) Right-click on the template, and click on Open.

 5) You now enter the Template editor, where you edit the template, and save it 
by clicking Save.

 6) Choose File => Close to leave the Template editor.

DELETING A TEMPLATE

 1) Choose File => New or click the New document 
button.

 2) In the dialog box New: Click on the tab on which 
the template is placed.

 3) Right-click on the template, and click on Delete.

 4) Click OK to leave the dialog box.

THE PAGE TYPE FIELD BLINKS BLUE IN THE 

TEMPLATE EDITOR

WHEN YOU ARE IN THE TEMPLATE EDITOR, 
THIS IS INDICATED BY THE PAGE TYPE FIELD, 
WHICH BECOMES BLUE AND STARTS BLINK-

ING, IN THE LOWER-LEFT CORNER OF THE 

SCREEN.
Blinks green in

the Template

editor
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TEMPLATE FOR CLICKING ON THE NEW DOCUMENT BUTTON

When you click on the New document button, you enter a project consisting of a 
single blank page.

However, you can create your own template project, which is used as template, 
when you click this button:

 1) Create the project that you wish to use as project template.

 2) Save the project in the folder Pcselcad\Standard\Template.

 3) In the Windows Explorer: Right-click on the project file, select Rename, cor-
rect the file name to filenew.std and press <Enter>.

Then project is now applied as template when clicking the New document button.

TEMPLATES IN Automation

Quite a few templates have been 
created in Automation. When you 
open the Templates folder in the 
SubDrawings tab in the Explorer 
window, just let the mouse rest an 
instance over a template name. 
This gives you a hint telling you 
what the template contains.
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In this section you get information about installing 
and updating program modules, and how to adapt 
the system to your needs.

You can read about:

- Installing new Modules........................................p. 847

- Automatic program update ...............................p. 852

- Adapting the System to your needs.................p. 854

- User Defined short-cuts .....................................p. 856

- Colors.....................................................................p. 860

- Tanking licenses ...................................................p. 863

- Reducing Repetitive Strain Injuries....................p. 869

In the appendix “Settings” on page 895 you can see 
how to change settings in the Settings menu.

Updating, Modules and Licenses
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MODULES AND SCRIPTS

This chapter gives you an overview over which modules you can install and unin-
stall in Automation, and gives a short description of what it means to apply scripts.

WHAT CAN YOU INSTALL

In Automation you find the extra tools in the 
Tools menu.

To use these tools, you must first install them as 
described in “How to install and uninstall” on 
page 849.

So, if you do not have as many options as dis-
played in the figure to the right, this is because 
some of these modules have yet not been 
installed.

Below you can get an overview over the different 
modules.

THIS CHAPTER DESCRIBES

— WHAT YOU CAN INSTALL .......................................................................... p. 847

— HOW TO INSTALL AND UNINSTALL............................................................. p. 849

— RE-INSTALLING OR UPDATING MODULES ................................................... p. 849

— STARTING A MODULE ............................................................................... p. 850

— SCRIPTS ................................................................................................. p. 851

TOOL DESCRIPTION

RENAME SYMBOLS DESCRIBED IN “Rename selected symbols” on page 322.

DATABASE DESCRIBED IN THE PCSCHEMATIC DATABASE MANUAL.

SYMBOL DOCUMENTA-

TION

FOR AUTOMATIC GENERATION OF SYMBOL DOCUMENTATION.
DESCRIBED IN THE PCSCHEMATIC TOOLS MANUAL.

GRAPHICAL TERMINAL 

PLAN

FOR AUTOMATIC GENERATION OF GRAPHICAL TERMINAL PLANS.
DESCRIBED IN THE PCSCHEMATIC TOOLS MANUAL.
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GRAPHICAL CABLE 

PLAN

FOR AUTOMATIC GENERATION OF GRAPHICAL CABLE PLANS.
DESCRIBED IN THE PCSCHEMATIC TOOLS MANUAL.

GRAPHICAL CONNEC-

TION PLAN

FOR AUTOMATIC GENERATION OF GRAPHICAL CONNECTION PLANS. 
DESCRIBED IN THE PCSCHEMATIC GRAPHICAL CONNECTION 

PLANS MANUAL.

EDIT SYMBOL DATA-

FIELDS

MODULE WHICH GIVES YOU THE OPTION OF EXPORTING DATA FOR 

ALL COMPONENT NAMES WITH ATTACHED SYMBOL DATAFIELDS IN 

THE ACTIVE PROJECT TO EXCEL. THE SYMBOL DATAFIELDS CAN 

THEN BE EDITED IN EXCEL AND CAN SUBSEQUENTLY BE IMPORTED 

BACK INTO THE PROJECT.

CONVERT FILES FROM 

VER11 OR OLDER

MODULE FOR CONVERTING PROJECTS CREATED IN VERSION 11 

AND PREVIOUS VERSIONS TO UNICODE. DESCRIBED IN “Unicode” 
on page 10.

LIST COMPARE MODULE THAT CAN COMPARE PARTS OR COMPONENTS LISTS 

FROM TWO DIFFERENT PROJECTS.

TEXT TRANSLATOR FOR TRANSLATING TEXTS IN PROJECTS. DESCRIBED IN THE 

PCSCHEMATIC TOOLS MANUAL.

GENERATE PROJECT 

FROM SELECTED 

OPTIONS

DESCRIBED IN “Projects with selectable options” on 
page 578.

EXPORT/IMPORT CLIP-

PROJECT

THIS MODULE CAN BE DOWNLOADED AT www.pcschema-
tic.com/EN/download-menu/other/download-other.htm.

DOWNLOAD A TUTORIAL AT www.pcschematic.com/manuals.

EXPORT/IMPORT 

RAILDESIGNER

THIS MODULE CAN BE DOWNLOADED AT www.pcschema-
tic.com/EN/download-menu/other/download-other.htm.

SINGLELINE DIAGRAM FOR AUTOMATIC GENERATION OF SINGLE LINE DIAGRAMS.

NET NAVIGATOR SEE “Net Navigator” on page 223.

PANELROUTER THE PANELROUTER CAN AUTOMATICALLY DRAW THE CONNEC-

TIONS BETWEEN THE CONNECTION POINTS ON THE MECHANICAL 

SYMBOLS ON MECHANICAL PAGES, BASED ON THE INFORMATION 

SPECIFIED ON THE DIAGRAM PAGES.
THE PANELROUTER IS DESCRIBED IN A SEPARATE MANUAL, WHICH 

YOU CAN DOWNLOAD AT www.pcschematic.com/manuals.

DWG/DXF MAP SET-

TINGS

FOR SETTING UP PARAMETERS FOR DWG/DXF IMPORT/EXPORT. 
DESCRIBED IN THE PCSCHEMATIC TOOLS MANUAL.

CREATE VARIABLE LIST 

IN (SUB)DRAWING

DESCRIBED IN “Sub drawings” on page 289.

PROJECT GENERATOR DESCRIBED IN THE PROJECT GENERATOR MANUAL.

MOUSE CHASING SYS-

TEM

FOR REDUCING REPETITIVE STRAIN INJURIES — SEE “Preventing 
Repetitive Strain Injuries” on page 869.

PANEL BUILDER MODULE FOR BUILDING PANELS AUTOMATICALLY. DESCRIBED IN 

THE MINI MANUAL PANEL BUILDER - TUTORIAL, WHICH CAN BE 

DOWNLOADED AT www.pcschematic.com/manuals.

SCRIPTS SEE “Scripts” on page 851.

TOOL DESCRIPTION
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HOW TO INSTALL AND UNINSTALL

To install or uninstall modules choose File => Modules, and you enter the Mod-
ules dialog box:

Here you get a survey of which modules can be installed, as well as which mod-
ules are installed in your case.

In a net installation you can therefore see which modules can be installed on all of 
the PC’s on the net, and which are installed on your machine. Opposed to this, the 
settings you see under Settings => Tools are individual settings for your PC only.

By clicking on a module on the list, you can install or uninstall the module by click-
ing on Install or Uninstall respectively.

If you have no need for converting Automation DOS files to Automation Windows 
files, you can click on Symbol conversion, TYP to SYM, and then click Uninstall.

Clicking on Install all will install all modules on your PC.

RE-INSTALLING OR UPDATING MODULES

If you have uninstalled a module, you can install it again at any time, with no harm 
done.

If you need to update a module, you do not have to uninstall the module first. Just 
click on the module name, and click Install.
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STARTING A MODULE

When a module is installed, a line is 
inserted in the dialog box Settings => 
Tools, and maybe also an extra button in 
the toolbar.

The module can then be started by first 
clicking on Tools, and then on the name 
of the module.
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SCRIPTS

You can create your own scripts from the build-in interface for COM/OLE Automa-
tion.

The documentation for how to create your own scripts this can be downloaded at 
www.pcschematic.com under Download => Modules, drivers etc. At 
www.pcschematic.com/articles you can read a little more about the options.

When you choose Tools => Scripts, you enter the Scripting dialog box. (You may 
need to install Scripts under Files => Modules first). In this dialog box you find a 
list of scripts, which you can choose to execute.

In the dialog box Scripting you can execute, add and edit scripts:

If you select Include in Tools menu, you can subsequently execute the selected 
script directly from the Tools menu.

NO UNDO ON SCRIPTS

PLEASE NOTE THAT IT IS NOT POSSIBLE TO UNDO THE EXECUTION OF A 

SCRIPT. SO, AS A PRECAUTION, PLEASE SAVE THE PROJECT, AND SAVE IT 

AGAIN UNDER A NEW NAME, BEFORE EXECUTING THE SCRIPT.

Short description of the selected script
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UPDATE AND AUTOMATIC INFORMATION

This chapter describes how you can update Automation via the internet, when 
new updates are created for the program version you are using. It is also described 
how you, via the internet, can receive information automatically from PCSCHE-
MATIC A/S about Automation.

UPDATING VIA THE INTERNET

When you have access to the internet from your PC, you can get Automation to 
examine automatically whether new updates exist for the version of the program, 
that you are working on. To do this, you must first choose Settings => System/
License.

In the lower-left corner of the System tab you 
can then choose:

• 21.XX update: Here you automatically 
receive information when updates exist 
for the version you are using.

• Newer version: Here you automatically 
receive information when a new version 
is released.

• Information: Here you automatically get 
new information from PCSCHEMATIC A/
S — see “Information from PCSCHEMA-
TIC A/S via the internet” on page 853. When this automatic check is selected 
and new information is released, an information window will appear when you 
start the program. This will only take place the first time a new piece of infor-
mation is released.

• Scan for releases: Here you can manually activate a search for new updates 
and new versions.

When new updates exist, this is displayed below the relevant checkbox. A button 
will also be displayed to the right of the checkbox. When you click this button, you 
enter PCSCHEMATIC’s website, from which you can download the update.

Icon for updates

When you have activated the automatic check, an icon is displayed in the lower-
right corner of the screen. When you click the icon, you enter the dialog box Set-
tings => System/License on the System tab, as which is described above.

If you do not wish to see this message again, you can select Do not show this 
message again. — When a new patch is available, the message will pop up again.

THIS CHAPTER DESCRIBES

— UPDATING VIA THE INTERNET ....................................................................p. 852

— INFORMATION FROM PCSCHEMATIC A/S VIA THE INTERNET....................p. 853
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When you right-click on the icon, a menu is displayed, which gives access to 
PCSCHEMATIC’s website, from which you can download the update.

INFORMATION FROM PCSCHEMATIC A/S VIA THE INTERNET

If you have access to the internet on your PC, you can make Automation examine 
automatically whether important information about the program have been 
released. This information could e.g. be:

• If a critical error have been reported, which can cause loss of data. This way 
you can get this information the same moment the error is detected, along 
with a work-around on how to avoid the problem until the error is corrected.

• Information on changed release dates.

... as well as other information of this character.

Activating automatic information

The function can be set in the dialog box Set-
tings => System/License on the System tab, by 
selecting Information in the lower-right corner of 
the dialog box, as displayed in “Updating via the internet” on page 852.

If you click the button to the right of the check box, a list of the latest pieces of infor-
mation are displayed.

You will only receive information from the program version you are working in.

Icon for Information

When the function is activated, an icon is displayed in the 
lower-right corner of the screen. When you click the icon, a list 
of the latest pieces of information are displayed.

Automatic status popup

When you right-click on the icon and 
choose Automatic status popup, a pop-up 
window is displayed, when new information 
exist. If this function is not activated, the 
icon will start blinking when new information 
exist.
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ADAPTING THE SYSTEM TO YOUR NEEDS

In Automation you can do quite a few things to adapt the system to your needs, in 
order to work faster and in a more appropriate way for you.

DESCRIBED IN OTHER CHAPTERS

You will find a summary of some of these options below:

ADDITIONAL POSSIBILITIES

Apart from the possibilities mentioned above, you will find the following options:

Favorites

When you right-click anywhere in a project, it is now possible to choose Favorites.

THIS CHAPTER DESCRIBES

— WHERE YOU FIND THESE OPTIONS DESCRIBED...........................................p. 854

— ADDITIONAL OPTIONS ...............................................................................p. 854

OPTION PAGE

DOCKING THE PROGRAM WINDOWS 23

INSTALLING EXTRA MODULES 847

DEFINE YOUR OWN SHORT-CUT KEYS 856

CHANGE THE SYSTEM COLORS 860

OTHER PROGRAM SETTINGS 895
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This gives you the option to specify some favorite functions:

These functions are activated when you press down <Shift>, <Ctrl> or <Alt> and 
right-click on an object.

Specify character set

Under Settings => System/License on the System tab, you can specify which 
character set shall be applied on the project pages.

The options are here Standard, Latin2, Russian, Baltic and Polish.

The information of the chosen character set is included in each project file sepa-
rately.

More character sets will be created on request.
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SHORT-CUT KEYS

In Automation you will find most commands accessible through short-cut keys. It 
is also possible to define your own short-cut keys in the program — as described in 
“User defined short-cut keys” on page 858.

FUNCTION SHORT-CUT KEY FUNCTION SHORT-CUT KEY

AREAS <A> PANELBUILDER <SHIFT+P>

ARTICLE <V> PANELROUTER <SHIFT+R>

AUTO COMMAND 

CHANGE

<SHIFT+Z> PRECEDING <F6>

CHANGE STATE <SHIFT + 
SPACEBAR>

PREVIOUS PAGE <PAGEUP>

CIRCLES / ARCS <C> PREVIOUS SELECTED 

PAGE

<F10>

COMPONENT 

GROUPING

<CTRL+F7> PRINT <CTRL+P>

COMPONENT WIZ-

ARD

<W> RECTANGLE <CTRL+F>

COORDINATES <CTRL+ I> REDRAW <CTRL+G>

COPY <CTRL+C> REPLACE <CTRL+H>

DATABASE <D> REPLACE SYMBOL <F4>

DELETE <DEL> ROTATE 90O <SPACEBAR>

DRAW ON/OFF <INSERT> ROUTER, ACTIVATE <R>

ELEVATION ON/OFF <F11> SAVE PROJECT <CTRL+S>

FIND <CTRL+F> SELECT ALL <CTRL+A>

FIND ARTICLE <V> SELECT COMPONENT <SHIFT+C>

FIND NEXT <F3> SLANTED LINES <CTRL+K>

FIND TYPE <B> SNAP, FINE <SHIFT>

GO TO: AVAILABLE 

SYMBOLS

<F9> STRAIGHT LINES <CTRL+R>

GO TO: COMPO-

NENTS

<SHIFT+F9> SURVEY WINDOW ON/OFF <F12>

GO TO: SYMBOLS 

FOR COMPONENT

<ALT+F9> SYMBOL MENU <F8>

INSERT POTENTIAL <P> SYMBOLS <S>

KEYBOARD ENTRY <K> TEXTS <T>

LINES <L> TYPE <B>

THE SHORT-CUT KEYS
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Please note that using lower or upper case letters effects the short-cut function. 
Thus <Shift+c> will not activate the Circles command. Whether CapsLock is active 
makes no difference.

Right-clicking

To get further functions/options when working with the program, use right-click. For 
example you can right-click on a symbol, the pickmenu or on the entire page. 
Right-clicking in many cases causes a menu to appear, a menu containing func-
tions and/or data dealing with whatever you are clicking on.

When in doubt, you can always try right-clicking.

Buttons with double functions

If you — without clicking — let the mouse rest for a moment on a button, a hint dis-
playing the function of the button will be displayed in a tiny yellow rectangle below 
the button. If there is a plus (+) in front of the hint, this tells you that the button con-
tains another function as well. This other function will be activated by pressing 
down <Ctrl> while clicking on the button.

For instance click on the Symbol button on the top part of the screen, and then let 
the mouse rest on the Symbol menu button on the left hand side of the screen. A 
yellow rectangle appear in which it says +Symbol menu, indicating you have got 
two options: You either just click the button, which brings you into the symbol 
menu, or if you press down <Ctrl> while clicking the button, you go directly into the 
database.

Or, experiment with the other buttons, and find out for yourself which other func-
tions are included in the program buttons.

Faster short-cuts for activating the Pencil

— See “Short-cuts for activating the Pencil” on page 33.

MOUNTING ASSIS-

TANT

<SHIFT+M> UNDO <CTRL+Z>

NET NAVIGATOR <N> VIEW ARTICLE DATA <CTRL+F2>

NEXT <F5> VIEW CONDUCTING <SHIFT+F2>

NEXT PAGE <PAGEDOWN> WRITE TEXT <K>

NEW DOCUMENT <CTRL+N> ZOOM <Z>

OBJECT LISTER <F7> ZOOM IN <CTRL+HOME>

ON-LINE MANUAL <F1> ZOOM, MOVE / PAN <CTRL>+ARROW 

KEYS

OPEN <CTRL+O> ZOOM OUT <CTRL+END>

PAGE MENU <SHIFT+P> ZOOM TO PAGE <HOME>

FUNCTION SHORT-CUT KEY FUNCTION SHORT-CUT KEY

THE SHORT-CUT KEYS
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USER DEFINED SHORT-CUT KEYS

In Automation you can design your own short-cuts. This is done by entering Set-
tings => Shortcuts.

You then see the following dialog box:

In this dialog box you can create short-cut keys for all commands in Automation. 
The predefined short-cut keys can also be changed.

In order to change or create a short-cut key, you do like this:

 1) Choose the menu where the command is located

 2) Choose the command

 3) Click in the Press new shortcut key field and type in the new short-cut key

 4) Click on Assign

The short-cut key is not assigned to the command before you click Assign.

If a short-cut key is already defined for a command, the short-cut key is displayed 
in the Current key field.

If you want to remove a short-cut key, you choose the command and click Remove.

Click on Close when you have finished your changes.

Choose Menu (1) Choose Command (2)

Type in New short-cut key (3) The Current short-cut key
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Reset all

When you click Reset all in the lower-right corner of the dialog box, all short-cut 
keys are reset to their default values, which they were assigned when the program 
was installed. — See “Short-cut Keys” on page 856.

Displaying and printing short-cuts

When you click Show all, all short-cut keys are displayed in a list, which you can 
print by clicking on Print, or save it by clicking Save.
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COLORS

In Automation you can both create custom colors and set the system colors as 
you like.

To set the colors in Automation, click Settings => Basic settings.

In the dialog box Basic settings you can choose whether to edit System colors of 
Custom colors.

System colors

If you click on System you enter the following dialog box:

Here you specify which elements you want to change the color settings for.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO SET CUSTOM AND SYSTEM COLORS.
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You have the following options:

Click on Colors when you have chosen which color settings you want to change.

In the dialog box Color you either click on a Basic color or a Custom color and 
click OK.

OPTION REMARKS

BACKGROUND THE BACKGROUND COLOR OF THE SCREEN. IF BLACK BACKGROUND IS 

CHOSEN UNDER SETTINGS => POINTER/SCREEN, THE BACKGROUND 

COLOR CANNOT BE DETERMINED HERE.

DOTTED GRID THE COLOR OF THE DOTS IN DOTTED GRID.

SQUARED GRID THE COLOR OF THE LINES IN SQUARED GRID.

SQUARED GRID-10 HERE YOU CAN DETERMINE THE COLOR OF EACH TENTH LINE IN THE 

SQUARED GRID, FOR INSTANCE TO HIGHLIGHT THESE LINES.

HELP OBJECTS THE COLOR OF REFERENCE POINTS, THE CENTRE OF CIRCLES, THE 

CURRENT PATH NUMBERS, THE DISPLAYING OF PAGE MARGINS, THE 

APPEARANCE OF THE ORIGO E.T.C. IN SHORT: EVERYTHING WHICH IS 

HELP INFORMATION ON THE PAGES, BUT ARE NOT DISPLAYED WHEN 

YOU PRINT OUT PROJECT PAGES.

OBJECT SELEC-

TION

WHEN YOU CHOOSE AN OBJECT IN Automation, THIS IS INDICATED 

BY A COLORED BOX COVERING THE OBJECT. IT IS THE COLOR OF THIS 

BOX YOU DETERMINE HERE.

CROSS HAIRS HERE YOU DETERMINE THE COLOR OF THE CROSS HAIRS. PLEASE 

NOTE, THAT YOU HERE HAVE TO CHOOSE THE COLOR COMPLIMENTARY 
TO THE COLOR YOU WANT TO SEE ON THE SCREEN.

GRADIENT BARS IF YOU HAVE SELECTED GRADIENT TOOLBARS UNDER SETTINGS => 

POINTER/SCREEN (SEE “Pointer/Screen” on page 906), YOU CAN 

HERE SPECIFY THE COLORS FOR THIS. THE THREE MOST APPLIED 

COLORS (FROM WINDOWS 2000, WINDOWS XP AND WINDOWS VISTA) 
ARE PREDEFINED UNDER USERDEFINED COLORS IN THE DIALOG BOX 

COLOR.
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CUSTOM COLORS

When you in Settings => Basic settings click on Custom at the bottom of the dia-
log box, you get the option of defining your own colors, which subsequently will be 
easily accessible anywhere you need to select colors in the program.

Create a new color

This is how to create a new color:

The created color is displayed under Custom colors, when you select new colors 
using the color field in the toolbar for lines. — See “Line color: F” on page 77.

It is possible to create 16 custom colors.

1) Choose a color

2) Choose

3) Click here

4) Click OK

luminance
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TANKING LICENSES

WHAT IS LICENSE TANKING

When you are using a net license key on Automation, you have the option of tank-
ing licenses. This meaning, that you have the option of giving away a license from 
the PC on which the key is mounted, to a PC which has no license key. This can be 
done for a period of time between 10 minutes and 30 days.

This gives this PC the possibility of working independent from the net, which the 
PC with the license key is attached to.

Licenses can be tanked in two ways:

 1) By tanking a license to a PC which is on the net for the moment — see 
“Transferring licenses by License tanking” on page 864.

 2) By transferring a license file to a PC which is not on the net — see “Transfer-
ring licenses via license tanking” on page 865.

LIMITING HOW MANY LICENCES TO TANK

It is possible to limit how many licenses, that can be tanked from a license key, so 
that e.g. only 3 out of 5 licenses can be tanked. The function makes sure that there 
is always a predefined amount of licenses available in the company. The license 
keys can only be programmed by PCSCHEMATIC A/S.

It is also possible to log the license tanking, so that the administrator can see who 
is tanking the licenses.

Please contact your local support service for further information about this.

THIS CHAPTER DESCRIBES

— WHAT IS LICENSE TANKING .......................................................................p. 863

— LIMITING HOW MANY LICENCES TO TANK....................................................p. 863

— TRANSFERRING LICENSES BY LICENSE TANK..............................................p. 864

— TRANSFERRING LICENSES BY LICENSE FILE ...............................................p. 865

— STATUS BUTTON FOR TANK STATUS ..........................................................p. 868

— SUPERPRO MONITOR ...............................................................................p. 868

NET LICENSE KEY REQUIRED (FLOATING VERSION)

TO MAKE USE OF TANKING LICENSES, THE SYSTEM, WHICH GIVES AWAY THE 

LICENSE, MUST HAVE A NET LICENSE KEY.
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TRANSFERRING LICENSES BY LICENSE TANKING

To tank a licence to the PC which you are working on for the moment — from a net 
license key placed on another PC —, do the following:

 1) Choose Settings => System/License, click on the License tab, and the 
license key settings are displayed on the lower-left corner of the tab:

 2) Click on License Tank:

 3) In the dialog box License Tank: Select a Time or a Date and click on Tank 
license.

 4) You are now informed whether you are allowed to tank the license: Click OK.

 5) In the dialog box License tank: Click Close.

The net license key herby loose a license for the specified period of time. When the 
tanking period expires, the licence automatically returns to the net license key.

Releasing a tanked license

If you wish to release a license, which has been tanked as described above, 
choose Settings => System/License => License => License Tank, and click on 
Release the tanked license.
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TRANSFERRING LICENSES VIA LICENSE TANKING

When you wish to transfer a license from a PC, which you can not access via a net-
work, do this:

 1) Create a license file in Automation with information about your home PC 
(the PC that needs the license), for use when transferring the license. — See 
“Creating a license file” on page 865.

 2) Send the file via e-mail/floppy disc to the person administrating Automation 
licenses on the system, from which you wish to tank a license.

 3) The administrator opens a special program for transferring licenses via file/e-
mail, transfers a license to the file you sent, and returns the file to you. — 
See “Giving away licenses via license files” on page 866.

 4) You receive a file, load it in Automation, and use the license for the 
assigned period of time. — See “Loading a license file containing a license” 
on page 865.

Creating a license file

 1) Choose Settings => System/License => License: The license key settings 
are displayed in the lower-left corner — as displayed in “Transferring licenses 
by License tanking” on page 864.

 2) Click on License Tank.

 3) In the dialog box License Tank: Click on Create file.

 4) In the dialog box Save license file: Specify where to save the license file 
(the Pcselcad folder is suggested), and click OK.

 5) In the dialog box License file: Click on Close.

Now send an e-mail to the administrator for the system, from which you wish to 
receive a license. In this e-mail you mention for how long you want the license 
(max. 30 days), and attach the license file to the e-mail.

Loading a license file containing a license

When you receive a license file containing a license from the administrator, you 
can load the license in Automation like this:

ASSIGNED LICENSE FILES CAN NOT BE RETURNED

WHEN YOU ARE ASSIGNED A LICENSE VIA A LICENSE FILE, IT IS NOT POSSI-

BLE TO RETURN THIS LICENSE.

IF FOR INSTANCE YOU HAVE BEEN ASSIGNED THE LICENSE FOR A PERIOD OF 

20 DAYS, YOU CAN NOT RETURN THIS LICENSE IN THESE 20 DAYS.

THE SYSTEM, FROM WHICH YOU RECEIVED THIS LICENSE, WILL THEREFORE 

NOT BE ABLE TO GET THIS LICENSE BACK, BEFORE THE 20 DAYS ARE OVER.

THE LICENSE CAN ONLY BE USED ON YOUR PC.
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 1) Place the license file on your harddisk — for instance in the folder Pcselcad.

 2) Start Automation. You now get the following message:

 3) Click on License file.

 4) In the dialog box Open: Click on the license file, and click on Open.

 5) Automation is now started, and you can work with the program in the spec-
ified period of time.

See for how long you will keep the license

When you have tanked a license, and choose Settings => System/License => 
License => License Tank, you can see for how much longer you have the license:

When the tanked license expires

If the PC is connected to a network when the tanked license expires, Automation 
automatically looks for an available license, and continues normally, if an available 
license is found.

GIVING AWAY LICENSES VIA LICENSE FILES

If you are the administrator of the licenses on a system with a net license key, and 
receive a license file, you can give away a license like this:
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age 866



Tanking licenses

Auto
 1) In Windows Explorer: Start the program PCsTank.exe — which for instance 
is placed on the server in the Pcselcad folder, or on your own PC.

 2) In the program Automation License Tank: Click on Open license file.

 3) In the dialog box Open: Click on the license file, which you received, and 
click on Open.

 4) In the program Automation License Tank: Click on Find available license.

 5) When an available license is found: Click on Tank license.

 6) In the dialog box License Tank: Specify for how long to tank the license, and 
click on Tank license.

 7) You now get a message telling for how long the license is tanked: Click OK.

 8) In the program Automation License Tank: Click on Close.

The received license file has now got a license assigned for the specified period of 
time, and you return the license file via e-mail/floppy disk.

Please note, that it is the same file you send back. No new file is created for this 
purpose.

ASSIGNED TANKED LICENSE FILES CAN NOT BE RETURNED

WHEN YOU GIVE AWAY A LICENSE VIA A LICENSE FILE, YOU CAN IN NO WAY 

RETURN THIS LICENSE BEFORE THE SPECIFIED PERIOD OF TIME EXPIRES.

IF FOR INSTANCE YOU HAVE GIVEN AWAY THE LICENSE FOR A PERIOD OF 20 
DAYS, THE SYSTEM CAN NOT GET THIS LICENSE BACK BEFORE THE 20 DAYS 

ARE OVER.

THE LICENSE CAN ONLY BE USED ON THE PC, ON WHICH THE LICENSE FILE 

WAS ORIGINALLY CREATED.
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STATUS BUTTON FOR TANK STATUS

In the right-hand side of the status bar a Status /Info 
function button for tank status is displayed, when a 
license have been tanked.

When you click on the button, the remaining tanked time is 
displayed. The function is activated automatically when 
the program is started, and when half of the remaining 
tanked time has been used. The next time it is activated is when half of the now 
remaining time has been used (i.e. 3/4 of the total time) — e.t.c.

When you right-click on the button, a menu is displayed from which the automatic 
pop-up information can be disabled.

SUPERPRO MONITOR

If you choose Settings => System/License => License => SuperPro monitor, 
you enter a net license key monitor, where the available net license keys are dis-
played.

Here you can select the license server(s), on which the program shall look for 
Automation license keys.

When you select a PC in the left-hand side of the dialog box, its license keys are 
displayed in the right-hand side of the dialog box.

When you double-click on one of these license keys in the right-hand side, you get 
further information.

Set a check mark here to look for license keys

Double-click on a license key for further information
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PREVENTING REPETITIVE STRAIN INJURIES

In order to prevent repetitive strain injuries — and at the same time save working 
hours — Automation includes the special developed program Mouse Chasing 
System, which registers which menu functions and buttons you click on during 
your daily work. From the basis of this information, you can then block for clicking 
on specific functions, and thereby learn the short-cuts to the functions gradually.

STARTING THE Mouse Chasing System

To start the Mouse Chasing System choose Tools => Mouse Chasing System.

You have now started the Mouse Chasing System, and the following dialog box is 
displayed:

When you click anywhere in the Automation program, the dialog box disappears. 
Click the Mouse Chasing System button at the bottom of the screen when you 
want to see the dialog box again.

HOW TO INSTALL Mouse Chasing System

IF Mouse Chasing System IS NOT AN OPTION IN THE TOOLS MENU, YOU 

INSTALL IT LIKE THIS:

1) CHOOSE FILE => MODULES

2) YOU NOW ENTER THE DIALOG BOX MODULES: CLICK ON Mouse Chasing 
System, AND CLICK ON INSTALL

3) CLICK CLOSE TO LEAVE THE DIALOG BOX
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The system registers what you click on

The Mouse Chasing System now registers all the menu selections you make and 
all the buttons you click on, and makes statistics about how many times you click in 
a menu or at a button.

When you click on a function in the dialog box, and then click on Block, the func-
tion is blocked when you click on it in Automation.

Clicking on a blocked function in Automation

When you click on a blocked function in Automation you get the following mes-
sage:

This way the program informs you about the short-cut key to the function. When 
you press this key, the dialog box disappears automatically, and the function is acti-
vated.

If no short-cut key is defined, you can create a short-cut key as described in “User 
defined short-cut keys” on page 858.

Blocks the selected

function

Remove blocking

of selected function

Clear chosen

function

Clear alle

functions

Save the informa-

tion in a file

Statistical

information
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Automatic blocking

When you click on Auto Block you can specify 
that the program shall automatically block all 
functions which have been clicked on more 
than for instance 100 times.

When you click on Show all, all menu choices 
in Automation are shown. You can then 
choose which functions to block.

Learning the short-cut keys by need

Because the mouse chaser tells you which functions you click on the most, you 
can concentrate on learning these functions. If for instance you block the three 
most used functions, you can learn these without using any special effort.

When you have learned the short-cut keys for these three functions, you can then 
block the three functions you now click on the most — and keep on doing so until 
you have learned the short-cut keys you need to know.

Disabling the Mouse Chasing System

You can at any time disable the blocking of the clicking on a function, by first click-
ing on the function in the Mouse Chasing System and then clicking on Unblock.

When you want to close the Mouse Chasing System, just choose Tools => 
Mouse Chasing System so that the check mark in front of Mouse Chasing 
System disappears.

Starts automatically along with Automation

When you do not close Mouse Chasing System before closing Automation, the 
Mouse Chasing System closes when you exit Automation. It will then start auto-
matically the next time you start Automation. This way you can perform statistics 
on which functions you click on for a longer period of time.

THE MOUSE CHASING SYSTEM CAN BE CLOSED DOWN

When the Mouse Chasing System is closed down, Automation is informed about 
this, so that it knows that the Mouse Chasing System has been closed down.
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In this section you get information about network 
security checks, revision control, registration of file 
types e.t.c.

You can read about:

- Access codes on projects .................................p. 875

- Locking project files.............................................p. 876

- Revision control....................................................p. 878

- Registering PCSCHEMATIC file types ..............p. 883

- Starting functions and DDE ................................p. 886

- Compressed saving / Zipping ...........................p. 891

Access codes, Registration e.t.c.





Passwords on Projects

Automation

Page 875

PASSWORDS ON PROJECTS

In Automation you can create a password for your project files, in order to prevent 
others from opening or saving them.

When you choose Settings => Project data, you can click 
on one of the password buttons.

You then enter this dialog box:

If a password already exists for the project, you first have to enter the previous 
password in the field Previous password.

Then type in the new password in New password, and type in the new password 
once more in Confirm new password.

Click OK.

The next time the project is opened or saved — depending on the password type 
used — you must type in the password and click OK.

THIS CHAPTER DESCRIBES

THIS CHAPTER DESCRIBES HOW TO USE PASSWORDS IN Automation.
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LOCKING PROJECT FILES

Due to the security on net installations, the program control which program files are 
opened for the moment.

LOCKING OF A PROJECT IN USE

If you open a project file, which is being used by another user for the moment, you 
get a message informing you that another user is already working on the project, 
and gives you the name of the other user.

However, you are allowed to open a copy of the project. But when you want to save 
your copy of the project, you are only allowed to save it under another name. This 
takes place to prevent you from overwriting the changes made by the other user — 
and to prevent the other user from overwriting your changes as well.

When the original project is no longer occupied, you are can open it and make 
additional changes to the project.

LOCKING AFTER SYSTEM BREAK DOWN

When a project is not closed down in the authorized way — for instance due to 
power failure — Automation does not release the project.

If a new user then tries to open the project, he will be informed that the old user is 
still working on the project, even though this is not the case. The new user will 
therefore not be allowed to save the project under the original project name.

When this is the case, the old user just have to enter the project. A message is 
then displayed, telling the old user, that the project is already open. The old user 
must then answer Yes to re-open the project, and close it again. It is not required to 
save the project at this occasion.

Deleting the %pr file manually

If this procedure fails, the problem can be solved using the Windows Explorer.

Automation have placed a security file in the same folder as the project. The file 
has the same name as the project, but has the extension .%pr. If the name of the 
project is example.pro, the name of the security file will therefore be exam-
ple.%pr.

By entering the Explorer and deleting this file, the project is again accessible for 
other users.

Please note, that Automation deletes this file under normal circumstances, when 
the project is closed down.

THIS CHAPTER DESCRIBES

— LOCKING OF A PROJECT IN USE.................................................................p. 876

— LOCKING AFTER SYSTEM BREAK DOWN......................................................p. 876

— SHARING LICENSES ON A NETWORK ..........................................................p. 877
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SHARING LICENSES ON A NETWORK

On network installations, your license can be taken by others, if you have not 
worked on your PC for ten minutes. When you start working again, you get a mes-
sage telling you that your license has been lost to another user.

If you then click Yes to search for a free license, Automation finds an available 
license for you, if possible. If no license is available, you will have to restart the pro-
gram to start working again.
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REVISION CONTROL

WHAT IS REVISION CONTROL

When you start the revision control in Automation, the program keeps track of on 
which pages in the project, changes has been made.

However, there are not kept track of which changes have been made.

It is subsequently possible to see where changes have been made — see “Page 
menu and Object Lister during Revision control” on page 879.

It is also possible to print the edited pages — see “Printing during revision control” 
on page 879.

STARTING A REVISION

 1) Choose Settings => Project data => Revision

 2) Select Use Revision check

 3) Click on Start New Revision

The system now memorizes on which pages changes are being made subse-
quently.

THIS CHAPTER DESCRIBES

— WHAT IS REVISION CONTROL ....................................................................p. 878

— STARTING A REVISION ..............................................................................p. 878

— THE PAGE MENU AND THE OBJECT LISTER DURING REVISION CONTROL ......p. 879

— PRINTING DURING REVISION CONTROL.......................................................p. 879

— ENDING A REVISION..................................................................................p. 880

— DELETING REVISION INFORMATION ............................................................p. 881

— DATAFIELD FOR DISPLAYING LAST REVISION...............................................p. 881

Click here
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PAGE MENU AND OBJECT LISTER DURING REVISION CONTROL

When you have started a revision — see “Starting a revision” on page 878 — it is 
possible in the Page menu and the Object Lister to see on which pages changes 
have been made.

The Page menu during revision control

When you have started a 
revision, an extra column is 
displayed in the Page 
menu, named R. In this col-
umn an R is displayed for 
the pages, which have been 
changed since the start of 
the revision.

— Read more about the 
Page menu in “The Page 
menu” on page 544.

The Object Lister during revision control

When you have started a 
revision, the Object Lister 
for pages can contain an 
extra column, named R. In 
this column an R is dis-
played for the pages, which 
have been changed since 
the start of the revision.

You enter the Object Lis-
ter for pages by choosing 
Object Lister => Pages.

If the R column is not dis-
played, choose View => Pages => Revised. (Please note that the contents of the 
column Revision comes from the user defined Page data datafield of the same 
name). — Read more about pages in the Object Lister in “Editing Page data in the 
Object Lister” on page 350.

PRINTING DURING REVISION CONTROL

To print the pages, which have been changed since starting the revision control:

 1) Click on the Print pages button

 2) Select All pages

 3) In the dialog box Print: Click on the tab 
Settings

 4) Select From date and then select From 
revision date

 5) Click on OK
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The edited pages are now printed. — Read more about the dialog box Print in 
“Printing” on page 361.

ENDING A REVISION

 1) Choose Settings => Project data => Revision

 2) Choose End Revision

The revision is now ended. The next time you enter the dialog box Revision, the 
revision period is displayed.

If you subsequently try to edit pages in the project, you are informed that the revi-
sion has ended. However, you will get this message each time you try to make 
changes.

The Object Lister and the Page menu after ending a revision

When the revision has been ended, the R-column in the Object Lister and the 
Page menu change function: The R-column now displays the pages, which have 
been changed since the revision ended. — See “Page menu and Object Lister 
during Revision control” on page 879.

Creating a password after ending a revision

If you wish to make sure that no changes are made after ending a revision, you can 
subsequently enter a password for the project. — Read more about this in “Pas-
swords on Projects” on page 875.

ENDING A REVISION AND DELETING REV. DATA IS NOT THE SAME

ENDING A REVISION AND DELETING REVISION DATA IS NOT THE SAME THING. 
— SEE “Deleting revision information” on page 881.
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DELETING REVISION INFORMATION

 1) Choose Settings => Project data => Revision

 2) Deselect Use Revision check

 3) You are now informed that all revision settings are deleted: Click OK

 4) In the dialog box Revision: Click OK

 5) In the dialog box Settings: Click OK

DATAFIELD FOR SHOWING LAST REVISION

To include a history in the revision information in Automation, you can create con-
secutively numbered revision datafields in the menus Page data and Project data. 
These datafields can the be filled out as the revisions are made.

When information about the last revision shall be placed on a project page, you 
place the datafield Page revision, which fetches the contents from the last filled 
out of these datafields.

Do for instance the following:

 1) Create the datafields Rev1, Rev2, ... , Rev9 under Settings => Project data 
— see “Page data and Project data Datafields” on page 755, particularly 
“Adding New datafields to Project data and Page data” on page 758.

ALL REVISION INFORMATION IS DELETED

PLEASE NOTE THAT ALL REVISION INFORMATION IS HEREBY 

DELETED FROM THE PROJECT. — SEE “Ending a revision” on 
page 880 ALSO.
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 2) At the position where you need information about the last revision, you then 
insert the Project data datafield Last revision, and select one of the data-
fields Rev1 ... Rev9 below Linked to datafield in the dialog box Datafield:

 3) Fill out the datafields with revision information as the revisions are per-
formed:

 4) At the position where you placed the Last revision datafield in the project, 
the contents of the last filled out revision datafield is now displayed (In this 
example the contents of the datafield Rev4):

CAN ALSO ATTACH HISTORY TO OTHER DATAFIELDS

YOU CAN ALSO USE THE DATAFIELD LAST REVISION WITH A SEQUENCE OF 

OTHER DATAFIELDS WITH IDENTICAL NAMES, WHEN YOU NEED TO ATTACH 

HISTORY INFORMATION TO THESE DATAFIELDS.
Automation

age 882



Registration of PCSCHEMATIC file types

Auto
REGISTRATION OF PCSCHEMATIC FILE TYPES

REGISTRATION OF FILE TYPES

In order to for instance start Automation projects directly from Windows Explorer, 
you must register the program file type (*.pro) in Windows. Hereby you tell Win-
dows which program to use for starting *.pro files.

When you have done this, you furthermore get the option to apply the Windows 
indexing services for searching for project texts and properties — see “Indexing” on 
page 1373.

To register the program file type in Windows, do this:

 1) Choose Settings => System/License => System and click on File type 
registration:

 2) You then enter the dialog box File type registration:

 3) To register .pro files, first click on .PRO Project Files and then on Register. 
The file type is now registered. (.sym files are registered correspondingly).

When a file type is already registered by another program, this will be displayed in 
the dialog box.

When a file type is already set as Registered (this meaning registered by 
Automation), no harm will be done by clicking Register again.

THIS CHAPTER DESCRIBES

— REGISTRATION OF PCSCHEMATIC FILE TYPES .......................................p. 883

— REGISTRATION OF .PRO FILES .................................................................p. 884

— REGISTRATION OF .SYM FILES .................................................................p. 884

Click here
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Unregistering

To unregister a file type, select the file type and click on Unregister.

THE EFFECT OF REGISTERING .PRO FILES

When *.pro files are registered, this has the following effect:

- Existing Automation projects can be started directly from the Windows 
Explorer. Right-click on the Automation project in the Windows Explorer, and 
choose Open.

- New Automation projects can be created directly from the Windows Explorer. 
Right-click on the Automation project in the Windows Explorer, and choose 
New.

- Projects can be printed from the Windows Explorer. Right-click on the 
Automation project in the Windows Explorer, and choose Print.

- When you right-click on a project in the Windows Explorer and choose Proper-
ties => Project data, the project data are displayed for the selected project.

- The first five Project data datafields are displayed as a hint in the Windows 
Explorer, when the mouse cursor rests over the project file.

- A PCSCHEMATIC icon is displayed in front of Automation files in the Windows 
Explorer.

- It becomes possible to apply the Windows Indexing services to search for pro-
ject texts and properties, as described in “Indexing” on page 1373.

Creating new projects from the menu in the Windows Explorer

If you wish to start creating a new project from the Windows Explorer, do this:

 1) In the Windows Explorer: Click on the folder in which you want to create the 
new project

 2) Choose File => New => PCSCHEMATIC project file

 3) In the selected folder you now type in the name of the project, and press 
<Enter>

 4) Double-click on the file, and the project is opened in Automation.

THE EFFECT OF REGISTERING .SYM FILES

To register .sym files, see “Registration of file types” on page 883.

When *.sym files are registered, this has the following effect:

- Automation symbols can be opened in the Symbol editor directly from the 
Windows Explorer. Right-click on the Automation symbol in the Windows 
Explorer, and choose Open.

- New symbols can be created directly from Windows Explorer. Right-click on the 
Automation symbol in the Windows Explorer, and choose New.

- A PCSCHEMATIC icon is displayed in front of Automation symbols in the Win-
dows Explorer.
Automation

age 884



Registration of PCSCHEMATIC file types

Auto
- It becomes possible to apply the Windows Indexing services to search for sym-
bol texts, as described in “Indexing” on page 1373.
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STARTING FUNCTIONS, BATCH PRINTING AND DDE

It is both possible to open a Automation file on a specified page, and to start 
Automation files directly from the Explorer in Windows. It is also possible to start 
Automation from expert systems.

Furthermore it is possible to batch print Automation projects.

These options are described in the following.

STARTING FUNCTIONS

Automation contains the following starting functions, which can all be activated 
from the command line:

1. Loading a project with a specified page open

It is possible to open a Automation file on a specified project page. This is done 
using the command line parameter /P.

If you want to load the project edemo.pro and display page 7, you type:

C:\PCSECAD\PCSECAD.EXE EDEMO.PRO /P7

2. Loading a project with a specified symbol selected

It is possible to open a Automation file with a specified symbol selected. This is 
done using the command line parameter /S.

If you want to load the project edemo.pro with the symbol K1 selected, you type:

C:\PCSECAD\PCSECAD.EXE EDEMO.PRO /SK1

The first project page containing a K1 symbol will be displayed, and all K1 symbols 
in the project will be selected.

Correspondingly you can type C:\PCSECAD\PCSECAD.EXE EDEMO.PRO /
SK1:13, which causes all K1 symbols to be selected, and the project to be opened 
on the project page where K1:13 is placed.

3. Opening only a few project pages

It is also possible only to load individual project pages. This is done using the com-
mand line parameter /L.

If for instance you only want to open page 3 from the edemo.pro project, you type:

C:\PCSECAD\PCSECAD.EXE /L[3] EDEMO.PRO

THIS CHAPTER DESCRIBES

— STARTING FUNCTIONS ..............................................................................p. 886

— COMMAND LINES FOR CREATING PDF, DWG AND DXF FILES ....................p. 888

— BATCH PRINTING ......................................................................................p. 889

— DDE FUNCTIONS......................................................................................p. 889
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If for instance you want to open the pages 3, 5 and 7 from edemo.pro, you type:

C:\PCSECAD\PCSECAD.EXE /L[3][5][7] EDEMO.PRO

The name of the opened pages becomes part of the project name in the limited 
project which is opened. Therefore you do not risk to save the limited version of the 
project which replaces the original project. In the example mentioned above, the 
limited project will be named edemo.[3][5][7].pro.

4. Open template project with partslist from another system

You can open Automation from another software system/program, so that a tem-
plate project is opened together with a partslist, which contains the components to 
be placed in the project.

Write for instance:

C:\PCSELCAD\PCSELCAD.EXE C:\PCSELCAD\STANDARD\Template.pro /IP 
C:\PCSELCAD\LIST\partslist.xls

Here the first part is the path to the template project, that you wish to use.

The parameter /IP means "Import Partslist".

The third part is the path to the partslist containing the components, that you wish 
to use in the project. The partslist can both be in the formats *.xls and *.xml.

This enables you to place symbols in the project based on the partslist, as 
described in “Placing symbols via lists” on page 743.

5. Export lists

You can open Automation and a specific project in the program from other soft-
ware systems / programs, and generate a list from the project. The command 
opens Automation and subsequently closes it again without changing the con-
tents of the project in the process.

Write for instance (must be written in a single line):

C:\PCSELCAD\PCSELCAD.EXE C:\PCSELCAD\PROJECT\Project.pro /LISTEX-
PORT /FormatFile=c:\Test\PartList.pff /OutputPath=c:\test\output

The command contains the following sections:

• The path to the exe file for Automation (C:\PCSELCAD\PCSELCAD.EXE)

• The path to the project (C:\PCSELCAD\PROJECT\Project.pro)

• The parameter /LISTEXPORT

• The path to the format file (/FormatFile=c:\Test\PartList.pff)

• The path to the folder where the generated list is saved (/Output-
Path=c:\test\output)

It is not required that the list is already generated in the project. It is exclusively the 
applied format file that specifies which type of list that is generated in the process. 
When executing the command the most recent data from the project pages are 
included in the generated list. (If a not updated similar list exists in the project, the 
contents in the generated list will therefore differ from the not updated list in the 
project). The project is not subsequently saved, so the project itself will in no way 
be changed by executing the command.
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The format file also specifies whether this causes an Excel file or a comma sepa-
rated file to be generated.

— Read more about format files in “Format files” on page 718, and get an overview 
over the possible format files in “The List files and their Extensions” on page 727.

The name of the generated list file will be the name of the project file followed by a 
dash, which is followed by a letter code for the list type.

This could for instance be Projectname-PRT.csv, where the list type is a parts list.

The following letter codes are applied:

COMMAND FILES FOR SAVING PROJECTS AS PDF, DWG AND DXF
FILES

In Automation you can create command line files, which automatically saves 
Automation projects as PDF, DWG or DXF files.
Do this:

 1) Create a text file — for instance in Notepad — which contains a command 
line for Automation. In “Examples on command lines for creating PDF files” 
on page 888 below, you can see examples on "SAVEASPDF" files of the 
type *.cmd.

 2) Start Automation with this cmd file as parameter in the command line — for 
instance C:\Pcselcad\Pcselcad.exe C:\PATH-TO-CMDFILE\SAVEA-
SPDF.cmd

Examples on command lines for creating PDF files

Below you can see some examples on command lines, which you can save in a  
*.cmd file, so that PDF files are created automatically from Automation projects:

FILESAVEAS .PDF C:\Pcselcad\Project\*.pro

All .pro-files in the folder C:\Pcselcad\Project\  are saved as PDF files in the same 
folder.

FILESAVEAS .PDF C:\Pcselcad\Project\*.pro C:\Pcselcad\Project\PDFSAVE

All .pro-filer in the folder C:\Pcselcad\Project\ are saved in the folder 
C:\Pcselcad\Project\PDFSAVE as PDF files.

The folder C:\Pcselcad\Project\PDFSAVE must be created before executing the 
command.

FILESAVEAS .PDF @C:\Pcselcad\Project\ProList.txt

LIST TYPE LETTER CODE

PARTS LIST PRT

COMPONENTS LIST CMP

TERMINALS LIST TRM

CABLES LIST CBL

PLC LIST PLC

CONNECT POINTS LIST NET

CONNECTIONS LIST CNP
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All project files in the listfile C:\Pcselcad\Project\Prolist.txt are saved as PDF 
files in the same folder as each individual PRO file.

FILESAVEAS .PDF @C:\Pcselcad\Project\ProList.txt C:\Pcselcad\Project\PDF-
SAVE

All project files in the listfile C:\Pcselcad\Project\Prolist.txt are saved in the folder 
C:\Pcselcad\Project\PDFSAVE as PDF-files.

The folder C:\Pcselcad\Project\PDFSAVE must be created before executing the 
command.

Command lines for creating DWG and DXF files

To create DWG or DXF files using command lines, you just replace .PDF with 
.DWG or .DXF respectively in the examples above.

BATCH PRINTING

The following function for batch printing in Automation exists, which can be acti-
vated from the command line, or e.g. from a schedule program:

Batch printing from stand-alone installation

To print the file C:\batch.pro (where Automation is installed in the folder 
C:\Pcselcad), write this:

C:\PCSELCAD\PCSELCAD.EXE -xp C:\batch.pro

— When you need to print more than one file, write the names of these after 
C:\batch.pro, only separated by a space character:

C:\PCSELCAD\PCSELCAD.EXE -xp C:\batch.pro C:\batch2.pro

Batch printing from net installation

To print the file C:\batch.pro (where Automation is installed in the folder 
F:\Pcselcad), write this:

F:\PCSELCAD\PCSELCAD.EXE /n:C:\PCSELNET -xp C:\batch.pro

Here F:\PCSELCAD is the system catalog, while /n:C:\PCSELNET is the worksta-
tion catalog.

— When you need to print more than one file, write the names of these after 
C:\batch.pro, only separated by a space character:

F:\PCSELCAD\PCSELCAD.EXE /n:C:\PCSELNET -xp C:\batch.pro C:\bat2.pro

DDE FUNCTIONS

In Automation exists DDE functions, which makes it possible to right-click on a 
.pro file in the Windows Explorer, and then getting the options Open, New, and 
Print.

Thus it is possible to open a file by double-clicking on it — or by right-clicking and 
choosing Open. Also a new project can be opened by right-click New, and a pro-
ject can be printed by right-click Print.
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Registration of Automation

From the command line .pro files for Automation are registered using the param-
eter /REGISTER — for instance type:

C:\PCSECAD\PCSECAD.EXE /REGISTER

The program only have to be started once this way.

The registration is removed by C:\PCSECAD\PCSECAD.EXE /UNREGISTER.

DDE registration also has the consequence that once you have started 
Automation, and opens a file from the Windows Explorer, this file is opened in the 
running program.
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COMPRESSED SAVING / ZIPPING PROJECTS

WHAT IS ZIPPING?

The Zip program is so commonly used for compressing files, that it is close to 
becoming an international standard for file compression.

Therefore automatic zipping of project documents have become an integrated 
option in Automation.

SET THE PROGRAM TO AUTOMATIC ZIPPING

When you wish to set Automation to save project files in the zip format automati-
cally, you can choose Settings => System/License => System and activate 
Compressed saving:

The projects still gets the extension *.pro, though they are zipped.

Opening zipped project files

When a project is opened, Automation automatically analyses whether the project 
is zipped or not. When a project is saved in the zip format — from Automation — 
it is opened like any other project.

It therefore has no consequence for your working process with the program, if you 
choose compressed saving.

ADVANTAGES BY ZIPPING IN Automation

When you set Automation to automatic zipping, the size of the projects are 
reduced to about 8-12% of the original size, and both loading and saving are faster 
for projects on networks. For projects on local disks, there will be no time differ-
ence.

The compression follows the zip standard completely. Therefore you can choose to 
change the extension of a zipped project document to .zip, after which you can let 
the document be unzipped by a common unzipping program.

THIS CHAPTER DESCRIBES

— WHAT IS ZIPPING .....................................................................................p. 891

— SET THE PROGRAM TO AUTOMATIC ZIPPING...............................................p. 891

— GAINS BY ZIPPING IN Automation .........................................................p. 891

Click here
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SETTINGS

CHOICES IN THE DIALOG BOX SETTINGS

The dialog box Settings is a menu in Automation. If you wish to be able to select 
all tabs in the dialog box, choose Settings => Settings. (If the tab you are looking 
for is not displayed in the dialog box for the moment, you can click the right- and 
left-arrows in the upper right-hand corner of the dialog box).

When you wish just to choose one of the menu items, you can choose this directly 
from the menu: When for instance you wish to access the tab Tools directly, you 
therefore choose Settings => Tools. Hereby the dialog box Settings is opened, 
and the tab Tools is selected. Please note that the tab Tools then becomes the 
only tab in the dialog box.

Entering Settings without an active project

It is possible to enter the Settings dialog box when no projects are open. Tabs in 
Settings, which are not project related, are not displayed when there are no active 
projects.

THE TABS IN THE SETTINGS MENU

The tabs in the dialog box Settings includes:

THIS CHAPTER DESCRIBES

IN THIS CHAPTER YOU CAN READ ABOUT WHICH TABS YOU CAN SELECT IN THE DIALOG BOX 

SETTINGS, AND GET FURTHER INFORMATION ON THE VARIOUS SETTINGS IN THE DIALOG 

BOX.

A SURVEY OF THE CONTENTS OF THE TABS, EXISTS IN “The Tabs in the Settings 
menu” on page 895.

TAB CONTENTS

PROJECT DATA

p. 897
SPECIFICATION OF DATAFIELDS CONCERNING THE ENTIRE PROJECT. 
PASSWORDS, PROJECT REMARKS, REFERENCE DESIGNATIONS, MOUNT-

ING CORRECT DRAWING, PROJECT LOGO, REVISION CONTROL AND 

RELAY REFERENCE TYPE.

PAGE DATA

p. 900
SPECIFICATION OF DATAFIELDS CONCERNING THE PAGE YOU ARE 

WORKING ON IN THE PROJECT. PLACING A DRAWING HEADER ON THE 

PAGE. REFERENCE SETTINGS E.G. FOR CURRENT PATHS, ARTICLE DATA 

FOR THE PAGE, AND REFERENCE DESIGNATIONS FOR THE PAGE.

PAGE SETUP

p. 903
SPECIFICATION OF PAPER SIZE, PAGE TYPE, PAGE SCALING, AS WELL 

AS GRID AND SNAP FOR THE PAGE YOU ARE WORKING ON.

PAGE REMARKS

p. 905
HERE YOU CAN TYPE IN REMARKS FOR THE ACTIVE PROJECT PAGE.

POINTER/SCREEN

p. 906
SETTINGS DEALING WITH WHAT IS DISPLAYED ON THE SCREEN, AND 

HOW IT IS DISPLAYED.
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DIRECTORIES

p. 911
SPECIFICATION OF WHERE DIFFERENT TYPES OF FILES WILL BE SUG-

GESTED SAVED/LOADED FROM, AS WELL AS FOR WHICH TYPES OF FILES 

A BACKUP WILL BE MADE. SPECIFICATION OF THE ORDER IN WHICH THE 

SYMBOL FOLDERS WILL BE EXAMINED, WHEN THE PATH TO A SYMBOL IS 

NOT SPECIFIED (ALIAS).

TOOLS

p. 914
HERE YOU SPECIFY WHICH OTHER PROGRAMS CAN BE STARTED FROM 

Automation.

DATABASE

p. 916
CHOOSE DATABASE FILE AND SETTINGS. ACTIVATING AND DEACTIVAT-

ING THE DATABASE.

SYSTEM

p. 918
COMPANY AND USER NAME. LICENSE KEY SETTINGS. FILE TYPE REGIS-

TRATION. SPECIFICATION FOR INTERVAL BETWEEN SAVING AUTO 

RECOVER INFORMATION.
CHOOSING CHARACTER SETS FOR OTHER LANGUAGES, AND CHOOSE 

LANGUAGE.

LICENSE

p. 920
LICENSE KEY SETTINGS.

TEXT/SYMBOL 

DEFAULTS

p. 921

SPECIFICATION OF THE STANDARD APPEARANCE OF VARIOUS TYPES OF 

TEXTS IN THE PROGRAM. SPECIFICATION OF WHICH DRAWING HEADERS 

CAN BE USED, AS WELL AS WHICH SIGNAL SYMBOLS AND SIGNAL SYM-

BOL NAMES THAT WILL BE SUGGESTED IN THE DIALOG BOX SIGNALS.
CREATION OF DATAFIELDS FOR DATA SYMBOLS.
DEFAULT CABLE DIRECTIONS.

BASIC SETTINGS 

p. 925
SPECIFICATION OF BASIC SETTINGS FOR DIFFERENT TYPES OF LINES 

AND SPECIFICATION OF TEXT PROPERTIES FOR TEXTS IN REFERENCE 

FRAMES, CLOUDS AND MEASUREMENT TEXTS. YOU CAN ALSO DEFINE 

SYSTEM COLORS AND CUSTOM COLORS.

SPECIAL SETTINGS 

p. 927
SETTINGS WHICH ONLY APPLY FOR THE ACTIVE PROJECT.

SHORTCUTS

p. 930
SPECIFICATION OF USER-DEFINED SHORTCUTS.

TAB CONTENTS
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PROJECT DATA

On the tab Settings => Project data you handle information and specify general 
settings for the project. You can add and fill out the Project data datafields, specify 
passwords for the active project, choose a project logo, choose reference designa-
tions, set up mounting correct drawing, start/stop a revision control and choose the 
reference type for relays.

Clicking on the Project data button brings you directly into this dialog box.

Project title

Here you type in a title for the project.

List of project titles

It is possible to create a list of project titles, consisting of predefined values for the 
datafield.

To apply/create such a list of project titles, click the Values button to the right of the 
Project title field, and then administrate the list as described in “The Values dialog 
box” on page 121.

Remarks in projects

In the Remarks field at the top of the dialog box you can type in remarks for the 
project. There is no limitation for the size of the remarks in the Remarks field.

When you have typed in a remark, you can right-click in the Remarks field. This 
gives you the opportunity to print out the remark, or to save it as an independent 
text file.

Passwords

For further details about passwords on projects, please refer to “Passwords on Pro-
jects” on page 875.
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Logo

— See “Inserting logos in projects” on page 581.

Project data

In Project data you type in information regarding the entire project, which you can 
read more about in “Project and Page data” on page 125.

The field names you specify here, can be inserted into your project, when you 
choose Insert => Insert Datafield and click on Project data. The program then 
collects the information you have typed in here, and place it in the project. If you 
need to change an information, you therefore only have to do it here once and for 
all. Read more about datafields in “Datafields” on page 116.

Buttons for handling Project and Page data datafields

On the tab Settings => Project data as well as on the tab Settings => Page data 
you will find the following buttons for handling datafields. (The buttons are 
described for the Project data tab, but have similar functions on the Page data 
tab).

Save as default

Clicking on the Save as default button, saves the datafields you have specified as 
default datafields of the type Project data. When you start up a new project, these 
datafields will be suggested.

Export and import Project data

When you click the Export projekt data to file button, you can save the project 
data as an Excel file or as a comma separated file (*.csv). If you click the Import 
project data from file button, you can import project data from an Excel file or a 
comma separated file.

Add, Edit and Remove datafields

Using the buttons Add datafield, Edit datafield and Remove datafield you can 
delete, add or edit field names in the menu, as described in “Adding New datafields 
to Project data and Page data” on page 758.

Values

When you click on a datafield and then click the Values button, you can create /
maintain a list of predefined values for the datafield. Read more about lists of val-
ues in “The Values dialog box” on page 121.

Remove unused datafields

When you click the Remove unused data fields button, all unused datafields are 
removed.

Move datafields up and down in the dialog box

When you click on a datafield and then click the Move datafield up or the Move 
datafield down button, you can move the datafield up or down in the list of data-
fields in the dialog box. You can also click on a datafield in the dialog box, keep the 
mouse button pressed down, and drag the datafield to another position.
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Automatic renumbering of pages

When you select Automatic renumbering of pages, the program automatically 
renumbers the project pages to consecutive page numbering. If Automatic 
renumbering of pages is selected, and you insert a new page between project 
page 6 and project page 7, the new page will then get page number 7, while the 
previous page 7 is renumbered to page 8. If subsequent project pages exist, these 
will also be incremented by one — page 8 becomes page 9 etc.

The setting only applies for the active project, and it will by default not be activated 
when you start a new project.

Relay reference type

Here you specify whether you wish to use reference crosses or contact mirrors for 
relay references. — See “Contact mirrors and Reference crosses” on page 428.

Revision

— See “Revision control” on page 878.

Reference designations for the project

When you click on Reference designations, you can specify the reference desig-
nations you want to use in the project. Please refer to “On reference designations” 
on page 373 for further details.

Mounting correct drawing

When you select Mounting correct drawing, the program supports you in creat-
ing mounting correct drawings. Please refer to “Mounting correct drawing” on 
page 100 for further details.

Do not display Project data when starting a new project

If you do not wish to see the tab Project data when creating new projects, choose 
Settings => Project data, and deselect Show this dialog when creating a new 
project. This check box is displayed at the bottom of the tab.

BE VERY CAREFUL USING THIS FUNCTION!

IT IS RECOMMENDED THAT YOU DO NOT SELECT AUTOMATIC RENUMBER-

ING OF PAGES, UNLESS YOU ARE ABSOLUTELY SURE ABOUT WHAT YOU ARE 

DOING, AND HAVE A CLEAR UNDERSTANDING OF ALL OF THE POSSIBLE CON-

SEQUENCES.
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PAGE DATA

On the tab Settings => Page data you specify various kinds of settings regarding 
the project page you are working on right now.

Clicking the Page data button also brings you directly into this dialog box.

Page title

Here you type in the title of the page.

List of page titles

It is possible to create a list of possible page titles, consisting of predefined values 
for the datafield.

To apply/create such a list of page titles, click the Values button to the right of the 
Project title field, and then administrate the list as described in “The Values dialog 
box” on page 121.

Include page in Table of Contents

If you select Include this page in Table of Contents, the page is included in the 
table of contents.
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Mark as last used page

When you select Mark as last used page, this setting has effect on the datafields 
Next used page, Used pages and Last used page.

— See “Last used page active” on page 363.

Page data

Under Page data you type in information, which is attached to the page you are 
working on in the project. — Read more about this in “Project and Page data” on 
page 125.

The field names specified here, are the datafield names you can insert into your 
project, when you choose Insert => Insert Datafield, and select Page data. When 
you insert a datafield, the program collects the information you have typed in here, 
and insert it where you have placed the datafield. — Read more about datafields in 
“Datafields” on page 116.

Buttons for handling Page data datafields

See how to use the buttons under Page data for handling page data datafields in 
“Buttons for handling Project and Page data datafields” on page 898.

Reference designations for the page

In Automation you can attach reference designations to all symbols placed on the 
same page.

If reference designations are already attached to the page, they are displayed, as 
you can see on the figure. When you wish to specify new reference designations 
for the page, click on Select.

— Please refer to “On reference designations” on page 373 for further details.

Reference designations is only visible on this tab if reference designations have 
been chosen for the project on the Project data tab. — See “Reference designati-
ons for the project” on page 899.

Drawing headers

In this part of the dialog box you specify which drawing header you want to place 
on the page. This is described in “Inserting a drawing header on a page in a pro-
ject” on page 586.

References

When you click on the References button, you enter the dialog box Reference 
system setup, where you specify the settings for the reference system/current 

REMEMBER TO UPDATE TABLES OF CONTENTS

WHEN YOU SELECT MARK AS LAST USED PAGE, YOU SHOULD SUBSE-

QUENTLY REMEMBER TO UPDATE THE TABLES OF CONTENTS IN THE PRO-

JECT, SO THAT THEY ONLY CONTAIN PAGES FROM THE FIRST PROJECT PAGE 

TO THE "LAST" PROJECT PAGE.
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path numbers on the page. — Read more about this in “Current path numbers / 
Reference System” on page 433.

Article data

Clicking on the Article data button brings you into the dialog box Page article 
data.

Here you type in article data for the page if you need to.

When you right-click on the page itself, and then choose Page article data, you 
also enter this dialog box.
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PAGE SETUP

On the tab Settings => Page setup you have the options mentioned below for 
specifying the page setup. — Page settings can also be copied between pages, as 
described in “Page setup - and transferring this to other pages” on page 558.

Paper size

In the upper-left corner of the tab you select the Paper size of the active page, as 
described in “Paper size” on page 561.

Page type and Page function

See how to select the Page type in “Page type” on page 560.

The Page function is also displayed here, but can not be changed. This has been 
specified when the page was created, and can never be changed. Please refer to 
“Creating a new page” on page 546 for further details.

Please note that a Page function can be set to Normal, as described in “Change 
page function & Transfer page function to other pages” on page 549.

Grid and Snap

Grid and Snap is also specified here — read more about this in “Screen / Image 
Functions” on page 42.
mation

Page 903



P

Settings
You can also select Follow page scale in order to specify that snap and grid fol-

lows the page scale — see “Setting the scale of the page” on page 533.

Scale factor and Reading direction

— Read more about Scale factor in “Setting the scale of the page” on page 533.

— Reading direction is described in “Specify reading direction” on page 141.

Contains a list

If you select Contains a list, diagram pages are 
allowed to contain either a Components List or 
a Parts List for the page.

— Read more about this in “Diagram pages - 
containing a Parts or Components list” on 
page 828.

Default settings

If you want to see the current standard settings, you click on the Show defaults 
button. To load the default settings, you click on the Load defaults button.

If you, on the other hand, want to save the specified settings as the future default 
settings, you click on the Save as default button.

Click OK when the settings are satisfactory.

Standard settings for List pages and Chapter tabs

If you have selected a list page and choose Settings => Page setup, and choose 
Save as default, the page size of the selected list page becomes the default page 
size for list pages. This works correspondingly for chapter tabs.

— Please also see “Standard page sizes for List and Chapter tabs” on page 561.

"OTHER SYMBOLS"

IN Automation VERSION 19 AND EARLIER VERSIONS, YOU WERE HERE 

ABLE TO SPECIFY FROM WHICH DATAFIELD IN THE DATABASE, THAT THE 

SYMBOLS ON THE PAGE WERE FETCHED. THIS IS NOW DONE IN THE COMPO-

NENT MENU. — SEE “The page database field for symbols” on page 257.
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PAGE REMARKS

On the tab Settings => Page remarks, you can type in remarks about the selected 
page in the project.

It is possible to print all page remarks in the project as a list. For this purpose you 
can use the list for printing page remarks, which is installed with the program. — 
See the survey of lists that comes with the program in “Predefined lists” on 
page 830.
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POINTER/SCREEN

The tab Settings => Pointer/Screen consists of a number of check boxes, in 
which you specify how you want the screen and pointer settings.

Grid display: Here you specify the appearance of the grid on the screen. Please 
refer to “Grid” on page 48 for further details.

Align grid to 1. Reference: If you want your grid aligned to the first reference 
number on the page, you select Align grid to 1. Reference. This goes for both 
vertical and horizontal reference systems.

You then have to adapt the size of the grid/snap in order to make it fit the interval 
between the current path numbers.

Grid on list pages: Select this option if you want grid on list pages.

Cross hairs / Small cross hairs: Here you specify whether you wish to use a 
cross hairs, as well as the appearance of the cross hairs. Read more about cross 
hairs in “Dictionary” on page 967.

Pointer: Specifies whether a mouse pointer is displayed on the screen. Is automat-
ically selected if Cross hairs is deselected.

Keep cursor position: When you open a dialog box while working on a diagram 
page, you have to move the cross hairs in order to make choices in the dialog box. 
Therefore, you can use Keep cursor position to control where to position the cur-
sor when the dialog box is closed:

- When Keep cursor position is not activated: The cursor remains where you 
last clicked in the dialog box.

- When Keep cursor position is activated: The cursor jumps back to the exact 
same position in the diagram, as it had before opening the dialog box.

Straighten lines: Here you specify whether the connecting lines should be 
straightened when you move a symbol. Is enabled by default.
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Ortho 45: When you draw Lines, and have chosen Straight lines, you are only 
allowed to draw horizontal and vertical lines. However, if you select this function, 
you are also allowed to draw diagonal lines.

Line width follows page scale: When Line width follows page scale is acti-
vated, lines on pages with page scale are drawn with a line width that reflects the 
selected page scale.

Cross hairs line displayed right angled: When you are drawing Straight lines, a 
rubber band always appear, radiating from the last place you clicked towards the 
cross hairs.

If you have selected this function, you will always see the line as it will be drawn if 
you click in this very moment.

If you have deselected this function, you will see a line going from where you 
clicked last to the exact position of the cross hairs.

Depending on which snap you are using, these lines will not always be the same.

Cross hairs figure with snap: When this function is selected, the objects in the 
cross hairs follow the actual snap. This way you will continuously see where the 
object will be placed when you click.

If the function is deselected, the symbols will only follow the exact position cross 
hairs — but will still be placed according to the actual snap if you click. — Read 
more about snap in “Snap” on page 47.

Net router: When you move mechanical symbols, the program can display which 
other mechanical symbols the symbol is connected to — according to the informa-
tion on the electrical pages. Read more about this in “Displaying connections for 
mechanical symbols” on page 703.

Middle mouse button: If you use a mouse with a middle mouse button, you here 
can specify how this middle button functions in Automation. You can choose 
either Zoom or Pan.

Mouse wheel: If you use a mouse with a mouse wheel between the two mouse 
buttons, you can here specify how this mouse wheel functions in Automation. You 
can choose either Scroll, Zoom: Wheel Forward or Zoom: Wheel Backward. 
Read more about this in “Zoom and Scroll for mouse with a wheel” on page 43.

Unit of measurement: Here you specify according to which unit of measurement 
Automation interprets the object positions you type in. If the unit of measurement 
is set to mm and you type in 15, this will be interpreted as 15mm.

However, you can still type in another unit of measurement together with the num-
ber — typing in 15 cm will still be interpreted as 15cm.

Show message in (ms): Specify how long time the hints are displayed in the pro-
gram.

Ask for Names: If this function is selected, you will enter the Component data 
dialog box each time you place a symbol in your project. If the function is dese-
lected, you have to right-click on the symbols later on, choose Component data, 
and then fill out the symbol name and other information.
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Insert - in front of symbol names: When there is no minus in front of the symbol 
name in the symbol definition, a minus will be inserted in front of the symbol name, 
when you place the symbol.

To insert a minus in front of already placed symbols choose Functions => Special 
Functions => Prefix all symbol names with -.

Keep zoom: Imagine you have zoomed in on an area — for instance the upper-
right corner — of a project page, and change to another page in the project. If 
Keep zoom is selected, you will then also see the upper-right corner of the page 
you change to. If the function is deselected, you will see the entire new page.

Keep page zoom: If Keep zoom is selected, you also get the option to select 
Keep page zoom. If you select this function, the program remembers which zoom 
you are using on each individual page. When you close a project, the applied zoom 
settings are not memorized.

Show scrollbars: When you have zoomed in on an area, you can drag the scroll-
bars to move the zoom — see “The Scrollbars” on page 43.
When you deselect Show scrollbars you get a larger work area on the screen.
— See Auto hide scrollbars below.

Auto hide scrollbars: Is only displayed when Show scrollbars is selected. If you 
activate Auto hide scrollbars, the scrollbars are only displayed when you point 
the mouse pointer to the far right or to the bottom of the screen. This way you do 
maintain the full work area and are still able to use the scrollbars.

Flat buttons: If you want the program to apply the flat Windows 98 buttons, you 
select Flat buttons. If Flat buttons is not selected, the buttons will be displayed in 
Windows 95 style.

Gradient toolbars: This option only exist in Windows 7 and previous versions of 
Windows. If you wish to apply the gradient look, as known from e.g. the Microsoft 
Office programs, select Gradient toolbars. See how to set the colors in “Colors” 
on page 860.
— Please note that dialog boxes aways have gradient look.

Gradient Pickmenu: This option only exist in Windows 7 and previous versions of 
Windows. Is only displayed when you have selected Gradient toolbars. Select 
Gradient Pickmenu if you also want gradient look in pickmenus.

Transparent windows: Some windows can remain on screen while you are work-
ing on the drawing area in the project. These windows can be set to become trans-
parent by selecting Transparent windows. You can set the degree of 
transparency by moving the slider below Transparent windows. This makes it 
possible to get an idea of what is behind the dialog box on the drawing area.

When the window / dialog box is activated — e.g. by clicking on it — the window 
becomes fully visible again. When you click on the drawing area of the screen, the 
window becomes transparent again.

The best way to set the degree of transparency, is to open e.g. the Object Lister 
(press <F7>), and select Symbols, so that the Object Lister contains data. Then 
select Settings => Pointer/Screen, and drag the slider below Transparent win-
dows to a position, where you get the desired transparency in the Object Lister.

The following windows will also become transparent, when Transparent windows 
is selected: The Show available window, the Insert component list window, the 
Find and Replace window, and the result window from Design check.
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Component menu active: Here you can specify whether the Component menu 
is active. Please note that this change will first occur when the program is 
restarted.

Please note that choosing to deactivate this window will make it impossible to use 
the short-cut [F9] for searching for components with available symbols.

Hints: If you let the mouse pointer rest for a moment, on for instance a program 
button, you will see the name of the button displayed in a small text field. Or, if you 
let the pointer rest on a symbol in the symbol pick menu, the symbol title will be dis-
played. This is called hints, and here is the place you specify whether you want 
hints when working with the program.

Show popup information: When selected and you let the mouse cursor rest over 
a symbol, a window is displayed containing information about the symbol. The win-
dow disappears when you move the mouse again.

Show popup help: When you have started a function, which requires more than 
one action, and you have not moved the mouse for a while, a window is displayed, 
telling what the program expects you to do.

Page tabs: On the bottom of each project page, you see some small tabs, display-
ing which project page you are working on. Clicking on these tabs enables you to 
change back and forth between the project pages quickly. This is the place to 
select whether you want tabs on your pages or not.

If the function is disabled, the drawing area on the screen will become a little larger.

Black background: Selecting this function will make the project pages turn black, 
while lines, symbols and so forth will become white.

Survey window: Here you enable and disable the Survey window. Short-cut 
<F12>.

Explorer window: Here you enable and disable the Explorer window. Please refer 
to “The Explorer window: The Projects tab” on page 335 for further details. In 
Show in Edit symbol you specify whether to display the Explorer window when 
editing symbols.

Help frame: Clicking here makes a standard margin appear on the project pages. 
The margin is displayed by a red dash line. The help frame is not included when 
you print out project pages.

Printer help frame: Clicking here will make the printable area of your printer visi-
ble. The printable area is displayed by a grey dash line, and is not displayed when 
you print the project pages.

Symbol pickmenu: Here you turn the pickmenu on and off. Read more about the 
symbol pick menu in “Fetching symbols from the Pickmenu” on page 152.

Reference points: Reference points are created to make it easier to work with the 
diagrams on the screen (and to make it easier to attach information to objects intel-
ligently). However, when you have zoomed out on a page, the reference points can 
take too much attention, and for instance make it difficult to read connection 
names. When you select Auto, the program only makes reference points visible 
when you zoom in on a page. You can adjust when to show the reference points by 
dragging the slider.
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You can also specify whether or not to display reference points on screen by click-
ing the Reference points button in the left toolbar, or by choosing View => Refer-
ence points. Read more about reference points in “Dictionary” on page 967. The 
reference points are not visible when you print out the project.

Representation of crossing non-connected conducting lines: Here you specify 
how to represent non-connected conducting lines, when they cross on diagram 
pages. You have the following options:

• No gap: The lines cross.

• With gap: A gap is opened on one of the lines.

• Gap with arc: A gap is opened on one of the lines and an arc is drawn on the 
other line.

— Also see “Priority on lines” on page 85.
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DIRECTORIES

Directories

On the tab Settings => Directories you specify in which folder/directory you want 
the program automatically to suggest you to save the various types of program 
files. If you want to save a project, and have chosen the setting above, the program 
will automatically suggest you to save it in the folder Project.

When you click on the Browse button in front 
of a directory, you get a little Explorer window, 
where you can locate the folder you now wish 
to apply as directory:

Click on the desired folder, and click OK.

Displaying System catalog and Worksta-
tion catalog

At the bottom of the tab Directories the sys-
tem catalog is displayed, as well as the work-
station catalog on net installations.

Save with backup

In the right-hand side of the dialog box you specify for which kind of files you want 
backups to be made. These backups are made when you save a file, and contains 
the previous version of the file.

The backups gets the same names as the files, but the extension of the files are 
changed to the character ~ followed by the first two characters in the extension of 
the original. Thus the backup of the project demo.pro will be called demo.~pr, 
while the backup of the symbol symbol.sym will be called symbol.~sy.

Here the System catalog is displayed,

as well as the Workstation catalog
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Alias for directories

When you on the tab Settings => Directories click on Show directory alias, you 
enter the following dialog box:

Here you get the option to assign an alias to each symbol folder/directory.

This makes it easy for you to move the symbol directories, if this should become 
necessary.

The Alias concept

As displayed above, the directory C:\PCSELCAD\SYMBOL\MISC has the alias 
MISC. If it at some point is decided to move this directory to for instance I:\SYM-
BOLS\MISC, you only have to correct the path here. The program will then fetch 
symbols from the new symbol library.

You will normally not need to type in the alias MISC anywhere in Automation; it is 
merely a name you have given to the program, so that it internally can distinguish 
between the various aliases. But it is a good idea to give them appropriate names, 
so that you yourself can distinguish between them here in the Alias for directories 
dialog box.

Specify which directories to search in first

When you fetch a symbol from the database, and the symbol is not already in the 
project, the program will search the symbol folders in the order you have specified 
under Alias for directories, starting from the top. The program then finds the first 
symbol with the given symbol name. The order of the directories is therefore impor-
tant.

To save time, it is therefore a good idea to place the folders, you use the most, on 
the top of the list. You can move the aliases by clicking and dragging.

If for instance you want User to be on top, then click on User, keep the mouse but-
ton pressed down, drag the alias to the top of the list, and let go of the mouse but-
ton. User is now placed on top of the list.
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Replacing all symbols - based on Alias

If you apply Functions => Special functions => Replace all symbols all symbols 
in the projects are loaded into the project again — based on the order in which they 
appear under Alias for directories.

— See “Replacing all symbols in a project” on page 216.

Correcting directories or alias

If you want to correct an alias name or path, you first 
have to make sure that you are working in an empty 
project, and that no other projects are open.

Then right-click on the place in the list where you want 
to make changes. — If you are not working in an empty 
project, or other projects are open, you will get a warn-
ing, and will not be allowed to make any changes.

If you want to change an alias name, you then choose Change alias, and if you 
want to remove an alias, you choose Remove alias.

If you choose Modify path, you enter a dialog box, where you click your way to the 
desired directory, and click OK.

When you want to add a new alias to the list, you choose Add new alias. Then you 
type in the name of the alias, and click your way to the desired directory.

Click on Close when you have completed the corrections.

Example

If you are working inside an empty project — having no other projects open — and 
want to add a new alias, which you want to be placed as number three on the alias 
list, then start by choosing Settings => Directories.

Click on Symbols in the left-hand side of the dialog box, and then click on Show 
directory alias. Right-click on the lower part of the list, and choose Add new 
alias.

Now type in the alias name, click OK, click your way to an appropriate directory, 
and click OK again. Move the new alias to the third position on the list by clicking 
and dragging.

Click OK.

Alias when installing databases

When you install a database on Automation, the program automatically creates 
an alias to the library containing the symbols of the database.

Administrator control

If Administrator is selected, various system settings can be controlled by the sys-
tem administrator. This function should only be activated after consulting the sys-
tem administrator.
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TOOLS

In the program tool bar you can choose a menu called Tools. From this menu you 
can for instance change back and forth between Automation and other programs, 
or create list files based on predefined settings.

Starting other programs from the Tools menu

On the tab Settings => Tools — you specify which other programs you can start 
directly from the Tools menu.

You do this by typing in the name you want to see in the Tools menu in the MENU 
name column, while you type in the full path and program name in the PROGRAM 
name column on the same line.

You can here use the following parameters:

%SYSDIR% here specifies the directory in which the program is installed.

%SYSDIR8% works as %SYSDIR%, but is used on net systems, which only han-
dles eight characters in file names.

%HOMEDIR% is the home directory. This is the same as %SYSDIR% if the pro-
gram is not installed on a network server.

%HOMEDIR8% works as %HOMEDIR%, but is used on net systems, which only 
handles eight characters in file names.

%DATABASE% is the name of the database attached to the program.

%NET% is used when an application needs to know whether it is running on a net 
installation. This is a special parameter which only works for Automation applica-
tions.
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Creating list files from the Tools menu

If there is a specific list format that you frequently use, you can choose to make it 
available directly from the Tools menu. See how to do this in “Placing fixed list for-
mats in the Tools menu” on page 719.

Inserting a button in the program tool bar

To make it easier to change to another program, it is also possible to insert your 
own buttons on the program tool bar.

If you want to add a button with the text NP on it, in order to be able to change to 
Notepad quickly, you just add #B(NP)# after the program name for Notepad.

If you have got a bitmap file which you want displayed on the button, you type in the 
name of the file (including the full path) instead of NP in the example above: #B(bit-
map file)#. The size of the bitmap file should be 20x20 pixels.

Removing or editing menu items in the Tools menu

If you want to remove or edit a menu item, just right-click it in the Settings => 
Tools tab and choose Remove menu item or Edit menu item respectively.
mation

Page 915



P

Settings
DATABASE

On the tab Settings => Database you specify whether to work in Automation 
with- or without a connected database, by clicking on On or Off respectively.

Select database file

By clicking on Select database file you enter a dialog box, from which you specify 
which database you want to work with — see “Choosing a database” on page 687.

Database setup

By clicking on Database setup you enter a dialog box, where you specify the data-
base setup, as it will appear when working in Automation. Read more about this in 
“Database settings” on page 670.

You can read more about the database program in the PCSCHEMATIC Database 
manual.

Database fields saved in project files

Settings for project component database. — See “Project component database” on 
page 642.

Locking the project component database

— See “Locking the project component database for the active project” on 
page 645.
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UPDATE SYMBOLS FROM DATABASE

When selecting Update Components when changing Article No. you can spec-
ify whether/how Automation updates the other symbols for the component, when 
the article number is changed for one of the symbols for a component.

This update is made when the article number is changed for the symbol in the 
Component data dialog box, having Change all symbols for the component 
selected.

The function is activated by first selecting Update Components when changing 
Article No.. When you subsequently click on Settings, you enter the dialog box 
Update from Component Database:

Here you have the following options:

OPTION DESCRIPTION

DO NOT UPDATE TYPE TEXTS FOR THE COMPONENT IS NOT UPDATED.

UPDATE MISSING ONLY TYPE TEXTS ARE ONLY UPDATED FOR THOSE OF THE SYMBOLS FOR 

THE COMPONENT, WITH NO PREVIOUSLY SPECIFIED TYPE TEXT.

UPDATE ALL ALL TYPE TEXTS FOR THE COMPONENT IS UPDATED ACCORDING TO 

THE DATABASE.

UPDATE CONNECTION 

POINTS

ALL CONNECTION NAMES FOR THE COMPONENTS ARE UPDATED 

ACCORDING TO THE SPECIFIED CONNECTION NAMES IN THE DATA-

BASE.

UPDATE CABLE WIRES UPDATES ALL CABLE WIRES, SO THAT THEY GET THE NAMES SPECI-

FIED IN THE DATABASE.

CHECK FOR CORRECT 

SYMBOLS

IT IS CHECKED WHETHER THE SYMBOLS FOR THE COMPONENT HAVE 

THE CORRECT SYMBOL FILE NAMES — ACCORDING TO THE DATA-

BASE INFORMATION.

CHECK FOR UNKNOWN 

ARTICLE NO.
IT IS CHECKED WHETHER THE NEW ARTICLE NUMBER FOR THE COM-

PONENT EXISTS IN THE DATABASE.
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Company and User name

On the tab Settings => System/License => System you can type in your own 
name, as well as the name of your company. This information can automatically be 
inserted in your projects, when you choose Insert => Insert Datafield, and click 
on System data. The program then collects the information you have typed in 
here, and inserts it into the project. If you have to change this information later on, 
you only have to do it once right here. — Read more about datafields in “Data-
fields” on page 116.

Automatic recovery information

If you select Select auto recover information every, you will make Automation 
save automatic recovery information every 30 minutes. By clicking on the up and 
down-arrows you can change the contents of the Interval in minutes field. The 
recovery file is saved in the directory Pcselcad using the same project name, but 
with the extension .recoveryPRO.

After an unauthorized closure, Automation will automatically start up from the 
automatic recovery file.

Compressed saving

— See “Compressed saving / Zipping projects” on page 891.

SAVE YOUR PROJECTS FREQUENTLY

PLEASE REMEMBER TO SAVE YOUR PROJECT OFTEN. THE AUTOMATIC 

RECOVERY FILE IS ONLY MEANT AS A MEANS OF RE-CREATING THE PROJECT 

FILE IF THE SYSTEM CRASHES — FOR INSTANCE BECAUSE OF A POWER 

SUPPLY FAILURE.
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age 918



Settings

Auto
Load previous project

When you select Load previous project at program start, Automation automat-
ically opens the last active project, the next time you start the program.

Choose language

Under Choose language you can choose in which language to use for the pro-
gram texts in Automation.

It is possible to choose between English, Czech, Polish, Chinese, German, Hun-
garian, Portuguese, Norwegian, Swedish and Danish.

If these options are not available in your installation, you can have them sent to you 
by contacting PCSCHEMATIC A/S.

When changing language the program must be restarted.

Select set of characters

When you want to specify which set of characters you want to use in the project, 
the options are Standard (normally used), Latin2, Russian, Baltic and Polish.

The codes for these characters (<Alt>+0xxx) follows the common Windows charac-
ter sets.

The information of the chosen character set is included in each project file sepa-
rately. More character sets will be created on request.

Automatic check for Updates, New versions and Information

In the lower-right corner of the dialog box, you 
can select 21.XX update, Newer version and 
Information. This makes it possible for you to 
receive information — via the internet — 
when updates or new versions are released, 
or to get important information about the pro-
gram automatically.

— Read more about this in “Update and Auto-
matic information” on page 852.

You can also check for new updates by choos-
ing Help => Check for updates from the 
menu line at the top of the screen.

USING STATES IN DRAWING HEADERS FOR CHANGING LANGUAGE

YOU CAN USE STATES IN DRAWING HEADERS FOR CHANGING LANGUAGE FOR 

TEXTS IN DRAWING HEADERS.

WHEN YOU USE THIS OPTION, THE LANGUAGE YOU CHOOSE HERE DETER-

MINES WHICH LANGUAGE IS SELECTED IN THE DRAWING HEADERS YOU SUB-

SEQUENTLY ASSIGN TO PAGES IN THE PROJECT.

— READ MORE ABOUT THIS IN “Drawing headers with states” on 
page 816.
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LICENSE

On the tab Settings => System/License => License you have the following 
options:

License key and Servers

The License key field is used for license key settings. Normally, you will not have 
to change the license key settings, because these are set when the program is 
installed. Read more about this in "License key" in the Installation & Information 
manual.

When a SuperPro license key is applied, the license key number is displayed under 
Settings => System/License => License => License key.

— Please also refer to “Tanking licenses” on page 863.

Time-out

For the SuperPro NET key you can set a Time-out for the license to None, 10 
min., 20 min. or 30 min.. If there has been no activity on the PC in the specified 
period of time, the license is released for other users. When you continue working 
with the program, Automation automatically searches for a free license, and con-
tinue working normally when a free license is found.

Software license key

Up to version 15, it was only possible to purchase Automation along with a physi-
cal license key. Since version 17 was released you normally purchase Automation 
with a software license key. How to install this license system is described in the 
PCS License Server - Install guide.
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TEXT/SYMBOL DEFAULTS

The tab Settings => Text/Symbol defaults is divided in two parts: Text defaults 
on the upper part, and Symbol defaults on the lower part.

Text defaults

— Read more about this part of the dialog box in “Texts displayed in the project 
(general setting)” on page 138.

— If you want to change the Name format of the symbol names in the project, 
please refer to “Naming symbols due to page and current path number” on 
page 436.

— See also “Default text properties for free texts” on page 112, “Appearance of 
references” on page 426, “Changing the reference crosses” on page 435 and 
“Specifying default text settings for Edit symbol mode” on page 781.
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Transferring text defaults between projects
If you wish to transfer all text and naming settings between projects, click All:

Here you get the following options:

Settings for different customers

If you have created different project templates, which contains the text and naming 
standards for different customers, you can use the possibilities above to easily 
transfer these settings from a template to the active project.

Symbol defaults

The program contains lists specifying which symbols can be used as for instance 
drawing headers or signal symbols, and other lists specifying the names of the 
user defined datafields for symbols and lines. Under Symbol defaults you can 
specify which symbols are represented in these lists, and also specify the names 
of the various types of datafields for symbols and lines.

Adding a symbol to a list requires that the symbol is already created — read more 
about creating symbols in “Creating Symbols” on page 761.

Transfer all text settings to the project: Click here to transfer all the text 
settings that you have specified under Text defaults to all objects in the 
project. — This means that all settings specified under Free, Symbol, 
Connection, Reference and Line are hereby transferred to all objects in 
the project.

Load all default text settings: Click here to transfer all default text set-
tings to the project. (See below).

Save all text settings as default: Click here to save all text settings in the 
active project as default text settings.

Use project default text settings when placing objects: When you 
select this option, all settings that you have specified here under Text 
defaults, will be applied when placing objects in the project.
Therefore, if a symbol is designed with specific text properties, these will 
be overruled by the specified text defaults, when the symbol is placed in 
the project.
Automation

age 922



Settings

Auto
Inserting symbols in lists / Create datafields

In order to place a symbol/datafield in a list, you first specify — on the left-hand 
side — which type of list you wish to place the symbol/datafield in. Then click the 
Add button.

For symbols: You now enter the Symbol menu where you click on the symbol you 
want to add to the list, and click OK.

For datafields: You now enter the dialog box Enter text where you type in the name 
of the datafield that you wish to create, and click OK.

— Read more about adding a symbol (here a drawing header) to a list in “Adding 
drawing headers to the List Of Drawing Headers” on page 815.

CALCULATED LINE DATAFIELDS

It is also possible to create calculated line datafields, where you for instance can 
combine different line datafields in a single datafield. — See “Calculated line data-
fields (Formula editor)” on page 82.

Removing symbols or datafields from lists

You can remove symbols and datafields from the lists by clicking on the down-
arrow in the Drawing headers field, then click on the symbol or datafield you wish 
to remove, click on the Remove button, and answer Yes to remove it from the list. 
— You can read more about removing a symbol from a list in “Removing drawing 
headers from List of Drawing Headers” on page 815.

— Read more about drawing headers in “Creating Drawing Headers” on page 807.

— Read more about signal symbols in “Creating Signal Symbols” on page 803.

— Read more about join signal symbols in “Creating Join symbols” on page 806.

— Read more about symbol datafields and line datafields in “Creating symbol 
datafields” on page 798.

— Read more about reference symbols in “Changing the reference crosses” on 
page 435.

List of signal names

There also exists a list of signal names. When you place a signal symbol on a pro-
ject drawing, and click on  the Used button in the Signals dialog box, you will get a 
list of signal names to choose from. By clicking on Signal names in the left-hand 
side of the dialog box, you can specify which signal names that will be suggested 
in this list. Here you can add or remove signal names, as described for symbols 
above. — Read more about the dialog box Signals in “Signal symbols” on 
page 225, and about adding signal names to the list in “Frequently used signal 
symbol Names” on page 806.

Cable direction and Default cable quantity

At the bottom of the tab you can specify the default cable direction for horizontal 
and vertical cables.

You can also specify whether the Default cable quantity is 0 or 1:

• When you choose 0: The Quantity field is used for typing in the lengths of the 
individual cables, which can then be accumulated in the project lists.
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• When you choose 1: The Quantity field is used for counting the number of 
cables (cable symbols) in the project.

Activate Follow connected on symbols

Follow connected can be activated/deactivated as a general setting in the active 
project, by clicking on Activate Follow connected on symbols.

This setting is activated by default.

— Read more about Follow connected in “Follow connected lines” on page 95.
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BASIC SETTINGS

On the tab Settings => Basic settings you have the following options:

Line settings

Here you can specify the basic settings for different types of lines in the project.

To change how a line type from now on will be drawn in the project, do this:

 1) Click on the desired line type - for instance Lines

 2) Specify Line color, Line type and Line width

 3) Click Apply

You also have these options:

When you click the Transfer standard settings as project settings button, the 
saved standard settings are transferred for all of the line types as project settings.

When you click the Transfer project settings as default settings button, the pro-
ject settings for all of the line types are transferred as standard settings for future 
projects.

When you click the Transfer line setting to project button, the settings for the 
selected line type in the dialog box, are transferred to all lines of the this type in the 
project.

Reference frame, cloud and measurement texts

Here you can specify the basic settings for how texts appears for reference frames, 
clouds and measurement objects in the project. To edit how these texts appear in 
the project from now on, do this:

 1) Click on the desired text type - for instance Reference designations
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 2) Click the Text properties button

 3) In the dialog box Text properties: Specify the appearance of the selected 
text type and click OK.

 4) In the Basic settings tab: Click Apply.

Beyond this, you have the same options as described above.

System colors and custom colors

At the bottom of the tab, you can change System colors and Custom colors. Read 
more about this in “Colors” on page 860.
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SPECIAL SETTINGS

On the tab Settings => Special settings you can set specific settings, which only 
apply for the active project.

Default setting in the dialog box: Rename symbols

Here you can specify the default setting for all dialog boxes for renaming symbols. 
If for instance you work with pneumatics, you can choose to set it to Do NOT 
rename symbols.

Default setting in the dialog box: Component data

If you select Show full Reference designation here, the setting Show full Refer-
ence designation will by default be selected on the Ref.design. tab in the dialog 
box Component data when you place new symbols in the project.

Do not show dots on: Conducting lines or Connection points

When you under Do not show dots on select Conducting lines, dots will not be 
shown on conducting lines in the diagrams. — Please note that all connections 
must be indicated by either dots or bend according to the EN61082 standard.

When you under Do not show dots on select Connection points, dots will not be 
shown on connection points in the diagrams.

CLICK APPLY TO ACTIVATE THE CHANGES

WHEN YOU CHANGE SETTINGS IN SETTINGS => SPECIAL SETTINGS, YOU 

MUST SUBSEQUENTLY CLICK THE APPLY BUTTON TO ACTIVATE THE 

CHANGES.
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Signal name from PLC or component

When you draw a line from a connection point on a PLC symbol, and terminate the 
line in a signal symbol (without connecting the line to a connection point on another 
symbol), you can here specify that the program by default suggests to name this 
signal symbol from either the PLC address/Function text or the Connected com-
ponent/Connection point (-K1:14).

This means that the signal symbol is either named from the function text on the 
connection point on the connected symbol, or from the symbol and the connection 
point. — See “Signal names assigned from Function text or Connection name” on 
page 228.

Printer and PDF dialog

If you choose Show list update reminder before printing and before exporting 
PDF files, you will be asked whether to update project lists before printing and 
before exporting the project as a PDF file.

Settings for the page type Ground plan / Mechanical

If you select Show lines in symbols as thin lines, symbols on Ground plan/
Mechanical pages are drawn using thin lines, when displayed on the screen. This 
is meant to increase the on-screen readability, but if this is not the case on your 
screen, just disable this setting.

Update lists when saving a project

Here you choose whether lists are not updated when projects are saved, if they are 
always updated when projects are saved, or whether you are asked first.

Update from component database when saving a project

Here you choose whether the project components are not updated from the 
attached component database when projects are saved, if they are always updated 
from the attached component database when projects are saved, or whether you 
are asked first.

Fixed line break on texts

When you place datafields in projects, you can specify a maximal Width for the 
datafields in the dialog box Datafield. If you select Wrap text, the text will continue 
on the line below, when the text is longer than the specified width. If you select 
Keep line break (^), these line breaks are also transferred to lists. — See “Data-
fields” on page 116.

Under Fixed line break in texts you can specify whether line breaks in the project 
are made exactly at the specified number of characters in the field Width. If it for 
instance says 10 in the Width field, the line break will be made after exactly 10 
characters, regardless of whether the line break is made in the middle of a word.

In lists the line break will always be made exactly at the specified width, because 
longer texts risk overwriting the contents of the next column in the list.

If you want the program to make exact line breaks on diagram pages also, select 
On all pages.
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If you want the program only to make exact line breaks in lists, select Lists only.

This setting also has effect on free texts, if you have specified a line width and 
selected Wrap text. — Read more about free texts in “General purpose / Free 
texts” on page 109.

ONLY EFFECT FOR SMALL TEXT WIDTHS

THE SETTING WILL TYPICALLY ONLY MAKE A DIFFERENCE FOR VERY SMALL 

LINE WIDTHS. IF FOR INSTANCE WIDTH IS SET TO 25, THE PROGRAM WILL 

PLACE AS MANY WORDS AS POSSIBLE ON EACH LINE, AS LONG AS THE 

TOTAL NUMBER OF CHARACTERS ON THE LINES IS BELOW 25 CHARACTERS 

— NO MATTER WHICH OF THE SETTINGS YOU HAVE CHOSEN.
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SHORT-CUTS

On the tab Settings => Shortcuts you can define your own keyboard shortcuts, or 
edit the already created shortcuts. See how to do this in “User defined short-cut 
keys” on page 858.

You can see the predefined shortcuts in “Short-cut Keys” on page 856.
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DATAFIELDS IN AUTOMATION

In the following it is displayed which datafields can be inserted on project pages 
and drawing headers / lists via the dialog box Datafield. You can enter this dialog 
box by choosing Insert => Insert datafield.

The datafields are grouped in the same order in which they appear in the dialog 
box.

Datafields demarcated by an asterisk (*), are user defined datafields.

SYSTEM DATA DATAFIELDS

PROJECT DATA DATAFIELDS

DATAFIELDS

— SYSTEM DATA ..........................................................................................p. 931

— PROJECT DATA ........................................................................................p. 931

— PAGE DATA..............................................................................................p. 932

— SYMBOL DATAFIELD..................................................................................p. 934

— TABLE OF CONTENTS................................................................................p. 935

— PARTS/COMPONENTS LIST........................................................................p. 936

— TERMINALS LIST .......................................................................................p. 938

— CABLE LIST ..............................................................................................p. 940

— PLC LIST DATA ........................................................................................p. 942

— CONNECTIONS LIST ..................................................................................p. 945

DATAFIELD DESCRIPTION

USER NAME USER NAME FROM SETTINGS.

DATE DATE

TIME TIME

COMPANY NAME COMPANY NAME FROM SETTINGS.

PROGRAM TYPE PROGRAM TYPE

PROGRAM PATH THE FULL PATH TO WHERE THE PROGRAM IS INSTALLED.

DATAFIELD DESCRIPTION

PROJECT NUMBER (*) PROJECT

REVISION (*) REVISION.

CUSTOMER NAME (*) CUSTOMER NAME

SUBJECT NAME (*) SUBJECT NAME

DESIGNER (*) DESIGNER

TITLE TITLE
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PAGE DATA DATAFIELDS

FILE NAME FILE NAME FOR THE PROJECT. HERE YOU CAN CHOOSE TO DIS-

PLAY ANY PART OF THE FILE NAME. YOU CAN SELECT WITH FILE 

PATH, PATH NAME AND/OR WITH FILE EXTENSION.

FILE DATE/TIME FILE DATE/TIME FOR THE LAST TIME THAT THE PROJECT WAS 

SAVED. CHOOSE EITHER DATE AND TIME, DATE, TIME OR 

YEAR.

REFERENCE DESIGNATION REFERENCE DESIGNATION DEFINED IN THE PROJECT: CHOOSE 

BETWEEN ALL, FUNCTIONAL ASPECT AND LOCATIONAL 

ASPECT, AND SPECIFY WHETHER THE INSERT THE DESIGNA-

TION, DESCRIPTION OR DESCRIPTION 2.

LOGO1 OR LOGO2 THE SELECTED LOGO IS INSERTED. — SEE “Inserting logos 
in projects” on page 581.

CREATION DATE/TIME TIME AND DATA FOR WHEN THE PROJECT WAS CREATED. 
CHOOSE EITHER DATE AND TIME, DATE, TIME OR YEAR.

REMARKS REMARKS FROM THE REMARKS FIELD.

LAST REVISION THE DATAFIELD LAST REVISION IS USED FOR DISPLAYING THE 

MOST RECENT REVISION OF THE PROJECT. THERE CAN BE CRE-

ATED A LIST OF REVISION DATAFIELDS IN THE MENUS, WHICH 

CAN BE FILLED OUT AS THE REVISIONS ARE PERFORMED.

— SEE “Datafield for showing last revision” on 
page 881.

LAST WIRE NUMBER DISPLAYS THE NAME OF THE LAST WIRE NUMBER IN THE PRO-

JECT.

DATAFIELD DESCRIPTION

DRAWING NO. DRAWING NUMBER. EITHER FROM PAGE OR FROM CHAPTER 
(FROM THE CHAPTER DIVIDER PAGE).

APPROVED (*) APPROVED. EITHER FROM PAGE OR FROM CHAPTER (FROM 

THE CHAPTER DIVIDER PAGE).

DATE (*) DATE. EITHER FROM PAGE OR FROM CHAPTER (FROM THE 

CHAPTER DIVIDER PAGE).

REVISION (*) REVISION. EITHER FROM PAGE OR FROM CHAPTER (FROM THE 

CHAPTER DIVIDER PAGE).

CONSTRUCTOR CONSTRUCTOR. EITHER FROM PAGE OR FROM CHAPTER 
(FROM THE CHAPTER DIVIDER PAGE).

APPROVED BY APPROVED BY. EITHER FROM PAGE OR FROM CHAPTER (FROM 

THE CHAPTER DIVIDER PAGE).

APPROVED DATE APPROVED DATE. EITHER FROM PAGE OR FROM CHAPTER 
(FROM THE CHAPTER DIVIDER PAGE).

PAGE INDEX PAGE INDEX.

PAGE NUMBER PAGE NUMBER. EITHER FROM PAGE OR FROM CHAPTER (FROM 

THE CHAPTER DIVIDER PAGE).

TITLE TITLE. EITHER FROM PAGE OR FROM CHAPTER (FROM THE 

CHAPTER DIVIDER PAGE).

REMARKS REMARKS FROM THE REMARKS FIELD.

DATAFIELD DESCRIPTION
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DATE FOR LAST CHANGE TIME AND DATE FOR LAST CHANGE ON THE PAGE. CHOOSE 

BETWEEN DATE AND TIME, DATE, TIME OR YEAR.
IF YOU NEED TO SET THE TIME/DATE FOR ALL PAGES IN THE 

PROJECT, CHOOSE FUNCTIONS => SPECIAL FUNCTIONS => 
SET DATE FOR LAST CHANGE ON ALL PAGES AND ANSWER YES 
TO SET THE DATE FOR LAST CHANGE TO NOW.

SCALE FACTOR SCALE FACTOR.

PRINT SCALE PRINT SCALE.

TEXT CORNER TEXT CORNER.

FIRST USED PAGE FIRST USED PAGE. HERE YOU MUST EITHER CHOOSE IN THE 

PROJECT OR IN THE CHAPTER. YOU CAN THEN SELECT/DESE-

LECT ONLY SHOW DES. IF DIFFERENT (THE REFERENCE DESIG-

NATIONS ARE ONLY DISPLAYED IF THEY DIFFER FROM THE 

REFERENCE DESIGNATIONS ON THE PREVIOUS PAGE), FUNC-

TION ASPECT, LOCATION ASPECT AND/OR PRODUCT ASPECT.

LAST USED PAGE LAST USED PAGE. HERE YOU MUST EITHER CHOOSE IN THE 

PROJECT OR IN THE CHAPTER. YOU CAN THEN SELECT/DESE-

LECT ONLY SHOW DES. IF DIFFERENT, FUNCTION ASPECT, 
LOCATION ASPECT AND/OR PRODUCT ASPECT.

NEXT USED PAGE NEXT USED PAGE. YOU CAN SELECT/DESELECT NOT CHAP-

TERS, ONLY SHOW DES. IF DIFFERENT (THE REFERENCE DESIG-

NATIONS ARE ONLY DISPLAYED IF THEY DIFFER FROM THE 

REFERENCE DESIGNATIONS ON THE PREVIOUS PAGE), FUNC-

TION ASPECT, LOCATION ASPECT AND/OR PRODUCT ASPECT.

PREVIOUS USED PAGE PREVIOUS USED PAGE. YOU CAN SELECT/DESELECT NOT 

CHAPTERS, ONLY SHOW DES. IF DIFFERENT (THE REFERENCE 

DESIGNATIONS ARE ONLY DISPLAYED IF THEY DIFFER FROM THE 

REFERENCE DESIGNATIONS ON THE PREVIOUS PAGE), FUNC-

TION ASPECT, LOCATION ASPECT AND/OR PRODUCT ASPECT.

USED PAGES USED PAGES.HERE YOU MUST EITHER CHOOSE IN THE PRO-

JECT OR IN THE CHAPTER. YOU CAN THEN SELECT/DESELECT 

ONLY SHOW DES. IF DIFFERENT, FUNCTION ASPECT, LOCA-

TION ASPECT AND/OR PRODUCT ASPECT.

PAGE DESIGNATION PAGE DESIGNATION. CHOOSE BETWEEN DESIGNATION AND 

DESCRIPTION. THEN SELECT IF IT IS FOR THE REFERENCE 

DESIGNATION (THE FULL REFERENCE DESIGNATION), THE 

FUNCTION ASPECT, LOCATION ASPECT AND/OR PRODUCT 

ASPECT.

PICTURE BITMAP PICTURE.

CREATION DATE/TIME CREATION DATE/TIME. CHOOSE BETWEEN DATE AND TIME, 
DATE, TIME AND YEAR.

LAST REVISION THE DATAFIELD LAST REVISION IS USED FOR DISPLAYING THE 

MOST RECENT REVISION OF THE PROJECT. THERE CAN BE CRE-

ATED A LIST OF REVISION DATAFIELDS IN THE MENUS, WHICH 

CAN BE FILLED OUT AS THE REVISIONS ARE PERFORMED.

— SEE “Datafield for showing last revision” on 
page 881.

FIRST/LAST OBJ THE DATAFIELD FIRST/LAST OBJ CAN DISPLAY THE FIRST AND/
OR THE LAST OBJECT IN THE LIST PAGE.
HERE YOU CAN CHOOSE EITHER FIRST AND LAST, FIRST OR 

LAST.

DATAFIELD DESCRIPTION
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SYMBOL DATAFIELDS

Contains user-designed symbol datafields. — See “Symbol datafields” on 
page 120.

Symbol datafields can also be created with a list of predefined values. — See 
“Symbol datafields with predefined values” on page 121.

When using symbol datafields of this type in the definition of a symbol, you can 
also fetch data from any datafield in the attached database. — See “Extra symbol 
Datafields in symbols” on page 776, particularly “Inserting symbol datafields from 
database in symbol definition” on page 776.

Symbol datafields for terminal, cable and PLC lists

When you use symbol datafields in terminal, cable and PLC lists, you can specify 
whether to fetch the values for the fields from the actual symbol or from the compo-
nent (same text for all symbols for the component in the list).

Edit symbol: Description and reference designation as extra
Symbol datafield

When you are designing a symbol — in the Edit symbol mode — you have the fol-
lowing extra datafields at your disposal:

LAST PRINTED TIME AND DATE FOR WHEN THE PAGE WAS PRINTED LAST. 
HERE YOU CAN CHOOSE BETWEEN DATE AND TIME, DATE, 
TIME AND YEAR.

ACTIVE LAYER SPECIFIES THE NAME OF THE ACTIVE LAYER. IF IT HAS BEEN 

CHOSEN TO SHOW A LAYER GROUP, THE NAME OF THE GROUP 

IS DISPLAYED HERE.

GROUP OF LAYERS SPECIFIES WHICH LAYERS A GROUP CONTAINS.

PAGE TAB COLOR INSERTS A THREE CHARACTER LONG FIELD, WHICH HAS THE 

SAME COLOR AS THE PAGE TAB.
IT IS NOT POSSIBLE TO INSERT A PRE-TEXT FOR THIS DATA-

FIELD. — READ MORE ABOUT COLOR ON PAGE TABS IN 

“Colors on page tabs” on page 557.

DATAFIELD DESCRIPTION

=+-DESIGN. THE REFERENCE DESIGNATION FOR THE COMPONENT:
CHOOSE EITHER DESIGNATION, DESCRIPTION OR DESCRIPTION 2 
— AND ...
CHOOSE EITHER FULL REFERENCE DESGINATION, FUNCTION 

ASPECT, LOCATION ASPECT OR PRODUCT ASPECT.

DESCRIPTION INSERT THE CONTENTS OF THE DATAFIELD, WHICH IS MAPPED TO 

THE DESCRIPTION FIELD IN THE DIALOG BOX SETTINGS => DATA-

BASE => DATABASE SETUP => COMPONENT DATA — SEE 

“Transferring article data to symbols and lines” on 
page 672 AND ITS SUBSECTION “Description” on page 673.

QUANTITY THE CONTENTS OF THE QUANTITY FIELD ON THE GENERAL TAB IN 

THE DIALOG BOX COMPONENT DATA. — SEE “Predefined sym-
bol datafields” on page 124.

DATAFIELD DESCRIPTION
Automation

age 934



Datafields in Automation

Auto
TABLE OF CONTENTS DATAFIELDS

DATAFIELD DESCRIPTION

DATE (*) DATE

REVISION (*) REVISION

PAGE INDEX PAGE INDEX

PAGE NUMBER PAGE NUMBER

TITLE TITLE

DATE FOR LAST 

CHANGE

DATE FOR LAST CHANGE

SCALE FACTOR SCALE FACTOR

PRINT SCALE PRINT SCALE

PAGE DESIGNATION PAGE DESIGNATION. THIS CAN EITHER BE FULL REFERENCE DESIG-

NATION, FUNCTION ASPECT, LOCATION ASPECT AND/OR PRODUCT 

ASPECT — AND SPECIFY WHETHER TO PLACE THE DESIGNATION, 
THE DESCRIPTION OR DESCRIPTION 2.

CREATION DATE/TIME CREATION DATE/TIME FOR THE PAGE. CHOOSE BETWEEN DATE 

AND TIME, DATE, TIME AND YEAR.

LINE NUMBER LINE/SUBJECT NUMBER FOR THE LIST POINT.
YOU CAN HERE CHOOSE BETWEEN ON ALL LINES AND ON USED 

LINES.

FIRST/LAST OBJ THE DATAFIELD FIRST/LAST OBJ CAN DISPLAY THE FIRST AND/OR 

THE LAST OBJECT IN THE LIST PAGE.
YOU CAN HERE CHOOSE BETWEEN FIRST AND LAST, FIRST AND 

LAST.

LAST REVISION THE DATAFIELD LAST REVISION IS USED FOR DISPLAYING THE MOST 

RECENT REVISION OF THE PROJECT. THERE CAN BE CREATED A 

LIST OF REVISION DATAFIELDS IN THE MENUS, WHICH CAN BE 

FILLED OUT AS THE REVISIONS ARE PERFORMED.

— SEE “Datafield for showing last revision” on page 881.

REMARKS REMARKS FROM THE REMARKS FIELD FOR THE PAGE.

— SEE “Page remarks” on page 905.

FIRST USED PAGE FIRST USED PAGE. HERE YOU MUST EITHER CHOOSE IN THE PRO-

JECT OR IN THE CHAPTER. YOU CAN THEN SELECT/DESELECT ONLY 

SHOW DES. IF DIFFERENT (THE REFERENCE DESIGNATIONS ARE 

ONLY DISPLAYED IF THEY DIFFER FROM THE REFERENCE DESIGNA-

TIONS ON THE PREVIOUS PAGE), FUNCTION ASPECT, LOCATION 

ASPECT AND/OR PRODUCT ASPECT.

LAST USED PAGE LAST USED PAGE. HERE YOU MUST EITHER CHOOSE IN THE PRO-

JECT OR IN THE CHAPTER. YOU CAN THEN SELECT/DESELECT ONLY 

SHOW DES. IF DIFFERENT (THE REFERENCE DESIGNATIONS ARE 

ONLY DISPLAYED IF THEY DIFFER FROM THE REFERENCE DESIGNA-

TIONS ON THE PREVIOUS PAGE), FUNCTION ASPECT, LOCATION 

ASPECT AND/OR PRODUCT ASPECT.

— SEE “Last used page active” on page 363.

STATE. PRIMARY 

HEADER

THE SELECTED STATE OF THE PRIMARY DRAWING HEADER. — SEE 

“Two drawing headers on the same page” on page 591.

STATE. SECONDARY 

HEADER

THE SELECTED STATE OF THE SECONDARY DRAWING HEADER.

— SEE “Two drawing headers on the same page” on 
page 591.
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PARTS/COMPONENTS LIST DATAFIELDS

The list also contains datafields from the attached database. If you use a database 
from PCSCHEMATIC, the datafield names from the database are written in capi-
tals. This makes it easy to distinguish these datafields from the other datafields. If 
you create your own database, it is recommended that you also write these names 
in capitals.

Fields from the PCSCHEMATIC database are not displayed below. You can see 
these in “Datafields in the component database” on page 956.

PAGE TAB COLOR THE COLOR OF THE PAGE TAB.

PAGE PAPER FORMAT FOR INSTANCE A3.

PAGE PAPER NORM FOR INSTANCE ISO.

PAGE PAPER SIZE FOR INSTANCE 420MM X 297MM.

DATAFIELD DESCRIPTION

NAME THE NAME OF THE COMPONENT. YOU CAN HERE ALSO CHOOSE 

WITH QUANTITY, FUNCTION ASPECT, LOCATION ASPECT AND/OR 

PRODUCT ASPECT.

TYPE THE TYPE OF THE COMPONENT.

ARTICLE NO. THE ARTICLE NUMBER OF THE COMPONENT. YOU CAN CHOOSE 

FOR COMPONENT OR FOR SUBDRAWING. THIS ALSO MAKES IT 

POSSIBLE TO LET ARTICLE NUMBERS FOR SUB DRAWINGS APPEAR 

IN THE LIST.

— READ MORE ABOUT SUB DRAWINGS IN “Sub drawings” on 
page 289.

FUNCTION THE FUNCTION OF THE COMPONENT

DESCRIPTION THE DESCRIPTION OF THE COMPONENT FROM THE DATABASE.

OBJECT GROUP NAME IF THE COMPONENT IS PART OF AN OBJECT GROUP, THIS DATA-

FIELD DSIPLAYS THE NAME OF THE OBJECT GROUP. — READ 

MORE ABOUT OBJECT GROUPS IN “Object groups” on 
page 283.

SYMBOL NAME THE SYMBOL FILE NAME OF THE COMPONENT

SYMBOL FIGURE THE SYMBOL FIGURE OF THE COMPONENT

SYMBOL TITLE THE TITLE OF THE COMPONENT

SYMBOL DATE TIME AND DATE FOR SAVING THE SYMBOL. CHOOSE BETWEEN 

DATE AND TIME, DATE, TIME AND YEAR.

DATAFIELD DESCRIPTION
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QUANTITY THE QUANTITY OF THE COMPONENT.
CHOOSE BETWEEN QUANTITY ("NUMBER OF UNITS"), QUANTITY 

COMPL. PACKAGES (ROUNDED UP TO THE NEAREST INTEGER), OR 

QUANTITY IN PACKAGES (SPECIFIED WITH DECIMALS).
WHEN YOU SELECT WITH QUANTITY (ONLY POSSIBLE FOR QUAN-

TITY COMPL. PACKAGES OR QUANTITY IN PACKAGES), BOTH 

QUANTITY AND PACKAGE INFORMATION IS DISPLAYED.
PLEASE NOTE, THAT THE INFORMATION QUANTIY PR. PACKAGE IS 

SPECIFIED IN THE DATABASE FIELD UNITSPERPACK. (SELECT 

SETTINGS => DATABASE => DATABASE SETUP, AND ASSIGN THE 

DATABASE FIELD UNITSPERPACK TO UNITS/PACK. — SEE 

“Transferring article data to symbols and lines” on 
page 672).

YOU CAN ALSO SELECT/DESELECT +(NO OF CABLES). THIS GIVES 

YOU THE NUMBER OF CABLES IN BRACKETS AFTER THE QUANTITY 

IN PARTS LISTS.

TOTAL QUANTITY TOTAL QUANTITY FOR THE FULL PROJECT. HERE YOU CAN SEE 

HOW MANY UNITS OF THIS ARTICLE NUMBER ARE USED IN THE 

PROJECT. CHOOSE BETWEEN QUANTITY ("NUMBER OF UNITS"), 
QUANTITY COMPL. PACKAGES (ROUNDED UP TO THE NEAREST 

INTEGER), OR QUANTITY IN PACKAGES (SPECIFIED WITH DECI-

MALS).
WHEN YOU SELECT WITH QUANTITY (ONLY POSSIBLE FOR QUAN-

TITY COMPL. PACKAGES OR QUANTITY IN PACKAGES), BOTH 

QUANTITY AND PACKAGE INFORMATION IS DISPLAYED.
PLEASE NOTE, THAT THE INFORMATION QUANTIY PR. PACKAGE IS 

SPECIFIED IN THE DATABASE FIELD UNITSPERPACK. (SELECT 

SETTINGS => DATABASE => DATABASE SETUP, AND ASSIGN THE 

DATABASE FIELD UNITSPERPACK TO UNITS/PACK. — SEE 

“Transferring article data to symbols and lines” on 
page 672).

YOU CAN ALSO SELECT/DESELECT +(NO OF CABLES). THIS GIVES 

YOU THE NUMBER OF CABLES IN BRACKETS AFTER THE QUANTITY 

IN PARTS LISTS.

UNIT QUANTITY THE NUMBER OF COMPONENTS REFERRING TO THE UNIT PAGE

PRICE1 PRICE1

PRICE2 PRICE2

TOTAL ARTICLE PRICE1 TOTAL ARTICLE PRICE1

TOTAL ARTICLE PRICE2 TOTAL ARTICLE PRICE2

TOTAL PRICE1 TOTAL PRICE1

TOTAL PRICE2 TOTAL PRICE2

UNIT NAME LIST UNIT NAME LIST. HERE YOU CAN SELECT/DESELECT FUNCTION 

ASPECT, LOCATION ASPECT AND/OR PRODUCT ASPECT.

NAME LIST LIST OF COMPONENTS HAVING THE SAME ARTICLE NUMBER

REFPOSTITON THE PAGE/CURRENT PATH NUMBER OF THE COMPONENT. HERE 

CAN BE REFERRED TO CURRENTPATH, PAGE, FUNCTION ASPECT, 
LOCATION ASPECT AND/OR PRODUCT ASPECT.

MECHANICAL POSITION THE LOCATION OF THE MECHANICAL SYMBOL. CAN BE EITHER X,Y 

POSITION OR FIELD POSITION. PLEASE REFER TO “References 
in Lists to the position of mechanical symbols” on 
page 705 FOR FURTHER INFORMATION.

DATAFIELD DESCRIPTION
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TERMINALS LIST DATAFIELDS

The list also contains datafields from the attached database. If you use a database 
from PCSCHEMATIC, the datafield names from the database are written in capi-
tals. This makes it easy to distinguish these datafields from the other datafields. If 
you create your own database, it is recommended that you also write these names 
in capitals.

Fields from the PCSCHEMATIC database are not displayed below. You can see 
these in “Datafields in the component database” on page 956.

MECHANICAL PAGE THE PAGE NUMBER FOR THE GROUND PLAN PAGE, WHERE THE 

MECHANICAL SYMBOL IS PLACED. YOU CAN HERE CHOOSE 

WHETHER TO ADD THE LOCATION ASPECT, THE FUNCTION 

ASPECT AND/OR THE PRODUCT ASPECT ALONG WITH THE PAGE 

NUMBER.

=+DESIGN. THE REFERENCE DESIGNATION FOR THE COMPONENT:
CHOOSE EITHER DESIGNATION, DESCRIPTION OR DESCRIPTION 2 
— AND ...
CHOOSE EITHER FULL REFERENCE DESGINATION, FUNCTION 

ASPECT, LOCATION ASPECT OR PRODUCT ASPECT.

SYMBOL TYPE THE MAIN SYMBOL TYPE FOR THE COMPONENT.

CABLE WIRES CHOOSE BETWEEN WIRE COUNT, USED WIRE COUNT AND FREE 

WIRES COUNT.

EAN13 BARCODE DATAFIELD WHICH AUTOMATICALLY GENERATES AN EAN13 BAR-

CODE FOR THE COMPONENT. YOU CAN HERE CHOOSE THE 

BETWEEN STANDARD SIZES NORMAL 12X31 MM, SMALL 10X25 
MM AND LARGE 20X62 MM.

LINE NUMBER LINE/SUBJECT NUMBER FOR THE LIST POINT. CHOOSE BETWEEN 

ON ALL LINES OR ON USED LINES.

SYMBOL FILE NAME THE LIBRARY FILENAME FOR THE SYMBOL.
YOU CAN HERE CHOOSE WITH FILE PATH, FILE NAME AND WITH 

FILE EXTENSION. WHEN THERE ARE MORE THAN ONE SYMBOL 

FOR A COMPONENT, THE DATAFIELD INSERTS THE FILENAME FOR 

THE MOST SIGNIFICANT SYMBOL.

DATAFIELD DESCRIPTION

T.NAME THE NAME OF THE TERMINAL. YOU CAN HERE SELECT WITH SUB 

NAME, WITH CONNECTION NAME, FUNCTION ASPECT, LOCATION 

ASPECT AND/OR PRODUCT ASPECT.

T.TYPE THE TYPE OF THE TERMINAL.

T.ARTICLE THE ARTICLE NUMBER OF THE TERMINAL.

T.FUNCTION THE FUNCTION OF THE TERMINAL.

DESCRIPTION THE DESCRIPTION OF THE COMPONENT FROM THE DATABASE. 
CHOOSE EITHER TERMINAL, EXTERNAL (THE DESCRIPTION FROM 

THE INTERNALLY CONNECTED COMPONENT) OR INTERNAL (THE 

DESCRIPTION FROM THE EXTERNALLY CONNECTED COMPONENT).

T.=+DESIGN THE REFERENCE DESIGNATION FOR THE TERMINAL:
CHOOSE EITHER DESIGNATION, DESCRIPTION OR DESCRIPTION 2  
— AND ...
CHOOSE EITHER FULL REFERENCE DESGINATION, FUNCTION 

ASPECT, LOCATION ASPECT OR PRODUCT ASPECT.

DATAFIELD DESCRIPTION
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C.NAME THE CONNECTION NAME OF THE TERMINAL. CHOOSE EITHER OUT-

PUT SIDE, INPUT SIDE, INPUT SIDE/OUTPUT SIDE OR OUTPUT SIDE/
INPUT SIDE.

C.FUNCTION THE CONNECTION FUNCTION OF THE TERMINAL. CHOOSE EITHER 

OUTPUT SIDE, INPUT SIDE, INPUT SIDE/OUTPUT SIDE OR OUTPUT 

SIDE/INPUT SIDE.

C.LABEL THE CONNECTION LABEL OF THE TERMINAL. CHOOSE EITHER OUT-

PUT SIDE, INPUT SIDE, INPUT SIDE/OUTPUT SIDE OR OUTPUT SIDE/
INPUT SIDE.

C.DESCR. THE CONNECTION DESCRIPTION OF THE TERMINAL. CHOOSE 

EITHER OUTPUT SIDE, INPUT SIDE, INPUT SIDE/OUTPUT SIDE OR 

OUTPUT SIDE/INPUT SIDE.

C.REF THE CONNECTION CURRENT PATH OF THE TERMINAL. YOU CAN 

HERE SELECT FUNCTIONAL ASPECT, LOCATIONAL ASPECT, PAGE 
AND CURRENT PATH.

IE.NAME INTERNAL/EXTERNAL COMPONENT NAME. THIS CAN EITHER BE 

EXTERNAL OR INTERNAL. YOU CAN HERE SELECT WITH SUB 

NAME, WITH CONNECTION NAME, FUNCTION ASPECT, LOCATION 

ASPECT AND/OR PRODUCT ASPECT.

IE.TYPE INTERNAL/EXTERNAL COMPONENT TYPE. THIS CAN EITHER BE 

EXTERNAL OR INTERNAL.

IE.ARTICLE INTERNAL/EXTERNAL COMPONENT ARTICLE NUMBER. THIS CAN 

EITHER BE EXTERNAL OR INTERNAL.

IE.FUNCTION INTERNAL/EXTERNAL COMPONENT FUNCTION. THIS CAN EITHER BE 

EXTERNAL OR INTERNAL.

IE.=+DESIGN INTERNAL/EXTERNAL COMPONENT FUNCTION/LOCATION. THIS 

CAN EITHER BE EXTERNAL OR INTERNAL. CHOOSE BETWEEN REF-

ERENCE DESIGNATION, FUNCTION ASPECT, LOCATION ASPECT OR 

PRODUCT ASPECT.

IE.=+DESCRIPTION THE DESCRIPTION FOR THE INTERNAL/EXTERNAL COMPONENT 

FUNCTION/LOCATION. THIS CAN EITHER BE EXTERNAL OR INTER-

NAL. CHOOSE BETWEEN REFERENCE DESIGNATION, FUNCTION 

ASPECT, LOCATION ASPECT OR PRODUCT ASPECT.

IE.C.NAME INTERNAL/EXTERNAL COMPONENT CONNECTION NAME. THIS CAN 

EITHER BE EXTERNAL OR INTERNAL.

IE.C.FUNCTION INTERNAL/EXTERNAL COMPONENT CONNECTION FUNCTION. THIS 

CAN EITHER BE EXTERNAL OR INTERNAL.

IE.C.LABEL INTERNAL/EXTERNAL COMPONENT CONNECTION LABEL. THIS CAN 

EITHER BE EXTERNAL OR INTERNAL.

IE.C.DESCR. INTERNAL/EXTERNAL COMPONENT CONNECTION DESCRIPTION. 
THIS CAN EITHER BE EXTERNAL OR INTERNAL.

IE.C.REF. INTERNAL/EXTERNAL COMPONENT CONNECTION CURRENT PATH. 
THIS CAN EITHER BE EXTERNAL OR INTERNAL. YOU CAN HERE 

SELECT WITH SUB NAME, WITH CONNECTION NAME, FUNCTION 

ASPECT, LOCATION ASPECT AND/OR PRODUCT ASPECT.

IE.SIGNAL INTERNAL/EXTERNAL SIGNAL NAME. THIS CAN EITHER BE EXTER-

NAL OR INTERNAL. YOU CAN ALSO CHOOSE FUNCTION ASPECT, 
LOCATION ASPECT AND/OR PRODUCT ASPECT.

IE.WIRENO INTERNAL/EXTERNAL WIRE NUMBER. THIS CAN EITHER BE EXTER-

NAL OR INTERNAL.YOU CAN ALSO CHOOSE FUNCTION ASPECT, 
LOCATION ASPECT OR PRODUCT ASPECT.

DATAFIELD DESCRIPTION
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CABLE LIST DATAFIELDS

The list also contains datafields from the attached database. If you use a database 
from PCSCHEMATIC, the datafield names from the database are written in capi-
tals. This makes it easy to distinguish these datafields from the other datafields. If 
you create your own database, it is recommended that you also write these names 
in capitals.

IE.CB.NAME INTERNAL/EXTERNAL CABLE NAME. THIS CAN EITHER BE EXTER-

NAL OR INTERNAL. YOU CAN HERE SELECT WITH SUB NAME, WITH 

CONNECTION NAME, FUNCTION ASPECT, LOCATION ASPECT AND/
OR PRODUCT ASPECT.

IE.CB.TYPE INTERNAL/EXTERNAL CABLE TYPE. THIS CAN EITHER BE EXTER-

NAL OR INTERNAL.

IE.CB.ARTICLE INTERNAL/EXTERNAL CABLE ARTICLE NUMBER. THIS CAN EITHER 

BE EXTERNAL OR INTERNAL.

IE.CB.FUNCTION INTERNAL/EXTERNAL CABLE FUNCTION. THIS CAN EITHER BE 

EXTERNAL OR INTERNAL.

IE.CB.=+DESIGN. INTERNAL/EXTERNAL CABLE FUNCTION/LOCATION. THIS CAN 

EITHER BE EXTERNAL OR INTERNAL. CHOOSE BETWEEN FULL 

REFERENCE DESIGNATION, FUNCTION ASPECT, LOCATION ASPECT 
AND/OR PRODUCT ASPECT.

IE.CB.=+DESCRIPTION DESCRIPTION FOR THE INTERNAL/EXTERNAL CABLE FUNCTION/
LOCATION. THIS CAN EITHER BE EXTERNAL OR INTERNAL. 
CHOOSE BETWEEN FULL REFERENCE DESIGNATION, FUNCTION 

ASPECT, LOCATION ASPECT OR PRODUCT ASPECT.

IE.CB.W.NAME INTERNAL/EXTERNAL CABLE WIRE NAME. THIS CAN EITHER BE 

EXTERNAL OR INTERNAL.

IE.CB.W.FUNCTION INTERNAL/EXTERNAL CABLE WIRE FUNCTION. THIS CAN EITHER 

BE EXTERNAL OR INTERNAL.

IE.CB.W.LABEL INTERNAL/EXTERNAL CABLE WIRE LABEL. THIS CAN EITHER BE 

EXTERNAL OR INTERNAL.

IE.CB.W.DESCR. INTERNAL/EXTERNAL CABLE WIRE DESCRIPTION. THIS CAN 

EITHER BE EXTERNAL OR INTERNAL.

IE.CB.W.REF. INTERNAL/EXTERNAL CABLE WIRE CURRENT PATH. THIS CAN 

EITHER BE EXTERNAL OR INTERNAL. YOU CAN HERE SELECT CUR-

RENT PATH, PAGE, FUNCTION ASPECT, LOCATION ASPECT AND/
OR PRODUCT ASPECT.

JUMPER LINK — SEE “Jumper links in Lists and Terminal plans” on 
page 92.

LINE NUMBER LINE/SUBJECT NUMBER FOR THE LIST POINT. YOU CAN HERE 

CHOOSE ON ALL LINES OR ON USED LINES.

POS. NO. THE POSITION NUMBER.

LINE-NAME NAME OF THE CONNECTED LINE. CHOOSE BETWEEN OUTPUT SIDE 
AND INPUT SIDE.

LINE-TYPE TYPE OF THE CONNECTED LINE. CHOOSE BETWEEN OUTPUT SIDE 
AND INPUT SIDE.

LINE-ARTICLE ARTICLE NUMBER OF THE CONNECTED LINE. CHOOSE BETWEEN 

OUTPUT SIDE AND INPUT SIDE.

LINE-FUNCTION FUNCTION OF THE CONNECTED LINE. CHOOSE BETWEEN OUTPUT 

SIDE AND INPUT SIDE.

DATAFIELD DESCRIPTION
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Fields from the PCSCHEMATIC database are not displayed below. You can see 
these in “Datafields in the component database” on page 956.

DATAFIELD DESCRIPTION

CB.NAME CABLE NAME. THIS CAN EITHER BE WITH SUB NAME, WITH CONNEC-

TION NAME, FUNCTION ASPECT, LOCATION ASPECT AND/OR PRODUCT 

ASPECT.

CB.TYPE CABLE TYPE

CB.ARTICLE CABLE ARTICLE NUMBER

CB.FUNCTION CABLE FUNCTION

DESCRIPTION THE DESCRIPTION OF THE COMPONENT FROM THE DATABASE. CHOOSE 

EITHER CABLE, FROM (THE DESCRIPTION FROM THE COMPONENT IN 

THE "FROM" END) OR TO (THE DESCRIPTION FROM THE COMPONENT IN 

THE "TO" END).

CB.=+DESIGN. THE REFERENCE DESIGNATION FOR THE CABLE:
CHOOSE EITHER DESIGNATION, DESCRIPTION OR DESCRIPTION 2 
— AND ...
CHOOSE EITHER FULL REFERENCE DESGINATION, FUNCTION ASPECT, 
LOCATION ASPECT OR PRODUCT ASPECT.

CB.W.NAME CABLE WIRE NAME

CB.W.FUNCTION CABLE WIRE TYPE

CB.W.LABEL CABLE WIRE ARTICLE NUMBER

CB.W.DESCR. CABLE WIRE FUNCTION

CB.W.REF. CABLE WIRE CURRENT PATH. HERE CAN BE REFERRED TO CURRENT 

PATH, PAGE, FUNCTION ASPECT, LOCATION ASPECT AND/OR PRODUCT 

ASPECT.

FT.NAME FROM/TO COMPONENT NAME. THIS CAN EITHER BE WITH SUB NAME, 
WITH CONNECTION NAME, FUNCTION ASPECT, LOCATION ASPECT 
AND/OR PRODUCT ASPECT.

FT.TYPE FROM/TO COMPONENT TYPE

FT.ARTICLE FROM/TO COMPONENT ARTICLE NUMBER

FT.FUNCTION FROM/TO COMPONENT FUNCTION

FT.=+DESIGN. FROM/TO COMPONENT REFERENCE DESIGNATION. THIS CAN EITHER BE 

FULL REFERENCE DESIGNATION, FUNCTION ASPECT, LOCATION 

ASPECT OR PRODUCT ASPECT.

FT.=+DESCRIP-

TION

DESCRIPTION FOR THE FROM/TO COMPONENT REFERENCE DESIGNA-

TION. THIS CAN EITHER BE FULL REFERENCE DESIGNATION, FUNCTION 

ASPECT, LOCATION ASPECT OR PRODUCT ASPECT.

FT.C.NAME FROM/TO COMPONENT CONNECTION NAME

FT.C.FUNCTION FROM/TO COMPONENT CONNECTION TYPE

FT.C.LABEL FROM/TO COMPONENT CONNECTION ARTICLE NUMBER

FT.C.DESCR. FROM/TO COMPONENT CONNECTION FUNCTION

FT.C.REF. FROM/TO COMPONENT CONNECTION CURRENT PATH. HERE CAN BE 

REFERRED TO CURRENT PATH, PAGE, FUNCTION ASPECT, LOCATION 

ASPECT AND/OR PRODUCT ASPECT.

CB.W.SIGNAL CABLE WIRE SIGNAL NAME. YOU CAN ALSO SELECT FUNCTION ASPECT, 
LOCATION ASPECT AND/OR PRODUCT ASPECT.

CB.W.WIRENO CABLE WIRE WIRE NUMBER. YOU CAN ALSO SELECT FUNCTION 

ASPECT, LOCATION ASPECT AND/OR PRODUCT ASPECT.

CABLE WIRES CHOOSE BETWEEN WIRE COUNT, USED WIRES COUNT, FREE WIRES 

COUNT OR FREE WIRE NAMES.
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PLC LIST DATAFIELDS

The list also contains datafields from the attached database. If you use a database 
from PCSCHEMATIC, the datafield names from the database are written in capi-
tals. This makes it easy to distinguish these datafields from the other datafields. If 
you create your own database, it is recommended that you also write these names 
in capitals.

Fields from the PCSCHEMATIC database are not displayed below. You can see 
these in “Datafields in the component database” on page 956.

The PLC connected component

For all datafields from the database it is possible to specify whether to display data 
for the PLC or the Connected component. If Connected component is chosen, 
data will be fetched from the component that the PLC either activates data from or 
receives data from.

When you have selected a symbol on a project page and enter the dialog box 
Component data, you can specify that the component represented by the sym-
bols should be understood as the connected component by selecting The PLC 
connected component. — See “The PLC connected component” on page 177.

LINE NUMBER LINE/SUBJECT NUMBER FOR THE LIST POINT. CHOOSE ON ALL LINES 
OR ON USED LINES.

LINE-NAME NAME OF THE CONNECTED LINE.

LINE-TYPE TYPE OF THE CONNECTED LINE.

LINE-ARTICLE ARTICLE NUMBER OF THE CONNECTED LINE.

LINE-FUNCTION FUNCTION OF THE CONNECTED LINE.

QUANTITY QUANTITY. CHOOSE BETWEEN: QUANTITY: 3 (FROM THE QUANTITY 
FIELD IN THE DIALOG BOX LINE ARTICLE DATA), QUANTITY COMPL. 
PACKAGES: 1 (QUANTITY IN COMPLETE PACKAGES — THE SIZE OF THE 

PACKAGES IS SPECIFIED IN THE DATABASE FIELD UNITSPERPACK) 
AND QUANTITY IN PACKAGES: 0,6.

LENGTH DISPLAYS THE LENGTH OF FOR INSTANCE A CABLE OR A WIRE.

— SEE “Cable direction and Default cable quantity” on 
page 923 AND “The Quantity field in the dialog box Compo-
nent data” on page 175.

DATAFIELD DESCRIPTION

PLC NAME PLC NAME. THIS CAN EITHER BE WITH SUB NAME, WITH CONNECTION 

NAME, FUNCTION ASPECT, LOCATION ASPECT AND/OR PRODUCT 

ASPECT.

PLC TYPE PLC TYPE

PLC ARTICLE PLC ARTICLE

PLC FUNCTION PLC FUNCTION

DESCRIPTION THE DESCRIPTION OF THE COMPONENT FROM THE DATABASE. CHOOSE 

EITHER PLC OR CONNECTED COMPONENT.

DATAFIELD DESCRIPTION
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PLC =+DESIGN. PLC REFERENCE DESIGNATIONS. THIS CAN EITHER BE FULL REFER-

ENCE DESIGNATION, FUNCTION ASPECT, LOCATION ASPECT AND/OR 

PRODUCT ASPECT. CHOOSE EITHER DESIGNATION OR DESCRIPTION.

C.NAME CONNECTION NAME OF PLC

C.FUNCTION CONNECTION FUNCTION OF PLC

C.LABEL CONNECTION LABEL OF PLC

C.DESCR. CONNECTION DESCRIPTION OF PLC

I/O STATUS SPECIFIES WHETHER THE I/O STATUS IS INPUT OR OUTPUT.

I/O STATUS TYPE I/O STATUS TYPE — SPECIFIES WHETHER IT FOR INSTANCE IS AN ANA-

LOGUE OR A DIGITAL I/O.

C.REF. CONNECTION CURRENT PATH OF PLC. HERE CAN BE REFERRED TO 

CURRENT PATH, PAGE, FUNCTION ASPECT, LOCATION ASPECT AND/OR 

PRODUCT ASPECT.

CC.NAME CONNECTED COMPONENT NAME. THIS CAN EITHER BE WITH SUB 

NAME, WITH CONNECTION NAME, FUNCTION ASPECT, LOCATION 

ASPECT AND/OR PRODUCT ASPECT

CC.TYPE CONNECTED COMPONENT TYPE

CC.ARTICLE CONNECTED COMPONENT ARTICLE NUMBER

CC.FUNCTION CONNECTED COMPONENT FUNCTION

CC.=+DESIGN. CONNECTED COMPONENT FUNCTIONAL AND LOCATIONAL ASPECT. 
THIS CAN EITHER BE FULL REFERENCE DESIGNATION, FUNCTION 

ASPECT, LOCATION ASPECT OR PRODUCT ASPECT. CHOOSE BETWEEN 

DESIGNATION AND DESCRIPTION.

CC.C.NAME CONNECTED COMPONENT CONNECTION NAME.

CC.C.FUNCTION CONNECTED COMPONENT CONNECTION FUNCTION

CC.C.LABEL CONNECTED COMPONENT CONNECTION LABEL

CC.C.DESCR. CONNECTED COMPONENT CONNECTION DESCRIPTION

CC.C.REF. CONNECTED COMPONENT CONNECTION CURRENT PATH. HERE CAN BE 

REFERRED TO CURRENT PATH, PAGE, FUNCTION ASPECT, LOCATION 

ASPECT AND/OR PRODUCT ASPECT.

C.SIGNAL CONNECTED SIGNAL NAME. YOU CAN ALSO CHOOSE FUNCTION 

ASPECT, LOCATION ASPECT AND/OR PRODUCT ASPECT.

C.WIRENO. CONNECTED WIRE NUMBER. YOU CAN ALSO CHOOSE FUNCTION 

ASPECT, LOCATION ASPECT AND/OR PRODUCT ASPECT.

SIGNALPATH PLC SIGNAL PATH THROUGH TERMINALS AND CABLES. THIS CAN 

EITHER BE WITH SUB NAME, WITH CONNECTION NAME, FUNCTION 

ASPECT, LOCATION ASPECT AND/OR PRODUCT ASPECT.

LINE NUMBER LINE/SUBJECT NUMBER FOR THE LIST POINT. CHOOSE BETWEEN ON 

ALL LINES AND ON USED LINES.

LINE-NAME NAME OF THE CONNECTED LINE. CHOOSE BETWEEN AT PLC CONNEC-

TION AND AT CONNECTED SYMBOL. — SEE “Article data on lines” 
on page 80.

LINE-TYPE TYPE OF THE CONNECTED LINE. CHOOSE BETWEEN AT PLC CONNEC-

TION AND AT CONNECTED SYMBOL. — SEE “Article data on lines” 
on page 80.

DATAFIELD DESCRIPTION
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LINE-ARTICLE ARTICLE NUMBER OF THE CONNECTED LINE. CHOOSE BETWEEN AT 

PLC CONNECTION AND AT CONNECTED SYMBOL. — SEE “Article 
data on lines” on page 80.

LINE-FUNCTION FUNCTION OF THE CONNECTED LINE. CHOOSE BETWEEN AT PLC CON-

NECTION AND AT CONNECTED SYMBOL. — SEE “Article data on 
lines” on page 80.

DATAFIELD DESCRIPTION
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CONNECTIONS LIST DATAFIELDS

The list also contains datafields from the attached database. If you use a database 
from PCSCHEMATIC, the datafield names from the database are written in capi-
tals. This makes it easy to distinguish these datafields from the other datafields. If 
you create your own database, it is recommended that you also write these names 
in capitals.

Fields from the PCSCHEMATIC database are not displayed below. You can see 
these in “Datafields in the component database” on page 956.

If you have created your own line datafields, these also appears in the list of con-
nections list datafields. — See “Creating symbol datafields” on page 798 and “Line 

datafields” on page 82.

DATAFIELD DESCRIPTION

SIGNAL THE SIGNAL NAME FOR THE CONNECTION. YOU CAN CHOOSE TO 

INCLUDE LOCATION ASPECT, FUNCTION ASPECT AND/OR PRODUCT 

NAME.

NAME THE NAME OF THE COMPONENT. YOU CAN CHOOSE FROM (THE COMPO-

NENT IN THE "FROM" END), TO (THE COMPONENT IN THE "TO" END), 
FROM/TO OR TO/FROM.
YOU CAN ALSO CHOOSE TO INCLUDE WITH SUB NAME, WITH CONNEC-

TION NAME, FUNCTION ASPECT, LOCATION ASPECT AND/OR PRODUCT 

ASPECT.

TYPE THE TYPE DESCRIPTION FOR THE COMPONENT. YOU CAN CHOOSE 

FROM OR TO.

ARTICLE NO. THE ARTICLE NUMBER FOR THE COMPONENT. YOU CAN CHOOSE FROM 
OR TO.

FUNCTION THE FUNCTION OF THE COMPONENT. YOU CAN CHOOSE FROM OR TO.

DESCRIPTION THE DESCRIPTION OF THE COMPONENT FROM THE DATABASE. CHOOSE 

EITHER FROM (THE DESCRIPTION FROM THE COMPONENT IN THE 

"FROM" END), TO (THE DESCRIPTION FROM THE COMPONENT IN THE 

"TO" END), LINE ARTICLE DATA OR WIRE NUMBER.

=+DESIGN. THE REFERENCE DESIGNATION FOR THE COMPONENT:
CHOOSE FROM (THE COMPONENT IN THE "FROM" END) OR TO (THE 

COMPONENT IN THE "TO" END) — AND ...
CHOOSE EITHER FULL REFERENCE DESIGNATION, FUNCTION ASPECT, 
LOCATION ASPECT OR PRODUCT ASPECT.

=+DESCRIPTION THE DESCRIPTION OF THE REFERENCE DESIGNATION FOR THE COMPO-

NENT:
CHOOSE FROM (THE COMPONENT IN THE "FROM" END) OR TO (THE 

COMPONENT IN THE "TO" END) — AND ...
CHOOSE EITHER FULL REFERENCE DESIGNATION, FUNCTION ASPECT, 
LOCATION ASPECT OR PRODUCT ASPECT.

C.NAME THE COMPONENT CONNECTION NAME

C.FUNCTION THE COMPONENT CONNECTION TYPE

C.LABEL THE COMPONENT CONNECTION LABEL

C.DESCR. THE COMPONENT CONNECTION DESCRIPTION

C.REF. THE COMPONENT CONNECTION CURRENT PATH. HERE CAN BE 

REFERRED TO CURRENT PATH, PAGE, FUNCTION ASPECT, LOCATION 

ASPECT AND/OR PRODUCT ASPECT.

WIRENO THE WIRE NUMBER FOR THE CONNECTION. THIS CAN EITHER BE WITH 

FUNCTION ASPECT, LOCATION ASPECT AND/OR PRODUCT ASPECT.
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WIRENO TYPE THE TYPE OF THE WIRE NUMBER FOR THE CONNECTION.

WIRENO ARTICLE THE ARTICLE NUMBER OF THE WIRE NUMBER FOR THE CONNECTION.

WIRENO FUNCTION THE FUNCTION OF THE WIRE NUMBER FOR THE CONNECTION.

WIRENO QUANTITY THE QUANTITY OF THE WIRE NUMBER FOR THE CONNECTION.

LINE NUMBER THE LINE OR ITEM NUMBER OF THE LIST ITEM. CHOOSE EITHER ON ALL 

LINES OR ON USED LINES.

LINE-NAME THE NAME OF THE CONNECTED LINE.

LINE-TYPE THE TYPE OF THE CONNECTED LINE.

LINE-ARTICLE THE ARTICLE NUMBER OF THE CONNECTED LINE.

LINE-FUNCTION THE FUNCTION OF THE CONNECTED LINE.

LINE LENGTH WIRE LENGTH OF THE CONNECTION (LINE QUANTITY).

JUMPER LINK — SEE “Jumper links in Lists and Terminal plans” on page 92.

CB.NAME THE CABLE NAME. YOU CAN ALSO CHOOSE TO INCLUDE WITH SUB 

NAME, WITH CONNECTION NAME, FUNCTION ASPECT, LOCATION 

ASPECT AND/OR PRODUCT ASPECT.

CB.W.NAME THE CABLE WIRE NAME.

DATAFIELD DESCRIPTION
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SYNTAX FOR DATABASE FIELDS IN THE DATABASE

In this appendix you can see the syntax for what you can specify in the most impor-
tant database fields in the component database.

These database fields are described in this chapter:

Beyond these database fields, these database fields are described here:

- The database field ACCESSORY: See “Accessories in the database” on 
page 664

- The database field REFID: See “Specifying Ref. Letter for the symbol in the 
Database” on page 667

The interpretation of the fields in the database (mapping)

How Automation interprets the information in the different fields in the database, 
is specified in the dialog box Settings => Database => Database setup => Com-
ponent data.

As a default setting it is here for instance specified that the database field 
PCSTYPE contains the names of the electrical symbols, and that the database 
field MECTYPE contains the names of the mechanical symbols — and so on. 
When this appendix refers to the database fields PCSTYPE, MECTYPE etc. this is 
in the context that the settings ("mapping") in this dialog box has not been changed 
from the standard settings.

Read more about this in “Transferring article data to symbols and lines” on 
page 672.

General description of the database fields in the database

In “Electrical and Mechanical symbols for components” on page 651 you will find a 
general description of the database fields in the database.

DATABASE FIELD APPENDIX

PCSTYPE SEE “The database field PCSTYPE in the compo-
nent database” on page 948.

PINDATA SEE “The database field PINDATA in the component 
database” on page 950 AND “The Database field 
PINDATA: Counting” on page 952.

MECTYPE SEE “The Database field MECTYPE” on page 954.
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Syntax for database fields in the database
THE DATABASE FIELD PCSTYPE IN THE COMPONENT DATABASE

Read more about the database field PCSTYPE in “Electrical symbols” on 
page 651.

One symbol:

PLC1OUT-UF

Multiple symbols: ;

PLC1OUT-P;PLC1OUT-UF

Multiple symbols of the same kind: #n

PLC1OUT-UF#8

PLCREF8;PLC1OUT-UF#8

Or-function with multiple drawing options: [A|B|C]

PLCREF8;[PLC1OUT-UF#8|PLC8OUT]

Sub names: A( )

PLCREF4I4O;O(PCSOUT-UF#4);I(PLCIN-UF#4)

Symboltype: =A or =A,B

PLCREF8-; PLC1OUT-UF=T,P#8

Options:

N Normal T,R Terminal/Relay

R Relay T,O Terminal/Open

O Open T,C Terminal/Close

C Close T,S Terminal/Switch

S Switch T,P Terminal/PLC

M MasterReference

W WithReference

T Terminal

PREREQUISITE: "DIAGRAM SYMBOL" IS SET TO PCSTYPE

IN ORDER FOR THE PROGRAM TO UNDERSTAND THAT THE PCSTYPE FIELD 

IN THE DATABASE CONTAINS NAMES OF ONE OR MORE ELECTRICAL SYM-

BOLS FOR THE COMPONENT, THE FIELD DIAGRAM SYMBOL MUST BE SET TO 

PCSTYPE IN THE DIALOG BOX SETTINGS => DATABASE => DATABASE 

SETUP => COMPONENT DATA. THIS IS ALSO THE DEFAULT SETTING WHEN 

INSTALLING Automation.

READ MORE ABOUT THIS IN “Transferring article data to symbols and 
lines” on page 672.
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P PLC

X PLC Reference

States: §n

PLCREFOUT4D4A;PLC1OUTAD#4§1; PLC1OUTAD#4§2

Activating "With reference"

SYMBOLFILENAME*W With reference is activated for the symbol,

with the status With reference)

SYMBOLFILENAME*M With reference is activated for the symbol,

with the status Main reference)

FILE=

If the PCSTYPE field is too short, you can type in FILE=xxxxxx.pcs, where 
xxxxxx.pcs is the file containing the information for the PCSTYPE field, specified 
according to the syntax described above.

The file must be placed in the database folder, which you have selected in Set-
tings => Directories.

Please note! In PCSTYPE files semicolon is the same as a line break:

PLCREF8-;PLC1OUT-UF#8

Is equal to: PLCREF8-

PLC1OUT-UF#8

Or: PLCREF8-;

PLC1OUT-UF#8;
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Syntax for database fields in the database
THE DATABASE FIELD PINDATA IN THE COMPONENT DATABASE

Read more about pindata in “Connection names/Pindata” on page 657 and 
“Addressing PLC symbols via the database” on page 660.

One connection:

10

Multiple connections on the same symbol: ,

1,2,3,4,5,6

Consecutive connection names on the same symbol: ,..,

1,..,6

Separation between the connections of multiple symbols: ;

1,2;3,4;5,6

Consecutive connection names on symbols with a single con-
nection: ;..;

1;..;6

Specification of I/O address: [adr]

1[10.00];2[10.01];3[10.02]

Specification of I/O status: /I:status

1[/I:OP];2[/I:IP]

1[10.00/I:IP];2[10.01/I:IP]

Options:

ET External terminal connection

IT Internal terminal connection

OP Output PLC connection, I/O Status type = None

OPA Output PLC connection, I/O Status type = Analog

PREREQUISITE: "PIN NAMES" IS SET TO PCSTYPE

IN ORDER FOR THE PROGRAM TO UNDERSTAND THAT THE PCSTYPE FIELD 

IN THE DATABASE CONTAINS NAMES OF ONE OR MORE ELECTRICAL SYM-

BOLS FOR THE COMPONENT, THE FIELD PIN NAMES MUST BE SET TO PIN-
DATA IN THE DIALOG BOX SETTINGS => DATABASE => DATABASE SETUP 

=> COMPONENT DATA. THIS IS ALSO THE DEFAULT SETTING WHEN INSTALL-

ING Automation.

READ MORE ABOUT THIS IN “Transferring article data to symbols and 
lines” on page 672.
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OPD Output PLC connection, I/O Status type = Digital

IP Input PLC connection, I/O Status type = None

IPA Input PLC connection, I/O Status type = Analog

IPD Input PLC connection, I/O Status type = Digital

EI Eksternal terminal connection with PLC input

EO Eksternal terminal connection with PLC output

II Internal terminal connection with PLC input

IO Internal terminal connection with PLC output

N Changes the status to "no status"
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Syntax for database fields in the database
THE DATABASE FIELD PINDATA: COUNTING

Read more about counting functions in the PINDATA field in “Addressing PLC sym-
bols via the database” on page 660.

Counting on the same symbol: {++(A),}#n

Please note: There must be a comma before }

{++(1),}#16 => 1,2,3,4,5,6,……….

{++(1)[10.++(0)],}#16 => 1[10.0],2[10.1],3[10.2],……….

{A++(1)[Y10.++(0)],}#16 => A1[Y10.0],A2[Y10.1],A3[Y10.2],……….

Counting on multiple symbols with one connection each:
{++(A);}#n

Please note: There must be a semicolon before }

{++(1);}#16 => 1;2;3;4;5;6;……….

{++(1)[10.++(0)];}#16 => 1[10.0];2[10.1];3[10.2];……….

{A++(1)[Y10.++(0)];}#16 => A1[Y10.0];A2[Y10.1];A3[Y10.2];……….

Counting on multiple symbols with two connections each:
{++(A),++(B);}#n

{++(1),++(1)G;}#8 => 1,1G;2,2G;3,3G;………….

{++(1)[10.++(0)],++(1)G;}#8=>1[10.0],1G;2[10.1],2G;……..

Incrementing with more than 1: {++d(A);}#n

{++2(1);}#8 => 1;3;5;7;9;……

{++2(1),++2(2);}#8 => 1,2;3,4;5,6;7,8;9,10;……

Incrementing with specified numbering system: {++(DA);}#n

{++(1)[10.++(D0)];}#8 => {++(1)[10.++(0)];}#8 Decimal

{++(1)[10.++(H0)];}#8 => Hexadecimal

{++(1)[10.++(O0)];}#8 => Octal

{++(1)[10.++(B0)];}#8 => Binary

Neutralize the significance of D,H,O,B: {++(/DA);}#n

Please note: There must be placed a / before D

{++(1)[++(/O0)];}#8 => 1,O0;2,O2;3,O3;……..

Specification of field width (number of digits): {++(A:x);}#n

{++(1)[10.++(00:2)];}#8 => 1[10.00];2[10.01];3[10.02];……

Decrementing: {--(A);}#n

{--(20),++(1);}#4 => 20,1;19,2;18,3;17,4;……….
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Example

A PLC reference symbol with two connections for each PLC output and eight PLC 
symbols with each two connections pr. symbol:

PCSTYPE = PLCREF8-1;PLC1OUT-P#8

PINDATA = {B++(0)[++(10.00)],A++(0),}#8; {B++(0),A++(0);}#8

The incremented value of PINDATA:

B0[10.00],A0,B1[10.01],A1,……..,B7[10.07],A7; B0,A0; B1,A1;……….;B7,A7

FILE=

If the PINDATA field is to short, you can type in FILE=xxxxxx.pin, where 
xxxxxx.pin is the name of the file with the PINDATA contents, specified according 
to the syntax described above.

The file must be placed in the database folder, which you have selected under Set-
tings => Directories.

Please note! In PCSTYPE files semicolon is the same as a line break:

{B++(0)[++(10.00)],A++(0),}#8; {B++(0),A++(0);}#8

Is equal to: {B++(0)[++(10.00)],A++(0),}#8

{B++(0),A++(0);}#8

Or: {B++(0)[++(10.00)],A++(0),}#8;

{B++(0),A++(0);}#8;
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Syntax for database fields in the database
THE DATABASE FIELD MECTYPE

Read more about the database field MECTYPE in “Mechanical symbols in the 
database” on page 662.

One symbol:

PCSMV3

Multiple symbols: ;

Specification of two different symbols:

PCSMV3;PCSMV5

Multiple symbols of the same kind: #n

Specification of 8 PCSMV3 symbols:

PCSMV3#8

PCSMV5;PCSMV3#8 (1 PCSMV5 symbol and 8 PCSMV3 symbols)

Or-function with multiple drawing options: [A|B|C]

The symbol PCSMV3 and the symbol PCSMV4 or PCSMV5:

PCSMV3;[PCSMV4|PCSMV5]

States: §n

The symbol PCSMV3 displayed in state 1:

PCSMV3§1

Dimensions on wire tryay: #xXXmmyYYmm

A wire tray with the width 30mm and the height 40mm is specified like this:

#x30mmy40mm

These values are also used for calculating capacity in wire trays in PCSCHE-
MATIC Panelrouter.

PREREQUISITE: "MECHANICAL SYMBOL" IS SET TO MECTYPE

IN ORDER FOR THE PROGRAM TO UNDERSTAND THAT THE MECTYPE FIELD 

IN THE DATABASE CONTAINS NAMES OF ONE OR MORE ELECTRICAL SYM-

BOLS FOR THE COMPONENT, THE FIELD MECHANICAL SYMBOL MUST BE SET 

TO MECTYPE IN THE DIALOG BOX SETTINGS => DATABASE => DATABASE 

SETUP => COMPONENT DATA. THIS IS ALSO THE DEFAULT SETTING WHEN 

INSTALLING Automation.

READ MORE ABOUT THIS IN “Transferring article data to symbols and 
lines” on page 672.
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Diamater on wires and cables: #R

A diameter of 1mm including insulation is specified like this:

#R0,5mm ("R" is for "radius")

Distance between connections in jumper links: #X

A distance of 5mm between connections in jumper links is specified like this:

#X5mm

This value is also used as a control function for jumper links in PCSCHEMATIC 
Panelrouter.

FILE=

If the MECTYPE field is to short, you can type in FILE=xxxxxx.pcs, where 
xxxxxx.pcs is the name of the file with the MECTYPE contents, specified accord-
ing to the syntax described above. (You have the same option for PCSTYPE and 
PINDATA).

The file must be placed in the database folder, which you have selected under Set-
tings => Directories.

Automatic generation of symbols

The syntax for automatic generation of symbols via the MECTYPE field is 
described in “Syntax for automatic generation of symbols” on page 220.
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Datafields in the component database
DATAFIELDS IN THE COMPONENT DATABASE

In this appendix you get an overview over the created datafields in the component 

database, which are installed with the Automation software.

Datafield: EANNUMBER

Contains the EANNUMBER for the component.

In standard installations of Automation the applied Article no is set to be fetched 
from this field in the database. The contents of this filed will therefore appear as the 
article number for components in projects.

— See “Transferring article data to symbols and lines” on page 672.

Datafield: STOCKNO

Contains the stock number for the component. The stock number can be used as 
an alternative article number.

— See “Alternative article number” on page 672.

Datafield: ORDERNO

Contains the order number for the component specified by the component manu-
facturer.

Datafield: TYPE

Contains the component type.

In standard installations of Automation the applied Type is set to be fetched from 
this field in the database. The contents of this field will therefore appear as the type 
for components in projects.

— See “Transferring article data to symbols and lines” on page 672.

Datafield: DESCRIPT

Contains the description for the component in Danish.

Datafield: UKDESCRIPT

Contains the description for the component in English.

INTERPRETATION OF THE CONTENTS OF THE DATAFIELDS IN AUTOMATION

IN THE DIALOG BOX SETTINGS => DATABASE => DATABASE SETUP => 
COMPONENT DATA YOU CAN SPECIFY HOW Automation INTERPRETS THE 

CONTENTS IN THE FIELDS IN THE ATTACHED COMPONTENT DATABASE (HOW 

THE "MAPPING" IS BETWEEN THE COMPONENT DATABASE AND 

Automation).

READ MORE ABOUT THIS IN “Transferring article data to symbols and 
lines” on page 672.
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In UK standard installations of Automation the applied Description is set to be 
fetched from this filed in the database. The contents of this field will therefore 
appear as the description for components in projects.

— See “Transferring article data to symbols and lines” on page 672.

Datafield: DEDESCRIPT

Contains the description for the component in German.

Datafield: REMARKS

General remarks and/or additional information about the component from the com-
ponent manufacturer.

Datafield: CATALOGUE

Here you can specify a link to a data sheet for the component.

— Please also see “URL links” on page 684, where you can read about how to 
apply a so-called alias for easier specification of the path to data sheets.

Datafield: SOURCE

Specifies the component vendor / source of the component.

— See “Searching for components in the Database menu” on page 634 and 
“Selecting a Fabricate / Vendor” on page 634 to see how select components by 
fabricate/vendor.

— See “Sorting in parts and components lists” on page 601 to see how to sort lists 
by source.

Datafield: MANUFACTUR

Specifies the component manufacturer.

— See “Searching for components in the Database menu” on page 634 and 
“Selecting a Fabricate / Vendor” on page 634 to see how select components by 
fabricate/vendor.

Datafield: UNITPRPACK

Specifies "the number of units in each package".

— See “Correct amount of jumper links in parts lists” on page 92.

Datafield: PRICE

Contains the list price for the component.

Datafield: DISCOUNT

Contains a discount factor — if any — for the component. The discount factor can 
by included in the calculation for some datafields in parts/component lists.

— See “Parts/components list datafields” on page 936.
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Datafield: NETPRICE

Specifies the net price for the component.

Datafield: TAX

Is not used normally.

Datafield: WEIGHT

Specifies the weight of the component.

Datafield: PCSTYPE

Specifies which electrical symbol(s) that represent the component in the diagram 
drawings.

— Read more about this in “Electrical symbols” on page 651.

Datafield: PINDATA

Contains the pindata for the component.

— Read more about this in “Connection names/Pindata” on page 657.

Datafield: MECTYPE

Specifies which mechanical symbol(s) that represent the component on the 
mechanical drawings.

— Read more about this in “Mechanical symbols in the database” on page 662.

Datafield: HEIGHT

Specifies the average height for the connection terminals for the component. The 
height is entered in mm, without specification of the unit of measurement. The 
datafield is used in conjunction with the PC|SCHEMATIC Panelrouter.

Datafield: SINGLELINESYMBOL

Specifies single line symbols — if any — for the component.

— See “Single line diagrams” on page 461.

Datafield: INSTTYPE

Used for installation symbols on ground plan / mechanical pages.

Datafield: OPT__ACCESSORY

Here you can specify which article number(s) — if any — that can appear as 
optional accessories in the dialog box Component data.

— See “Optional accessories - Mechanical” on page 677.
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Datafield: OPT_ADDON

Specifies the article number(s) for optional addon ("electrical accessories") — if 
any — for the component.

Optional addon appears in Show available on both diagram and arrangement 
drawings.

— See “Optional accessories - Electrical” on page 677.

Datafield: ACCESSORY

Here you can specify the article number(s) for fixed accessories — if any — for the 
component.

Fixed accessories appear alone on parts and components lists. In lists fixed acces-
sories appear under the component it is accessories for.

— See “The Accessory tab” on page 180 and “Fixed accessories” on page 677.

Datafield: PICTURE

Can contain a link to a picture. The picture is for instance displayed in the dialog 
box Component data.

Datafield: TABLECODE

Specifies which component group the component belongs to. The component 
groups are displayed in the Database menu.

— See “About the Database menu” on page 633, “Choosing a folder in the article 
menu” on page 634 and “Choosing a database Menu” on page 681.

Datafield: REFID

Here you can specify the reference id for the component.

— See “Specifying Ref. Letter for the symbol in the Database” on page 667.

Datafield: SUBDRAWING

This datafield makes it possible to include subdrawings as components in the data-
base. When you have created a subdrawing in Automation, you specify the path 
(alias + file name) to the subdrawing file in the SUBDRAWING field. When you 
then place a symbol in the pickmenu, and from this symbol in the pickmenu link to 
the article number for the subdrawing, you can subsequently insert the subdrawing 
in projects directly from the pickmenu.

— See “Placing symbols in the pickmenu” on page 198.

Datafield: RATING

Can contain specification of component ratings. The information can be displayed 
next to the electrical and mechanical symbols for the component, if these are cre-
ated with an inserted Datafield of the type Symbol Datafields => DB[RATING].

Datafield: APPROVED

Here you can specify whether a component is approved.
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— See “Approved and Obsolete components in the database” on page 679.

Datafield: OBSOLETE

Here you can specify whether a component is obsolete.

— See “Approved and Obsolete components in the database” on page 679.

Datafield: CWCODE

This datafield is not meant for users. The datafield is used by the Component Wiz-
ard for creating components in the PCSCHEMATIC component database, and 
specifies the component type.

— Read more about the Component Wizard this in the Component Wizard man-
ual, which can be downloaded at www.pcschematic.com/manuals.
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VARIABLES

Variable definition: /@n

Normal variable: /@n

Variable with default value:  xxxx/@n

Variable that inserts a value in a text: xxxx</@n>

Insertion with default value: xxxx<yyyy/@n>

/@n n is a number between 1 and 64000. Variables contain-
ing small numbers will be processed faster than varia-
bles containing larger numbers. Therefore smaller 
numbers are recommended in variables.

/@1     Variable 1 /@10     Variable 10

/@1 The variable has no default value. Fields in the project defini-
tion file, where the variable value will be typed in later, are 
empty.

3389110610000/@1 3389110610000 is displayed in field in the project definition 
file, where the variable value will be typed in later.

-P1/@3 The variable has the default value –P1.

The value that is typed in later, overwrites the default value.

-P</@3> The text (name) has a fixed part (-P) and a variable part </
@3>

</@4> out

</@4> in Can be applied with benefit where the same value shall be 
inserted into texts, where the fixed part are different from text 
to text. Here the values could for instance be ’Weighing’ in 
one case, and ’Casting’ in another.

-P</@3>

-S</@3> Can be applied where all — or some — names in a sub draw-
ing always have the same serial number.
E.g. –P1 and –S1

-P<1/@3> The text (name) has a fixed part (-P) and a variable part </
@3>, which has the default value ’1’.

<Weighing/@4> out The variable has the default value ’Weighing’.
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Indexed variables: /@n[i]    or   /@n[i1,i2,i3,....]

Possible control via variables in symbol names

/@4[1] The variable takes the value from the first parameter in a 
comma separated text.
E.g.: BK,BL,BU,GR The variable gets the value BK

/@4[2] E.g.: BK,BL,BU,GR The variable gets the value BL

/@4[2,3] E.g.: BK,BL,BU,GR The variable gets the value BL,BU

This function is very useful for cables.
Below this is shown with cable wire colors.

< BK,BL,BU,GR/@4[1]> => BK

< BK,BL,BU,GR/@4[2]> => BL

< BK,BL,BU,GR/@4[3]> => BU

< BK,BL,BU,GR/@4[4]> => GR

/@1=-M1 => The symbol gets the name -M1

/@1=! => The symbol and connecting lines becomes invisible.

/@1=!C => The symbol and connecting lines — up to a cable symbol 
— becomes invisible.

/@1=? => The symbol name is not controlled from the variable.
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Variables in reference designations

You can insert individual variables in all aspects in reference designations. To 
insert a variable in an aspect designation, enter the dialog box Reference desig-
nations and create an aspect designation, in which you insert a variable — for 
instance +23/@3 in a position aspect.

When you then want to insert an aspect designation with an attached variable on 
either a symbol, a reference frame or a page, just do this by selecting the relevant 
aspect designation from either the Component data dialog box, the Reference 
frame data dialog box or the Page data dialog box.

VARIABLES IN REFERENCE DESIGNATIONS - IN PREVIOUS VERSIONS

IN VERSION 18 AND PREVIOUS VERSIONS OF Automation YOU HAD TO 

HANDLE VARIABLES IN REFERENCE DESIGNATIONS DIFFERENTLY.

IN ORDER TO HANDLE PROJECTS CREATED IN PREVIOUS VERSIONS IT IS 

STILL POSSIBLE TO USE THE OLD PROCEDURE, BUT WE STRONGLY RECOM-

MEND TO USE THE NEW PROCEDURE DESCRIBED ABOVE.

IN PREVIOUS VERSIONS OF Automation YOU HAD TO DO THE FOLLOWING 

TO USE VARIABLES FOR CONTROLLING REFERENCE DESIGNATIONS ON REF-

ERENCE FRAMES:

 1) Click on Texts

 2) Double-click on the reference designation for the reference frame

 3) In the dialog box Change text: Type in the name of the variable 
(e.g. /@3)

IN PREVIOUS VERSIONS OF Automation YOU HAD TO DO THE FOLLOWING 

TO USE VARIABLES FOR CONTROLLING REFERENCE DESIGNATIONS ON 

PAGES:

 1) Right-click on the page and choose Page article data

 2) In the dialog box Page article data: Type in the name of the var-
iable (e.g. /@7) in the Name field
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STRUCTURE FOR PROJECT DEFINITION FILES

A project definition file consists of three parts, of which the first two are optional.

Part 1: Specifying aliases / applied folders (Optional)

The settings in this section, corresponds to the settings which can be set from the 
dialog box Options for project generator, in the tab Generate/update project.
— See “The Generate/update project tab” on page 23.

FOLDERS

Name for Alias 1

E.g.: FOLDER1

Path to the first folder to examine for drawing templates, 
sub drawings and projects.
E.g.: C:\PCschematic\MySubDrawings

Name for Alias 2 Path to the second folder to examine for drawing tem-
plates, sub drawings and projects.

Name for Alias 3
(Relative to other alias)

E.g.: %FOLDER1%\SubDrawings
— Can both be relative to aliases defined in the Project 
generator dialog box, and to aliases defined on a previ-
ous line here in the project definition file.

... ...

GENERATOR OPTIONS

UpdateLists=yes Options: ’yes’ / ’no’

UpdateFromDB=yes Options: ’yes’ / ’no’

AutoNumSymbolNames=yes Options: ’yes’ / ’no’

PLCSync=FromPLCref Options: ’none’ / ’FromPLCref’ / ’ToPLCref’

MakeInvisibleUnrefSig-
nals=yes

Options: ’yes’ / ’no’

MakeInvisibleUnrefCa-
bles=yes

Options: ’yes’ / ’no’
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Part 2: Specifying Project data and/or Reference designations

(Optional)

PCSCHEMATIC DATA

PROJECTDATA

Datafield from Project data Value for datafield

Datafield from Project data Value for datafield

... ...

REFERENCE DESIGNATIONS

FUNCTION

Function aspect Description

Function aspect Description

... ...

LOCATION

Location aspect Description

Location aspect Description

... ...

PRODUCT

Product aspect Description

Product aspect Description

... ...
mation

Page 965



P

Part 3: Specifying Drawing templates, Sub drawings and Pro-
jects

When Updating projects

When Merging projects

PCSCHEMATIC PAGES

TEMPLATE PAGES

Multipage project Page no. / Empty

Drawing template / Single-page 
project

Page no. / Empty @1 @2 ...

Sub drawing ~ @1 @2 ...

Project / Page #REMAIN

NEWPAGES>>

Multipage project Page no. / Empty

Drawing template / Single-page 
project

Page no. / Empty @1 @2 ...

Sub drawing ~ @1 @2 ...

Project / Page #REMAIN

<<NEWPAGES

MERGE

Project 1

Project 2

Project 3

...

Project n
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DICTIONARY

Activate next (in lists): The first time the program meets a check mark in an Acti-
vate next check box, you tell the program to collect information about the first com-
ponent in the list. Subsequent datafields, such as Description and Quantity, will 
then be regarded as the description and quantity of the first component respec-
tively.

The next time the program meets a check mark in the Activate next check box, it 
collects information about the following component on the list. The subsequent 
datafields Description and Quantity, will then be regarded as the description and 
quantity of the next component on the list — and so on.

It is important to note, that if you place a datafield just a bit higher on the page, 
than the datafield for which you enabled Activate next, this datafield will collect it 
is information from the previous component.

Please refer to “Creating Lists” on page 818 to get an example on how to use Acti-
vate next.

Alignment: Specifies where the reference point of a text is located. Read more 
about this in “Specifying text properties / Appearance of text” on page 133. See ref-
erence point.

Click: To press down the left mouse button once. Read more about the actions you 
can perform with the mouse in “The mouse” on page 25.

Command toolbar: Has got a varying appearance on the screen. It holds func-
tions and editing-tools for the various drawing facilities. Point number 3 on the fig-
ure on page 967.

Connection name: The name of a connection point.

1 2 3

5

6

7

10

8

4

11 12

17

1413

9

16

15
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Connection point: The point in which a symbol can be connected to a line. Please 
refer to “Place connection points” on page 764 for more information.

Cross hairs: When you are working on a project drawing, the location of the 
mouse pointer i demarcated by the crossing of a horizontal and a vertical line. This 
point is called the cross hairs.

Datafield: All information concerning the entire project, is gathered in the dialog 
box Settings => Project data. Among others, the project title, and the name and 
address of the customer is specified in this dialog box.

If you need to insert one of these informations on a list in your project — for 
instance the address of the customer — choose Insert => Insert Datafield. Here 
you first click on Project data and then on the datafield Address. When you 
update your list, the address of the customer will be inserted where you placed the 
datafield.

If the customer changes his address later on, you only have to change the address 
in Settings => Project data, which causes the address to be changed automati-
cally everywhere the datafield Address exists in the project.

Datafields therefore makes it possible for you to control central information — 
which is being applied several places in the project — in just one dialog box. If an 
information have to be changed, you just have to change it once, and the program 
will correct all the places the datafields are inserted in the project.

Datafields attached to the individual pages in the project, can be found in Settings 
=> Page data.

Dimmed: If an option in a menu is written in grey, you say it is dimmed, and it can-
not be chosen.

Directories: See Folders.

Docking: To move a program window or toolbar to another fixed position on the 
screen. Please refer to “Docking Windows and Toolbars” on page 26.

Double-click: To click two times on the left mouse-button. It is important not to 
move the mouse while clicking. Read more about the actions you can perform with 
the mouse in “The mouse” on page 25.

Drag’n draw: In Automation it is possible to save parts of diagrams as sub draw-
ings, which you can then drag directly into project pages in other projects. This is in 
Automation called Drag’n Draw. Hereby you can also drag project pages or full 
projects into the active project. — Read more about this in “Sub drawings” on 
page 289.

Drag and drop: Press down the left mouse button, and keep it pressed down while 
moving the mouse pointer across the screen. Is typically applied when you move 
an object or apply the zoom function. You are said to drag the object across the 
screen. Read more about the actions you can perform with the mouse in “The 
mouse” on page 25.

Drawing header: Apart from being what you normally understand as a drawing 
header — namely a frame containing information which can be placed around a 
project drawing — formulas for lists, tables of contents and unit drawings are also 
conceived as drawing headers in Automation.
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You can say that a drawing header is a template with text and graphics, which you 
can choose to place on the various pages in your project. It can for instance con-
tain your company logo. Read more about drawing headers, and how to create 
your own drawing header in “Creating Drawing Headers” on page 807.

Read more about how to create lists in “Creating Lists” on page 818.

Read more about how to create unit drawings in “Creating Unit Drawings” on 
page 833.

And, finally, you can read about how to insert an already created drawing header in 
“Insert drawing headers/formulas” on page 585.

Drawing objects: See objects.

Drive: The place where all your folders and files are gathered is called a drive. If 
you have to load a file from a diskette, you have to contact the disk drive (often 
called A:), and if you have to load something from your hard disk, you for instance 
have to contact the c:\-drive (There can also be other drives on your hard disk).

Elevation: The height in which an object is placed on a ground plan drawing. Read 
more about this in “Drawing with elevation” on page 532.

Elevation window: Is used to type in the height in which you want to place an 
object on a ground plan drawing.

Explorer window: A window in which you can locate pages and symbols in the 
projects. Point number 6 on the figure on page 967. Described in further detail in 
“The Explorer window: The Projects tab” on page 335.

File: Anything you save on a computer, is saved in what you call a file. Each time 
you for instance save a project or a symbol, these are saved in a file. When you 
fetch the project or symbol again, you are said to open the file.

Folder: In order not to place all files on the computer in the same place, you collect 
files, which belong together, in the same folder. Inside this folder you can create 
sub folders — and so on.

Free text: A text which is not connected to a symbol, a line or the like. Read more 
in “General purpose / Free texts” on page 109.

Grid: The dots you see placed at fixed intervals on the paper on a drawing, are 
called the grid of the drawing. You specify the distance between the dots in Set-
tings => Page setup. Read more about this in “Grid” on page 48.

Hints: When you let the mouse pointer rest on for instance a program button, you 
will see the name of the button displayed in a small text field. Or, if you let the 
mouse pointer rest for a moment on a symbol in the symbol toolbar, you will get a 
short description of the symbol. This facility is called hints, and can enabled/disa-
bled in Settings => Screen/Pointer.

Left toolbar: Contains various page- and zoom functions, as well as information 
on the page settings. Point number 7 on the figure on page 967.

Maximize: To maximize a window means to make it fill out the entire screen. In the 
upper-right corner of a window, you will find the Maximize button. Click this button, 
and you will maximize the window.
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Menu: A place where you can choose which command to carry out in the program. 
See “Menus” on page 23 for further details.

Menu bar: Consists of the menus, that contains all the functions in the program. 
Use the mouse or the <Alt> key to choose the functions. For instance choose File 
by pressing <Alt+f>. Point number 1 on the figure on page 967.

Minimize: To minimize a window means to remove it from the screen temporarily, 
so that you cannot work on it. It will then be placed as a small button on the lower 
part of the screen. When you click on this button, the window is enlarged, and you 
will be able to work on it again.

In the upper-right corner of a window, you will find the Minimize button. Click this 
button, and you will minimize the window.

MMB Drag’n Draw: Short form of "Module and Model Based Drag’n Draw". — See 
drag’n draw.

Mouse pointer: The arrow/pointer displayed on the screen, which is controlled by 
the mouse. When it is above a field in which you can enter text, it is converted to a 
short vertical line.

Non conducting symbol: A symbol, which cannot be connected to a conducting 
line, without causing a warning to appear. If you connect a normal symbol to a non 
conducting line, you will be warned about it, but will be allowed to do so if you 
insist.

NP: “Non printable.” Texts/lines/circles in this color will be displayed on the screen, 
but not on print. Read more about this in “Specifying text properties / Appearance 
of text” on page 133.

Objects: A common name for the symbols, lines, texts, and circles that can be 
placed on a project drawing. Also called drawing objects. Read more about this in 
“On Drawing objects” on page 53.

Page tabs: On the lower part of the screen you will see some small tabs, telling 
you which project page you are located on. By clicking on these tabs, you can jump 
back and forth between the project pages. These tabs are called page tabs, and 
can be activated/deactivated in Settings => Pointer/Screen.

Parking: If you have not specified what a conduction line is to be connected to, you 
can temporarily park the line. You can then wait to connect it until later. Read more 
about this in “Conducting (electrical) lines” on page 79 and “Signal symbols” on 
page 225.

Path: If you want to specify the exact location of a file on your PC, you can specify 
the path that leads to the file. This path starts by specifying on which drive the file 
is located, and then specifies which folder or sub folder the file is located. At the 
end, there is the file name itself. The file project.pro which is saved in the Project 
folder, thus has the path: c:\Pcselcad\Project\project.pro.

Pickmenu: A place you can place symbols for easy access while working. Point 
number 4 on the figure on page 967. Described in further detail in “Fetching sym-
bols from the Pickmenu” on page 152.
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Program toolbar: Contains the program buttons. Here you can choose the various 
functions. The common file- and print functions are located here, along with the 
more general drawing- and editing tools. Point number 2 on the figure on page 967.

Reference point: All symbols and texts have got a reference point. For symbols, 
the reference point is demarcated by a *, while the reference point for texts is +. 
When you want to move a symbol, it is the reference point you click on to select 
(get in contact with) the symbol, and if you want to rotate the symbol, it is rotated 
around the reference point. — This also goes for texts. Read more in “Creating 
Symbols” on page 761 and in “Specifying text properties / Appearance of text” on 
page 133.

Right-click: To click once on the right mouse-button. Read more about the actions 
you can perform with the mouse in “The mouse” on page 25.

Scroll: If you only see a smaller part of your drawing on the screen for the moment, 
and wish to see something that is placed to the right of the displayed section, you 
can gradually move the displayed section to the right on the drawing, until you see 
what you want on the screen. Moving the displayed section is called scrolling.

You can scroll by using the Survey window in the lower-right corner of the screen. 
Click on the black box in the survey window, and drag it until it covers the area you 
want to see on the full screen.

Read more about this in “Screen / Image Functions” on page 42.

Signal symbol: A symbol, which states an electrical connection, that is not dis-
played otherwise on the drawing. Thus, if a signal symbol with the name L1 is 
placed on two different pages in a project, this means these two places are electri-
cally connected. It is the signal name only, that states the electrical connection.

Therefore, a signal symbol having the name L2, has no connection to a signal 
symbol having the name L1 — even though the same symbol is used for the two 
signals.

Read more about signal symbols in “Creating Signal Symbols” on page 803.

Snap: When you want to place an object on the screen, it is important to be able to 
place it exactly where you want it. To support this, you have got the option to spec-
ify that objects can only be placed at fixed intervals of, say, 2.50mm. — If you then 
want to place a symbol, you will only be able to move it in steps of 2.50mm at the 
time. This enables you to place the symbol accurately in relation to the other sym-
bols.

If the distance between the points in which the symbols can be placed is 2.50mm, 
you say that snap is 2.50mm.

By clicking on the Snap button in the left toolbar, you can change back and forth 
between normal snap (for instance 2.50mm) and fine snap (for instance 0.50mm).

If <Shift> is pressed down while an object is in the cross hairs, you will change to 
the fine snap, and as soon as you let go of the <Shift> key, or place the object, you 
return to normal snap.

In Settings => Page setup you specify the snap settings.

Read more about snap in “Snap” on page 47.

Status bar: Contains coordinates, layer title and help text. Point number 11 on the 
figure on page 967.
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Sub drawing: See “Sub drawings” on page 289.

Survey window: Displays the entire page, while the zoom, you are presently work-
ing in, is displayed by a black box. Point number 9 on the figure on page 967. Read 
more in “The Survey window” on page 46.

Tanking: See “Tanking licenses” on page 863.

Untick: To remove a check mark from a check box.

Work area: Reflects the size of paper you have chosen to draw on. Point number 8 
on the figure on page 967.

Zoom: If you need to zoom in on something, this means you have to mark up a 
section of the drawing you have on the screen, and then the section will be 
enlarged.

Read more about this in “Screen / Image Functions” on page 42.
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Enter Wire Numbers Manually . . . . . . . . . . . . 453
Error

general protection error . . . . . . . . . . . . . . . 49
Even pages  . . . . . . . . . . . . . . . . . . . . . . . . . 362
Excel

integration with, survey . . . . . . . . . . . . . . 735
place symbols via lists  . . . . . . . . . . . . . . 743
PLC I/O addressing via . . . . . . . . . . . . . . 486

Explorer window . . . . . . . . . . . . . . . . . . 335, 909
displaying and hiding information . . . . . . . 336
move . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
Selecting a symbol on a page . . . . . . . . . 338

Export
DWG and DXF files  . . . . . . . . . . . . . . . . 732
PLC I/O data to Excel . . . . . . . . . . . . . . . 486
project as DWG or DXF file . . . . . . . . . . . 732
symbol as DWG or DXF file  . . . . . . . . . . 734

Extend line . . . . . . . . . . . . . . . . . . . . . . . . . . . 97
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Extend line button . . . . . . . . . . . . . . . . . . . . . . 95
Extended lines . . . . . . . . . . . . . . . . . . . . . . . . 95
Extensions

of list files . . . . . . . . . . . . . . . . . . . . . . . . 727
External program  . . . . . . . . . . . . . . . . . . . . . 721

F
FABRICATE (Show all) . . . . . . . . . . . . . . . . . 634
Fabricate choice

in Database menu  . . . . . . . . . . . . . . . . . 677
Factor, ellipses . . . . . . . . . . . . . . . . . . . . . . . 107
Favorites  . . . . . . . . . . . . . . . . . . . . . . . . . . . 854
Field headings  . . . . . . . . . . . . . . . . . . . . . . . 724
File =>

Close . . . . . . . . . . . . . . . . . . . . . . . . . . . 570
Close and return to PCschematic project . 740
Export to =>

DWG / DXF . . . . . . . . . . . . . . . . . . . . 732
PDF . . . . . . . . . . . . . . . . . . . . . . . . . 367

Modules . . . . . . . . . . . . . . . . . . . . . . . . . 849
New . . . . . . . . . . . . . . . . . . . . . 35, 564, 838
New =>

PCschematic project file . . . . . . . . . . . . 884
Open Unit  . . . . . . . . . . . . . . . . . . . . . . . 836
Print  . . . . . . . . . . . . . . . . . . . . . . . . . . . 361
Print =>

Select pages =>  . . . . . . . . . . . . . . . . . 531
Save unit as . . . . . . . . . . . . . . . . . . . . . . 835
Send to  . . . . . . . . . . . . . . . . . . . . . . . . . 541

File format  . . . . . . . . . . . . . . . . . . . . . . . . . . 724
File type registration, dialog box  . . . . . . . . . . 883
Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 969

commasep. files
place symbols via  . . . . . . . . . . . . . . . . 743

DWG/DXF  . . . . . . . . . . . . . . . . . . . . . . . 729
file names

in database fields  . . . . . . . . . . . . . . . . 685
from Object Lister . . . . . . . . . . . . . . . . . . 347
lists as files  . . . . . . . . . . . . . . . . . . . . . . 717
pindata files  . . . . . . . . . . . . . . . . . . . . . . 658
registering PCSCHEMATIC filtypes . . . . . 883
wire number . . . . . . . . . . . . . . . . . . . . . . 455

Files =>
Modules =>

Scripts  . . . . . . . . . . . . . . . . . . . . . . . 851
Fill character  . . . . . . . . . . . . . . . . . . . . . . . . 118
Filled areas  . . . . . . . . . . . . . . . . . . . . . . . . . . 75
Find Next . . . . . . . . . . . . . . . . . . . . . . . . . . . 352
Find Whole Text Only . . . . . . . . . . . . . . . . . . 352
Fixed digits  . . . . . . . . . . . . . . . . . . . . . . . . . 449
Fixed text direction . . . . . . . . . . . . . . . . . . . . 136
Flat buttons  . . . . . . . . . . . . . . . . . . . . . . . . . 908
FLOWCHAR, symbol folder . . . . . . . . . . . . . . 248
Fold corner  . . . . . . . . . . . . . . . . . . . . . . . . . . 75

for reference frames . . . . . . . . . . . . . . . . 409
FOLDERS  . . . . . . . . . . . . . . . . . . . . . . . . . . 964
Folders  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 969

change symbol in . . . . . . . . . . . . . . . . . . 796
delete symbol from . . . . . . . . . . . . . . . . . 796

most used . . . . . . . . . . . . . . . . . . . . . . . .912
symbol folders  . . . . . . . . . . . . . . . . . . . .247

Follow connected button  . . . . . . . . . . . . .96, 804
Follow connected lines  . . . . . . . . . . . . . . . . . .95
Font . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .134
Foreign languages  . . . . . . . . . . . . . . . . . . . .855
Format file  . . . . . . . . . . . . . . . . . . . . . . . . . .718
Formulas

insert  . . . . . . . . . . . . . . . . . . . . . . . . . . .585
projects  . . . . . . . . . . . . . . . . . . . . . . . . .563

Frame  . . . . . . . . . . . . . . . . . . . . . . . . . . . . .135
Free texts . . . . . . . . . . . . . . . . . . . . . . .109, 969

change . . . . . . . . . . . . . . . . . . . . . . . . . .830
Ftp

links in database fields  . . . . . . . . . . . . . .685
Full circle  . . . . . . . . . . . . . . . . . . . . . . . . . . .106
FUNCTION . . . . . . . . . . . . . . . . . . . . . . . . . .965
Function aspects . . . . . . . . . . . . . . . . . .373, 381
Functions =>

Auto command change  . . . . . . . . . . . . . . .57
Auto Name . . . . . . . . . . . . . . . . . . . . . . .196
Centre drawing . . . . . . . . . . . . . . . . . . . .562
Component Grouping  . . . . . . . . . . .238, 614
Coordinates  . . . . . . . . . . . . . . . . . . . . . . .98
Count down  . . . . . . . . . . . . . . . . . . . . . .132
Count up  . . . . . . . . . . . . . . . . . . . . . . . .132
Database =>

Find Article . . . . . . . . . . . . . . . . . . . . .169
Find Type . . . . . . . . . . . . . . . . . . . . . .170
Insert in Database  . . . . . . . . . . . . . . . .649
Update from Database  . . . . . . . . . . . . .191

Design Check . . . . . . . . . . . . . . . . .355, 358
Design Check =>

Used more than once

deselect . . . . . . . . . . . . . . . . . . . .359
Generate isometry . . . . . . . . . . . . . . . . . .562
Go to Available symbols  . . . . . . . . . . . . .263
Measurement  . . . . . . . . . . . . . . . . . . . . .710
Mechanical load  . . . . . . . . . . . . . . . . . . .698
Object Lister . . . . . . . . . . . . . . . . . . . . . .342
Place Accessory . . . . . . . . . . . . . . . . . . .246
Place available Symbols  . . . . . . . . . . . . .268
Replace symbol  . . . . . . . . . . . . . . . . . . .213
Select name . . . . . . . . . . . . . . . . . . . . . .264
Show conducting . . . . . . . . . . . . . . . . . . . .80
Show signal  . . . . . . . . . . . . . . . . . . . . . .231
Special Functions =>

Convert Branches to Dots  . . . . . . . . . . .104
Convert Dots to Branches  . . . . . . . . . . .104
Convert to Branches . . . . . . . . . . . . . . .104
Create CurrentPath No on all Symb . . . . .437
Exchange Article with Alt. Article on all Symbols 

673
Prefix all symbol names with -  . . . .403, 908
Set all articles as approved in the database 681
Set unreferenced cable symbols invisible  .246
Set unreferenced signal symbols invisible .232
Transfer data from PLCref. to PLCsymb.  .481
Transfer data from PLCsymb. to PLCref.  .481
Transfer Proj. Texts to Auto Compl. func.  .110
Automation
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Special functions =>
Replace all symbols  . . . . . . . . . . . . . . 216

Update references . . . . . . . . . . . . . 426, 435
View Jumper Links . . . . . . . . . . . . . . . . . . 92
Wire numbers  . . . . . . . . . . . . . . . . . . . . 443

G
General protection error . . . . . . . . . . . . . . . . . 49
General purpose texts  . . . . . . . . . . . . . . . . . 109
General, tab  . . . . . . . . . . . . . . . . . . . . . . . . 598
Generation names . . . . . . . . . . . . . . . . . . . . 437
German version

PCSCHEMATIC Viewer . . . . . . . . . . . . . 748
Grafisk klemplan, værktøj . . . . . . . . . . . . . . . 848
Graphical terminal plans, tool

Tools
Grapgical terminal plans  . . . . . . . . . . . 847

Grid  . . . . . . . . . . . . . . . . . . . . . . . . . . . 48, 969
Grid display . . . . . . . . . . . . . . . . . . . . . . . . . 906
Ground plan  . . . . . . . . . . . . . . . . . . . . . . . . 521

place symbols on . . . . . . . . . . . . . . . . . . 525
with elevation  . . . . . . . . . . . . . . . . . . . . 532

Ground plan, page type  . . . . . . . . . . . . . . . . 560
Group Number . . . . . . . . . . . . . . . . . . . . . . . 617
Grouping

components  . . . . . . . . . . . . . . . . . . . . . 613
layers  . . . . . . . . . . . . . . . . . . . . . . . . . . 529

Guess
wire numbers . . . . . . . . . . . . . . . . . . . . . 446

H
Half circle  . . . . . . . . . . . . . . . . . . . . . . . . . . 106
Heat loss calculation

acc. to EN61439-3 . . . . . . . . . . . . . . . . . 519
Height . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 134
Help  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
Help =>

Check for updates  . . . . . . . . . . . . . . . . . 919
Http

//www.pcschematic.com  . . . . . . . . . . . . 19
Help frame  . . . . . . . . . . . . . . . . . . . . . . 36, 909
Help objects color  . . . . . . . . . . . . . . . . . . . . 861
Hints . . . . . . . . . . . . . . . . . . . . . . . . . . 909, 969
Home view

set User Home view . . . . . . . . . . . . . . . . . 45
HOMEDIR . . . . . . . . . . . . . . . . . . . . . . . . . . 914
Horizontal reference . . . . . . . . . . . . . . . . . . . 140
Horizontal, tab . . . . . . . . . . . . . . . . . . . . . . . 434
Hot-line . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
House drawing  . . . . . . . . . . . . . . . . . . . . . . 521
Http

links in database fields . . . . . . . . . . . . . . 685
Hungarian version

PCSCHEMATIC Viewer . . . . . . . . . . . . . 748
Hydraulics

place symbols via lists  . . . . . . . . . . . . . . 743
Hydraulics, symbols . . . . . . . . . . . . . . . . . . . 248

I
I/O lists

read . . . . . . . . . . . . . . . . . . . . . . . . . . . . 483
I/O symbols

create PLC I/O symbols  . . . . . . . . . . . . . 790
IEC 81346 . . . . . . . . . . . . . . . . . . . . . . . . . . 371
IECINST, symbol folder  . . . . . . . . . . . . . . . . 248
IECPNEU, symbol folder . . . . . . . . . . . . . . . . 248
Ignored, page function  . . . . . . . . . . . . . . . . . 548
Image

insert . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66
scale . . . . . . . . . . . . . . . . . . . . . . . . . . . 331

Image functions  . . . . . . . . . . . . . . . . . . . . . . . 42
Import

DWG and DXF files  . . . . . . . . . . . . . . . . 730
as page in project  . . . . . . . . . . . . . . . . 730

PLC I/O data from Excel . . . . . . . . . . . . . 487
Include cable wires . . . . . . . . . . . . . . . . . . . . 445
Include fixed accessories from Database . . . . 599
Include Lines with article data . . . . . . . . . . . . 599
Index

on-line manual . . . . . . . . . . . . . . . . . . . . . 41
Indexed variables . . . . . . . . . . . . . . . . . . . . . 962
Information

automatic information . . . . . . . . . . . . . . . 852
Insert

data fields  . . . . . . . . . . . . . . . . . . . . . . . 812
image  . . . . . . . . . . . . . . . . . . . . . . . . . . . 66
list . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 593
logo . . . . . . . . . . . . . . . . . . . . . . . . . . . . 581
page for mechanical drawing . . . . . . . . . . 696
unit drawing . . . . . . . . . . . . . . . . . . . . . . 625

Insert - in front of symbol names  . . . . . . 403, 908
Insert =>

Insert data field  . . . . . . . . . . . . . . . 116, 931
Insert object . . . . . . . . . . . . . . . . . . 737, 738
Insert Picture  . . . . . . . . . . . . . . . . . . . . . 330
Insert Potential . . . . . . . . . . . . . . . . . . . . . 86
Insert Reference Frame  . . . . . . . . . . . . . 407
Insert sub drawing  . . . . . . . . . . . . . . . . . 100

Insert Line Point
for reference frames . . . . . . . . . . . . . . . . 409

Insert new  . . . . . . . . . . . . . . . . . . . . . . . . . . 545
symbols or connection names . . . . . . . . . 328

Insertion points . . . . . . . . . . . . . . . . . . . . . . . 312
Install modules . . . . . . . . . . . . . . . . . . . . . . . 849
Installation

electrical installation . . . . . . . . . . . . . . . . 519
pickmenu . . . . . . . . . . . . . . . . . . . . . . . . 525

instdemo.pro, demo project . . . . . . . . . . . . . . 525
Intelligent

copying of areas . . . . . . . . . . . . . . . . . . . 271
reference designations . . . . . . . . . . . . . 274

Interface
database . . . . . . . . . . . . . . . . . . . . . . . . 670

Internet
automatic information and update  . . . . . . 852

Interval in minutes  . . . . . . . . . . . . . . . . . . . . 918
mation
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Invert text . . . . . . . . . . . . . . . . . . . . . . . . . . . 127
Invisible . . . . . . . . . . . . . . . . . . . . . . . . . . . . 528

areas . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
circles  . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
lines  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
objects . . . . . . . . . . . . . . . . . . . . . . . . . . . 69
Sub drawings . . . . . . . . . . . . . . . . . . . . . . 71
symbols . . . . . . . . . . . . . . . . . . . . . . . . . . 69
texts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70

ISO
paper size  . . . . . . . . . . . . . . . . . . . . . . . 561

ISO 81346 . . . . . . . . . . . . . . . . . . . . . . . . . . 371
Isometric, page type . . . . . . . . . . . . . . . . . . . 560
Isometrical drawing . . . . . . . . . . . . . . . . . . . . 562
Isometrical symbols

create  . . . . . . . . . . . . . . . . . . . . . . . . . . 692
Italic text  . . . . . . . . . . . . . . . . . . . . . . . . . . . 136

J
JIS

paper size  . . . . . . . . . . . . . . . . . . . . . . . 561
Join symbols

define  . . . . . . . . . . . . . . . . . . . . . . . . . . 806
Jokers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 605
Jumper links . . . . . . . . . . . . . . . . . . . . . . . . . . 91

in lists and terminal plans  . . . . . . . . . . . . . 92

K
Keep cursor position . . . . . . . . . . . . . . . . . . . 906
Keep page zoom  . . . . . . . . . . . . . . . . . . 44, 908
Keep zoom  . . . . . . . . . . . . . . . . . . . . . . 44, 908
Klemmer

standarder . . . . . . . . . . . . . . . . . . . . . . . 188
Klemmer for indgående ledere  . . . . . . . . . . . 188
Komponenter

rename selected
selecting symbols  . . . . . . . . . . . . . . . . 324

L
Language . . . . . . . . . . . . . . . . . . . . . . . . . . . 919
Layers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 528

and drawing headers  . . . . . . . . . . . . . . . 530
change using the mouse . . . . . . . . . . . . . 530
grouping layers . . . . . . . . . . . . . . . . . . . . 529
print page with  . . . . . . . . . . . . . . . . . . . . 531

Left tool bar  . . . . . . . . . . . . . . . . . . . . . . . . . . 37
Left toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . 969
License key  . . . . . . . . . . . . . . . . . . . . . . . . . 920

software license key . . . . . . . . . . . . . . . . 920
Licenses

SuperPro monitor . . . . . . . . . . . . . . . . . . 868
tankning licenses  . . . . . . . . . . . . . . . . . . 863
transfer licenses by tanking . . . . . . . . . . . 864
transfer licenses via license files  . . . . . . . 865

Line data fields . . . . . . . . . . . . . . . . . . . . . . . . 82
calculated  . . . . . . . . . . . . . . . . . . . . . . . . 82

Line width follows page scale  . . . . . . . . . . . . 907
Lines . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53, 72

article data . . . . . . . . . . . . . . . . . . . . . . . . 80

Automatic line drawing  . . . . . . . . . . . . . . .95
automatic wire numbering  . . . . . . . . . . . .443
by measures . . . . . . . . . . . . . . . . . . . . . . .98
changing elevation  . . . . . . . . . . . . . . . . .532
color . . . . . . . . . . . . . . . . . . . . . . . . . . . . .77
curved  . . . . . . . . . . . . . . . . . . . . . . . . . . .74
distance  . . . . . . . . . . . . . . . . . . . . . . . . . .76
electrical . . . . . . . . . . . . . . . . . . . . . . . . . .79
extended  . . . . . . . . . . . . . . . . . . . . . . . . .95
follow connected lines . . . . . . . . . . . . . . . .95
in symbols  . . . . . . . . . . . . . . . . . . . . . . .764
invisible  . . . . . . . . . . . . . . . . . . . . . . . . . .70
jumper links  . . . . . . . . . . . . . . . . . . . . . . .91
Object Lister . . . . . . . . . . . . . . . . . . . . . .342
rectangles . . . . . . . . . . . . . . . . . . . . . . . . .75
round . . . . . . . . . . . . . . . . . . . . . . . . . . . .74
router . . . . . . . . . . . . . . . . . . . . . . . . . . . .95
select elevated  . . . . . . . . . . . . . . . . . . . .532
slanted . . . . . . . . . . . . . . . . . . . . . . . . . . .74
straight . . . . . . . . . . . . . . . . . . . . . . . . . . .73
toolbar  . . . . . . . . . . . . . . . . . . . . . . . . . . .73
transfer article data . . . . . . . . . . . . . . . . . .62
trim/extend . . . . . . . . . . . . . . . . . . . . . . . .97
type  . . . . . . . . . . . . . . . . . . . . . . . . . . . . .75
types for ground plans . . . . . . . . . . . . . . .523
width  . . . . . . . . . . . . . . . . . . . . . . . . . . . .76
wire numbers file

with reference designations . . . . . . . . . .456
without wire number, deselect  . . . . . . . . .444

Links
edit . . . . . . . . . . . . . . . . . . . . . . . . . . . . .742
in database fields  . . . . . . . . . . . . . . . . . .685

List Compare  . . . . . . . . . . . . . . . . . . . . . . . .848
List Files

External program  . . . . . . . . . . . . . . . . . .721
List files

buttons in the dialog box  . . . . . . . . . . . . .722
create . . . . . . . . . . . . . . . . . . . . . . . . . . .718
criteria  . . . . . . . . . . . . . . . . . . . . . . . . . .723
example . . . . . . . . . . . . . . . . . . . . . . . . .726
extensions  . . . . . . . . . . . . . . . . . . . . . . .727
field headings . . . . . . . . . . . . . . . . . . . . .724
file format . . . . . . . . . . . . . . . . . . . . . . . .724
matching the system you export to . . . . . .723
reference designations in . . . . . . . . . . . . .725
the contents  . . . . . . . . . . . . . . . . . . . . . .723
the file name . . . . . . . . . . . . . . . . . . . . . .723
the format file  . . . . . . . . . . . . . . . . . . . . .718

List of dtawing headers  . . . . . . . . . . . . . . . . .815
List of used objects . . . . . . . . . . . . . . . . . . . .351
List setup

terminals- cables- and PLC lists . . . . . . . .609
List symbols  . . . . . . . . . . . . . . . . . . . . . . . . .829
Lists

add to the list of drawing headers . . . . . . .824
as files  . . . . . . . . . . . . . . . . . . . . . . . . . .717
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